source: projects/specs/trunk/e/empathy/empathy-vl.spec @ 623

Revision 623, 14.6 KB checked in by Takemikaduchi, 14 years ago (diff)

takemikaduchi fix and add spec file

Line 
1%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3## Minimum required versions of GLib, GTK+, libtelepathy, and Mission-Control,
4## respectively.
5%global gtk2_min_version        2.14
6%global glib2_min_version       2.18.0
7%global tp_mc_min_version       5.3.2
8%global tp_glib_min_version     0.7.35
9#global enchant_version         1.4.0
10%global aspell_version          0.50
11%global libcanberra_version     0.4
12%global gnome_keyring_version   2.22
13%global libnotify_version       0.4.4
14
15Summary:        GNOME Instant Messaging Client
16Summary(ja):    GNOME インスタントメッセージクラアイント
17
18Name:           empathy
19Version:        2.28.2
20Release:        1%{?_dist_release}
21
22Group:          Applications/Communications
23License:        GPLv2+
24URL:            http://live.gnome.org/Empathy
25
26Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.28/%{name}-%{version}.tar.bz2
27Source1:        %{name}-README.ConnectionManagers
28
29BuildRoot: %{_tmppath}/%{name}-%{version}-root
30
31#BuildRequires: enchant-devel >= %{enchant_version}
32BuildRequires:  aspell-devel >= %{aspell_version}
33BuildRequires:  iso-codes
34BuildRequires:  desktop-file-utils
35BuildRequires:  evolution-data-server-devel
36BuildRequires:  GConf2-devel
37BuildRequires:  gettext
38BuildRequires:  glib2-devel >= %{glib2_min_version}
39BuildRequires:  gnome-doc-utils >= 0.17.3
40BuildRequires:  gnome-panel
41BuildRequires:  gtk2-devel >= %{gtk2_min_version}
42BuildRequires:  intltool
43BuildRequires:  libxml2-devel
44BuildRequires:  perl(XML::Parser)
45BuildRequires:  pygtk2-devel
46BuildRequires:  telepathy-glib-devel >= %{tp_glib_min_version}
47BuildRequires:  telepathy-mission-control-devel >= %{tp_mc_min_version}
48BuildRequires:  farsight2-devel
49BuildRequires:  telepathy-farsight-devel
50BuildRequires:  libcanberra-devel >= %{libcanberra_version}
51BuildRequires:  gnome-keyring-devel >= %{gnome_keyring_version}
52BuildRequires:  unique-devel
53BuildRequires:  libnotify-devel >= %{libnotify_version}
54BuildRequires:  libtelepathy-devel
55BuildRequires:  libgnomecanvas-devel
56BuildRequires:  libbonoboui-devel
57BuildRequires:  python-devel
58
59Requires:       %{name}-libs = %{version}-%{release}
60Requires:       telepathy-filesystem
61## Empathy is useless without a proper Telepathy connection manager installed.
62## We hardcode dependencies on Salut and Gabble to support XMPP on a default
63## install, in both the link-local and Jabber/GoogleTalk incarnations.
64## (RHBZ: 308871 and 334221)
65## TODO: Perhaps we can configure these to be installed "on demand" with
66##       PackageKit and friends?
67Requires:       telepathy-gabble
68Requires:       telepathy-salut
69## Also hardcode Haze dependency since Empathy is the default IM client in F10+
70## and I'd hate for people to simply disregard it for lack of the "out of the
71## box" protocol support that Pidgin has. (RHBZ: 458935)
72BuildRequires:  telepathy-haze
73# Require this for VOIP support
74Requires:       telepathy-stream-engine
75
76Requires(pre):  GConf2
77
78Requires(post): GConf2
79Requires(post): scrollkeeper
80
81Requires(preun):        GConf2
82
83Requires(postun):       scrollkeeper
84
85## We're using Empathy's upstreamed profiles for Haze-provided stuff now.
86Obsoletes:      telepathy-haze-mission-control < 0.2.0-3
87Provides:       telepathy-haze-mission-control = 0.2.0-3
88
89%description
90Empathy provides a powerful multiple protocol instant messaging
91client using the Telepathy framework.
92
93
94%package        devel
95Summary:        Development files for %{name}
96Summary(ja):    Development files for %{name}
97Group:          Development/Libraries
98Requires:       %{name}-libs = %{version}-%{release}
99Requires:       pkgconfig
100## Needs these for the various #include directives in its headers, as well
101## as pkgconfig dependencies...
102Requires:       glib2-devel
103Requires:       telepathy-glib-devel
104Requires:       telepathy-mission-control-devel
105Requires:       libxml2-devel
106
107%description    devel
108The %{name}-devel package contains libraries and header files for
109developing applications that use %{name}.
110
111
112%package        libs
113Summary:        Shared libraries for %{name}
114Summary(ja):    Shared libraries for %{name}
115Group:          Development/Libraries
116Requires:       glib2
117Requires:       gtk2
118Requires:       telepathy-glib
119Requires:       telepathy-mission-control
120
121%description    libs
122The %{name}-libs package contains shared libraries used by Empathy.
123
124
125%package        python
126Summary:        Python bindings for libempathy and libempathy-gtk
127Summary(ja):    Python bindings for libempathy and libempathy-gtk
128Group:          Development/Languages
129Requires:       %{name}-libs = %{version}-%{release}   
130
131%description    python
132This package contains the empathy and empathygtk Python modules, which provide
133bindings to the libempathy and libempathy-gtk libraries, respectively.
134
135%prep
136%setup -q
137
138
139%build
140## GCC complains about some unused functions, so we forcibly show those as
141## simple warnings instead of build-halting errors.
142%configure --with-compile-warnings=yes --disable-static
143## RPATHs are yucky.
144sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
145sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
146
147##make %{?_smp_mflags}
148## don't use _smp_mflags at empathy-2.18.1
149make
150
151install -m 0644 %{SOURCE1} ./README.ConnectionManagers
152
153
154%install
155rm -rf $RPM_BUILD_ROOT
156make install DESTDIR=$RPM_BUILD_ROOT
157find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
158
159%find_lang %{name}
160
161desktop-file-install --vendor "" --delete-original      \
162        --dir %{buildroot}%{_datadir}/applications      \
163        %{buildroot}%{_datadir}/applications/%{name}.desktop
164
165
166%clean
167rm -rf %{buildroot}
168
169
170%pre
171if [ "$1" -gt 1 ]; then
172        export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
173        gconftool-2 --makefile-uninstall-rule   \
174                %{_sysconfdir}/gconf/schemas/GNOME_Megaphone_Applet.schemas     \
175                %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null ||:
176fi
177
178
179%post
180export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
181gconftool-2 --makefile-install-rule     \
182        %{_sysconfdir}/gconf/schemas/GNOME_Megaphone_Applet.schemas     \
183        %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null ||:
184scrollkeeper-update -q -o %{_datadir}/omf/%{name} ||:
185touch --no-create %{_datadir}/icons/hicolor ||:
186%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
187
188%post libs -p /sbin/ldconfig
189
190
191%preun
192if [ "$1" -eq 0 ]; then
193        export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
194        gconftool-2 --makefile-uninstall-rule   \
195                %{_sysconfdir}/gconf/schemas/GNOME_Megaphone_Applet.schemas     \
196                %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null ||:
197fi
198
199
200%postun
201scrollkeeper-update -q || :
202touch --no-create %{_datadir}/icons/hicolor || :
203if [ -x %{_bindir}/gtk-update-icon-cache ]; then
204        %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
205fi
206
207%postun libs -p /sbin/ldconfig
208
209
210%files -f %{name}.lang
211%defattr(-,root,root,-)
212%doc AUTHORS COPYING README README.ConnectionManagers NEWS
213%{_sysconfdir}/gconf/schemas/%{name}.schemas
214%{_sysconfdir}/gconf/schemas/GNOME_Megaphone_Applet.schemas
215%{_bindir}/empathy
216%{_bindir}/empathy-logs
217%{_datadir}/dbus-1/services/*
218%{_datadir}/empathy
219%{_datadir}/applications/*.desktop
220%{_datadir}/gnome/help/%{name}/
221#{_datadir}/omf/%{name}/
222%{_datadir}/icons/hicolor/*/apps/%{name}*
223#{_datadir}/mission-control/profiles/*.profile
224%{_datadir}/telepathy/clients/Empathy.client
225%{_libexecdir}/megaphone-applet
226%{_libexecdir}/nothere-applet
227%{_libdir}/bonobo/servers/GNOME_Megaphone_Applet.server
228%{_libdir}/bonobo/servers/GNOME_NotHere_Applet.server
229%{_mandir}/man1/empathy*.1.gz
230
231%files  libs
232%defattr(-,root,root,-)
233%{_libdir}/libempathy*.so.*
234
235%files  devel
236%defattr(-,root,root,-)
237%{_includedir}/libempathy*/
238%{_libdir}/libempathy*.so
239%{_libdir}/pkgconfig/libempathy*.pc
240%{_datadir}/gtk-doc/html/libempathy*
241
242%files  python
243%defattr(-,root,root,-)
244%{python_sitearch}/empathy*.so
245
246%changelog
247* Sat Mar 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
248- new upstream release
249- add BuildRequires: libtelepathy-devel, libgnomecanvas-devel, libbonoboui-devel, python-devel
250
251* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.1-4
252- rebuilt with python-2.6.4
253
254* Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> - 2.28.1-3
255- unuse %%{?_smp_mflags} option to make
256
257* Wed Nov 11 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.1-2
258- add {gnome-keyring,libcanberra,libnotify,unique}-devel to BuildRequires
259
260* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
261- new upstream release
262
263* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
264- new upstream release
265
266* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
267- initial build for Vine Linux
268
269* Tue Sep  9 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.92-1
270- Update to 2.23.92
271
272* Thu Sep  4 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.91-1
273- Update to 2.23.91
274
275* Sun Aug 24 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-2
276- Now that Empathy will be the default IM client in F10+, hardcode a dependency
277  on telepathy-haze to keep the same protocol functionality across upgrades,
278  for a much improved "out of the box" experience.
279- Reference: bug 458935.
280
281* Fri Aug 22 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-1
282- Update to new upstream release (2.23.90)
283
284* Fri Aug 15 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-3
285- Apply patch from Colin Walters to automagically update profile namings for
286  the switch to using Empathy's provided profiles.
287- Drop the upgrade script (no longer needed since it's automatically done).
288  - upgrade-haze-profiles.sh
289
290* Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-2
291- Use upstream's AIM, ICQ, MSN-Haze, and Yahoo profiles instead of recommending
292  the telepathy-haze-mission-control package. (The Haze-provided ones have grown
293  horribly stale...). This makes for better automagic functionality (if Haze is
294  installed, Empathy/MC will autodetect it) and tracks upstream more closely.
295  + upgrade-haze-profiles.sh
296
297* Mon Aug 04 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-1
298- Update to new upstream release (2.23.6)
299- Use the in-tarball libtool scripts instead of the system copy to workaround
300  'make install' errors.
301
302* Wed Jul 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.4-1
303- Update to 0.23.4.
304- Update source url.
305
306* Mon Jun  2 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.3-1
307- Update to 0.23.3.
308- Remove reference to stream-engine in connections managers readme.
309
310* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.2-1
311- Update to 0.23.2.
312- Add man pages.
313- Use enchant-devel, instead of aspell-devel.
314
315* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-3
316- Rebuild for new e-d-s.
317
318* Sun May  4 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-2
319- Drop multiple copies of COPYING file.
320- Drop BR on gnome-vfs2-devel.
321- Require telepathy-stream-engine for VOIP support.
322- Add BR on iso-codes-devel, so spell-checking is enabled.
323
324* Wed Apr 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.23.1-1
325- Update to new upstream release (0.23.1)
326- Drop libtelepathy dependencies; upstream switched fully to telepathy-glib.
327
328* Fri Apr 11 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.1-1
329- Update to new upstream release (0.22.1)
330
331* Mon Mar 10 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.0-1
332- Update to new upstream release (0.22.0)
333
334* Sun Mar 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.91-1
335- Update to new upstream release (0.21.91)
336
337* Fri Feb 22 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.90-1
338- Update to new upstream release (0.21.90)
339
340* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.21.4-2
341- Autorebuild for GCC 4.3
342
343* Mon Dec 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.4-1
344- Update to new upstream release (0.21.4)
345
346* Tue Nov 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.2-1
347- Update to new upstream release (0.21.2)
348- Drop backported drag-and-drop patch (fixed upstream):
349    - svn380-fix-contact-DnD.patch
350- Update README.ConnectionManagers: Include Haze package note, remove Galago
351  note (a feed-only connection manager isn't useful for instant messaging),
352  and fix some wording.
353
354* Fri Oct 19 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-5
355- Backport upstream patch to fixes crashes when using drag-and-drop of a
356  contact from the buddy list to the current conversation window to initiate a
357  conversation:
358    + svn380-fix-contact-DnD.patch
359- Resolves: GNOME bug 483168 (crash in Empathy Instant Messenger: I had
360  dragged a contact ...)
361
362* Tue Oct 16 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-4
363- Depend on Salut and Gabble to enable XMPP by default. Otherwise, Empathy
364  is essentially useless due to the need to install an external connection
365  manager. Also, add a README.ConnectionManagers to the installed
366  documentation which lists other possibilities.
367- Resolves: bug 308871 (Make empathy dependent at least on telepathy-gabble)
368  and bug 334221 (Default empathy install is useless).
369
370* Wed Oct 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-3
371- Enable VoIP support for those brave enough to test/break/debug it (F9+
372  only). Though it is functional, it is still deemed rather unstable by
373  upstream. Use it at your own risk. :)
374
375* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-2
376- Disable VoIP support at this time, since it is deemed unstable by upstream
377  for now. (Thanks to Brian Pepple for the notice.)
378 
379* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-1
380- Update to new upstream release (0.14).
381
382* Sun Sep 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.13-1
383- Update to new upstream release (0.13), which adds a panel applet (Megaphone)
384  and python bindings.
385- Split shared libraries into a libs subpackage for easier handling
386  in multi-lib environments.
387
388* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-2
389- Add ldconfig invocations to %%post and %%postun scriptlets.
390
391* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-1
392- Update to new upstream release (0.12).
393- Build against new mission-control stack.
394- Update License tag (GPLv2+).
395- Alphabetize BuildRequires list (aesthetic-only change).
396
397* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.8-2
398- Rebuild for selinux ppc32 issue.
399
400* Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-1
401- Update to new upstream release (0.11)
402
403* Fri Jun 22 2007 David Nielsen <david@lovesunix.net> - 0.8-1
404- bump to 0.8
405- Now with aspell support (deat to teh speeling mistaks)
406
407* Sat Jun  9 2007 David Nielsen <david@lovesunix.net> - 0.7-1
408- bump to 0.7
409
410* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-3
411- Add telepathy-filesystem to Requires
412- Move .desktop from autostart to applications
413- Nasty hackery to make empathy launch from the menu
414
415* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-2
416- Add gettext to BuildRequires
417
418* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.6-1
419- Bump to 0.6
420
421* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.5-2
422- Let Empathy own the directory and not just the files in it
423
424* Tue May 30 2007 David Nielsen <david@lovesunix.net> - 0.5-1
425- Initial package
Note: See TracBrowser for help on using the repository browser.