source: projects/specs/trunk/e/empathy/empathy-vl.spec @ 7354

Revision 7354, 17.1 KB checked in by Takemikaduchi, 11 years ago (diff)

rebuild

Line 
1%define major_ver 3.6
2%define minor_ver 3
3%define rel       2
4
5%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
6
7## Minimum required versions of GLib, GTK+, libtelepathy, and Mission-Control,
8## respectively.
9%global gtk3_min_version        3.6.0
10%global glib2_min_version       2.34.0
11%global tp_mc_min_version       5.12.0
12%global tp_glib_min_version     0.18.0
13%global tp_logger_min_version   0.2.10
14%global aspell_version          0.50
15%global libcanberra_version     0.25
16%global libnotify_version       0.7.4
17%global folks_version           0.6.8
18%global libsecret_version       0.5
19
20Summary:        GNOME Instant Messaging Client
21Summary(ja):    GNOME インスタントメッセージクラアイント
22
23Name:           empathy
24Version:        %{major_ver}.%{minor_ver}
25Release:        %{rel}%{?_dist_release}
26
27Group:          Applications/Communications
28License:        GPLv2+
29URL:            http://live.gnome.org/Empathy
30
31Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/%{majorver}/%{name}-%{version}.tar.xz
32Source1:        %{name}-README.ConnectionManagers
33
34BuildRoot: %{_tmppath}/%{name}-%{version}-root
35
36#BuildRequires: enchant-devel >= %{enchant_version}
37BuildRequires:  aspell-devel >= %{aspell_version}
38BuildRequires:  iso-codes
39BuildRequires:  desktop-file-utils
40BuildRequires:  evolution-data-server-devel
41BuildRequires:  gettext
42BuildRequires:  glib2-devel >= %{glib2_min_version}
43BuildRequires:  gnome-panel
44BuildRequires:  gtk3-devel >= %{gtk3_min_version}
45BuildRequires:  intltool
46BuildRequires:  libxml2-devel
47BuildRequires:  perl(XML::Parser)
48BuildRequires:  telepathy-glib-devel >= %{tp_glib_min_version}
49BuildRequires:  telepathy-logger-devel >= %{tp_logger_min_version}
50BuildRequires:  telepathy-mission-control-devel >= %{tp_mc_min_version}
51BuildRequires:  farstream-devel
52BuildRequires:  telepathy-farstream-devel
53BuildRequires:  libcanberra-gtk3-devel >= %{libcanberra_version}
54BuildRequires:  unique3-devel
55BuildRequires:  libnotify-devel >= %{libnotify_version}
56BuildRequires:  folks-devel >= %{folks_version}
57BuildRequires:  gcr-devel >= %{gnome_keyring_version}
58BuildRequires:  libsecret-devel >= %{libsecret_version}
59BuildRequires:  openssl-devel
60BuildRequires:  NetworkManager-glib-devel
61BuildRequires:  WebKit3-gtk-devel
62BuildRequires:  geoclue-devel
63BuildRequires:  enchant-devel
64BuildRequires:  libICE-devel
65BuildRequires:  cheese-devel
66BuildRequires:  pulseaudio-libs-devel
67BuildRequires:  gnome-online-accounts-devel
68BuildRequires:  libgudev1-devel
69BuildRequires:  libchamplain-gtk-devel
70BuildRequires:  gsettings-desktop-schemas-devel
71BuildRequires:  yelp-tools
72
73Requires:       telepathy-filesystem
74Requires:       telepathy-gabble
75Requires:       telepathy-salut
76Requires:       telepathy-idle
77## Also hardcode Haze dependency since Empathy is the default IM client in F10+
78## and I'd hate for people to simply disregard it for lack of the "out of the
79## box" protocol support that Pidgin has. (RHBZ: 458935)
80BuildRequires:  telepathy-haze
81# Require this for VOIP support
82Requires:       telepathy-mission-control >= %{tp_mc_min_version}
83
84
85## We're using Empathy's upstreamed profiles for Haze-provided stuff now.
86Obsoletes:      telepathy-haze-mission-control < 0.2.0-3
87Provides:       telepathy-haze-mission-control = 0.2.0-3
88## upstream 2.29.1 removed shared libraries: #599086
89Obsoletes: empathy-libs < 2.29.1, empathy-devel < 2.29.1
90## upstream 2.29.1 removed python bindings' #599039
91Obsoletes: empathy-python < 2.29.1
92
93Vendor: Project Vine
94Distribution: Vine Linux
95
96%description
97Empathy provides a powerful multiple protocol instant messaging
98client using the Telepathy framework.
99
100
101%package -n     nautilus-sendto-empathy
102License:        GPLv2+
103Summary:        Nautilus-sendto plugin for empathy
104Summary(ja):    empathy 用 nautilus-sendto プラグイン
105Group:          User Interface/Desktop
106
107Requires:       %{name} = %{version}-%{release}
108Requires:       nautilus-sendto
109BuildRequires:  nautilus-sendto-devel
110
111%description -n nautilus-sendto-empathy
112This package contains nautilus-sendto plugin for the Empathy IM application.
113
114
115%prep
116%setup -q
117
118
119%build
120## GCC complains about some unused functions, so we forcibly show those as
121## simple warnings instead of build-halting errors.
122%configure --disable-static
123
124##make %{?_smp_mflags}
125## don't use _smp_mflags at empathy-2.18.1
126make
127
128install -m 0644 %{SOURCE1} ./README.ConnectionManagers
129
130
131%install
132rm -rf $RPM_BUILD_ROOT
133make install DESTDIR=$RPM_BUILD_ROOT
134find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
135
136%find_lang %{name}
137
138desktop-file-install --vendor "" --delete-original      \
139        --dir %{buildroot}%{_datadir}/applications      \
140        %{buildroot}%{_datadir}/applications/%{name}.desktop
141
142
143%clean
144rm -rf %{buildroot}
145
146
147%post
148touch --no-create %{_datadir}/icons/hicolor ||:
149%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
150
151%postun
152touch --no-create %{_datadir}/icons/hicolor || :
153if [ -x %{_bindir}/gtk-update-icon-cache ]; then
154        %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
155        glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
156fi
157
158%posttrans
159gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null ||:
160glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
161
162
163%files -f %{name}.lang
164%defattr(-,root,root,-)
165%doc AUTHORS COPYING README README.ConnectionManagers NEWS
166%{_bindir}/empathy
167%{_bindir}/empathy-accounts
168%{_bindir}/empathy-debugger
169%{_libexecdir}/empathy-auth-client
170%{_libexecdir}/empathy-call
171%{_libexecdir}/empathy-chat
172%{_libdir}/%{name}/libempathy*.so
173%{_libdir}/mission-control-plugins.0/mcp-account-manager-goa.so
174%{_datadir}/GConf/gsettings/*
175%{_datadir}/applications/*.desktop
176%{_datadir}/adium/message-styles
177%{_datadir}/dbus-1/services/*
178%{_datadir}/%{name}
179%{_datadir}/glib-2.0/schemas/*.xml
180%{_datadir}/help/*/%{name}
181%{_datadir}/icons/hicolor/*/apps/%{name}*
182%{_datadir}/telepathy/clients/*.client
183%{_mandir}/man1/empathy*.1*
184
185%files -n nautilus-sendto-empathy
186%defattr(-,root,root,-)
187%{_libdir}/nautilus-sendto/plugins/libnstempathy.so
188
189
190%changelog
191* Fri Jan 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-2
192- fix spec
193
194* Fri Jan 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
195- new upstream release
196
197* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
198- new upstream release
199
200* Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
201- rebuild with telepathy-logger-0.6.0
202
203* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
204- new upstream release
205
206* Fri Oct 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0.3-1
207- new upstream release
208
209* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
210- new upstream release
211- add BuildRequires: libsecret-devel, yelp-tools
212- remove BuildRequires: libgnome-keyring-devel
213
214* Sun Jul 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2.3-1
215- new upstream release
216
217* Tue Jun 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2.1-1
218- new upstream release
219
220* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
221- new upstream release
222
223* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
224- new upstream release
225- change BuildRequires: gcr-devel instead of gnome-keyring-devel
226- change BuildRequires: farstream-devel instead of farsight2-devel
227- change BuildRequires: telepathy-farstream-devel instead of telepathy-farsight-devel
228- add BuildRequires: itstool
229- remove Requires: telepathy-stream-engine
230- add Requires: telepathy-idle
231
232* Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
233- new upstream release
234
235* Thu Nov 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1.1-1
236- new upstream release
237
238* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
239- new upstream release
240- add BuildRequires: libgudev1-devel, gnome-online-accounts-devel
241
242* Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0.1-1
243- new upstream release
244
245* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
246- new upstream release
247
248* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
249- new upstream release
250
251* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
252- new upstream release
253
254* Sun Aug 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5.1-1
255- new upstream release
256
257* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
258- new upstream release
259- add BuildRequires: pulseaudio-libs-devel
260
261* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
262- new upstream release
263- change BuildRequires: gtk3-devel instead of gtk2-devel
264- change BuildRequires: unique3-devel instead of unique-devel
265- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
266- change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
267- add BuildRequires: gsettings-desktop-schemas, libICE-devel, cheese-devel, libchamplain-gtk-devel
268
269* Sun Jan 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
270- new upstream release
271- add BuildRequires: openssl-devel, NetworkManager-glib-devel, WebKit-devel
272                     geoclue-devel, enchant-devel
273- add Requires: telepathy-mission-control
274- add configure option: --with-ca-file=/usr/share/ssl/certs/ca-bundle.crt
275
276* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0.1-1
277- new upstream release
278- add BuildRequires: folks-devel, telepathy-logger-devel, gnome-keyring-devel
279- fix %files
280- fix %post, %postun
281- drop %pre, %preun
282
283* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0.1-3
284- rebuild with evolution-data-server-2.30.2
285- add nautilus-sendto-empathy package
286  - add configure option (--enable-nautilus-sendto=yes)
287  - add BuildRequires: nautilus-sendto-devel
288
289* Sat Jun 12 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-2
290- add Obsoletes: empathy-python < 2.29.1
291
292* Tue Apr 13 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-1
293- new upstream release
294- add new files: %%{_bindir}/empathy-{accounts,debugger}
295- drop -libs, -devel, -python sub packages: upstream removed
296  - Obsoletes: empathy-{libs,devel} < 2.29.1
297  - drop BuildRequires: python-devel
298- drop %%{_bindir}/empathy-logs in %%files: upstream don not install
299- drop applet files in %%files: upstream removed the panel applets
300  - update %%post, %pre and %%preun
301- update BuildRequires version for glib2 and tp_glib
302- defined major_ver, minor_ver and rel
303- fix BuildRequires for gnome-keyring
304
305* Sat Mar 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
306- new upstream release
307- add BuildRequires: libtelepathy-devel, libgnomecanvas-devel, libbonoboui-devel, python-devel
308
309* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.1-4
310- rebuilt with python-2.6.4
311
312* Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> - 2.28.1-3
313- unuse %%{?_smp_mflags} option to make
314
315* Wed Nov 11 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.1-2
316- add {gnome-keyring,libcanberra,libnotify,unique}-devel to BuildRequires
317
318* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
319- new upstream release
320
321* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
322- new upstream release
323
324* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
325- initial build for Vine Linux
326
327* Tue Sep  9 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.92-1
328- Update to 2.23.92
329
330* Thu Sep  4 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.91-1
331- Update to 2.23.91
332
333* Sun Aug 24 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-2
334- Now that Empathy will be the default IM client in F10+, hardcode a dependency
335  on telepathy-haze to keep the same protocol functionality across upgrades,
336  for a much improved "out of the box" experience.
337- Reference: bug 458935.
338
339* Fri Aug 22 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-1
340- Update to new upstream release (2.23.90)
341
342* Fri Aug 15 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-3
343- Apply patch from Colin Walters to automagically update profile namings for
344  the switch to using Empathy's provided profiles.
345- Drop the upgrade script (no longer needed since it's automatically done).
346  - upgrade-haze-profiles.sh
347
348* Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-2
349- Use upstream's AIM, ICQ, MSN-Haze, and Yahoo profiles instead of recommending
350  the telepathy-haze-mission-control package. (The Haze-provided ones have grown
351  horribly stale...). This makes for better automagic functionality (if Haze is
352  installed, Empathy/MC will autodetect it) and tracks upstream more closely.
353  + upgrade-haze-profiles.sh
354
355* Mon Aug 04 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-1
356- Update to new upstream release (2.23.6)
357- Use the in-tarball libtool scripts instead of the system copy to workaround
358  'make install' errors.
359
360* Wed Jul 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.4-1
361- Update to 0.23.4.
362- Update source url.
363
364* Mon Jun  2 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.3-1
365- Update to 0.23.3.
366- Remove reference to stream-engine in connections managers readme.
367
368* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.2-1
369- Update to 0.23.2.
370- Add man pages.
371- Use enchant-devel, instead of aspell-devel.
372
373* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-3
374- Rebuild for new e-d-s.
375
376* Sun May  4 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-2
377- Drop multiple copies of COPYING file.
378- Drop BR on gnome-vfs2-devel.
379- Require telepathy-stream-engine for VOIP support.
380- Add BR on iso-codes-devel, so spell-checking is enabled.
381
382* Wed Apr 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.23.1-1
383- Update to new upstream release (0.23.1)
384- Drop libtelepathy dependencies; upstream switched fully to telepathy-glib.
385
386* Fri Apr 11 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.1-1
387- Update to new upstream release (0.22.1)
388
389* Mon Mar 10 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.0-1
390- Update to new upstream release (0.22.0)
391
392* Sun Mar 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.91-1
393- Update to new upstream release (0.21.91)
394
395* Fri Feb 22 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.90-1
396- Update to new upstream release (0.21.90)
397
398* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.21.4-2
399- Autorebuild for GCC 4.3
400
401* Mon Dec 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.4-1
402- Update to new upstream release (0.21.4)
403
404* Tue Nov 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.2-1
405- Update to new upstream release (0.21.2)
406- Drop backported drag-and-drop patch (fixed upstream):
407    - svn380-fix-contact-DnD.patch
408- Update README.ConnectionManagers: Include Haze package note, remove Galago
409  note (a feed-only connection manager isn't useful for instant messaging),
410  and fix some wording.
411
412* Fri Oct 19 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-5
413- Backport upstream patch to fixes crashes when using drag-and-drop of a
414  contact from the buddy list to the current conversation window to initiate a
415  conversation:
416    + svn380-fix-contact-DnD.patch
417- Resolves: GNOME bug 483168 (crash in Empathy Instant Messenger: I had
418  dragged a contact ...)
419
420* Tue Oct 16 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-4
421- Depend on Salut and Gabble to enable XMPP by default. Otherwise, Empathy
422  is essentially useless due to the need to install an external connection
423  manager. Also, add a README.ConnectionManagers to the installed
424  documentation which lists other possibilities.
425- Resolves: bug 308871 (Make empathy dependent at least on telepathy-gabble)
426  and bug 334221 (Default empathy install is useless).
427
428* Wed Oct 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-3
429- Enable VoIP support for those brave enough to test/break/debug it (F9+
430  only). Though it is functional, it is still deemed rather unstable by
431  upstream. Use it at your own risk. :)
432
433* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-2
434- Disable VoIP support at this time, since it is deemed unstable by upstream
435  for now. (Thanks to Brian Pepple for the notice.)
436 
437* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-1
438- Update to new upstream release (0.14).
439
440* Sun Sep 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.13-1
441- Update to new upstream release (0.13), which adds a panel applet (Megaphone)
442  and python bindings.
443- Split shared libraries into a libs subpackage for easier handling
444  in multi-lib environments.
445
446* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-2
447- Add ldconfig invocations to %%post and %%postun scriptlets.
448
449* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-1
450- Update to new upstream release (0.12).
451- Build against new mission-control stack.
452- Update License tag (GPLv2+).
453- Alphabetize BuildRequires list (aesthetic-only change).
454
455* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.8-2
456- Rebuild for selinux ppc32 issue.
457
458* Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-1
459- Update to new upstream release (0.11)
460
461* Fri Jun 22 2007 David Nielsen <david@lovesunix.net> - 0.8-1
462- bump to 0.8
463- Now with aspell support (deat to teh speeling mistaks)
464
465* Sat Jun  9 2007 David Nielsen <david@lovesunix.net> - 0.7-1
466- bump to 0.7
467
468* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-3
469- Add telepathy-filesystem to Requires
470- Move .desktop from autostart to applications
471- Nasty hackery to make empathy launch from the menu
472
473* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-2
474- Add gettext to BuildRequires
475
476* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.6-1
477- Bump to 0.6
478
479* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.5-2
480- Let Empathy own the directory and not just the files in it
481
482* Tue May 30 2007 David Nielsen <david@lovesunix.net> - 0.5-1
483- Initial package
Note: See TracBrowser for help on using the repository browser.