source: projects/specs/trunk/e/empathy/empathy-vl.spec @ 6924

Revision 6924, 16.9 KB checked in by Takemikaduchi, 12 years ago (diff)

libunistring: add Requires,
others: new upstream release

Line 
1%define major_ver 3.6
2%define minor_ver 0.3
3%define rel       1
4
5%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
6
7## Minimum required versions of GLib, GTK+, libtelepathy, and Mission-Control,
8## respectively.
9%global gtk3_min_version        3.6.0
10%global glib2_min_version       2.34.0
11%global tp_mc_min_version       5.12.0
12%global tp_glib_min_version     0.18.0
13%global tp_logger_min_version   0.2.10
14%global aspell_version          0.50
15%global libcanberra_version     0.25
16%global libnotify_version       0.7.4
17%global folks_version           0.6.8
18%global libsecret_version       0.5
19
20Summary:        GNOME Instant Messaging Client
21Summary(ja):    GNOME インスタントメッセージクラアイント
22
23Name:           empathy
24Version:        %{major_ver}.%{minor_ver}
25Release:        %{rel}%{?_dist_release}
26
27Group:          Applications/Communications
28License:        GPLv2+
29URL:            http://live.gnome.org/Empathy
30
31Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/%{majorver}/%{name}-%{version}.tar.xz
32Source1:        %{name}-README.ConnectionManagers
33
34BuildRoot: %{_tmppath}/%{name}-%{version}-root
35
36#BuildRequires: enchant-devel >= %{enchant_version}
37BuildRequires:  aspell-devel >= %{aspell_version}
38BuildRequires:  iso-codes
39BuildRequires:  desktop-file-utils
40BuildRequires:  evolution-data-server-devel
41BuildRequires:  gettext
42BuildRequires:  glib2-devel >= %{glib2_min_version}
43BuildRequires:  gnome-panel
44BuildRequires:  gtk3-devel >= %{gtk3_min_version}
45BuildRequires:  intltool
46BuildRequires:  libxml2-devel
47BuildRequires:  perl(XML::Parser)
48BuildRequires:  telepathy-glib-devel >= %{tp_glib_min_version}
49BuildRequires:  telepathy-logger-devel >= %{tp_logger_min_version}
50BuildRequires:  telepathy-mission-control-devel >= %{tp_mc_min_version}
51BuildRequires:  farstream-devel
52BuildRequires:  telepathy-farstream-devel
53BuildRequires:  libcanberra-gtk3-devel >= %{libcanberra_version}
54BuildRequires:  unique3-devel
55BuildRequires:  libnotify-devel >= %{libnotify_version}
56BuildRequires:  folks-devel >= %{folks_version}
57BuildRequires:  gcr-devel >= %{gnome_keyring_version}
58BuildRequires:  libsecret-devel >= %{libsecret_version}
59BuildRequires:  openssl-devel
60BuildRequires:  NetworkManager-glib-devel
61BuildRequires:  WebKit3-gtk-devel
62BuildRequires:  geoclue-devel
63BuildRequires:  enchant-devel
64BuildRequires:  libICE-devel
65BuildRequires:  cheese-devel
66BuildRequires:  pulseaudio-libs-devel
67BuildRequires:  gnome-online-accounts-devel
68BuildRequires:  libgudev1-devel
69BuildRequires:  libchamplain-gtk-devel
70BuildRequires:  gsettings-desktop-schemas-devel
71BuildRequires:  yelp-tools
72
73Requires:       telepathy-filesystem
74Requires:       telepathy-gabble
75Requires:       telepathy-salut
76Requires:       telepathy-idle
77## Also hardcode Haze dependency since Empathy is the default IM client in F10+
78## and I'd hate for people to simply disregard it for lack of the "out of the
79## box" protocol support that Pidgin has. (RHBZ: 458935)
80BuildRequires:  telepathy-haze
81# Require this for VOIP support
82Requires:       telepathy-mission-control >= %{tp_mc_min_version}
83
84
85## We're using Empathy's upstreamed profiles for Haze-provided stuff now.
86Obsoletes:      telepathy-haze-mission-control < 0.2.0-3
87Provides:       telepathy-haze-mission-control = 0.2.0-3
88## upstream 2.29.1 removed shared libraries: #599086
89Obsoletes: empathy-libs < 2.29.1, empathy-devel < 2.29.1
90## upstream 2.29.1 removed python bindings' #599039
91Obsoletes: empathy-python < 2.29.1
92
93Vendor: Project Vine
94Distribution: Vine Linux
95
96%description
97Empathy provides a powerful multiple protocol instant messaging
98client using the Telepathy framework.
99
100
101%package -n     nautilus-sendto-empathy
102License:        GPLv2+
103Summary:        Nautilus-sendto plugin for empathy
104Summary(ja):    empathy 用 nautilus-sendto プラグイン
105Group:          User Interface/Desktop
106
107Requires:       %{name} = %{version}-%{release}
108Requires:       nautilus-sendto
109BuildRequires:  nautilus-sendto-devel
110
111%description -n nautilus-sendto-empathy
112This package contains nautilus-sendto plugin for the Empathy IM application.
113
114
115%prep
116%setup -q
117
118
119%build
120## GCC complains about some unused functions, so we forcibly show those as
121## simple warnings instead of build-halting errors.
122%configure --disable-static
123
124## RPATHs are yucky.
125sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
126sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
127
128##make %{?_smp_mflags}
129## don't use _smp_mflags at empathy-2.18.1
130make
131
132install -m 0644 %{SOURCE1} ./README.ConnectionManagers
133
134
135%install
136rm -rf $RPM_BUILD_ROOT
137make install DESTDIR=$RPM_BUILD_ROOT
138find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
139
140%find_lang %{name}
141
142desktop-file-install --vendor "" --delete-original      \
143        --dir %{buildroot}%{_datadir}/applications      \
144        %{buildroot}%{_datadir}/applications/%{name}.desktop
145
146
147%clean
148rm -rf %{buildroot}
149
150
151%post
152touch --no-create %{_datadir}/icons/hicolor ||:
153%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
154
155%postun
156touch --no-create %{_datadir}/icons/hicolor || :
157if [ -x %{_bindir}/gtk-update-icon-cache ]; then
158        %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
159        glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
160fi
161
162%posttrans
163gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null ||:
164glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
165
166
167%files -f %{name}.lang
168%defattr(-,root,root,-)
169%doc AUTHORS COPYING README README.ConnectionManagers NEWS
170%{_bindir}/empathy
171%{_bindir}/empathy-accounts
172%{_bindir}/empathy-debugger
173%{_libdir}/mission-control-plugins.0/mcp-account-manager-goa.so
174%{_libexecdir}/empathy-auth-client
175%{_libexecdir}/empathy-call
176%{_libexecdir}/empathy-chat
177%{_libdir}/%{name}/libempathy*.so
178%{_libdir}/mission-control-plugins.0/mcp-account-manager-goa.so
179%{_datadir}/GConf/gsettings/*
180%{_datadir}/applications/*.desktop
181%{_datadir}/adium/message-styles
182%{_datadir}/dbus-1/services/*
183%{_datadir}/%{name}
184%{_datadir}/glib-2.0/schemas/*.xml
185%{_datadir}/help/*/%{name}
186%{_datadir}/icons/hicolor/*/apps/%{name}*
187%{_datadir}/telepathy/clients/*.client
188%{_mandir}/man1/empathy*.1*
189
190%files -n nautilus-sendto-empathy
191%defattr(-,root,root,-)
192%{_libdir}/nautilus-sendto/plugins/libnstempathy.so
193
194
195%changelog
196* Fri Oct 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0.3-1
197- new upstream release
198
199* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
200- new upstream release
201- add BuildRequires: libsecret-devel, yelp-tools
202- remove BuildRequires: libgnome-keyring-devel
203
204* Sun Jul 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2.3-1
205- new upstream release
206
207* Tue Jun 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2.1-1
208- new upstream release
209
210* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
211- new upstream release
212
213* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
214- new upstream release
215- change BuildRequires: gcr-devel instead of gnome-keyring-devel
216- change BuildRequires: farstream-devel instead of farsight2-devel
217- change BuildRequires: telepathy-farstream-devel instead of telepathy-farsight-devel
218- add BuildRequires: itstool
219- remove Requires: telepathy-stream-engine
220- add Requires: telepathy-idle
221
222* Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
223- new upstream release
224
225* Thu Nov 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1.1-1
226- new upstream release
227
228* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
229- new upstream release
230- add BuildRequires: libgudev1-devel, gnome-online-accounts-devel
231
232* Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0.1-1
233- new upstream release
234
235* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
236- new upstream release
237
238* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
239- new upstream release
240
241* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
242- new upstream release
243
244* Sun Aug 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5.1-1
245- new upstream release
246
247* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
248- new upstream release
249- add BuildRequires: pulseaudio-libs-devel
250
251* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
252- new upstream release
253- change BuildRequires: gtk3-devel instead of gtk2-devel
254- change BuildRequires: unique3-devel instead of unique-devel
255- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
256- change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
257- add BuildRequires: gsettings-desktop-schemas, libICE-devel, cheese-devel, libchamplain-gtk-devel
258
259* Sun Jan 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
260- new upstream release
261- add BuildRequires: openssl-devel, NetworkManager-glib-devel, WebKit-devel
262                     geoclue-devel, enchant-devel
263- add Requires: telepathy-mission-control
264- add configure option: --with-ca-file=/usr/share/ssl/certs/ca-bundle.crt
265
266* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0.1-1
267- new upstream release
268- add BuildRequires: folks-devel, telepathy-logger-devel, gnome-keyring-devel
269- fix %files
270- fix %post, %postun
271- drop %pre, %preun
272
273* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0.1-3
274- rebuild with evolution-data-server-2.30.2
275- add nautilus-sendto-empathy package
276  - add configure option (--enable-nautilus-sendto=yes)
277  - add BuildRequires: nautilus-sendto-devel
278
279* Sat Jun 12 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-2
280- add Obsoletes: empathy-python < 2.29.1
281
282* Tue Apr 13 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-1
283- new upstream release
284- add new files: %%{_bindir}/empathy-{accounts,debugger}
285- drop -libs, -devel, -python sub packages: upstream removed
286  - Obsoletes: empathy-{libs,devel} < 2.29.1
287  - drop BuildRequires: python-devel
288- drop %%{_bindir}/empathy-logs in %%files: upstream don not install
289- drop applet files in %%files: upstream removed the panel applets
290  - update %%post, %pre and %%preun
291- update BuildRequires version for glib2 and tp_glib
292- defined major_ver, minor_ver and rel
293- fix BuildRequires for gnome-keyring
294
295* Sat Mar 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
296- new upstream release
297- add BuildRequires: libtelepathy-devel, libgnomecanvas-devel, libbonoboui-devel, python-devel
298
299* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.1-4
300- rebuilt with python-2.6.4
301
302* Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> - 2.28.1-3
303- unuse %%{?_smp_mflags} option to make
304
305* Wed Nov 11 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.1-2
306- add {gnome-keyring,libcanberra,libnotify,unique}-devel to BuildRequires
307
308* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
309- new upstream release
310
311* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
312- new upstream release
313
314* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
315- initial build for Vine Linux
316
317* Tue Sep  9 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.92-1
318- Update to 2.23.92
319
320* Thu Sep  4 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.91-1
321- Update to 2.23.91
322
323* Sun Aug 24 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-2
324- Now that Empathy will be the default IM client in F10+, hardcode a dependency
325  on telepathy-haze to keep the same protocol functionality across upgrades,
326  for a much improved "out of the box" experience.
327- Reference: bug 458935.
328
329* Fri Aug 22 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-1
330- Update to new upstream release (2.23.90)
331
332* Fri Aug 15 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-3
333- Apply patch from Colin Walters to automagically update profile namings for
334  the switch to using Empathy's provided profiles.
335- Drop the upgrade script (no longer needed since it's automatically done).
336  - upgrade-haze-profiles.sh
337
338* Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-2
339- Use upstream's AIM, ICQ, MSN-Haze, and Yahoo profiles instead of recommending
340  the telepathy-haze-mission-control package. (The Haze-provided ones have grown
341  horribly stale...). This makes for better automagic functionality (if Haze is
342  installed, Empathy/MC will autodetect it) and tracks upstream more closely.
343  + upgrade-haze-profiles.sh
344
345* Mon Aug 04 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-1
346- Update to new upstream release (2.23.6)
347- Use the in-tarball libtool scripts instead of the system copy to workaround
348  'make install' errors.
349
350* Wed Jul 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.4-1
351- Update to 0.23.4.
352- Update source url.
353
354* Mon Jun  2 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.3-1
355- Update to 0.23.3.
356- Remove reference to stream-engine in connections managers readme.
357
358* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.2-1
359- Update to 0.23.2.
360- Add man pages.
361- Use enchant-devel, instead of aspell-devel.
362
363* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-3
364- Rebuild for new e-d-s.
365
366* Sun May  4 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-2
367- Drop multiple copies of COPYING file.
368- Drop BR on gnome-vfs2-devel.
369- Require telepathy-stream-engine for VOIP support.
370- Add BR on iso-codes-devel, so spell-checking is enabled.
371
372* Wed Apr 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.23.1-1
373- Update to new upstream release (0.23.1)
374- Drop libtelepathy dependencies; upstream switched fully to telepathy-glib.
375
376* Fri Apr 11 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.1-1
377- Update to new upstream release (0.22.1)
378
379* Mon Mar 10 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.0-1
380- Update to new upstream release (0.22.0)
381
382* Sun Mar 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.91-1
383- Update to new upstream release (0.21.91)
384
385* Fri Feb 22 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.90-1
386- Update to new upstream release (0.21.90)
387
388* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.21.4-2
389- Autorebuild for GCC 4.3
390
391* Mon Dec 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.4-1
392- Update to new upstream release (0.21.4)
393
394* Tue Nov 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.2-1
395- Update to new upstream release (0.21.2)
396- Drop backported drag-and-drop patch (fixed upstream):
397    - svn380-fix-contact-DnD.patch
398- Update README.ConnectionManagers: Include Haze package note, remove Galago
399  note (a feed-only connection manager isn't useful for instant messaging),
400  and fix some wording.
401
402* Fri Oct 19 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-5
403- Backport upstream patch to fixes crashes when using drag-and-drop of a
404  contact from the buddy list to the current conversation window to initiate a
405  conversation:
406    + svn380-fix-contact-DnD.patch
407- Resolves: GNOME bug 483168 (crash in Empathy Instant Messenger: I had
408  dragged a contact ...)
409
410* Tue Oct 16 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-4
411- Depend on Salut and Gabble to enable XMPP by default. Otherwise, Empathy
412  is essentially useless due to the need to install an external connection
413  manager. Also, add a README.ConnectionManagers to the installed
414  documentation which lists other possibilities.
415- Resolves: bug 308871 (Make empathy dependent at least on telepathy-gabble)
416  and bug 334221 (Default empathy install is useless).
417
418* Wed Oct 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-3
419- Enable VoIP support for those brave enough to test/break/debug it (F9+
420  only). Though it is functional, it is still deemed rather unstable by
421  upstream. Use it at your own risk. :)
422
423* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-2
424- Disable VoIP support at this time, since it is deemed unstable by upstream
425  for now. (Thanks to Brian Pepple for the notice.)
426 
427* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-1
428- Update to new upstream release (0.14).
429
430* Sun Sep 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.13-1
431- Update to new upstream release (0.13), which adds a panel applet (Megaphone)
432  and python bindings.
433- Split shared libraries into a libs subpackage for easier handling
434  in multi-lib environments.
435
436* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-2
437- Add ldconfig invocations to %%post and %%postun scriptlets.
438
439* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-1
440- Update to new upstream release (0.12).
441- Build against new mission-control stack.
442- Update License tag (GPLv2+).
443- Alphabetize BuildRequires list (aesthetic-only change).
444
445* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.8-2
446- Rebuild for selinux ppc32 issue.
447
448* Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-1
449- Update to new upstream release (0.11)
450
451* Fri Jun 22 2007 David Nielsen <david@lovesunix.net> - 0.8-1
452- bump to 0.8
453- Now with aspell support (deat to teh speeling mistaks)
454
455* Sat Jun  9 2007 David Nielsen <david@lovesunix.net> - 0.7-1
456- bump to 0.7
457
458* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-3
459- Add telepathy-filesystem to Requires
460- Move .desktop from autostart to applications
461- Nasty hackery to make empathy launch from the menu
462
463* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-2
464- Add gettext to BuildRequires
465
466* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.6-1
467- Bump to 0.6
468
469* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.5-2
470- Let Empathy own the directory and not just the files in it
471
472* Tue May 30 2007 David Nielsen <david@lovesunix.net> - 0.5-1
473- Initial package
Note: See TracBrowser for help on using the repository browser.