source: projects/specs/trunk/e/empathy/empathy-vl.spec @ 6273

Revision 6273, 16.7 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1%define major_ver 3.4
2%define minor_ver 2.1
3%define rel       1
4
5%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
6
7## Minimum required versions of GLib, GTK+, libtelepathy, and Mission-Control,
8## respectively.
9%global gtk3_min_version        3.4.0
10%global glib2_min_version       2.32.0
11%global tp_mc_min_version       5.12.0
12%global tp_glib_min_version     0.18.0
13%global tp_logger_min_version   0.2.10
14%global aspell_version          0.50
15%global libcanberra_version     0.25
16%global gnome_keyring_version   3.4
17%global libnotify_version       0.7.4
18%global folks_version           0.6.8
19
20Summary:        GNOME Instant Messaging Client
21Summary(ja):    GNOME インスタントメッセージクラアイント
22
23Name:           empathy
24Version:        %{major_ver}.%{minor_ver}
25Release:        %{rel}%{?_dist_release}
26
27Group:          Applications/Communications
28License:        GPLv2+
29URL:            http://live.gnome.org/Empathy
30
31Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/%{majorver}/%{name}-%{version}.tar.xz
32Source1:        %{name}-README.ConnectionManagers
33
34BuildRoot: %{_tmppath}/%{name}-%{version}-root
35
36#BuildRequires: enchant-devel >= %{enchant_version}
37BuildRequires:  aspell-devel >= %{aspell_version}
38BuildRequires:  iso-codes
39BuildRequires:  desktop-file-utils
40BuildRequires:  evolution-data-server-devel
41BuildRequires:  gettext
42BuildRequires:  glib2-devel >= %{glib2_min_version}
43BuildRequires:  gnome-doc-utils >= 0.17.3
44BuildRequires:  gnome-panel
45BuildRequires:  gtk3-devel >= %{gtk3_min_version}
46BuildRequires:  intltool
47BuildRequires:  libxml2-devel
48BuildRequires:  perl(XML::Parser)
49BuildRequires:  telepathy-glib-devel >= %{tp_glib_min_version}
50BuildRequires:  telepathy-logger-devel >= %{tp_logger_min_version}
51BuildRequires:  telepathy-mission-control-devel >= %{tp_mc_min_version}
52BuildRequires:  farstream-devel
53BuildRequires:  telepathy-farstream-devel
54BuildRequires:  libcanberra-gtk3-devel >= %{libcanberra_version}
55BuildRequires:  libgnome-keyring-devel >= %{gnome_keyring_version}
56BuildRequires:  unique3-devel
57BuildRequires:  libnotify-devel >= %{libnotify_version}
58BuildRequires:  folks-devel >= %{folks_version}
59BuildRequires:  gcr-devel >= %{gnome_keyring_version}
60BuildRequires:  openssl-devel
61BuildRequires:  NetworkManager-glib-devel
62BuildRequires:  WebKit3-gtk-devel
63BuildRequires:  geoclue-devel
64BuildRequires:  enchant-devel
65BuildRequires:  libICE-devel
66BuildRequires:  cheese-devel
67BuildRequires:  pulseaudio-libs-devel
68BuildRequires:  gnome-online-accounts-devel
69BuildRequires:  libgudev1-devel
70BuildRequires:  libchamplain-gtk-devel
71BuildRequires:  gsettings-desktop-schemas-devel
72BuildRequires:  itstool
73
74Requires:       telepathy-filesystem
75Requires:       telepathy-gabble
76Requires:       telepathy-salut
77Requires:       telepathy-idle
78## Also hardcode Haze dependency since Empathy is the default IM client in F10+
79## and I'd hate for people to simply disregard it for lack of the "out of the
80## box" protocol support that Pidgin has. (RHBZ: 458935)
81BuildRequires:  telepathy-haze
82# Require this for VOIP support
83Requires:       telepathy-mission-control >= %{tp_mc_min_version}
84
85
86Requires(post): GConf2
87Requires(post): scrollkeeper
88
89Requires(postun):       scrollkeeper
90
91## We're using Empathy's upstreamed profiles for Haze-provided stuff now.
92Obsoletes:      telepathy-haze-mission-control < 0.2.0-3
93Provides:       telepathy-haze-mission-control = 0.2.0-3
94## upstream 2.29.1 removed shared libraries: #599086
95Obsoletes: empathy-libs < 2.29.1, empathy-devel < 2.29.1
96## upstream 2.29.1 removed python bindings' #599039
97Obsoletes: empathy-python < 2.29.1
98
99Vendor: Project Vine
100Distribution: Vine Linux
101
102%description
103Empathy provides a powerful multiple protocol instant messaging
104client using the Telepathy framework.
105
106
107%package -n     nautilus-sendto-empathy
108License:        GPLv2+
109Summary:        Nautilus-sendto plugin for empathy
110Summary(ja):    empathy 用 nautilus-sendto プラグイン
111Group:          User Interface/Desktop
112
113Requires:       %{name} = %{version}-%{release}
114Requires:       nautilus-sendto
115BuildRequires:  nautilus-sendto-devel
116
117%description -n nautilus-sendto-empathy
118This package contains nautilus-sendto plugin for the Empathy IM application.
119
120
121%prep
122%setup -q
123
124
125%build
126## GCC complains about some unused functions, so we forcibly show those as
127## simple warnings instead of build-halting errors.
128%configure --disable-static
129
130## RPATHs are yucky.
131sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
132sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
133
134##make %{?_smp_mflags}
135## don't use _smp_mflags at empathy-2.18.1
136make
137
138install -m 0644 %{SOURCE1} ./README.ConnectionManagers
139
140
141%install
142rm -rf $RPM_BUILD_ROOT
143make install DESTDIR=$RPM_BUILD_ROOT
144find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
145
146%find_lang %{name}
147
148desktop-file-install --vendor "" --delete-original      \
149        --dir %{buildroot}%{_datadir}/applications      \
150        %{buildroot}%{_datadir}/applications/%{name}.desktop
151
152
153%clean
154rm -rf %{buildroot}
155
156
157%post
158scrollkeeper-update -q -o %{_datadir}/omf/%{name} ||:
159touch --no-create %{_datadir}/icons/hicolor ||:
160%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
161
162%postun
163scrollkeeper-update -q || :
164touch --no-create %{_datadir}/icons/hicolor || :
165if [ -x %{_bindir}/gtk-update-icon-cache ]; then
166        %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
167        glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
168fi
169
170%posttrans
171gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null ||:
172glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
173
174
175%files -f %{name}.lang
176%defattr(-,root,root,-)
177%doc AUTHORS COPYING README README.ConnectionManagers NEWS
178%{_bindir}/empathy
179%{_bindir}/empathy-accounts
180%{_bindir}/empathy-debugger
181%{_libdir}/mission-control-plugins.0/mcp-account-manager-goa.so
182%{_libexecdir}/empathy-auth-client
183%{_libexecdir}/empathy-call
184%{_libexecdir}/empathy-chat
185%{_datadir}/dbus-1/services/*
186%{_datadir}/empathy
187%{_datadir}/glib-2.0/schemas/*.xml
188%{_datadir}/GConf/gsettings/*
189%{_datadir}/applications/*.desktop
190%{_datadir}/help/*/%{name}
191#{_datadir}/omf/%{name}/
192%{_datadir}/icons/hicolor/*/apps/%{name}*
193#{_datadir}/mission-control/profiles/*.profile
194%{_datadir}/telepathy/clients/*.client
195%{_mandir}/man1/empathy*.1*
196
197%files -n nautilus-sendto-empathy
198%defattr(-,root,root,-)
199%{_libdir}/nautilus-sendto/plugins/libnstempathy.so
200
201
202%changelog
203* Tue Jun 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2.1-1
204- new upstream release
205
206* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
207- new upstream release
208
209* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
210- new upstream release
211- change BuildRequires: gcr-devel instead of gnome-keyring-devel
212- change BuildRequires: farstream-devel instead of farsight2-devel
213- change BuildRequires: telepathy-farstream-devel instead of telepathy-farsight-devel
214- add BuildRequires: itstool
215- remove Requires: telepathy-stream-engine
216- add Requires: telepathy-idle
217
218* Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
219- new upstream release
220
221* Thu Nov 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1.1-1
222- new upstream release
223
224* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
225- new upstream release
226- add BuildRequires: libgudev1-devel, gnome-online-accounts-devel
227
228* Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0.1-1
229- new upstream release
230
231* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
232- new upstream release
233
234* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
235- new upstream release
236
237* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
238- new upstream release
239
240* Sun Aug 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5.1-1
241- new upstream release
242
243* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
244- new upstream release
245- add BuildRequires: pulseaudio-libs-devel
246
247* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
248- new upstream release
249- change BuildRequires: gtk3-devel instead of gtk2-devel
250- change BuildRequires: unique3-devel instead of unique-devel
251- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
252- change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
253- add BuildRequires: gsettings-desktop-schemas, libICE-devel, cheese-devel, libchamplain-gtk-devel
254
255* Sun Jan 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
256- new upstream release
257- add BuildRequires: openssl-devel, NetworkManager-glib-devel, WebKit-devel
258                     geoclue-devel, enchant-devel
259- add Requires: telepathy-mission-control
260- add configure option: --with-ca-file=/usr/share/ssl/certs/ca-bundle.crt
261
262* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0.1-1
263- new upstream release
264- add BuildRequires: folks-devel, telepathy-logger-devel, gnome-keyring-devel
265- fix %files
266- fix %post, %postun
267- drop %pre, %preun
268
269* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0.1-3
270- rebuild with evolution-data-server-2.30.2
271- add nautilus-sendto-empathy package
272  - add configure option (--enable-nautilus-sendto=yes)
273  - add BuildRequires: nautilus-sendto-devel
274
275* Sat Jun 12 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-2
276- add Obsoletes: empathy-python < 2.29.1
277
278* Tue Apr 13 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-1
279- new upstream release
280- add new files: %%{_bindir}/empathy-{accounts,debugger}
281- drop -libs, -devel, -python sub packages: upstream removed
282  - Obsoletes: empathy-{libs,devel} < 2.29.1
283  - drop BuildRequires: python-devel
284- drop %%{_bindir}/empathy-logs in %%files: upstream don not install
285- drop applet files in %%files: upstream removed the panel applets
286  - update %%post, %pre and %%preun
287- update BuildRequires version for glib2 and tp_glib
288- defined major_ver, minor_ver and rel
289- fix BuildRequires for gnome-keyring
290
291* Sat Mar 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
292- new upstream release
293- add BuildRequires: libtelepathy-devel, libgnomecanvas-devel, libbonoboui-devel, python-devel
294
295* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.1-4
296- rebuilt with python-2.6.4
297
298* Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> - 2.28.1-3
299- unuse %%{?_smp_mflags} option to make
300
301* Wed Nov 11 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.1-2
302- add {gnome-keyring,libcanberra,libnotify,unique}-devel to BuildRequires
303
304* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
305- new upstream release
306
307* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
308- new upstream release
309
310* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
311- initial build for Vine Linux
312
313* Tue Sep  9 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.92-1
314- Update to 2.23.92
315
316* Thu Sep  4 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.91-1
317- Update to 2.23.91
318
319* Sun Aug 24 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-2
320- Now that Empathy will be the default IM client in F10+, hardcode a dependency
321  on telepathy-haze to keep the same protocol functionality across upgrades,
322  for a much improved "out of the box" experience.
323- Reference: bug 458935.
324
325* Fri Aug 22 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-1
326- Update to new upstream release (2.23.90)
327
328* Fri Aug 15 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-3
329- Apply patch from Colin Walters to automagically update profile namings for
330  the switch to using Empathy's provided profiles.
331- Drop the upgrade script (no longer needed since it's automatically done).
332  - upgrade-haze-profiles.sh
333
334* Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-2
335- Use upstream's AIM, ICQ, MSN-Haze, and Yahoo profiles instead of recommending
336  the telepathy-haze-mission-control package. (The Haze-provided ones have grown
337  horribly stale...). This makes for better automagic functionality (if Haze is
338  installed, Empathy/MC will autodetect it) and tracks upstream more closely.
339  + upgrade-haze-profiles.sh
340
341* Mon Aug 04 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-1
342- Update to new upstream release (2.23.6)
343- Use the in-tarball libtool scripts instead of the system copy to workaround
344  'make install' errors.
345
346* Wed Jul 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.4-1
347- Update to 0.23.4.
348- Update source url.
349
350* Mon Jun  2 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.3-1
351- Update to 0.23.3.
352- Remove reference to stream-engine in connections managers readme.
353
354* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.2-1
355- Update to 0.23.2.
356- Add man pages.
357- Use enchant-devel, instead of aspell-devel.
358
359* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-3
360- Rebuild for new e-d-s.
361
362* Sun May  4 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-2
363- Drop multiple copies of COPYING file.
364- Drop BR on gnome-vfs2-devel.
365- Require telepathy-stream-engine for VOIP support.
366- Add BR on iso-codes-devel, so spell-checking is enabled.
367
368* Wed Apr 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.23.1-1
369- Update to new upstream release (0.23.1)
370- Drop libtelepathy dependencies; upstream switched fully to telepathy-glib.
371
372* Fri Apr 11 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.1-1
373- Update to new upstream release (0.22.1)
374
375* Mon Mar 10 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.0-1
376- Update to new upstream release (0.22.0)
377
378* Sun Mar 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.91-1
379- Update to new upstream release (0.21.91)
380
381* Fri Feb 22 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.90-1
382- Update to new upstream release (0.21.90)
383
384* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.21.4-2
385- Autorebuild for GCC 4.3
386
387* Mon Dec 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.4-1
388- Update to new upstream release (0.21.4)
389
390* Tue Nov 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.2-1
391- Update to new upstream release (0.21.2)
392- Drop backported drag-and-drop patch (fixed upstream):
393    - svn380-fix-contact-DnD.patch
394- Update README.ConnectionManagers: Include Haze package note, remove Galago
395  note (a feed-only connection manager isn't useful for instant messaging),
396  and fix some wording.
397
398* Fri Oct 19 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-5
399- Backport upstream patch to fixes crashes when using drag-and-drop of a
400  contact from the buddy list to the current conversation window to initiate a
401  conversation:
402    + svn380-fix-contact-DnD.patch
403- Resolves: GNOME bug 483168 (crash in Empathy Instant Messenger: I had
404  dragged a contact ...)
405
406* Tue Oct 16 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-4
407- Depend on Salut and Gabble to enable XMPP by default. Otherwise, Empathy
408  is essentially useless due to the need to install an external connection
409  manager. Also, add a README.ConnectionManagers to the installed
410  documentation which lists other possibilities.
411- Resolves: bug 308871 (Make empathy dependent at least on telepathy-gabble)
412  and bug 334221 (Default empathy install is useless).
413
414* Wed Oct 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-3
415- Enable VoIP support for those brave enough to test/break/debug it (F9+
416  only). Though it is functional, it is still deemed rather unstable by
417  upstream. Use it at your own risk. :)
418
419* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-2
420- Disable VoIP support at this time, since it is deemed unstable by upstream
421  for now. (Thanks to Brian Pepple for the notice.)
422 
423* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-1
424- Update to new upstream release (0.14).
425
426* Sun Sep 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.13-1
427- Update to new upstream release (0.13), which adds a panel applet (Megaphone)
428  and python bindings.
429- Split shared libraries into a libs subpackage for easier handling
430  in multi-lib environments.
431
432* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-2
433- Add ldconfig invocations to %%post and %%postun scriptlets.
434
435* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-1
436- Update to new upstream release (0.12).
437- Build against new mission-control stack.
438- Update License tag (GPLv2+).
439- Alphabetize BuildRequires list (aesthetic-only change).
440
441* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.8-2
442- Rebuild for selinux ppc32 issue.
443
444* Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-1
445- Update to new upstream release (0.11)
446
447* Fri Jun 22 2007 David Nielsen <david@lovesunix.net> - 0.8-1
448- bump to 0.8
449- Now with aspell support (deat to teh speeling mistaks)
450
451* Sat Jun  9 2007 David Nielsen <david@lovesunix.net> - 0.7-1
452- bump to 0.7
453
454* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-3
455- Add telepathy-filesystem to Requires
456- Move .desktop from autostart to applications
457- Nasty hackery to make empathy launch from the menu
458
459* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-2
460- Add gettext to BuildRequires
461
462* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.6-1
463- Bump to 0.6
464
465* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.5-2
466- Let Empathy own the directory and not just the files in it
467
468* Tue May 30 2007 David Nielsen <david@lovesunix.net> - 0.5-1
469- Initial package
Note: See TracBrowser for help on using the repository browser.