source: projects/specs/trunk/e/empathy/empathy-vl.spec @ 521

Revision 521, 14.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3## Minimum required versions of GLib, GTK+, libtelepathy, and Mission-Control,
4## respectively.
5%global gtk2_min_version        2.14
6%global glib2_min_version       2.18.0
7%global tp_mc_min_version       5.3.2
8%global tp_glib_min_version     0.7.35
9#global enchant_version         1.4.0
10%global aspell_version          0.50
11%global libcanberra_version     0.4
12%global gnome_keyring_version   2.22
13%global libnotify_version       0.4.4
14
15Summary:        GNOME Instant Messaging Client
16Summary(ja):    GNOME インスタントメッセージクラアイント
17
18Name:           empathy
19Version:        2.28.1
20Release:        4%{?_dist_release}
21
22Group:          Applications/Communications
23License:        GPLv2+
24URL:            http://live.gnome.org/Empathy
25
26Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.28/%{name}-%{version}.tar.bz2
27Source1:        %{name}-README.ConnectionManagers
28
29BuildRoot: %{_tmppath}/%{name}-%{version}-root
30
31#BuildRequires: enchant-devel >= %{enchant_version}
32BuildRequires:  aspell-devel >= %{aspell_version}
33BuildRequires:  iso-codes
34BuildRequires:  desktop-file-utils
35BuildRequires:  evolution-data-server-devel
36BuildRequires:  GConf2-devel
37BuildRequires:  gettext
38BuildRequires:  glib2-devel >= %{glib2_min_version}
39BuildRequires:  gnome-doc-utils >= 0.17.3
40BuildRequires:  gnome-panel
41BuildRequires:  gtk2-devel >= %{gtk2_min_version}
42BuildRequires:  intltool
43BuildRequires:  libxml2-devel
44BuildRequires:  perl(XML::Parser)
45BuildRequires:  pygtk2-devel
46BuildRequires:  telepathy-glib-devel >= %{tp_glib_min_version}
47BuildRequires:  telepathy-mission-control-devel >= %{tp_mc_min_version}
48BuildRequires:  farsight2-devel
49BuildRequires:  telepathy-farsight-devel
50BuildRequires:  libcanberra-devel >= %{libcanberra_version}
51BuildRequires:  gnome-keyring-devel >= %{gnome_keyring_version}
52BuildRequires:  unique-devel
53BuildRequires:  libnotify-devel >= %{libnotify_version}
54
55Requires:       %{name}-libs = %{version}-%{release}
56Requires:       telepathy-filesystem
57## Empathy is useless without a proper Telepathy connection manager installed.
58## We hardcode dependencies on Salut and Gabble to support XMPP on a default
59## install, in both the link-local and Jabber/GoogleTalk incarnations.
60## (RHBZ: 308871 and 334221)
61## TODO: Perhaps we can configure these to be installed "on demand" with
62##       PackageKit and friends?
63Requires:       telepathy-gabble
64Requires:       telepathy-salut
65## Also hardcode Haze dependency since Empathy is the default IM client in F10+
66## and I'd hate for people to simply disregard it for lack of the "out of the
67## box" protocol support that Pidgin has. (RHBZ: 458935)
68Requires:       telepathy-haze
69# Require this for VOIP support
70Requires:       telepathy-stream-engine
71
72Requires(pre):  GConf2
73
74Requires(post): GConf2
75Requires(post): scrollkeeper
76
77Requires(preun):        GConf2
78
79Requires(postun):       scrollkeeper
80
81## We're using Empathy's upstreamed profiles for Haze-provided stuff now.
82Obsoletes:      telepathy-haze-mission-control < 0.2.0-3
83Provides:       telepathy-haze-mission-control = 0.2.0-3
84
85%description
86Empathy provides a powerful multiple protocol instant messaging
87client using the Telepathy framework.
88
89
90%package        devel
91Summary:        Development files for %{name}
92Summary(ja):    Development files for %{name}
93Group:          Development/Libraries
94Requires:       %{name}-libs = %{version}-%{release}
95Requires:       pkgconfig
96## Needs these for the various #include directives in its headers, as well
97## as pkgconfig dependencies...
98Requires:       glib2-devel
99Requires:       telepathy-glib-devel
100Requires:       telepathy-mission-control-devel
101Requires:       libxml2-devel
102
103%description    devel
104The %{name}-devel package contains libraries and header files for
105developing applications that use %{name}.
106
107
108%package        libs
109Summary:        Shared libraries for %{name}
110Summary(ja):    Shared libraries for %{name}
111Group:          Development/Libraries
112Requires:       glib2
113Requires:       gtk2
114Requires:       telepathy-glib
115Requires:       telepathy-mission-control
116
117%description    libs
118The %{name}-libs package contains shared libraries used by Empathy.
119
120
121%package        python
122Summary:        Python bindings for libempathy and libempathy-gtk
123Summary(ja):    Python bindings for libempathy and libempathy-gtk
124Group:          Development/Languages
125Requires:       %{name}-libs = %{version}-%{release}   
126
127%description    python
128This package contains the empathy and empathygtk Python modules, which provide
129bindings to the libempathy and libempathy-gtk libraries, respectively.
130
131%prep
132%setup -q
133
134
135%build
136## GCC complains about some unused functions, so we forcibly show those as
137## simple warnings instead of build-halting errors.
138%configure --with-compile-warnings=yes --disable-static
139## RPATHs are yucky.
140sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
141sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
142
143##make %{?_smp_mflags}
144## don't use _smp_mflags at empathy-2.18.1
145make
146
147install -m 0644 %{SOURCE1} ./README.ConnectionManagers
148
149
150%install
151rm -rf $RPM_BUILD_ROOT
152make install DESTDIR=$RPM_BUILD_ROOT
153find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
154
155%find_lang %{name}
156
157desktop-file-install --vendor "" --delete-original      \
158        --dir %{buildroot}%{_datadir}/applications      \
159        %{buildroot}%{_datadir}/applications/%{name}.desktop
160
161
162%clean
163rm -rf %{buildroot}
164
165
166%pre
167if [ "$1" -gt 1 ]; then
168        export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
169        gconftool-2 --makefile-uninstall-rule   \
170                %{_sysconfdir}/gconf/schemas/GNOME_Megaphone_Applet.schemas     \
171                %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null ||:
172fi
173
174
175%post
176export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
177gconftool-2 --makefile-install-rule     \
178        %{_sysconfdir}/gconf/schemas/GNOME_Megaphone_Applet.schemas     \
179        %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null ||:
180scrollkeeper-update -q -o %{_datadir}/omf/%{name} ||:
181touch --no-create %{_datadir}/icons/hicolor ||:
182%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
183
184%post libs -p /sbin/ldconfig
185
186
187%preun
188if [ "$1" -eq 0 ]; then
189        export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
190        gconftool-2 --makefile-uninstall-rule   \
191                %{_sysconfdir}/gconf/schemas/GNOME_Megaphone_Applet.schemas     \
192                %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null ||:
193fi
194
195
196%postun
197scrollkeeper-update -q || :
198touch --no-create %{_datadir}/icons/hicolor || :
199if [ -x %{_bindir}/gtk-update-icon-cache ]; then
200        %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
201fi
202
203%postun libs -p /sbin/ldconfig
204
205
206%files -f %{name}.lang
207%defattr(-,root,root,-)
208%doc AUTHORS COPYING README README.ConnectionManagers NEWS
209%{_sysconfdir}/gconf/schemas/%{name}.schemas
210%{_sysconfdir}/gconf/schemas/GNOME_Megaphone_Applet.schemas
211%{_bindir}/empathy
212%{_bindir}/empathy-logs
213%{_datadir}/dbus-1/services/*
214%{_datadir}/empathy
215%{_datadir}/applications/*.desktop
216%{_datadir}/gnome/help/%{name}/
217#{_datadir}/omf/%{name}/
218%{_datadir}/icons/hicolor/*/apps/%{name}*
219#{_datadir}/mission-control/profiles/*.profile
220%{_datadir}/telepathy/clients/Empathy.client
221%{_libexecdir}/megaphone-applet
222%{_libexecdir}/nothere-applet
223%{_libdir}/bonobo/servers/GNOME_Megaphone_Applet.server
224%{_libdir}/bonobo/servers/GNOME_NotHere_Applet.server
225%{_mandir}/man1/empathy*.1.gz
226
227%files  libs
228%defattr(-,root,root,-)
229%{_libdir}/libempathy*.so.*
230
231%files  devel
232%defattr(-,root,root,-)
233%{_includedir}/libempathy*/
234%{_libdir}/libempathy*.so
235%{_libdir}/pkgconfig/libempathy*.pc
236%{_datadir}/gtk-doc/html/libempathy*
237
238%files  python
239%defattr(-,root,root,-)
240%{python_sitearch}/empathy*.so
241
242%changelog
243* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.1-4
244- rebuilt with python-2.6.4
245
246* Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> - 2.28.1-3
247- unuse %%{?_smp_mflags} option to make
248
249* Wed Nov 11 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.1-2
250- add {gnome-keyring,libcanberra,libnotify,unique}-devel to BuildRequires
251
252* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
253- new upstream release
254
255* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
256- new upstream release
257
258* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
259- initial build for Vine Linux
260
261* Tue Sep  9 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.92-1
262- Update to 2.23.92
263
264* Thu Sep  4 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.91-1
265- Update to 2.23.91
266
267* Sun Aug 24 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-2
268- Now that Empathy will be the default IM client in F10+, hardcode a dependency
269  on telepathy-haze to keep the same protocol functionality across upgrades,
270  for a much improved "out of the box" experience.
271- Reference: bug 458935.
272
273* Fri Aug 22 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-1
274- Update to new upstream release (2.23.90)
275
276* Fri Aug 15 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-3
277- Apply patch from Colin Walters to automagically update profile namings for
278  the switch to using Empathy's provided profiles.
279- Drop the upgrade script (no longer needed since it's automatically done).
280  - upgrade-haze-profiles.sh
281
282* Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-2
283- Use upstream's AIM, ICQ, MSN-Haze, and Yahoo profiles instead of recommending
284  the telepathy-haze-mission-control package. (The Haze-provided ones have grown
285  horribly stale...). This makes for better automagic functionality (if Haze is
286  installed, Empathy/MC will autodetect it) and tracks upstream more closely.
287  + upgrade-haze-profiles.sh
288
289* Mon Aug 04 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-1
290- Update to new upstream release (2.23.6)
291- Use the in-tarball libtool scripts instead of the system copy to workaround
292  'make install' errors.
293
294* Wed Jul 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.4-1
295- Update to 0.23.4.
296- Update source url.
297
298* Mon Jun  2 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.3-1
299- Update to 0.23.3.
300- Remove reference to stream-engine in connections managers readme.
301
302* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.2-1
303- Update to 0.23.2.
304- Add man pages.
305- Use enchant-devel, instead of aspell-devel.
306
307* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-3
308- Rebuild for new e-d-s.
309
310* Sun May  4 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-2
311- Drop multiple copies of COPYING file.
312- Drop BR on gnome-vfs2-devel.
313- Require telepathy-stream-engine for VOIP support.
314- Add BR on iso-codes-devel, so spell-checking is enabled.
315
316* Wed Apr 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.23.1-1
317- Update to new upstream release (0.23.1)
318- Drop libtelepathy dependencies; upstream switched fully to telepathy-glib.
319
320* Fri Apr 11 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.1-1
321- Update to new upstream release (0.22.1)
322
323* Mon Mar 10 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.0-1
324- Update to new upstream release (0.22.0)
325
326* Sun Mar 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.91-1
327- Update to new upstream release (0.21.91)
328
329* Fri Feb 22 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.90-1
330- Update to new upstream release (0.21.90)
331
332* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.21.4-2
333- Autorebuild for GCC 4.3
334
335* Mon Dec 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.4-1
336- Update to new upstream release (0.21.4)
337
338* Tue Nov 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.2-1
339- Update to new upstream release (0.21.2)
340- Drop backported drag-and-drop patch (fixed upstream):
341    - svn380-fix-contact-DnD.patch
342- Update README.ConnectionManagers: Include Haze package note, remove Galago
343  note (a feed-only connection manager isn't useful for instant messaging),
344  and fix some wording.
345
346* Fri Oct 19 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-5
347- Backport upstream patch to fixes crashes when using drag-and-drop of a
348  contact from the buddy list to the current conversation window to initiate a
349  conversation:
350    + svn380-fix-contact-DnD.patch
351- Resolves: GNOME bug 483168 (crash in Empathy Instant Messenger: I had
352  dragged a contact ...)
353
354* Tue Oct 16 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-4
355- Depend on Salut and Gabble to enable XMPP by default. Otherwise, Empathy
356  is essentially useless due to the need to install an external connection
357  manager. Also, add a README.ConnectionManagers to the installed
358  documentation which lists other possibilities.
359- Resolves: bug 308871 (Make empathy dependent at least on telepathy-gabble)
360  and bug 334221 (Default empathy install is useless).
361
362* Wed Oct 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-3
363- Enable VoIP support for those brave enough to test/break/debug it (F9+
364  only). Though it is functional, it is still deemed rather unstable by
365  upstream. Use it at your own risk. :)
366
367* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-2
368- Disable VoIP support at this time, since it is deemed unstable by upstream
369  for now. (Thanks to Brian Pepple for the notice.)
370 
371* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-1
372- Update to new upstream release (0.14).
373
374* Sun Sep 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.13-1
375- Update to new upstream release (0.13), which adds a panel applet (Megaphone)
376  and python bindings.
377- Split shared libraries into a libs subpackage for easier handling
378  in multi-lib environments.
379
380* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-2
381- Add ldconfig invocations to %%post and %%postun scriptlets.
382
383* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-1
384- Update to new upstream release (0.12).
385- Build against new mission-control stack.
386- Update License tag (GPLv2+).
387- Alphabetize BuildRequires list (aesthetic-only change).
388
389* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.8-2
390- Rebuild for selinux ppc32 issue.
391
392* Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-1
393- Update to new upstream release (0.11)
394
395* Fri Jun 22 2007 David Nielsen <david@lovesunix.net> - 0.8-1
396- bump to 0.8
397- Now with aspell support (deat to teh speeling mistaks)
398
399* Sat Jun  9 2007 David Nielsen <david@lovesunix.net> - 0.7-1
400- bump to 0.7
401
402* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-3
403- Add telepathy-filesystem to Requires
404- Move .desktop from autostart to applications
405- Nasty hackery to make empathy launch from the menu
406
407* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-2
408- Add gettext to BuildRequires
409
410* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.6-1
411- Bump to 0.6
412
413* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.5-2
414- Let Empathy own the directory and not just the files in it
415
416* Tue May 30 2007 David Nielsen <david@lovesunix.net> - 0.5-1
417- Initial package
Note: See TracBrowser for help on using the repository browser.