source: projects/specs/trunk/e/empathy/empathy-vl.spec @ 8353

Revision 8353, 17.3 KB checked in by Takemikaduchi, 10 years ago (diff)

GNOME-3.12.0

Line 
1%define major_ver 3.12
2%define minor_ver 0
3%define rel       1
4
5%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
6
7## Minimum required versions of GLib, GTK+, libtelepathy, and Mission-Control,
8## respectively.
9%global gtk3_min_version        3.12.0
10%global glib2_min_version       2.40.0
11%global tp_mc_min_version       5.12.0
12%global tp_glib_min_version     0.18.0
13%global tp_logger_min_version   0.2.10
14%global aspell_version          0.50
15%global libcanberra_version     0.25
16%global libnotify_version       0.7.4
17%global folks_version           0.6.8
18%global libsecret_version       0.5
19
20Summary:        GNOME Instant Messaging Client
21Summary(ja):    GNOME インスタントメッセージクラアイント
22
23Name:           empathy
24Version:        %{major_ver}.%{minor_ver}
25Release:        %{rel}%{?_dist_release}
26
27Group:          Applications/Communications
28License:        GPLv2+
29URL:            http://live.gnome.org/Empathy
30
31Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/%{majorver}/%{name}-%{version}.tar.xz
32Source1:        %{name}-README.ConnectionManagers
33
34BuildRoot: %{_tmppath}/%{name}-%{version}-root
35
36#BuildRequires: enchant-devel >= %{enchant_version}
37BuildRequires:  aspell-devel >= %{aspell_version}
38BuildRequires:  iso-codes
39BuildRequires:  desktop-file-utils
40BuildRequires:  evolution-data-server-devel
41BuildRequires:  gettext
42BuildRequires:  glib2-devel >= %{glib2_min_version}
43BuildRequires:  gtk3-devel >= %{gtk3_min_version}
44BuildRequires:  intltool
45BuildRequires:  libxml2-devel
46BuildRequires:  perl(XML::Parser)
47BuildRequires:  telepathy-glib-devel >= %{tp_glib_min_version}
48BuildRequires:  telepathy-logger-devel >= %{tp_logger_min_version}
49BuildRequires:  telepathy-mission-control-devel >= %{tp_mc_min_version}
50BuildRequires:  farstream-devel
51BuildRequires:  telepathy-farstream-devel
52BuildRequires:  libcanberra-gtk3-devel >= %{libcanberra_version}
53BuildRequires:  unique3-devel
54BuildRequires:  libnotify-devel >= %{libnotify_version}
55BuildRequires:  folks-devel >= %{folks_version}
56BuildRequires:  gcr-devel >= %{gnome_keyring_version}
57BuildRequires:  libsecret-devel >= %{libsecret_version}
58BuildRequires:  openssl-devel
59BuildRequires:  NetworkManager-glib-devel
60BuildRequires:  WebKit3-gtk-devel
61BuildRequires:  geoclue-devel
62BuildRequires:  enchant-devel
63BuildRequires:  libICE-devel
64BuildRequires:  cheese-devel
65BuildRequires:  pulseaudio-libs-devel
66BuildRequires:  gnome-online-accounts-devel
67BuildRequires:  libgudev1-devel
68BuildRequires:  libchamplain-gtk-devel
69BuildRequires:  gsettings-desktop-schemas-devel
70BuildRequires:  yelp-tools
71
72Requires:       telepathy-filesystem
73Requires:       telepathy-gabble
74Requires:       telepathy-salut
75Requires:       telepathy-idle
76## Also hardcode Haze dependency since Empathy is the default IM client in F10+
77## and I'd hate for people to simply disregard it for lack of the "out of the
78## box" protocol support that Pidgin has. (RHBZ: 458935)
79BuildRequires:  telepathy-haze
80# Require this for VOIP support
81Requires:       telepathy-mission-control >= %{tp_mc_min_version}
82
83
84## We're using Empathy's upstreamed profiles for Haze-provided stuff now.
85Obsoletes:      telepathy-haze-mission-control < 0.2.0-3
86Provides:       telepathy-haze-mission-control = 0.2.0-3
87## upstream 2.29.1 removed shared libraries: #599086
88Obsoletes: empathy-libs < 2.29.1, empathy-devel < 2.29.1
89## upstream 2.29.1 removed python bindings' #599039
90Obsoletes: empathy-python < 2.29.1
91
92Obsoletes: nautilus-sendto-empathy < 3.7.0
93
94Vendor: Project Vine
95Distribution: Vine Linux
96
97%description
98Empathy provides a powerful multiple protocol instant messaging
99client using the Telepathy framework.
100
101
102%prep
103%setup -q
104
105
106%build
107## GCC complains about some unused functions, so we forcibly show those as
108## simple warnings instead of build-halting errors.
109%configure --disable-static
110
111##make %{?_smp_mflags}
112## don't use _smp_mflags at empathy-2.18.1
113make
114
115install -m 0644 %{SOURCE1} ./README.ConnectionManagers
116
117
118%install
119rm -rf $RPM_BUILD_ROOT
120make install DESTDIR=$RPM_BUILD_ROOT
121find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
122
123%find_lang %{name}
124%find_lang %{name}-tpaw
125
126desktop-file-install --vendor "" --delete-original      \
127        --dir %{buildroot}%{_datadir}/applications      \
128        %{buildroot}%{_datadir}/applications/%{name}.desktop
129
130
131%clean
132rm -rf %{buildroot}
133
134
135%post
136touch --no-create %{_datadir}/icons/hicolor ||:
137%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
138
139%postun
140touch --no-create %{_datadir}/icons/hicolor || :
141if [ -x %{_bindir}/gtk-update-icon-cache ]; then
142        %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
143        glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
144fi
145
146%posttrans
147gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null ||:
148glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
149
150
151%files -f %{name}.lang -f %{name}-tpaw.lang
152%defattr(-,root,root,-)
153%doc AUTHORS COPYING README README.ConnectionManagers NEWS
154%{_bindir}/empathy
155%{_bindir}/empathy-accounts
156%{_bindir}/empathy-debugger
157%{_libexecdir}/empathy-auth-client
158%{_libexecdir}/empathy-call
159%{_libexecdir}/empathy-chat
160%{_libdir}/%{name}/libempathy*.so
161%{_libdir}/mission-control-plugins.0/mcp-account-manager-goa.so
162%{_datadir}/GConf/gsettings/*
163%{_datadir}/appdata/empathy.appdata.xml
164%{_datadir}/applications/*.desktop
165%{_datadir}/adium/message-styles
166%{_datadir}/dbus-1/services/*
167%{_datadir}/%{name}
168%{_datadir}/glib-2.0/schemas/*.xml
169%{_datadir}/help/*/%{name}
170%{_datadir}/icons/hicolor/*/apps/%{name}*
171%{_datadir}/telepathy/clients/*.client
172%{_mandir}/man1/empathy*.1*
173
174
175%changelog
176* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
177- new upstream release
178
179* Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
180- new upstream release
181
182* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
183- new upstream release
184
185* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
186- new upstream release
187
188* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
189- new upstream release
190
191* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
192- new upstream release
193- remove BuildRequires: gnome-panel, nautilus-sendto-devel
194- remove nautilus-sendto-empathy subpackage
195
196* Fri Jan 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-2
197- fix spec
198
199* Fri Jan 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
200- new upstream release
201
202* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
203- new upstream release
204
205* Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
206- rebuild with telepathy-logger-0.6.0
207
208* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
209- new upstream release
210
211* Fri Oct 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0.3-1
212- new upstream release
213
214* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
215- new upstream release
216- add BuildRequires: libsecret-devel, yelp-tools
217- remove BuildRequires: libgnome-keyring-devel
218
219* Sun Jul 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2.3-1
220- new upstream release
221
222* Tue Jun 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2.1-1
223- new upstream release
224
225* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
226- new upstream release
227
228* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
229- new upstream release
230- change BuildRequires: gcr-devel instead of gnome-keyring-devel
231- change BuildRequires: farstream-devel instead of farsight2-devel
232- change BuildRequires: telepathy-farstream-devel instead of telepathy-farsight-devel
233- add BuildRequires: itstool
234- remove Requires: telepathy-stream-engine
235- add Requires: telepathy-idle
236
237* Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
238- new upstream release
239
240* Thu Nov 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1.1-1
241- new upstream release
242
243* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
244- new upstream release
245- add BuildRequires: libgudev1-devel, gnome-online-accounts-devel
246
247* Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0.1-1
248- new upstream release
249
250* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
251- new upstream release
252
253* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
254- new upstream release
255
256* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
257- new upstream release
258
259* Sun Aug 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5.1-1
260- new upstream release
261
262* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
263- new upstream release
264- add BuildRequires: pulseaudio-libs-devel
265
266* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
267- new upstream release
268- change BuildRequires: gtk3-devel instead of gtk2-devel
269- change BuildRequires: unique3-devel instead of unique-devel
270- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
271- change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
272- add BuildRequires: gsettings-desktop-schemas, libICE-devel, cheese-devel, libchamplain-gtk-devel
273
274* Sun Jan 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
275- new upstream release
276- add BuildRequires: openssl-devel, NetworkManager-glib-devel, WebKit-devel
277                     geoclue-devel, enchant-devel
278- add Requires: telepathy-mission-control
279- add configure option: --with-ca-file=/usr/share/ssl/certs/ca-bundle.crt
280
281* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0.1-1
282- new upstream release
283- add BuildRequires: folks-devel, telepathy-logger-devel, gnome-keyring-devel
284- fix %files
285- fix %post, %postun
286- drop %pre, %preun
287
288* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0.1-3
289- rebuild with evolution-data-server-2.30.2
290- add nautilus-sendto-empathy package
291  - add configure option (--enable-nautilus-sendto=yes)
292  - add BuildRequires: nautilus-sendto-devel
293
294* Sat Jun 12 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-2
295- add Obsoletes: empathy-python < 2.29.1
296
297* Tue Apr 13 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-1
298- new upstream release
299- add new files: %%{_bindir}/empathy-{accounts,debugger}
300- drop -libs, -devel, -python sub packages: upstream removed
301  - Obsoletes: empathy-{libs,devel} < 2.29.1
302  - drop BuildRequires: python-devel
303- drop %%{_bindir}/empathy-logs in %%files: upstream don not install
304- drop applet files in %%files: upstream removed the panel applets
305  - update %%post, %pre and %%preun
306- update BuildRequires version for glib2 and tp_glib
307- defined major_ver, minor_ver and rel
308- fix BuildRequires for gnome-keyring
309
310* Sat Mar 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
311- new upstream release
312- add BuildRequires: libtelepathy-devel, libgnomecanvas-devel, libbonoboui-devel, python-devel
313
314* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.1-4
315- rebuilt with python-2.6.4
316
317* Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> - 2.28.1-3
318- unuse %%{?_smp_mflags} option to make
319
320* Wed Nov 11 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.1-2
321- add {gnome-keyring,libcanberra,libnotify,unique}-devel to BuildRequires
322
323* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
324- new upstream release
325
326* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
327- new upstream release
328
329* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
330- initial build for Vine Linux
331
332* Tue Sep  9 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.92-1
333- Update to 2.23.92
334
335* Thu Sep  4 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.91-1
336- Update to 2.23.91
337
338* Sun Aug 24 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-2
339- Now that Empathy will be the default IM client in F10+, hardcode a dependency
340  on telepathy-haze to keep the same protocol functionality across upgrades,
341  for a much improved "out of the box" experience.
342- Reference: bug 458935.
343
344* Fri Aug 22 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-1
345- Update to new upstream release (2.23.90)
346
347* Fri Aug 15 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-3
348- Apply patch from Colin Walters to automagically update profile namings for
349  the switch to using Empathy's provided profiles.
350- Drop the upgrade script (no longer needed since it's automatically done).
351  - upgrade-haze-profiles.sh
352
353* Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-2
354- Use upstream's AIM, ICQ, MSN-Haze, and Yahoo profiles instead of recommending
355  the telepathy-haze-mission-control package. (The Haze-provided ones have grown
356  horribly stale...). This makes for better automagic functionality (if Haze is
357  installed, Empathy/MC will autodetect it) and tracks upstream more closely.
358  + upgrade-haze-profiles.sh
359
360* Mon Aug 04 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-1
361- Update to new upstream release (2.23.6)
362- Use the in-tarball libtool scripts instead of the system copy to workaround
363  'make install' errors.
364
365* Wed Jul 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.4-1
366- Update to 0.23.4.
367- Update source url.
368
369* Mon Jun  2 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.3-1
370- Update to 0.23.3.
371- Remove reference to stream-engine in connections managers readme.
372
373* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.2-1
374- Update to 0.23.2.
375- Add man pages.
376- Use enchant-devel, instead of aspell-devel.
377
378* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-3
379- Rebuild for new e-d-s.
380
381* Sun May  4 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-2
382- Drop multiple copies of COPYING file.
383- Drop BR on gnome-vfs2-devel.
384- Require telepathy-stream-engine for VOIP support.
385- Add BR on iso-codes-devel, so spell-checking is enabled.
386
387* Wed Apr 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.23.1-1
388- Update to new upstream release (0.23.1)
389- Drop libtelepathy dependencies; upstream switched fully to telepathy-glib.
390
391* Fri Apr 11 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.1-1
392- Update to new upstream release (0.22.1)
393
394* Mon Mar 10 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.0-1
395- Update to new upstream release (0.22.0)
396
397* Sun Mar 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.91-1
398- Update to new upstream release (0.21.91)
399
400* Fri Feb 22 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.90-1
401- Update to new upstream release (0.21.90)
402
403* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.21.4-2
404- Autorebuild for GCC 4.3
405
406* Mon Dec 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.4-1
407- Update to new upstream release (0.21.4)
408
409* Tue Nov 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.2-1
410- Update to new upstream release (0.21.2)
411- Drop backported drag-and-drop patch (fixed upstream):
412    - svn380-fix-contact-DnD.patch
413- Update README.ConnectionManagers: Include Haze package note, remove Galago
414  note (a feed-only connection manager isn't useful for instant messaging),
415  and fix some wording.
416
417* Fri Oct 19 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-5
418- Backport upstream patch to fixes crashes when using drag-and-drop of a
419  contact from the buddy list to the current conversation window to initiate a
420  conversation:
421    + svn380-fix-contact-DnD.patch
422- Resolves: GNOME bug 483168 (crash in Empathy Instant Messenger: I had
423  dragged a contact ...)
424
425* Tue Oct 16 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-4
426- Depend on Salut and Gabble to enable XMPP by default. Otherwise, Empathy
427  is essentially useless due to the need to install an external connection
428  manager. Also, add a README.ConnectionManagers to the installed
429  documentation which lists other possibilities.
430- Resolves: bug 308871 (Make empathy dependent at least on telepathy-gabble)
431  and bug 334221 (Default empathy install is useless).
432
433* Wed Oct 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-3
434- Enable VoIP support for those brave enough to test/break/debug it (F9+
435  only). Though it is functional, it is still deemed rather unstable by
436  upstream. Use it at your own risk. :)
437
438* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-2
439- Disable VoIP support at this time, since it is deemed unstable by upstream
440  for now. (Thanks to Brian Pepple for the notice.)
441 
442* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-1
443- Update to new upstream release (0.14).
444
445* Sun Sep 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.13-1
446- Update to new upstream release (0.13), which adds a panel applet (Megaphone)
447  and python bindings.
448- Split shared libraries into a libs subpackage for easier handling
449  in multi-lib environments.
450
451* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-2
452- Add ldconfig invocations to %%post and %%postun scriptlets.
453
454* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-1
455- Update to new upstream release (0.12).
456- Build against new mission-control stack.
457- Update License tag (GPLv2+).
458- Alphabetize BuildRequires list (aesthetic-only change).
459
460* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.8-2
461- Rebuild for selinux ppc32 issue.
462
463* Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-1
464- Update to new upstream release (0.11)
465
466* Fri Jun 22 2007 David Nielsen <david@lovesunix.net> - 0.8-1
467- bump to 0.8
468- Now with aspell support (deat to teh speeling mistaks)
469
470* Sat Jun  9 2007 David Nielsen <david@lovesunix.net> - 0.7-1
471- bump to 0.7
472
473* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-3
474- Add telepathy-filesystem to Requires
475- Move .desktop from autostart to applications
476- Nasty hackery to make empathy launch from the menu
477
478* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-2
479- Add gettext to BuildRequires
480
481* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.6-1
482- Bump to 0.6
483
484* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.5-2
485- Let Empathy own the directory and not just the files in it
486
487* Wed May 30 2007 David Nielsen <david@lovesunix.net> - 0.5-1
488- Initial package
Note: See TracBrowser for help on using the repository browser.