source: projects/specs/trunk/e/empathy/empathy-vl.spec @ 7047

Revision 7047, 17.1 KB checked in by Takemikaduchi, 12 years ago (diff)

giggle, gnome-shell-extensions, telepathy-logger: new upstream release
empathy, gnome-shell: rebuild with telepathy-logger-0.6.0

RevLine 
[6890]1%define major_ver 3.6
[6951]2%define minor_ver 1
[7047]3%define rel       2
[1186]4
[521]5%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
6
7## Minimum required versions of GLib, GTK+, libtelepathy, and Mission-Control,
8## respectively.
[6890]9%global gtk3_min_version        3.6.0
10%global glib2_min_version       2.34.0
[6011]11%global tp_mc_min_version       5.12.0
12%global tp_glib_min_version     0.18.0
[5038]13%global tp_logger_min_version   0.2.10
[521]14%global aspell_version          0.50
[5038]15%global libcanberra_version     0.25
[4850]16%global libnotify_version       0.7.4
[6011]17%global folks_version           0.6.8
[6890]18%global libsecret_version       0.5
[521]19
20Summary:        GNOME Instant Messaging Client
21Summary(ja):    GNOME インスタントメッセージクラアイント
22
23Name:           empathy
[1186]24Version:        %{major_ver}.%{minor_ver}
25Release:        %{rel}%{?_dist_release}
[521]26
27Group:          Applications/Communications
28License:        GPLv2+
29URL:            http://live.gnome.org/Empathy
30
[4616]31Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/%{majorver}/%{name}-%{version}.tar.xz
[521]32Source1:        %{name}-README.ConnectionManagers
33
34BuildRoot: %{_tmppath}/%{name}-%{version}-root
35
36#BuildRequires: enchant-devel >= %{enchant_version}
37BuildRequires:  aspell-devel >= %{aspell_version}
38BuildRequires:  iso-codes
39BuildRequires:  desktop-file-utils
40BuildRequires:  evolution-data-server-devel
41BuildRequires:  gettext
42BuildRequires:  glib2-devel >= %{glib2_min_version}
43BuildRequires:  gnome-panel
[4616]44BuildRequires:  gtk3-devel >= %{gtk3_min_version}
[521]45BuildRequires:  intltool
46BuildRequires:  libxml2-devel
47BuildRequires:  perl(XML::Parser)
48BuildRequires:  telepathy-glib-devel >= %{tp_glib_min_version}
[5038]49BuildRequires:  telepathy-logger-devel >= %{tp_logger_min_version}
[521]50BuildRequires:  telepathy-mission-control-devel >= %{tp_mc_min_version}
[6011]51BuildRequires:  farstream-devel
52BuildRequires:  telepathy-farstream-devel
[4616]53BuildRequires:  libcanberra-gtk3-devel >= %{libcanberra_version}
54BuildRequires:  unique3-devel
[521]55BuildRequires:  libnotify-devel >= %{libnotify_version}
[5038]56BuildRequires:  folks-devel >= %{folks_version}
[6011]57BuildRequires:  gcr-devel >= %{gnome_keyring_version}
[6890]58BuildRequires:  libsecret-devel >= %{libsecret_version}
[2610]59BuildRequires:  openssl-devel
60BuildRequires:  NetworkManager-glib-devel
[4616]61BuildRequires:  WebKit3-gtk-devel
[2610]62BuildRequires:  geoclue-devel
63BuildRequires:  enchant-devel
[4616]64BuildRequires:  libICE-devel
65BuildRequires:  cheese-devel
[5038]66BuildRequires:  pulseaudio-libs-devel
67BuildRequires:  gnome-online-accounts-devel
68BuildRequires:  libgudev1-devel
[4616]69BuildRequires:  libchamplain-gtk-devel
[6011]70BuildRequires:  gsettings-desktop-schemas-devel
[6890]71BuildRequires:  yelp-tools
[521]72
73Requires:       telepathy-filesystem
74Requires:       telepathy-gabble
75Requires:       telepathy-salut
[6011]76Requires:       telepathy-idle
[521]77## Also hardcode Haze dependency since Empathy is the default IM client in F10+
78## and I'd hate for people to simply disregard it for lack of the "out of the
79## box" protocol support that Pidgin has. (RHBZ: 458935)
[623]80BuildRequires:  telepathy-haze
[521]81# Require this for VOIP support
[2610]82Requires:       telepathy-mission-control >= %{tp_mc_min_version}
[521]83
84
85## We're using Empathy's upstreamed profiles for Haze-provided stuff now.
86Obsoletes:      telepathy-haze-mission-control < 0.2.0-3
87Provides:       telepathy-haze-mission-control = 0.2.0-3
[1186]88## upstream 2.29.1 removed shared libraries: #599086
89Obsoletes: empathy-libs < 2.29.1, empathy-devel < 2.29.1
90## upstream 2.29.1 removed python bindings' #599039
[1191]91Obsoletes: empathy-python < 2.29.1
[521]92
[4616]93Vendor: Project Vine
94Distribution: Vine Linux
95
[521]96%description
97Empathy provides a powerful multiple protocol instant messaging
98client using the Telepathy framework.
99
100
[1250]101%package -n     nautilus-sendto-empathy
102License:        GPLv2+
103Summary:        Nautilus-sendto plugin for empathy
104Summary(ja):    empathy 用 nautilus-sendto プラグイン
105Group:          User Interface/Desktop
106
107Requires:       %{name} = %{version}-%{release}
108Requires:       nautilus-sendto
109BuildRequires:  nautilus-sendto-devel
110
111%description -n nautilus-sendto-empathy
112This package contains nautilus-sendto plugin for the Empathy IM application.
113
114
[521]115%prep
116%setup -q
117
118
119%build
120## GCC complains about some unused functions, so we forcibly show those as
121## simple warnings instead of build-halting errors.
[4812]122%configure --disable-static
123
[521]124## RPATHs are yucky.
125sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
126sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
127
128##make %{?_smp_mflags}
129## don't use _smp_mflags at empathy-2.18.1
130make
131
132install -m 0644 %{SOURCE1} ./README.ConnectionManagers
133
134
135%install
136rm -rf $RPM_BUILD_ROOT
137make install DESTDIR=$RPM_BUILD_ROOT
138find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
139
140%find_lang %{name}
141
142desktop-file-install --vendor "" --delete-original      \
143        --dir %{buildroot}%{_datadir}/applications      \
144        %{buildroot}%{_datadir}/applications/%{name}.desktop
145
146
147%clean
148rm -rf %{buildroot}
149
150
151%post
152touch --no-create %{_datadir}/icons/hicolor ||:
153%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
154
155%postun
156touch --no-create %{_datadir}/icons/hicolor || :
157if [ -x %{_bindir}/gtk-update-icon-cache ]; then
158        %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
[2041]159        glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
[521]160fi
161
[2041]162%posttrans
163gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null ||:
164glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
[521]165
[2041]166
[521]167%files -f %{name}.lang
168%defattr(-,root,root,-)
169%doc AUTHORS COPYING README README.ConnectionManagers NEWS
170%{_bindir}/empathy
[1186]171%{_bindir}/empathy-accounts
172%{_bindir}/empathy-debugger
[5038]173%{_libdir}/mission-control-plugins.0/mcp-account-manager-goa.so
[2041]174%{_libexecdir}/empathy-auth-client
[6011]175%{_libexecdir}/empathy-call
[4616]176%{_libexecdir}/empathy-chat
[6890]177%{_libdir}/%{name}/libempathy*.so
178%{_libdir}/mission-control-plugins.0/mcp-account-manager-goa.so
[2041]179%{_datadir}/GConf/gsettings/*
[521]180%{_datadir}/applications/*.desktop
[6890]181%{_datadir}/adium/message-styles
182%{_datadir}/dbus-1/services/*
183%{_datadir}/%{name}
184%{_datadir}/glib-2.0/schemas/*.xml
[6011]185%{_datadir}/help/*/%{name}
[521]186%{_datadir}/icons/hicolor/*/apps/%{name}*
[2041]187%{_datadir}/telepathy/clients/*.client
[1186]188%{_mandir}/man1/empathy*.1*
[521]189
[1250]190%files -n nautilus-sendto-empathy
191%defattr(-,root,root,-)
192%{_libdir}/nautilus-sendto/plugins/libnstempathy.so
[521]193
[1250]194
[521]195%changelog
[7047]196* Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
197- rebuild with telepathy-logger-0.6.0
198
[6951]199* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
200- new upstream release
201
[6924]202* Fri Oct 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0.3-1
203- new upstream release
204
[6890]205* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
206- new upstream release
207- add BuildRequires: libsecret-devel, yelp-tools
208- remove BuildRequires: libgnome-keyring-devel
209
[6537]210* Sun Jul 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2.3-1
211- new upstream release
212
[6273]213* Tue Jun 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2.1-1
214- new upstream release
215
[6201]216* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
217- new upstream release
218
[6078]219* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
[6011]220- new upstream release
221- change BuildRequires: gcr-devel instead of gnome-keyring-devel
222- change BuildRequires: farstream-devel instead of farsight2-devel
223- change BuildRequires: telepathy-farstream-devel instead of telepathy-farsight-devel
224- add BuildRequires: itstool
225- remove Requires: telepathy-stream-engine
226- add Requires: telepathy-idle
227
[5168]228* Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
229- new upstream release
230
[5094]231* Thu Nov 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1.1-1
232- new upstream release
233
[5038]234* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
235- new upstream release
236- add BuildRequires: libgudev1-devel, gnome-online-accounts-devel
237
[5007]238* Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0.1-1
239- new upstream release
240
[4850]241* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
242- new upstream release
243
[4812]244* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
245- new upstream release
246
[4704]247* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
248- new upstream release
249
[4677]250* Sun Aug 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5.1-1
251- new upstream release
252
[4650]253* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
254- new upstream release
255- add BuildRequires: pulseaudio-libs-devel
256
[4616]257* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
258- new upstream release
259- change BuildRequires: gtk3-devel instead of gtk2-devel
260- change BuildRequires: unique3-devel instead of unique-devel
261- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
262- change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
263- add BuildRequires: gsettings-desktop-schemas, libICE-devel, cheese-devel, libchamplain-gtk-devel
264
[2610]265* Sun Jan 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
266- new upstream release
267- add BuildRequires: openssl-devel, NetworkManager-glib-devel, WebKit-devel
268                     geoclue-devel, enchant-devel
269- add Requires: telepathy-mission-control
270- add configure option: --with-ca-file=/usr/share/ssl/certs/ca-bundle.crt
271
[2041]272* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0.1-1
273- new upstream release
274- add BuildRequires: folks-devel, telepathy-logger-devel, gnome-keyring-devel
275- fix %files
276- fix %post, %postun
277- drop %pre, %preun
278
[1250]279* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0.1-3
280- rebuild with evolution-data-server-2.30.2
281- add nautilus-sendto-empathy package
282  - add configure option (--enable-nautilus-sendto=yes)
283  - add BuildRequires: nautilus-sendto-devel
284
[1191]285* Sat Jun 12 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-2
286- add Obsoletes: empathy-python < 2.29.1
287
[1186]288* Tue Apr 13 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-1
289- new upstream release
290- add new files: %%{_bindir}/empathy-{accounts,debugger}
291- drop -libs, -devel, -python sub packages: upstream removed
292  - Obsoletes: empathy-{libs,devel} < 2.29.1
293  - drop BuildRequires: python-devel
294- drop %%{_bindir}/empathy-logs in %%files: upstream don not install
295- drop applet files in %%files: upstream removed the panel applets
296  - update %%post, %pre and %%preun
297- update BuildRequires version for glib2 and tp_glib
298- defined major_ver, minor_ver and rel
299- fix BuildRequires for gnome-keyring
300
[623]301* Sat Mar 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
302- new upstream release
303- add BuildRequires: libtelepathy-devel, libgnomecanvas-devel, libbonoboui-devel, python-devel
304
[521]305* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.1-4
306- rebuilt with python-2.6.4
307
308* Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> - 2.28.1-3
309- unuse %%{?_smp_mflags} option to make
310
311* Wed Nov 11 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.1-2
312- add {gnome-keyring,libcanberra,libnotify,unique}-devel to BuildRequires
313
314* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
315- new upstream release
316
317* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
318- new upstream release
319
320* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
321- initial build for Vine Linux
322
323* Tue Sep  9 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.92-1
324- Update to 2.23.92
325
326* Thu Sep  4 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.91-1
327- Update to 2.23.91
328
329* Sun Aug 24 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-2
330- Now that Empathy will be the default IM client in F10+, hardcode a dependency
331  on telepathy-haze to keep the same protocol functionality across upgrades,
332  for a much improved "out of the box" experience.
333- Reference: bug 458935.
334
335* Fri Aug 22 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-1
336- Update to new upstream release (2.23.90)
337
338* Fri Aug 15 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-3
339- Apply patch from Colin Walters to automagically update profile namings for
340  the switch to using Empathy's provided profiles.
341- Drop the upgrade script (no longer needed since it's automatically done).
342  - upgrade-haze-profiles.sh
343
344* Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-2
345- Use upstream's AIM, ICQ, MSN-Haze, and Yahoo profiles instead of recommending
346  the telepathy-haze-mission-control package. (The Haze-provided ones have grown
347  horribly stale...). This makes for better automagic functionality (if Haze is
348  installed, Empathy/MC will autodetect it) and tracks upstream more closely.
349  + upgrade-haze-profiles.sh
350
351* Mon Aug 04 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-1
352- Update to new upstream release (2.23.6)
353- Use the in-tarball libtool scripts instead of the system copy to workaround
354  'make install' errors.
355
356* Wed Jul 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.4-1
357- Update to 0.23.4.
358- Update source url.
359
360* Mon Jun  2 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.3-1
361- Update to 0.23.3.
362- Remove reference to stream-engine in connections managers readme.
363
364* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.2-1
365- Update to 0.23.2.
366- Add man pages.
367- Use enchant-devel, instead of aspell-devel.
368
369* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-3
370- Rebuild for new e-d-s.
371
372* Sun May  4 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-2
373- Drop multiple copies of COPYING file.
374- Drop BR on gnome-vfs2-devel.
375- Require telepathy-stream-engine for VOIP support.
376- Add BR on iso-codes-devel, so spell-checking is enabled.
377
378* Wed Apr 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.23.1-1
379- Update to new upstream release (0.23.1)
380- Drop libtelepathy dependencies; upstream switched fully to telepathy-glib.
381
382* Fri Apr 11 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.1-1
383- Update to new upstream release (0.22.1)
384
385* Mon Mar 10 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.0-1
386- Update to new upstream release (0.22.0)
387
388* Sun Mar 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.91-1
389- Update to new upstream release (0.21.91)
390
391* Fri Feb 22 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.90-1
392- Update to new upstream release (0.21.90)
393
394* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.21.4-2
395- Autorebuild for GCC 4.3
396
397* Mon Dec 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.4-1
398- Update to new upstream release (0.21.4)
399
400* Tue Nov 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.2-1
401- Update to new upstream release (0.21.2)
402- Drop backported drag-and-drop patch (fixed upstream):
403    - svn380-fix-contact-DnD.patch
404- Update README.ConnectionManagers: Include Haze package note, remove Galago
405  note (a feed-only connection manager isn't useful for instant messaging),
406  and fix some wording.
407
408* Fri Oct 19 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-5
409- Backport upstream patch to fixes crashes when using drag-and-drop of a
410  contact from the buddy list to the current conversation window to initiate a
411  conversation:
412    + svn380-fix-contact-DnD.patch
413- Resolves: GNOME bug 483168 (crash in Empathy Instant Messenger: I had
414  dragged a contact ...)
415
416* Tue Oct 16 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-4
417- Depend on Salut and Gabble to enable XMPP by default. Otherwise, Empathy
418  is essentially useless due to the need to install an external connection
419  manager. Also, add a README.ConnectionManagers to the installed
420  documentation which lists other possibilities.
421- Resolves: bug 308871 (Make empathy dependent at least on telepathy-gabble)
422  and bug 334221 (Default empathy install is useless).
423
424* Wed Oct 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-3
425- Enable VoIP support for those brave enough to test/break/debug it (F9+
426  only). Though it is functional, it is still deemed rather unstable by
427  upstream. Use it at your own risk. :)
428
429* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-2
430- Disable VoIP support at this time, since it is deemed unstable by upstream
431  for now. (Thanks to Brian Pepple for the notice.)
432 
433* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-1
434- Update to new upstream release (0.14).
435
436* Sun Sep 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.13-1
437- Update to new upstream release (0.13), which adds a panel applet (Megaphone)
438  and python bindings.
439- Split shared libraries into a libs subpackage for easier handling
440  in multi-lib environments.
441
442* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-2
443- Add ldconfig invocations to %%post and %%postun scriptlets.
444
445* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-1
446- Update to new upstream release (0.12).
447- Build against new mission-control stack.
448- Update License tag (GPLv2+).
449- Alphabetize BuildRequires list (aesthetic-only change).
450
451* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.8-2
452- Rebuild for selinux ppc32 issue.
453
454* Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-1
455- Update to new upstream release (0.11)
456
457* Fri Jun 22 2007 David Nielsen <david@lovesunix.net> - 0.8-1
458- bump to 0.8
459- Now with aspell support (deat to teh speeling mistaks)
460
461* Sat Jun  9 2007 David Nielsen <david@lovesunix.net> - 0.7-1
462- bump to 0.7
463
464* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-3
465- Add telepathy-filesystem to Requires
466- Move .desktop from autostart to applications
467- Nasty hackery to make empathy launch from the menu
468
469* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-2
470- Add gettext to BuildRequires
471
472* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.6-1
473- Bump to 0.6
474
475* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.5-2
476- Let Empathy own the directory and not just the files in it
477
478* Tue May 30 2007 David Nielsen <david@lovesunix.net> - 0.5-1
479- Initial package
Note: See TracBrowser for help on using the repository browser.