source: projects/specs/trunk/e/emerillon/emerillon-vl.spec @ 4874

Revision 4874, 3.4 KB checked in by yasumichi, 13 years ago (diff)

import emerillon-vl.spec

Line 
1# Basic Information
2Name:           emerillon
3Version:        0.1.90
4Release:        1%{?_dist_release}
5License:        GPLv2
6Group:          Applications/Other
7Source0:        http://download.gnome.org/sources/emerillon/0.1/emerillon-0.1.90.tar.xz
8BuildRoot:      %{_tmppath}/%{name}-%{version}-root
9
10Vendor:         Project Vine
11Distribution:   Vine Linux
12Packager:       yasumichi
13
14Summary:        Emerillon is a map viewer.
15Summary(ja):    Emerillon は、マップビューアーです。
16
17# Dependency
18BuildRequires:  glib2-devel
19BuildRequires:  gtk3-devel
20BuildRequires:  libchamplain-gtk-devel
21BuildRequires:  geoclue-devel
22BuildRequires:  libpeas-devel
23BuildRequires:  gtk-doc
24BuildRequires:  gnome-doc-utils
25BuildRequires:  rest-devel
26BuildRequires:  gobject-introspection-devel
27BuildRequires:  vala-devel
28
29%description
30Emerillon is a map viewer. Aiming at simple user interface, Emerillon is a
31powerful, extensible application. It is pronounced Ey-may-ree-yon.
32
33It features OpenStreetMap based maps: the street map, the cycling map and
34the transportation map. Use it to:
35
36- Browse maps,
37- Search the map for places,
38- Placemark places for later quick access.
39
40%description -l ja
41Emerillon は、マップビューアーです。簡単なユーザーインターフェースを目指して
42おり、強力で拡張可能なアプリケーションです。エーメイリーヨンと発音します。
43
44Emerillon は、OpenStreetMap に基づいた地図を特色としています: 街路図、自転車
45道図および交通機関の地図があります。以下のように利用してください:
46
47- 地図を閲覧する
48- 地図で場所を検索する
49- 後で素早くアクセスするために場所にマーカーを付与する
50
51%package devel
52Summary:        Development files for %{name}
53Summary(ja):    %{name} の開発用ファイル
54Group:          Development/Libraries
55Requires:       %{name} = %{version}-%{release}
56Requires:       gtk3-devel
57Requires:       libchamplain-gtk-devel
58Requires:       pkgconfig
59
60%description devel
61Development files for %{name}
62
63%description -l ja devel
64%{name} の開発用ファイル
65
66%prep
67%setup -q
68
69%build
70%configure
71%{__make} %{?_smp_mflags}
72
73%install
74%{__rm} -rf ${RPM_BUILD_ROOT}
75export GSETTINGS_DISABLE_SCHEMAS_COMPILE=1
76%{__make} install DESTDIR=${RPM_BUILD_ROOT}
77unset GSETTINGS_DISABLE_SCHEMAS_COMPILE
78
79%find_lang %{name}
80
81%{__rm} ${RPM_BUILD_ROOT}%{_libdir}/emerillon/plugins/*.la
82
83
84%clean
85%{__rm} -rf ${RPM_BUILD_ROOT}
86
87%post -p /sbin/ldconfig
88
89%postun
90/sbin/ldconfig
91if [ $1 -eq 0 ] ; then
92        glib-compile-schemas --allow-any-name %{_datadir}/glib-2.0/schemas || :
93fi
94
95%posttrans
96glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
97
98
99%files -f %{name}.lang
100%defattr(-,root,root)
101%doc AUTHORS COPYING ChangeLog NEWS README TODO
102%{_bindir}/emerillon
103%{_libdir}/emerillon
104%{_libdir}/girepository-1.0/Emerillon-0.2.typelib
105%{_datadir}/GConf/gsettings/emerillon.convert
106%{_datadir}/applications/emerillon.desktop
107%{_datadir}/emerillon/emerillon-ui.xml
108%{_datadir}/glib-2.0/schemas/org.gnome.emerillon.gschema.xml
109%{_datadir}/gnome/help/emerillon
110%{_datadir}/vala/vapi/emerillon.deps
111%{_datadir}/vala/vapi/emerillon.vapi
112
113%files devel
114%defattr(-,root,root)
115%{_includedir}/emerillon-0.1/emerillon/emerillon.h
116%{_includedir}/emerillon-0.1/emerillon/sidebar.h
117%{_includedir}/emerillon-0.1/emerillon/window.h
118%{_libdir}/pkgconfig/emerillon.pc
119%{_datadir}/gir-1.0/Emerillon-0.2.gir
120%{_datadir}/gtk-doc/html/emerillon
121
122%changelog
123* Sat Oct 08 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.1.90-1
124- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.