source: projects/specs/trunk/e/emacs24/emacs24-vl.spec @ 2443

Revision 2443, 25.2 KB checked in by munepi, 14 years ago (diff)

updated emacs24, yatex, FD spec files

Line 
1%define emacsversion 24.0.50
2%define bzrdate 20110101
3%define emacsrelease 2%{?bzrdate:.%bzrdate}%{?_dist_release}
4
5%define _noVersionedDependencies 1
6%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
7
8%define infodir %{_infodir}/emacs-%{emacsversion}
9
10%define menutreeelversion 0.97
11
12Summary:      GNU Emacs editor
13Summary(ja):  GNU Emacs エディタ
14Name:         emacs24
15Provides:     emacs-snapshot
16Version:      %{emacsversion}
17Release:      %{emacsrelease}
18Source0:      ftp://ftp.gnu.org/pub/gnu/emacs/emacs-%{version}%{?bzrdate:.bzr%bzrdate}.tar.xz
19#Source0:      ftp://alpha.gnu.org/gnu/emacs/pretest/emacs-%{emacsversion}.tar.gz
20Source1:      emacs-snapshot.sh
21
22Source10:     site-start.el.emacs24
23
24## local settings for local system
25Source20:     emacs24-local.el
26
27# desktop file
28Source50:     emacs24.desktop.in
29
30## Enable Japanese Menu
31## http://www11.atwiki.jp/s-irie/pages/13.html
32Source100:    menu-tree-el-%{menutreeelversion}.tar.gz
33Source110:    menu-tree-init.el.emacs24
34
35## default settings for Vine Linux
36Source150:    vine-default-base.el
37Source151:    vine-default-faces.el
38
39## Vine Patch(es)
40#Patch10:      emacs-21.1-ppc-nocombreloc.patch
41Patch11:      emacs-23.0.60-locallisppath.patch
42Patch20:      emacs-23.1.90-fixed-resolution.patch
43
44# Fixed in upstream CVS. (from Fedora)
45#Patch30:      emacs-23.1-scroll.patch
46#Patch31:      emacs-23.1-indian.patch
47#Patch32:      emacs-23.1-memmove.patch
48# Accepted by upstream.
49#Patch33: emacs-23.2-m17ncheck.patch
50# Fix rhbz#595546
51# Upstream: http://emacsbugs.donarmstrong.com/cgi/bugreport.cgi?bug=6158
52#Patch34: emacs-23.2-hideshow-comment.patch
53# Reported upstream http://debbugs.gnu.org/cgi/bugreport.cgi?bug=4129
54#Patch35: emacs-23.2-spacing.patch
55
56# security patches (from Debian)
57
58# security patches (from Ubuntu)
59# # http://www.vupen.com/english/advisories/2010/0734
60# # https://code.launchpad.net/~ubuntu-branches/ubuntu/karmic/emacs23/karmic-security
61# Patch501:      emacs23-CVE-2010-0825-fix-movemail-race.diff
62
63# patches from Mandrake
64Patch1001:    emacs-21.1-bzip2.patch.bz2
65
66License:      GPLv3+
67Group:        Applications/Editors/Emacs
68
69Distribution: Vine
70Vendor:       Project Vine
71Packager:     munepi, daisuke
72
73BuildRoot:    %{_tmppath}/%{name}-%{version}-root
74# Requires:     tamago >= 4.0.6
75Obsoletes:    mule-base, mule-canna, mule-wnn6, mule, emacs-beta
76Obsoletes:    emacs21 <= 21.2-0vl7
77Obsoletes:    emacs22 <= 22.0.50
78Obsoletes:    emacs23 <= 23.0.91-2.20090325vl5
79Provides:     emacs24 = %{version}
80Provides:     emacsen = 0.1
81#% prereq_ge    emacsen-common
82Requires(post):    emacsen-common
83Requires(postun):    emacsen-common
84
85BuildRequires: autoconf
86BuildRequires: xz
87BuildRequires: atk-devel
88BuildRequires: dbus-devel GConf2-devel
89BuildRequires: alsa-lib-devel
90BuildRequires: gnutls-devel
91BuildRequires: gtk2-devel, cairo-devel
92BuildRequires: freetype-devel, fontconfig-devel
93BuildRequires: libpng-devel, libjpeg-devel, libtiff-devel, libungif-devel
94BuildRequires: librsvg2-devel, libotf-devel
95BuildRequires: m17n-lib-devel
96BuildRequires: libX11-devel, libXau-devel, libXdmcp-devel, libXrender-devel
97BuildRequires: libXt-devel, libXpm-devel, ncurses-devel
98BuildRequires: xorg-x11-proto-devel, zlib-devel
99BuildRequires: texinfo
100BuildRequires: nkf
101
102%description
103GNU Emacs is the extensible, customizable, self-documenting real-time
104display editor.
105
106%description -l ja
107GNU Emacs は拡張性が高く、さまざまなカスタマイズが可能な高機能エディタです。
108
109
110%prep
111
112%setup -q -n emacs-%{version}
113
114%ifarch ppc
115#%patch10 -p1
116%endif
117
118%patch11 -p1
119%patch20 -p1
120
121#%patch30 -p1 -b .scroll
122#%patch31 -p1
123#%patch32 -p1 -b .memmove
124#%patch33 -p1 -b .m17ncheck
125#%patch34 -p0 -b .hideshow-comment
126#%patch35 -p1 -b .spacing
127
128#%patch501 -p1 -b .movemail
129
130%patch1001 -p1
131
132autoconf
133
134
135%build
136
137export CFLAGS="-DMAIL_USE_LOCKF $RPM_OPT_FLAGS"
138#to find installinfo
139export PATH="$PATH:/sbin:/usr/sbin"
140
141%configure --with-pop --with-sound \
142    --libexecdir=%{_libdir} --infodir=%{infodir} \
143    --disable-rename \
144    --with-toolkit=gtk \
145    --with-freetype --with-xft \
146    --enable-font-backend \
147    --without-gpm \
148        --with-libotf \
149%if %{?_dist_release} == "vl5"
150      --without-m17n-flt \
151%endif
152%if %{?_dist_release} == "vl6"
153      --with-m17n-flt \
154      --with-dbus --with-gconf \
155%endif
156    ;
157
158%__make bootstrap
159%__make %{?_smp_mflags}
160
161
162#%define recompile src/emacs -batch --no-init-file --no-site-file -f batch-byte-compile
163
164# recompile patched .el files
165#%{recompile} lisp/mail/mh-utils.el lisp/progmodes/make-mode.el
166
167# bytecompile python-mode, ssl, php-mode and rpm-spec-mode
168#cp %SOURCE12  %SOURCE14 %SOURCE16 %SOURCE17 .
169##%%{recompile} rpm-spec-mode.el php-mode.el ssl.el po-mode.el
170
171
172%install
173[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
174
175ARCHDIR=${RPM_ARCH}-vine-linux
176
177%makeinstall libexecdir=$RPM_BUILD_ROOT%{_libdir} \
178        infodir=${RPM_BUILD_ROOT}%{infodir}
179
180## This is a duplicate of the file in FLAVOR/site-lisp
181%__rm -f $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/subdirs.el || exit 1
182
183# (cd $RPM_BUILD_ROOT%{_mandir}/man1/; %__mv ctags.1 gctags.1)
184# (cd $RPM_BUILD_ROOT%{_bindir}/; %__mv ctags gctags)
185
186%__mkdir_p  $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/etc
187%__mkdir_p  $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp
188# cp %{SOURCE100} $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/menu-tree.el
189# nkf -w %{SOURCE100} > $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/menu-tree-utf8.el
190%__tar zxvf %{SOURCE100}
191%__cp -a menu-tree-el-%{menutreeelversion}/menu-tree.el $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/
192nkf -w --overwrite $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/menu-tree.el
193
194## vine default
195%__cp -a %{SOURCE150} %{SOURCE151} \
196    $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/
197
198# The elisp reference manual
199#bzcat %{SOURCE13} | tar xf -
200#pushd elisp-manual-21-2.8
201#install -m 644 elisp elisp-? elisp-?? $RPM_BUILD_ROOT/%{infodir}
202#popd
203
204# some modifications of installed files
205
206#rm -f $RPM_BUILD_ROOT%{infodir}/dir
207#gzip -9nf $RPM_BUILD_ROOT%{infodir}/*
208
209%__install -m 644 %{SOURCE10} \
210        $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/site-start.el
211%__sed -i -e 's/EMACS_VERSION/%{version}/g' \
212        $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/site-start.el
213
214## create site-start.d directory
215%__install -m 755 -d ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d
216
217# install coding-system init.el
218%__install -m644 %{SOURCE110} \
219    $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/menu-tree-init.el
220%__ln_s -f %{_datadir}/emacs-%{version}/site-lisp/menu-tree-init.el \
221    ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d/60menu-tree-init.el
222
223## install system-wide configure file
224%__install -m755 -d ${RPM_BUILD_ROOT}/etc/emacs
225%__install -m644 %{SOURCE20} ${RPM_BUILD_ROOT}/etc/emacs/emacs24-local.el
226%__sed -i -e 's/EMACS_VERSION/%{version}/g' \
227    ${RPM_BUILD_ROOT}/etc/emacs/emacs24-local.el
228
229## Python mode, php mode and rpm-spec mode
230
231## make file list
232strip $RPM_BUILD_ROOT%{_bindir}/* || :
233
234# install desktop file
235%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/applications
236%__sed -e "s/@@EMACS_VERSION@@/%{emacsversion}/g" %{SOURCE50} > \
237    $RPM_BUILD_ROOT%{_datadir}/applications/$(basename %{SOURCE50} .in)
238[ -f $RPM_BUILD_ROOT%{_datadir}/applications/emacs.desktop ] && \
239    %__rm -f $RPM_BUILD_ROOT%{_datadir}/applications/emacs.desktop || exit 1
240
241# install icons
242%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/icons
243%__cp -a etc/images/icons/hicolor $RPM_BUILD_ROOT%{_datadir}/icons/
244
245## remove man files
246%__rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/* || exit 1
247
248## Remove ctags
249#rm -f $RPM_BUILD_ROOT/usr/bin/ctags
250#rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/*ctags*
251#rm -f $RPM_BUILD_ROOT/%{_datadir}/emacs/%{version}/etc/ctags*
252
253DIR="${RPM_BUILD_ROOT}%{_datadir}/emacs \
254     ${RPM_BUILD_ROOT}%{_datadir}/emacs-%{version}"
255BIN=${RPM_BUILD_ROOT}%{_bindir}
256LIB=${RPM_BUILD_ROOT}%{_libdir}
257EL="*.el"
258
259## prepare file list for emacs
260echo "/usr/bin/ctags
261/usr/bin/ebrowse
262/usr/bin/etags
263/usr/bin/rcs-checkin
264/usr/bin/emacs
265/usr/bin/emacsclient
266/usr/bin/grep-changelog" |
267    %__sed -e "s#[^\n]*#mv ${RPM_BUILD_ROOT}\0 ${RPM_BUILD_ROOT}\0.emacs-%{version}#"|
268    awk '{system($_)}' 
269
270find $DIR $BIN $LIB -type d |
271  %__sed -e "s#^${RPM_BUILD_ROOT}#%dir #" > rpm-files
272
273find $DIR $BIN $LIB -type f |
274  %__sed -e "
275    s#^${RPM_BUILD_ROOT}\(.*movemail\)#%attr(2755, root, mail) \1#
276    s#^${RPM_BUILD_ROOT}##
277  " >> rpm-files
278
279
280%clean
281[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
282
283
284%define info_files ccmode cl dired-x ediff emacs forms gnus info message mh-e reftex sc vip viper widget
285
286
287%pre
288
289if [ -L %{_datadir}/emacs-%{version}/site-lisp ] ; then
290    %__rm -f %{_datadir}/emacs-%{version}/site-lisp
291fi
292
293if [ -d %{_datadir}/emacs/%{version}/site-lisp ] ; then
294    find %{_datadir}/emacs/%{version}/site-lisp/* -maxdepth 0 | grep -v subdirs.el | \
295        xargs %__rm -rf
296fi
297
298
299%post
300
301if [ "$1" = 1 ]; then
302
303%_addflavorslist emacs-%{version}
304
305export PRIORITY=50
306
307%_installemacs emacs-%{version}
308
309unset PRIORITY
310fi
311
312if [ "$1" = 2 ]; then
313
314#  export PRIORITY=50
315 
316#  %_installemacs emacs-%{version}
317 
318#  unset PRIORITY
319   
320  echo emacs-%{version} >  /var/lib/emacsen-common/doinstaflavor-emacs
321   
322fi
323
324
325%postun
326
327if [ $1 = 1 ]; then
328# run upgrade install time
329
330# old version uninstall
331
332%_removeflavorslist emacs-%{version}
333
334%_removeemacs emacs-%{version}
335
336#new version install
337if [ -f /var/lib/emacsen-common/doinstaflavor-emacs ] ; then
338
339NEWFLAVOR=$(cat /var/lib/emacsen-common/doinstaflavor-emacs)
340
341%_addflavorslist $NEWFLAVOR
342
343export PRIORITY=50
344
345%_installemacs $NEWFLAVOR
346
347unset PRIORITY
348
349%__rm -rf /var/lib/emacsen-common/doinstaflavor-emacs
350
351fi
352
353fi
354
355
356%preun
357if [ $1 = 0 ]; then
358
359%_removeflavorslist emacs-%{version}
360
361%_removeemacs emacs-%{version}
362
363fi
364
365
366%triggerpostun -- emacs23 < %{version}-%{release}
367
368%_addflavorslist emacs-%{version}
369
370export PRIORITY=50
371
372%_installemacs emacs-%{version}
373
374unset PRIORITY
375
376
377%files -f rpm-files
378%defattr(-,root,root)
379%doc INSTALL INSTALL.BZR README BUGS ChangeLog COPYING
380%dir %{_sysconfdir}/emacs-%{version}
381%dir %{_sysconfdir}/emacs-%{version}/site-start.d
382%{_sysconfdir}/emacs-%{version}/site-start.d/*.el
383%config(noreplace) %{_sysconfdir}/emacs/emacs24-local.el
384%{_infodir}/*
385# %{_mandir}/*/*
386%{_datadir}/applications/emacs24.desktop
387%{_datadir}/icons/hicolor/*
388# %{_datadir}/emacs-%{version}/site-lisp
389%dir %{_localstatedir}/games/emacs
390%{_localstatedir}/games/emacs/*
391
392
393%changelog
394* Thu Dec 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-2.20110101
395- emacs24 24.0.50 (20110101) snapshot
396
397* Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-1.20101203
398- emacs24 24.0.50 (20101203) snapshot
399- applied new vine-default system
400  - updated site-start.el
401  - updated vine-default-{base,faces}.el
402  - dropped showvdefaultemacs
403    - merged to emacsen-common package as show-vine-default.sh
404  - renamed local wide configration file to emacs24-local.el
405- updated menu-tree.el to version 0.97
406
407* Sun Nov 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-1.20101120
408- emacs24 24.0.50 (20101120) snapshot
409- added Provides: emacs-snapshot
410
411* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-4
412- updated vine-default-base.el
413  - changed the variable next-line-add-newlines to nil (default)
414
415* Thu Sep 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-3
416- updated menu-tree.el to version 0.96
417
418* Sat Jul 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-2
419- applied some patches from Fedora
420  - Fixed handling of dual spacing fonts rhbz#599437
421  - Add patch to fix rhbz#595546 hideshow library matches wrong parenthesis
422    under certain circumstances
423  - Added a patch fixing m17n and libotf version checking (m17ncheck)
424- updated menu-tree.el to version 0.95
425- merged emacs23-vl.spec of Vine Linux 5.1
426#* Thu Apr 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-9
427#- applied security fix emacs23-CVE-2010-0825-fix-movemail-race.diff from Ubuntu
428#
429#* Fri Feb 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-8
430#- added Requires(post): emacsen-common, Requires(postun): emacsen-common
431#
432#* Fri Feb 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-7
433#- dropped BuildRequires: m17n-lib-devel
434#- added --without-m17n-flt in %%configure
435
436* Mon May 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-1
437- new upstream release
438- updated menu-tree.el to version 0.94
439- updated menu-tree-init.el.emacs23
440  - used prefer-coding-system
441
442* Wed Apr 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.96-1
443- updated to 23.1.96 (23.2 pretest)
444
445* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.95-2
446- removed /usr/share/emacs/site-lisp/subdirs.el
447
448* Sat Apr 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.95-1
449- updated to 23.1.95 (23.2 pretest)
450- added BuildRequires:
451  - atk-devel
452  - dbus-devel
453  - GConf2-devel
454  - alsa-lib-devel
455- added some configure options:
456  --with-libotf --with-m17n-flt --with-dbus --with-gconf
457
458* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.94-1
459- updated to 23.1.94
460
461* Thu Mar 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.93-1
462- updated to 23.1.93 alpha
463
464* Sat Feb 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.92-2
465- added Requires(post): emacsen-common, Requires(postun): emacsen-common
466
467* Tue Feb 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.92-1
468- update to 23.1.92 alpha
469
470* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-6
471- added BuildRequires:
472  - librsvg2-devel
473  - m17n-lib-devel
474  - libotf-devel
475
476* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-5
477- changed License to GPLv3+
478- renamed emacs23.desktop to emacs23.desktop.in
479- updated vine-default-base.el (See [vine-users:079919])
480- fixed in upstream CVS (from Fedora)
481  - fix #543046 - Using scroll bar in emacs highlights/selects text
482  - fix #542657 - emacs does not display indic text
483  - Fixed rhbz#545398 - ETags messes up filenames
484
485* Tue Sep 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-4
486- rebuilt to add signature
487
488* Fri Aug 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-3
489- added BuildRequires: nkf
490- updated menu-tree-init.el.emacs23
491  - fixed menu-tree encoding <BTS:VineLinux:766>
492- set Exec=emacs-@@EMACS_VERSION@@ in emacs23.desktop
493
494* Wed Aug 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-2
495- replaced BR: libungif-devel with BR: giflib-devel
496
497* Sat Aug 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-1
498- new upstream release
499
500* Sat Jul 25 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.0.96-2.20090714
501- updated vine-default-faces.el to sync with emacs22
502
503* Tue Jul 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.96-1.20090714
504- update to 23.0.96 (20090714) snapshot
505- update vine-default-faces.el
506  - use bash to call gconftool-2
507
508* Sat Jun 27 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-4.20090527
509- update vine-default-faces.el
510  - added \'font in default-frame-alist
511    (if \'font is already in default-frame-alist, overwrited it)
512
513* Wed Jun 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-3.20090527
514- update vine-default-faces.el:
515  - use set-frame-font
516    bacause set-default-font function is obsolete since Emacs 23.1
517    (See M-x describe-function RET set-default-font)
518
519* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-2.20090527
520- update vine-default-faces.el:
521  - set desktop-gnome-interface-monospace-font-name
522    from /desktop/gnome/interface/monospace_font_name
523  - automatically set set-default-font
524    with desktop-gnome-interface-monospace-font-name
525
526* Wed May 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.94-1.20090527
527- update to emacs-23.0.94 (20090527) snapshot
528- add --without-gpm to configure
529
530* Thu May 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-7.20090422
531- defined show-vine-default function in site-start.el
532  - added showvdefaultemacs script
533
534* Wed May 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-6.20090422
535- set PRIORITY=40
536
537* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-5.20090422
538- changed menu-tree-init.el from hard copy to symbolic link
539  on /etc/emacs-23.0.92/site-start.d
540- added %%{_mandir}/*/* in %%files section
541
542* Sat May 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-4.20090422
543- updated menu-tree.el to v0.93
544
545* Fri May 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-3.20090422
546- returned alternatives priority to 30
547  (emacs: 30, emacs22: 30)
548
549* Sun Apr 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-2.20090422
550- installed system-wide configure file in /etc/emacs
551- updated vine-default-base.el
552- changed alternatives priority from 30 to 50
553  (emacs: 50, emacs22: 30)
554
555* Wed Apr 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.92-1.20090422
556- update to emacs 23.0.92 (20090422) snapshot
557- add %%triggerpostun to fix alternatives
558
559* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.91-3.20090325
560- renamed from emacs23 to emacs (emacs-22.x would be renamed to emacs22)
561- updated default settings for Vine Linux
562  - dropped vine-default-mouse.el, vine-default-misc.el
563
564* Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.91-2.20090325
565- enable default settings for Vine Linux
566  - added site-start.el.emacs23
567  - updated site-start.el
568  - added vine-default-base.el, vine-default-faces.el, vine-default-mouse.el,
569    vine-default-misc.el
570
571* Wed Mar 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.91-1.20090325
572- emacs23 23.0.91 snapshot
573
574* Tue Sep 09 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 23.0.60-2.20080908
575- drop patch10
576- s/emacsrelese/emacsrelease/
577
578* Mon Sep 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.60-1.20080908
579- emacs23 23.0.60 snapshot
580
581* Sun Sep 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.3-1
582- new upstream release
583
584* Mon Aug 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 22.2-3
585- import security fixes from Debian
586  CVE-2008-2142: fix insecure setting of fast-lock-cache-directories
587  CVE-2008-1694: fix insecure temporary file creation in vcdiff script
588                 leading to possible symlink attacks
589
590* Tue Jun 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.2-2
591- update menu-tree.el
592- add 60menu-tree-init.el to sed coding-system and load menu-tree
593- build with xorg-x11-7.3
594  - update BuildRequires
595
596* Sun Mar 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.2-1
597- new upstream release
598
599* Wed Nov 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 22.1-0vl2
600- add Patch10000 to fix local variable processing security bypass
601  vulnerability.
602  - http://www.frsirt.com/english/advisories/2007/3715
603  - http://bugs.debian.org/449008
604
605* Mon Jun 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 22.1-0vl1
606- new upstream release
607- rename to emacs from emacs22 (emacs-21.x would be renameed to emacs21)
608- drop emcws support
609
610* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 22.0.50-0.20060403vl3
611- rebuilt with new toolchain
612
613* Sat May 06 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 22.0.50-0.20060403vl2
614- changed Group:
615
616* Mon Apr 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20060403vl1
617- update to CVS-20060403
618- update emacs22.desktop
619
620* Wed Sep 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050927vl2
621- fix site-start.el
622
623* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050927vl1
624- update to CVS-20050927
625
626* Thu Sep  8 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050907vl1
627- initial build for Vine Linux based on emacs package.
628  - emacs-22.0.50 on CVS-20050907
629
630* Sat Sep  3 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.4-0vl3
631- create site-start.d directory on %install
632
633* Thu Feb 17 2005 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.4-0vl2
634- included leim-21.4
635- update emcws-21.3-20031213.gz
636
637* Wed Feb 16 2005 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.4-0vl1
638- update
639
640* Sat Jul 24 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl7
641- rebuild with Xaw3d, add BuildRequires: Xaw3d-devel
642
643* Fri Jul 23 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl6
644- add Patch20 to fix display resolutions. (set to 96dpi)
645  (do not compute dynamically from display's size)
646
647* Tue Mar 16 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.3-0vl5
648- rebuilt with new toolchain environment
649
650* Thu Jul 17 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.3-0vl4
651- use site-start.el(reading /etc/emacs-21.3/site-start.d/*.el)
652
653* Wed May  7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 21.3-0vl3
654- add BuildPrereq: libpng >= 1.2.5
655
656* Tue Apr 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl2
657- fixed %%pre script
658
659* Tue Mar 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl1
660- new upstream release
661- remove patch14 whick included in upstream
662
663* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl11
664- add patch14 to fix frame title text encoding.
665  - http://tsukuba.m17n.org/mule-ja-archive/2002-10/msg00004.html
666
667* Tue Dec 10 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.2-0vl10
668- autoconf-2.13, not autoconf in %%setup section
669- BuildPreReq: autoconf213
670
671* Mon Dec  9 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl9
672- modifiy rpm scripts.
673
674* Mon Dec  9 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl8
675- rename to emacs
676- obsoletes emacs21 <= 21.2-0vl7, provides emacs21 = %%{version}
677
678* Sun Dec  1 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl7
679- enable menubar fontset patch (Patch103)
680
681* Sat Nov 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl6
682- add requires/buildprereq tags.
683
684* Sat Nov 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl5
685- add emcws-20021014
686
687* Sun Jul 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl4
688- removed *-mode
689
690* Sat Jul 20 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl3
691- python-mode was made pending
692- some additional *.el files was moved from "emacs/site-lisp" to
693  "emacs-(version)/site-lisp"
694
695* Sat Jul 13 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl2
696- added some sources and patches from rawhide 21.2-11 and mandrake 21.2-7mdk
697
698* Sat May 11 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.2-0vl1
699- update.
700- Package Name emacs-beta -> emacs21
701- Add Patch100,101,102, Source100(default = Disable)
702- (from http://phe.phyas.aichi-edu.ac.jp/~cyamauch/pl2.html#emacs21)
703- --infodir=%{_infodir}/emacs-21.2(VineSeed-Plus:00723)
704
705* Thu Dec 27 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl7
706- site-lisp moved under /usr/share/emacs-21.1/ (Patch11 and %%pre section)
707
708* Thu Dec 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl5
709- move /tmp -> /var/lib/emacsen-common (IP(package)C file)
710
711* Fri Nov 02 2001 Tomoya TAKA <tomoya@olive.plala.or.jp> 21.1-0vl4
712- replace patch10 with patch11, posted to gnu.emacs.bug
713  Message-Id: <jebsiza3db.fsf@sykes.suse.de>
714  (reported by ABE Yuji <cbo46560@pop12.odn.ne.jp>)
715
716* Fri Oct 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.1-0vl3
717- fixed build to fail in alpha( only apply patch0 to ppc)
718
719* Tue Oct 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl2
720- added Patch10 (thanks Kitame-san)
721
722* Mon Oct 22 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.1-0vl1
723- update to 21.1
724
725* Sun Sep 9 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.104-0vl14
726- support  shared installing otheremacsen.
727
728* Mon Jul 23 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.104-0vl3
729- update 21.0.104
730
731* Thu Jul 19 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.103-0vl2
732- support emacsen-common
733
734* Wed May 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
735- 21.0.103-0vl1
736- updated to 21.0.103
737- revamped and cleaned up spec file :-)
738- Requires: tamago >= 4.0.6 (...is it reasonable? Mmm...)
739
740* Mon Jan 22 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.95-0vl2
741- fixed .spec bugs( _libdir)
742
743* Fri Jan 12 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.95-0vl1
744- updated to 21.0.95
745
746* Wed Dec 20 2000 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.93-0vl3
747- fixed emacs-beta.spec
748
749* Sat Dec 16 2000 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.93-0vl2
750- 21.0.93 test packaging.
751
752* Fri Jun 30 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
753- added linespace-patch
754
755* Mon Jun 19 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
756- updated to emacs 20.7
757
758* Thu Apr 20 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
759- updated to emacs 20.6
760
761* Mon Feb 28 2000 kenji KITAYAMA <kenji@gandalf.doshisha.ac.jp>
762- [emacs-20.5a-2]
763- Modified reference of Emacs Info
764
765* Sun Jan 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
766- [emacs-20.5a-2]
767- added ppc patch
768
769* Fri Jan  7 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
770- [emacs-20.5a-1]
771- change version from 20.5 to 20.5a
772- added Mule-4.1 patch
773
774* Fri Jan  7 2000 Yasuyuki Furukawa <yasu@on.cs.keio.ac.jp>
775- [emacs-20.5-1]
776- add desktop-link files for desktop menu.
777
778* Thu Dec 24 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
779- [emacs-20.4-16]
780- replaced Y2K savvy timezone.{el,elc} with one from brand-new apel-10.0
781
782* Tue Dec 21 1999 Jun Nishii <jun@vinelinux.org>
783- added documents
784- strip bins
785
786* Wed Dec  1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
787- [emacs-20.4-14]
788- Change Group to Applications/Editors/Emacs
789
790* Sat Nov  6 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
791- [emacs-20.4-13]
792- included Y2K savvy timezone.{el,elc},
793  modified by Mr. Youichi Teranishi <teranishi@gohome.org>
794
795* Tue Oct 12 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
796- [emacs-20.4-12]
797- Modified info-dir.
798- Removed -c option from %setup.
799
800* Sun Sep 20 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
801- fixed XIM support patch
802* Sun Sep 19 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
803- fixed postinst bug and fontset patch
804* Sun Jul 18 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
805- first build
Note: See TracBrowser for help on using the repository browser.