source: projects/specs/trunk/e/emacs24/emacs24-vl.spec @ 6199

Revision 6199, 27.4 KB checked in by munepi, 12 years ago (diff)

updated emacs24-vl.spec

Line 
1%define emacsversion 24.0.97
2#% define bzrdate 20110817
3%define emacsrelease 1%{?bzrdate:.%bzrdate}%{?_dist_release}
4%define vine_default_major_version %(echo %_dist_release|%__sed s/vl//)
5
6%define _noVersionedDependencies 1
7%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
8
9%define infodir %{_infodir}/emacs-%{emacsversion}
10
11%define menutreeelversion 0.97
12
13Summary:      GNU Emacs editor
14Summary(ja):  GNU Emacs エディタ
15Name:         emacs24
16Provides:     emacs-snapshot
17Version:      %{emacsversion}
18Release:      %{emacsrelease}
19#Source0:      ftp://ftp.gnu.org/pub/gnu/emacs/emacs-%{version}%{?bzrdate:.bzr%bzrdate}.tar.xz
20Source0:      ftp://alpha.gnu.org/gnu/emacs/pretest/emacs-%{emacsversion}.tar.gz
21Source1:      emacs-snapshot.sh
22
23Source10:     site-start.el.emacs24
24
25## local settings for local system
26Source20:     emacs24-local.el
27
28# desktop file
29Source50:     emacs24.desktop.in
30
31## Enable Japanese Menu
32## http://www11.atwiki.jp/s-irie/pages/13.html
33Source100:    menu-tree-el-%{menutreeelversion}.tar.gz
34Source110:    menu-tree-init.el.emacs24
35
36## default settings for Vine Linux
37Source150:    vine-default-base.el
38Source151:    vine-default-faces.el
39
40## Vine Patch(es)
41#Patch10:      emacs-21.1-ppc-nocombreloc.patch
42Patch11:      emacs-23.0.60-locallisppath.patch
43Patch20:      emacs-23.1.90-fixed-resolution.patch
44Patch30:      emacs-24.0.90-libs-termcap.patch
45
46# Fixed in upstream CVS. (from Fedora)
47
48# security patches (from Debian)
49
50# security patches (from Ubuntu)
51
52# patches from Mandrake
53Patch1001:    emacs-21.1-bzip2.patch.bz2
54
55License:      GPLv3+
56Group:        Applications/Editors/Emacs
57
58Distribution: Vine Linux
59Vendor:       Project Vine
60Packager:     munepi, daisuke
61
62BuildRoot:    %{_tmppath}/%{name}-%{version}-root
63# Requires:     tamago >= 4.0.6
64Obsoletes:    mule-base, mule-canna, mule-wnn6, mule, emacs-beta
65Obsoletes:    emacs21 <= 21.2-0vl7
66Obsoletes:    emacs22 <= 22.0.50
67Obsoletes:    emacs23 <= 23.0.91-2.20090325vl5
68Provides:     emacs24 = %{version}
69Provides:     emacsen = 0.1
70#% prereq_ge    emacsen-common
71Requires(post):    emacsen-common
72Requires(postun):    emacsen-common
73
74BuildRequires: autoconf
75BuildRequires: xz
76BuildRequires: atk-devel
77BuildRequires: dbus-devel GConf2-devel
78BuildRequires: alsa-lib-devel
79BuildRequires: gnutls-devel
80%if %{?_dist_release} >= "vl7"
81BuildRequires: gtk3-devel
82%else
83BuildRequires: gtk2-devel
84%endif
85BuildRequires: cairo-devel
86BuildRequires: freetype2-devel, fontconfig-devel
87BuildRequires: libpng-devel, libjpeg-devel, libtiff-devel, libungif-devel
88BuildRequires: librsvg2-devel, libotf-devel
89BuildRequires: ImageMagick-devel
90BuildRequires: libxml2-devel > 2.6.17
91BuildRequires: m17n-lib-devel
92BuildRequires: libX11-devel, libXau-devel, libXdmcp-devel, libXrender-devel
93BuildRequires: libSM-devel, libXt-devel, libXpm-devel, ncurses-devel
94BuildRequires: xorg-x11-proto-devel, zlib-devel
95BuildRequires: texinfo
96BuildRequires: nkf
97
98%description
99GNU Emacs is the extensible, customizable, self-documenting real-time
100display editor.
101
102%description -l ja
103GNU Emacs は拡張性が高く、さまざまなカスタマイズが可能な高機能エディタです。
104
105
106%prep
107
108%setup -q -n emacs-%{version}
109
110%ifarch ppc
111#%patch10 -p1
112%endif
113
114%patch11 -p1
115%patch20 -p1
116%patch30 -p1
117
118%patch1001 -p1
119
120#autoconf
121autoreconf -i -I m4
122
123%build
124
125export CFLAGS="-DMAIL_USE_LOCKF $RPM_OPT_FLAGS"
126#to find installinfo
127export PATH="$PATH:/sbin:/usr/sbin"
128
129%configure --with-pop --with-sound \
130    --libexecdir=%{_libdir} --infodir=%{infodir} \
131    --disable-rename \
132%if %{?_dist_release} >= "vl7"
133    --with-x-toolkit=gtk3 \
134%else
135    --with-x-toolkit=gtk \
136%endif
137    --with-freetype --with-xft \
138    --enable-font-backend \
139    --without-gpm \
140    --with-libotf \
141    --with-m17n-flt \
142    --with-dbus --with-gconf \
143    ;
144
145%__make bootstrap
146%__make %{?_smp_mflags}
147
148
149#%define recompile src/emacs -batch --no-init-file --no-site-file -f batch-byte-compile
150
151# recompile patched .el files
152#%{recompile} lisp/mail/mh-utils.el lisp/progmodes/make-mode.el
153
154# bytecompile python-mode, ssl, php-mode and rpm-spec-mode
155#cp %SOURCE12  %SOURCE14 %SOURCE16 %SOURCE17 .
156##%%{recompile} rpm-spec-mode.el php-mode.el ssl.el po-mode.el
157
158
159%install
160[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
161
162ARCHDIR=${RPM_ARCH}-vine-linux
163
164%makeinstall libexecdir=$RPM_BUILD_ROOT%{_libdir} \
165        infodir=${RPM_BUILD_ROOT}%{infodir}
166
167## This is a duplicate of the file in FLAVOR/site-lisp
168%__rm -f $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/subdirs.el || exit 1
169
170# (cd $RPM_BUILD_ROOT%{_mandir}/man1/; %__mv ctags.1 gctags.1)
171# (cd $RPM_BUILD_ROOT%{_bindir}/; %__mv ctags gctags)
172
173%__mkdir_p  $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/etc
174%__mkdir_p  $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp
175# cp %{SOURCE100} $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/menu-tree.el
176# nkf -w %{SOURCE100} > $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/menu-tree-utf8.el
177%__tar zxvf %{SOURCE100}
178%__cp -a menu-tree-el-%{menutreeelversion}/menu-tree.el $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/
179nkf -w --overwrite $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/menu-tree.el
180
181## vine default
182%__cp -a %{SOURCE150} %{SOURCE151} \
183    $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/
184
185# The elisp reference manual
186#bzcat %{SOURCE13} | tar xf -
187#pushd elisp-manual-21-2.8
188#install -m 644 elisp elisp-? elisp-?? $RPM_BUILD_ROOT/%{infodir}
189#popd
190
191# some modifications of installed files
192
193#rm -f $RPM_BUILD_ROOT%{infodir}/dir
194#gzip -9nf $RPM_BUILD_ROOT%{infodir}/*
195
196%__install -m 644 %{SOURCE10} \
197        $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/site-start.el
198%__sed -i -e 's/EMACS_VERSION/%{version}/g' \
199          -e 's/VINE_DEFAULT_MAJOR_VERSION/%{vine_default_major_version}/g' \
200        $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/site-start.el
201
202## create site-start.d directory
203%__install -m 755 -d ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d
204
205# install coding-system init.el
206%__install -m644 %{SOURCE110} \
207    $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/menu-tree-init.el
208%__ln_s -f %{_datadir}/emacs-%{version}/site-lisp/menu-tree-init.el \
209    ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d/60menu-tree-init.el
210
211## install system-wide configure file
212%__install -m755 -d ${RPM_BUILD_ROOT}/etc/emacs
213%__install -m644 %{SOURCE20} ${RPM_BUILD_ROOT}/etc/emacs/emacs24-local.el
214%__sed -i -e 's/EMACS_VERSION/%{version}/g' \
215    ${RPM_BUILD_ROOT}/etc/emacs/emacs24-local.el
216
217## Python mode, php mode and rpm-spec mode
218
219## make file list
220strip $RPM_BUILD_ROOT%{_bindir}/* || :
221
222# install desktop file
223%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/applications
224%__sed -e "s/@@EMACS_VERSION@@/%{emacsversion}/g" %{SOURCE50} > \
225    $RPM_BUILD_ROOT%{_datadir}/applications/$(basename %{SOURCE50} .in)
226[ -f $RPM_BUILD_ROOT%{_datadir}/applications/emacs.desktop ] && \
227    %__rm -f $RPM_BUILD_ROOT%{_datadir}/applications/emacs.desktop || exit 1
228
229# install icons
230%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/icons
231%__cp -a etc/images/icons/hicolor $RPM_BUILD_ROOT%{_datadir}/icons/
232
233## remove man files
234%__rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/* || exit 1
235
236## Remove ctags
237#rm -f $RPM_BUILD_ROOT/usr/bin/ctags
238#rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/*ctags*
239#rm -f $RPM_BUILD_ROOT/%{_datadir}/emacs/%{version}/etc/ctags*
240
241DIR="${RPM_BUILD_ROOT}%{_datadir}/emacs \
242     ${RPM_BUILD_ROOT}%{_datadir}/emacs-%{version}"
243BIN=${RPM_BUILD_ROOT}%{_bindir}
244LIB=${RPM_BUILD_ROOT}%{_libdir}
245EL="*.el"
246
247## prepare file list for emacs
248echo "/usr/bin/ctags
249/usr/bin/ebrowse
250/usr/bin/etags
251/usr/bin/rcs-checkin
252/usr/bin/emacs
253/usr/bin/emacsclient
254/usr/bin/grep-changelog
255/usr/share/icons/hicolor/scalable/apps/emacs.svg
256/usr/share/icons/hicolor/scalable/mimetypes/emacs-document.svg" |
257    %__sed -e "s#[^\n]*#mv ${RPM_BUILD_ROOT}\0 ${RPM_BUILD_ROOT}\0.emacs-%{version}#"|
258    awk '{system($_)}' 
259
260find $DIR $BIN $LIB -type d |
261  %__sed -e "s#^${RPM_BUILD_ROOT}#%dir #" > rpm-files
262
263find $DIR $BIN $LIB -type f |
264  %__sed -e "
265    s#^${RPM_BUILD_ROOT}\(.*movemail\)#%attr(2755, root, mail) \1#
266    s#^${RPM_BUILD_ROOT}##
267  " >> rpm-files
268
269
270%clean
271[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
272
273
274%define info_files ccmode cl dired-x ediff emacs forms gnus info message mh-e reftex sc vip viper widget
275
276
277%pre
278
279if [ -L %{_datadir}/emacs-%{version}/site-lisp ] ; then
280    %__rm -f %{_datadir}/emacs-%{version}/site-lisp
281fi
282
283if [ -d %{_datadir}/emacs/%{version}/site-lisp ] ; then
284    find %{_datadir}/emacs/%{version}/site-lisp/* -maxdepth 0 | grep -v subdirs.el | \
285        xargs %__rm -rf
286fi
287
288
289%post
290
291if [ "$1" = 1 ]; then
292
293%_addflavorslist emacs-%{version}
294
295export PRIORITY=50
296
297%_installemacs emacs-%{version}
298
299unset PRIORITY
300fi
301
302if [ "$1" = 2 ]; then
303
304#  export PRIORITY=50
305 
306#  %_installemacs emacs-%{version}
307 
308#  unset PRIORITY
309   
310  echo emacs-%{version} >  /var/lib/emacsen-common/doinstaflavor-emacs
311   
312fi
313
314
315%postun
316
317if [ $1 = 1 ]; then
318# run upgrade install time
319
320# old version uninstall
321
322%_removeflavorslist emacs-%{version}
323
324%_removeemacs emacs-%{version}
325
326#new version install
327if [ -f /var/lib/emacsen-common/doinstaflavor-emacs ] ; then
328
329NEWFLAVOR=$(cat /var/lib/emacsen-common/doinstaflavor-emacs)
330
331%_addflavorslist $NEWFLAVOR
332
333export PRIORITY=50
334
335%_installemacs $NEWFLAVOR
336
337unset PRIORITY
338
339%__rm -rf /var/lib/emacsen-common/doinstaflavor-emacs
340
341fi
342
343fi
344
345
346%preun
347if [ $1 = 0 ]; then
348
349%_removeflavorslist emacs-%{version}
350
351%_removeemacs emacs-%{version}
352
353fi
354
355
356%triggerpostun -- emacs23 < %{version}-%{release}
357
358%_addflavorslist emacs-%{version}
359
360export PRIORITY=50
361
362%_installemacs emacs-%{version}
363
364unset PRIORITY
365
366
367%files -f rpm-files
368%defattr(-,root,root)
369%doc INSTALL README BUGS ChangeLog COPYING
370#%doc INSTALL.BZR
371%dir %{_sysconfdir}/emacs-%{version}
372%dir %{_sysconfdir}/emacs-%{version}/site-start.d
373%{_sysconfdir}/emacs-%{version}/site-start.d/*.el
374%config(noreplace) %{_sysconfdir}/emacs/emacs24-local.el
375%{_infodir}/*
376# %{_mandir}/*/*
377%{_datadir}/applications/emacs24.desktop
378%{_datadir}/icons/hicolor/*
379# %{_datadir}/emacs-%{version}/site-lisp
380%dir %{_localstatedir}/games/emacs
381%{_localstatedir}/games/emacs/*
382
383
384%changelog
385* Sat May 19 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.97-1
386- updated to 24.0.97 (24.1 pretest)
387
388* Sun Apr 29 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.96-1
389- updated to 24.0.96 (24.1 pretest)
390
391* Mon Apr  2 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.95-1
392- updated to 24.0.95 (24.1 pretest)
393
394* Sun Mar 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.0.94-2
395- rebuild with ImageMagick-6.7.5.10
396
397* Mon Feb 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.94-1
398- updated to 24.0.94 (24.1 pretest)
399
400* Tue Feb 14 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.93-2
401- use gtk as X toolkit (for vl6)
402
403* Mon Jan 30 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.93-1
404- updated to 24.0.93 (24.1 pretest)
405
406* Thu Dec  1 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.92-1
407- updated to 24.0.92 (24.1 pretest)
408
409* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.91-1
410- updated to 24.0.91 (24.1 pretest)
411
412* Thu Oct  6 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.90-2
413- set --with-x-toolkit=gtk3 (%%configure)
414  - added BuildRequires: gtk3-devel
415
416* Mon Sep 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.90-1
417- updated to 24.0.90 (24.1 pretest)
418- applied emacs-24.0.90-libs-termcap.patch
419
420* Sat Jul 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-10.20110817
421- emacs24 24.0.50 (20110817) snapshot
422- added BuildRequires: ImageMagick-devel, libSM-devel, libxml2-devel > 2.6.17
423
424* Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-9.20110604
425- emacs24 24.0.50 (20110604) snapshot
426
427* Thu Apr 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-8.20110413
428- emacs24 24.0.50 (20110413) snapshot
429
430* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-7.20110318
431- updated site-start.el
432  - defined vine-default-major-version, vine-default-minor-version,
433    vine-default-version
434  - set "ibus-el" to emacs-ime as default
435  - added ", modified for Vine Linux" to the end of emacs-build-system
436  - set "Vine _at_mark_ vinelinux.org" to report-emacs-bug-address
437
438* Sun Apr 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-6.20110318
439- fixed site-start.el
440  - do not use the macro loop (contained in the common lisp)
441
442* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-5.20110318
443- emacs24 24.0.50 (20110318) snapshot
444
445* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-4.20110222
446- emacs24 24.0.50 (20110222) snapshot
447- updated site-start.el
448  - defined the function drop-vine-default-from-load-path (regex)
449
450* Sat Jan 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-3.20110128
451- emacs24 24.0.50 (20110128) snapshot
452
453* Sun Jan 02 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-2.20110101
454- emacs24 24.0.50 (20110101) snapshot
455
456* Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-1.20101203
457- emacs24 24.0.50 (20101203) snapshot
458- applied new vine-default system
459  - updated site-start.el
460  - updated vine-default-{base,faces}.el
461  - dropped showvdefaultemacs
462    - merged to emacsen-common package as show-vine-default.sh
463  - renamed local wide configration file to emacs24-local.el
464- updated menu-tree.el to version 0.97
465- added Provides: emacs-snapshot
466
467* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-4
468- updated vine-default-base.el
469  - changed the variable next-line-add-newlines to nil (default)
470
471* Thu Sep 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-3
472- updated menu-tree.el to version 0.96
473
474* Sat Jul 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-2
475- applied some patches from Fedora
476  - Fixed handling of dual spacing fonts rhbz#599437
477  - Add patch to fix rhbz#595546 hideshow library matches wrong parenthesis
478    under certain circumstances
479  - Added a patch fixing m17n and libotf version checking (m17ncheck)
480- updated menu-tree.el to version 0.95
481- merged emacs23-vl.spec of Vine Linux 5.1
482#* Thu Apr 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-9
483#- applied security fix emacs23-CVE-2010-0825-fix-movemail-race.diff from Ubuntu
484#
485#* Fri Feb 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-8
486#- added Requires(post): emacsen-common, Requires(postun): emacsen-common
487#
488#* Fri Feb 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-7
489#- dropped BuildRequires: m17n-lib-devel
490#- added --without-m17n-flt in %%configure
491
492* Mon May 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-1
493- new upstream release
494- updated menu-tree.el to version 0.94
495- updated menu-tree-init.el.emacs23
496  - used prefer-coding-system
497
498* Wed Apr 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.96-1
499- updated to 23.1.96 (23.2 pretest)
500
501* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.95-2
502- removed /usr/share/emacs/site-lisp/subdirs.el
503
504* Sat Apr 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.95-1
505- updated to 23.1.95 (23.2 pretest)
506- added BuildRequires:
507  - atk-devel
508  - dbus-devel
509  - GConf2-devel
510  - alsa-lib-devel
511- added some configure options:
512  --with-libotf --with-m17n-flt --with-dbus --with-gconf
513
514* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.94-1
515- updated to 23.1.94
516
517* Thu Mar 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.93-1
518- updated to 23.1.93 alpha
519
520* Sat Feb 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.92-2
521- added Requires(post): emacsen-common, Requires(postun): emacsen-common
522
523* Tue Feb 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.92-1
524- update to 23.1.92 alpha
525
526* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-6
527- added BuildRequires:
528  - librsvg2-devel
529  - m17n-lib-devel
530  - libotf-devel
531
532* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-5
533- changed License to GPLv3+
534- renamed emacs23.desktop to emacs23.desktop.in
535- updated vine-default-base.el (See [vine-users:079919])
536- fixed in upstream CVS (from Fedora)
537  - fix #543046 - Using scroll bar in emacs highlights/selects text
538  - fix #542657 - emacs does not display indic text
539  - Fixed rhbz#545398 - ETags messes up filenames
540
541* Tue Sep 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-4
542- rebuilt to add signature
543
544* Fri Aug 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-3
545- added BuildRequires: nkf
546- updated menu-tree-init.el.emacs23
547  - fixed menu-tree encoding <BTS:VineLinux:766>
548- set Exec=emacs-@@EMACS_VERSION@@ in emacs23.desktop
549
550* Wed Aug 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-2
551- replaced BR: libungif-devel with BR: giflib-devel
552
553* Sat Aug 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-1
554- new upstream release
555
556* Sat Jul 25 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.0.96-2.20090714
557- updated vine-default-faces.el to sync with emacs22
558
559* Tue Jul 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.96-1.20090714
560- update to 23.0.96 (20090714) snapshot
561- update vine-default-faces.el
562  - use bash to call gconftool-2
563
564* Sat Jun 27 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-4.20090527
565- update vine-default-faces.el
566  - added \'font in default-frame-alist
567    (if \'font is already in default-frame-alist, overwrited it)
568
569* Wed Jun 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-3.20090527
570- update vine-default-faces.el:
571  - use set-frame-font
572    bacause set-default-font function is obsolete since Emacs 23.1
573    (See M-x describe-function RET set-default-font)
574
575* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-2.20090527
576- update vine-default-faces.el:
577  - set desktop-gnome-interface-monospace-font-name
578    from /desktop/gnome/interface/monospace_font_name
579  - automatically set set-default-font
580    with desktop-gnome-interface-monospace-font-name
581
582* Wed May 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.94-1.20090527
583- update to emacs-23.0.94 (20090527) snapshot
584- add --without-gpm to configure
585
586* Thu May 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-7.20090422
587- defined show-vine-default function in site-start.el
588  - added showvdefaultemacs script
589
590* Wed May 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-6.20090422
591- set PRIORITY=40
592
593* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-5.20090422
594- changed menu-tree-init.el from hard copy to symbolic link
595  on /etc/emacs-23.0.92/site-start.d
596- added %%{_mandir}/*/* in %%files section
597
598* Sat May 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-4.20090422
599- updated menu-tree.el to v0.93
600
601* Fri May 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-3.20090422
602- returned alternatives priority to 30
603  (emacs: 30, emacs22: 30)
604
605* Sun Apr 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-2.20090422
606- installed system-wide configure file in /etc/emacs
607- updated vine-default-base.el
608- changed alternatives priority from 30 to 50
609  (emacs: 50, emacs22: 30)
610
611* Wed Apr 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.92-1.20090422
612- update to emacs 23.0.92 (20090422) snapshot
613- add %%triggerpostun to fix alternatives
614
615* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.91-3.20090325
616- renamed from emacs23 to emacs (emacs-22.x would be renamed to emacs22)
617- updated default settings for Vine Linux
618  - dropped vine-default-mouse.el, vine-default-misc.el
619
620* Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.91-2.20090325
621- enable default settings for Vine Linux
622  - added site-start.el.emacs23
623  - updated site-start.el
624  - added vine-default-base.el, vine-default-faces.el, vine-default-mouse.el,
625    vine-default-misc.el
626
627* Wed Mar 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.91-1.20090325
628- emacs23 23.0.91 snapshot
629
630* Tue Sep 09 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 23.0.60-2.20080908
631- drop patch10
632- s/emacsrelese/emacsrelease/
633
634* Mon Sep 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.60-1.20080908
635- emacs23 23.0.60 snapshot
636
637* Sun Sep 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.3-1
638- new upstream release
639
640* Mon Aug 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 22.2-3
641- import security fixes from Debian
642  CVE-2008-2142: fix insecure setting of fast-lock-cache-directories
643  CVE-2008-1694: fix insecure temporary file creation in vcdiff script
644                 leading to possible symlink attacks
645
646* Tue Jun 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.2-2
647- update menu-tree.el
648- add 60menu-tree-init.el to sed coding-system and load menu-tree
649- build with xorg-x11-7.3
650  - update BuildRequires
651
652* Sun Mar 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.2-1
653- new upstream release
654
655* Wed Nov 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 22.1-0vl2
656- add Patch10000 to fix local variable processing security bypass
657  vulnerability.
658  - http://www.frsirt.com/english/advisories/2007/3715
659  - http://bugs.debian.org/449008
660
661* Mon Jun 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 22.1-0vl1
662- new upstream release
663- rename to emacs from emacs22 (emacs-21.x would be renameed to emacs21)
664- drop emcws support
665
666* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 22.0.50-0.20060403vl3
667- rebuilt with new toolchain
668
669* Sat May 06 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 22.0.50-0.20060403vl2
670- changed Group:
671
672* Mon Apr 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20060403vl1
673- update to CVS-20060403
674- update emacs22.desktop
675
676* Wed Sep 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050927vl2
677- fix site-start.el
678
679* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050927vl1
680- update to CVS-20050927
681
682* Thu Sep  8 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050907vl1
683- initial build for Vine Linux based on emacs package.
684  - emacs-22.0.50 on CVS-20050907
685
686* Sat Sep  3 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.4-0vl3
687- create site-start.d directory on %install
688
689* Thu Feb 17 2005 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.4-0vl2
690- included leim-21.4
691- update emcws-21.3-20031213.gz
692
693* Wed Feb 16 2005 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.4-0vl1
694- update
695
696* Sat Jul 24 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl7
697- rebuild with Xaw3d, add BuildRequires: Xaw3d-devel
698
699* Fri Jul 23 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl6
700- add Patch20 to fix display resolutions. (set to 96dpi)
701  (do not compute dynamically from display's size)
702
703* Tue Mar 16 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.3-0vl5
704- rebuilt with new toolchain environment
705
706* Thu Jul 17 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.3-0vl4
707- use site-start.el(reading /etc/emacs-21.3/site-start.d/*.el)
708
709* Wed May  7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 21.3-0vl3
710- add BuildPrereq: libpng >= 1.2.5
711
712* Tue Apr 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl2
713- fixed %%pre script
714
715* Tue Mar 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl1
716- new upstream release
717- remove patch14 whick included in upstream
718
719* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl11
720- add patch14 to fix frame title text encoding.
721  - http://tsukuba.m17n.org/mule-ja-archive/2002-10/msg00004.html
722
723* Tue Dec 10 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.2-0vl10
724- autoconf-2.13, not autoconf in %%setup section
725- BuildPreReq: autoconf213
726
727* Mon Dec  9 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl9
728- modifiy rpm scripts.
729
730* Mon Dec  9 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl8
731- rename to emacs
732- obsoletes emacs21 <= 21.2-0vl7, provides emacs21 = %%{version}
733
734* Sun Dec  1 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl7
735- enable menubar fontset patch (Patch103)
736
737* Sat Nov 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl6
738- add requires/buildprereq tags.
739
740* Sat Nov 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl5
741- add emcws-20021014
742
743* Sun Jul 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl4
744- removed *-mode
745
746* Sat Jul 20 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl3
747- python-mode was made pending
748- some additional *.el files was moved from "emacs/site-lisp" to
749  "emacs-(version)/site-lisp"
750
751* Sat Jul 13 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl2
752- added some sources and patches from rawhide 21.2-11 and mandrake 21.2-7mdk
753
754* Sat May 11 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.2-0vl1
755- update.
756- Package Name emacs-beta -> emacs21
757- Add Patch100,101,102, Source100(default = Disable)
758- (from http://phe.phyas.aichi-edu.ac.jp/~cyamauch/pl2.html#emacs21)
759- --infodir=%{_infodir}/emacs-21.2(VineSeed-Plus:00723)
760
761* Thu Dec 27 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl7
762- site-lisp moved under /usr/share/emacs-21.1/ (Patch11 and %%pre section)
763
764* Thu Dec 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl5
765- move /tmp -> /var/lib/emacsen-common (IP(package)C file)
766
767* Fri Nov 02 2001 Tomoya TAKA <tomoya@olive.plala.or.jp> 21.1-0vl4
768- replace patch10 with patch11, posted to gnu.emacs.bug
769  Message-Id: <jebsiza3db.fsf@sykes.suse.de>
770  (reported by ABE Yuji <cbo46560@pop12.odn.ne.jp>)
771
772* Fri Oct 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.1-0vl3
773- fixed build to fail in alpha( only apply patch0 to ppc)
774
775* Tue Oct 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl2
776- added Patch10 (thanks Kitame-san)
777
778* Mon Oct 22 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.1-0vl1
779- update to 21.1
780
781* Sun Sep 9 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.104-0vl14
782- support  shared installing otheremacsen.
783
784* Mon Jul 23 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.104-0vl3
785- update 21.0.104
786
787* Thu Jul 19 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.103-0vl2
788- support emacsen-common
789
790* Wed May 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
791- 21.0.103-0vl1
792- updated to 21.0.103
793- revamped and cleaned up spec file :-)
794- Requires: tamago >= 4.0.6 (...is it reasonable? Mmm...)
795
796* Mon Jan 22 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.95-0vl2
797- fixed .spec bugs( _libdir)
798
799* Fri Jan 12 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.95-0vl1
800- updated to 21.0.95
801
802* Wed Dec 20 2000 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.93-0vl3
803- fixed emacs-beta.spec
804
805* Sat Dec 16 2000 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.93-0vl2
806- 21.0.93 test packaging.
807
808* Fri Jun 30 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
809- added linespace-patch
810
811* Mon Jun 19 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
812- updated to emacs 20.7
813
814* Thu Apr 20 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
815- updated to emacs 20.6
816
817* Mon Feb 28 2000 kenji KITAYAMA <kenji@gandalf.doshisha.ac.jp>
818- [emacs-20.5a-2]
819- Modified reference of Emacs Info
820
821* Sun Jan 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
822- [emacs-20.5a-2]
823- added ppc patch
824
825* Fri Jan  7 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
826- [emacs-20.5a-1]
827- change version from 20.5 to 20.5a
828- added Mule-4.1 patch
829
830* Fri Jan  7 2000 Yasuyuki Furukawa <yasu@on.cs.keio.ac.jp>
831- [emacs-20.5-1]
832- add desktop-link files for desktop menu.
833
834* Thu Dec 24 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
835- [emacs-20.4-16]
836- replaced Y2K savvy timezone.{el,elc} with one from brand-new apel-10.0
837
838* Tue Dec 21 1999 Jun Nishii <jun@vinelinux.org>
839- added documents
840- strip bins
841
842* Wed Dec  1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
843- [emacs-20.4-14]
844- Change Group to Applications/Editors/Emacs
845
846* Sat Nov  6 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
847- [emacs-20.4-13]
848- included Y2K savvy timezone.{el,elc},
849  modified by Mr. Youichi Teranishi <teranishi@gohome.org>
850
851* Tue Oct 12 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
852- [emacs-20.4-12]
853- Modified info-dir.
854- Removed -c option from %setup.
855
856* Sun Sep 20 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
857- fixed XIM support patch
858* Sun Sep 19 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
859- fixed postinst bug and fontset patch
860* Sun Jul 18 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
861- first build
Note: See TracBrowser for help on using the repository browser.