source: projects/specs/trunk/e/emacs24/emacs24-vl.spec @ 2750

Revision 2750, 25.5 KB checked in by munepi, 13 years ago (diff)

updated emacs, emacs24, wl, yatex, auctex, IIIMECF; added wl-beta; supported new vine-default

Line 
1%define emacsversion 24.0.50
2%define bzrdate 20110222
3%define emacsrelease 4%{?bzrdate:.%bzrdate}%{?_dist_release}
4
5%define _noVersionedDependencies 1
6%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
7
8%define infodir %{_infodir}/emacs-%{emacsversion}
9
10%define menutreeelversion 0.97
11
12Summary:      GNU Emacs editor
13Summary(ja):  GNU Emacs エディタ
14Name:         emacs24
15Provides:     emacs-snapshot
16Version:      %{emacsversion}
17Release:      %{emacsrelease}
18Source0:      ftp://ftp.gnu.org/pub/gnu/emacs/emacs-%{version}%{?bzrdate:.bzr%bzrdate}.tar.xz
19#Source0:      ftp://alpha.gnu.org/gnu/emacs/pretest/emacs-%{emacsversion}.tar.gz
20Source1:      emacs-snapshot.sh
21
22Source10:     site-start.el.emacs24
23
24## local settings for local system
25Source20:     emacs24-local.el
26
27# desktop file
28Source50:     emacs24.desktop.in
29
30## Enable Japanese Menu
31## http://www11.atwiki.jp/s-irie/pages/13.html
32Source100:    menu-tree-el-%{menutreeelversion}.tar.gz
33Source110:    menu-tree-init.el.emacs24
34
35## default settings for Vine Linux
36Source150:    vine-default-base.el
37Source151:    vine-default-faces.el
38
39## Vine Patch(es)
40#Patch10:      emacs-21.1-ppc-nocombreloc.patch
41Patch11:      emacs-23.0.60-locallisppath.patch
42Patch20:      emacs-23.1.90-fixed-resolution.patch
43
44# Fixed in upstream CVS. (from Fedora)
45#Patch30:      emacs-23.1-scroll.patch
46#Patch31:      emacs-23.1-indian.patch
47#Patch32:      emacs-23.1-memmove.patch
48# Accepted by upstream.
49#Patch33: emacs-23.2-m17ncheck.patch
50# Fix rhbz#595546
51# Upstream: http://emacsbugs.donarmstrong.com/cgi/bugreport.cgi?bug=6158
52#Patch34: emacs-23.2-hideshow-comment.patch
53# Reported upstream http://debbugs.gnu.org/cgi/bugreport.cgi?bug=4129
54#Patch35: emacs-23.2-spacing.patch
55
56# security patches (from Debian)
57
58# security patches (from Ubuntu)
59# # http://www.vupen.com/english/advisories/2010/0734
60# # https://code.launchpad.net/~ubuntu-branches/ubuntu/karmic/emacs23/karmic-security
61# Patch501:      emacs23-CVE-2010-0825-fix-movemail-race.diff
62
63# patches from Mandrake
64Patch1001:    emacs-21.1-bzip2.patch.bz2
65
66License:      GPLv3+
67Group:        Applications/Editors/Emacs
68
69Distribution: Vine
70Vendor:       Project Vine
71Packager:     munepi, daisuke
72
73BuildRoot:    %{_tmppath}/%{name}-%{version}-root
74# Requires:     tamago >= 4.0.6
75Obsoletes:    mule-base, mule-canna, mule-wnn6, mule, emacs-beta
76Obsoletes:    emacs21 <= 21.2-0vl7
77Obsoletes:    emacs22 <= 22.0.50
78Obsoletes:    emacs23 <= 23.0.91-2.20090325vl5
79Provides:     emacs24 = %{version}
80Provides:     emacsen = 0.1
81#% prereq_ge    emacsen-common
82Requires(post):    emacsen-common
83Requires(postun):    emacsen-common
84
85BuildRequires: autoconf
86BuildRequires: xz
87BuildRequires: atk-devel
88BuildRequires: dbus-devel GConf2-devel
89BuildRequires: alsa-lib-devel
90BuildRequires: gnutls-devel
91BuildRequires: gtk2-devel, cairo-devel
92BuildRequires: freetype-devel, fontconfig-devel
93BuildRequires: libpng-devel, libjpeg-devel, libtiff-devel, libungif-devel
94BuildRequires: librsvg2-devel, libotf-devel
95BuildRequires: m17n-lib-devel
96BuildRequires: libX11-devel, libXau-devel, libXdmcp-devel, libXrender-devel
97BuildRequires: libXt-devel, libXpm-devel, ncurses-devel
98BuildRequires: xorg-x11-proto-devel, zlib-devel
99BuildRequires: texinfo
100BuildRequires: nkf
101
102%description
103GNU Emacs is the extensible, customizable, self-documenting real-time
104display editor.
105
106%description -l ja
107GNU Emacs は拡張性が高く、さまざまなカスタマイズが可能な高機能エディタです。
108
109
110%prep
111
112%setup -q -n emacs-%{version}
113
114%ifarch ppc
115#%patch10 -p1
116%endif
117
118%patch11 -p1
119%patch20 -p1
120
121#%patch30 -p1 -b .scroll
122#%patch31 -p1
123#%patch32 -p1 -b .memmove
124#%patch33 -p1 -b .m17ncheck
125#%patch34 -p0 -b .hideshow-comment
126#%patch35 -p1 -b .spacing
127
128#%patch501 -p1 -b .movemail
129
130%patch1001 -p1
131
132autoconf
133
134
135%build
136
137export CFLAGS="-DMAIL_USE_LOCKF $RPM_OPT_FLAGS"
138#to find installinfo
139export PATH="$PATH:/sbin:/usr/sbin"
140
141%configure --with-pop --with-sound \
142    --libexecdir=%{_libdir} --infodir=%{infodir} \
143    --disable-rename \
144    --with-toolkit=gtk \
145    --with-freetype --with-xft \
146    --enable-font-backend \
147    --without-gpm \
148        --with-libotf \
149%if %{?_dist_release} == "vl5"
150      --without-m17n-flt \
151%endif
152%if %{?_dist_release} == "vl6"
153      --with-m17n-flt \
154      --with-dbus --with-gconf \
155%endif
156    ;
157
158%__make bootstrap
159%__make %{?_smp_mflags}
160
161
162#%define recompile src/emacs -batch --no-init-file --no-site-file -f batch-byte-compile
163
164# recompile patched .el files
165#%{recompile} lisp/mail/mh-utils.el lisp/progmodes/make-mode.el
166
167# bytecompile python-mode, ssl, php-mode and rpm-spec-mode
168#cp %SOURCE12  %SOURCE14 %SOURCE16 %SOURCE17 .
169##%%{recompile} rpm-spec-mode.el php-mode.el ssl.el po-mode.el
170
171
172%install
173[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
174
175ARCHDIR=${RPM_ARCH}-vine-linux
176
177%makeinstall libexecdir=$RPM_BUILD_ROOT%{_libdir} \
178        infodir=${RPM_BUILD_ROOT}%{infodir}
179
180## This is a duplicate of the file in FLAVOR/site-lisp
181%__rm -f $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/subdirs.el || exit 1
182
183# (cd $RPM_BUILD_ROOT%{_mandir}/man1/; %__mv ctags.1 gctags.1)
184# (cd $RPM_BUILD_ROOT%{_bindir}/; %__mv ctags gctags)
185
186%__mkdir_p  $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/etc
187%__mkdir_p  $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp
188# cp %{SOURCE100} $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/menu-tree.el
189# nkf -w %{SOURCE100} > $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/menu-tree-utf8.el
190%__tar zxvf %{SOURCE100}
191%__cp -a menu-tree-el-%{menutreeelversion}/menu-tree.el $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/
192nkf -w --overwrite $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/menu-tree.el
193
194## vine default
195%__cp -a %{SOURCE150} %{SOURCE151} \
196    $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/
197
198# The elisp reference manual
199#bzcat %{SOURCE13} | tar xf -
200#pushd elisp-manual-21-2.8
201#install -m 644 elisp elisp-? elisp-?? $RPM_BUILD_ROOT/%{infodir}
202#popd
203
204# some modifications of installed files
205
206#rm -f $RPM_BUILD_ROOT%{infodir}/dir
207#gzip -9nf $RPM_BUILD_ROOT%{infodir}/*
208
209%__install -m 644 %{SOURCE10} \
210        $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/site-start.el
211%__sed -i -e 's/EMACS_VERSION/%{version}/g' \
212        $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/site-start.el
213
214## create site-start.d directory
215%__install -m 755 -d ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d
216
217# install coding-system init.el
218%__install -m644 %{SOURCE110} \
219    $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/menu-tree-init.el
220%__ln_s -f %{_datadir}/emacs-%{version}/site-lisp/menu-tree-init.el \
221    ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d/60menu-tree-init.el
222
223## install system-wide configure file
224%__install -m755 -d ${RPM_BUILD_ROOT}/etc/emacs
225%__install -m644 %{SOURCE20} ${RPM_BUILD_ROOT}/etc/emacs/emacs24-local.el
226%__sed -i -e 's/EMACS_VERSION/%{version}/g' \
227    ${RPM_BUILD_ROOT}/etc/emacs/emacs24-local.el
228
229## Python mode, php mode and rpm-spec mode
230
231## make file list
232strip $RPM_BUILD_ROOT%{_bindir}/* || :
233
234# install desktop file
235%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/applications
236%__sed -e "s/@@EMACS_VERSION@@/%{emacsversion}/g" %{SOURCE50} > \
237    $RPM_BUILD_ROOT%{_datadir}/applications/$(basename %{SOURCE50} .in)
238[ -f $RPM_BUILD_ROOT%{_datadir}/applications/emacs.desktop ] && \
239    %__rm -f $RPM_BUILD_ROOT%{_datadir}/applications/emacs.desktop || exit 1
240
241# install icons
242%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/icons
243%__cp -a etc/images/icons/hicolor $RPM_BUILD_ROOT%{_datadir}/icons/
244
245## remove man files
246%__rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/* || exit 1
247
248## Remove ctags
249#rm -f $RPM_BUILD_ROOT/usr/bin/ctags
250#rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/*ctags*
251#rm -f $RPM_BUILD_ROOT/%{_datadir}/emacs/%{version}/etc/ctags*
252
253DIR="${RPM_BUILD_ROOT}%{_datadir}/emacs \
254     ${RPM_BUILD_ROOT}%{_datadir}/emacs-%{version}"
255BIN=${RPM_BUILD_ROOT}%{_bindir}
256LIB=${RPM_BUILD_ROOT}%{_libdir}
257EL="*.el"
258
259## prepare file list for emacs
260echo "/usr/bin/ctags
261/usr/bin/ebrowse
262/usr/bin/etags
263/usr/bin/rcs-checkin
264/usr/bin/emacs
265/usr/bin/emacsclient
266/usr/bin/grep-changelog
267/usr/share/icons/hicolor/scalable/apps/emacs.svg
268/usr/share/icons/hicolor/scalable/mimetypes/emacs-document.svg" |
269    %__sed -e "s#[^\n]*#mv ${RPM_BUILD_ROOT}\0 ${RPM_BUILD_ROOT}\0.emacs-%{version}#"|
270    awk '{system($_)}' 
271
272find $DIR $BIN $LIB -type d |
273  %__sed -e "s#^${RPM_BUILD_ROOT}#%dir #" > rpm-files
274
275find $DIR $BIN $LIB -type f |
276  %__sed -e "
277    s#^${RPM_BUILD_ROOT}\(.*movemail\)#%attr(2755, root, mail) \1#
278    s#^${RPM_BUILD_ROOT}##
279  " >> rpm-files
280
281
282%clean
283[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
284
285
286%define info_files ccmode cl dired-x ediff emacs forms gnus info message mh-e reftex sc vip viper widget
287
288
289%pre
290
291if [ -L %{_datadir}/emacs-%{version}/site-lisp ] ; then
292    %__rm -f %{_datadir}/emacs-%{version}/site-lisp
293fi
294
295if [ -d %{_datadir}/emacs/%{version}/site-lisp ] ; then
296    find %{_datadir}/emacs/%{version}/site-lisp/* -maxdepth 0 | grep -v subdirs.el | \
297        xargs %__rm -rf
298fi
299
300
301%post
302
303if [ "$1" = 1 ]; then
304
305%_addflavorslist emacs-%{version}
306
307export PRIORITY=50
308
309%_installemacs emacs-%{version}
310
311unset PRIORITY
312fi
313
314if [ "$1" = 2 ]; then
315
316#  export PRIORITY=50
317 
318#  %_installemacs emacs-%{version}
319 
320#  unset PRIORITY
321   
322  echo emacs-%{version} >  /var/lib/emacsen-common/doinstaflavor-emacs
323   
324fi
325
326
327%postun
328
329if [ $1 = 1 ]; then
330# run upgrade install time
331
332# old version uninstall
333
334%_removeflavorslist emacs-%{version}
335
336%_removeemacs emacs-%{version}
337
338#new version install
339if [ -f /var/lib/emacsen-common/doinstaflavor-emacs ] ; then
340
341NEWFLAVOR=$(cat /var/lib/emacsen-common/doinstaflavor-emacs)
342
343%_addflavorslist $NEWFLAVOR
344
345export PRIORITY=50
346
347%_installemacs $NEWFLAVOR
348
349unset PRIORITY
350
351%__rm -rf /var/lib/emacsen-common/doinstaflavor-emacs
352
353fi
354
355fi
356
357
358%preun
359if [ $1 = 0 ]; then
360
361%_removeflavorslist emacs-%{version}
362
363%_removeemacs emacs-%{version}
364
365fi
366
367
368%triggerpostun -- emacs23 < %{version}-%{release}
369
370%_addflavorslist emacs-%{version}
371
372export PRIORITY=50
373
374%_installemacs emacs-%{version}
375
376unset PRIORITY
377
378
379%files -f rpm-files
380%defattr(-,root,root)
381%doc INSTALL INSTALL.BZR README BUGS ChangeLog COPYING
382%dir %{_sysconfdir}/emacs-%{version}
383%dir %{_sysconfdir}/emacs-%{version}/site-start.d
384%{_sysconfdir}/emacs-%{version}/site-start.d/*.el
385%config(noreplace) %{_sysconfdir}/emacs/emacs24-local.el
386%{_infodir}/*
387# %{_mandir}/*/*
388%{_datadir}/applications/emacs24.desktop
389%{_datadir}/icons/hicolor/*
390# %{_datadir}/emacs-%{version}/site-lisp
391%dir %{_localstatedir}/games/emacs
392%{_localstatedir}/games/emacs/*
393
394
395%changelog
396* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-4.20110222
397- emacs24 24.0.50 (20110222) snapshot
398- updated site-start.el
399  - defined the function drop-vine-default-from-load-path (regex)
400
401* Sat Jan 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-3.20110128
402- emacs24 24.0.50 (20110128) snapshot
403
404* Sun Jan 02 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-2.20110101
405- emacs24 24.0.50 (20110101) snapshot
406
407* Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-1.20101203
408- emacs24 24.0.50 (20101203) snapshot
409- applied new vine-default system
410  - updated site-start.el
411  - updated vine-default-{base,faces}.el
412  - dropped showvdefaultemacs
413    - merged to emacsen-common package as show-vine-default.sh
414  - renamed local wide configration file to emacs24-local.el
415- updated menu-tree.el to version 0.97
416- added Provides: emacs-snapshot
417
418* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-4
419- updated vine-default-base.el
420  - changed the variable next-line-add-newlines to nil (default)
421
422* Thu Sep 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-3
423- updated menu-tree.el to version 0.96
424
425* Sat Jul 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-2
426- applied some patches from Fedora
427  - Fixed handling of dual spacing fonts rhbz#599437
428  - Add patch to fix rhbz#595546 hideshow library matches wrong parenthesis
429    under certain circumstances
430  - Added a patch fixing m17n and libotf version checking (m17ncheck)
431- updated menu-tree.el to version 0.95
432- merged emacs23-vl.spec of Vine Linux 5.1
433#* Thu Apr 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-9
434#- applied security fix emacs23-CVE-2010-0825-fix-movemail-race.diff from Ubuntu
435#
436#* Fri Feb 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-8
437#- added Requires(post): emacsen-common, Requires(postun): emacsen-common
438#
439#* Fri Feb 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-7
440#- dropped BuildRequires: m17n-lib-devel
441#- added --without-m17n-flt in %%configure
442
443* Mon May 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-1
444- new upstream release
445- updated menu-tree.el to version 0.94
446- updated menu-tree-init.el.emacs23
447  - used prefer-coding-system
448
449* Wed Apr 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.96-1
450- updated to 23.1.96 (23.2 pretest)
451
452* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.95-2
453- removed /usr/share/emacs/site-lisp/subdirs.el
454
455* Sat Apr 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.95-1
456- updated to 23.1.95 (23.2 pretest)
457- added BuildRequires:
458  - atk-devel
459  - dbus-devel
460  - GConf2-devel
461  - alsa-lib-devel
462- added some configure options:
463  --with-libotf --with-m17n-flt --with-dbus --with-gconf
464
465* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.94-1
466- updated to 23.1.94
467
468* Thu Mar 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.93-1
469- updated to 23.1.93 alpha
470
471* Sat Feb 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.92-2
472- added Requires(post): emacsen-common, Requires(postun): emacsen-common
473
474* Tue Feb 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.92-1
475- update to 23.1.92 alpha
476
477* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-6
478- added BuildRequires:
479  - librsvg2-devel
480  - m17n-lib-devel
481  - libotf-devel
482
483* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-5
484- changed License to GPLv3+
485- renamed emacs23.desktop to emacs23.desktop.in
486- updated vine-default-base.el (See [vine-users:079919])
487- fixed in upstream CVS (from Fedora)
488  - fix #543046 - Using scroll bar in emacs highlights/selects text
489  - fix #542657 - emacs does not display indic text
490  - Fixed rhbz#545398 - ETags messes up filenames
491
492* Tue Sep 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-4
493- rebuilt to add signature
494
495* Fri Aug 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-3
496- added BuildRequires: nkf
497- updated menu-tree-init.el.emacs23
498  - fixed menu-tree encoding <BTS:VineLinux:766>
499- set Exec=emacs-@@EMACS_VERSION@@ in emacs23.desktop
500
501* Wed Aug 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-2
502- replaced BR: libungif-devel with BR: giflib-devel
503
504* Sat Aug 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-1
505- new upstream release
506
507* Sat Jul 25 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.0.96-2.20090714
508- updated vine-default-faces.el to sync with emacs22
509
510* Tue Jul 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.96-1.20090714
511- update to 23.0.96 (20090714) snapshot
512- update vine-default-faces.el
513  - use bash to call gconftool-2
514
515* Sat Jun 27 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-4.20090527
516- update vine-default-faces.el
517  - added \'font in default-frame-alist
518    (if \'font is already in default-frame-alist, overwrited it)
519
520* Wed Jun 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-3.20090527
521- update vine-default-faces.el:
522  - use set-frame-font
523    bacause set-default-font function is obsolete since Emacs 23.1
524    (See M-x describe-function RET set-default-font)
525
526* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-2.20090527
527- update vine-default-faces.el:
528  - set desktop-gnome-interface-monospace-font-name
529    from /desktop/gnome/interface/monospace_font_name
530  - automatically set set-default-font
531    with desktop-gnome-interface-monospace-font-name
532
533* Wed May 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.94-1.20090527
534- update to emacs-23.0.94 (20090527) snapshot
535- add --without-gpm to configure
536
537* Thu May 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-7.20090422
538- defined show-vine-default function in site-start.el
539  - added showvdefaultemacs script
540
541* Wed May 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-6.20090422
542- set PRIORITY=40
543
544* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-5.20090422
545- changed menu-tree-init.el from hard copy to symbolic link
546  on /etc/emacs-23.0.92/site-start.d
547- added %%{_mandir}/*/* in %%files section
548
549* Sat May 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-4.20090422
550- updated menu-tree.el to v0.93
551
552* Fri May 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-3.20090422
553- returned alternatives priority to 30
554  (emacs: 30, emacs22: 30)
555
556* Sun Apr 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-2.20090422
557- installed system-wide configure file in /etc/emacs
558- updated vine-default-base.el
559- changed alternatives priority from 30 to 50
560  (emacs: 50, emacs22: 30)
561
562* Wed Apr 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.92-1.20090422
563- update to emacs 23.0.92 (20090422) snapshot
564- add %%triggerpostun to fix alternatives
565
566* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.91-3.20090325
567- renamed from emacs23 to emacs (emacs-22.x would be renamed to emacs22)
568- updated default settings for Vine Linux
569  - dropped vine-default-mouse.el, vine-default-misc.el
570
571* Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.91-2.20090325
572- enable default settings for Vine Linux
573  - added site-start.el.emacs23
574  - updated site-start.el
575  - added vine-default-base.el, vine-default-faces.el, vine-default-mouse.el,
576    vine-default-misc.el
577
578* Wed Mar 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.91-1.20090325
579- emacs23 23.0.91 snapshot
580
581* Tue Sep 09 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 23.0.60-2.20080908
582- drop patch10
583- s/emacsrelese/emacsrelease/
584
585* Mon Sep 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.60-1.20080908
586- emacs23 23.0.60 snapshot
587
588* Sun Sep 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.3-1
589- new upstream release
590
591* Mon Aug 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 22.2-3
592- import security fixes from Debian
593  CVE-2008-2142: fix insecure setting of fast-lock-cache-directories
594  CVE-2008-1694: fix insecure temporary file creation in vcdiff script
595                 leading to possible symlink attacks
596
597* Tue Jun 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.2-2
598- update menu-tree.el
599- add 60menu-tree-init.el to sed coding-system and load menu-tree
600- build with xorg-x11-7.3
601  - update BuildRequires
602
603* Sun Mar 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.2-1
604- new upstream release
605
606* Wed Nov 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 22.1-0vl2
607- add Patch10000 to fix local variable processing security bypass
608  vulnerability.
609  - http://www.frsirt.com/english/advisories/2007/3715
610  - http://bugs.debian.org/449008
611
612* Mon Jun 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 22.1-0vl1
613- new upstream release
614- rename to emacs from emacs22 (emacs-21.x would be renameed to emacs21)
615- drop emcws support
616
617* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 22.0.50-0.20060403vl3
618- rebuilt with new toolchain
619
620* Sat May 06 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 22.0.50-0.20060403vl2
621- changed Group:
622
623* Mon Apr 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20060403vl1
624- update to CVS-20060403
625- update emacs22.desktop
626
627* Wed Sep 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050927vl2
628- fix site-start.el
629
630* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050927vl1
631- update to CVS-20050927
632
633* Thu Sep  8 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050907vl1
634- initial build for Vine Linux based on emacs package.
635  - emacs-22.0.50 on CVS-20050907
636
637* Sat Sep  3 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.4-0vl3
638- create site-start.d directory on %install
639
640* Thu Feb 17 2005 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.4-0vl2
641- included leim-21.4
642- update emcws-21.3-20031213.gz
643
644* Wed Feb 16 2005 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.4-0vl1
645- update
646
647* Sat Jul 24 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl7
648- rebuild with Xaw3d, add BuildRequires: Xaw3d-devel
649
650* Fri Jul 23 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl6
651- add Patch20 to fix display resolutions. (set to 96dpi)
652  (do not compute dynamically from display's size)
653
654* Tue Mar 16 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.3-0vl5
655- rebuilt with new toolchain environment
656
657* Thu Jul 17 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.3-0vl4
658- use site-start.el(reading /etc/emacs-21.3/site-start.d/*.el)
659
660* Wed May  7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 21.3-0vl3
661- add BuildPrereq: libpng >= 1.2.5
662
663* Tue Apr 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl2
664- fixed %%pre script
665
666* Tue Mar 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl1
667- new upstream release
668- remove patch14 whick included in upstream
669
670* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl11
671- add patch14 to fix frame title text encoding.
672  - http://tsukuba.m17n.org/mule-ja-archive/2002-10/msg00004.html
673
674* Tue Dec 10 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.2-0vl10
675- autoconf-2.13, not autoconf in %%setup section
676- BuildPreReq: autoconf213
677
678* Mon Dec  9 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl9
679- modifiy rpm scripts.
680
681* Mon Dec  9 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl8
682- rename to emacs
683- obsoletes emacs21 <= 21.2-0vl7, provides emacs21 = %%{version}
684
685* Sun Dec  1 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl7
686- enable menubar fontset patch (Patch103)
687
688* Sat Nov 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl6
689- add requires/buildprereq tags.
690
691* Sat Nov 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl5
692- add emcws-20021014
693
694* Sun Jul 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl4
695- removed *-mode
696
697* Sat Jul 20 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl3
698- python-mode was made pending
699- some additional *.el files was moved from "emacs/site-lisp" to
700  "emacs-(version)/site-lisp"
701
702* Sat Jul 13 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl2
703- added some sources and patches from rawhide 21.2-11 and mandrake 21.2-7mdk
704
705* Sat May 11 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.2-0vl1
706- update.
707- Package Name emacs-beta -> emacs21
708- Add Patch100,101,102, Source100(default = Disable)
709- (from http://phe.phyas.aichi-edu.ac.jp/~cyamauch/pl2.html#emacs21)
710- --infodir=%{_infodir}/emacs-21.2(VineSeed-Plus:00723)
711
712* Thu Dec 27 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl7
713- site-lisp moved under /usr/share/emacs-21.1/ (Patch11 and %%pre section)
714
715* Thu Dec 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl5
716- move /tmp -> /var/lib/emacsen-common (IP(package)C file)
717
718* Fri Nov 02 2001 Tomoya TAKA <tomoya@olive.plala.or.jp> 21.1-0vl4
719- replace patch10 with patch11, posted to gnu.emacs.bug
720  Message-Id: <jebsiza3db.fsf@sykes.suse.de>
721  (reported by ABE Yuji <cbo46560@pop12.odn.ne.jp>)
722
723* Fri Oct 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.1-0vl3
724- fixed build to fail in alpha( only apply patch0 to ppc)
725
726* Tue Oct 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl2
727- added Patch10 (thanks Kitame-san)
728
729* Mon Oct 22 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.1-0vl1
730- update to 21.1
731
732* Sun Sep 9 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.104-0vl14
733- support  shared installing otheremacsen.
734
735* Mon Jul 23 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.104-0vl3
736- update 21.0.104
737
738* Thu Jul 19 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.103-0vl2
739- support emacsen-common
740
741* Wed May 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
742- 21.0.103-0vl1
743- updated to 21.0.103
744- revamped and cleaned up spec file :-)
745- Requires: tamago >= 4.0.6 (...is it reasonable? Mmm...)
746
747* Mon Jan 22 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.95-0vl2
748- fixed .spec bugs( _libdir)
749
750* Fri Jan 12 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.95-0vl1
751- updated to 21.0.95
752
753* Wed Dec 20 2000 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.93-0vl3
754- fixed emacs-beta.spec
755
756* Sat Dec 16 2000 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.93-0vl2
757- 21.0.93 test packaging.
758
759* Fri Jun 30 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
760- added linespace-patch
761
762* Mon Jun 19 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
763- updated to emacs 20.7
764
765* Thu Apr 20 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
766- updated to emacs 20.6
767
768* Mon Feb 28 2000 kenji KITAYAMA <kenji@gandalf.doshisha.ac.jp>
769- [emacs-20.5a-2]
770- Modified reference of Emacs Info
771
772* Sun Jan 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
773- [emacs-20.5a-2]
774- added ppc patch
775
776* Fri Jan  7 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
777- [emacs-20.5a-1]
778- change version from 20.5 to 20.5a
779- added Mule-4.1 patch
780
781* Fri Jan  7 2000 Yasuyuki Furukawa <yasu@on.cs.keio.ac.jp>
782- [emacs-20.5-1]
783- add desktop-link files for desktop menu.
784
785* Thu Dec 24 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
786- [emacs-20.4-16]
787- replaced Y2K savvy timezone.{el,elc} with one from brand-new apel-10.0
788
789* Tue Dec 21 1999 Jun Nishii <jun@vinelinux.org>
790- added documents
791- strip bins
792
793* Wed Dec  1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
794- [emacs-20.4-14]
795- Change Group to Applications/Editors/Emacs
796
797* Sat Nov  6 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
798- [emacs-20.4-13]
799- included Y2K savvy timezone.{el,elc},
800  modified by Mr. Youichi Teranishi <teranishi@gohome.org>
801
802* Tue Oct 12 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
803- [emacs-20.4-12]
804- Modified info-dir.
805- Removed -c option from %setup.
806
807* Sun Sep 20 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
808- fixed XIM support patch
809* Sun Sep 19 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
810- fixed postinst bug and fontset patch
811* Sun Jul 18 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
812- first build
Note: See TracBrowser for help on using the repository browser.