source: projects/specs/trunk/e/emacs23/emacs23-vl.spec @ 6322

Revision 6322, 28.5 KB checked in by munepi, 12 years ago (diff)

added emacs23

Line 
1%define emacsversion 23.4
2#% define rcversion rc1
3%define emacsrelease 2%{?rcversion:.%rcversion}%{?_dist_release}
4%define vine_default_major_version %(echo %_dist_release|%__sed s/vl//)
5
6%define _noVersionedDependencies 1
7%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
8
9%define infodir %{_infodir}/emacs-%{emacsversion}
10
11%define menutreeelversion 0.97
12
13Summary:      GNU Emacs editor
14Summary(ja):  GNU Emacs エディタ
15#Name:         emacs
16Name:         emacs23
17Version:      %{emacsversion}
18Release:      %{emacsrelease}
19Source0:      ftp://ftp.gnu.org/pub/gnu/emacs/emacs-%{version}.tar.bz2
20#Source0:      ftp://alpha.gnu.org/gnu/emacs/pretest/emacs-%{emacsversion}%{?rcversion:-%rcversion}.tar.gz
21
22## Sources from Rawhide 21.2-11
23Source10:     site-start.el.emacs23
24Source11:     python-mode.el
25Source12:     http://www.tihlde.org/~stigb/rpm-spec-mode.el
26Source13:     ftp://ftp.gnu.org/gnu/emacs/elisp-manual-21-2.8.tar.bz2
27# 1.0.2 - http://prdownloads.sourceforge.net/php-mode/php-mode-102.el
28Source14:     php-mode.el
29Source15:     php-mode-init.el
30Source16:     ssl.el
31Source17:     po-mode.el
32Source18:     po-mode-init.el
33
34## local settings for local system
35Source20:     emacs23-local.el
36
37# desktop file
38Source50:     emacs23.desktop.in
39
40## Enable Japanese Menu
41## http://www11.atwiki.jp/s-irie/pages/13.html
42Source100:    menu-tree-el-%{menutreeelversion}.tar.gz
43Source110:    menu-tree-init.el.emacs23
44
45## default settings for Vine Linux
46Source150:    vine-default-base.el
47Source151:    vine-default-faces.el
48
49## Vine Patch(es)
50Patch10:      emacs-21.1-ppc-nocombreloc.patch
51Patch11:      emacs-23.0.60-locallisppath.patch
52Patch20:      emacs-23.1.90-fixed-resolution.patch
53
54# Fixed in upstream CVS. (from Fedora)
55#Patch30:      emacs-23.1-scroll.patch
56#Patch31:      emacs-23.1-indian.patch
57#Patch32:      emacs-23.1-memmove.patch
58# Accepted by upstream.
59#Patch33: emacs-23.2-m17ncheck.patch
60# Fix rhbz#595546
61# Upstream: http://emacsbugs.donarmstrong.com/cgi/bugreport.cgi?bug=6158
62Patch34: emacs-23.2-hideshow-comment.patch
63# Reported upstream http://debbugs.gnu.org/cgi/bugreport.cgi?bug=4129
64#Patch35: emacs-23.2-spacing.patch
65# http://bzr.savannah.gnu.org/lh/emacs/trunk/revision/106247
66Patch36: emacs-23.3-wm-state-hidden.patch
67# rhbz#751154
68Patch37: emacs-23.3-xgselect.patch
69# http://bzr.savannah.gnu.org/lh/emacs/trunk/revision/103228
70Patch38: emacs-23.1-103228_103227.patch
71# Upstream implemented the change in revno. 101105
72Patch40: emacs-23.1-xdg.patch
73# http://lists.gnu.org/archive/html/emacs-devel/2012-01/msg00387.html
74#Patch41: emacs-23.3-ede-cve-2012-0035.patch
75
76# security patches (from Debian)
77
78# security patches (from Ubuntu)
79# # http://www.vupen.com/english/advisories/2010/0734
80# # https://code.launchpad.net/~ubuntu-branches/ubuntu/karmic/emacs23/karmic-security
81# Patch501:      emacs23-CVE-2010-0825-fix-movemail-race.diff
82
83# patches from Mandrake
84Patch1001:    emacs-21.1-bzip2.patch.bz2
85
86License:      GPLv3+
87Group:        Applications/Editors/Emacs
88
89Distribution: Vine
90Vendor:       Project Vine
91Packager:     munepi, daisuke
92
93BuildRoot:    %{_tmppath}/%{name}-%{version}-root
94# Requires:     tamago >= 4.0.6
95Obsoletes:    mule-base, mule-canna, mule-wnn6, mule, emacs-beta
96Obsoletes:    emacs21 <= 21.2-0vl7
97Obsoletes:    emacs22 <= 22.1
98Obsoletes:    emacs23 <= 23.1
99Provides:     emacs23 = %{version}
100Provides:     emacsen = 0.1
101#% prereq_ge    emacsen-common
102Requires(post):    emacsen-common
103Requires(postun):    emacsen-common
104
105BuildRequires: autoconf
106%if %{?_dist_release} == "vl6" || %{?_dist_release} == "vl7"
107BuildRequires: atk-devel
108BuildRequires: dbus-devel GConf2-devel
109BuildRequires: alsa-lib-devel
110%endif
111BuildRequires: gtk2-devel, cairo-devel
112BuildRequires: freetype-devel, fontconfig-devel
113BuildRequires: libpng-devel, libjpeg-devel, libtiff-devel, libungif-devel
114##!! For vl5, m17n-lib-devel (plus)
115BuildRequires: librsvg2-devel, libotf-devel
116%if %{?_dist_release} == "vl6" || %{?_dist_release} == "vl7"
117BuildRequires: m17n-lib-devel
118%endif
119BuildRequires: libX11-devel, libXau-devel, libXdmcp-devel, libXrender-devel
120BuildRequires: libXt-devel, libXpm-devel, ncurses-devel
121BuildRequires: xorg-x11-proto-devel, zlib-devel
122BuildRequires: texinfo
123BuildRequires: nkf
124
125%description
126GNU Emacs is the extensible, customizable, self-documenting real-time
127display editor.
128
129%description -l ja
130GNU Emacs は拡張性が高く、さまざまなカスタマイズが可能な高機能エディタです。
131
132
133%prep
134
135%setup -q -n emacs-%{version}
136
137%ifarch ppc
138#%patch10 -p1
139%endif
140
141%patch11 -p1
142%patch20 -p1
143
144#%patch30 -p1 -b .scroll
145#%patch31 -p1
146#%patch32 -p1 -b .memmove
147#%patch33 -p1 -b .m17ncheck
148%patch34 -p0 -b .hideshow-comment
149#%patch35 -p1 -b .spacing
150%patch36 -p1 -b .wm-state-hidden
151%patch37 -p1 -b .xgselect
152%patch38 -p0 -b .svn17
153%patch40 -p1 -b .xdg
154#%patch41 -p1 -b .ede-cve-2012-0035
155
156#%patch501 -p1 -b .movemail
157
158%patch1001 -p1
159
160autoconf
161
162
163%build
164
165export CFLAGS="-DMAIL_USE_LOCKF $RPM_OPT_FLAGS"
166#to find installinfo
167export PATH="$PATH:/sbin:/usr/sbin"
168
169%configure --with-pop --with-sound \
170    --libexecdir=%{_libdir} --infodir=%{infodir} \
171    --disable-rename \
172    --with-toolkit=gtk \
173    --with-freetype --with-xft \
174    --enable-font-backend \
175    --without-gpm \
176        --with-libotf \
177%if %{?_dist_release} == "vl5"
178      --without-m17n-flt \
179%endif
180%if %{?_dist_release} == "vl6" || %{?_dist_release} == "vl7"
181      --with-m17n-flt \
182      --with-dbus --with-gconf \
183%endif
184    ;
185
186%__make bootstrap
187%__make %{?_smp_mflags}
188
189
190#%define recompile src/emacs -batch --no-init-file --no-site-file -f batch-byte-compile
191
192# recompile patched .el files
193#%{recompile} lisp/mail/mh-utils.el lisp/progmodes/make-mode.el
194
195# bytecompile python-mode, ssl, php-mode and rpm-spec-mode
196#cp %SOURCE12  %SOURCE14 %SOURCE16 %SOURCE17 .
197##%%{recompile} rpm-spec-mode.el php-mode.el ssl.el po-mode.el
198
199
200%install
201[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
202
203ARCHDIR=${RPM_ARCH}-vine-linux
204
205%makeinstall libexecdir=$RPM_BUILD_ROOT%{_libdir} \
206        infodir=${RPM_BUILD_ROOT}%{infodir}
207
208## This is a duplicate of the file in FLAVOR/site-lisp
209%__rm -f $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/subdirs.el || exit 1
210
211(cd $RPM_BUILD_ROOT%{_mandir}/man1/; %__mv ctags.1 gctags.1)
212(cd $RPM_BUILD_ROOT%{_bindir}/; %__mv ctags gctags)
213
214%__mkdir_p  $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/etc
215%__mkdir_p  $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp
216# cp %{SOURCE100} $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/menu-tree.el
217# nkf -w %{SOURCE100} > $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/menu-tree-utf8.el
218%__tar zxvf %{SOURCE100}
219%__cp -a menu-tree-el-%{menutreeelversion}/menu-tree.el $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/
220nkf -w --overwrite $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/menu-tree.el
221
222## vine default
223%__cp -a %{SOURCE150} %{SOURCE151} \
224    $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/
225
226# The elisp reference manual
227#bzcat %{SOURCE13} | tar xf -
228#pushd elisp-manual-21-2.8
229#install -m 644 elisp elisp-? elisp-?? $RPM_BUILD_ROOT/%{infodir}
230#popd
231
232# some modifications of installed files
233
234#rm -f $RPM_BUILD_ROOT%{infodir}/dir
235#gzip -9nf $RPM_BUILD_ROOT%{infodir}/*
236
237%__install -m 644 %{SOURCE10} \
238        $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/site-start.el
239%__sed -i -e 's/EMACS_VERSION/%{version}/g' \
240          -e 's/VINE_DEFAULT_MAJOR_VERSION/%{vine_default_major_version}/g' \
241        $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/site-start.el
242
243## create site-start.d directory
244%__install -m 755 -d ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d
245
246# install coding-system init.el
247%__install -m644 %{SOURCE110} \
248    $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/menu-tree-init.el
249%__ln_s -f %{_datadir}/emacs-%{version}/site-lisp/menu-tree-init.el \
250    ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d/60menu-tree-init.el
251
252## install system-wide configure file
253%__install -m755 -d ${RPM_BUILD_ROOT}/etc/emacs
254%__install -m644 %{SOURCE20} ${RPM_BUILD_ROOT}/etc/emacs/emacs23-local.el
255%__sed -i -e 's/EMACS_VERSION/%{version}/g' \
256    ${RPM_BUILD_ROOT}/etc/emacs/emacs23-local.el
257
258## Python mode, php mode and rpm-spec mode
259
260## make file list
261strip $RPM_BUILD_ROOT%{_bindir}/* || :
262
263# install desktop file
264%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/applications
265%__sed -e "s/@@EMACS_VERSION@@/%{emacsversion}/g" %{SOURCE50} > \
266    $RPM_BUILD_ROOT%{_datadir}/applications/$(basename %{SOURCE50} .in)
267[ -f $RPM_BUILD_ROOT%{_datadir}/applications/emacs.desktop ] && \
268    %__rm -f $RPM_BUILD_ROOT%{_datadir}/applications/emacs.desktop || exit 1
269
270# install icons
271%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/icons
272%__cp -a etc/images/icons/hicolor $RPM_BUILD_ROOT%{_datadir}/icons/
273
274## remove man files
275%__rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/* || exit 1
276
277## Remove ctags
278#rm -f $RPM_BUILD_ROOT/usr/bin/ctags
279#rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/*ctags*
280#rm -f $RPM_BUILD_ROOT/%{_datadir}/emacs/%{version}/etc/ctags*
281
282DIR="${RPM_BUILD_ROOT}%{_datadir}/emacs \
283     ${RPM_BUILD_ROOT}%{_datadir}/emacs-%{version}"
284BIN=${RPM_BUILD_ROOT}%{_bindir}
285LIB=${RPM_BUILD_ROOT}%{_libdir}
286EL="*.el"
287
288## prepare file list for emacs
289
290echo "/usr/bin/b2m
291/usr/bin/ebrowse
292/usr/bin/etags
293/usr/bin/rcs-checkin
294/usr/bin/emacs
295/usr/bin/emacsclient
296/usr/bin/gctags
297/usr/bin/grep-changelog
298/usr/share/icons/hicolor/scalable/apps/emacs.svg
299/usr/share/icons/hicolor/scalable/mimetypes/emacs-document.svg"|
300    %__sed -e "s#[^\n]*#mv ${RPM_BUILD_ROOT}\0 ${RPM_BUILD_ROOT}\0.emacs-%{version}#"|
301    awk '{system($_)}' 
302
303
304# find ${RPM_BUILD_ROOT}/%{_mandir} -type f |
305# sed -e "s#\.gz##"|
306# sed -e "s#[^\n]*#mv \0.gz \0-emacs-%{version}.gz#"|
307#    awk '{system($_)}'
308
309
310
311
312#find ${RPM_BUILD_ROOT}/%{_infodir} -type f |
313#sed -e "s#\.gz##"|
314#sed -e "s#[^\n]*#mv \0.gz \0-e21.gz#"|
315#    awk '{system($_)}'
316
317
318
319
320
321find $DIR $BIN $LIB -type d |
322  %__sed -e "s#^${RPM_BUILD_ROOT}#%dir #" > rpm-files
323
324find $DIR $BIN $LIB -type f |
325  %__sed -e "
326    s#^${RPM_BUILD_ROOT}\(.*movemail\)#%attr(2755, root, mail) \1#
327    s#^${RPM_BUILD_ROOT}##
328  " >> rpm-files
329
330
331%clean
332[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
333
334
335%define info_files ccmode cl dired-x ediff emacs forms gnus info message mh-e reftex sc vip viper widget
336
337
338%pre
339
340if [ -L %{_datadir}/emacs-%{version}/site-lisp ] ; then
341    %__rm -f %{_datadir}/emacs-%{version}/site-lisp
342fi
343
344if [ -d %{_datadir}/emacs/%{version}/site-lisp ] ; then
345    find %{_datadir}/emacs/%{version}/site-lisp/* -maxdepth 0 | grep -v subdirs.el | \
346        xargs %__rm -rf
347fi
348
349
350%post
351
352if [ "$1" = 1 ]; then
353
354%_addflavorslist emacs-%{version}
355
356export PRIORITY=40
357
358%_installemacs emacs-%{version}
359
360unset PRIORITY
361fi
362
363if [ "$1" = 2 ]; then
364
365#  export PRIORITY=40
366 
367#  %_installemacs emacs-%{version}
368 
369#  unset PRIORITY
370   
371  echo emacs-%{version} >  /var/lib/emacsen-common/doinstaflavor-emacs
372   
373fi
374
375
376%postun
377
378if [ $1 = 1 ]; then
379# run upgrade install time
380
381# old version uninstall
382
383%_removeflavorslist emacs-%{version}
384
385%_removeemacs emacs-%{version}
386
387#new version install
388if [ -f /var/lib/emacsen-common/doinstaflavor-emacs ] ; then
389
390NEWFLAVOR=$(cat /var/lib/emacsen-common/doinstaflavor-emacs)
391
392%_addflavorslist $NEWFLAVOR
393
394export PRIORITY=40
395
396%_installemacs $NEWFLAVOR
397
398unset PRIORITY
399
400%__rm -rf /var/lib/emacsen-common/doinstaflavor-emacs
401
402fi
403
404fi
405
406
407%preun
408if [ $1 = 0 ]; then
409
410%_removeflavorslist emacs-%{version}
411
412%_removeemacs emacs-%{version}
413
414fi
415
416
417%triggerpostun -- emacs23 < %{version}-%{release}
418
419%_addflavorslist emacs-%{version}
420
421export PRIORITY=40
422
423%_installemacs emacs-%{version}
424
425unset PRIORITY
426
427
428%files -f rpm-files
429%defattr(-,root,root)
430%doc INSTALL README BUGS ChangeLog
431%dir %{_sysconfdir}/emacs-%{version}
432%dir %{_sysconfdir}/emacs-%{version}/site-start.d
433%{_sysconfdir}/emacs-%{version}/site-start.d/*.el
434%config(noreplace) %{_sysconfdir}/emacs/emacs23-local.el
435%{_infodir}/*
436# %{_mandir}/*/*
437%{_datadir}/applications/emacs23.desktop
438%{_datadir}/icons/hicolor/*
439# %{_datadir}/emacs-%{version}/site-lisp
440%dir %{_localstatedir}/games/emacs
441%{_localstatedir}/games/emacs/*
442
443%changelog
444* Tue Jun 12 2012 Munehiro Yamamoto <munepi@vinelinux.org> 23.4-2
445- renamed from emacs-23.4 to emacs23-23.4
446
447* Mon Jan 30 2012 Munehiro Yamamoto <munepi@vinelinux.org> 23.4-1
448- update to 23.4
449
450* Sat Jan 21 2012 Munehiro Yamamoto <munepi@vinelinux.org> 23.3-5
451- added patch41 to handle CVE-2012-0035: CEDET global-ede-mode file loading
452  vulnerability (rhbz#773024)
453
454* Fri Jan 06 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 23.3-4
455- update to 23.3b
456- add patch36: Check for _NET_WM_STATE_HIDDEN (rhbz#711739)
457- add patch37: Initialize xgselect in function xg_select when
458  gfds_size == 0 (rhbz#751154)
459- add patch38: Apply upstream Subversion >= 1.7 dir structure
460  fix for vc-svn.el.
461- add patch40: use xdg-open for opening URLs
462
463* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 23.3-3
464- updated site-start.el
465  - defined vine-default-major-version, vine-default-minor-version,
466    vine-default-version
467  - set "ibus-el" to emacs-ime as default
468  - added a string ", modified for Vine Linux" to the end of emacs-build-system
469  - set "Vine _at_mark_ vinelinux.org" to report-emacs-bug-address
470
471* Sun Apr 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 23.3-2
472- fixed site-start.el
473  - do not use the macro loop (contained in the common lisp)
474
475* Fri Mar 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 23.3-1
476- new upstream release
477
478* Tue Mar 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 23.3-1.rc1
479- updated to 23.3-rc1 (23.3 release candidate)
480
481* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 23.2.94-1
482- updated to 23.2.94 (23.3 pretest)
483- updated site-start.el
484  - defined the function drop-vine-default-from-load-path (regex)
485
486* Wed Feb 02 2011 Munehiro Yamamoto <munepi@vinelinux.org> 23.2.93-1
487- updated to 23.2.93 (23.3 pretest)
488
489* Sat Jan 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 23.2.92-1
490- updated to 23.2.92 (23.3 pretest)
491- dropped upstreamed patches
492  - emacs-23.2-m17ncheck.patch
493  - emacs-23.2-spacing.patch
494
495* Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-5
496- applied new vine-default system
497  - updated site-start.el
498  - updated vine-default-{base,faces}.el
499  - dropped showvdefaultemacs
500    - merged to emacsen-common package as show-vine-default.sh
501  - renamed local wide configration file to emacs23-local.el
502- updated menu-tree.el to version 0.97
503- updated emacs23.desktop.in and menu-tree-init.el.emacs23, little
504
505* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-4
506- updated vine-default-base.el
507  - changed the variable next-line-add-newlines to nil (default)
508
509* Thu Sep 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-3
510- updated menu-tree.el to version 0.96
511
512* Sat Jul 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-2
513- applied some patches from Fedora
514  - Fixed handling of dual spacing fonts rhbz#599437
515  - Add patch to fix rhbz#595546 hideshow library matches wrong parenthesis
516    under certain circumstances
517  - Added a patch fixing m17n and libotf version checking (m17ncheck)
518- updated menu-tree.el to version 0.95
519- merged emacs23-vl.spec of Vine Linux 5.1
520#* Thu Apr 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-9
521#- applied security fix emacs23-CVE-2010-0825-fix-movemail-race.diff from Ubuntu
522#
523#* Fri Feb 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-8
524#- added Requires(post): emacsen-common, Requires(postun): emacsen-common
525#
526#* Fri Feb 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-7
527#- dropped BuildRequires: m17n-lib-devel
528#- added --without-m17n-flt in %%configure
529
530* Mon May 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-1
531- new upstream release
532- updated menu-tree.el to version 0.94
533- updated menu-tree-init.el.emacs23
534  - used prefer-coding-system
535
536* Wed Apr 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.96-1
537- updated to 23.1.96 (23.2 pretest)
538
539* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.95-2
540- removed /usr/share/emacs/site-lisp/subdirs.el
541
542* Sat Apr 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.95-1
543- updated to 23.1.95 (23.2 pretest)
544- added BuildRequires:
545  - atk-devel
546  - dbus-devel
547  - GConf2-devel
548  - alsa-lib-devel
549- added some configure options:
550  --with-libotf --with-m17n-flt --with-dbus --with-gconf
551
552* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.94-1
553- updated to 23.1.94
554
555* Thu Mar 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.93-1
556- updated to 23.1.93 alpha
557
558* Sat Feb 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.92-2
559- added Requires(post): emacsen-common, Requires(postun): emacsen-common
560
561* Tue Feb 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.92-1
562- update to 23.1.92 alpha
563
564* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-6
565- added BuildRequires:
566  - librsvg2-devel
567  - m17n-lib-devel
568  - libotf-devel
569
570* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-5
571- changed License to GPLv3+
572- renamed emacs23.desktop to emacs23.desktop.in
573- updated vine-default-base.el (See [vine-users:079919])
574- fixed in upstream CVS (from Fedora)
575  - fix #543046 - Using scroll bar in emacs highlights/selects text
576  - fix #542657 - emacs does not display indic text
577  - Fixed rhbz#545398 - ETags messes up filenames
578
579* Tue Sep 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-4
580- rebuilt to add signature
581
582* Fri Aug 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-3
583- added BuildRequires: nkf
584- updated menu-tree-init.el.emacs23
585  - fixed menu-tree encoding <BTS:VineLinux:766>
586- set Exec=emacs-@@EMACS_VERSION@@ in emacs23.desktop
587
588* Wed Aug 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-2
589- replaced BR: libungif-devel with BR: giflib-devel
590
591* Sat Aug 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-1
592- new upstream release
593
594* Sat Jul 25 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.0.96-2.20090714
595- updated vine-default-faces.el to sync with emacs22
596
597* Tue Jul 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.96-1.20090714
598- update to 23.0.96 (20090714) snapshot
599- update vine-default-faces.el
600  - use bash to call gconftool-2
601
602* Sat Jun 27 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-4.20090527
603- update vine-default-faces.el
604  - added \'font in default-frame-alist
605    (if \'font is already in default-frame-alist, overwrited it)
606
607* Wed Jun 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-3.20090527
608- update vine-default-faces.el:
609  - use set-frame-font
610    bacause set-default-font function is obsolete since Emacs 23.1
611    (See M-x describe-function RET set-default-font)
612
613* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-2.20090527
614- update vine-default-faces.el:
615  - set desktop-gnome-interface-monospace-font-name
616    from /desktop/gnome/interface/monospace_font_name
617  - automatically set set-default-font
618    with desktop-gnome-interface-monospace-font-name
619
620* Wed May 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.94-1.20090527
621- update to emacs-23.0.94 (20090527) snapshot
622- add --without-gpm to configure
623
624* Thu May 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-7.20090422
625- defined show-vine-default function in site-start.el
626  - added showvdefaultemacs script
627
628* Wed May 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-6.20090422
629- set PRIORITY=40
630
631* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-5.20090422
632- changed menu-tree-init.el from hard copy to symbolic link
633  on /etc/emacs-23.0.92/site-start.d
634- added %%{_mandir}/*/* in %%files section
635
636* Sat May 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-4.20090422
637- updated menu-tree.el to v0.93
638
639* Fri May 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-3.20090422
640- returned alternatives priority to 30
641  (emacs: 30, emacs22: 30)
642
643* Sun Apr 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-2.20090422
644- installed system-wide configure file in /etc/emacs
645- updated vine-default-base.el
646- changed alternatives priority from 30 to 50
647  (emacs: 50, emacs22: 30)
648
649* Wed Apr 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.92-1.20090422
650- update to emacs 23.0.92 (20090422) snapshot
651- add %%triggerpostun to fix alternatives
652
653* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.91-3.20090325
654- renamed from emacs23 to emacs (emacs-22.x would be renamed to emacs22)
655- updated default settings for Vine Linux
656  - dropped vine-default-mouse.el, vine-default-misc.el
657
658* Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.91-2.20090325
659- enable default settings for Vine Linux
660  - added site-start.el.emacs23
661  - updated site-start.el
662  - added vine-default-base.el, vine-default-faces.el, vine-default-mouse.el,
663    vine-default-misc.el
664
665* Wed Mar 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.91-1.20090325
666- emacs23 23.0.91 snapshot
667
668* Tue Sep 09 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 23.0.60-2.20080908
669- drop patch10
670- s/emacsrelese/emacsrelease/
671
672* Mon Sep 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.60-1.20080908
673- emacs23 23.0.60 snapshot
674
675* Sun Sep 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.3-1
676- new upstream release
677
678* Mon Aug 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 22.2-3
679- import security fixes from Debian
680  CVE-2008-2142: fix insecure setting of fast-lock-cache-directories
681  CVE-2008-1694: fix insecure temporary file creation in vcdiff script
682                 leading to possible symlink attacks
683
684* Tue Jun 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.2-2
685- update menu-tree.el
686- add 60menu-tree-init.el to sed coding-system and load menu-tree
687- build with xorg-x11-7.3
688  - update BuildRequires
689
690* Sun Mar 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.2-1
691- new upstream release
692
693* Wed Nov 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 22.1-0vl2
694- add Patch10000 to fix local variable processing security bypass
695  vulnerability.
696  - http://www.frsirt.com/english/advisories/2007/3715
697  - http://bugs.debian.org/449008
698
699* Mon Jun 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 22.1-0vl1
700- new upstream release
701- rename to emacs from emacs22 (emacs-21.x would be renameed to emacs21)
702- drop emcws support
703
704* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 22.0.50-0.20060403vl3
705- rebuilt with new toolchain
706
707* Sat May 06 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 22.0.50-0.20060403vl2
708- changed Group:
709
710* Mon Apr 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20060403vl1
711- update to CVS-20060403
712- update emacs22.desktop
713
714* Wed Sep 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050927vl2
715- fix site-start.el
716
717* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050927vl1
718- update to CVS-20050927
719
720* Thu Sep  8 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050907vl1
721- initial build for Vine Linux based on emacs package.
722  - emacs-22.0.50 on CVS-20050907
723
724* Sat Sep  3 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.4-0vl3
725- create site-start.d directory on %install
726
727* Thu Feb 17 2005 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.4-0vl2
728- included leim-21.4
729- update emcws-21.3-20031213.gz
730
731* Wed Feb 16 2005 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.4-0vl1
732- update
733
734* Sat Jul 24 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl7
735- rebuild with Xaw3d, add BuildRequires: Xaw3d-devel
736
737* Fri Jul 23 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl6
738- add Patch20 to fix display resolutions. (set to 96dpi)
739  (do not compute dynamically from display's size)
740
741* Tue Mar 16 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.3-0vl5
742- rebuilt with new toolchain environment
743
744* Thu Jul 17 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.3-0vl4
745- use site-start.el(reading /etc/emacs-21.3/site-start.d/*.el)
746
747* Wed May  7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 21.3-0vl3
748- add BuildPrereq: libpng >= 1.2.5
749
750* Tue Apr 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl2
751- fixed %%pre script
752
753* Tue Mar 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl1
754- new upstream release
755- remove patch14 whick included in upstream
756
757* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl11
758- add patch14 to fix frame title text encoding.
759  - http://tsukuba.m17n.org/mule-ja-archive/2002-10/msg00004.html
760
761* Tue Dec 10 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.2-0vl10
762- autoconf-2.13, not autoconf in %%setup section
763- BuildPreReq: autoconf213
764
765* Mon Dec  9 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl9
766- modifiy rpm scripts.
767
768* Mon Dec  9 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl8
769- rename to emacs
770- obsoletes emacs21 <= 21.2-0vl7, provides emacs21 = %%{version}
771
772* Sun Dec  1 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl7
773- enable menubar fontset patch (Patch103)
774
775* Sat Nov 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl6
776- add requires/buildprereq tags.
777
778* Sat Nov 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl5
779- add emcws-20021014
780
781* Sun Jul 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl4
782- removed *-mode
783
784* Sat Jul 20 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl3
785- python-mode was made pending
786- some additional *.el files was moved from "emacs/site-lisp" to
787  "emacs-(version)/site-lisp"
788
789* Sat Jul 13 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl2
790- added some sources and patches from rawhide 21.2-11 and mandrake 21.2-7mdk
791
792* Sat May 11 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.2-0vl1
793- update.
794- Package Name emacs-beta -> emacs21
795- Add Patch100,101,102, Source100(default = Disable)
796- (from http://phe.phyas.aichi-edu.ac.jp/~cyamauch/pl2.html#emacs21)
797- --infodir=%{_infodir}/emacs-21.2(VineSeed-Plus:00723)
798
799* Thu Dec 27 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl7
800- site-lisp moved under /usr/share/emacs-21.1/ (Patch11 and %%pre section)
801
802* Thu Dec 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl5
803- move /tmp -> /var/lib/emacsen-common (IP(package)C file)
804
805* Fri Nov 02 2001 Tomoya TAKA <tomoya@olive.plala.or.jp> 21.1-0vl4
806- replace patch10 with patch11, posted to gnu.emacs.bug
807  Message-Id: <jebsiza3db.fsf@sykes.suse.de>
808  (reported by ABE Yuji <cbo46560@pop12.odn.ne.jp>)
809
810* Fri Oct 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.1-0vl3
811- fixed build to fail in alpha( only apply patch0 to ppc)
812
813* Tue Oct 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl2
814- added Patch10 (thanks Kitame-san)
815
816* Mon Oct 22 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.1-0vl1
817- update to 21.1
818
819* Sun Sep 9 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.104-0vl14
820- support  shared installing otheremacsen.
821
822* Mon Jul 23 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.104-0vl3
823- update 21.0.104
824
825* Thu Jul 19 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.103-0vl2
826- support emacsen-common
827
828* Wed May 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
829- 21.0.103-0vl1
830- updated to 21.0.103
831- revamped and cleaned up spec file :-)
832- Requires: tamago >= 4.0.6 (...is it reasonable? Mmm...)
833
834* Mon Jan 22 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.95-0vl2
835- fixed .spec bugs( _libdir)
836
837* Fri Jan 12 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.95-0vl1
838- updated to 21.0.95
839
840* Wed Dec 20 2000 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.93-0vl3
841- fixed emacs-beta.spec
842
843* Sat Dec 16 2000 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.93-0vl2
844- 21.0.93 test packaging.
845
846* Fri Jun 30 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
847- added linespace-patch
848
849* Mon Jun 19 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
850- updated to emacs 20.7
851
852* Thu Apr 20 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
853- updated to emacs 20.6
854
855* Mon Feb 28 2000 kenji KITAYAMA <kenji@gandalf.doshisha.ac.jp>
856- [emacs-20.5a-2]
857- Modified reference of Emacs Info
858
859* Sun Jan 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
860- [emacs-20.5a-2]
861- added ppc patch
862
863* Fri Jan  7 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
864- [emacs-20.5a-1]
865- change version from 20.5 to 20.5a
866- added Mule-4.1 patch
867
868* Fri Jan  7 2000 Yasuyuki Furukawa <yasu@on.cs.keio.ac.jp>
869- [emacs-20.5-1]
870- add desktop-link files for desktop menu.
871
872* Thu Dec 24 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
873- [emacs-20.4-16]
874- replaced Y2K savvy timezone.{el,elc} with one from brand-new apel-10.0
875
876* Tue Dec 21 1999 Jun Nishii <jun@vinelinux.org>
877- added documents
878- strip bins
879
880* Wed Dec  1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
881- [emacs-20.4-14]
882- Change Group to Applications/Editors/Emacs
883
884* Sat Nov  6 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
885- [emacs-20.4-13]
886- included Y2K savvy timezone.{el,elc},
887  modified by Mr. Youichi Teranishi <teranishi@gohome.org>
888
889* Tue Oct 12 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
890- [emacs-20.4-12]
891- Modified info-dir.
892- Removed -c option from %setup.
893
894* Sun Sep 20 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
895- fixed XIM support patch
896* Sun Sep 19 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
897- fixed postinst bug and fontset patch
898* Sun Jul 18 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
899- first build
Note: See TracBrowser for help on using the repository browser.