source: projects/specs/trunk/e/emacs/emacs26-vl.spec @ 11704

Revision 11704, 30.0 KB checked in by iwaim, 6 years ago (diff)

emacs: rename files

Line 
1%define emacsversion 25.3
2#% define gitcommit 20110817
3#%define emacsrelease 1.rc2%{?gitcommit:.%gitcommit}%{?_dist_release}
4%define emacsrelease 1%{?_dist_release}
5%define vine_default_major_version %(echo %_dist_release|%__sed s/vl//)
6
7%define _noVersionedDependencies 1
8%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
9
10%define infodir %{_infodir}/emacs-%{emacsversion}
11
12%define menutreeelversion 0.97
13
14Summary:      GNU Emacs editor
15Summary(ja):  GNU Emacs エディタ
16Name:         emacs
17#Name:         emacs25
18#Provides:     emacs-snapshot
19Version:      %{emacsversion}
20Release:      %{emacsrelease}
21Source0:      ftp://ftp.gnu.org/pub/gnu/emacs/emacs-%{version}.tar.xz
22#Source0:      ftp://ftp.gnu.org/pub/gnu/emacs/emacs-%{version}%{?gitcommit:.git%gitcommit}.tar.xz
23#Source0:      ftp://alpha.gnu.org/gnu/emacs/pretest/emacs-%{emacsversion}-rc2.tar.xz
24#Source1:      emacs-snapshot.sh
25
26Source10:     site-start.el.emacs25
27
28## local settings for local system
29Source20:     emacs25-local.el
30
31# desktop file
32Source50:     emacs25.desktop.in
33
34## Enable Japanese Menu
35## http://www11.atwiki.jp/s-irie/pages/13.html
36# Source100:    menu-tree-el-%{menutreeelversion}.tar.gz
37# Source101:    menu-tree-init.el.emacs25
38Source102:    coding-system-init.el.emacs25
39
40## default settings for Vine Linux
41Source150:    vine-default-base.el
42
43## Vine Patch(es)
44Patch11:      emacs-24.3.90-locallisppath.patch
45#Patch20:      emacs-23.1.90-fixed-resolution.patch
46Patch30:      emacs-24.0.90-libs-termcap.patch
47
48# patches from Fedora
49# rhbz#713600
50Patch107: emacs-spellchecker.patch
51
52# security patches (from Debian)
53
54#Patch1001:    emacs-21.1-bzip2.patch.bz2
55
56License:      GPLv3+
57Group:        Applications/Editors/Emacs
58
59Distribution: Vine Linux
60Vendor:       Project Vine
61Packager:     munepi, daisuke
62
63BuildRoot:    %{_tmppath}/%{name}-%{version}-root
64# Requires:     tamago >= 4.0.6
65Obsoletes:    mule-base, mule-canna, mule-wnn6, mule, emacs-beta
66Obsoletes:    emacs21 <= 21.2-0vl7
67Obsoletes:    emacs22 <= 22.1
68Obsoletes:    emacs23 <= 23.1
69Obsoletes:    emacs24 <= 24.1
70# Obsoletes:    emacs25 <= 25.1
71Provides:     emacs25 = %{version}
72Provides:     emacsen = 0.1
73#% prereq_ge    emacsen-common
74Requires(post):    emacsen-common
75Requires(postun):    emacsen-common
76
77BuildRequires: autoconf
78BuildRequires: xz
79BuildRequires: atk-devel
80BuildRequires: dbus-devel GConf2-devel
81BuildRequires: alsa-lib-devel
82BuildRequires: gnutls-devel
83#if %{?_dist_release} >= "vl7"
84#BuildRequires: gtk3-devel
85#else
86BuildRequires: gtk2-devel
87#endif
88BuildRequires: cairo-devel
89BuildRequires: freetype2-devel, fontconfig-devel
90BuildRequires: libpng-devel, libjpeg-devel, libtiff-devel, libungif-devel
91BuildRequires: librsvg2-devel, libotf-devel
92BuildRequires: ImageMagick-devel
93BuildRequires: libxml2-devel > 2.6.17
94BuildRequires: m17n-lib-devel
95BuildRequires: libX11-devel, libXau-devel, libXdmcp-devel, libXrender-devel
96BuildRequires: libSM-devel, libXt-devel, libXpm-devel, ncurses-devel
97BuildRequires: xorg-x11-proto-devel, zlib-devel
98BuildRequires: texinfo
99BuildRequires: nkf
100
101%description
102GNU Emacs is the extensible, customizable, self-documenting real-time
103display editor.
104
105%description -l ja
106GNU Emacs は拡張性が高く、さまざまなカスタマイズが可能な高機能エディタです。
107
108
109%prep
110
111%setup -q -n emacs-%{version}
112
113%patch11 -p1
114#%patch20 -p1
115#%patch30 -p1
116
117%patch107 -p1 -b .spellchecker
118
119#%patch1001 -p1
120
121
122# Avoid trademark issues
123grep -v "tetris.elc" lisp/Makefile.in > lisp/Makefile.in.new \
124   && %__mv lisp/Makefile.in.new lisp/Makefile.in || exit 1
125%__rm -f lisp/play/tetris.el lisp/play/tetris.elc || exit 1
126
127#autoconf
128autoreconf -i -I m4
129
130%build
131export CFLAGS="-DMAIL_USE_LOCKF $RPM_OPT_FLAGS"
132#to find installinfo
133export PATH="$PATH:/sbin:/usr/sbin"
134
135%configure --with-pop --with-sound \
136    --libexecdir=%{_libdir} --infodir=%{infodir} \
137    --disable-rename \
138    --with-x-toolkit=gtk \
139    --with-freetype --with-xft \
140    --enable-font-backend \
141    --without-gpm \
142    --with-libotf \
143    --with-m17n-flt \
144    --with-dbus --with-gconf \
145    ;
146#    --with-x-toolkit=gtk3 \
147
148%__make bootstrap
149%__make %{?_smp_mflags}
150
151
152%install
153[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
154
155%makeinstall libexecdir=$RPM_BUILD_ROOT%{_libdir} \
156        infodir=${RPM_BUILD_ROOT}%{infodir}
157
158## This is a duplicate of the file in FLAVOR/site-lisp
159%__rm -f $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/subdirs.el || exit 1
160
161# (cd $RPM_BUILD_ROOT%{_mandir}/man1/; %__mv ctags.1 gctags.1)
162# (cd $RPM_BUILD_ROOT%{_bindir}/; %__mv ctags gctags)
163
164%__mkdir_p  $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/etc
165%__mkdir_p  $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp
166# %__tar zxvf %{SOURCE100}
167# %__cp -a menu-tree-el-%{menutreeelversion}/menu-tree.el $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/
168# nkf -w --overwrite $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/menu-tree.el
169
170## vine default
171%__cp -a %{SOURCE150} \
172    $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/
173
174# The elisp reference manual
175#bzcat %{SOURCE13} | tar xf -
176#pushd elisp-manual-21-2.8
177#install -m 644 elisp elisp-? elisp-?? $RPM_BUILD_ROOT/%{infodir}
178#popd
179
180# some modifications of installed files
181
182#rm -f $RPM_BUILD_ROOT%{infodir}/dir
183#gzip -9nf $RPM_BUILD_ROOT%{infodir}/*
184
185%__install -m 644 %{SOURCE10} \
186        $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/site-start.el
187%__sed -i -e 's/EMACS_VERSION/%{version}/g' \
188          -e 's/VINE_DEFAULT_MAJOR_VERSION/%{vine_default_major_version}/g' \
189        $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/site-start.el
190
191## create site-start.d directory
192%__install -m 755 -d ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d
193
194# install coding-system init.el
195# %__install -m644 %{SOURCE101} \
196#     $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/menu-tree-init.el
197# %__ln_s -f %{_datadir}/emacs-%{version}/site-lisp/menu-tree-init.el \
198#     ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d/60menu-tree-init.el
199%__install -m644 %{SOURCE102} \
200    $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/coding-system-init.el
201%__ln_s -f %{_datadir}/emacs-%{version}/site-lisp/coding-system-init.el \
202    ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d/60coding-system-init.el
203
204## install system-wide configure file
205%__install -m755 -d ${RPM_BUILD_ROOT}/etc/emacs
206%__install -m644 %{SOURCE20} ${RPM_BUILD_ROOT}/etc/emacs/emacs25-local.el
207%__sed -i -e 's/EMACS_VERSION/%{version}/g' \
208    ${RPM_BUILD_ROOT}/etc/emacs/emacs25-local.el
209
210## Python mode, php mode and rpm-spec mode
211
212## make file list
213strip $RPM_BUILD_ROOT%{_bindir}/* || :
214
215# install desktop file
216%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/applications
217%__sed -e "s/@@EMACS_VERSION@@/%{emacsversion}/g" %{SOURCE50} > \
218    $RPM_BUILD_ROOT%{_datadir}/applications/$(basename %{SOURCE50} .in)
219[ -f $RPM_BUILD_ROOT%{_datadir}/applications/emacs.desktop ] && \
220    %__rm -f $RPM_BUILD_ROOT%{_datadir}/applications/emacs.desktop || exit 1
221
222# install icons
223%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/icons
224%__cp -a etc/images/icons/hicolor $RPM_BUILD_ROOT%{_datadir}/icons/
225
226## remove man files
227%__rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/* || exit 1
228
229## Remove ctags
230#rm -f $RPM_BUILD_ROOT/usr/bin/ctags
231#rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/*ctags*
232#rm -f $RPM_BUILD_ROOT/%{_datadir}/emacs/%{version}/etc/ctags*
233
234DIR="${RPM_BUILD_ROOT}%{_datadir}/emacs \
235     ${RPM_BUILD_ROOT}%{_datadir}/emacs-%{version}"
236BIN=${RPM_BUILD_ROOT}%{_bindir}
237LIB=${RPM_BUILD_ROOT}%{_libdir}
238EL="*.el"
239
240## prepare file list for emacs
241echo "/usr/bin/ctags
242/usr/bin/ebrowse
243/usr/bin/etags
244/usr/bin/rcs-checkin
245/usr/bin/emacs
246/usr/bin/emacsclient
247/usr/bin/grep-changelog
248/usr/share/icons/hicolor/scalable/apps/emacs.svg
249/usr/share/icons/hicolor/scalable/mimetypes/emacs-document.svg" |
250    %__sed -e "s#[^\n]*#mv ${RPM_BUILD_ROOT}\0 ${RPM_BUILD_ROOT}\0.emacs-%{version}#"|
251    awk '{system($_)}'
252
253find $DIR $BIN $LIB -type d |
254  %__sed -e "s#^${RPM_BUILD_ROOT}#%dir #" > rpm-files
255
256find $DIR $BIN $LIB -type f -o -type l |
257  %__sed -e "
258    s#^${RPM_BUILD_ROOT}\(.*movemail\)#%attr(2755, root, mail) \1#
259    s#^${RPM_BUILD_ROOT}##
260  " >> rpm-files
261
262
263%clean
264[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
265
266
267%define info_files ccmode cl dired-x ediff emacs forms gnus info message mh-e reftex sc vip viper widget
268
269
270%pre
271
272if [ -L %{_datadir}/emacs-%{version}/site-lisp ] ; then
273    %__rm -f %{_datadir}/emacs-%{version}/site-lisp
274fi
275
276if [ -d %{_datadir}/emacs/%{version}/site-lisp ] ; then
277    find %{_datadir}/emacs/%{version}/site-lisp/* -maxdepth 0 | grep -v subdirs.el | \
278        xargs %__rm -rf
279fi
280
281
282%post
283touch --no-create %{_datadir}/icons/hicolor
284if [ -x %{_bindir}/gtk-update-icon-cache ]; then
285   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
286fi
287%{_bindir}/update-desktop-database %{_datadir}/applications &>/dev/null ||:
288
289if [ "$1" = 1 ]; then
290
291%_addflavorslist emacs-%{version}
292
293export PRIORITY=50
294
295%_installemacs emacs-%{version}
296
297unset PRIORITY
298fi
299
300if [ "$1" = 2 ]; then
301
302#  export PRIORITY=50
303 
304#  %_installemacs emacs-%{version}
305 
306#  unset PRIORITY
307   
308  echo emacs-%{version} >  /var/lib/emacsen-common/doinstaflavor-emacs
309   
310fi
311
312
313%postun
314%{_bindir}/update-desktop-database %{_datadir}/applications &>/dev/null ||:
315touch --no-create %{_datadir}/icons/hicolor
316if [ -x %{_bindir}/gtk-update-icon-cache ]; then
317  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
318fi
319
320if [ $1 = 1 ]; then
321# run upgrade install time
322
323# old version uninstall
324
325%_removeflavorslist emacs-%{version}
326
327%_removeemacs emacs-%{version}
328
329#new version install
330if [ -f /var/lib/emacsen-common/doinstaflavor-emacs ] ; then
331
332NEWFLAVOR=$(cat /var/lib/emacsen-common/doinstaflavor-emacs)
333
334%_addflavorslist $NEWFLAVOR
335
336export PRIORITY=50
337
338%_installemacs $NEWFLAVOR
339
340unset PRIORITY
341
342%__rm -rf /var/lib/emacsen-common/doinstaflavor-emacs
343
344fi
345
346fi
347
348
349%preun
350if [ $1 = 0 ]; then
351
352%_removeflavorslist emacs-%{version}
353
354%_removeemacs emacs-%{version}
355
356fi
357
358
359%triggerpostun -- emacs23 < %{version}-%{release}
360
361%_addflavorslist emacs-%{version}
362
363export PRIORITY=50
364
365%_installemacs emacs-%{version}
366
367unset PRIORITY
368
369
370%files -f rpm-files
371%defattr(-,root,root)
372%doc INSTALL README BUGS ChangeLog COPYING
373#%doc INSTALL.BZR
374%dir %{_sysconfdir}/emacs-%{version}
375%dir %{_sysconfdir}/emacs-%{version}/site-start.d
376%{_sysconfdir}/emacs-%{version}/site-start.d/*.el
377%config(noreplace) %{_sysconfdir}/emacs/emacs25-local.el
378%{_infodir}/*
379# %{_mandir}/*/*
380%{_datadir}/applications/emacs25.desktop
381%{_datadir}/appdata/emacs.appdata.xml
382%{_datadir}/icons/hicolor/*
383# %{_datadir}/emacs-%{version}/site-lisp
384%dir %{_localstatedir}/games/emacs
385%{_localstatedir}/games/emacs/*
386
387
388%changelog
389* Tue May 29 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 25.3-1
390- update to 25.3
391- add appdata file
392
393* Mon Aug 22 2016 Munehiro Yamamoto <munepi@vinelinux.org> 25.1-1.rc2-1
394- update to Emacs 25.1 Release Candidate 2
395
396* Mon Feb  8 2016 Munehiro Yamamoto <munepi@vinelinux.org> 25.0.90-1
397- update to 25.0.90
398
399* Sun Apr 12 2015 Munehiro Yamamoto <munepi@vinelinux.org> 24.5-1
400- new upstream release
401
402* Mon Mar  9 2015 Munehiro Yamamoto <munepi@vinelinux.org> 24.4.91-1
403- update to 24.4.91
404
405* Fri Mar  6 2015 Munehiro Yamamoto <munepi@vinelinux.org> 24.4.90-1
406- update to 24.4.90
407
408* Thu Oct 23 2014 Munehiro Yamamoto <munepi@vinelinux.org> 24.4-1
409- new upstream release
410
411* Fri Aug 15 2014 Munehiro Yamamoto <munepi@vinelinux.org> 24.3.93-1
412- updated to 24.3.93
413
414* Sun Jul  6 2014 Munehiro Yamamoto <munepi@vinelinux.org> 24.3.92-1
415- updated to 24.3.92
416
417* Wed Jul 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.3.91-2
418- rebuild with ImageMagick-6.8.9.5
419
420* Mon May 12 2014 Munehiro Yamamoto <munepi@vinelinux.org> 24.3.91-1
421- updated to 24.3.91
422
423* Sun Apr 27 2014 Munehiro Yamamoto <munepi@vinelinux.org> 24.3.90-1
424- updated to 24.3.90
425
426* Tue Feb 25 2014 NAKAMURA Kenta <kenta@vinelinux.org> 24.3-5
427- rebuilt with gnutls-3.2
428
429* Mon Jan 13 2014 Munehiro Yamamoto <munepi@vinelinux.org> 24.3-4
430- rebuilt
431
432* Wed Aug 14 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.3-3
433- rebuild with ImageMagick-6.8.6.8
434
435* Sat May 11 2013 Munehiro Yamamoto <munepi@vinelinux.org> 24.3-2
436- dropped some obsolete patches
437- disable menu-tree-el
438  - added coding-system-init.el instead of menu-tree-init.el
439
440* Sat Mar 30 2013 Munehiro Yamamoto <munepi@vinelinux.org> 24.3-1
441- new upstream release
442
443* Thu Feb  7 2013 Munehiro Yamamoto <munepi@vinelinux.org> 24.2.93-1
444- updated to 24.2.93 (24.3 pretest)
445
446* Mon Jan 14 2013 Munehiro Yamamoto <munepi@vinelinux.org> 24.2.92-1
447- updated to 24.2.92 (24.3 pretest)
448
449* Sun Nov 25 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.2.90-1
450- updated to 24.2.90 (24.3 pretest)
451
452* Mon Aug 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.2-1
453- new upstream release
454
455* Sun Jun 10 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.1-1
456- new upstream release
457
458* Sat May 19 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.97-1
459- updated to 24.0.97 (24.1 pretest)
460
461* Sun Apr 29 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.96-1
462- updated to 24.0.96 (24.1 pretest)
463
464* Mon Apr  2 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.95-1
465- updated to 24.0.95 (24.1 pretest)
466
467* Sun Mar 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.0.94-2
468- rebuild with ImageMagick-6.7.5.10
469
470* Mon Feb 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.94-1
471- updated to 24.0.94 (24.1 pretest)
472
473* Tue Feb 14 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.93-2
474- use gtk as X toolkit (for vl6)
475
476* Mon Jan 30 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.93-1
477- updated to 24.0.93 (24.1 pretest)
478
479* Thu Dec  1 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.92-1
480- updated to 24.0.92 (24.1 pretest)
481
482* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.91-1
483- updated to 24.0.91 (24.1 pretest)
484
485* Thu Oct  6 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.90-2
486- set --with-x-toolkit=gtk3 (%%configure)
487  - added BuildRequires: gtk3-devel
488
489* Mon Sep 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.90-1
490- updated to 24.0.90 (24.1 pretest)
491- applied emacs-24.0.90-libs-termcap.patch
492
493* Sat Jul 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-10.20110817
494- emacs24 24.0.50 (20110817) snapshot
495- added BuildRequires: ImageMagick-devel, libSM-devel, libxml2-devel > 2.6.17
496
497* Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-9.20110604
498- emacs24 24.0.50 (20110604) snapshot
499
500* Wed Apr 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-8.20110413
501- emacs24 24.0.50 (20110413) snapshot
502
503* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-7.20110318
504- updated site-start.el
505  - defined vine-default-major-version, vine-default-minor-version,
506    vine-default-version
507  - set "ibus-el" to emacs-ime as default
508  - added ", modified for Vine Linux" to the end of emacs-build-system
509  - set "Vine _at_mark_ vinelinux.org" to report-emacs-bug-address
510
511* Sun Apr 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-6.20110318
512- fixed site-start.el
513  - do not use the macro loop (contained in the common lisp)
514
515* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-5.20110318
516- emacs24 24.0.50 (20110318) snapshot
517
518* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-4.20110222
519- emacs24 24.0.50 (20110222) snapshot
520- updated site-start.el
521  - defined the function drop-vine-default-from-load-path (regex)
522
523* Sat Jan 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-3.20110128
524- emacs24 24.0.50 (20110128) snapshot
525
526* Sun Jan 02 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-2.20110101
527- emacs24 24.0.50 (20110101) snapshot
528
529* Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-1.20101203
530- emacs24 24.0.50 (20101203) snapshot
531- applied new vine-default system
532  - updated site-start.el
533  - updated vine-default-{base,faces}.el
534  - dropped showvdefaultemacs
535    - merged to emacsen-common package as show-vine-default.sh
536  - renamed local wide configration file to emacs24-local.el
537- updated menu-tree.el to version 0.97
538- added Provides: emacs-snapshot
539
540* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-4
541- updated vine-default-base.el
542  - changed the variable next-line-add-newlines to nil (default)
543
544* Thu Sep 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-3
545- updated menu-tree.el to version 0.96
546
547* Sat Jul 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-2
548- applied some patches from Fedora
549  - Fixed handling of dual spacing fonts rhbz#599437
550  - Add patch to fix rhbz#595546 hideshow library matches wrong parenthesis
551    under certain circumstances
552  - Added a patch fixing m17n and libotf version checking (m17ncheck)
553- updated menu-tree.el to version 0.95
554- merged emacs23-vl.spec of Vine Linux 5.1
555#* Thu Apr 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-9
556#- applied security fix emacs23-CVE-2010-0825-fix-movemail-race.diff from Ubuntu
557#
558#* Fri Feb 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-8
559#- added Requires(post): emacsen-common, Requires(postun): emacsen-common
560#
561#* Fri Feb 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-7
562#- dropped BuildRequires: m17n-lib-devel
563#- added --without-m17n-flt in %%configure
564
565* Mon May 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-1
566- new upstream release
567- updated menu-tree.el to version 0.94
568- updated menu-tree-init.el.emacs23
569  - used prefer-coding-system
570
571* Wed Apr 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.96-1
572- updated to 23.1.96 (23.2 pretest)
573
574* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.95-2
575- removed /usr/share/emacs/site-lisp/subdirs.el
576
577* Sat Apr 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.95-1
578- updated to 23.1.95 (23.2 pretest)
579- added BuildRequires:
580  - atk-devel
581  - dbus-devel
582  - GConf2-devel
583  - alsa-lib-devel
584- added some configure options:
585  --with-libotf --with-m17n-flt --with-dbus --with-gconf
586
587* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.94-1
588- updated to 23.1.94
589
590* Thu Mar 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.93-1
591- updated to 23.1.93 alpha
592
593* Sat Feb 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.92-2
594- added Requires(post): emacsen-common, Requires(postun): emacsen-common
595
596* Tue Feb 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.92-1
597- update to 23.1.92 alpha
598
599* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-6
600- added BuildRequires:
601  - librsvg2-devel
602  - m17n-lib-devel
603  - libotf-devel
604
605* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-5
606- changed License to GPLv3+
607- renamed emacs23.desktop to emacs23.desktop.in
608- updated vine-default-base.el (See [vine-users:079919])
609- fixed in upstream CVS (from Fedora)
610  - fix #543046 - Using scroll bar in emacs highlights/selects text
611  - fix #542657 - emacs does not display indic text
612  - Fixed rhbz#545398 - ETags messes up filenames
613
614* Tue Sep 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-4
615- rebuilt to add signature
616
617* Wed Aug 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-3
618- added BuildRequires: nkf
619- updated menu-tree-init.el.emacs23
620  - fixed menu-tree encoding <BTS:VineLinux:766>
621- set Exec=emacs-@@EMACS_VERSION@@ in emacs23.desktop
622
623* Wed Aug 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-2
624- replaced BR: libungif-devel with BR: giflib-devel
625
626* Sat Aug 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-1
627- new upstream release
628
629* Sat Jul 25 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.0.96-2.20090714
630- updated vine-default-faces.el to sync with emacs22
631
632* Tue Jul 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.96-1.20090714
633- update to 23.0.96 (20090714) snapshot
634- update vine-default-faces.el
635  - use bash to call gconftool-2
636
637* Sat Jun 27 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-4.20090527
638- update vine-default-faces.el
639  - added \'font in default-frame-alist
640    (if \'font is already in default-frame-alist, overwrited it)
641
642* Wed Jun 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-3.20090527
643- update vine-default-faces.el:
644  - use set-frame-font
645    bacause set-default-font function is obsolete since Emacs 23.1
646    (See M-x describe-function RET set-default-font)
647
648* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-2.20090527
649- update vine-default-faces.el:
650  - set desktop-gnome-interface-monospace-font-name
651    from /desktop/gnome/interface/monospace_font_name
652  - automatically set set-default-font
653    with desktop-gnome-interface-monospace-font-name
654
655* Wed May 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.94-1.20090527
656- update to emacs-23.0.94 (20090527) snapshot
657- add --without-gpm to configure
658
659* Thu May 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-7.20090422
660- defined show-vine-default function in site-start.el
661  - added showvdefaultemacs script
662
663* Wed May 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-6.20090422
664- set PRIORITY=40
665
666* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-5.20090422
667- changed menu-tree-init.el from hard copy to symbolic link
668  on /etc/emacs-23.0.92/site-start.d
669- added %%{_mandir}/*/* in %%files section
670
671* Sat May 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-4.20090422
672- updated menu-tree.el to v0.93
673
674* Fri May 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-3.20090422
675- returned alternatives priority to 30
676  (emacs: 30, emacs22: 30)
677
678* Sun Apr 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-2.20090422
679- installed system-wide configure file in /etc/emacs
680- updated vine-default-base.el
681- changed alternatives priority from 30 to 50
682  (emacs: 50, emacs22: 30)
683
684* Wed Apr 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.92-1.20090422
685- update to emacs 23.0.92 (20090422) snapshot
686- add %%triggerpostun to fix alternatives
687
688* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.91-3.20090325
689- renamed from emacs23 to emacs (emacs-22.x would be renamed to emacs22)
690- updated default settings for Vine Linux
691  - dropped vine-default-mouse.el, vine-default-misc.el
692
693* Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.91-2.20090325
694- enable default settings for Vine Linux
695  - added site-start.el.emacs23
696  - updated site-start.el
697  - added vine-default-base.el, vine-default-faces.el, vine-default-mouse.el,
698    vine-default-misc.el
699
700* Wed Mar 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.91-1.20090325
701- emacs23 23.0.91 snapshot
702
703* Tue Sep 09 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 23.0.60-2.20080908
704- drop patch10
705- s/emacsrelese/emacsrelease/
706
707* Mon Sep 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.60-1.20080908
708- emacs23 23.0.60 snapshot
709
710* Sun Sep 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.3-1
711- new upstream release
712
713* Mon Aug 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 22.2-3
714- import security fixes from Debian
715  CVE-2008-2142: fix insecure setting of fast-lock-cache-directories
716  CVE-2008-1694: fix insecure temporary file creation in vcdiff script
717                 leading to possible symlink attacks
718
719* Wed Jun 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.2-2
720- update menu-tree.el
721- add 60menu-tree-init.el to sed coding-system and load menu-tree
722- build with xorg-x11-7.3
723  - update BuildRequires
724
725* Sun Mar 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.2-1
726- new upstream release
727
728* Wed Nov 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 22.1-0vl2
729- add Patch10000 to fix local variable processing security bypass
730  vulnerability.
731  - http://www.frsirt.com/english/advisories/2007/3715
732  - http://bugs.debian.org/449008
733
734* Mon Jun 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 22.1-0vl1
735- new upstream release
736- rename to emacs from emacs22 (emacs-21.x would be renameed to emacs21)
737- drop emcws support
738
739* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 22.0.50-0.20060403vl3
740- rebuilt with new toolchain
741
742* Sat May 06 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 22.0.50-0.20060403vl2
743- changed Group:
744
745* Mon Apr 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20060403vl1
746- update to CVS-20060403
747- update emacs22.desktop
748
749* Wed Sep 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050927vl2
750- fix site-start.el
751
752* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050927vl1
753- update to CVS-20050927
754
755* Thu Sep  8 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050907vl1
756- initial build for Vine Linux based on emacs package.
757  - emacs-22.0.50 on CVS-20050907
758
759* Sat Sep  3 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.4-0vl3
760- create site-start.d directory on %install
761
762* Thu Feb 17 2005 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.4-0vl2
763- included leim-21.4
764- update emcws-21.3-20031213.gz
765
766* Wed Feb 16 2005 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.4-0vl1
767- update
768
769* Sat Jul 24 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl7
770- rebuild with Xaw3d, add BuildRequires: Xaw3d-devel
771
772* Fri Jul 23 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl6
773- add Patch20 to fix display resolutions. (set to 96dpi)
774  (do not compute dynamically from display's size)
775
776* Tue Mar 16 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.3-0vl5
777- rebuilt with new toolchain environment
778
779* Thu Jul 17 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.3-0vl4
780- use site-start.el(reading /etc/emacs-21.3/site-start.d/*.el)
781
782* Wed May  7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 21.3-0vl3
783- add BuildPrereq: libpng >= 1.2.5
784
785* Tue Apr 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl2
786- fixed %%pre script
787
788* Tue Mar 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl1
789- new upstream release
790- remove patch14 whick included in upstream
791
792* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl11
793- add patch14 to fix frame title text encoding.
794  - http://tsukuba.m17n.org/mule-ja-archive/2002-10/msg00004.html
795
796* Tue Dec 10 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.2-0vl10
797- autoconf-2.13, not autoconf in %%setup section
798- BuildPreReq: autoconf213
799
800* Mon Dec  9 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl9
801- modifiy rpm scripts.
802
803* Mon Dec  9 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl8
804- rename to emacs
805- obsoletes emacs21 <= 21.2-0vl7, provides emacs21 = %%{version}
806
807* Sun Dec  1 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl7
808- enable menubar fontset patch (Patch103)
809
810* Sat Nov 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl6
811- add requires/buildprereq tags.
812
813* Sat Nov 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl5
814- add emcws-20021014
815
816* Sun Jul 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl4
817- removed *-mode
818
819* Sat Jul 20 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl3
820- python-mode was made pending
821- some additional *.el files was moved from "emacs/site-lisp" to
822  "emacs-(version)/site-lisp"
823
824* Sat Jul 13 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl2
825- added some sources and patches from rawhide 21.2-11 and mandrake 21.2-7mdk
826
827* Sat May 11 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.2-0vl1
828- update.
829- Package Name emacs-beta -> emacs21
830- Add Patch100,101,102, Source100(default = Disable)
831- (from http://phe.phyas.aichi-edu.ac.jp/~cyamauch/pl2.html#emacs21)
832- --infodir=%{_infodir}/emacs-21.2(VineSeed-Plus:00723)
833
834* Thu Dec 27 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl7
835- site-lisp moved under /usr/share/emacs-21.1/ (Patch11 and %%pre section)
836
837* Thu Dec 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl5
838- move /tmp -> /var/lib/emacsen-common (IP(package)C file)
839
840* Fri Nov 02 2001 Tomoya TAKA <tomoya@olive.plala.or.jp> 21.1-0vl4
841- replace patch10 with patch11, posted to gnu.emacs.bug
842  Message-Id: <jebsiza3db.fsf@sykes.suse.de>
843  (reported by ABE Yuji <cbo46560@pop12.odn.ne.jp>)
844
845* Fri Oct 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.1-0vl3
846- fixed build to fail in alpha( only apply patch0 to ppc)
847
848* Tue Oct 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl2
849- added Patch10 (thanks Kitame-san)
850
851* Mon Oct 22 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.1-0vl1
852- update to 21.1
853
854* Sun Sep 9 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.104-0vl14
855- support  shared installing otheremacsen.
856
857* Mon Jul 23 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.104-0vl3
858- update 21.0.104
859
860* Thu Jul 19 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.103-0vl2
861- support emacsen-common
862
863* Wed May 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
864- 21.0.103-0vl1
865- updated to 21.0.103
866- revamped and cleaned up spec file :-)
867- Requires: tamago >= 4.0.6 (...is it reasonable? Mmm...)
868
869* Mon Jan 22 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.95-0vl2
870- fixed .spec bugs( _libdir)
871
872* Fri Jan 12 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.95-0vl1
873- updated to 21.0.95
874
875* Wed Dec 20 2000 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.93-0vl3
876- fixed emacs-beta.spec
877
878* Sat Dec 16 2000 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.93-0vl2
879- 21.0.93 test packaging.
880
881* Fri Jun 30 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
882- added linespace-patch
883
884* Mon Jun 19 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
885- updated to emacs 20.7
886
887* Thu Apr 20 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
888- updated to emacs 20.6
889
890* Mon Feb 28 2000 kenji KITAYAMA <kenji@gandalf.doshisha.ac.jp>
891- [emacs-20.5a-2]
892- Modified reference of Emacs Info
893
894* Sun Jan 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
895- [emacs-20.5a-2]
896- added ppc patch
897
898* Fri Jan  7 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
899- [emacs-20.5a-1]
900- change version from 20.5 to 20.5a
901- added Mule-4.1 patch
902
903* Fri Jan  7 2000 Yasuyuki Furukawa <yasu@on.cs.keio.ac.jp>
904- [emacs-20.5-1]
905- add desktop-link files for desktop menu.
906
907* Fri Dec 24 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
908- [emacs-20.4-16]
909- replaced Y2K savvy timezone.{el,elc} with one from brand-new apel-10.0
910
911* Tue Dec 21 1999 Jun Nishii <jun@vinelinux.org>
912- added documents
913- strip bins
914
915* Wed Dec  1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
916- [emacs-20.4-14]
917- Change Group to Applications/Editors/Emacs
918
919* Sat Nov  6 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
920- [emacs-20.4-13]
921- included Y2K savvy timezone.{el,elc},
922  modified by Mr. Youichi Teranishi <teranishi@gohome.org>
923
924* Tue Oct 12 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
925- [emacs-20.4-12]
926- Modified info-dir.
927- Removed -c option from %setup.
928
929* Mon Sep 20 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
930- fixed XIM support patch
931* Sun Sep 19 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
932- fixed postinst bug and fontset patch
933* Sun Jul 18 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
934- first build
Note: See TracBrowser for help on using the repository browser.