source: projects/specs/trunk/e/emacs/emacs25-vl.spec @ 10750

Revision 10750, 29.9 KB checked in by munepi, 8 years ago (diff)

updated Emacs 25.1 RC2

renamed: coding-system-init.el.emacs24 -> coding-system-init.el.emacs25
renamed: emacs24-local.el -> emacs25-local.el
renamed: emacs24-vl.spec -> emacs25-vl.spec
renamed: emacs24.desktop.in -> emacs25.desktop.in
renamed: site-start.el.emacs24 -> site-start.el.emacs25

Line 
1%define emacsversion 25.1
2#% define gitcommit 20110817
3%define emacsrelease 1.rc2%{?gitcommit:.%gitcommit}%{?_dist_release}
4%define vine_default_major_version %(echo %_dist_release|%__sed s/vl//)
5
6%define _noVersionedDependencies 1
7%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
8
9%define infodir %{_infodir}/emacs-%{emacsversion}
10
11%define menutreeelversion 0.97
12
13Summary:      GNU Emacs editor
14Summary(ja):  GNU Emacs エディタ
15Name:         emacs
16#Name:         emacs25
17#Provides:     emacs-snapshot
18Version:      %{emacsversion}
19Release:      %{emacsrelease}
20#Source0:      ftp://ftp.gnu.org/pub/gnu/emacs/emacs-%{version}.tar.xz
21#Source0:      ftp://ftp.gnu.org/pub/gnu/emacs/emacs-%{version}%{?gitcommit:.git%gitcommit}.tar.xz
22Source0:      ftp://alpha.gnu.org/gnu/emacs/pretest/emacs-%{emacsversion}-rc2.tar.xz
23#Source1:      emacs-snapshot.sh
24
25Source10:     site-start.el.emacs25
26
27## local settings for local system
28Source20:     emacs25-local.el
29
30# desktop file
31Source50:     emacs25.desktop.in
32
33## Enable Japanese Menu
34## http://www11.atwiki.jp/s-irie/pages/13.html
35# Source100:    menu-tree-el-%{menutreeelversion}.tar.gz
36# Source101:    menu-tree-init.el.emacs25
37Source102:    coding-system-init.el.emacs25
38
39## default settings for Vine Linux
40Source150:    vine-default-base.el
41
42## Vine Patch(es)
43Patch11:      emacs-24.3.90-locallisppath.patch
44#Patch20:      emacs-23.1.90-fixed-resolution.patch
45Patch30:      emacs-24.0.90-libs-termcap.patch
46
47# patches from Fedora
48# rhbz#713600
49Patch107: emacs-spellchecker.patch
50
51# security patches (from Debian)
52
53#Patch1001:    emacs-21.1-bzip2.patch.bz2
54
55License:      GPLv3+
56Group:        Applications/Editors/Emacs
57
58Distribution: Vine Linux
59Vendor:       Project Vine
60Packager:     munepi, daisuke
61
62BuildRoot:    %{_tmppath}/%{name}-%{version}-root
63# Requires:     tamago >= 4.0.6
64Obsoletes:    mule-base, mule-canna, mule-wnn6, mule, emacs-beta
65Obsoletes:    emacs21 <= 21.2-0vl7
66Obsoletes:    emacs22 <= 22.1
67Obsoletes:    emacs23 <= 23.1
68Obsoletes:    emacs24 <= 24.1
69# Obsoletes:    emacs25 <= 25.1
70Provides:     emacs25 = %{version}
71Provides:     emacsen = 0.1
72#% prereq_ge    emacsen-common
73Requires(post):    emacsen-common
74Requires(postun):    emacsen-common
75
76BuildRequires: autoconf
77BuildRequires: xz
78BuildRequires: atk-devel
79BuildRequires: dbus-devel GConf2-devel
80BuildRequires: alsa-lib-devel
81BuildRequires: gnutls-devel
82#if %{?_dist_release} >= "vl7"
83#BuildRequires: gtk3-devel
84#else
85BuildRequires: gtk2-devel
86#endif
87BuildRequires: cairo-devel
88BuildRequires: freetype2-devel, fontconfig-devel
89BuildRequires: libpng-devel, libjpeg-devel, libtiff-devel, libungif-devel
90BuildRequires: librsvg2-devel, libotf-devel
91BuildRequires: ImageMagick-devel
92BuildRequires: libxml2-devel > 2.6.17
93BuildRequires: m17n-lib-devel
94BuildRequires: libX11-devel, libXau-devel, libXdmcp-devel, libXrender-devel
95BuildRequires: libSM-devel, libXt-devel, libXpm-devel, ncurses-devel
96BuildRequires: xorg-x11-proto-devel, zlib-devel
97BuildRequires: texinfo
98BuildRequires: nkf
99
100%description
101GNU Emacs is the extensible, customizable, self-documenting real-time
102display editor.
103
104%description -l ja
105GNU Emacs は拡張性が高く、さまざまなカスタマイズが可能な高機能エディタです。
106
107
108%prep
109
110%setup -q -n emacs-%{version}
111
112%patch11 -p1
113#%patch20 -p1
114#%patch30 -p1
115
116%patch107 -p1 -b .spellchecker
117
118#%patch1001 -p1
119
120
121# Avoid trademark issues
122grep -v "tetris.elc" lisp/Makefile.in > lisp/Makefile.in.new \
123   && %__mv lisp/Makefile.in.new lisp/Makefile.in || exit 1
124%__rm -f lisp/play/tetris.el lisp/play/tetris.elc || exit 1
125
126#autoconf
127autoreconf -i -I m4
128
129%build
130export CFLAGS="-DMAIL_USE_LOCKF $RPM_OPT_FLAGS"
131#to find installinfo
132export PATH="$PATH:/sbin:/usr/sbin"
133
134%configure --with-pop --with-sound \
135    --libexecdir=%{_libdir} --infodir=%{infodir} \
136    --disable-rename \
137    --with-x-toolkit=gtk \
138    --with-freetype --with-xft \
139    --enable-font-backend \
140    --without-gpm \
141    --with-libotf \
142    --with-m17n-flt \
143    --with-dbus --with-gconf \
144    ;
145#    --with-x-toolkit=gtk3 \
146
147%__make bootstrap
148%__make %{?_smp_mflags}
149
150
151%install
152[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
153
154%makeinstall libexecdir=$RPM_BUILD_ROOT%{_libdir} \
155        infodir=${RPM_BUILD_ROOT}%{infodir}
156
157## This is a duplicate of the file in FLAVOR/site-lisp
158%__rm -f $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/subdirs.el || exit 1
159
160# (cd $RPM_BUILD_ROOT%{_mandir}/man1/; %__mv ctags.1 gctags.1)
161# (cd $RPM_BUILD_ROOT%{_bindir}/; %__mv ctags gctags)
162
163%__mkdir_p  $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/etc
164%__mkdir_p  $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp
165# %__tar zxvf %{SOURCE100}
166# %__cp -a menu-tree-el-%{menutreeelversion}/menu-tree.el $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/
167# nkf -w --overwrite $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/menu-tree.el
168
169## vine default
170%__cp -a %{SOURCE150} \
171    $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/
172
173# The elisp reference manual
174#bzcat %{SOURCE13} | tar xf -
175#pushd elisp-manual-21-2.8
176#install -m 644 elisp elisp-? elisp-?? $RPM_BUILD_ROOT/%{infodir}
177#popd
178
179# some modifications of installed files
180
181#rm -f $RPM_BUILD_ROOT%{infodir}/dir
182#gzip -9nf $RPM_BUILD_ROOT%{infodir}/*
183
184%__install -m 644 %{SOURCE10} \
185        $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/site-start.el
186%__sed -i -e 's/EMACS_VERSION/%{version}/g' \
187          -e 's/VINE_DEFAULT_MAJOR_VERSION/%{vine_default_major_version}/g' \
188        $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/site-start.el
189
190## create site-start.d directory
191%__install -m 755 -d ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d
192
193# install coding-system init.el
194# %__install -m644 %{SOURCE101} \
195#     $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/menu-tree-init.el
196# %__ln_s -f %{_datadir}/emacs-%{version}/site-lisp/menu-tree-init.el \
197#     ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d/60menu-tree-init.el
198%__install -m644 %{SOURCE102} \
199    $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/coding-system-init.el
200%__ln_s -f %{_datadir}/emacs-%{version}/site-lisp/coding-system-init.el \
201    ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d/60coding-system-init.el
202
203## install system-wide configure file
204%__install -m755 -d ${RPM_BUILD_ROOT}/etc/emacs
205%__install -m644 %{SOURCE20} ${RPM_BUILD_ROOT}/etc/emacs/emacs25-local.el
206%__sed -i -e 's/EMACS_VERSION/%{version}/g' \
207    ${RPM_BUILD_ROOT}/etc/emacs/emacs25-local.el
208
209## Python mode, php mode and rpm-spec mode
210
211## make file list
212strip $RPM_BUILD_ROOT%{_bindir}/* || :
213
214# install desktop file
215%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/applications
216%__sed -e "s/@@EMACS_VERSION@@/%{emacsversion}/g" %{SOURCE50} > \
217    $RPM_BUILD_ROOT%{_datadir}/applications/$(basename %{SOURCE50} .in)
218[ -f $RPM_BUILD_ROOT%{_datadir}/applications/emacs.desktop ] && \
219    %__rm -f $RPM_BUILD_ROOT%{_datadir}/applications/emacs.desktop || exit 1
220
221# install icons
222%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/icons
223%__cp -a etc/images/icons/hicolor $RPM_BUILD_ROOT%{_datadir}/icons/
224
225## remove man files
226%__rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/* || exit 1
227
228## Remove ctags
229#rm -f $RPM_BUILD_ROOT/usr/bin/ctags
230#rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/*ctags*
231#rm -f $RPM_BUILD_ROOT/%{_datadir}/emacs/%{version}/etc/ctags*
232
233DIR="${RPM_BUILD_ROOT}%{_datadir}/emacs \
234     ${RPM_BUILD_ROOT}%{_datadir}/emacs-%{version}"
235BIN=${RPM_BUILD_ROOT}%{_bindir}
236LIB=${RPM_BUILD_ROOT}%{_libdir}
237EL="*.el"
238
239## prepare file list for emacs
240echo "/usr/bin/ctags
241/usr/bin/ebrowse
242/usr/bin/etags
243/usr/bin/rcs-checkin
244/usr/bin/emacs
245/usr/bin/emacsclient
246/usr/bin/grep-changelog
247/usr/share/icons/hicolor/scalable/apps/emacs.svg
248/usr/share/icons/hicolor/scalable/mimetypes/emacs-document.svg" |
249    %__sed -e "s#[^\n]*#mv ${RPM_BUILD_ROOT}\0 ${RPM_BUILD_ROOT}\0.emacs-%{version}#"|
250    awk '{system($_)}'
251
252find $DIR $BIN $LIB -type d |
253  %__sed -e "s#^${RPM_BUILD_ROOT}#%dir #" > rpm-files
254
255find $DIR $BIN $LIB -type f -o -type l |
256  %__sed -e "
257    s#^${RPM_BUILD_ROOT}\(.*movemail\)#%attr(2755, root, mail) \1#
258    s#^${RPM_BUILD_ROOT}##
259  " >> rpm-files
260
261
262%clean
263[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
264
265
266%define info_files ccmode cl dired-x ediff emacs forms gnus info message mh-e reftex sc vip viper widget
267
268
269%pre
270
271if [ -L %{_datadir}/emacs-%{version}/site-lisp ] ; then
272    %__rm -f %{_datadir}/emacs-%{version}/site-lisp
273fi
274
275if [ -d %{_datadir}/emacs/%{version}/site-lisp ] ; then
276    find %{_datadir}/emacs/%{version}/site-lisp/* -maxdepth 0 | grep -v subdirs.el | \
277        xargs %__rm -rf
278fi
279
280
281%post
282touch --no-create %{_datadir}/icons/hicolor
283if [ -x %{_bindir}/gtk-update-icon-cache ]; then
284   %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
285fi
286%{_bindir}/update-desktop-database %{_datadir}/applications &>/dev/null ||:
287
288if [ "$1" = 1 ]; then
289
290%_addflavorslist emacs-%{version}
291
292export PRIORITY=50
293
294%_installemacs emacs-%{version}
295
296unset PRIORITY
297fi
298
299if [ "$1" = 2 ]; then
300
301#  export PRIORITY=50
302 
303#  %_installemacs emacs-%{version}
304 
305#  unset PRIORITY
306   
307  echo emacs-%{version} >  /var/lib/emacsen-common/doinstaflavor-emacs
308   
309fi
310
311
312%postun
313%{_bindir}/update-desktop-database %{_datadir}/applications &>/dev/null ||:
314touch --no-create %{_datadir}/icons/hicolor
315if [ -x %{_bindir}/gtk-update-icon-cache ]; then
316  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
317fi
318
319if [ $1 = 1 ]; then
320# run upgrade install time
321
322# old version uninstall
323
324%_removeflavorslist emacs-%{version}
325
326%_removeemacs emacs-%{version}
327
328#new version install
329if [ -f /var/lib/emacsen-common/doinstaflavor-emacs ] ; then
330
331NEWFLAVOR=$(cat /var/lib/emacsen-common/doinstaflavor-emacs)
332
333%_addflavorslist $NEWFLAVOR
334
335export PRIORITY=50
336
337%_installemacs $NEWFLAVOR
338
339unset PRIORITY
340
341%__rm -rf /var/lib/emacsen-common/doinstaflavor-emacs
342
343fi
344
345fi
346
347
348%preun
349if [ $1 = 0 ]; then
350
351%_removeflavorslist emacs-%{version}
352
353%_removeemacs emacs-%{version}
354
355fi
356
357
358%triggerpostun -- emacs23 < %{version}-%{release}
359
360%_addflavorslist emacs-%{version}
361
362export PRIORITY=50
363
364%_installemacs emacs-%{version}
365
366unset PRIORITY
367
368
369%files -f rpm-files
370%defattr(-,root,root)
371%doc INSTALL README BUGS ChangeLog COPYING
372#%doc INSTALL.BZR
373%dir %{_sysconfdir}/emacs-%{version}
374%dir %{_sysconfdir}/emacs-%{version}/site-start.d
375%{_sysconfdir}/emacs-%{version}/site-start.d/*.el
376%config(noreplace) %{_sysconfdir}/emacs/emacs25-local.el
377%{_infodir}/*
378# %{_mandir}/*/*
379%{_datadir}/applications/emacs25.desktop
380%{_datadir}/icons/hicolor/*
381# %{_datadir}/emacs-%{version}/site-lisp
382%dir %{_localstatedir}/games/emacs
383%{_localstatedir}/games/emacs/*
384
385
386%changelog
387* Mon Aug 22 2016 Munehiro Yamamoto <munepi@vinelinux.org> 25.1-1.rc2-1
388- update to Emacs 25.1 Release Candidate 2
389
390* Mon Feb  8 2016 Munehiro Yamamoto <munepi@vinelinux.org> 25.0.90-1
391- update to 25.0.90
392
393* Sun Apr 12 2015 Munehiro Yamamoto <munepi@vinelinux.org> 24.5-1
394- new upstream release
395
396* Mon Mar  9 2015 Munehiro Yamamoto <munepi@vinelinux.org> 24.4.91-1
397- update to 24.4.91
398
399* Fri Mar  6 2015 Munehiro Yamamoto <munepi@vinelinux.org> 24.4.90-1
400- update to 24.4.90
401
402* Thu Oct 23 2014 Munehiro Yamamoto <munepi@vinelinux.org> 24.4-1
403- new upstream release
404
405* Fri Aug 15 2014 Munehiro Yamamoto <munepi@vinelinux.org> 24.3.93-1
406- updated to 24.3.93
407
408* Sun Jul  6 2014 Munehiro Yamamoto <munepi@vinelinux.org> 24.3.92-1
409- updated to 24.3.92
410
411* Wed Jul 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.3.91-2
412- rebuild with ImageMagick-6.8.9.5
413
414* Mon May 12 2014 Munehiro Yamamoto <munepi@vinelinux.org> 24.3.91-1
415- updated to 24.3.91
416
417* Sun Apr 27 2014 Munehiro Yamamoto <munepi@vinelinux.org> 24.3.90-1
418- updated to 24.3.90
419
420* Tue Feb 25 2014 NAKAMURA Kenta <kenta@vinelinux.org> 24.3-5
421- rebuilt with gnutls-3.2
422
423* Mon Jan 13 2014 Munehiro Yamamoto <munepi@vinelinux.org> 24.3-4
424- rebuilt
425
426* Wed Aug 14 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.3-3
427- rebuild with ImageMagick-6.8.6.8
428
429* Sat May 11 2013 Munehiro Yamamoto <munepi@vinelinux.org> 24.3-2
430- dropped some obsolete patches
431- disable menu-tree-el
432  - added coding-system-init.el instead of menu-tree-init.el
433
434* Sat Mar 30 2013 Munehiro Yamamoto <munepi@vinelinux.org> 24.3-1
435- new upstream release
436
437* Thu Feb  7 2013 Munehiro Yamamoto <munepi@vinelinux.org> 24.2.93-1
438- updated to 24.2.93 (24.3 pretest)
439
440* Mon Jan 14 2013 Munehiro Yamamoto <munepi@vinelinux.org> 24.2.92-1
441- updated to 24.2.92 (24.3 pretest)
442
443* Sun Nov 25 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.2.90-1
444- updated to 24.2.90 (24.3 pretest)
445
446* Mon Aug 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.2-1
447- new upstream release
448
449* Sun Jun 10 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.1-1
450- new upstream release
451
452* Sat May 19 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.97-1
453- updated to 24.0.97 (24.1 pretest)
454
455* Sun Apr 29 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.96-1
456- updated to 24.0.96 (24.1 pretest)
457
458* Mon Apr  2 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.95-1
459- updated to 24.0.95 (24.1 pretest)
460
461* Sun Mar 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.0.94-2
462- rebuild with ImageMagick-6.7.5.10
463
464* Mon Feb 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.94-1
465- updated to 24.0.94 (24.1 pretest)
466
467* Tue Feb 14 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.93-2
468- use gtk as X toolkit (for vl6)
469
470* Mon Jan 30 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.93-1
471- updated to 24.0.93 (24.1 pretest)
472
473* Thu Dec  1 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.92-1
474- updated to 24.0.92 (24.1 pretest)
475
476* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.91-1
477- updated to 24.0.91 (24.1 pretest)
478
479* Thu Oct  6 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.90-2
480- set --with-x-toolkit=gtk3 (%%configure)
481  - added BuildRequires: gtk3-devel
482
483* Mon Sep 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.90-1
484- updated to 24.0.90 (24.1 pretest)
485- applied emacs-24.0.90-libs-termcap.patch
486
487* Sat Jul 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-10.20110817
488- emacs24 24.0.50 (20110817) snapshot
489- added BuildRequires: ImageMagick-devel, libSM-devel, libxml2-devel > 2.6.17
490
491* Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-9.20110604
492- emacs24 24.0.50 (20110604) snapshot
493
494* Wed Apr 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-8.20110413
495- emacs24 24.0.50 (20110413) snapshot
496
497* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-7.20110318
498- updated site-start.el
499  - defined vine-default-major-version, vine-default-minor-version,
500    vine-default-version
501  - set "ibus-el" to emacs-ime as default
502  - added ", modified for Vine Linux" to the end of emacs-build-system
503  - set "Vine _at_mark_ vinelinux.org" to report-emacs-bug-address
504
505* Sun Apr 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-6.20110318
506- fixed site-start.el
507  - do not use the macro loop (contained in the common lisp)
508
509* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-5.20110318
510- emacs24 24.0.50 (20110318) snapshot
511
512* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-4.20110222
513- emacs24 24.0.50 (20110222) snapshot
514- updated site-start.el
515  - defined the function drop-vine-default-from-load-path (regex)
516
517* Sat Jan 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-3.20110128
518- emacs24 24.0.50 (20110128) snapshot
519
520* Sun Jan 02 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-2.20110101
521- emacs24 24.0.50 (20110101) snapshot
522
523* Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-1.20101203
524- emacs24 24.0.50 (20101203) snapshot
525- applied new vine-default system
526  - updated site-start.el
527  - updated vine-default-{base,faces}.el
528  - dropped showvdefaultemacs
529    - merged to emacsen-common package as show-vine-default.sh
530  - renamed local wide configration file to emacs24-local.el
531- updated menu-tree.el to version 0.97
532- added Provides: emacs-snapshot
533
534* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-4
535- updated vine-default-base.el
536  - changed the variable next-line-add-newlines to nil (default)
537
538* Thu Sep 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-3
539- updated menu-tree.el to version 0.96
540
541* Sat Jul 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-2
542- applied some patches from Fedora
543  - Fixed handling of dual spacing fonts rhbz#599437
544  - Add patch to fix rhbz#595546 hideshow library matches wrong parenthesis
545    under certain circumstances
546  - Added a patch fixing m17n and libotf version checking (m17ncheck)
547- updated menu-tree.el to version 0.95
548- merged emacs23-vl.spec of Vine Linux 5.1
549#* Thu Apr 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-9
550#- applied security fix emacs23-CVE-2010-0825-fix-movemail-race.diff from Ubuntu
551#
552#* Fri Feb 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-8
553#- added Requires(post): emacsen-common, Requires(postun): emacsen-common
554#
555#* Fri Feb 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-7
556#- dropped BuildRequires: m17n-lib-devel
557#- added --without-m17n-flt in %%configure
558
559* Mon May 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-1
560- new upstream release
561- updated menu-tree.el to version 0.94
562- updated menu-tree-init.el.emacs23
563  - used prefer-coding-system
564
565* Wed Apr 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.96-1
566- updated to 23.1.96 (23.2 pretest)
567
568* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.95-2
569- removed /usr/share/emacs/site-lisp/subdirs.el
570
571* Sat Apr 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.95-1
572- updated to 23.1.95 (23.2 pretest)
573- added BuildRequires:
574  - atk-devel
575  - dbus-devel
576  - GConf2-devel
577  - alsa-lib-devel
578- added some configure options:
579  --with-libotf --with-m17n-flt --with-dbus --with-gconf
580
581* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.94-1
582- updated to 23.1.94
583
584* Thu Mar 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.93-1
585- updated to 23.1.93 alpha
586
587* Sat Feb 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.92-2
588- added Requires(post): emacsen-common, Requires(postun): emacsen-common
589
590* Tue Feb 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.92-1
591- update to 23.1.92 alpha
592
593* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-6
594- added BuildRequires:
595  - librsvg2-devel
596  - m17n-lib-devel
597  - libotf-devel
598
599* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-5
600- changed License to GPLv3+
601- renamed emacs23.desktop to emacs23.desktop.in
602- updated vine-default-base.el (See [vine-users:079919])
603- fixed in upstream CVS (from Fedora)
604  - fix #543046 - Using scroll bar in emacs highlights/selects text
605  - fix #542657 - emacs does not display indic text
606  - Fixed rhbz#545398 - ETags messes up filenames
607
608* Tue Sep 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-4
609- rebuilt to add signature
610
611* Wed Aug 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-3
612- added BuildRequires: nkf
613- updated menu-tree-init.el.emacs23
614  - fixed menu-tree encoding <BTS:VineLinux:766>
615- set Exec=emacs-@@EMACS_VERSION@@ in emacs23.desktop
616
617* Wed Aug 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-2
618- replaced BR: libungif-devel with BR: giflib-devel
619
620* Sat Aug 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-1
621- new upstream release
622
623* Sat Jul 25 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.0.96-2.20090714
624- updated vine-default-faces.el to sync with emacs22
625
626* Tue Jul 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.96-1.20090714
627- update to 23.0.96 (20090714) snapshot
628- update vine-default-faces.el
629  - use bash to call gconftool-2
630
631* Sat Jun 27 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-4.20090527
632- update vine-default-faces.el
633  - added \'font in default-frame-alist
634    (if \'font is already in default-frame-alist, overwrited it)
635
636* Wed Jun 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-3.20090527
637- update vine-default-faces.el:
638  - use set-frame-font
639    bacause set-default-font function is obsolete since Emacs 23.1
640    (See M-x describe-function RET set-default-font)
641
642* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-2.20090527
643- update vine-default-faces.el:
644  - set desktop-gnome-interface-monospace-font-name
645    from /desktop/gnome/interface/monospace_font_name
646  - automatically set set-default-font
647    with desktop-gnome-interface-monospace-font-name
648
649* Wed May 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.94-1.20090527
650- update to emacs-23.0.94 (20090527) snapshot
651- add --without-gpm to configure
652
653* Thu May 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-7.20090422
654- defined show-vine-default function in site-start.el
655  - added showvdefaultemacs script
656
657* Wed May 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-6.20090422
658- set PRIORITY=40
659
660* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-5.20090422
661- changed menu-tree-init.el from hard copy to symbolic link
662  on /etc/emacs-23.0.92/site-start.d
663- added %%{_mandir}/*/* in %%files section
664
665* Sat May 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-4.20090422
666- updated menu-tree.el to v0.93
667
668* Fri May 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-3.20090422
669- returned alternatives priority to 30
670  (emacs: 30, emacs22: 30)
671
672* Sun Apr 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-2.20090422
673- installed system-wide configure file in /etc/emacs
674- updated vine-default-base.el
675- changed alternatives priority from 30 to 50
676  (emacs: 50, emacs22: 30)
677
678* Wed Apr 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.92-1.20090422
679- update to emacs 23.0.92 (20090422) snapshot
680- add %%triggerpostun to fix alternatives
681
682* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.91-3.20090325
683- renamed from emacs23 to emacs (emacs-22.x would be renamed to emacs22)
684- updated default settings for Vine Linux
685  - dropped vine-default-mouse.el, vine-default-misc.el
686
687* Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.91-2.20090325
688- enable default settings for Vine Linux
689  - added site-start.el.emacs23
690  - updated site-start.el
691  - added vine-default-base.el, vine-default-faces.el, vine-default-mouse.el,
692    vine-default-misc.el
693
694* Wed Mar 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.91-1.20090325
695- emacs23 23.0.91 snapshot
696
697* Tue Sep 09 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 23.0.60-2.20080908
698- drop patch10
699- s/emacsrelese/emacsrelease/
700
701* Mon Sep 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.60-1.20080908
702- emacs23 23.0.60 snapshot
703
704* Sun Sep 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.3-1
705- new upstream release
706
707* Mon Aug 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 22.2-3
708- import security fixes from Debian
709  CVE-2008-2142: fix insecure setting of fast-lock-cache-directories
710  CVE-2008-1694: fix insecure temporary file creation in vcdiff script
711                 leading to possible symlink attacks
712
713* Wed Jun 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.2-2
714- update menu-tree.el
715- add 60menu-tree-init.el to sed coding-system and load menu-tree
716- build with xorg-x11-7.3
717  - update BuildRequires
718
719* Sun Mar 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.2-1
720- new upstream release
721
722* Wed Nov 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 22.1-0vl2
723- add Patch10000 to fix local variable processing security bypass
724  vulnerability.
725  - http://www.frsirt.com/english/advisories/2007/3715
726  - http://bugs.debian.org/449008
727
728* Mon Jun 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 22.1-0vl1
729- new upstream release
730- rename to emacs from emacs22 (emacs-21.x would be renameed to emacs21)
731- drop emcws support
732
733* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 22.0.50-0.20060403vl3
734- rebuilt with new toolchain
735
736* Sat May 06 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 22.0.50-0.20060403vl2
737- changed Group:
738
739* Mon Apr 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20060403vl1
740- update to CVS-20060403
741- update emacs22.desktop
742
743* Wed Sep 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050927vl2
744- fix site-start.el
745
746* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050927vl1
747- update to CVS-20050927
748
749* Thu Sep  8 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050907vl1
750- initial build for Vine Linux based on emacs package.
751  - emacs-22.0.50 on CVS-20050907
752
753* Sat Sep  3 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.4-0vl3
754- create site-start.d directory on %install
755
756* Thu Feb 17 2005 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.4-0vl2
757- included leim-21.4
758- update emcws-21.3-20031213.gz
759
760* Wed Feb 16 2005 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.4-0vl1
761- update
762
763* Sat Jul 24 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl7
764- rebuild with Xaw3d, add BuildRequires: Xaw3d-devel
765
766* Fri Jul 23 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl6
767- add Patch20 to fix display resolutions. (set to 96dpi)
768  (do not compute dynamically from display's size)
769
770* Tue Mar 16 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.3-0vl5
771- rebuilt with new toolchain environment
772
773* Thu Jul 17 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.3-0vl4
774- use site-start.el(reading /etc/emacs-21.3/site-start.d/*.el)
775
776* Wed May  7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 21.3-0vl3
777- add BuildPrereq: libpng >= 1.2.5
778
779* Tue Apr 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl2
780- fixed %%pre script
781
782* Tue Mar 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl1
783- new upstream release
784- remove patch14 whick included in upstream
785
786* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl11
787- add patch14 to fix frame title text encoding.
788  - http://tsukuba.m17n.org/mule-ja-archive/2002-10/msg00004.html
789
790* Tue Dec 10 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.2-0vl10
791- autoconf-2.13, not autoconf in %%setup section
792- BuildPreReq: autoconf213
793
794* Mon Dec  9 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl9
795- modifiy rpm scripts.
796
797* Mon Dec  9 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl8
798- rename to emacs
799- obsoletes emacs21 <= 21.2-0vl7, provides emacs21 = %%{version}
800
801* Sun Dec  1 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl7
802- enable menubar fontset patch (Patch103)
803
804* Sat Nov 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl6
805- add requires/buildprereq tags.
806
807* Sat Nov 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl5
808- add emcws-20021014
809
810* Sun Jul 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl4
811- removed *-mode
812
813* Sat Jul 20 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl3
814- python-mode was made pending
815- some additional *.el files was moved from "emacs/site-lisp" to
816  "emacs-(version)/site-lisp"
817
818* Sat Jul 13 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl2
819- added some sources and patches from rawhide 21.2-11 and mandrake 21.2-7mdk
820
821* Sat May 11 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.2-0vl1
822- update.
823- Package Name emacs-beta -> emacs21
824- Add Patch100,101,102, Source100(default = Disable)
825- (from http://phe.phyas.aichi-edu.ac.jp/~cyamauch/pl2.html#emacs21)
826- --infodir=%{_infodir}/emacs-21.2(VineSeed-Plus:00723)
827
828* Thu Dec 27 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl7
829- site-lisp moved under /usr/share/emacs-21.1/ (Patch11 and %%pre section)
830
831* Thu Dec 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl5
832- move /tmp -> /var/lib/emacsen-common (IP(package)C file)
833
834* Fri Nov 02 2001 Tomoya TAKA <tomoya@olive.plala.or.jp> 21.1-0vl4
835- replace patch10 with patch11, posted to gnu.emacs.bug
836  Message-Id: <jebsiza3db.fsf@sykes.suse.de>
837  (reported by ABE Yuji <cbo46560@pop12.odn.ne.jp>)
838
839* Fri Oct 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.1-0vl3
840- fixed build to fail in alpha( only apply patch0 to ppc)
841
842* Tue Oct 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl2
843- added Patch10 (thanks Kitame-san)
844
845* Mon Oct 22 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.1-0vl1
846- update to 21.1
847
848* Sun Sep 9 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.104-0vl14
849- support  shared installing otheremacsen.
850
851* Mon Jul 23 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.104-0vl3
852- update 21.0.104
853
854* Thu Jul 19 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.103-0vl2
855- support emacsen-common
856
857* Wed May 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
858- 21.0.103-0vl1
859- updated to 21.0.103
860- revamped and cleaned up spec file :-)
861- Requires: tamago >= 4.0.6 (...is it reasonable? Mmm...)
862
863* Mon Jan 22 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.95-0vl2
864- fixed .spec bugs( _libdir)
865
866* Fri Jan 12 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.95-0vl1
867- updated to 21.0.95
868
869* Wed Dec 20 2000 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.93-0vl3
870- fixed emacs-beta.spec
871
872* Sat Dec 16 2000 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.93-0vl2
873- 21.0.93 test packaging.
874
875* Fri Jun 30 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
876- added linespace-patch
877
878* Mon Jun 19 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
879- updated to emacs 20.7
880
881* Thu Apr 20 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
882- updated to emacs 20.6
883
884* Mon Feb 28 2000 kenji KITAYAMA <kenji@gandalf.doshisha.ac.jp>
885- [emacs-20.5a-2]
886- Modified reference of Emacs Info
887
888* Sun Jan 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
889- [emacs-20.5a-2]
890- added ppc patch
891
892* Fri Jan  7 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
893- [emacs-20.5a-1]
894- change version from 20.5 to 20.5a
895- added Mule-4.1 patch
896
897* Fri Jan  7 2000 Yasuyuki Furukawa <yasu@on.cs.keio.ac.jp>
898- [emacs-20.5-1]
899- add desktop-link files for desktop menu.
900
901* Fri Dec 24 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
902- [emacs-20.4-16]
903- replaced Y2K savvy timezone.{el,elc} with one from brand-new apel-10.0
904
905* Tue Dec 21 1999 Jun Nishii <jun@vinelinux.org>
906- added documents
907- strip bins
908
909* Wed Dec  1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
910- [emacs-20.4-14]
911- Change Group to Applications/Editors/Emacs
912
913* Sat Nov  6 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
914- [emacs-20.4-13]
915- included Y2K savvy timezone.{el,elc},
916  modified by Mr. Youichi Teranishi <teranishi@gohome.org>
917
918* Tue Oct 12 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
919- [emacs-20.4-12]
920- Modified info-dir.
921- Removed -c option from %setup.
922
923* Mon Sep 20 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
924- fixed XIM support patch
925* Sun Sep 19 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
926- fixed postinst bug and fontset patch
927* Sun Jul 18 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
928- first build
Note: See TracBrowser for help on using the repository browser.