source: projects/specs/trunk/e/emacs/emacs24-vl.spec @ 8721

Revision 8721, 28.6 KB checked in by Takemikaduchi, 10 years ago (diff)

cinnamon-2.2.14, python-2.7.7, ImageMagick?-6.8.9.5

Line 
1%define emacsversion 24.3.91
2#% define gitdate 20110817
3%define emacsrelease 2%{?gitdate:.%gitdate}%{?_dist_release}
4%define vine_default_major_version %(echo %_dist_release|%__sed s/vl//)
5
6%define _noVersionedDependencies 1
7%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
8
9%define infodir %{_infodir}/emacs-%{emacsversion}
10
11%define menutreeelversion 0.97
12
13Summary:      GNU Emacs editor
14Summary(ja):  GNU Emacs エディタ
15Name:         emacs
16#Name:         emacs24
17#Provides:     emacs-snapshot
18Version:      %{emacsversion}
19Release:      %{emacsrelease}
20#Source0:      ftp://ftp.gnu.org/pub/gnu/emacs/emacs-%{version}.tar.xz
21#Source0:      ftp://ftp.gnu.org/pub/gnu/emacs/emacs-%{version}%{?gitdate:.git%gitdate}.tar.xz
22Source0:      ftp://alpha.gnu.org/gnu/emacs/pretest/emacs-%{emacsversion}.tar.xz
23Source1:      emacs-snapshot.sh
24
25Source10:     site-start.el.emacs24
26
27## local settings for local system
28Source20:     emacs24-local.el
29
30# desktop file
31Source50:     emacs24.desktop.in
32
33## Enable Japanese Menu
34## http://www11.atwiki.jp/s-irie/pages/13.html
35# Source100:    menu-tree-el-%{menutreeelversion}.tar.gz
36# Source101:    menu-tree-init.el.emacs24
37Source102:    coding-system-init.el.emacs24
38
39## default settings for Vine Linux
40Source150:    vine-default-base.el
41
42## Vine Patch(es)
43Patch11:      emacs-24.3.90-locallisppath.patch
44#Patch20:      emacs-23.1.90-fixed-resolution.patch
45Patch30:      emacs-24.0.90-libs-termcap.patch
46
47# patches from Fedora
48# rhbz#713600
49Patch107: emacs-spellchecker.patch
50
51# security patches (from Debian)
52
53#Patch1001:    emacs-21.1-bzip2.patch.bz2
54
55License:      GPLv3+
56Group:        Applications/Editors/Emacs
57
58Distribution: Vine Linux
59Vendor:       Project Vine
60Packager:     munepi, daisuke
61
62BuildRoot:    %{_tmppath}/%{name}-%{version}-root
63# Requires:     tamago >= 4.0.6
64Obsoletes:    mule-base, mule-canna, mule-wnn6, mule, emacs-beta
65Obsoletes:    emacs21 <= 21.2-0vl7
66Obsoletes:    emacs22 <= 22.1
67Obsoletes:    emacs23 <= 23.1
68Obsoletes:    emacs24 <= 24.1
69#Provides:     emacs24 = %{version}
70Provides:     emacsen = 0.1
71#% prereq_ge    emacsen-common
72Requires(post):    emacsen-common
73Requires(postun):    emacsen-common
74
75BuildRequires: autoconf
76BuildRequires: xz
77BuildRequires: atk-devel
78BuildRequires: dbus-devel GConf2-devel
79BuildRequires: alsa-lib-devel
80BuildRequires: gnutls-devel
81#if %{?_dist_release} >= "vl7"
82#BuildRequires: gtk3-devel
83#else
84BuildRequires: gtk2-devel
85#endif
86BuildRequires: cairo-devel
87BuildRequires: freetype2-devel, fontconfig-devel
88BuildRequires: libpng-devel, libjpeg-devel, libtiff-devel, libungif-devel
89BuildRequires: librsvg2-devel, libotf-devel
90BuildRequires: ImageMagick-devel
91BuildRequires: libxml2-devel > 2.6.17
92BuildRequires: m17n-lib-devel
93BuildRequires: libX11-devel, libXau-devel, libXdmcp-devel, libXrender-devel
94BuildRequires: libSM-devel, libXt-devel, libXpm-devel, ncurses-devel
95BuildRequires: xorg-x11-proto-devel, zlib-devel
96BuildRequires: texinfo
97BuildRequires: nkf
98
99%description
100GNU Emacs is the extensible, customizable, self-documenting real-time
101display editor.
102
103%description -l ja
104GNU Emacs は拡張性が高く、さまざまなカスタマイズが可能な高機能エディタです。
105
106
107%prep
108
109%setup -q -n emacs-%{version}
110
111%patch11 -p1
112#%patch20 -p1
113#%patch30 -p1
114
115%patch107 -p1 -b .spellchecker
116
117#%patch1001 -p1
118
119
120# Avoid trademark issues
121grep -v "tetris.elc" lisp/Makefile.in > lisp/Makefile.in.new \
122   && %__mv lisp/Makefile.in.new lisp/Makefile.in || exit 1
123%__rm -f lisp/play/tetris.el lisp/play/tetris.elc || exit 1
124
125#autoconf
126autoreconf -i -I m4
127
128%build
129export CFLAGS="-DMAIL_USE_LOCKF $RPM_OPT_FLAGS"
130#to find installinfo
131export PATH="$PATH:/sbin:/usr/sbin"
132
133%configure --with-pop --with-sound \
134    --libexecdir=%{_libdir} --infodir=%{infodir} \
135    --disable-rename \
136    --with-x-toolkit=gtk \
137    --with-freetype --with-xft \
138    --enable-font-backend \
139    --without-gpm \
140    --with-libotf \
141    --with-m17n-flt \
142    --with-dbus --with-gconf \
143    ;
144#    --with-x-toolkit=gtk3 \
145
146%__make bootstrap
147%__make %{?_smp_mflags}
148
149
150%install
151[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
152
153%makeinstall libexecdir=$RPM_BUILD_ROOT%{_libdir} \
154        infodir=${RPM_BUILD_ROOT}%{infodir}
155
156## This is a duplicate of the file in FLAVOR/site-lisp
157%__rm -f $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/subdirs.el || exit 1
158
159# (cd $RPM_BUILD_ROOT%{_mandir}/man1/; %__mv ctags.1 gctags.1)
160# (cd $RPM_BUILD_ROOT%{_bindir}/; %__mv ctags gctags)
161
162%__mkdir_p  $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/etc
163%__mkdir_p  $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp
164# %__tar zxvf %{SOURCE100}
165# %__cp -a menu-tree-el-%{menutreeelversion}/menu-tree.el $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/
166# nkf -w --overwrite $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/menu-tree.el
167
168## vine default
169%__cp -a %{SOURCE150} \
170    $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/
171
172# The elisp reference manual
173#bzcat %{SOURCE13} | tar xf -
174#pushd elisp-manual-21-2.8
175#install -m 644 elisp elisp-? elisp-?? $RPM_BUILD_ROOT/%{infodir}
176#popd
177
178# some modifications of installed files
179
180#rm -f $RPM_BUILD_ROOT%{infodir}/dir
181#gzip -9nf $RPM_BUILD_ROOT%{infodir}/*
182
183%__install -m 644 %{SOURCE10} \
184        $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/site-start.el
185%__sed -i -e 's/EMACS_VERSION/%{version}/g' \
186          -e 's/VINE_DEFAULT_MAJOR_VERSION/%{vine_default_major_version}/g' \
187        $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/site-start.el
188
189## create site-start.d directory
190%__install -m 755 -d ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d
191
192# install coding-system init.el
193# %__install -m644 %{SOURCE101} \
194#     $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/menu-tree-init.el
195# %__ln_s -f %{_datadir}/emacs-%{version}/site-lisp/menu-tree-init.el \
196#     ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d/60menu-tree-init.el
197%__install -m644 %{SOURCE102} \
198    $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/coding-system-init.el
199%__ln_s -f %{_datadir}/emacs-%{version}/site-lisp/coding-system-init.el \
200    ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d/60coding-system-init.el
201
202## install system-wide configure file
203%__install -m755 -d ${RPM_BUILD_ROOT}/etc/emacs
204%__install -m644 %{SOURCE20} ${RPM_BUILD_ROOT}/etc/emacs/emacs24-local.el
205%__sed -i -e 's/EMACS_VERSION/%{version}/g' \
206    ${RPM_BUILD_ROOT}/etc/emacs/emacs24-local.el
207
208## Python mode, php mode and rpm-spec mode
209
210## make file list
211strip $RPM_BUILD_ROOT%{_bindir}/* || :
212
213# install desktop file
214%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/applications
215%__sed -e "s/@@EMACS_VERSION@@/%{emacsversion}/g" %{SOURCE50} > \
216    $RPM_BUILD_ROOT%{_datadir}/applications/$(basename %{SOURCE50} .in)
217[ -f $RPM_BUILD_ROOT%{_datadir}/applications/emacs.desktop ] && \
218    %__rm -f $RPM_BUILD_ROOT%{_datadir}/applications/emacs.desktop || exit 1
219
220# install icons
221%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/icons
222%__cp -a etc/images/icons/hicolor $RPM_BUILD_ROOT%{_datadir}/icons/
223
224## remove man files
225%__rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/* || exit 1
226
227## Remove ctags
228#rm -f $RPM_BUILD_ROOT/usr/bin/ctags
229#rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/*ctags*
230#rm -f $RPM_BUILD_ROOT/%{_datadir}/emacs/%{version}/etc/ctags*
231
232DIR="${RPM_BUILD_ROOT}%{_datadir}/emacs \
233     ${RPM_BUILD_ROOT}%{_datadir}/emacs-%{version}"
234BIN=${RPM_BUILD_ROOT}%{_bindir}
235LIB=${RPM_BUILD_ROOT}%{_libdir}
236EL="*.el"
237
238## prepare file list for emacs
239echo "/usr/bin/ctags
240/usr/bin/ebrowse
241/usr/bin/etags
242/usr/bin/rcs-checkin
243/usr/bin/emacs
244/usr/bin/emacsclient
245/usr/bin/grep-changelog
246/usr/share/icons/hicolor/scalable/apps/emacs.svg
247/usr/share/icons/hicolor/scalable/mimetypes/emacs-document.svg" |
248    %__sed -e "s#[^\n]*#mv ${RPM_BUILD_ROOT}\0 ${RPM_BUILD_ROOT}\0.emacs-%{version}#"|
249    awk '{system($_)}'
250
251find $DIR $BIN $LIB -type d |
252  %__sed -e "s#^${RPM_BUILD_ROOT}#%dir #" > rpm-files
253
254find $DIR $BIN $LIB -type f -o -type l |
255  %__sed -e "
256    s#^${RPM_BUILD_ROOT}\(.*movemail\)#%attr(2755, root, mail) \1#
257    s#^${RPM_BUILD_ROOT}##
258  " >> rpm-files
259
260
261%clean
262[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
263
264
265%define info_files ccmode cl dired-x ediff emacs forms gnus info message mh-e reftex sc vip viper widget
266
267
268%pre
269
270if [ -L %{_datadir}/emacs-%{version}/site-lisp ] ; then
271    %__rm -f %{_datadir}/emacs-%{version}/site-lisp
272fi
273
274if [ -d %{_datadir}/emacs/%{version}/site-lisp ] ; then
275    find %{_datadir}/emacs/%{version}/site-lisp/* -maxdepth 0 | grep -v subdirs.el | \
276        xargs %__rm -rf
277fi
278
279
280%post
281
282if [ "$1" = 1 ]; then
283
284%_addflavorslist emacs-%{version}
285
286export PRIORITY=50
287
288%_installemacs emacs-%{version}
289
290unset PRIORITY
291fi
292
293if [ "$1" = 2 ]; then
294
295#  export PRIORITY=50
296 
297#  %_installemacs emacs-%{version}
298 
299#  unset PRIORITY
300   
301  echo emacs-%{version} >  /var/lib/emacsen-common/doinstaflavor-emacs
302   
303fi
304
305
306%postun
307
308if [ $1 = 1 ]; then
309# run upgrade install time
310
311# old version uninstall
312
313%_removeflavorslist emacs-%{version}
314
315%_removeemacs emacs-%{version}
316
317#new version install
318if [ -f /var/lib/emacsen-common/doinstaflavor-emacs ] ; then
319
320NEWFLAVOR=$(cat /var/lib/emacsen-common/doinstaflavor-emacs)
321
322%_addflavorslist $NEWFLAVOR
323
324export PRIORITY=50
325
326%_installemacs $NEWFLAVOR
327
328unset PRIORITY
329
330%__rm -rf /var/lib/emacsen-common/doinstaflavor-emacs
331
332fi
333
334fi
335
336
337%preun
338if [ $1 = 0 ]; then
339
340%_removeflavorslist emacs-%{version}
341
342%_removeemacs emacs-%{version}
343
344fi
345
346
347%triggerpostun -- emacs23 < %{version}-%{release}
348
349%_addflavorslist emacs-%{version}
350
351export PRIORITY=50
352
353%_installemacs emacs-%{version}
354
355unset PRIORITY
356
357
358%files -f rpm-files
359%defattr(-,root,root)
360%doc INSTALL README BUGS ChangeLog COPYING
361#%doc INSTALL.BZR
362%dir %{_sysconfdir}/emacs-%{version}
363%dir %{_sysconfdir}/emacs-%{version}/site-start.d
364%{_sysconfdir}/emacs-%{version}/site-start.d/*.el
365%config(noreplace) %{_sysconfdir}/emacs/emacs24-local.el
366%{_infodir}/*
367# %{_mandir}/*/*
368%{_datadir}/applications/emacs24.desktop
369%{_datadir}/icons/hicolor/*
370# %{_datadir}/emacs-%{version}/site-lisp
371%dir %{_localstatedir}/games/emacs
372%{_localstatedir}/games/emacs/*
373
374
375%changelog
376* Wed Jul 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.3.91-2
377- rebuild with ImageMagick-6.8.9.5
378
379* Mon May 12 2014 Munehiro Yamamoto <munepi@vinelinux.org> 24.3.91-1
380- updated to 24.3.91
381
382* Sun Apr 27 2014 Munehiro Yamamoto <munepi@vinelinux.org> 24.3.90-1
383- updated to 24.3.90
384
385* Tue Feb 25 2014 NAKAMURA Kenta <kenta@vinelinux.org> 24.3-5
386- rebuilt with gnutls-3.2
387
388* Mon Jan 13 2014 Munehiro Yamamoto <munepi@vinelinux.org> 24.3-4
389- rebuilt
390
391* Wed Aug 14 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.3-3
392- rebuild with ImageMagick-6.8.6.8
393
394* Sat May 11 2013 Munehiro Yamamoto <munepi@vinelinux.org> 24.3-2
395- dropped some obsolete patches
396- disable menu-tree-el
397  - added coding-system-init.el instead of menu-tree-init.el
398
399* Sat Mar 30 2013 Munehiro Yamamoto <munepi@vinelinux.org> 24.3-1
400- new upstream release
401
402* Thu Feb  7 2013 Munehiro Yamamoto <munepi@vinelinux.org> 24.2.93-1
403- updated to 24.2.93 (24.3 pretest)
404
405* Mon Jan 14 2013 Munehiro Yamamoto <munepi@vinelinux.org> 24.2.92-1
406- updated to 24.2.92 (24.3 pretest)
407
408* Sun Nov 25 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.2.90-1
409- updated to 24.2.90 (24.3 pretest)
410
411* Mon Aug 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.2-1
412- new upstream release
413
414* Sun Jun 10 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.1-1
415- new upstream release
416
417* Sat May 19 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.97-1
418- updated to 24.0.97 (24.1 pretest)
419
420* Sun Apr 29 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.96-1
421- updated to 24.0.96 (24.1 pretest)
422
423* Mon Apr  2 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.95-1
424- updated to 24.0.95 (24.1 pretest)
425
426* Sun Mar 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.0.94-2
427- rebuild with ImageMagick-6.7.5.10
428
429* Mon Feb 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.94-1
430- updated to 24.0.94 (24.1 pretest)
431
432* Tue Feb 14 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.93-2
433- use gtk as X toolkit (for vl6)
434
435* Mon Jan 30 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.93-1
436- updated to 24.0.93 (24.1 pretest)
437
438* Thu Dec  1 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.92-1
439- updated to 24.0.92 (24.1 pretest)
440
441* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.91-1
442- updated to 24.0.91 (24.1 pretest)
443
444* Thu Oct  6 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.90-2
445- set --with-x-toolkit=gtk3 (%%configure)
446  - added BuildRequires: gtk3-devel
447
448* Mon Sep 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.90-1
449- updated to 24.0.90 (24.1 pretest)
450- applied emacs-24.0.90-libs-termcap.patch
451
452* Sat Jul 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-10.20110817
453- emacs24 24.0.50 (20110817) snapshot
454- added BuildRequires: ImageMagick-devel, libSM-devel, libxml2-devel > 2.6.17
455
456* Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-9.20110604
457- emacs24 24.0.50 (20110604) snapshot
458
459* Wed Apr 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-8.20110413
460- emacs24 24.0.50 (20110413) snapshot
461
462* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-7.20110318
463- updated site-start.el
464  - defined vine-default-major-version, vine-default-minor-version,
465    vine-default-version
466  - set "ibus-el" to emacs-ime as default
467  - added ", modified for Vine Linux" to the end of emacs-build-system
468  - set "Vine _at_mark_ vinelinux.org" to report-emacs-bug-address
469
470* Sun Apr 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-6.20110318
471- fixed site-start.el
472  - do not use the macro loop (contained in the common lisp)
473
474* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-5.20110318
475- emacs24 24.0.50 (20110318) snapshot
476
477* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-4.20110222
478- emacs24 24.0.50 (20110222) snapshot
479- updated site-start.el
480  - defined the function drop-vine-default-from-load-path (regex)
481
482* Sat Jan 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-3.20110128
483- emacs24 24.0.50 (20110128) snapshot
484
485* Sun Jan 02 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-2.20110101
486- emacs24 24.0.50 (20110101) snapshot
487
488* Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-1.20101203
489- emacs24 24.0.50 (20101203) snapshot
490- applied new vine-default system
491  - updated site-start.el
492  - updated vine-default-{base,faces}.el
493  - dropped showvdefaultemacs
494    - merged to emacsen-common package as show-vine-default.sh
495  - renamed local wide configration file to emacs24-local.el
496- updated menu-tree.el to version 0.97
497- added Provides: emacs-snapshot
498
499* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-4
500- updated vine-default-base.el
501  - changed the variable next-line-add-newlines to nil (default)
502
503* Thu Sep 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-3
504- updated menu-tree.el to version 0.96
505
506* Sat Jul 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-2
507- applied some patches from Fedora
508  - Fixed handling of dual spacing fonts rhbz#599437
509  - Add patch to fix rhbz#595546 hideshow library matches wrong parenthesis
510    under certain circumstances
511  - Added a patch fixing m17n and libotf version checking (m17ncheck)
512- updated menu-tree.el to version 0.95
513- merged emacs23-vl.spec of Vine Linux 5.1
514#* Thu Apr 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-9
515#- applied security fix emacs23-CVE-2010-0825-fix-movemail-race.diff from Ubuntu
516#
517#* Fri Feb 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-8
518#- added Requires(post): emacsen-common, Requires(postun): emacsen-common
519#
520#* Fri Feb 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-7
521#- dropped BuildRequires: m17n-lib-devel
522#- added --without-m17n-flt in %%configure
523
524* Mon May 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-1
525- new upstream release
526- updated menu-tree.el to version 0.94
527- updated menu-tree-init.el.emacs23
528  - used prefer-coding-system
529
530* Wed Apr 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.96-1
531- updated to 23.1.96 (23.2 pretest)
532
533* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.95-2
534- removed /usr/share/emacs/site-lisp/subdirs.el
535
536* Sat Apr 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.95-1
537- updated to 23.1.95 (23.2 pretest)
538- added BuildRequires:
539  - atk-devel
540  - dbus-devel
541  - GConf2-devel
542  - alsa-lib-devel
543- added some configure options:
544  --with-libotf --with-m17n-flt --with-dbus --with-gconf
545
546* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.94-1
547- updated to 23.1.94
548
549* Thu Mar 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.93-1
550- updated to 23.1.93 alpha
551
552* Sat Feb 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.92-2
553- added Requires(post): emacsen-common, Requires(postun): emacsen-common
554
555* Tue Feb 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.92-1
556- update to 23.1.92 alpha
557
558* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-6
559- added BuildRequires:
560  - librsvg2-devel
561  - m17n-lib-devel
562  - libotf-devel
563
564* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-5
565- changed License to GPLv3+
566- renamed emacs23.desktop to emacs23.desktop.in
567- updated vine-default-base.el (See [vine-users:079919])
568- fixed in upstream CVS (from Fedora)
569  - fix #543046 - Using scroll bar in emacs highlights/selects text
570  - fix #542657 - emacs does not display indic text
571  - Fixed rhbz#545398 - ETags messes up filenames
572
573* Tue Sep 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-4
574- rebuilt to add signature
575
576* Wed Aug 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-3
577- added BuildRequires: nkf
578- updated menu-tree-init.el.emacs23
579  - fixed menu-tree encoding <BTS:VineLinux:766>
580- set Exec=emacs-@@EMACS_VERSION@@ in emacs23.desktop
581
582* Wed Aug 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-2
583- replaced BR: libungif-devel with BR: giflib-devel
584
585* Sat Aug 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-1
586- new upstream release
587
588* Sat Jul 25 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.0.96-2.20090714
589- updated vine-default-faces.el to sync with emacs22
590
591* Tue Jul 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.96-1.20090714
592- update to 23.0.96 (20090714) snapshot
593- update vine-default-faces.el
594  - use bash to call gconftool-2
595
596* Sat Jun 27 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-4.20090527
597- update vine-default-faces.el
598  - added \'font in default-frame-alist
599    (if \'font is already in default-frame-alist, overwrited it)
600
601* Wed Jun 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-3.20090527
602- update vine-default-faces.el:
603  - use set-frame-font
604    bacause set-default-font function is obsolete since Emacs 23.1
605    (See M-x describe-function RET set-default-font)
606
607* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-2.20090527
608- update vine-default-faces.el:
609  - set desktop-gnome-interface-monospace-font-name
610    from /desktop/gnome/interface/monospace_font_name
611  - automatically set set-default-font
612    with desktop-gnome-interface-monospace-font-name
613
614* Wed May 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.94-1.20090527
615- update to emacs-23.0.94 (20090527) snapshot
616- add --without-gpm to configure
617
618* Thu May 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-7.20090422
619- defined show-vine-default function in site-start.el
620  - added showvdefaultemacs script
621
622* Wed May 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-6.20090422
623- set PRIORITY=40
624
625* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-5.20090422
626- changed menu-tree-init.el from hard copy to symbolic link
627  on /etc/emacs-23.0.92/site-start.d
628- added %%{_mandir}/*/* in %%files section
629
630* Sat May 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-4.20090422
631- updated menu-tree.el to v0.93
632
633* Fri May 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-3.20090422
634- returned alternatives priority to 30
635  (emacs: 30, emacs22: 30)
636
637* Sun Apr 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-2.20090422
638- installed system-wide configure file in /etc/emacs
639- updated vine-default-base.el
640- changed alternatives priority from 30 to 50
641  (emacs: 50, emacs22: 30)
642
643* Wed Apr 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.92-1.20090422
644- update to emacs 23.0.92 (20090422) snapshot
645- add %%triggerpostun to fix alternatives
646
647* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.91-3.20090325
648- renamed from emacs23 to emacs (emacs-22.x would be renamed to emacs22)
649- updated default settings for Vine Linux
650  - dropped vine-default-mouse.el, vine-default-misc.el
651
652* Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.91-2.20090325
653- enable default settings for Vine Linux
654  - added site-start.el.emacs23
655  - updated site-start.el
656  - added vine-default-base.el, vine-default-faces.el, vine-default-mouse.el,
657    vine-default-misc.el
658
659* Wed Mar 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.91-1.20090325
660- emacs23 23.0.91 snapshot
661
662* Tue Sep 09 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 23.0.60-2.20080908
663- drop patch10
664- s/emacsrelese/emacsrelease/
665
666* Mon Sep 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.60-1.20080908
667- emacs23 23.0.60 snapshot
668
669* Sun Sep 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.3-1
670- new upstream release
671
672* Mon Aug 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 22.2-3
673- import security fixes from Debian
674  CVE-2008-2142: fix insecure setting of fast-lock-cache-directories
675  CVE-2008-1694: fix insecure temporary file creation in vcdiff script
676                 leading to possible symlink attacks
677
678* Wed Jun 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.2-2
679- update menu-tree.el
680- add 60menu-tree-init.el to sed coding-system and load menu-tree
681- build with xorg-x11-7.3
682  - update BuildRequires
683
684* Sun Mar 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.2-1
685- new upstream release
686
687* Wed Nov 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 22.1-0vl2
688- add Patch10000 to fix local variable processing security bypass
689  vulnerability.
690  - http://www.frsirt.com/english/advisories/2007/3715
691  - http://bugs.debian.org/449008
692
693* Mon Jun 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 22.1-0vl1
694- new upstream release
695- rename to emacs from emacs22 (emacs-21.x would be renameed to emacs21)
696- drop emcws support
697
698* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 22.0.50-0.20060403vl3
699- rebuilt with new toolchain
700
701* Sat May 06 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 22.0.50-0.20060403vl2
702- changed Group:
703
704* Mon Apr 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20060403vl1
705- update to CVS-20060403
706- update emacs22.desktop
707
708* Wed Sep 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050927vl2
709- fix site-start.el
710
711* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050927vl1
712- update to CVS-20050927
713
714* Thu Sep  8 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050907vl1
715- initial build for Vine Linux based on emacs package.
716  - emacs-22.0.50 on CVS-20050907
717
718* Sat Sep  3 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.4-0vl3
719- create site-start.d directory on %install
720
721* Thu Feb 17 2005 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.4-0vl2
722- included leim-21.4
723- update emcws-21.3-20031213.gz
724
725* Wed Feb 16 2005 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.4-0vl1
726- update
727
728* Sat Jul 24 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl7
729- rebuild with Xaw3d, add BuildRequires: Xaw3d-devel
730
731* Fri Jul 23 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl6
732- add Patch20 to fix display resolutions. (set to 96dpi)
733  (do not compute dynamically from display's size)
734
735* Tue Mar 16 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.3-0vl5
736- rebuilt with new toolchain environment
737
738* Thu Jul 17 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.3-0vl4
739- use site-start.el(reading /etc/emacs-21.3/site-start.d/*.el)
740
741* Wed May  7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 21.3-0vl3
742- add BuildPrereq: libpng >= 1.2.5
743
744* Tue Apr 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl2
745- fixed %%pre script
746
747* Tue Mar 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl1
748- new upstream release
749- remove patch14 whick included in upstream
750
751* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl11
752- add patch14 to fix frame title text encoding.
753  - http://tsukuba.m17n.org/mule-ja-archive/2002-10/msg00004.html
754
755* Tue Dec 10 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.2-0vl10
756- autoconf-2.13, not autoconf in %%setup section
757- BuildPreReq: autoconf213
758
759* Mon Dec  9 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl9
760- modifiy rpm scripts.
761
762* Mon Dec  9 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl8
763- rename to emacs
764- obsoletes emacs21 <= 21.2-0vl7, provides emacs21 = %%{version}
765
766* Sun Dec  1 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl7
767- enable menubar fontset patch (Patch103)
768
769* Sat Nov 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl6
770- add requires/buildprereq tags.
771
772* Sat Nov 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl5
773- add emcws-20021014
774
775* Sun Jul 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl4
776- removed *-mode
777
778* Sat Jul 20 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl3
779- python-mode was made pending
780- some additional *.el files was moved from "emacs/site-lisp" to
781  "emacs-(version)/site-lisp"
782
783* Sat Jul 13 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl2
784- added some sources and patches from rawhide 21.2-11 and mandrake 21.2-7mdk
785
786* Sat May 11 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.2-0vl1
787- update.
788- Package Name emacs-beta -> emacs21
789- Add Patch100,101,102, Source100(default = Disable)
790- (from http://phe.phyas.aichi-edu.ac.jp/~cyamauch/pl2.html#emacs21)
791- --infodir=%{_infodir}/emacs-21.2(VineSeed-Plus:00723)
792
793* Thu Dec 27 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl7
794- site-lisp moved under /usr/share/emacs-21.1/ (Patch11 and %%pre section)
795
796* Thu Dec 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl5
797- move /tmp -> /var/lib/emacsen-common (IP(package)C file)
798
799* Fri Nov 02 2001 Tomoya TAKA <tomoya@olive.plala.or.jp> 21.1-0vl4
800- replace patch10 with patch11, posted to gnu.emacs.bug
801  Message-Id: <jebsiza3db.fsf@sykes.suse.de>
802  (reported by ABE Yuji <cbo46560@pop12.odn.ne.jp>)
803
804* Fri Oct 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.1-0vl3
805- fixed build to fail in alpha( only apply patch0 to ppc)
806
807* Tue Oct 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl2
808- added Patch10 (thanks Kitame-san)
809
810* Mon Oct 22 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.1-0vl1
811- update to 21.1
812
813* Sun Sep 9 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.104-0vl14
814- support  shared installing otheremacsen.
815
816* Mon Jul 23 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.104-0vl3
817- update 21.0.104
818
819* Thu Jul 19 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.103-0vl2
820- support emacsen-common
821
822* Wed May 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
823- 21.0.103-0vl1
824- updated to 21.0.103
825- revamped and cleaned up spec file :-)
826- Requires: tamago >= 4.0.6 (...is it reasonable? Mmm...)
827
828* Mon Jan 22 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.95-0vl2
829- fixed .spec bugs( _libdir)
830
831* Fri Jan 12 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.95-0vl1
832- updated to 21.0.95
833
834* Wed Dec 20 2000 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.93-0vl3
835- fixed emacs-beta.spec
836
837* Sat Dec 16 2000 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.93-0vl2
838- 21.0.93 test packaging.
839
840* Fri Jun 30 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
841- added linespace-patch
842
843* Mon Jun 19 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
844- updated to emacs 20.7
845
846* Thu Apr 20 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
847- updated to emacs 20.6
848
849* Mon Feb 28 2000 kenji KITAYAMA <kenji@gandalf.doshisha.ac.jp>
850- [emacs-20.5a-2]
851- Modified reference of Emacs Info
852
853* Sun Jan 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
854- [emacs-20.5a-2]
855- added ppc patch
856
857* Fri Jan  7 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
858- [emacs-20.5a-1]
859- change version from 20.5 to 20.5a
860- added Mule-4.1 patch
861
862* Fri Jan  7 2000 Yasuyuki Furukawa <yasu@on.cs.keio.ac.jp>
863- [emacs-20.5-1]
864- add desktop-link files for desktop menu.
865
866* Fri Dec 24 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
867- [emacs-20.4-16]
868- replaced Y2K savvy timezone.{el,elc} with one from brand-new apel-10.0
869
870* Tue Dec 21 1999 Jun Nishii <jun@vinelinux.org>
871- added documents
872- strip bins
873
874* Wed Dec  1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
875- [emacs-20.4-14]
876- Change Group to Applications/Editors/Emacs
877
878* Sat Nov  6 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
879- [emacs-20.4-13]
880- included Y2K savvy timezone.{el,elc},
881  modified by Mr. Youichi Teranishi <teranishi@gohome.org>
882
883* Tue Oct 12 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
884- [emacs-20.4-12]
885- Modified info-dir.
886- Removed -c option from %setup.
887
888* Mon Sep 20 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
889- fixed XIM support patch
890* Sun Sep 19 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
891- fixed postinst bug and fontset patch
892* Sun Jul 18 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
893- first build
Note: See TracBrowser for help on using the repository browser.