source: projects/specs/trunk/e/emacs/emacs24-vl.spec @ 8277

Revision 8277, 29.2 KB checked in by kenta, 10 years ago (diff)

emacs: rebuilt with gnutls-3.2

Line 
1%define emacsversion 24.3
2#% define bzrdate 20110817
3%define emacsrelease 5%{?bzrdate:.%bzrdate}%{?_dist_release}
4%define vine_default_major_version %(echo %_dist_release|%__sed s/vl//)
5
6%define _noVersionedDependencies 1
7%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
8
9%define infodir %{_infodir}/emacs-%{emacsversion}
10
11%define menutreeelversion 0.97
12
13Summary:      GNU Emacs editor
14Summary(ja):  GNU Emacs エディタ
15Name:         emacs
16#Name:         emacs24
17#Provides:     emacs-snapshot
18Version:      %{emacsversion}
19Release:      %{emacsrelease}
20#Source0:      ftp://ftp.gnu.org/pub/gnu/emacs/emacs-%{version}.tar.xz
21#Source0:      ftp://ftp.gnu.org/pub/gnu/emacs/emacs-%{version}%{?bzrdate:.bzr%bzrdate}.tar.xz
22Source0:      ftp://alpha.gnu.org/gnu/emacs/pretest/emacs-%{emacsversion}.tar.xz
23Source1:      emacs-snapshot.sh
24
25Source10:     site-start.el.emacs24
26
27## local settings for local system
28Source20:     emacs24-local.el
29
30# desktop file
31Source50:     emacs24.desktop.in
32
33## Enable Japanese Menu
34## http://www11.atwiki.jp/s-irie/pages/13.html
35# Source100:    menu-tree-el-%{menutreeelversion}.tar.gz
36# Source101:    menu-tree-init.el.emacs24
37Source102:    coding-system-init.el.emacs24
38
39## default settings for Vine Linux
40Source150:    vine-default-base.el
41
42## Vine Patch(es)
43Patch11:      emacs-24.2.90-locallisppath.patch
44#Patch20:      emacs-23.1.90-fixed-resolution.patch
45Patch30:      emacs-24.0.90-libs-termcap.patch
46
47# patches from Fedora
48# rhbz#713600
49Patch107: emacs-spellchecker.patch
50# Fix for emacs bug #922519
51Patch110: emacs-style-change-cb.patch
52# Fix for emacs bug #562719
53Patch111: emacs-bell-dont-work.patch
54# Fix for emacs bug #929353
55Patch112: emacs-gtk-warning.patch
56# Fix for emacs bug #948838
57Patch113: emacs-help-update.patch
58# Fix for emacs bug #13460.
59Patch150: emacs-24.3-hunspell.patch
60# Fix for emacs bug #827033
61Patch151: emacs-24.3-hunspell.2.patch
62
63# security patches (from Debian)
64
65#Patch1001:    emacs-21.1-bzip2.patch.bz2
66
67License:      GPLv3+
68Group:        Applications/Editors/Emacs
69
70Distribution: Vine Linux
71Vendor:       Project Vine
72Packager:     munepi, daisuke
73
74BuildRoot:    %{_tmppath}/%{name}-%{version}-root
75# Requires:     tamago >= 4.0.6
76Obsoletes:    mule-base, mule-canna, mule-wnn6, mule, emacs-beta
77Obsoletes:    emacs21 <= 21.2-0vl7
78Obsoletes:    emacs22 <= 22.1
79Obsoletes:    emacs23 <= 23.1
80Obsoletes:    emacs24 <= 24.1
81#Provides:     emacs24 = %{version}
82Provides:     emacsen = 0.1
83#% prereq_ge    emacsen-common
84Requires(post):    emacsen-common
85Requires(postun):    emacsen-common
86
87BuildRequires: autoconf
88BuildRequires: xz
89BuildRequires: atk-devel
90BuildRequires: dbus-devel GConf2-devel
91BuildRequires: alsa-lib-devel
92BuildRequires: gnutls-devel
93%if %{?_dist_release} >= "vl7"
94BuildRequires: gtk3-devel
95%else
96BuildRequires: gtk2-devel
97%endif
98BuildRequires: cairo-devel
99BuildRequires: freetype2-devel, fontconfig-devel
100BuildRequires: libpng-devel, libjpeg-devel, libtiff-devel, libungif-devel
101BuildRequires: librsvg2-devel, libotf-devel
102BuildRequires: ImageMagick-devel
103BuildRequires: libxml2-devel > 2.6.17
104BuildRequires: m17n-lib-devel
105BuildRequires: libX11-devel, libXau-devel, libXdmcp-devel, libXrender-devel
106BuildRequires: libSM-devel, libXt-devel, libXpm-devel, ncurses-devel
107BuildRequires: xorg-x11-proto-devel, zlib-devel
108BuildRequires: texinfo
109BuildRequires: nkf
110
111%description
112GNU Emacs is the extensible, customizable, self-documenting real-time
113display editor.
114
115%description -l ja
116GNU Emacs は拡張性が高く、さまざまなカスタマイズが可能な高機能エディタです。
117
118
119%prep
120
121%setup -q -n emacs-%{version}
122
123%patch11 -p1
124#%patch20 -p1
125#%patch30 -p1
126
127%patch107 -p1 -b .spellchecker
128%patch110 -p1 -b .style-change-cb.patch
129%patch111 -p1 -b .bell-dont-work.patch
130%patch112 -p1 -b .gtk-warning.patch
131%patch113 -p1 -b .help-update.patch
132%patch150 -p1 -b .hunspell
133%patch151 -p1 -b .hunspell.2
134
135#%patch1001 -p1
136
137
138# Avoid trademark issues
139grep -v "tetris.elc" lisp/Makefile.in > lisp/Makefile.in.new \
140   && %__mv lisp/Makefile.in.new lisp/Makefile.in || exit 1
141%__rm -f lisp/play/tetris.el lisp/play/tetris.elc || exit 1
142
143#autoconf
144autoreconf -i -I m4
145
146%build
147# Remove unpatched files as all files in the lisp directory are
148# installed.
149%__rm lisp/textmodes/ispell.el.hunspell || exit 1
150%__rm lisp/textmodes/ispell.el.hunspell.2 || exit 1
151%__rm lisp/textmodes/ispell.el.spellchecker || exit 1
152
153export CFLAGS="-DMAIL_USE_LOCKF $RPM_OPT_FLAGS"
154#to find installinfo
155export PATH="$PATH:/sbin:/usr/sbin"
156
157%configure --with-pop --with-sound \
158    --libexecdir=%{_libdir} --infodir=%{infodir} \
159    --disable-rename \
160%if %{?_dist_release} >= "vl7"
161    --with-x-toolkit=gtk3 \
162%else
163    --with-x-toolkit=gtk \
164%endif
165    --with-freetype --with-xft \
166    --enable-font-backend \
167    --without-gpm \
168    --with-libotf \
169    --with-m17n-flt \
170    --with-dbus --with-gconf \
171    ;
172
173%__make bootstrap
174%__make %{?_smp_mflags}
175
176
177%install
178[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
179
180ARCHDIR=${RPM_ARCH}-vine-linux
181
182%makeinstall libexecdir=$RPM_BUILD_ROOT%{_libdir} \
183        infodir=${RPM_BUILD_ROOT}%{infodir}
184
185## This is a duplicate of the file in FLAVOR/site-lisp
186%__rm -f $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/subdirs.el || exit 1
187
188# (cd $RPM_BUILD_ROOT%{_mandir}/man1/; %__mv ctags.1 gctags.1)
189# (cd $RPM_BUILD_ROOT%{_bindir}/; %__mv ctags gctags)
190
191%__mkdir_p  $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/etc
192%__mkdir_p  $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp
193# %__tar zxvf %{SOURCE100}
194# %__cp -a menu-tree-el-%{menutreeelversion}/menu-tree.el $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/
195# nkf -w --overwrite $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/menu-tree.el
196
197## vine default
198%__cp -a %{SOURCE150} \
199    $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/
200
201# The elisp reference manual
202#bzcat %{SOURCE13} | tar xf -
203#pushd elisp-manual-21-2.8
204#install -m 644 elisp elisp-? elisp-?? $RPM_BUILD_ROOT/%{infodir}
205#popd
206
207# some modifications of installed files
208
209#rm -f $RPM_BUILD_ROOT%{infodir}/dir
210#gzip -9nf $RPM_BUILD_ROOT%{infodir}/*
211
212%__install -m 644 %{SOURCE10} \
213        $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/site-start.el
214%__sed -i -e 's/EMACS_VERSION/%{version}/g' \
215          -e 's/VINE_DEFAULT_MAJOR_VERSION/%{vine_default_major_version}/g' \
216        $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/site-start.el
217
218## create site-start.d directory
219%__install -m 755 -d ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d
220
221# install coding-system init.el
222# %__install -m644 %{SOURCE101} \
223#     $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/menu-tree-init.el
224# %__ln_s -f %{_datadir}/emacs-%{version}/site-lisp/menu-tree-init.el \
225#     ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d/60menu-tree-init.el
226%__install -m644 %{SOURCE102} \
227    $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/coding-system-init.el
228%__ln_s -f %{_datadir}/emacs-%{version}/site-lisp/coding-system-init.el \
229    ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d/60coding-system-init.el
230
231## install system-wide configure file
232%__install -m755 -d ${RPM_BUILD_ROOT}/etc/emacs
233%__install -m644 %{SOURCE20} ${RPM_BUILD_ROOT}/etc/emacs/emacs24-local.el
234%__sed -i -e 's/EMACS_VERSION/%{version}/g' \
235    ${RPM_BUILD_ROOT}/etc/emacs/emacs24-local.el
236
237## Python mode, php mode and rpm-spec mode
238
239## make file list
240strip $RPM_BUILD_ROOT%{_bindir}/* || :
241
242# install desktop file
243%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/applications
244%__sed -e "s/@@EMACS_VERSION@@/%{emacsversion}/g" %{SOURCE50} > \
245    $RPM_BUILD_ROOT%{_datadir}/applications/$(basename %{SOURCE50} .in)
246[ -f $RPM_BUILD_ROOT%{_datadir}/applications/emacs.desktop ] && \
247    %__rm -f $RPM_BUILD_ROOT%{_datadir}/applications/emacs.desktop || exit 1
248
249# install icons
250%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/icons
251%__cp -a etc/images/icons/hicolor $RPM_BUILD_ROOT%{_datadir}/icons/
252
253## remove man files
254%__rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/* || exit 1
255
256## Remove ctags
257#rm -f $RPM_BUILD_ROOT/usr/bin/ctags
258#rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/*ctags*
259#rm -f $RPM_BUILD_ROOT/%{_datadir}/emacs/%{version}/etc/ctags*
260
261DIR="${RPM_BUILD_ROOT}%{_datadir}/emacs \
262     ${RPM_BUILD_ROOT}%{_datadir}/emacs-%{version}"
263BIN=${RPM_BUILD_ROOT}%{_bindir}
264LIB=${RPM_BUILD_ROOT}%{_libdir}
265EL="*.el"
266
267## prepare file list for emacs
268echo "/usr/bin/ctags
269/usr/bin/ebrowse
270/usr/bin/etags
271/usr/bin/rcs-checkin
272/usr/bin/emacs
273/usr/bin/emacsclient
274/usr/bin/grep-changelog
275/usr/share/icons/hicolor/scalable/apps/emacs.svg
276/usr/share/icons/hicolor/scalable/mimetypes/emacs-document.svg" |
277    %__sed -e "s#[^\n]*#mv ${RPM_BUILD_ROOT}\0 ${RPM_BUILD_ROOT}\0.emacs-%{version}#"|
278    awk '{system($_)}'
279
280find $DIR $BIN $LIB -type d |
281  %__sed -e "s#^${RPM_BUILD_ROOT}#%dir #" > rpm-files
282
283find $DIR $BIN $LIB -type f -o -type l |
284  %__sed -e "
285    s#^${RPM_BUILD_ROOT}\(.*movemail\)#%attr(2755, root, mail) \1#
286    s#^${RPM_BUILD_ROOT}##
287  " >> rpm-files
288
289
290%clean
291[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
292
293
294%define info_files ccmode cl dired-x ediff emacs forms gnus info message mh-e reftex sc vip viper widget
295
296
297%pre
298
299if [ -L %{_datadir}/emacs-%{version}/site-lisp ] ; then
300    %__rm -f %{_datadir}/emacs-%{version}/site-lisp
301fi
302
303if [ -d %{_datadir}/emacs/%{version}/site-lisp ] ; then
304    find %{_datadir}/emacs/%{version}/site-lisp/* -maxdepth 0 | grep -v subdirs.el | \
305        xargs %__rm -rf
306fi
307
308
309%post
310
311if [ "$1" = 1 ]; then
312
313%_addflavorslist emacs-%{version}
314
315export PRIORITY=50
316
317%_installemacs emacs-%{version}
318
319unset PRIORITY
320fi
321
322if [ "$1" = 2 ]; then
323
324#  export PRIORITY=50
325 
326#  %_installemacs emacs-%{version}
327 
328#  unset PRIORITY
329   
330  echo emacs-%{version} >  /var/lib/emacsen-common/doinstaflavor-emacs
331   
332fi
333
334
335%postun
336
337if [ $1 = 1 ]; then
338# run upgrade install time
339
340# old version uninstall
341
342%_removeflavorslist emacs-%{version}
343
344%_removeemacs emacs-%{version}
345
346#new version install
347if [ -f /var/lib/emacsen-common/doinstaflavor-emacs ] ; then
348
349NEWFLAVOR=$(cat /var/lib/emacsen-common/doinstaflavor-emacs)
350
351%_addflavorslist $NEWFLAVOR
352
353export PRIORITY=50
354
355%_installemacs $NEWFLAVOR
356
357unset PRIORITY
358
359%__rm -rf /var/lib/emacsen-common/doinstaflavor-emacs
360
361fi
362
363fi
364
365
366%preun
367if [ $1 = 0 ]; then
368
369%_removeflavorslist emacs-%{version}
370
371%_removeemacs emacs-%{version}
372
373fi
374
375
376%triggerpostun -- emacs23 < %{version}-%{release}
377
378%_addflavorslist emacs-%{version}
379
380export PRIORITY=50
381
382%_installemacs emacs-%{version}
383
384unset PRIORITY
385
386
387%files -f rpm-files
388%defattr(-,root,root)
389%doc INSTALL README BUGS ChangeLog COPYING
390#%doc INSTALL.BZR
391%dir %{_sysconfdir}/emacs-%{version}
392%dir %{_sysconfdir}/emacs-%{version}/site-start.d
393%{_sysconfdir}/emacs-%{version}/site-start.d/*.el
394%config(noreplace) %{_sysconfdir}/emacs/emacs24-local.el
395%{_infodir}/*
396# %{_mandir}/*/*
397%{_datadir}/applications/emacs24.desktop
398%{_datadir}/icons/hicolor/*
399# %{_datadir}/emacs-%{version}/site-lisp
400%dir %{_localstatedir}/games/emacs
401%{_localstatedir}/games/emacs/*
402
403
404%changelog
405* Tue Feb 25 2014 NAKAMURA Kenta <kenta@vinelinux.org> 24.3-5
406- rebuilt with gnutls-3.2
407
408* Mon Jan 13 2014 Munehiro Yamamoto <munepi@vinelinux.org> 24.3-4
409- rebuilt
410
411* Wed Aug 14 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.3-3
412- rebuild with ImageMagick-6.8.6.8
413
414* Sat May 11 2013 Munehiro Yamamoto <munepi@vinelinux.org> 24.3-2
415- dropped some obsolete patches
416- disable menu-tree-el
417  - added coding-system-init.el instead of menu-tree-init.el
418
419* Sat Mar 30 2013 Munehiro Yamamoto <munepi@vinelinux.org> 24.3-1
420- new upstream release
421
422* Thu Feb  7 2013 Munehiro Yamamoto <munepi@vinelinux.org> 24.2.93-1
423- updated to 24.2.93 (24.3 pretest)
424
425* Mon Jan 14 2013 Munehiro Yamamoto <munepi@vinelinux.org> 24.2.92-1
426- updated to 24.2.92 (24.3 pretest)
427
428* Sun Nov 25 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.2.90-1
429- updated to 24.2.90 (24.3 pretest)
430
431* Mon Aug 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.2-1
432- new upstream release
433
434* Sun Jun 10 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.1-1
435- new upstream release
436
437* Sat May 19 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.97-1
438- updated to 24.0.97 (24.1 pretest)
439
440* Sun Apr 29 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.96-1
441- updated to 24.0.96 (24.1 pretest)
442
443* Mon Apr  2 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.95-1
444- updated to 24.0.95 (24.1 pretest)
445
446* Sun Mar 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.0.94-2
447- rebuild with ImageMagick-6.7.5.10
448
449* Mon Feb 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.94-1
450- updated to 24.0.94 (24.1 pretest)
451
452* Tue Feb 14 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.93-2
453- use gtk as X toolkit (for vl6)
454
455* Mon Jan 30 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.93-1
456- updated to 24.0.93 (24.1 pretest)
457
458* Thu Dec  1 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.92-1
459- updated to 24.0.92 (24.1 pretest)
460
461* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.91-1
462- updated to 24.0.91 (24.1 pretest)
463
464* Thu Oct  6 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.90-2
465- set --with-x-toolkit=gtk3 (%%configure)
466  - added BuildRequires: gtk3-devel
467
468* Mon Sep 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.90-1
469- updated to 24.0.90 (24.1 pretest)
470- applied emacs-24.0.90-libs-termcap.patch
471
472* Sat Jul 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-10.20110817
473- emacs24 24.0.50 (20110817) snapshot
474- added BuildRequires: ImageMagick-devel, libSM-devel, libxml2-devel > 2.6.17
475
476* Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-9.20110604
477- emacs24 24.0.50 (20110604) snapshot
478
479* Wed Apr 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-8.20110413
480- emacs24 24.0.50 (20110413) snapshot
481
482* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-7.20110318
483- updated site-start.el
484  - defined vine-default-major-version, vine-default-minor-version,
485    vine-default-version
486  - set "ibus-el" to emacs-ime as default
487  - added ", modified for Vine Linux" to the end of emacs-build-system
488  - set "Vine _at_mark_ vinelinux.org" to report-emacs-bug-address
489
490* Sun Apr 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-6.20110318
491- fixed site-start.el
492  - do not use the macro loop (contained in the common lisp)
493
494* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-5.20110318
495- emacs24 24.0.50 (20110318) snapshot
496
497* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-4.20110222
498- emacs24 24.0.50 (20110222) snapshot
499- updated site-start.el
500  - defined the function drop-vine-default-from-load-path (regex)
501
502* Sat Jan 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-3.20110128
503- emacs24 24.0.50 (20110128) snapshot
504
505* Sun Jan 02 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-2.20110101
506- emacs24 24.0.50 (20110101) snapshot
507
508* Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-1.20101203
509- emacs24 24.0.50 (20101203) snapshot
510- applied new vine-default system
511  - updated site-start.el
512  - updated vine-default-{base,faces}.el
513  - dropped showvdefaultemacs
514    - merged to emacsen-common package as show-vine-default.sh
515  - renamed local wide configration file to emacs24-local.el
516- updated menu-tree.el to version 0.97
517- added Provides: emacs-snapshot
518
519* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-4
520- updated vine-default-base.el
521  - changed the variable next-line-add-newlines to nil (default)
522
523* Thu Sep 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-3
524- updated menu-tree.el to version 0.96
525
526* Sat Jul 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-2
527- applied some patches from Fedora
528  - Fixed handling of dual spacing fonts rhbz#599437
529  - Add patch to fix rhbz#595546 hideshow library matches wrong parenthesis
530    under certain circumstances
531  - Added a patch fixing m17n and libotf version checking (m17ncheck)
532- updated menu-tree.el to version 0.95
533- merged emacs23-vl.spec of Vine Linux 5.1
534#* Thu Apr 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-9
535#- applied security fix emacs23-CVE-2010-0825-fix-movemail-race.diff from Ubuntu
536#
537#* Fri Feb 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-8
538#- added Requires(post): emacsen-common, Requires(postun): emacsen-common
539#
540#* Fri Feb 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-7
541#- dropped BuildRequires: m17n-lib-devel
542#- added --without-m17n-flt in %%configure
543
544* Mon May 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-1
545- new upstream release
546- updated menu-tree.el to version 0.94
547- updated menu-tree-init.el.emacs23
548  - used prefer-coding-system
549
550* Wed Apr 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.96-1
551- updated to 23.1.96 (23.2 pretest)
552
553* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.95-2
554- removed /usr/share/emacs/site-lisp/subdirs.el
555
556* Sat Apr 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.95-1
557- updated to 23.1.95 (23.2 pretest)
558- added BuildRequires:
559  - atk-devel
560  - dbus-devel
561  - GConf2-devel
562  - alsa-lib-devel
563- added some configure options:
564  --with-libotf --with-m17n-flt --with-dbus --with-gconf
565
566* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.94-1
567- updated to 23.1.94
568
569* Thu Mar 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.93-1
570- updated to 23.1.93 alpha
571
572* Sat Feb 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.92-2
573- added Requires(post): emacsen-common, Requires(postun): emacsen-common
574
575* Tue Feb 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.92-1
576- update to 23.1.92 alpha
577
578* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-6
579- added BuildRequires:
580  - librsvg2-devel
581  - m17n-lib-devel
582  - libotf-devel
583
584* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-5
585- changed License to GPLv3+
586- renamed emacs23.desktop to emacs23.desktop.in
587- updated vine-default-base.el (See [vine-users:079919])
588- fixed in upstream CVS (from Fedora)
589  - fix #543046 - Using scroll bar in emacs highlights/selects text
590  - fix #542657 - emacs does not display indic text
591  - Fixed rhbz#545398 - ETags messes up filenames
592
593* Tue Sep 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-4
594- rebuilt to add signature
595
596* Wed Aug 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-3
597- added BuildRequires: nkf
598- updated menu-tree-init.el.emacs23
599  - fixed menu-tree encoding <BTS:VineLinux:766>
600- set Exec=emacs-@@EMACS_VERSION@@ in emacs23.desktop
601
602* Wed Aug 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-2
603- replaced BR: libungif-devel with BR: giflib-devel
604
605* Sat Aug 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-1
606- new upstream release
607
608* Sat Jul 25 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.0.96-2.20090714
609- updated vine-default-faces.el to sync with emacs22
610
611* Tue Jul 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.96-1.20090714
612- update to 23.0.96 (20090714) snapshot
613- update vine-default-faces.el
614  - use bash to call gconftool-2
615
616* Sat Jun 27 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-4.20090527
617- update vine-default-faces.el
618  - added \'font in default-frame-alist
619    (if \'font is already in default-frame-alist, overwrited it)
620
621* Wed Jun 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-3.20090527
622- update vine-default-faces.el:
623  - use set-frame-font
624    bacause set-default-font function is obsolete since Emacs 23.1
625    (See M-x describe-function RET set-default-font)
626
627* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-2.20090527
628- update vine-default-faces.el:
629  - set desktop-gnome-interface-monospace-font-name
630    from /desktop/gnome/interface/monospace_font_name
631  - automatically set set-default-font
632    with desktop-gnome-interface-monospace-font-name
633
634* Wed May 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.94-1.20090527
635- update to emacs-23.0.94 (20090527) snapshot
636- add --without-gpm to configure
637
638* Thu May 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-7.20090422
639- defined show-vine-default function in site-start.el
640  - added showvdefaultemacs script
641
642* Wed May 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-6.20090422
643- set PRIORITY=40
644
645* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-5.20090422
646- changed menu-tree-init.el from hard copy to symbolic link
647  on /etc/emacs-23.0.92/site-start.d
648- added %%{_mandir}/*/* in %%files section
649
650* Sat May 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-4.20090422
651- updated menu-tree.el to v0.93
652
653* Fri May 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-3.20090422
654- returned alternatives priority to 30
655  (emacs: 30, emacs22: 30)
656
657* Sun Apr 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-2.20090422
658- installed system-wide configure file in /etc/emacs
659- updated vine-default-base.el
660- changed alternatives priority from 30 to 50
661  (emacs: 50, emacs22: 30)
662
663* Wed Apr 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.92-1.20090422
664- update to emacs 23.0.92 (20090422) snapshot
665- add %%triggerpostun to fix alternatives
666
667* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.91-3.20090325
668- renamed from emacs23 to emacs (emacs-22.x would be renamed to emacs22)
669- updated default settings for Vine Linux
670  - dropped vine-default-mouse.el, vine-default-misc.el
671
672* Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.91-2.20090325
673- enable default settings for Vine Linux
674  - added site-start.el.emacs23
675  - updated site-start.el
676  - added vine-default-base.el, vine-default-faces.el, vine-default-mouse.el,
677    vine-default-misc.el
678
679* Wed Mar 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.91-1.20090325
680- emacs23 23.0.91 snapshot
681
682* Tue Sep 09 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 23.0.60-2.20080908
683- drop patch10
684- s/emacsrelese/emacsrelease/
685
686* Mon Sep 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.60-1.20080908
687- emacs23 23.0.60 snapshot
688
689* Sun Sep 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.3-1
690- new upstream release
691
692* Mon Aug 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 22.2-3
693- import security fixes from Debian
694  CVE-2008-2142: fix insecure setting of fast-lock-cache-directories
695  CVE-2008-1694: fix insecure temporary file creation in vcdiff script
696                 leading to possible symlink attacks
697
698* Wed Jun 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.2-2
699- update menu-tree.el
700- add 60menu-tree-init.el to sed coding-system and load menu-tree
701- build with xorg-x11-7.3
702  - update BuildRequires
703
704* Sun Mar 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.2-1
705- new upstream release
706
707* Wed Nov 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 22.1-0vl2
708- add Patch10000 to fix local variable processing security bypass
709  vulnerability.
710  - http://www.frsirt.com/english/advisories/2007/3715
711  - http://bugs.debian.org/449008
712
713* Mon Jun 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 22.1-0vl1
714- new upstream release
715- rename to emacs from emacs22 (emacs-21.x would be renameed to emacs21)
716- drop emcws support
717
718* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 22.0.50-0.20060403vl3
719- rebuilt with new toolchain
720
721* Sat May 06 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 22.0.50-0.20060403vl2
722- changed Group:
723
724* Mon Apr 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20060403vl1
725- update to CVS-20060403
726- update emacs22.desktop
727
728* Wed Sep 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050927vl2
729- fix site-start.el
730
731* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050927vl1
732- update to CVS-20050927
733
734* Thu Sep  8 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050907vl1
735- initial build for Vine Linux based on emacs package.
736  - emacs-22.0.50 on CVS-20050907
737
738* Sat Sep  3 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.4-0vl3
739- create site-start.d directory on %install
740
741* Thu Feb 17 2005 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.4-0vl2
742- included leim-21.4
743- update emcws-21.3-20031213.gz
744
745* Wed Feb 16 2005 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.4-0vl1
746- update
747
748* Sat Jul 24 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl7
749- rebuild with Xaw3d, add BuildRequires: Xaw3d-devel
750
751* Fri Jul 23 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl6
752- add Patch20 to fix display resolutions. (set to 96dpi)
753  (do not compute dynamically from display's size)
754
755* Tue Mar 16 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.3-0vl5
756- rebuilt with new toolchain environment
757
758* Thu Jul 17 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.3-0vl4
759- use site-start.el(reading /etc/emacs-21.3/site-start.d/*.el)
760
761* Wed May  7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 21.3-0vl3
762- add BuildPrereq: libpng >= 1.2.5
763
764* Tue Apr 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl2
765- fixed %%pre script
766
767* Tue Mar 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl1
768- new upstream release
769- remove patch14 whick included in upstream
770
771* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl11
772- add patch14 to fix frame title text encoding.
773  - http://tsukuba.m17n.org/mule-ja-archive/2002-10/msg00004.html
774
775* Tue Dec 10 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.2-0vl10
776- autoconf-2.13, not autoconf in %%setup section
777- BuildPreReq: autoconf213
778
779* Mon Dec  9 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl9
780- modifiy rpm scripts.
781
782* Mon Dec  9 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl8
783- rename to emacs
784- obsoletes emacs21 <= 21.2-0vl7, provides emacs21 = %%{version}
785
786* Sun Dec  1 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl7
787- enable menubar fontset patch (Patch103)
788
789* Sat Nov 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl6
790- add requires/buildprereq tags.
791
792* Sat Nov 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl5
793- add emcws-20021014
794
795* Sun Jul 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl4
796- removed *-mode
797
798* Sat Jul 20 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl3
799- python-mode was made pending
800- some additional *.el files was moved from "emacs/site-lisp" to
801  "emacs-(version)/site-lisp"
802
803* Sat Jul 13 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl2
804- added some sources and patches from rawhide 21.2-11 and mandrake 21.2-7mdk
805
806* Sat May 11 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.2-0vl1
807- update.
808- Package Name emacs-beta -> emacs21
809- Add Patch100,101,102, Source100(default = Disable)
810- (from http://phe.phyas.aichi-edu.ac.jp/~cyamauch/pl2.html#emacs21)
811- --infodir=%{_infodir}/emacs-21.2(VineSeed-Plus:00723)
812
813* Thu Dec 27 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl7
814- site-lisp moved under /usr/share/emacs-21.1/ (Patch11 and %%pre section)
815
816* Thu Dec 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl5
817- move /tmp -> /var/lib/emacsen-common (IP(package)C file)
818
819* Fri Nov 02 2001 Tomoya TAKA <tomoya@olive.plala.or.jp> 21.1-0vl4
820- replace patch10 with patch11, posted to gnu.emacs.bug
821  Message-Id: <jebsiza3db.fsf@sykes.suse.de>
822  (reported by ABE Yuji <cbo46560@pop12.odn.ne.jp>)
823
824* Fri Oct 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.1-0vl3
825- fixed build to fail in alpha( only apply patch0 to ppc)
826
827* Tue Oct 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl2
828- added Patch10 (thanks Kitame-san)
829
830* Mon Oct 22 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.1-0vl1
831- update to 21.1
832
833* Sun Sep 9 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.104-0vl14
834- support  shared installing otheremacsen.
835
836* Mon Jul 23 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.104-0vl3
837- update 21.0.104
838
839* Thu Jul 19 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.103-0vl2
840- support emacsen-common
841
842* Wed May 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
843- 21.0.103-0vl1
844- updated to 21.0.103
845- revamped and cleaned up spec file :-)
846- Requires: tamago >= 4.0.6 (...is it reasonable? Mmm...)
847
848* Mon Jan 22 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.95-0vl2
849- fixed .spec bugs( _libdir)
850
851* Fri Jan 12 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.95-0vl1
852- updated to 21.0.95
853
854* Wed Dec 20 2000 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.93-0vl3
855- fixed emacs-beta.spec
856
857* Sat Dec 16 2000 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.93-0vl2
858- 21.0.93 test packaging.
859
860* Fri Jun 30 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
861- added linespace-patch
862
863* Mon Jun 19 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
864- updated to emacs 20.7
865
866* Thu Apr 20 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
867- updated to emacs 20.6
868
869* Mon Feb 28 2000 kenji KITAYAMA <kenji@gandalf.doshisha.ac.jp>
870- [emacs-20.5a-2]
871- Modified reference of Emacs Info
872
873* Sun Jan 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
874- [emacs-20.5a-2]
875- added ppc patch
876
877* Fri Jan  7 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
878- [emacs-20.5a-1]
879- change version from 20.5 to 20.5a
880- added Mule-4.1 patch
881
882* Fri Jan  7 2000 Yasuyuki Furukawa <yasu@on.cs.keio.ac.jp>
883- [emacs-20.5-1]
884- add desktop-link files for desktop menu.
885
886* Fri Dec 24 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
887- [emacs-20.4-16]
888- replaced Y2K savvy timezone.{el,elc} with one from brand-new apel-10.0
889
890* Tue Dec 21 1999 Jun Nishii <jun@vinelinux.org>
891- added documents
892- strip bins
893
894* Wed Dec  1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
895- [emacs-20.4-14]
896- Change Group to Applications/Editors/Emacs
897
898* Sat Nov  6 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
899- [emacs-20.4-13]
900- included Y2K savvy timezone.{el,elc},
901  modified by Mr. Youichi Teranishi <teranishi@gohome.org>
902
903* Tue Oct 12 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
904- [emacs-20.4-12]
905- Modified info-dir.
906- Removed -c option from %setup.
907
908* Mon Sep 20 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
909- fixed XIM support patch
910* Sun Sep 19 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
911- fixed postinst bug and fontset patch
912* Sun Jul 18 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
913- first build
Note: See TracBrowser for help on using the repository browser.