source: projects/specs/trunk/e/emacs/emacs24-vl.spec @ 7766

Revision 7766, 29.1 KB checked in by Takemikaduchi, 11 years ago (diff)

ETL,ImageMagick?,minitube,synfig,synfigstudio,xine-lib: new upstream release
others: rebuild with ImageMagick?-6.8.6.8

Line 
1%define emacsversion 24.3
2#% define bzrdate 20110817
3%define emacsrelease 3%{?bzrdate:.%bzrdate}%{?_dist_release}
4%define vine_default_major_version %(echo %_dist_release|%__sed s/vl//)
5
6%define _noVersionedDependencies 1
7%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
8
9%define infodir %{_infodir}/emacs-%{emacsversion}
10
11%define menutreeelversion 0.97
12
13Summary:      GNU Emacs editor
14Summary(ja):  GNU Emacs エディタ
15Name:         emacs
16#Name:         emacs24
17#Provides:     emacs-snapshot
18Version:      %{emacsversion}
19Release:      %{emacsrelease}
20#Source0:      ftp://ftp.gnu.org/pub/gnu/emacs/emacs-%{version}.tar.xz
21#Source0:      ftp://ftp.gnu.org/pub/gnu/emacs/emacs-%{version}%{?bzrdate:.bzr%bzrdate}.tar.xz
22Source0:      ftp://alpha.gnu.org/gnu/emacs/pretest/emacs-%{emacsversion}.tar.xz
23Source1:      emacs-snapshot.sh
24
25Source10:     site-start.el.emacs24
26
27## local settings for local system
28Source20:     emacs24-local.el
29
30# desktop file
31Source50:     emacs24.desktop.in
32
33## Enable Japanese Menu
34## http://www11.atwiki.jp/s-irie/pages/13.html
35# Source100:    menu-tree-el-%{menutreeelversion}.tar.gz
36# Source101:    menu-tree-init.el.emacs24
37Source102:    coding-system-init.el.emacs24
38
39## default settings for Vine Linux
40Source150:    vine-default-base.el
41
42## Vine Patch(es)
43Patch11:      emacs-24.2.90-locallisppath.patch
44#Patch20:      emacs-23.1.90-fixed-resolution.patch
45Patch30:      emacs-24.0.90-libs-termcap.patch
46
47# patches from Fedora
48# rhbz#713600
49Patch107: emacs-spellchecker.patch
50# Fix for emacs bug #922519
51Patch110: emacs-style-change-cb.patch
52# Fix for emacs bug #562719
53Patch111: emacs-bell-dont-work.patch
54# Fix for emacs bug #929353
55Patch112: emacs-gtk-warning.patch
56# Fix for emacs bug #948838
57Patch113: emacs-help-update.patch
58# Fix for emacs bug #13460.
59Patch150: emacs-24.3-hunspell.patch
60# Fix for emacs bug #827033
61Patch151: emacs-24.3-hunspell.2.patch
62
63# security patches (from Debian)
64
65#Patch1001:    emacs-21.1-bzip2.patch.bz2
66
67License:      GPLv3+
68Group:        Applications/Editors/Emacs
69
70Distribution: Vine Linux
71Vendor:       Project Vine
72Packager:     munepi, daisuke
73
74BuildRoot:    %{_tmppath}/%{name}-%{version}-root
75# Requires:     tamago >= 4.0.6
76Obsoletes:    mule-base, mule-canna, mule-wnn6, mule, emacs-beta
77Obsoletes:    emacs21 <= 21.2-0vl7
78Obsoletes:    emacs22 <= 22.1
79Obsoletes:    emacs23 <= 23.1
80Obsoletes:    emacs24 <= 24.1
81#Provides:     emacs24 = %{version}
82Provides:     emacsen = 0.1
83#% prereq_ge    emacsen-common
84Requires(post):    emacsen-common
85Requires(postun):    emacsen-common
86
87BuildRequires: autoconf
88BuildRequires: xz
89BuildRequires: atk-devel
90BuildRequires: dbus-devel GConf2-devel
91BuildRequires: alsa-lib-devel
92BuildRequires: gnutls-devel
93%if %{?_dist_release} >= "vl7"
94BuildRequires: gtk3-devel
95%else
96BuildRequires: gtk2-devel
97%endif
98BuildRequires: cairo-devel
99BuildRequires: freetype2-devel, fontconfig-devel
100BuildRequires: libpng-devel, libjpeg-devel, libtiff-devel, libungif-devel
101BuildRequires: librsvg2-devel, libotf-devel
102BuildRequires: ImageMagick-devel
103BuildRequires: libxml2-devel > 2.6.17
104BuildRequires: m17n-lib-devel
105BuildRequires: libX11-devel, libXau-devel, libXdmcp-devel, libXrender-devel
106BuildRequires: libSM-devel, libXt-devel, libXpm-devel, ncurses-devel
107BuildRequires: xorg-x11-proto-devel, zlib-devel
108BuildRequires: texinfo
109BuildRequires: nkf
110
111%description
112GNU Emacs is the extensible, customizable, self-documenting real-time
113display editor.
114
115%description -l ja
116GNU Emacs は拡張性が高く、さまざまなカスタマイズが可能な高機能エディタです。
117
118
119%prep
120
121%setup -q -n emacs-%{version}
122
123%patch11 -p1
124#%patch20 -p1
125#%patch30 -p1
126
127%patch107 -p1 -b .spellchecker
128%patch110 -p1 -b .style-change-cb.patch
129%patch111 -p1 -b .bell-dont-work.patch
130%patch112 -p1 -b .gtk-warning.patch
131%patch113 -p1 -b .help-update.patch
132%patch150 -p1 -b .hunspell
133%patch151 -p1 -b .hunspell.2
134
135#%patch1001 -p1
136
137
138# Avoid trademark issues
139grep -v "tetris.elc" lisp/Makefile.in > lisp/Makefile.in.new \
140   && %__mv lisp/Makefile.in.new lisp/Makefile.in || exit 1
141%__rm -f lisp/play/tetris.el lisp/play/tetris.elc || exit 1
142
143#autoconf
144autoreconf -i -I m4
145
146%build
147# Remove unpatched files as all files in the lisp directory are
148# installed.
149%__rm lisp/textmodes/ispell.el.hunspell || exit 1
150%__rm lisp/textmodes/ispell.el.hunspell.2 || exit 1
151%__rm lisp/textmodes/ispell.el.spellchecker || exit 1
152
153export CFLAGS="-DMAIL_USE_LOCKF $RPM_OPT_FLAGS"
154#to find installinfo
155export PATH="$PATH:/sbin:/usr/sbin"
156
157%configure --with-pop --with-sound \
158    --libexecdir=%{_libdir} --infodir=%{infodir} \
159    --disable-rename \
160%if %{?_dist_release} >= "vl7"
161    --with-x-toolkit=gtk3 \
162%else
163    --with-x-toolkit=gtk \
164%endif
165    --with-freetype --with-xft \
166    --enable-font-backend \
167    --without-gpm \
168    --with-libotf \
169    --with-m17n-flt \
170    --with-dbus --with-gconf \
171    ;
172
173%__make bootstrap
174%__make %{?_smp_mflags}
175
176
177%install
178[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
179
180ARCHDIR=${RPM_ARCH}-vine-linux
181
182%makeinstall libexecdir=$RPM_BUILD_ROOT%{_libdir} \
183        infodir=${RPM_BUILD_ROOT}%{infodir}
184
185## This is a duplicate of the file in FLAVOR/site-lisp
186%__rm -f $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/subdirs.el || exit 1
187
188# (cd $RPM_BUILD_ROOT%{_mandir}/man1/; %__mv ctags.1 gctags.1)
189# (cd $RPM_BUILD_ROOT%{_bindir}/; %__mv ctags gctags)
190
191%__mkdir_p  $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/etc
192%__mkdir_p  $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp
193# %__tar zxvf %{SOURCE100}
194# %__cp -a menu-tree-el-%{menutreeelversion}/menu-tree.el $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/
195# nkf -w --overwrite $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/menu-tree.el
196
197## vine default
198%__cp -a %{SOURCE150} \
199    $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/
200
201# The elisp reference manual
202#bzcat %{SOURCE13} | tar xf -
203#pushd elisp-manual-21-2.8
204#install -m 644 elisp elisp-? elisp-?? $RPM_BUILD_ROOT/%{infodir}
205#popd
206
207# some modifications of installed files
208
209#rm -f $RPM_BUILD_ROOT%{infodir}/dir
210#gzip -9nf $RPM_BUILD_ROOT%{infodir}/*
211
212%__install -m 644 %{SOURCE10} \
213        $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/site-start.el
214%__sed -i -e 's/EMACS_VERSION/%{version}/g' \
215          -e 's/VINE_DEFAULT_MAJOR_VERSION/%{vine_default_major_version}/g' \
216        $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/site-start.el
217
218## create site-start.d directory
219%__install -m 755 -d ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d
220
221# install coding-system init.el
222# %__install -m644 %{SOURCE101} \
223#     $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/menu-tree-init.el
224# %__ln_s -f %{_datadir}/emacs-%{version}/site-lisp/menu-tree-init.el \
225#     ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d/60menu-tree-init.el
226%__install -m644 %{SOURCE102} \
227    $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/coding-system-init.el
228%__ln_s -f %{_datadir}/emacs-%{version}/site-lisp/coding-system-init.el \
229    ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d/60coding-system-init.el
230
231## install system-wide configure file
232%__install -m755 -d ${RPM_BUILD_ROOT}/etc/emacs
233%__install -m644 %{SOURCE20} ${RPM_BUILD_ROOT}/etc/emacs/emacs24-local.el
234%__sed -i -e 's/EMACS_VERSION/%{version}/g' \
235    ${RPM_BUILD_ROOT}/etc/emacs/emacs24-local.el
236
237## Python mode, php mode and rpm-spec mode
238
239## make file list
240strip $RPM_BUILD_ROOT%{_bindir}/* || :
241
242# install desktop file
243%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/applications
244%__sed -e "s/@@EMACS_VERSION@@/%{emacsversion}/g" %{SOURCE50} > \
245    $RPM_BUILD_ROOT%{_datadir}/applications/$(basename %{SOURCE50} .in)
246[ -f $RPM_BUILD_ROOT%{_datadir}/applications/emacs.desktop ] && \
247    %__rm -f $RPM_BUILD_ROOT%{_datadir}/applications/emacs.desktop || exit 1
248
249# install icons
250%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/icons
251%__cp -a etc/images/icons/hicolor $RPM_BUILD_ROOT%{_datadir}/icons/
252
253## remove man files
254%__rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/* || exit 1
255
256## Remove ctags
257#rm -f $RPM_BUILD_ROOT/usr/bin/ctags
258#rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/*ctags*
259#rm -f $RPM_BUILD_ROOT/%{_datadir}/emacs/%{version}/etc/ctags*
260
261DIR="${RPM_BUILD_ROOT}%{_datadir}/emacs \
262     ${RPM_BUILD_ROOT}%{_datadir}/emacs-%{version}"
263BIN=${RPM_BUILD_ROOT}%{_bindir}
264LIB=${RPM_BUILD_ROOT}%{_libdir}
265EL="*.el"
266
267## prepare file list for emacs
268echo "/usr/bin/ctags
269/usr/bin/ebrowse
270/usr/bin/etags
271/usr/bin/rcs-checkin
272/usr/bin/emacs
273/usr/bin/emacsclient
274/usr/bin/grep-changelog
275/usr/share/icons/hicolor/scalable/apps/emacs.svg
276/usr/share/icons/hicolor/scalable/mimetypes/emacs-document.svg" |
277    %__sed -e "s#[^\n]*#mv ${RPM_BUILD_ROOT}\0 ${RPM_BUILD_ROOT}\0.emacs-%{version}#"|
278    awk '{system($_)}'
279
280find $DIR $BIN $LIB -type d |
281  %__sed -e "s#^${RPM_BUILD_ROOT}#%dir #" > rpm-files
282
283find $DIR $BIN $LIB -type f -o -type l |
284  %__sed -e "
285    s#^${RPM_BUILD_ROOT}\(.*movemail\)#%attr(2755, root, mail) \1#
286    s#^${RPM_BUILD_ROOT}##
287  " >> rpm-files
288
289
290%clean
291[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
292
293
294%define info_files ccmode cl dired-x ediff emacs forms gnus info message mh-e reftex sc vip viper widget
295
296
297%pre
298
299if [ -L %{_datadir}/emacs-%{version}/site-lisp ] ; then
300    %__rm -f %{_datadir}/emacs-%{version}/site-lisp
301fi
302
303if [ -d %{_datadir}/emacs/%{version}/site-lisp ] ; then
304    find %{_datadir}/emacs/%{version}/site-lisp/* -maxdepth 0 | grep -v subdirs.el | \
305        xargs %__rm -rf
306fi
307
308
309%post
310
311if [ "$1" = 1 ]; then
312
313%_addflavorslist emacs-%{version}
314
315export PRIORITY=50
316
317%_installemacs emacs-%{version}
318
319unset PRIORITY
320fi
321
322if [ "$1" = 2 ]; then
323
324#  export PRIORITY=50
325 
326#  %_installemacs emacs-%{version}
327 
328#  unset PRIORITY
329   
330  echo emacs-%{version} >  /var/lib/emacsen-common/doinstaflavor-emacs
331   
332fi
333
334
335%postun
336
337if [ $1 = 1 ]; then
338# run upgrade install time
339
340# old version uninstall
341
342%_removeflavorslist emacs-%{version}
343
344%_removeemacs emacs-%{version}
345
346#new version install
347if [ -f /var/lib/emacsen-common/doinstaflavor-emacs ] ; then
348
349NEWFLAVOR=$(cat /var/lib/emacsen-common/doinstaflavor-emacs)
350
351%_addflavorslist $NEWFLAVOR
352
353export PRIORITY=50
354
355%_installemacs $NEWFLAVOR
356
357unset PRIORITY
358
359%__rm -rf /var/lib/emacsen-common/doinstaflavor-emacs
360
361fi
362
363fi
364
365
366%preun
367if [ $1 = 0 ]; then
368
369%_removeflavorslist emacs-%{version}
370
371%_removeemacs emacs-%{version}
372
373fi
374
375
376%triggerpostun -- emacs23 < %{version}-%{release}
377
378%_addflavorslist emacs-%{version}
379
380export PRIORITY=50
381
382%_installemacs emacs-%{version}
383
384unset PRIORITY
385
386
387%files -f rpm-files
388%defattr(-,root,root)
389%doc INSTALL README BUGS ChangeLog COPYING
390#%doc INSTALL.BZR
391%dir %{_sysconfdir}/emacs-%{version}
392%dir %{_sysconfdir}/emacs-%{version}/site-start.d
393%{_sysconfdir}/emacs-%{version}/site-start.d/*.el
394%config(noreplace) %{_sysconfdir}/emacs/emacs24-local.el
395%{_infodir}/*
396# %{_mandir}/*/*
397%{_datadir}/applications/emacs24.desktop
398%{_datadir}/icons/hicolor/*
399# %{_datadir}/emacs-%{version}/site-lisp
400%dir %{_localstatedir}/games/emacs
401%{_localstatedir}/games/emacs/*
402
403
404%changelog
405* Wed Aug 14 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.3-3
406- rebuild with ImageMagick-6.8.6.8
407
408* Sat May 11 2013 Munehiro Yamamoto <munepi@vinelinux.org> 24.3-2
409- dropped some obsolete patches
410- disable menu-tree-el
411  - added coding-system-init.el instead of menu-tree-init.el
412
413* Sat Mar 30 2013 Munehiro Yamamoto <munepi@vinelinux.org> 24.3-1
414- new upstream release
415
416* Thu Feb  7 2013 Munehiro Yamamoto <munepi@vinelinux.org> 24.2.93-1
417- updated to 24.2.93 (24.3 pretest)
418
419* Mon Jan 14 2013 Munehiro Yamamoto <munepi@vinelinux.org> 24.2.92-1
420- updated to 24.2.92 (24.3 pretest)
421
422* Sun Nov 25 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.2.90-1
423- updated to 24.2.90 (24.3 pretest)
424
425* Mon Aug 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.2-1
426- new upstream release
427
428* Sun Jun 10 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.1-1
429- new upstream release
430
431* Sat May 19 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.97-1
432- updated to 24.0.97 (24.1 pretest)
433
434* Sun Apr 29 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.96-1
435- updated to 24.0.96 (24.1 pretest)
436
437* Mon Apr  2 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.95-1
438- updated to 24.0.95 (24.1 pretest)
439
440* Sun Mar 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.0.94-2
441- rebuild with ImageMagick-6.7.5.10
442
443* Mon Feb 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.94-1
444- updated to 24.0.94 (24.1 pretest)
445
446* Tue Feb 14 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.93-2
447- use gtk as X toolkit (for vl6)
448
449* Mon Jan 30 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.93-1
450- updated to 24.0.93 (24.1 pretest)
451
452* Thu Dec  1 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.92-1
453- updated to 24.0.92 (24.1 pretest)
454
455* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.91-1
456- updated to 24.0.91 (24.1 pretest)
457
458* Thu Oct  6 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.90-2
459- set --with-x-toolkit=gtk3 (%%configure)
460  - added BuildRequires: gtk3-devel
461
462* Mon Sep 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.90-1
463- updated to 24.0.90 (24.1 pretest)
464- applied emacs-24.0.90-libs-termcap.patch
465
466* Sat Jul 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-10.20110817
467- emacs24 24.0.50 (20110817) snapshot
468- added BuildRequires: ImageMagick-devel, libSM-devel, libxml2-devel > 2.6.17
469
470* Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-9.20110604
471- emacs24 24.0.50 (20110604) snapshot
472
473* Wed Apr 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-8.20110413
474- emacs24 24.0.50 (20110413) snapshot
475
476* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-7.20110318
477- updated site-start.el
478  - defined vine-default-major-version, vine-default-minor-version,
479    vine-default-version
480  - set "ibus-el" to emacs-ime as default
481  - added ", modified for Vine Linux" to the end of emacs-build-system
482  - set "Vine _at_mark_ vinelinux.org" to report-emacs-bug-address
483
484* Sun Apr 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-6.20110318
485- fixed site-start.el
486  - do not use the macro loop (contained in the common lisp)
487
488* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-5.20110318
489- emacs24 24.0.50 (20110318) snapshot
490
491* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-4.20110222
492- emacs24 24.0.50 (20110222) snapshot
493- updated site-start.el
494  - defined the function drop-vine-default-from-load-path (regex)
495
496* Sat Jan 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-3.20110128
497- emacs24 24.0.50 (20110128) snapshot
498
499* Sun Jan 02 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-2.20110101
500- emacs24 24.0.50 (20110101) snapshot
501
502* Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-1.20101203
503- emacs24 24.0.50 (20101203) snapshot
504- applied new vine-default system
505  - updated site-start.el
506  - updated vine-default-{base,faces}.el
507  - dropped showvdefaultemacs
508    - merged to emacsen-common package as show-vine-default.sh
509  - renamed local wide configration file to emacs24-local.el
510- updated menu-tree.el to version 0.97
511- added Provides: emacs-snapshot
512
513* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-4
514- updated vine-default-base.el
515  - changed the variable next-line-add-newlines to nil (default)
516
517* Thu Sep 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-3
518- updated menu-tree.el to version 0.96
519
520* Sat Jul 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-2
521- applied some patches from Fedora
522  - Fixed handling of dual spacing fonts rhbz#599437
523  - Add patch to fix rhbz#595546 hideshow library matches wrong parenthesis
524    under certain circumstances
525  - Added a patch fixing m17n and libotf version checking (m17ncheck)
526- updated menu-tree.el to version 0.95
527- merged emacs23-vl.spec of Vine Linux 5.1
528#* Thu Apr 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-9
529#- applied security fix emacs23-CVE-2010-0825-fix-movemail-race.diff from Ubuntu
530#
531#* Fri Feb 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-8
532#- added Requires(post): emacsen-common, Requires(postun): emacsen-common
533#
534#* Fri Feb 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-7
535#- dropped BuildRequires: m17n-lib-devel
536#- added --without-m17n-flt in %%configure
537
538* Mon May 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-1
539- new upstream release
540- updated menu-tree.el to version 0.94
541- updated menu-tree-init.el.emacs23
542  - used prefer-coding-system
543
544* Wed Apr 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.96-1
545- updated to 23.1.96 (23.2 pretest)
546
547* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.95-2
548- removed /usr/share/emacs/site-lisp/subdirs.el
549
550* Sat Apr 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.95-1
551- updated to 23.1.95 (23.2 pretest)
552- added BuildRequires:
553  - atk-devel
554  - dbus-devel
555  - GConf2-devel
556  - alsa-lib-devel
557- added some configure options:
558  --with-libotf --with-m17n-flt --with-dbus --with-gconf
559
560* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.94-1
561- updated to 23.1.94
562
563* Thu Mar 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.93-1
564- updated to 23.1.93 alpha
565
566* Sat Feb 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.92-2
567- added Requires(post): emacsen-common, Requires(postun): emacsen-common
568
569* Tue Feb 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.92-1
570- update to 23.1.92 alpha
571
572* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-6
573- added BuildRequires:
574  - librsvg2-devel
575  - m17n-lib-devel
576  - libotf-devel
577
578* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-5
579- changed License to GPLv3+
580- renamed emacs23.desktop to emacs23.desktop.in
581- updated vine-default-base.el (See [vine-users:079919])
582- fixed in upstream CVS (from Fedora)
583  - fix #543046 - Using scroll bar in emacs highlights/selects text
584  - fix #542657 - emacs does not display indic text
585  - Fixed rhbz#545398 - ETags messes up filenames
586
587* Tue Sep 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-4
588- rebuilt to add signature
589
590* Wed Aug 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-3
591- added BuildRequires: nkf
592- updated menu-tree-init.el.emacs23
593  - fixed menu-tree encoding <BTS:VineLinux:766>
594- set Exec=emacs-@@EMACS_VERSION@@ in emacs23.desktop
595
596* Wed Aug 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-2
597- replaced BR: libungif-devel with BR: giflib-devel
598
599* Sat Aug 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-1
600- new upstream release
601
602* Sat Jul 25 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.0.96-2.20090714
603- updated vine-default-faces.el to sync with emacs22
604
605* Tue Jul 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.96-1.20090714
606- update to 23.0.96 (20090714) snapshot
607- update vine-default-faces.el
608  - use bash to call gconftool-2
609
610* Sat Jun 27 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-4.20090527
611- update vine-default-faces.el
612  - added \'font in default-frame-alist
613    (if \'font is already in default-frame-alist, overwrited it)
614
615* Wed Jun 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-3.20090527
616- update vine-default-faces.el:
617  - use set-frame-font
618    bacause set-default-font function is obsolete since Emacs 23.1
619    (See M-x describe-function RET set-default-font)
620
621* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-2.20090527
622- update vine-default-faces.el:
623  - set desktop-gnome-interface-monospace-font-name
624    from /desktop/gnome/interface/monospace_font_name
625  - automatically set set-default-font
626    with desktop-gnome-interface-monospace-font-name
627
628* Wed May 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.94-1.20090527
629- update to emacs-23.0.94 (20090527) snapshot
630- add --without-gpm to configure
631
632* Thu May 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-7.20090422
633- defined show-vine-default function in site-start.el
634  - added showvdefaultemacs script
635
636* Wed May 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-6.20090422
637- set PRIORITY=40
638
639* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-5.20090422
640- changed menu-tree-init.el from hard copy to symbolic link
641  on /etc/emacs-23.0.92/site-start.d
642- added %%{_mandir}/*/* in %%files section
643
644* Sat May 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-4.20090422
645- updated menu-tree.el to v0.93
646
647* Fri May 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-3.20090422
648- returned alternatives priority to 30
649  (emacs: 30, emacs22: 30)
650
651* Sun Apr 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-2.20090422
652- installed system-wide configure file in /etc/emacs
653- updated vine-default-base.el
654- changed alternatives priority from 30 to 50
655  (emacs: 50, emacs22: 30)
656
657* Wed Apr 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.92-1.20090422
658- update to emacs 23.0.92 (20090422) snapshot
659- add %%triggerpostun to fix alternatives
660
661* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.91-3.20090325
662- renamed from emacs23 to emacs (emacs-22.x would be renamed to emacs22)
663- updated default settings for Vine Linux
664  - dropped vine-default-mouse.el, vine-default-misc.el
665
666* Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.91-2.20090325
667- enable default settings for Vine Linux
668  - added site-start.el.emacs23
669  - updated site-start.el
670  - added vine-default-base.el, vine-default-faces.el, vine-default-mouse.el,
671    vine-default-misc.el
672
673* Wed Mar 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.91-1.20090325
674- emacs23 23.0.91 snapshot
675
676* Tue Sep 09 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 23.0.60-2.20080908
677- drop patch10
678- s/emacsrelese/emacsrelease/
679
680* Mon Sep 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.60-1.20080908
681- emacs23 23.0.60 snapshot
682
683* Sun Sep 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.3-1
684- new upstream release
685
686* Mon Aug 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 22.2-3
687- import security fixes from Debian
688  CVE-2008-2142: fix insecure setting of fast-lock-cache-directories
689  CVE-2008-1694: fix insecure temporary file creation in vcdiff script
690                 leading to possible symlink attacks
691
692* Wed Jun 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.2-2
693- update menu-tree.el
694- add 60menu-tree-init.el to sed coding-system and load menu-tree
695- build with xorg-x11-7.3
696  - update BuildRequires
697
698* Sun Mar 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.2-1
699- new upstream release
700
701* Wed Nov 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 22.1-0vl2
702- add Patch10000 to fix local variable processing security bypass
703  vulnerability.
704  - http://www.frsirt.com/english/advisories/2007/3715
705  - http://bugs.debian.org/449008
706
707* Mon Jun 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 22.1-0vl1
708- new upstream release
709- rename to emacs from emacs22 (emacs-21.x would be renameed to emacs21)
710- drop emcws support
711
712* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 22.0.50-0.20060403vl3
713- rebuilt with new toolchain
714
715* Sat May 06 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 22.0.50-0.20060403vl2
716- changed Group:
717
718* Mon Apr 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20060403vl1
719- update to CVS-20060403
720- update emacs22.desktop
721
722* Wed Sep 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050927vl2
723- fix site-start.el
724
725* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050927vl1
726- update to CVS-20050927
727
728* Thu Sep  8 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050907vl1
729- initial build for Vine Linux based on emacs package.
730  - emacs-22.0.50 on CVS-20050907
731
732* Sat Sep  3 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.4-0vl3
733- create site-start.d directory on %install
734
735* Thu Feb 17 2005 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.4-0vl2
736- included leim-21.4
737- update emcws-21.3-20031213.gz
738
739* Wed Feb 16 2005 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.4-0vl1
740- update
741
742* Sat Jul 24 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl7
743- rebuild with Xaw3d, add BuildRequires: Xaw3d-devel
744
745* Fri Jul 23 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl6
746- add Patch20 to fix display resolutions. (set to 96dpi)
747  (do not compute dynamically from display's size)
748
749* Tue Mar 16 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.3-0vl5
750- rebuilt with new toolchain environment
751
752* Thu Jul 17 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.3-0vl4
753- use site-start.el(reading /etc/emacs-21.3/site-start.d/*.el)
754
755* Wed May  7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 21.3-0vl3
756- add BuildPrereq: libpng >= 1.2.5
757
758* Tue Apr 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl2
759- fixed %%pre script
760
761* Tue Mar 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl1
762- new upstream release
763- remove patch14 whick included in upstream
764
765* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl11
766- add patch14 to fix frame title text encoding.
767  - http://tsukuba.m17n.org/mule-ja-archive/2002-10/msg00004.html
768
769* Tue Dec 10 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.2-0vl10
770- autoconf-2.13, not autoconf in %%setup section
771- BuildPreReq: autoconf213
772
773* Mon Dec  9 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl9
774- modifiy rpm scripts.
775
776* Mon Dec  9 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl8
777- rename to emacs
778- obsoletes emacs21 <= 21.2-0vl7, provides emacs21 = %%{version}
779
780* Sun Dec  1 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl7
781- enable menubar fontset patch (Patch103)
782
783* Sat Nov 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl6
784- add requires/buildprereq tags.
785
786* Sat Nov 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl5
787- add emcws-20021014
788
789* Sun Jul 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl4
790- removed *-mode
791
792* Sat Jul 20 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl3
793- python-mode was made pending
794- some additional *.el files was moved from "emacs/site-lisp" to
795  "emacs-(version)/site-lisp"
796
797* Sat Jul 13 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl2
798- added some sources and patches from rawhide 21.2-11 and mandrake 21.2-7mdk
799
800* Sat May 11 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.2-0vl1
801- update.
802- Package Name emacs-beta -> emacs21
803- Add Patch100,101,102, Source100(default = Disable)
804- (from http://phe.phyas.aichi-edu.ac.jp/~cyamauch/pl2.html#emacs21)
805- --infodir=%{_infodir}/emacs-21.2(VineSeed-Plus:00723)
806
807* Thu Dec 27 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl7
808- site-lisp moved under /usr/share/emacs-21.1/ (Patch11 and %%pre section)
809
810* Thu Dec 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl5
811- move /tmp -> /var/lib/emacsen-common (IP(package)C file)
812
813* Fri Nov 02 2001 Tomoya TAKA <tomoya@olive.plala.or.jp> 21.1-0vl4
814- replace patch10 with patch11, posted to gnu.emacs.bug
815  Message-Id: <jebsiza3db.fsf@sykes.suse.de>
816  (reported by ABE Yuji <cbo46560@pop12.odn.ne.jp>)
817
818* Fri Oct 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.1-0vl3
819- fixed build to fail in alpha( only apply patch0 to ppc)
820
821* Tue Oct 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl2
822- added Patch10 (thanks Kitame-san)
823
824* Mon Oct 22 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.1-0vl1
825- update to 21.1
826
827* Sun Sep 9 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.104-0vl14
828- support  shared installing otheremacsen.
829
830* Mon Jul 23 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.104-0vl3
831- update 21.0.104
832
833* Thu Jul 19 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.103-0vl2
834- support emacsen-common
835
836* Wed May 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
837- 21.0.103-0vl1
838- updated to 21.0.103
839- revamped and cleaned up spec file :-)
840- Requires: tamago >= 4.0.6 (...is it reasonable? Mmm...)
841
842* Mon Jan 22 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.95-0vl2
843- fixed .spec bugs( _libdir)
844
845* Fri Jan 12 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.95-0vl1
846- updated to 21.0.95
847
848* Wed Dec 20 2000 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.93-0vl3
849- fixed emacs-beta.spec
850
851* Sat Dec 16 2000 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.93-0vl2
852- 21.0.93 test packaging.
853
854* Fri Jun 30 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
855- added linespace-patch
856
857* Mon Jun 19 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
858- updated to emacs 20.7
859
860* Thu Apr 20 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
861- updated to emacs 20.6
862
863* Mon Feb 28 2000 kenji KITAYAMA <kenji@gandalf.doshisha.ac.jp>
864- [emacs-20.5a-2]
865- Modified reference of Emacs Info
866
867* Sun Jan 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
868- [emacs-20.5a-2]
869- added ppc patch
870
871* Fri Jan  7 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
872- [emacs-20.5a-1]
873- change version from 20.5 to 20.5a
874- added Mule-4.1 patch
875
876* Fri Jan  7 2000 Yasuyuki Furukawa <yasu@on.cs.keio.ac.jp>
877- [emacs-20.5-1]
878- add desktop-link files for desktop menu.
879
880* Fri Dec 24 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
881- [emacs-20.4-16]
882- replaced Y2K savvy timezone.{el,elc} with one from brand-new apel-10.0
883
884* Tue Dec 21 1999 Jun Nishii <jun@vinelinux.org>
885- added documents
886- strip bins
887
888* Wed Dec  1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
889- [emacs-20.4-14]
890- Change Group to Applications/Editors/Emacs
891
892* Sat Nov  6 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
893- [emacs-20.4-13]
894- included Y2K savvy timezone.{el,elc},
895  modified by Mr. Youichi Teranishi <teranishi@gohome.org>
896
897* Tue Oct 12 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
898- [emacs-20.4-12]
899- Modified info-dir.
900- Removed -c option from %setup.
901
902* Mon Sep 20 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
903- fixed XIM support patch
904* Sun Sep 19 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
905- fixed postinst bug and fontset patch
906* Sun Jul 18 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
907- first build
Note: See TracBrowser for help on using the repository browser.