source: projects/specs/trunk/e/emacs/emacs24-vl.spec @ 6760

Revision 6760, 27.7 KB checked in by munepi, 12 years ago (diff)

new upstream release

Line 
1%define emacsversion 24.2
2#% define bzrdate 20110817
3%define emacsrelease 1%{?bzrdate:.%bzrdate}%{?_dist_release}
4%define vine_default_major_version %(echo %_dist_release|%__sed s/vl//)
5
6%define _noVersionedDependencies 1
7%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
8
9%define infodir %{_infodir}/emacs-%{emacsversion}
10
11%define menutreeelversion 0.97
12
13Summary:      GNU Emacs editor
14Summary(ja):  GNU Emacs エディタ
15Name:         emacs
16#Name:         emacs24
17#Provides:     emacs-snapshot
18Version:      %{emacsversion}
19Release:      %{emacsrelease}
20Source0:      ftp://ftp.gnu.org/pub/gnu/emacs/emacs-%{version}.tar.xz
21#Source0:      ftp://ftp.gnu.org/pub/gnu/emacs/emacs-%{version}%{?bzrdate:.bzr%bzrdate}.tar.xz
22#Source0:      ftp://alpha.gnu.org/gnu/emacs/pretest/emacs-%{emacsversion}.tar.gz
23Source1:      emacs-snapshot.sh
24
25Source10:     site-start.el.emacs24
26
27## local settings for local system
28Source20:     emacs24-local.el
29
30# desktop file
31Source50:     emacs24.desktop.in
32
33## Enable Japanese Menu
34## http://www11.atwiki.jp/s-irie/pages/13.html
35Source100:    menu-tree-el-%{menutreeelversion}.tar.gz
36Source110:    menu-tree-init.el.emacs24
37
38## default settings for Vine Linux
39Source150:    vine-default-base.el
40Source151:    vine-default-faces.el
41
42## Vine Patch(es)
43#Patch10:      emacs-21.1-ppc-nocombreloc.patch
44Patch11:      emacs-23.0.60-locallisppath.patch
45Patch20:      emacs-23.1.90-fixed-resolution.patch
46Patch30:      emacs-24.0.90-libs-termcap.patch
47
48# Fixed in upstream CVS. (from Fedora)
49
50# security patches (from Debian)
51
52# security patches (from Ubuntu)
53
54# patches from Mandrake
55Patch1001:    emacs-21.1-bzip2.patch.bz2
56
57License:      GPLv3+
58Group:        Applications/Editors/Emacs
59
60Distribution: Vine Linux
61Vendor:       Project Vine
62Packager:     munepi, daisuke
63
64BuildRoot:    %{_tmppath}/%{name}-%{version}-root
65# Requires:     tamago >= 4.0.6
66Obsoletes:    mule-base, mule-canna, mule-wnn6, mule, emacs-beta
67Obsoletes:    emacs21 <= 21.2-0vl7
68Obsoletes:    emacs22 <= 22.1
69Obsoletes:    emacs23 <= 23.1
70Obsoletes:    emacs24 <= 24.1
71#Provides:     emacs24 = %{version}
72Provides:     emacsen = 0.1
73#% prereq_ge    emacsen-common
74Requires(post):    emacsen-common
75Requires(postun):    emacsen-common
76
77BuildRequires: autoconf
78BuildRequires: xz
79BuildRequires: atk-devel
80BuildRequires: dbus-devel GConf2-devel
81BuildRequires: alsa-lib-devel
82BuildRequires: gnutls-devel
83%if %{?_dist_release} >= "vl7"
84BuildRequires: gtk3-devel
85%else
86BuildRequires: gtk2-devel
87%endif
88BuildRequires: cairo-devel
89BuildRequires: freetype2-devel, fontconfig-devel
90BuildRequires: libpng-devel, libjpeg-devel, libtiff-devel, libungif-devel
91BuildRequires: librsvg2-devel, libotf-devel
92BuildRequires: ImageMagick-devel
93BuildRequires: libxml2-devel > 2.6.17
94BuildRequires: m17n-lib-devel
95BuildRequires: libX11-devel, libXau-devel, libXdmcp-devel, libXrender-devel
96BuildRequires: libSM-devel, libXt-devel, libXpm-devel, ncurses-devel
97BuildRequires: xorg-x11-proto-devel, zlib-devel
98BuildRequires: texinfo
99BuildRequires: nkf
100
101%description
102GNU Emacs is the extensible, customizable, self-documenting real-time
103display editor.
104
105%description -l ja
106GNU Emacs は拡張性が高く、さまざまなカスタマイズが可能な高機能エディタです。
107
108
109%prep
110
111%setup -q -n emacs-%{version}
112
113%ifarch ppc
114#%patch10 -p1
115%endif
116
117%patch11 -p1
118%patch20 -p1
119%patch30 -p1
120
121%patch1001 -p1
122
123#autoconf
124autoreconf -i -I m4
125
126%build
127
128export CFLAGS="-DMAIL_USE_LOCKF $RPM_OPT_FLAGS"
129#to find installinfo
130export PATH="$PATH:/sbin:/usr/sbin"
131
132%configure --with-pop --with-sound \
133    --libexecdir=%{_libdir} --infodir=%{infodir} \
134    --disable-rename \
135%if %{?_dist_release} >= "vl7"
136    --with-x-toolkit=gtk3 \
137%else
138    --with-x-toolkit=gtk \
139%endif
140    --with-freetype --with-xft \
141    --enable-font-backend \
142    --without-gpm \
143    --with-libotf \
144    --with-m17n-flt \
145    --with-dbus --with-gconf \
146    ;
147
148%__make bootstrap
149%__make %{?_smp_mflags}
150
151
152#%define recompile src/emacs -batch --no-init-file --no-site-file -f batch-byte-compile
153
154# recompile patched .el files
155#%{recompile} lisp/mail/mh-utils.el lisp/progmodes/make-mode.el
156
157# bytecompile python-mode, ssl, php-mode and rpm-spec-mode
158#cp %SOURCE12  %SOURCE14 %SOURCE16 %SOURCE17 .
159##%%{recompile} rpm-spec-mode.el php-mode.el ssl.el po-mode.el
160
161
162%install
163[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
164
165ARCHDIR=${RPM_ARCH}-vine-linux
166
167%makeinstall libexecdir=$RPM_BUILD_ROOT%{_libdir} \
168        infodir=${RPM_BUILD_ROOT}%{infodir}
169
170## This is a duplicate of the file in FLAVOR/site-lisp
171%__rm -f $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/subdirs.el || exit 1
172
173# (cd $RPM_BUILD_ROOT%{_mandir}/man1/; %__mv ctags.1 gctags.1)
174# (cd $RPM_BUILD_ROOT%{_bindir}/; %__mv ctags gctags)
175
176%__mkdir_p  $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/etc
177%__mkdir_p  $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp
178# cp %{SOURCE100} $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/menu-tree.el
179# nkf -w %{SOURCE100} > $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/menu-tree-utf8.el
180%__tar zxvf %{SOURCE100}
181%__cp -a menu-tree-el-%{menutreeelversion}/menu-tree.el $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/
182nkf -w --overwrite $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/menu-tree.el
183
184## vine default
185%__cp -a %{SOURCE150} %{SOURCE151} \
186    $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/
187
188# The elisp reference manual
189#bzcat %{SOURCE13} | tar xf -
190#pushd elisp-manual-21-2.8
191#install -m 644 elisp elisp-? elisp-?? $RPM_BUILD_ROOT/%{infodir}
192#popd
193
194# some modifications of installed files
195
196#rm -f $RPM_BUILD_ROOT%{infodir}/dir
197#gzip -9nf $RPM_BUILD_ROOT%{infodir}/*
198
199%__install -m 644 %{SOURCE10} \
200        $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/site-start.el
201%__sed -i -e 's/EMACS_VERSION/%{version}/g' \
202          -e 's/VINE_DEFAULT_MAJOR_VERSION/%{vine_default_major_version}/g' \
203        $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/site-start.el
204
205## create site-start.d directory
206%__install -m 755 -d ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d
207
208# install coding-system init.el
209%__install -m644 %{SOURCE110} \
210    $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/menu-tree-init.el
211%__ln_s -f %{_datadir}/emacs-%{version}/site-lisp/menu-tree-init.el \
212    ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d/60menu-tree-init.el
213
214## install system-wide configure file
215%__install -m755 -d ${RPM_BUILD_ROOT}/etc/emacs
216%__install -m644 %{SOURCE20} ${RPM_BUILD_ROOT}/etc/emacs/emacs24-local.el
217%__sed -i -e 's/EMACS_VERSION/%{version}/g' \
218    ${RPM_BUILD_ROOT}/etc/emacs/emacs24-local.el
219
220## Python mode, php mode and rpm-spec mode
221
222## make file list
223strip $RPM_BUILD_ROOT%{_bindir}/* || :
224
225# install desktop file
226%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/applications
227%__sed -e "s/@@EMACS_VERSION@@/%{emacsversion}/g" %{SOURCE50} > \
228    $RPM_BUILD_ROOT%{_datadir}/applications/$(basename %{SOURCE50} .in)
229[ -f $RPM_BUILD_ROOT%{_datadir}/applications/emacs.desktop ] && \
230    %__rm -f $RPM_BUILD_ROOT%{_datadir}/applications/emacs.desktop || exit 1
231
232# install icons
233%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/icons
234%__cp -a etc/images/icons/hicolor $RPM_BUILD_ROOT%{_datadir}/icons/
235
236## remove man files
237%__rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/* || exit 1
238
239## Remove ctags
240#rm -f $RPM_BUILD_ROOT/usr/bin/ctags
241#rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/*ctags*
242#rm -f $RPM_BUILD_ROOT/%{_datadir}/emacs/%{version}/etc/ctags*
243
244DIR="${RPM_BUILD_ROOT}%{_datadir}/emacs \
245     ${RPM_BUILD_ROOT}%{_datadir}/emacs-%{version}"
246BIN=${RPM_BUILD_ROOT}%{_bindir}
247LIB=${RPM_BUILD_ROOT}%{_libdir}
248EL="*.el"
249
250## prepare file list for emacs
251echo "/usr/bin/ctags
252/usr/bin/ebrowse
253/usr/bin/etags
254/usr/bin/rcs-checkin
255/usr/bin/emacs
256/usr/bin/emacsclient
257/usr/bin/grep-changelog
258/usr/share/icons/hicolor/scalable/apps/emacs.svg
259/usr/share/icons/hicolor/scalable/mimetypes/emacs-document.svg" |
260    %__sed -e "s#[^\n]*#mv ${RPM_BUILD_ROOT}\0 ${RPM_BUILD_ROOT}\0.emacs-%{version}#"|
261    awk '{system($_)}' 
262
263find $DIR $BIN $LIB -type d |
264  %__sed -e "s#^${RPM_BUILD_ROOT}#%dir #" > rpm-files
265
266find $DIR $BIN $LIB -type f |
267  %__sed -e "
268    s#^${RPM_BUILD_ROOT}\(.*movemail\)#%attr(2755, root, mail) \1#
269    s#^${RPM_BUILD_ROOT}##
270  " >> rpm-files
271
272
273%clean
274[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
275
276
277%define info_files ccmode cl dired-x ediff emacs forms gnus info message mh-e reftex sc vip viper widget
278
279
280%pre
281
282if [ -L %{_datadir}/emacs-%{version}/site-lisp ] ; then
283    %__rm -f %{_datadir}/emacs-%{version}/site-lisp
284fi
285
286if [ -d %{_datadir}/emacs/%{version}/site-lisp ] ; then
287    find %{_datadir}/emacs/%{version}/site-lisp/* -maxdepth 0 | grep -v subdirs.el | \
288        xargs %__rm -rf
289fi
290
291
292%post
293
294if [ "$1" = 1 ]; then
295
296%_addflavorslist emacs-%{version}
297
298export PRIORITY=50
299
300%_installemacs emacs-%{version}
301
302unset PRIORITY
303fi
304
305if [ "$1" = 2 ]; then
306
307#  export PRIORITY=50
308 
309#  %_installemacs emacs-%{version}
310 
311#  unset PRIORITY
312   
313  echo emacs-%{version} >  /var/lib/emacsen-common/doinstaflavor-emacs
314   
315fi
316
317
318%postun
319
320if [ $1 = 1 ]; then
321# run upgrade install time
322
323# old version uninstall
324
325%_removeflavorslist emacs-%{version}
326
327%_removeemacs emacs-%{version}
328
329#new version install
330if [ -f /var/lib/emacsen-common/doinstaflavor-emacs ] ; then
331
332NEWFLAVOR=$(cat /var/lib/emacsen-common/doinstaflavor-emacs)
333
334%_addflavorslist $NEWFLAVOR
335
336export PRIORITY=50
337
338%_installemacs $NEWFLAVOR
339
340unset PRIORITY
341
342%__rm -rf /var/lib/emacsen-common/doinstaflavor-emacs
343
344fi
345
346fi
347
348
349%preun
350if [ $1 = 0 ]; then
351
352%_removeflavorslist emacs-%{version}
353
354%_removeemacs emacs-%{version}
355
356fi
357
358
359%triggerpostun -- emacs23 < %{version}-%{release}
360
361%_addflavorslist emacs-%{version}
362
363export PRIORITY=50
364
365%_installemacs emacs-%{version}
366
367unset PRIORITY
368
369
370%files -f rpm-files
371%defattr(-,root,root)
372%doc INSTALL README BUGS ChangeLog COPYING
373#%doc INSTALL.BZR
374%dir %{_sysconfdir}/emacs-%{version}
375%dir %{_sysconfdir}/emacs-%{version}/site-start.d
376%{_sysconfdir}/emacs-%{version}/site-start.d/*.el
377%config(noreplace) %{_sysconfdir}/emacs/emacs24-local.el
378%{_infodir}/*
379# %{_mandir}/*/*
380%{_datadir}/applications/emacs24.desktop
381%{_datadir}/icons/hicolor/*
382# %{_datadir}/emacs-%{version}/site-lisp
383%dir %{_localstatedir}/games/emacs
384%{_localstatedir}/games/emacs/*
385
386
387%changelog
388* Mon Aug 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.2-1
389- new upstream release
390
391* Sun Jun 10 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.1-1
392- new upstream release
393
394* Sat May 19 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.97-1
395- updated to 24.0.97 (24.1 pretest)
396
397* Sun Apr 29 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.96-1
398- updated to 24.0.96 (24.1 pretest)
399
400* Mon Apr  2 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.95-1
401- updated to 24.0.95 (24.1 pretest)
402
403* Sun Mar 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.0.94-2
404- rebuild with ImageMagick-6.7.5.10
405
406* Mon Feb 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.94-1
407- updated to 24.0.94 (24.1 pretest)
408
409* Tue Feb 14 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.93-2
410- use gtk as X toolkit (for vl6)
411
412* Mon Jan 30 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.93-1
413- updated to 24.0.93 (24.1 pretest)
414
415* Thu Dec  1 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.92-1
416- updated to 24.0.92 (24.1 pretest)
417
418* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.91-1
419- updated to 24.0.91 (24.1 pretest)
420
421* Thu Oct  6 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.90-2
422- set --with-x-toolkit=gtk3 (%%configure)
423  - added BuildRequires: gtk3-devel
424
425* Mon Sep 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.90-1
426- updated to 24.0.90 (24.1 pretest)
427- applied emacs-24.0.90-libs-termcap.patch
428
429* Sat Jul 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-10.20110817
430- emacs24 24.0.50 (20110817) snapshot
431- added BuildRequires: ImageMagick-devel, libSM-devel, libxml2-devel > 2.6.17
432
433* Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-9.20110604
434- emacs24 24.0.50 (20110604) snapshot
435
436* Thu Apr 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-8.20110413
437- emacs24 24.0.50 (20110413) snapshot
438
439* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-7.20110318
440- updated site-start.el
441  - defined vine-default-major-version, vine-default-minor-version,
442    vine-default-version
443  - set "ibus-el" to emacs-ime as default
444  - added ", modified for Vine Linux" to the end of emacs-build-system
445  - set "Vine _at_mark_ vinelinux.org" to report-emacs-bug-address
446
447* Sun Apr 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-6.20110318
448- fixed site-start.el
449  - do not use the macro loop (contained in the common lisp)
450
451* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-5.20110318
452- emacs24 24.0.50 (20110318) snapshot
453
454* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-4.20110222
455- emacs24 24.0.50 (20110222) snapshot
456- updated site-start.el
457  - defined the function drop-vine-default-from-load-path (regex)
458
459* Sat Jan 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-3.20110128
460- emacs24 24.0.50 (20110128) snapshot
461
462* Sun Jan 02 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-2.20110101
463- emacs24 24.0.50 (20110101) snapshot
464
465* Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-1.20101203
466- emacs24 24.0.50 (20101203) snapshot
467- applied new vine-default system
468  - updated site-start.el
469  - updated vine-default-{base,faces}.el
470  - dropped showvdefaultemacs
471    - merged to emacsen-common package as show-vine-default.sh
472  - renamed local wide configration file to emacs24-local.el
473- updated menu-tree.el to version 0.97
474- added Provides: emacs-snapshot
475
476* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-4
477- updated vine-default-base.el
478  - changed the variable next-line-add-newlines to nil (default)
479
480* Thu Sep 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-3
481- updated menu-tree.el to version 0.96
482
483* Sat Jul 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-2
484- applied some patches from Fedora
485  - Fixed handling of dual spacing fonts rhbz#599437
486  - Add patch to fix rhbz#595546 hideshow library matches wrong parenthesis
487    under certain circumstances
488  - Added a patch fixing m17n and libotf version checking (m17ncheck)
489- updated menu-tree.el to version 0.95
490- merged emacs23-vl.spec of Vine Linux 5.1
491#* Thu Apr 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-9
492#- applied security fix emacs23-CVE-2010-0825-fix-movemail-race.diff from Ubuntu
493#
494#* Fri Feb 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-8
495#- added Requires(post): emacsen-common, Requires(postun): emacsen-common
496#
497#* Fri Feb 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-7
498#- dropped BuildRequires: m17n-lib-devel
499#- added --without-m17n-flt in %%configure
500
501* Mon May 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-1
502- new upstream release
503- updated menu-tree.el to version 0.94
504- updated menu-tree-init.el.emacs23
505  - used prefer-coding-system
506
507* Wed Apr 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.96-1
508- updated to 23.1.96 (23.2 pretest)
509
510* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.95-2
511- removed /usr/share/emacs/site-lisp/subdirs.el
512
513* Sat Apr 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.95-1
514- updated to 23.1.95 (23.2 pretest)
515- added BuildRequires:
516  - atk-devel
517  - dbus-devel
518  - GConf2-devel
519  - alsa-lib-devel
520- added some configure options:
521  --with-libotf --with-m17n-flt --with-dbus --with-gconf
522
523* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.94-1
524- updated to 23.1.94
525
526* Thu Mar 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.93-1
527- updated to 23.1.93 alpha
528
529* Sat Feb 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.92-2
530- added Requires(post): emacsen-common, Requires(postun): emacsen-common
531
532* Tue Feb 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.92-1
533- update to 23.1.92 alpha
534
535* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-6
536- added BuildRequires:
537  - librsvg2-devel
538  - m17n-lib-devel
539  - libotf-devel
540
541* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-5
542- changed License to GPLv3+
543- renamed emacs23.desktop to emacs23.desktop.in
544- updated vine-default-base.el (See [vine-users:079919])
545- fixed in upstream CVS (from Fedora)
546  - fix #543046 - Using scroll bar in emacs highlights/selects text
547  - fix #542657 - emacs does not display indic text
548  - Fixed rhbz#545398 - ETags messes up filenames
549
550* Tue Sep 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-4
551- rebuilt to add signature
552
553* Fri Aug 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-3
554- added BuildRequires: nkf
555- updated menu-tree-init.el.emacs23
556  - fixed menu-tree encoding <BTS:VineLinux:766>
557- set Exec=emacs-@@EMACS_VERSION@@ in emacs23.desktop
558
559* Wed Aug 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-2
560- replaced BR: libungif-devel with BR: giflib-devel
561
562* Sat Aug 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-1
563- new upstream release
564
565* Sat Jul 25 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.0.96-2.20090714
566- updated vine-default-faces.el to sync with emacs22
567
568* Tue Jul 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.96-1.20090714
569- update to 23.0.96 (20090714) snapshot
570- update vine-default-faces.el
571  - use bash to call gconftool-2
572
573* Sat Jun 27 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-4.20090527
574- update vine-default-faces.el
575  - added \'font in default-frame-alist
576    (if \'font is already in default-frame-alist, overwrited it)
577
578* Wed Jun 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-3.20090527
579- update vine-default-faces.el:
580  - use set-frame-font
581    bacause set-default-font function is obsolete since Emacs 23.1
582    (See M-x describe-function RET set-default-font)
583
584* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-2.20090527
585- update vine-default-faces.el:
586  - set desktop-gnome-interface-monospace-font-name
587    from /desktop/gnome/interface/monospace_font_name
588  - automatically set set-default-font
589    with desktop-gnome-interface-monospace-font-name
590
591* Wed May 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.94-1.20090527
592- update to emacs-23.0.94 (20090527) snapshot
593- add --without-gpm to configure
594
595* Thu May 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-7.20090422
596- defined show-vine-default function in site-start.el
597  - added showvdefaultemacs script
598
599* Wed May 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-6.20090422
600- set PRIORITY=40
601
602* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-5.20090422
603- changed menu-tree-init.el from hard copy to symbolic link
604  on /etc/emacs-23.0.92/site-start.d
605- added %%{_mandir}/*/* in %%files section
606
607* Sat May 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-4.20090422
608- updated menu-tree.el to v0.93
609
610* Fri May 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-3.20090422
611- returned alternatives priority to 30
612  (emacs: 30, emacs22: 30)
613
614* Sun Apr 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-2.20090422
615- installed system-wide configure file in /etc/emacs
616- updated vine-default-base.el
617- changed alternatives priority from 30 to 50
618  (emacs: 50, emacs22: 30)
619
620* Wed Apr 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.92-1.20090422
621- update to emacs 23.0.92 (20090422) snapshot
622- add %%triggerpostun to fix alternatives
623
624* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.91-3.20090325
625- renamed from emacs23 to emacs (emacs-22.x would be renamed to emacs22)
626- updated default settings for Vine Linux
627  - dropped vine-default-mouse.el, vine-default-misc.el
628
629* Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.91-2.20090325
630- enable default settings for Vine Linux
631  - added site-start.el.emacs23
632  - updated site-start.el
633  - added vine-default-base.el, vine-default-faces.el, vine-default-mouse.el,
634    vine-default-misc.el
635
636* Wed Mar 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.91-1.20090325
637- emacs23 23.0.91 snapshot
638
639* Tue Sep 09 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 23.0.60-2.20080908
640- drop patch10
641- s/emacsrelese/emacsrelease/
642
643* Mon Sep 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.60-1.20080908
644- emacs23 23.0.60 snapshot
645
646* Sun Sep 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.3-1
647- new upstream release
648
649* Mon Aug 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 22.2-3
650- import security fixes from Debian
651  CVE-2008-2142: fix insecure setting of fast-lock-cache-directories
652  CVE-2008-1694: fix insecure temporary file creation in vcdiff script
653                 leading to possible symlink attacks
654
655* Tue Jun 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.2-2
656- update menu-tree.el
657- add 60menu-tree-init.el to sed coding-system and load menu-tree
658- build with xorg-x11-7.3
659  - update BuildRequires
660
661* Sun Mar 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.2-1
662- new upstream release
663
664* Wed Nov 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 22.1-0vl2
665- add Patch10000 to fix local variable processing security bypass
666  vulnerability.
667  - http://www.frsirt.com/english/advisories/2007/3715
668  - http://bugs.debian.org/449008
669
670* Mon Jun 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 22.1-0vl1
671- new upstream release
672- rename to emacs from emacs22 (emacs-21.x would be renameed to emacs21)
673- drop emcws support
674
675* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 22.0.50-0.20060403vl3
676- rebuilt with new toolchain
677
678* Sat May 06 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 22.0.50-0.20060403vl2
679- changed Group:
680
681* Mon Apr 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20060403vl1
682- update to CVS-20060403
683- update emacs22.desktop
684
685* Wed Sep 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050927vl2
686- fix site-start.el
687
688* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050927vl1
689- update to CVS-20050927
690
691* Thu Sep  8 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050907vl1
692- initial build for Vine Linux based on emacs package.
693  - emacs-22.0.50 on CVS-20050907
694
695* Sat Sep  3 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.4-0vl3
696- create site-start.d directory on %install
697
698* Thu Feb 17 2005 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.4-0vl2
699- included leim-21.4
700- update emcws-21.3-20031213.gz
701
702* Wed Feb 16 2005 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.4-0vl1
703- update
704
705* Sat Jul 24 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl7
706- rebuild with Xaw3d, add BuildRequires: Xaw3d-devel
707
708* Fri Jul 23 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl6
709- add Patch20 to fix display resolutions. (set to 96dpi)
710  (do not compute dynamically from display's size)
711
712* Tue Mar 16 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.3-0vl5
713- rebuilt with new toolchain environment
714
715* Thu Jul 17 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.3-0vl4
716- use site-start.el(reading /etc/emacs-21.3/site-start.d/*.el)
717
718* Wed May  7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 21.3-0vl3
719- add BuildPrereq: libpng >= 1.2.5
720
721* Tue Apr 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl2
722- fixed %%pre script
723
724* Tue Mar 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl1
725- new upstream release
726- remove patch14 whick included in upstream
727
728* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl11
729- add patch14 to fix frame title text encoding.
730  - http://tsukuba.m17n.org/mule-ja-archive/2002-10/msg00004.html
731
732* Tue Dec 10 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.2-0vl10
733- autoconf-2.13, not autoconf in %%setup section
734- BuildPreReq: autoconf213
735
736* Mon Dec  9 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl9
737- modifiy rpm scripts.
738
739* Mon Dec  9 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl8
740- rename to emacs
741- obsoletes emacs21 <= 21.2-0vl7, provides emacs21 = %%{version}
742
743* Sun Dec  1 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl7
744- enable menubar fontset patch (Patch103)
745
746* Sat Nov 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl6
747- add requires/buildprereq tags.
748
749* Sat Nov 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl5
750- add emcws-20021014
751
752* Sun Jul 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl4
753- removed *-mode
754
755* Sat Jul 20 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl3
756- python-mode was made pending
757- some additional *.el files was moved from "emacs/site-lisp" to
758  "emacs-(version)/site-lisp"
759
760* Sat Jul 13 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl2
761- added some sources and patches from rawhide 21.2-11 and mandrake 21.2-7mdk
762
763* Sat May 11 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.2-0vl1
764- update.
765- Package Name emacs-beta -> emacs21
766- Add Patch100,101,102, Source100(default = Disable)
767- (from http://phe.phyas.aichi-edu.ac.jp/~cyamauch/pl2.html#emacs21)
768- --infodir=%{_infodir}/emacs-21.2(VineSeed-Plus:00723)
769
770* Thu Dec 27 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl7
771- site-lisp moved under /usr/share/emacs-21.1/ (Patch11 and %%pre section)
772
773* Thu Dec 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl5
774- move /tmp -> /var/lib/emacsen-common (IP(package)C file)
775
776* Fri Nov 02 2001 Tomoya TAKA <tomoya@olive.plala.or.jp> 21.1-0vl4
777- replace patch10 with patch11, posted to gnu.emacs.bug
778  Message-Id: <jebsiza3db.fsf@sykes.suse.de>
779  (reported by ABE Yuji <cbo46560@pop12.odn.ne.jp>)
780
781* Fri Oct 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.1-0vl3
782- fixed build to fail in alpha( only apply patch0 to ppc)
783
784* Tue Oct 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl2
785- added Patch10 (thanks Kitame-san)
786
787* Mon Oct 22 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.1-0vl1
788- update to 21.1
789
790* Sun Sep 9 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.104-0vl14
791- support  shared installing otheremacsen.
792
793* Mon Jul 23 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.104-0vl3
794- update 21.0.104
795
796* Thu Jul 19 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.103-0vl2
797- support emacsen-common
798
799* Wed May 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
800- 21.0.103-0vl1
801- updated to 21.0.103
802- revamped and cleaned up spec file :-)
803- Requires: tamago >= 4.0.6 (...is it reasonable? Mmm...)
804
805* Mon Jan 22 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.95-0vl2
806- fixed .spec bugs( _libdir)
807
808* Fri Jan 12 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.95-0vl1
809- updated to 21.0.95
810
811* Wed Dec 20 2000 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.93-0vl3
812- fixed emacs-beta.spec
813
814* Sat Dec 16 2000 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.93-0vl2
815- 21.0.93 test packaging.
816
817* Fri Jun 30 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
818- added linespace-patch
819
820* Mon Jun 19 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
821- updated to emacs 20.7
822
823* Thu Apr 20 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
824- updated to emacs 20.6
825
826* Mon Feb 28 2000 kenji KITAYAMA <kenji@gandalf.doshisha.ac.jp>
827- [emacs-20.5a-2]
828- Modified reference of Emacs Info
829
830* Sun Jan 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
831- [emacs-20.5a-2]
832- added ppc patch
833
834* Fri Jan  7 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
835- [emacs-20.5a-1]
836- change version from 20.5 to 20.5a
837- added Mule-4.1 patch
838
839* Fri Jan  7 2000 Yasuyuki Furukawa <yasu@on.cs.keio.ac.jp>
840- [emacs-20.5-1]
841- add desktop-link files for desktop menu.
842
843* Thu Dec 24 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
844- [emacs-20.4-16]
845- replaced Y2K savvy timezone.{el,elc} with one from brand-new apel-10.0
846
847* Tue Dec 21 1999 Jun Nishii <jun@vinelinux.org>
848- added documents
849- strip bins
850
851* Wed Dec  1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
852- [emacs-20.4-14]
853- Change Group to Applications/Editors/Emacs
854
855* Sat Nov  6 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
856- [emacs-20.4-13]
857- included Y2K savvy timezone.{el,elc},
858  modified by Mr. Youichi Teranishi <teranishi@gohome.org>
859
860* Tue Oct 12 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
861- [emacs-20.4-12]
862- Modified info-dir.
863- Removed -c option from %setup.
864
865* Sun Sep 20 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
866- fixed XIM support patch
867* Sun Sep 19 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
868- fixed postinst bug and fontset patch
869* Sun Jul 18 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
870- first build
Note: See TracBrowser for help on using the repository browser.