source: projects/specs/trunk/e/emacs/emacs24-vl.spec @ 8390

Revision 8390, 28.4 KB checked in by munepi, 10 years ago (diff)

updated to 24.3.90

RevLine 
[8390]1%define emacsversion 24.3.90
[6317]2#% define bzrdate 20110817
[8390]3%define emacsrelease 1%{?bzrdate:.%bzrdate}%{?_dist_release}
[3304]4%define vine_default_major_version %(echo %_dist_release|%__sed s/vl//)
[625]5
6%define _noVersionedDependencies 1
7%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
8
9%define infodir %{_infodir}/emacs-%{emacsversion}
10
[2293]11%define menutreeelversion 0.97
[1100]12
[625]13Summary:      GNU Emacs editor
14Summary(ja):  GNU Emacs エディタ
[6760]15Name:         emacs
16#Name:         emacs24
17#Provides:     emacs-snapshot
[625]18Version:      %{emacsversion}
19Release:      %{emacsrelease}
[7672]20#Source0:      ftp://ftp.gnu.org/pub/gnu/emacs/emacs-%{version}.tar.xz
[6317]21#Source0:      ftp://ftp.gnu.org/pub/gnu/emacs/emacs-%{version}%{?bzrdate:.bzr%bzrdate}.tar.xz
[7672]22Source0:      ftp://alpha.gnu.org/gnu/emacs/pretest/emacs-%{emacsversion}.tar.xz
[6317]23Source1:      emacs-snapshot.sh
[625]24
[6317]25Source10:     site-start.el.emacs24
[625]26
27## local settings for local system
[6317]28Source20:     emacs24-local.el
[625]29
30# desktop file
[6317]31Source50:     emacs24.desktop.in
[625]32
33## Enable Japanese Menu
34## http://www11.atwiki.jp/s-irie/pages/13.html
[7672]35# Source100:    menu-tree-el-%{menutreeelversion}.tar.gz
36# Source101:    menu-tree-init.el.emacs24
37Source102:    coding-system-init.el.emacs24
[625]38
39## default settings for Vine Linux
40Source150:    vine-default-base.el
41
42## Vine Patch(es)
[8390]43Patch11:      emacs-24.3.90-locallisppath.patch
[7672]44#Patch20:      emacs-23.1.90-fixed-resolution.patch
[6317]45Patch30:      emacs-24.0.90-libs-termcap.patch
[625]46
[7672]47# patches from Fedora
48# rhbz#713600
49Patch107: emacs-spellchecker.patch
[625]50
51# security patches (from Debian)
52
[7672]53#Patch1001:    emacs-21.1-bzip2.patch.bz2
[1272]54
[625]55License:      GPLv3+
56Group:        Applications/Editors/Emacs
57
[6317]58Distribution: Vine Linux
[625]59Vendor:       Project Vine
60Packager:     munepi, daisuke
61
62BuildRoot:    %{_tmppath}/%{name}-%{version}-root
63# Requires:     tamago >= 4.0.6
64Obsoletes:    mule-base, mule-canna, mule-wnn6, mule, emacs-beta
65Obsoletes:    emacs21 <= 21.2-0vl7
[6760]66Obsoletes:    emacs22 <= 22.1
67Obsoletes:    emacs23 <= 23.1
68Obsoletes:    emacs24 <= 24.1
69#Provides:     emacs24 = %{version}
[625]70Provides:     emacsen = 0.1
71#% prereq_ge    emacsen-common
72Requires(post):    emacsen-common
73Requires(postun):    emacsen-common
74
75BuildRequires: autoconf
[6317]76BuildRequires: xz
[887]77BuildRequires: atk-devel
[1272]78BuildRequires: dbus-devel GConf2-devel
79BuildRequires: alsa-lib-devel
[6317]80BuildRequires: gnutls-devel
[8390]81#if %{?_dist_release} >= "vl7"
82#BuildRequires: gtk3-devel
83#else
[6317]84BuildRequires: gtk2-devel
[8390]85#endif
[6317]86BuildRequires: cairo-devel
87BuildRequires: freetype2-devel, fontconfig-devel
[625]88BuildRequires: libpng-devel, libjpeg-devel, libtiff-devel, libungif-devel
[887]89BuildRequires: librsvg2-devel, libotf-devel
[6317]90BuildRequires: ImageMagick-devel
91BuildRequires: libxml2-devel > 2.6.17
[887]92BuildRequires: m17n-lib-devel
[625]93BuildRequires: libX11-devel, libXau-devel, libXdmcp-devel, libXrender-devel
[6317]94BuildRequires: libSM-devel, libXt-devel, libXpm-devel, ncurses-devel
[625]95BuildRequires: xorg-x11-proto-devel, zlib-devel
96BuildRequires: texinfo
97BuildRequires: nkf
98
99%description
100GNU Emacs is the extensible, customizable, self-documenting real-time
101display editor.
102
103%description -l ja
[2293]104GNU Emacs は拡張性が高く、さまざまなカスタマイズが可能な高機能エディタです。
[625]105
106
107%prep
108
109%setup -q -n emacs-%{version}
110
111%patch11 -p1
[7672]112#%patch20 -p1
113#%patch30 -p1
[625]114
[7672]115%patch107 -p1 -b .spellchecker
[625]116
[7672]117#%patch1001 -p1
118
119
120# Avoid trademark issues
121grep -v "tetris.elc" lisp/Makefile.in > lisp/Makefile.in.new \
122   && %__mv lisp/Makefile.in.new lisp/Makefile.in || exit 1
123%__rm -f lisp/play/tetris.el lisp/play/tetris.elc || exit 1
124
[6317]125#autoconf
126autoreconf -i -I m4
[625]127
128%build
129export CFLAGS="-DMAIL_USE_LOCKF $RPM_OPT_FLAGS"
130#to find installinfo
131export PATH="$PATH:/sbin:/usr/sbin"
132
133%configure --with-pop --with-sound \
[1272]134    --libexecdir=%{_libdir} --infodir=%{infodir} \
135    --disable-rename \
[6317]136    --with-x-toolkit=gtk \
[5462]137    --with-freetype --with-xft \
138    --enable-font-backend \
[1272]139    --without-gpm \
[6317]140    --with-libotf \
141    --with-m17n-flt \
142    --with-dbus --with-gconf \
[1272]143    ;
[8390]144#    --with-x-toolkit=gtk3 \
[625]145
[887]146%__make bootstrap
147%__make %{?_smp_mflags}
[625]148
149
150%install
[1100]151[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
[625]152
153%makeinstall libexecdir=$RPM_BUILD_ROOT%{_libdir} \
154        infodir=${RPM_BUILD_ROOT}%{infodir}
155
[887]156## This is a duplicate of the file in FLAVOR/site-lisp
157%__rm -f $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/subdirs.el || exit 1
158
[6317]159# (cd $RPM_BUILD_ROOT%{_mandir}/man1/; %__mv ctags.1 gctags.1)
160# (cd $RPM_BUILD_ROOT%{_bindir}/; %__mv ctags gctags)
[625]161
[1100]162%__mkdir_p  $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/etc
163%__mkdir_p  $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp
[7672]164# %__tar zxvf %{SOURCE100}
165# %__cp -a menu-tree-el-%{menutreeelversion}/menu-tree.el $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/
166# nkf -w --overwrite $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/menu-tree.el
[625]167
168## vine default
[7672]169%__cp -a %{SOURCE150} \
[625]170    $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/
171
172# The elisp reference manual
173#bzcat %{SOURCE13} | tar xf -
174#pushd elisp-manual-21-2.8
175#install -m 644 elisp elisp-? elisp-?? $RPM_BUILD_ROOT/%{infodir}
176#popd
177
178# some modifications of installed files
179
180#rm -f $RPM_BUILD_ROOT%{infodir}/dir
181#gzip -9nf $RPM_BUILD_ROOT%{infodir}/*
182
[1100]183%__install -m 644 %{SOURCE10} \
[625]184        $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/site-start.el
[1100]185%__sed -i -e 's/EMACS_VERSION/%{version}/g' \
[3304]186          -e 's/VINE_DEFAULT_MAJOR_VERSION/%{vine_default_major_version}/g' \
[625]187        $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/site-start.el
188
189## create site-start.d directory
[1100]190%__install -m 755 -d ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d
[625]191
192# install coding-system init.el
[7672]193# %__install -m644 %{SOURCE101} \
194#     $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/menu-tree-init.el
195# %__ln_s -f %{_datadir}/emacs-%{version}/site-lisp/menu-tree-init.el \
196#     ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d/60menu-tree-init.el
197%__install -m644 %{SOURCE102} \
198    $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/coding-system-init.el
199%__ln_s -f %{_datadir}/emacs-%{version}/site-lisp/coding-system-init.el \
200    ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d/60coding-system-init.el
[625]201
202## install system-wide configure file
[2293]203%__install -m755 -d ${RPM_BUILD_ROOT}/etc/emacs
[6317]204%__install -m644 %{SOURCE20} ${RPM_BUILD_ROOT}/etc/emacs/emacs24-local.el
[2293]205%__sed -i -e 's/EMACS_VERSION/%{version}/g' \
[6317]206    ${RPM_BUILD_ROOT}/etc/emacs/emacs24-local.el
[625]207
208## Python mode, php mode and rpm-spec mode
209
210## make file list
211strip $RPM_BUILD_ROOT%{_bindir}/* || :
212
213# install desktop file
[1100]214%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/applications
[625]215%__sed -e "s/@@EMACS_VERSION@@/%{emacsversion}/g" %{SOURCE50} > \
216    $RPM_BUILD_ROOT%{_datadir}/applications/$(basename %{SOURCE50} .in)
[2293]217[ -f $RPM_BUILD_ROOT%{_datadir}/applications/emacs.desktop ] && \
218    %__rm -f $RPM_BUILD_ROOT%{_datadir}/applications/emacs.desktop || exit 1
[625]219
220# install icons
[1100]221%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/icons
222%__cp -a etc/images/icons/hicolor $RPM_BUILD_ROOT%{_datadir}/icons/
[625]223
[2293]224## remove man files
225%__rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/* || exit 1
226
227## Remove ctags
[625]228#rm -f $RPM_BUILD_ROOT/usr/bin/ctags
229#rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/*ctags*
[1100]230#rm -f $RPM_BUILD_ROOT/%{_datadir}/emacs/%{version}/etc/ctags*
[625]231
[1100]232DIR="${RPM_BUILD_ROOT}%{_datadir}/emacs \
233     ${RPM_BUILD_ROOT}%{_datadir}/emacs-%{version}"
[625]234BIN=${RPM_BUILD_ROOT}%{_bindir}
235LIB=${RPM_BUILD_ROOT}%{_libdir}
236EL="*.el"
237
238## prepare file list for emacs
[6317]239echo "/usr/bin/ctags
[625]240/usr/bin/ebrowse
241/usr/bin/etags
242/usr/bin/rcs-checkin
243/usr/bin/emacs
244/usr/bin/emacsclient
[2599]245/usr/bin/grep-changelog
246/usr/share/icons/hicolor/scalable/apps/emacs.svg
[6317]247/usr/share/icons/hicolor/scalable/mimetypes/emacs-document.svg" |
[2293]248    %__sed -e "s#[^\n]*#mv ${RPM_BUILD_ROOT}\0 ${RPM_BUILD_ROOT}\0.emacs-%{version}#"|
[7672]249    awk '{system($_)}'
[625]250
251find $DIR $BIN $LIB -type d |
[1100]252  %__sed -e "s#^${RPM_BUILD_ROOT}#%dir #" > rpm-files
[625]253
[7672]254find $DIR $BIN $LIB -type f -o -type l |
[1100]255  %__sed -e "
[625]256    s#^${RPM_BUILD_ROOT}\(.*movemail\)#%attr(2755, root, mail) \1#
257    s#^${RPM_BUILD_ROOT}##
258  " >> rpm-files
259
260
261%clean
[1100]262[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
[625]263
264
265%define info_files ccmode cl dired-x ediff emacs forms gnus info message mh-e reftex sc vip viper widget
266
267
268%pre
269
[1100]270if [ -L %{_datadir}/emacs-%{version}/site-lisp ] ; then
271    %__rm -f %{_datadir}/emacs-%{version}/site-lisp
[625]272fi
273
[1100]274if [ -d %{_datadir}/emacs/%{version}/site-lisp ] ; then
275    find %{_datadir}/emacs/%{version}/site-lisp/* -maxdepth 0 | grep -v subdirs.el | \
276        xargs %__rm -rf
[625]277fi
278
279
280%post
281
282if [ "$1" = 1 ]; then
283
284%_addflavorslist emacs-%{version}
285
[6317]286export PRIORITY=50
[625]287
288%_installemacs emacs-%{version}
289
290unset PRIORITY
291fi
292
293if [ "$1" = 2 ]; then
294
[6317]295#  export PRIORITY=50
[625]296 
297#  %_installemacs emacs-%{version}
298 
299#  unset PRIORITY
300   
301  echo emacs-%{version} >  /var/lib/emacsen-common/doinstaflavor-emacs
302   
303fi
304
305
306%postun
307
308if [ $1 = 1 ]; then
309# run upgrade install time
310
311# old version uninstall
312
313%_removeflavorslist emacs-%{version}
314
315%_removeemacs emacs-%{version}
316
317#new version install
318if [ -f /var/lib/emacsen-common/doinstaflavor-emacs ] ; then
319
320NEWFLAVOR=$(cat /var/lib/emacsen-common/doinstaflavor-emacs)
321
322%_addflavorslist $NEWFLAVOR
323
[6317]324export PRIORITY=50
[625]325
326%_installemacs $NEWFLAVOR
327
328unset PRIORITY
329
[1100]330%__rm -rf /var/lib/emacsen-common/doinstaflavor-emacs
[625]331
332fi
333
334fi
335
336
337%preun
338if [ $1 = 0 ]; then
339
340%_removeflavorslist emacs-%{version}
341
342%_removeemacs emacs-%{version}
343
344fi
345
346
347%triggerpostun -- emacs23 < %{version}-%{release}
348
349%_addflavorslist emacs-%{version}
350
[6317]351export PRIORITY=50
[625]352
353%_installemacs emacs-%{version}
354
355unset PRIORITY
356
357
358%files -f rpm-files
359%defattr(-,root,root)
[6317]360%doc INSTALL README BUGS ChangeLog COPYING
361#%doc INSTALL.BZR
[2293]362%dir %{_sysconfdir}/emacs-%{version}
363%dir %{_sysconfdir}/emacs-%{version}/site-start.d
364%{_sysconfdir}/emacs-%{version}/site-start.d/*.el
[6317]365%config(noreplace) %{_sysconfdir}/emacs/emacs24-local.el
[625]366%{_infodir}/*
367# %{_mandir}/*/*
[6317]368%{_datadir}/applications/emacs24.desktop
[625]369%{_datadir}/icons/hicolor/*
370# %{_datadir}/emacs-%{version}/site-lisp
371%dir %{_localstatedir}/games/emacs
372%{_localstatedir}/games/emacs/*
373
[6317]374
[625]375%changelog
[8390]376* Sun Apr 27 2014 Munehiro Yamamoto <munepi@vinelinux.org> 24.3.90-1
377- updated to 24.3.90
378
[8277]379* Tue Feb 25 2014 NAKAMURA Kenta <kenta@vinelinux.org> 24.3-5
380- rebuilt with gnutls-3.2
381
[8171]382* Mon Jan 13 2014 Munehiro Yamamoto <munepi@vinelinux.org> 24.3-4
383- rebuilt
384
[7766]385* Wed Aug 14 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.3-3
386- rebuild with ImageMagick-6.8.6.8
387
[7672]388* Sat May 11 2013 Munehiro Yamamoto <munepi@vinelinux.org> 24.3-2
389- dropped some obsolete patches
390- disable menu-tree-el
391  - added coding-system-init.el instead of menu-tree-init.el
392
393* Sat Mar 30 2013 Munehiro Yamamoto <munepi@vinelinux.org> 24.3-1
394- new upstream release
395
396* Thu Feb  7 2013 Munehiro Yamamoto <munepi@vinelinux.org> 24.2.93-1
397- updated to 24.2.93 (24.3 pretest)
398
399* Mon Jan 14 2013 Munehiro Yamamoto <munepi@vinelinux.org> 24.2.92-1
400- updated to 24.2.92 (24.3 pretest)
401
402* Sun Nov 25 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.2.90-1
403- updated to 24.2.90 (24.3 pretest)
404
[6760]405* Mon Aug 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.2-1
406- new upstream release
407
408* Sun Jun 10 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.1-1
409- new upstream release
410
[6317]411* Sat May 19 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.97-1
412- updated to 24.0.97 (24.1 pretest)
[5544]413
[6317]414* Sun Apr 29 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.96-1
415- updated to 24.0.96 (24.1 pretest)
[5462]416
[6317]417* Mon Apr  2 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.95-1
418- updated to 24.0.95 (24.1 pretest)
[5354]419
[6317]420* Sun Mar 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.0.94-2
421- rebuild with ImageMagick-6.7.5.10
422
423* Mon Feb 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.94-1
424- updated to 24.0.94 (24.1 pretest)
425
426* Tue Feb 14 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.93-2
427- use gtk as X toolkit (for vl6)
428
429* Mon Jan 30 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.93-1
430- updated to 24.0.93 (24.1 pretest)
431
432* Thu Dec  1 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.92-1
433- updated to 24.0.92 (24.1 pretest)
434
435* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.91-1
436- updated to 24.0.91 (24.1 pretest)
437
438* Thu Oct  6 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.90-2
439- set --with-x-toolkit=gtk3 (%%configure)
440  - added BuildRequires: gtk3-devel
441
442* Mon Sep 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.90-1
443- updated to 24.0.90 (24.1 pretest)
444- applied emacs-24.0.90-libs-termcap.patch
445
446* Sat Jul 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-10.20110817
447- emacs24 24.0.50 (20110817) snapshot
448- added BuildRequires: ImageMagick-devel, libSM-devel, libxml2-devel > 2.6.17
449
450* Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-9.20110604
451- emacs24 24.0.50 (20110604) snapshot
452
[7672]453* Wed Apr 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-8.20110413
[6317]454- emacs24 24.0.50 (20110413) snapshot
455
456* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-7.20110318
[3304]457- updated site-start.el
458  - defined vine-default-major-version, vine-default-minor-version,
459    vine-default-version
460  - set "ibus-el" to emacs-ime as default
[6317]461  - added ", modified for Vine Linux" to the end of emacs-build-system
[3304]462  - set "Vine _at_mark_ vinelinux.org" to report-emacs-bug-address
463
[6317]464* Sun Apr 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-6.20110318
[3288]465- fixed site-start.el
466  - do not use the macro loop (contained in the common lisp)
467
[6317]468* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-5.20110318
469- emacs24 24.0.50 (20110318) snapshot
[2987]470
[6317]471* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-4.20110222
472- emacs24 24.0.50 (20110222) snapshot
[2750]473- updated site-start.el
474  - defined the function drop-vine-default-from-load-path (regex)
475
[6317]476* Sat Jan 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-3.20110128
477- emacs24 24.0.50 (20110128) snapshot
[2625]478
[6317]479* Sun Jan 02 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-2.20110101
480- emacs24 24.0.50 (20110101) snapshot
[2599]481
[6317]482* Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-1.20101203
483- emacs24 24.0.50 (20101203) snapshot
[2293]484- applied new vine-default system
485  - updated site-start.el
486  - updated vine-default-{base,faces}.el
487  - dropped showvdefaultemacs
488    - merged to emacsen-common package as show-vine-default.sh
[6317]489  - renamed local wide configration file to emacs24-local.el
[2293]490- updated menu-tree.el to version 0.97
[6317]491- added Provides: emacs-snapshot
[2293]492
493* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-4
494- updated vine-default-base.el
495  - changed the variable next-line-add-newlines to nil (default)
496
497* Thu Sep 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-3
498- updated menu-tree.el to version 0.96
499
[1272]500* Sat Jul 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-2
501- applied some patches from Fedora
502  - Fixed handling of dual spacing fonts rhbz#599437
503  - Add patch to fix rhbz#595546 hideshow library matches wrong parenthesis
504    under certain circumstances
505  - Added a patch fixing m17n and libotf version checking (m17ncheck)
506- updated menu-tree.el to version 0.95
507- merged emacs23-vl.spec of Vine Linux 5.1
508#* Thu Apr 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-9
509#- applied security fix emacs23-CVE-2010-0825-fix-movemail-race.diff from Ubuntu
510#
511#* Fri Feb 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-8
512#- added Requires(post): emacsen-common, Requires(postun): emacsen-common
513#
514#* Fri Feb 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-7
515#- dropped BuildRequires: m17n-lib-devel
516#- added --without-m17n-flt in %%configure
517
[1100]518* Mon May 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-1
519- new upstream release
520- updated menu-tree.el to version 0.94
521- updated menu-tree-init.el.emacs23
522  - used prefer-coding-system
523
[887]524* Wed Apr 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.96-1
525- updated to 23.1.96 (23.2 pretest)
526
527* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.95-2
528- removed /usr/share/emacs/site-lisp/subdirs.el
529
530* Sat Apr 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.95-1
531- updated to 23.1.95 (23.2 pretest)
532- added BuildRequires:
533  - atk-devel
534  - dbus-devel
535  - GConf2-devel
536  - alsa-lib-devel
537- added some configure options:
538  --with-libotf --with-m17n-flt --with-dbus --with-gconf
539
[625]540* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.94-1
541- updated to 23.1.94
542
543* Thu Mar 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.93-1
544- updated to 23.1.93 alpha
545
546* Sat Feb 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.92-2
547- added Requires(post): emacsen-common, Requires(postun): emacsen-common
548
549* Tue Feb 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.92-1
550- update to 23.1.92 alpha
551
552* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-6
553- added BuildRequires:
554  - librsvg2-devel
555  - m17n-lib-devel
556  - libotf-devel
557
558* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-5
559- changed License to GPLv3+
560- renamed emacs23.desktop to emacs23.desktop.in
561- updated vine-default-base.el (See [vine-users:079919])
562- fixed in upstream CVS (from Fedora)
563  - fix #543046 - Using scroll bar in emacs highlights/selects text
564  - fix #542657 - emacs does not display indic text
565  - Fixed rhbz#545398 - ETags messes up filenames
566
567* Tue Sep 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-4
568- rebuilt to add signature
569
[7672]570* Wed Aug 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-3
[625]571- added BuildRequires: nkf
572- updated menu-tree-init.el.emacs23
573  - fixed menu-tree encoding <BTS:VineLinux:766>
574- set Exec=emacs-@@EMACS_VERSION@@ in emacs23.desktop
575
576* Wed Aug 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-2
577- replaced BR: libungif-devel with BR: giflib-devel
578
579* Sat Aug 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-1
580- new upstream release
581
582* Sat Jul 25 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.0.96-2.20090714
583- updated vine-default-faces.el to sync with emacs22
584
585* Tue Jul 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.96-1.20090714
586- update to 23.0.96 (20090714) snapshot
587- update vine-default-faces.el
588  - use bash to call gconftool-2
589
590* Sat Jun 27 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-4.20090527
591- update vine-default-faces.el
592  - added \'font in default-frame-alist
593    (if \'font is already in default-frame-alist, overwrited it)
594
595* Wed Jun 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-3.20090527
596- update vine-default-faces.el:
597  - use set-frame-font
598    bacause set-default-font function is obsolete since Emacs 23.1
599    (See M-x describe-function RET set-default-font)
600
601* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-2.20090527
602- update vine-default-faces.el:
603  - set desktop-gnome-interface-monospace-font-name
604    from /desktop/gnome/interface/monospace_font_name
605  - automatically set set-default-font
606    with desktop-gnome-interface-monospace-font-name
607
608* Wed May 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.94-1.20090527
609- update to emacs-23.0.94 (20090527) snapshot
610- add --without-gpm to configure
611
612* Thu May 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-7.20090422
613- defined show-vine-default function in site-start.el
614  - added showvdefaultemacs script
615
616* Wed May 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-6.20090422
617- set PRIORITY=40
618
619* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-5.20090422
620- changed menu-tree-init.el from hard copy to symbolic link
621  on /etc/emacs-23.0.92/site-start.d
622- added %%{_mandir}/*/* in %%files section
623
624* Sat May 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-4.20090422
625- updated menu-tree.el to v0.93
626
627* Fri May 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-3.20090422
628- returned alternatives priority to 30
629  (emacs: 30, emacs22: 30)
630
631* Sun Apr 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-2.20090422
632- installed system-wide configure file in /etc/emacs
633- updated vine-default-base.el
634- changed alternatives priority from 30 to 50
635  (emacs: 50, emacs22: 30)
636
637* Wed Apr 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.92-1.20090422
638- update to emacs 23.0.92 (20090422) snapshot
639- add %%triggerpostun to fix alternatives
640
641* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.91-3.20090325
642- renamed from emacs23 to emacs (emacs-22.x would be renamed to emacs22)
643- updated default settings for Vine Linux
644  - dropped vine-default-mouse.el, vine-default-misc.el
645
646* Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.91-2.20090325
647- enable default settings for Vine Linux
648  - added site-start.el.emacs23
649  - updated site-start.el
650  - added vine-default-base.el, vine-default-faces.el, vine-default-mouse.el,
651    vine-default-misc.el
652
653* Wed Mar 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.91-1.20090325
654- emacs23 23.0.91 snapshot
655
656* Tue Sep 09 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 23.0.60-2.20080908
657- drop patch10
658- s/emacsrelese/emacsrelease/
659
660* Mon Sep 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.60-1.20080908
661- emacs23 23.0.60 snapshot
662
663* Sun Sep 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.3-1
664- new upstream release
665
666* Mon Aug 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 22.2-3
667- import security fixes from Debian
668  CVE-2008-2142: fix insecure setting of fast-lock-cache-directories
669  CVE-2008-1694: fix insecure temporary file creation in vcdiff script
670                 leading to possible symlink attacks
671
[7672]672* Wed Jun 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.2-2
[625]673- update menu-tree.el
674- add 60menu-tree-init.el to sed coding-system and load menu-tree
675- build with xorg-x11-7.3
676  - update BuildRequires
677
678* Sun Mar 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.2-1
679- new upstream release
680
681* Wed Nov 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 22.1-0vl2
682- add Patch10000 to fix local variable processing security bypass
683  vulnerability.
684  - http://www.frsirt.com/english/advisories/2007/3715
685  - http://bugs.debian.org/449008
686
687* Mon Jun 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 22.1-0vl1
688- new upstream release
689- rename to emacs from emacs22 (emacs-21.x would be renameed to emacs21)
690- drop emcws support
691
692* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 22.0.50-0.20060403vl3
693- rebuilt with new toolchain
694
695* Sat May 06 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 22.0.50-0.20060403vl2
696- changed Group:
697
698* Mon Apr 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20060403vl1
699- update to CVS-20060403
700- update emacs22.desktop
701
702* Wed Sep 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050927vl2
703- fix site-start.el
704
705* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050927vl1
706- update to CVS-20050927
707
708* Thu Sep  8 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050907vl1
709- initial build for Vine Linux based on emacs package.
710  - emacs-22.0.50 on CVS-20050907
711
712* Sat Sep  3 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.4-0vl3
713- create site-start.d directory on %install
714
715* Thu Feb 17 2005 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.4-0vl2
716- included leim-21.4
717- update emcws-21.3-20031213.gz
718
719* Wed Feb 16 2005 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.4-0vl1
720- update
721
722* Sat Jul 24 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl7
723- rebuild with Xaw3d, add BuildRequires: Xaw3d-devel
724
725* Fri Jul 23 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl6
726- add Patch20 to fix display resolutions. (set to 96dpi)
727  (do not compute dynamically from display's size)
728
729* Tue Mar 16 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.3-0vl5
730- rebuilt with new toolchain environment
731
732* Thu Jul 17 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.3-0vl4
733- use site-start.el(reading /etc/emacs-21.3/site-start.d/*.el)
734
735* Wed May  7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 21.3-0vl3
736- add BuildPrereq: libpng >= 1.2.5
737
738* Tue Apr 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl2
739- fixed %%pre script
740
741* Tue Mar 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl1
742- new upstream release
743- remove patch14 whick included in upstream
744
745* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl11
746- add patch14 to fix frame title text encoding.
747  - http://tsukuba.m17n.org/mule-ja-archive/2002-10/msg00004.html
748
749* Tue Dec 10 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.2-0vl10
750- autoconf-2.13, not autoconf in %%setup section
751- BuildPreReq: autoconf213
752
753* Mon Dec  9 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl9
754- modifiy rpm scripts.
755
756* Mon Dec  9 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl8
757- rename to emacs
758- obsoletes emacs21 <= 21.2-0vl7, provides emacs21 = %%{version}
759
760* Sun Dec  1 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl7
761- enable menubar fontset patch (Patch103)
762
763* Sat Nov 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl6
764- add requires/buildprereq tags.
765
766* Sat Nov 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl5
767- add emcws-20021014
768
769* Sun Jul 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl4
770- removed *-mode
771
772* Sat Jul 20 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl3
773- python-mode was made pending
774- some additional *.el files was moved from "emacs/site-lisp" to
775  "emacs-(version)/site-lisp"
776
777* Sat Jul 13 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl2
778- added some sources and patches from rawhide 21.2-11 and mandrake 21.2-7mdk
779
780* Sat May 11 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.2-0vl1
781- update.
782- Package Name emacs-beta -> emacs21
783- Add Patch100,101,102, Source100(default = Disable)
784- (from http://phe.phyas.aichi-edu.ac.jp/~cyamauch/pl2.html#emacs21)
785- --infodir=%{_infodir}/emacs-21.2(VineSeed-Plus:00723)
786
787* Thu Dec 27 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl7
788- site-lisp moved under /usr/share/emacs-21.1/ (Patch11 and %%pre section)
789
790* Thu Dec 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl5
791- move /tmp -> /var/lib/emacsen-common (IP(package)C file)
792
793* Fri Nov 02 2001 Tomoya TAKA <tomoya@olive.plala.or.jp> 21.1-0vl4
794- replace patch10 with patch11, posted to gnu.emacs.bug
795  Message-Id: <jebsiza3db.fsf@sykes.suse.de>
796  (reported by ABE Yuji <cbo46560@pop12.odn.ne.jp>)
797
798* Fri Oct 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.1-0vl3
799- fixed build to fail in alpha( only apply patch0 to ppc)
800
801* Tue Oct 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl2
802- added Patch10 (thanks Kitame-san)
803
804* Mon Oct 22 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.1-0vl1
805- update to 21.1
806
807* Sun Sep 9 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.104-0vl14
808- support  shared installing otheremacsen.
809
810* Mon Jul 23 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.104-0vl3
811- update 21.0.104
812
813* Thu Jul 19 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.103-0vl2
814- support emacsen-common
815
816* Wed May 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
817- 21.0.103-0vl1
818- updated to 21.0.103
819- revamped and cleaned up spec file :-)
820- Requires: tamago >= 4.0.6 (...is it reasonable? Mmm...)
821
822* Mon Jan 22 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.95-0vl2
823- fixed .spec bugs( _libdir)
824
825* Fri Jan 12 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.95-0vl1
826- updated to 21.0.95
827
828* Wed Dec 20 2000 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.93-0vl3
829- fixed emacs-beta.spec
830
831* Sat Dec 16 2000 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.93-0vl2
832- 21.0.93 test packaging.
833
834* Fri Jun 30 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
835- added linespace-patch
836
837* Mon Jun 19 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
838- updated to emacs 20.7
839
840* Thu Apr 20 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
841- updated to emacs 20.6
842
843* Mon Feb 28 2000 kenji KITAYAMA <kenji@gandalf.doshisha.ac.jp>
844- [emacs-20.5a-2]
845- Modified reference of Emacs Info
846
847* Sun Jan 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
848- [emacs-20.5a-2]
849- added ppc patch
850
851* Fri Jan  7 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
852- [emacs-20.5a-1]
853- change version from 20.5 to 20.5a
854- added Mule-4.1 patch
855
856* Fri Jan  7 2000 Yasuyuki Furukawa <yasu@on.cs.keio.ac.jp>
857- [emacs-20.5-1]
858- add desktop-link files for desktop menu.
859
[7672]860* Fri Dec 24 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
[625]861- [emacs-20.4-16]
862- replaced Y2K savvy timezone.{el,elc} with one from brand-new apel-10.0
863
864* Tue Dec 21 1999 Jun Nishii <jun@vinelinux.org>
865- added documents
866- strip bins
867
868* Wed Dec  1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
869- [emacs-20.4-14]
870- Change Group to Applications/Editors/Emacs
871
872* Sat Nov  6 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
873- [emacs-20.4-13]
874- included Y2K savvy timezone.{el,elc},
875  modified by Mr. Youichi Teranishi <teranishi@gohome.org>
876
877* Tue Oct 12 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
878- [emacs-20.4-12]
879- Modified info-dir.
880- Removed -c option from %setup.
881
[7672]882* Mon Sep 20 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
[625]883- fixed XIM support patch
884* Sun Sep 19 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
885- fixed postinst bug and fontset patch
886* Sun Jul 18 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
887- first build
Note: See TracBrowser for help on using the repository browser.