source: projects/specs/trunk/e/elogind/elogind-vl.spec @ 12528

Revision 12528, 5.8 KB checked in by tomop, 3 years ago (diff)

updated 10 packages

elogind-246.9.2-1

glib-networking-2.66.0-1

glib2-2.66.7-1

glibmm-2.66.0-1

gnome-autoar-0.2.4-2

gpgme-1.15.1-1

gtk3-3.24.24-1

gtkmm3-3.24.3-1

libmariadb-3.1.11-1

postgresql-13.2-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name:         elogind
4Summary:      The systemd project's "logind", extracted to a standalone package
5Summary(ja):  systemdプロジェクトのlogindを単独で動作するようにしたソフトウェア
6Version:      246.9.2
7Release:      1%{?_dist_release}
8Group:        system
9Vendor:       Project Vine
10Distribution: Vine Linux
11Packager:     tomop
12
13License:      GPL2/LGPL2.1
14URL:          https://wiki.gentoo.org/wiki/Elogind
15
16Source0:      https://github.com/elogind/elogind/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
17Source1:      elogind.init
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20
21Requires: util-linux
22Requires: polkit
23Requires: dbus
24Requires: elogind-libs = %{version}-%{release}
25
26BuildRequires: meson
27BuildRequires: ninja
28BuildRequires: gperf
29BuildRequires: audit-libs-devel
30BuildRequires: libacl-devel
31BuildRequires: libblkid-devel
32BuildRequires: libcap-devel
33BuildRequires: libmount-devel
34BuildRequires: libxcrypt-devel
35BuildRequires: dbus-devel
36BuildRequires: eudev-libudev-devel
37BuildRequires: glib2-devel
38BuildRequires: pam-devel
39BuildRequires: pkgconfig
40BuildRequires: python3-devel
41BuildRequires: libxslt
42BuildRequires: docbook-style-xsl
43
44%description
45elogind is the systemd project's logind, extracted to a standalone package. It's designed for users who prefer a non-systemd init system, but still want to use popular software such as KDE/Wayland or GNOME that otherwise hard-depends on systemd.
46
47%description -l ja
48 eloginは、systemdプロジェクトのlogindを単体で抽出したものです。これは
49systemdを利用していないシステム上で、KDE、Wayland、GNOMEのようにsystemd
50に強く依存しているソフトウェアを使用したいユーザのために設計されています。
51
52
53%package libs
54Summary:     shared libraries for elogind
55Summary(ja): eloginのための共有ライブラリファイル
56Group:       system
57
58%description libs
59 This package contains shared libraries for elogind
60
61%description libs -l ja
62 このパッケージにはeloginを用いた開発のための共有ライブラリファイル
63が含まれています。
64
65
66%package devel
67Summary:     headers and libraries for elogind
68Summary(ja): eloginを用いた開発のためのヘッダ・ライブラリファイル
69Group:       programming
70Requires:    elogind-libs = %{version}-%{release}
71
72%description devel
73 This package contains headers and libraries for elogind
74
75%description devel -l ja
76 このパッケージにはeloginを用いた開発のためのヘッダ・ライブラリファイル
77が含まれています。
78
79
80%package -n compat32-elogind-libs
81Summary:     shared libraries for elogind
82Summary(ja): eloginのための共有ライブラリファイル
83Group:       system
84
85%description -n compat32-elogind-libs
86 This package contains shared libraries for elogind
87
88%description -n compat32-elogind-libs -l ja
89 このパッケージにはeloginを用いた開発のための共有ライブラリファイル
90が含まれています。
91
92
93%debug_package
94
95
96%prep
97%autosetup -p1
98
99
100%build
101export LANG=ja_JP.UTF-8
102%meson \
103 -Dman=true
104%meson_build
105
106
107%install
108export LANG=ja_JP.UTF-8
109%{__rm} -rf %{buildroot}
110%meson_install
111
112install -m755 -d %{buildroot}%{_initdir}
113install -m755 %{SOURCE1} %{buildroot}%{_initdir}/%{name}
114
115rm -f %{buildroot}/%{_lib}/libelogind.so
116ln -s ../../%{_lib}/libelogind.so.0 %{buildroot}%{_libdir}/libelogind.so
117perl -pi -e 's|^libdir=.*$|libdir=%{_libdir}|' %{buildroot}%{_libdir}/pkgconfig/libelogind.pc
118
119rm -rf %{buildroot}%{_datadir}/factory
120
121%find_lang %{name}
122
123
124%check
125export LANG=ja_JP.UTF-8
126%meson_test
127
128
129%clean
130%{__rm} -rf %{buildroot}
131
132
133%pre
134if [ $1 -gt 1 ]; then
135  if [ -e /etc/rc2.d/S03elogind ]; then
136    /sbin/chkconfig elogind off
137    touch /tmp/chkconfig-elogind-on
138  fi
139fi
140
141%post
142/sbin/chkconfig --add elogind
143if [ $1 -eq 1 ]; then
144  /sbin/chkconfig elogind on
145else
146  if [ -e /tmp/chkconfig-elogind-on ]; then
147    /sbin/chkconfig elogind on
148    rm -f /tmp/chkconfig-elogind-on
149  fi
150fi
151
152%preun
153if [ $1 -eq 0 ]; then
154  /sbin/chkconfig elogind off
155  /sbin/chkconfig --add elogind
156fi
157
158%post libs -p /sbin/ldconfig
159%postun libs -p /sbin/ldconfig
160
161
162%files -f %{name}.lang
163%defattr(-,root,root)
164%license LICENSE*
165%doc NEWS README
166%config(noreplace) %{_sysconfdir}/elogind/logind.conf
167%config(noreplace) %{_sysconfdir}/pam.d/elogind-user
168%{_initdir}/elogind
169/bin/*
170%{_bindir}/*
171/lib/elogind
172/lib/udev/rules.d/*
173/%{_lib}/security/*
174%{_datadir}/dbus-1/system-services/*
175%{_datadir}/dbus-1/system.d/*
176%{_datadir}/polkit-1/actions/*
177%dir %{_datadir}/zsh
178%{_datadir}/zsh/site-functions/*
179%dir %{_datadir}/bash-completion
180%dir %{_datadir}/bash-completion/completions
181%{_datadir}/bash-completion/completions/*
182%{_mandir}/man1/*
183%{_mandir}/man5/*
184%{_mandir}/man7/*
185%{_mandir}/man8/*
186
187%files libs
188/%{_lib}/*.so.*
189
190%files devel
191%defattr(-,root,root)
192%{_libdir}/libelogind.so
193%{_includedir}/elogind
194%{_libdir}/pkgconfig/libelogind.pc
195%{_mandir}/man3/*
196
197%if %{build_compat32}
198%files -n compat32-elogind-libs
199/%{_lib}/*.so.*
200%endif
201
202
203%changelog
204* Sat Feb 13 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 246.9.2-1
205- new upstream release.
206- updated Source1.
207
208* Sat May 25 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 241.3-2
209- added a initscript.
210
211* Fri May 10 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 241.3-1
212- new upstream release.
213- dropped Patch0: fixed in upstream.
214- added BR:libxcrypt-devel.
215- fixed %%post and %%postun scripts.
216- added BR:audit-libs-devel.
217- added BR:dbus-devel.
218- added BR:glib2-devel.
219
220* Sun Jan 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 239.3-3
221- added compat32-elogind-libs.
222
223* Wed Jan 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 239.3-2
224- separated libs.
225- built manuals.
226
227* Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 239.3-1
228- initial build for Vine Linux.
Note: See TracBrowser for help on using the repository browser.