source: projects/specs/trunk/e/elogind/elogind-vl.spec @ 12121

Revision 12121, 5.4 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

RevLine 
[12074]1%define pkg_version 241.3
[12121]2%define pkg_release 2%{?_dist_release}
[12000]3
[12012]4%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
5
[12000]6Name:         elogind
7Summary:      The systemd project's "logind", extracted to a standalone package
8Summary(ja):  systemdプロジェクトのlogindを単独で動作するようにしたソフトウェア
9Version:      %{pkg_version}
10Release:      %{pkg_release}
11License:      GPL2/LGPL2.1
12Group:        System Environment/Base
13URL:          https://wiki.gentoo.org/wiki/Elogind
14Vendor:       Project Vine
15Distribution: Vine Linux
16Packager:     tomop
17
[12121]18Source0:      https://github.com/elogind/elogind/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
19Source1:      elogind.init
[12000]20
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22
23Requires: util-linux
24Requires: polkit
25Requires: dbus
[12005]26Requires: elogind-libs = %{version}-%{release}
[12000]27
28BuildRequires: meson
29BuildRequires: ninja
30BuildRequires: gperf
[12074]31BuildRequires: audit-libs-devel
[12000]32BuildRequires: libacl-devel
33BuildRequires: libblkid-devel
34BuildRequires: libcap-devel
35BuildRequires: libmount-devel
[12074]36BuildRequires: libxcrypt-devel
37BuildRequires: dbus-devel
[12000]38BuildRequires: eudev-libudev-devel
[12074]39BuildRequires: glib2-devel
[12000]40BuildRequires: pam-devel
41BuildRequires: pkgconfig
42BuildRequires: python3-devel
[12005]43BuildRequires: libxslt
44BuildRequires: docbook-style-xsl
[12000]45
46%description
47elogind is the systemd project's logind, extracted to a standalone package. It's designed for users who prefer a non-systemd init system, but still want to use popular software such as KDE/Wayland or GNOME that otherwise hard-depends on systemd.
48
49%description -l ja
50 eloginは、systemdプロジェクトのlogindを単体で抽出したものです。これは
51systemdを利用していないシステム上で、KDE、Wayland、GNOMEのようにsystemd
52に強く依存しているソフトウェアを使用したいユーザのために設計されています。
53
[12005]54%package libs
55Summary:     shared libraries for elogind
56Summary(ja): eloginのための共有ライブラリファイル
[12012]57Group:       System Environment/Libraries
[12005]58
59%description libs
60 This package contains shared libraries for elogind
61
62%description libs -l ja
63 このパッケージにはeloginを用いた開発のための共有ライブラリファイル
64が含まれています。
65
[12000]66%package devel
67Summary:     headers and libraries for elogind
68Summary(ja): eloginを用いた開発のためのヘッダ・ライブラリファイル
69Group:       Development/Libraries
[12005]70Requires:    elogind-libs = %{version}-%{release}
[12000]71
72%description devel
73 This package contains headers and libraries for elogind
74
75%description devel -l ja
76 このパッケージにはeloginを用いた開発のためのヘッダ・ライブラリファイル
77が含まれています。
78
[12012]79%package -n compat32-elogind-libs
80Summary:     shared libraries for elogind
81Summary(ja): eloginのための共有ライブラリファイル
82Group:       System Environment/Libraries
83
84%description -n compat32-elogind-libs
85 This package contains shared libraries for elogind
86
87%description -n compat32-elogind-libs -l ja
88 このパッケージにはeloginを用いた開発のための共有ライブラリファイル
89が含まれています。
90
91
[12000]92%prep
93%autosetup -p1
94
95
96%build
97export LANG=ja_JP.UTF-8
98%meson
99%meson_build
100
101%install
102export LANG=ja_JP.UTF-8
103%{__rm} -rf %{buildroot}
104%meson_install
105
[12121]106install -m755 -d %{buildroot}%{_initdir}
107install -m755 %{SOURCE1} %{buildroot}%{_initdir}/%{name}
[12000]108
109rm -f %{buildroot}/%{_lib}/libelogind.so
110ln -s ../../%{_lib}/libelogind.so.0 %{buildroot}%{_libdir}/libelogind.so
111perl -pi -e 's|^libdir=.*$|libdir=%{_libdir}|' %{buildroot}%{_libdir}/pkgconfig/libelogind.pc
112
113rm -rf %{buildroot}%{_datadir}/factory
114
115%find_lang %{name}
116
117%check
118export LANG=ja_JP.UTF-8
119%meson_test
120
121%clean
122%{__rm} -rf %{buildroot}
123
124
[12121]125%post
126/sbin/chkconfig --add elogind
127
128%preun
129if [ $1 -eq 0 ]; then
130  /sbin/chkconfig elogind off
131  /sbin/chkconfig --add elogind
132fi
133
[12074]134%post libs
[12000]135/sbin/ldconfig
136
[12074]137%postun libs
[12000]138/sbin/ldconfig
139
140%files -f %{name}.lang
141%defattr(-,root,root)
142%license LICENSE*
143%doc NEWS README
144%config(noreplace) %{_sysconfdir}/elogind/logind.conf
145%config(noreplace) %{_sysconfdir}/pam.d/elogind-user
[12121]146%{_initdir}/elogind
[12000]147/bin/*
148%{_bindir}/*
149/lib/elogind
150/lib/udev/rules.d/*
151/%{_lib}/security/*
152%{_datadir}/dbus-1/system-services/*
153%{_datadir}/dbus-1/system.d/*
154%{_datadir}/polkit-1/actions/*
155%dir %{_datadir}/zsh
156%{_datadir}/zsh/site-functions/*
157%dir %{_datadir}/bash-completion
158%dir %{_datadir}/bash-completion/completions
159%{_datadir}/bash-completion/completions/*
[12005]160%{_mandir}/man1/*
161%{_mandir}/man5/*
162%{_mandir}/man7/*
163%{_mandir}/man8/*
[12000]164
[12005]165%files libs
166/%{_lib}/*.so.*
167
[12000]168%files devel
169%defattr(-,root,root)
170%{_libdir}/libelogind.so
171%{_includedir}/elogind
172%{_libdir}/pkgconfig/libelogind.pc
[12005]173%{_mandir}/man3/*
[12000]174
[12012]175%if %{build_compat32}
176%files -n compat32-elogind-libs
177/%{_lib}/*.so.*
178%endif
179
180
[12000]181%changelog
[12121]182* Sat May 25 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 241.3-2
183- added a initscript.
184
[12074]185* Fri May 10 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 241.3-1
186- new upstream release.
187- dropped Patch0: fixed in upstream.
188- added BR:libxcrypt-devel.
189- fixed %%post and %%postun scripts.
190- added BR:audit-libs-devel.
191- added BR:dbus-devel.
192- added BR:glib2-devel.
193
[12012]194* Sun Jan 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 239.3-3
195- added compat32-elogind-libs.
196
[12005]197* Wed Jan 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 239.3-2
198- separated libs.
199- built manuals.
200
[12000]201* Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 239.3-1
202- initial build for Vine Linux.
Note: See TracBrowser for help on using the repository browser.