source: projects/specs/trunk/e/elfutils/elfutils-vl.spec @ 7945

Revision 7945, 24.5 KB checked in by daisuke, 10 years ago (diff)

elfutils: update to 0.157

Line 
1%define eu_version 0.157
2%define eu_release 1
3
4%global nocheck true
5
6Summary: A collection of utilities and DSOs to handle compiled objects
7Name: elfutils
8Version: %{eu_version}
9Release: %{eu_release}%{?_dist_release}
10License: GPLv2 with exceptions
11Group: Development/Tools
12URL: https://fedorahosted.org/elfutils/
13Source: http://fedorahosted.org/releases/e/l/elfutils/%{name}-%{version}.tar.bz2
14
15Patch1: elfutils-robustify.patch
16Patch2: elfutils-portability.patch
17
18##VINE##
19Patch10: elfutils-0.131-readelf_c.patch
20
21Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
22Requires: elfutils-libs-%{_arch} = %{version}-%{release}
23
24BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
25BuildRequires: bison >= 1.875
26BuildRequires: flex >= 2.5.4a
27BuildRequires: bzip2
28BuildRequires: bzip2-devel
29BuildRequires: zlib-devel
30BuildRequires: xz-devel
31BuildRequires: gettext
32BuildRequires: m4
33BuildRequires: gcc >= 3.4
34# Need <byteswap.h> that gives unsigned bswap_16 etc.
35BuildRequires: glibc-headers >= 2.3.4-11
36
37%define _gnu %{nil}
38%define _program_prefix eu-
39
40%description
41Elfutils is a collection of utilities, including ld (a linker),
42nm (for listing symbols from object files), size (for listing the
43section sizes of an object or archive file), strip (for discarding
44symbols), readelf (to see the raw ELF file structures), and elflint
45(to check for well-formed ELF files).
46
47
48%package libs
49Summary: Libraries to handle compiled objects
50Group: System Environment/Libraries
51Provides: elfutils-libs-%{_arch} = %{version}-%{release}
52Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
53Conflicts: elfutils < %{version}-%{release}
54Conflicts: elfutils > %{version}-%{release}
55Conflicts: elfutils-devel < %{version}-%{release}
56Conflicts: elfutils-devel > %{version}-%{release}
57
58%description libs
59The elfutils-libs package contains libraries which implement DWARF, ELF,
60and machine-specific ELF handling.  These libraries are used by the programs
61in the elfutils package.  The elfutils-devel package enables building
62other programs using these libraries.
63
64
65%package devel
66Summary: Development libraries to handle compiled objects
67Group: Development/Libraries
68Provides: elfutils-devel-%{_arch} = %{version}-%{release}
69Requires: elfutils-libs-%{_arch} = %{version}-%{release}
70Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
71Conflicts: elfutils-libelf-devel < %{version}-%{release}
72Conflicts: elfutils-libelf-devel > %{version}-%{release}
73
74%description devel
75The elfutils-devel package contains the libraries to create
76applications for handling compiled objects.  libebl provides some
77higher-level ELF access functionality.  libdw provides access to
78the DWARF debugging information.  libasm provides a programmable
79assembler interface.
80
81
82%package devel-static
83Summary: Static archives to handle compiled objects
84Group: Development/Libraries
85Provides: elfutils-devel-static-%{_arch} = %{version}-%{release}
86Requires: elfutils-devel-%{_arch} = %{version}-%{release}
87Requires: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
88Conflicts: elfutils-libelf-devel < %{version}-%{release}
89Conflicts: elfutils-libelf-devel > %{version}-%{release}
90
91%description devel-static
92The elfutils-devel-static package contains the static archives
93with the code to handle compiled objects.
94
95
96%package libelf
97Summary: Library to read and write ELF files
98Group: System Environment/Libraries
99Provides: libelf = %{version}-%{release}
100Obsoletes: libelf <= 0.8.2-2
101Provides: elfutils-libelf-%{_arch} = %{version}-%{release}
102Conflicts: elfutils < %{version}-%{release}
103Conflicts: elfutils > %{version}-%{release}
104Conflicts: elfutils-libs < %{version}-%{release}
105Conflicts: elfutils-libs > %{version}-%{release}
106Conflicts: elfutils-libelf-devel < %{version}-%{release}
107Conflicts: elfutils-libelf-devel > %{version}-%{release}
108
109%description libelf
110The elfutils-libelf package provides a DSO which allows reading and
111writing ELF files on a high level.  Third party programs depend on
112this package to read internals of ELF files.  The programs of the
113elfutils package use it also to generate new ELF files.
114
115
116%package libelf-devel
117Summary: Development support for libelf
118Group: Development/Libraries
119Provides: libelf-devel = %{version}-%{release}
120Obsoletes: libelf-devel <= 0.8.2-2
121Provides: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
122Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
123Conflicts: libelf-devel < %{version}-%{release}
124
125%description libelf-devel
126The elfutils-libelf-devel package contains the libraries to create
127applications for handling compiled objects.  libelf allows you to
128access the internals of the ELF object file format, so you can see the
129different sections of an ELF file.
130
131
132%package libelf-devel-static
133Summary: Static archive of libelf
134Group: Development/Libraries
135Provides: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
136Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
137
138%description libelf-devel-static
139The elfutils-libelf-static package contains the static archive
140for libelf.
141
142
143%prep
144%setup -q
145%patch1 -p1 -b .robustify
146%patch2 -p1 -b .portability
147
148%patch10 -p0 -b .readelf_c
149
150find . -name \*.sh ! -perm -0100 -print | xargs chmod +x
151
152
153%build
154# Remove -Wall from default flags.  The makefiles enable enough warnings
155# themselves, and they use -Werror.  Appending -Wall defeats the cases where
156# the makefiles disable some specific warnings for specific code.
157RPM_OPT_FLAGS=${RPM_OPT_FLAGS/-Wall/}
158
159%configure --enable-dwz CFLAGS="$RPM_OPT_FLAGS -fexceptions"
160make -s %{?_smp_mflags}
161
162
163%install
164rm -rf ${RPM_BUILD_ROOT}
165make -s install DESTDIR=${RPM_BUILD_ROOT}
166
167chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/lib*.so*
168chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/elfutils/lib*.so*
169
170%find_lang %{name}
171
172# XXX Nuke unpackaged files
173{ cd ${RPM_BUILD_ROOT}
174  rm -f .%{_bindir}/eu-ld
175}
176
177
178
179%check
180make -s %{?_smp_mflags} check || (cat tests/test-suite.log; %{nocheck})
181
182
183%clean
184rm -rf ${RPM_BUILD_ROOT}
185
186
187%post libs -p /sbin/ldconfig
188
189%postun libs -p /sbin/ldconfig
190
191%post libelf -p /sbin/ldconfig
192
193%postun libelf -p /sbin/ldconfig
194
195
196%files -f %{name}.lang
197%defattr(-,root,root)
198%doc README TODO
199%{_bindir}/eu-addr2line
200%{_bindir}/eu-ar
201%{_bindir}/eu-elfcmp
202%{_bindir}/eu-elflint
203%{_bindir}/eu-findtextrel
204%{_bindir}/eu-nm
205%{_bindir}/eu-objdump
206%{_bindir}/eu-ranlib
207%{_bindir}/eu-readelf
208%{_bindir}/eu-size
209%{_bindir}/eu-strings
210%{_bindir}/eu-strip
211#%{_bindir}/eu-ld
212%{_bindir}/eu-unstrip
213%{_bindir}/eu-make-debug-archive
214
215
216%files libs
217%defattr(-,root,root)
218%{_libdir}/libasm-%{version}.so
219%{_libdir}/libasm.so.*
220%{_libdir}/libdw-%{version}.so
221%{_libdir}/libdw.so.*
222%dir %{_libdir}/elfutils
223%{_libdir}/elfutils/lib*.so
224
225
226%files devel
227%defattr(-,root,root)
228%{_includedir}/dwarf.h
229%dir %{_includedir}/elfutils
230%{_includedir}/elfutils/elf-knowledge.h
231%{_includedir}/elfutils/libasm.h
232%{_includedir}/elfutils/libebl.h
233%{_includedir}/elfutils/libdw.h
234%{_includedir}/elfutils/libdwfl.h
235%{_includedir}/elfutils/version.h
236%{_libdir}/libebl.a
237%{_libdir}/libasm.so
238%{_libdir}/libdw.so
239
240
241%files devel-static
242%defattr(-,root,root)
243%{_libdir}/libasm.a
244%{_libdir}/libdw.a
245
246
247%files libelf
248%defattr(-,root,root)
249%{_libdir}/libelf-%{version}.so
250%{_libdir}/libelf.so.*
251
252
253%files libelf-devel
254%defattr(-,root,root)
255%{_includedir}/libelf.h
256%{_includedir}/gelf.h
257%{_includedir}/nlist.h
258%{_libdir}/libelf.so
259
260
261%files libelf-devel-static
262%defattr(-,root,root)
263%{_libdir}/libelf.a
264
265
266%changelog
267* Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 0.157-1
268- update to 0.157
269
270* Wed Apr 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-2
271- add BR: zlib-devel, bzip2-devel, xz-devel, m4, gettext
272
273* Tue Apr 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-1
274- update to 0.152
275
276* Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.135-2
277- elfutils-libs: changed Group to System Environment/Libraries
278- elfutils-libelf: changed Group to System Environment/Libraries
279- elfutils-devel: changed Group to Development/Libraries
280- elfutils-devel-static: changed Group to Development/Libraries
281- elfutils-libelf-devel: changed Group to Development/Libraries
282- elfutils-libelf-devel-static: changed Group to Development/Libraries
283
284* Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.135-1
285- merged with Fedora 9 0.135-1
286
287  - Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 0.131-1vl5
288  - applied new versioning policy
289  - added elfutils-0.131-readelf_c.patch
290
291  - Thu Nov 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.131-0vl1
292  - new upstream release
293  - move libelf/libelf-devel obsoletes tag (<BTS:0568>)
294    - remove Obsoletes: libelf, libelf-devel from elfutils
295    - add Obsoletes: libelf to elfutils-libelf
296    - add Obsoletes: libelf-devel to elfutils-libelf-devel
297
298* Mon May 12 2008 Roland McGrath <roland@redhat.com> - 0.135-1
299- Update to 0.135
300  - libdwfl: bug fixes
301  - eu-strip: changed handling of ET_REL files wrt symbol tables and relocs
302
303* Wed Apr  9 2008 Roland McGrath <roland@redhat.com> - 0.134-1
304- Update to 0.134
305  - elflint: backend improvements for sparc, alpha (#204170)
306  - libdwfl, libelf: bug fixes (#439344, #438867, #438263, #438190)
307- Remove Conflicts: libelf-devel from elfutils-libelf-devel. (#435742)
308
309* Sun Mar  2 2008 Roland McGrath <roland@redhat.com> - 0.133-2
310- Update to 0.133
311  - readelf, elflint, libebl: SHT_GNU_ATTRIBUTE section handling (readelf -A)
312  - readelf: core note handling for NT_386_TLS, NT_PPC_SPE, Alpha NT_AUXV
313  - libdwfl: bug fixes and optimization in relocation handling
314  - elfcmp: bug fix for non-allocated section handling
315  - ld: implement newer features of binutils linker.
316- Install eu-objdump and libasm, now has limited disassembler support.
317
318* Mon Jan 21 2008 Roland McGrath <roland@redhat.com> - 0.132-3
319- Update to 0.132
320  - libelf: Use loff_t instead of off64_t in libelf.h header. (#377241)
321  - eu-readelf: Fix handling of ET_REL files in archives.
322  - libcpu: Implement x86 and x86-64 disassembler.
323  - libasm: Add interface for disassembler.
324  - all programs: add debugging of branch prediction.
325  - libelf: new function elf_scnshndx.
326
327* Sun Nov 11 2007 Roland McGrath <roland@redhat.com> - 0.131-1
328- Update to 0.131
329  - libdw: DW_FORM_ref_addr support; dwarf_formref entry point now deprecated;
330           bug fixes for oddly-formatted DWARF
331  - libdwfl: bug fixes in offline archive support, symbol table handling;
332             apply partial relocations for dwfl_module_address_section on ET_REL
333  - libebl: powerpc backend support for Altivec registers
334
335* Wed Oct 17 2007 Roland McGrath <roland@redhat.com> - 0.130-3
336- Fix ET_REL support.
337- Fix odd indentation in eu-readelf -x output.
338
339* Tue Oct 16 2007 Roland McGrath <roland@redhat.com> - 0.130-1
340- Update to 0.130
341  - eu-readelf -p option can take an argument like -x for one section
342  - eu-readelf --archive-index (or -c)
343  - eu-readelf -n improved output for core dumps
344  - eu-readelf: handle SHT_NOTE sections without requiring phdrs (#249467)
345  - eu-elflint: ditto
346  - eu-elflint: stricter checks on debug sections
347  - eu-unstrip: new options, --list (or -n), --relocate (or -R)
348  - libelf: new function elf_getdata_rawchunk, replaces gelf_rawchunk;
349            new functions gelf_getnote, gelf_getauxv, gelf_update_auxv
350  - libebl: backend improvements (#324031)
351  - libdwfl: build_id support, new functions for it
352  - libdwfl: dwfl_module_addrsym fixes (#268761, #268981)
353  - libdwfl offline archive support, new script eu-make-debug-archive
354
355* Mon Aug 20 2007 Roland McGrath <roland@redhat.com> - 0.129-2
356- Fix false-positive eu-elflint failure on ppc -mbss-plt binaries.
357
358* Tue Aug 14 2007 Roland McGrath <roland@redhat.com> - 0.129-1
359- Update to 0.129
360  - readelf: new options --hex-dump (or -x), --strings (or -p) (#250973)
361  - addr2line: new option --symbols (or -S)
362  - libdw: dwarf_getscopes fixes (#230235)
363  - libdwfl: dwfl_module_addrsym fixes (#249490)
364
365* Fri Jun  8 2007 Roland McGrath <roland@redhat.com> - 0.128-2
366- Update to 0.128
367  - new program: unstrip
368  - elfcmp: new option --hash-inexact
369- Replace Conflicts: with Provides/Requires using -arch
370
371* Wed Apr 18 2007 Roland McGrath <roland@redhat.com> - 0.127-1
372- Update to 0.127
373  - libdw: new function dwarf_getsrcdirs
374  - libdwfl: new functions dwfl_module_addrsym, dwfl_report_begin_add,
375             dwfl_module_address_section
376
377* Mon Feb  5 2007 Roland McGrath <roland@redhat.com> - 0.126-1
378- Update to 0.126
379  - New program eu-ar.
380  - libdw: fix missing dwarf_getelf (#227206)
381  - libdwfl: dwfl_module_addrname for st_size=0 symbols (#227167, #227231)
382- Resolves: RHBZ #227206, RHBZ #227167, RHBZ #227231
383
384* Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-3
385- Fix overeager warn_unused_result build failures.
386
387* Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-1
388- Update to 0.125
389  - elflint: Compare DT_GNU_HASH tests.
390  - move archives into -static RPMs
391  - libelf, elflint: better support for core file handling
392  - Really fix libdwfl sorting of modules with 64-bit addresses (#220817).
393- Resolves: RHBZ #220817, RHBZ #213792
394
395* Tue Oct 10 2006 Roland McGrath <roland@redhat.com> - 0.124-1
396- eu-strip -f: copy symtab into debuginfo file when relocs use it (#203000)
397- Update to 0.124
398  - libebl: fix ia64 reloc support (#206981)
399  - libebl: sparc backend support for return value location
400  - libebl, libdwfl: backend register name support extended with more info
401  - libelf, libdw: bug fixes for unaligned accesses on machines that care
402  - readelf, elflint: trivial bugs fixed
403
404* Mon Aug 14 2006 Roland McGrath <roland@redhat.com> 0.123-1
405- Update to 0.123
406  - libebl: Backend build fixes, thanks to Stepan Kasal.
407  - libebl: ia64 backend support for register names, return value location
408  - libdwfl: Handle truncated linux kernel module section names.
409  - libdwfl: Look for linux kernel vmlinux files with .debug suffix.
410  - elflint: Fix checks to permit --hash-style=gnu format.
411
412* Mon Jul 17 2006 Roland McGrath <roland@redhat.com> - 0.122-4
413- Fix warnings in elflint compilation.
414
415* Wed Jul 12 2006 Roland McGrath <roland@redhat.com> - 0.122-3
416- Update to 0.122
417  - Fix libdwfl sorting of modules with 64-bit addresses (#198225).
418  - libebl: add function to test for relative relocation
419  - elflint: fix and extend DT_RELCOUNT/DT_RELACOUNT checks
420  - elflint, readelf: add support for DT_GNU_HASH
421  - libelf: add elf_gnu_hash
422  - elflint, readelf: add support for 64-bit SysV-style hash tables
423  - libdwfl: new functions dwfl_module_getsymtab, dwfl_module_getsym.
424
425* Thu Jun 15 2006 Roland McGrath <roland@redhat.com> - 0.121-1
426- Update to 0.121
427  - libelf: bug fixes for rewriting existing files when using mmap (#187618).
428  - make all installed headers usable in C++ code (#193153).
429  - eu-readelf: better output format.
430  - eu-elflint: fix tests of dynamic section content.
431  - libdw, libdwfl: handle files without aranges info.
432
433* Thu May 25 2006 Jeremy Katz <katzj@redhat.com> - 0.120-3
434- rebuild to pick up -devel deps
435
436* Tue Apr  4 2006 Roland McGrath <roland@redhat.com> - 0.120-2
437- Update to 0.120
438  - License changed to GPL, with some exceptions for using
439    the libelf, libebl, libdw, and libdwfl library interfaces.
440    Red Hat elfutils is an included package of the Open Invention Network.
441  - dwarf.h updated for DWARF 3.0 final specification.
442  - libelf: Fix corruption in ELF_C_RDWR uses (#187618).
443  - libdwfl: New function dwfl_version; fixes for offline.
444
445* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2.1
446- bump again for double-long bug on ppc(64)
447
448* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2
449- rebuilt for new gcc4.1 snapshot and glibc changes
450
451* Fri Jan 13 2006 Roland McGrath <roland@redhat.com> - 0.119-1
452- update to 0.119
453
454* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
455- rebuilt
456
457* Sun Nov 27 2005 Roland McGrath <roland@redhat.com> - 0.118-1
458- update to 0.118
459  - elflint: more tests.
460  - libdwfl: New function dwfl_module_register_names.
461  - libebl: New backend hook for register names.
462- Make sure -fexceptions is always in CFLAGS.
463
464* Tue Nov 22 2005 Roland McGrath <roland@redhat.com> - 0.117-2
465- update to 0.117
466  - libdwfl: New function dwfl_module_return_value_location (#166118)
467  - libebl: Backend improvements for several CPUs
468
469* Mon Oct 31 2005 Roland McGrath <roland@redhat.com> - 0.116-1
470- update to 0.116
471  - libdw fixes, API changes and additions
472  - libdwfl fixes (#169672)
473  - eu-strip/libelf fix to preserve setuid/setgid permission bits (#167745)
474
475* Fri Sep  9 2005 Roland McGrath <roland@redhat.com> - 0.115-3
476- Update requires/conflicts for better biarch update behavior.
477
478* Mon Sep  5 2005 Roland McGrath <roland@redhat.com> - 0.115-2
479- update to 0.115
480  - New program eu-strings.
481  - libdw: New function dwarf_getscopes_die.
482  - libelf: speed-ups of non-mmap reading.
483  - Implement --enable-gcov option for configure.
484
485* Wed Aug 24 2005 Roland McGrath <roland@redhat.com> - 0.114-1
486- update to 0.114
487  - new program eu-ranlib
488  - libdw: new calls for inlines
489  - libdwfl: new calls for offline modules
490
491* Sat Aug 13 2005 Roland McGrath <roland@redhat.com> - 0.113-2
492- update to 0.113
493  - elflint: relax a bit.  Allow version definitions for defined symbols
494    against DSO versions also for symbols in nobits sections.
495    Allow .rodata section to have STRINGS and MERGE flag set.
496  - strip: add some more compatibility with binutils.
497  - libdwfl: bug fixes.
498- Separate libdw et al into elfutils-libs subpackage.
499
500* Sat Aug  6 2005 Roland McGrath <roland@redhat.com> - 0.112-1
501- update to 0.112
502  - elfcmp: some more relaxation.
503  - elflint: many more tests, especially regarding to symbol versioning.
504  - libelf: Add elfXX_offscn and gelf_offscn.
505  - libasm: asm_begin interface changes.
506  - libebl: Add three new interfaces to directly access machine, class,
507    and data encoding information.
508
509* Fri Jul 29 2005 Roland McGrath <roland@redhat.com> - 0.111-2
510- update portability patch
511
512* Thu Jul 28 2005 Roland McGrath <roland@redhat.com> - 0.111-1
513- update to 0.111
514  - libdwfl library now merged into libdw
515
516* Sun Jul 24 2005 Roland McGrath <roland@redhat.com> - 0.110-1
517- update to 0.110
518
519* Fri Jul 22 2005 Roland McGrath <roland@redhat.com> - 0.109-2
520- update to 0.109
521  - verify that libebl modules are from the same build
522  - new eu-elflint checks on copy relocations
523  - new program eu-elfcmp
524  - new experimental libdwfl library
525
526* Thu Jun  9 2005 Roland McGrath <roland@redhat.com> - 0.108-5
527- robustification of eu-strip and eu-readelf
528
529* Wed May 25 2005 Roland McGrath <roland@redhat.com> - 0.108-3
530- more robustification
531
532* Mon May 16 2005 Roland McGrath <roland@redhat.com> - 0.108-2
533- robustification
534
535* Mon May  9 2005 Roland McGrath <roland@redhat.com> - 0.108-1
536- update to 0.108
537  - merge strip fixes
538  - sort records in dwarf_getsrclines, fix dwarf_getsrc_die searching
539  - update elf.h from glibc
540
541* Sun May  8 2005 Roland McGrath <roland@redhat.com> - 0.107-2
542- fix strip -f byte-swapping bug
543
544* Sun May  8 2005 Roland McGrath <roland@redhat.com> - 0.107-1
545- update to 0.107
546  - readelf: improve DWARF output format
547  - elflint: -d option to support checking separate debuginfo files
548  - strip: fix ET_REL debuginfo files (#156341)
549
550* Mon Apr  4 2005 Roland McGrath <roland@redhat.com> - 0.106-3
551- fix some bugs in new code, reenable make check
552
553* Mon Apr  4 2005 Roland McGrath <roland@redhat.com> - 0.106-2
554- disable make check for most arches, for now
555
556* Mon Apr  4 2005 Roland McGrath <roland@redhat.com> - 0.106-1
557- update to 0.106
558
559* Mon Mar 28 2005 Roland McGrath <roland@redhat.com> - 0.104-2
560- update to 0.104
561
562* Wed Mar 23 2005 Jakub Jelinek <jakub@redhat.com> 0.103-2
563- update to 0.103
564
565* Wed Feb 16 2005 Jakub Jelinek <jakub@redhat.com> 0.101-2
566- update to 0.101.
567- use %%configure macro to get CFLAGS etc. right
568
569* Sat Feb  5 2005 Jeff Johnson <jbj@redhat.com> 0.99-2
570- upgrade to 0.99.
571
572* Sun Sep 26 2004 Jeff Johnson <jbj@redhat.com> 0.97-3
573- upgrade to 0.97.
574
575* Tue Aug 17 2004 Jakub Jelinek <jakub@redhat.com> 0.95-5
576- upgrade to 0.96.
577
578* Mon Jul  5 2004 Jakub Jelinek <jakub@redhat.com> 0.95-4
579- rebuilt with GCC 3.4.x, workaround VLA + alloca mixing
580  warning
581
582* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
583- rebuilt
584
585* Fri Apr  2 2004 Jeff Johnson <jbj@redhat.com> 0.95-2
586- upgrade to 0.95.
587
588* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
589- rebuilt
590
591* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
592- rebuilt
593
594* Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.94-1
595- upgrade to 0.94
596
597* Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.93-1
598- upgrade to 0.93
599
600* Thu Jan  8 2004 Jakub Jelinek <jakub@redhat.com> 0.92-1
601- full version
602- macroized spec file for GPL or OSL builds
603- include only libelf under GPL plus wrapper scripts
604
605* Wed Jan  7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-2
606- macroized spec file for GPL or OSL builds
607
608* Wed Jan  7 2004 Ulrich Drepper <drepper@redhat.com>
609- split elfutils-devel into two packages.
610
611* Wed Jan  7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-1
612- include only libelf under GPL plus wrapper scripts
613
614* Tue Dec 23 2003 Jeff Johnson <jbj@redhat.com> 0.89-3
615- readelf, not readline, in %%description (#111214).
616
617* Fri Sep 26 2003 Bill Nottingham <notting@redhat.com> 0.89-1
618- update to 0.89 (fix eu-strip)
619
620* Tue Sep 23 2003 Jakub Jelinek <jakub@redhat.com> 0.86-3
621- update to 0.86 (fix eu-strip on s390x/alpha)
622- libebl is an archive now; remove references to DSO
623
624* Mon Jul 14 2003 Jeff Johnson <jbj@redhat.com> 0.84-3
625- upgrade to 0.84 (readelf/elflint improvements, rawhide bugs fixed).
626
627* Fri Jul 11 2003 Jeff Johnson <jbj@redhat.com> 0.83-3
628- upgrade to 0.83 (fix invalid ELf handle on *.so strip, more).
629
630* Wed Jul  9 2003 Jeff Johnson <jbj@redhat.com> 0.82-3
631- upgrade to 0.82 (strip tests fixed on big-endian).
632
633* Tue Jul  8 2003 Jeff Johnson <jbj@redhat.com> 0.81-3
634- upgrade to 0.81 (strip excludes unused symtable entries, test borked).
635
636* Thu Jun 26 2003 Jeff Johnson <jbj@redhat.com> 0.80-3
637- upgrade to 0.80 (debugedit changes for kernel in progress).
638
639* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
640- rebuilt
641
642* Wed May 21 2003 Jeff Johnson <jbj@redhat.com> 0.79-2
643- upgrade to 0.79 (correct formats for size_t, more of libdw "works").
644
645* Mon May 19 2003 Jeff Johnson <jbj@redhat.com> 0.78-2
646- upgrade to 0.78 (libdwarf bugfix, libdw additions).
647
648* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
649- debuginfo rebuild
650
651* Thu Feb 20 2003 Jeff Johnson <jbj@redhat.com> 0.76-2
652- use the correct way of identifying the section via the sh_info link.
653
654* Sat Feb 15 2003 Jakub Jelinek <jakub@redhat.com> 0.75-2
655- update to 0.75 (eu-strip -g fix)
656
657* Tue Feb 11 2003 Jakub Jelinek <jakub@redhat.com> 0.74-2
658- update to 0.74 (fix for writing with some non-dirty sections)
659
660* Thu Feb  6 2003 Jeff Johnson <jbj@redhat.com> 0.73-3
661- another -0.73 update (with sparc fixes).
662- do "make check" in %%check, not %%install, section.
663
664* Mon Jan 27 2003 Jeff Johnson <jbj@redhat.com> 0.73-2
665- update to 0.73 (with s390 fixes).
666
667* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
668- rebuilt
669
670* Wed Jan 22 2003 Jakub Jelinek <jakub@redhat.com> 0.72-4
671- fix arguments to gelf_getsymshndx and elf_getshstrndx
672- fix other warnings
673- reenable checks on s390x
674
675* Sat Jan 11 2003 Karsten Hopp <karsten@redhat.de> 0.72-3
676- temporarily disable checks on s390x, until someone has
677  time to look at it
678
679* Thu Dec 12 2002 Jakub Jelinek <jakub@redhat.com> 0.72-2
680- update to 0.72
681
682* Wed Dec 11 2002 Jakub Jelinek <jakub@redhat.com> 0.71-2
683- update to 0.71
684
685* Wed Dec 11 2002 Jeff Johnson <jbj@redhat.com> 0.69-4
686- update to 0.69.
687- add "make check" and segfault avoidance patch.
688- elfutils-libelf needs to run ldconfig.
689
690* Tue Dec 10 2002 Jeff Johnson <jbj@redhat.com> 0.68-2
691- update to 0.68.
692
693* Fri Dec  6 2002 Jeff Johnson <jbj@redhat.com> 0.67-2
694- update to 0.67.
695
696* Tue Dec  3 2002 Jeff Johnson <jbj@redhat.com> 0.65-2
697- update to 0.65.
698
699* Mon Dec  2 2002 Jeff Johnson <jbj@redhat.com> 0.64-2
700- update to 0.64.
701
702* Sun Dec 1 2002 Ulrich Drepper <drepper@redhat.com> 0.64
703- split packages further into elfutils-libelf
704
705* Sat Nov 30 2002 Jeff Johnson <jbj@redhat.com> 0.63-2
706- update to 0.63.
707
708* Fri Nov 29 2002 Ulrich Drepper <drepper@redhat.com> 0.62
709- Adjust for dropping libtool
710
711* Sun Nov 24 2002 Jeff Johnson <jbj@redhat.com> 0.59-2
712- update to 0.59
713
714* Thu Nov 14 2002 Jeff Johnson <jbj@redhat.com> 0.56-2
715- update to 0.56
716
717* Thu Nov  7 2002 Jeff Johnson <jbj@redhat.com> 0.54-2
718- update to 0.54
719
720* Sun Oct 27 2002 Jeff Johnson <jbj@redhat.com> 0.53-2
721- update to 0.53
722- drop x86_64 hack, ICE fixed in gcc-3.2-11.
723
724* Sat Oct 26 2002 Jeff Johnson <jbj@redhat.com> 0.52-3
725- get beehive to punch a rhpkg generated package.
726
727* Wed Oct 23 2002 Jeff Johnson <jbj@redhat.com> 0.52-2
728- build in 8.0.1.
729- x86_64: avoid gcc-3.2 ICE on x86_64 for now.
730
731* Tue Oct 22 2002 Ulrich Drepper <drepper@redhat.com> 0.52
732- Add libelf-devel to conflicts for elfutils-devel
733
734* Mon Oct 21 2002 Ulrich Drepper <drepper@redhat.com> 0.50
735- Split into runtime and devel package
736
737* Fri Oct 18 2002 Ulrich Drepper <drepper@redhat.com> 0.49
738- integrate into official sources
739
740* Wed Oct 16 2002 Jeff Johnson <jbj@redhat.com> 0.46-1
741- Swaddle.
Note: See TracBrowser for help on using the repository browser.