source: projects/specs/trunk/e/elfutils/elfutils-vl.spec @ 11390

Revision 11390, 26.7 KB checked in by iwamoto, 6 years ago (diff)

elfutils: rebuilt for vineseed

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define eu_version 0.170
4%define eu_release 3
5
6%global nocheck true
7
8Summary: A collection of utilities and DSOs to handle compiled objects
9Summary(ja): コンパイル済みオブジェクトを扱うためのユーティリティ集
10Name: elfutils
11Version: %{eu_version}
12Release: %{eu_release}%{?_dist_release}
13
14License: GPLv3+ and (GPLv2+ or LGPLv3+)
15Group: Development/Tools
16URL: https://sourceware.org/elfutils/
17
18Source: https://sourceware.org/elfutils/ftp/%{version}/%{name}-%{version}.tar.bz2
19
20Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
21Requires: elfutils-libs-%{_arch} = %{version}-%{release}
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
24BuildRequires: bison >= 1.875
25BuildRequires: flex >= 2.5.4a
26BuildRequires: bzip2
27BuildRequires: bzip2-devel
28BuildRequires: zlib-devel
29BuildRequires: xz-devel
30BuildRequires: gettext
31BuildRequires: m4
32BuildRequires: gcc >= 3.4
33# Need <byteswap.h> that gives unsigned bswap_16 etc.
34BuildRequires: glibc-headers >= 2.3.4-11
35
36%define _gnu %{nil}
37%define _program_prefix eu-
38
39%description
40Elfutils is a collection of utilities, including ld (a linker),
41nm (for listing symbols from object files), size (for listing the
42section sizes of an object or archive file), strip (for discarding
43symbols), readelf (to see the raw ELF file structures), and elflint
44(to check for well-formed ELF files).
45
46
47%package libs
48Summary: Libraries to handle compiled objects
49Summary(ja): コンパイル済オブジェクトを扱うためのライブラリ
50License: GPLv2+ or LGPLv3+
51Group: System Environment/Libraries
52Provides: elfutils-libs-%{_arch} = %{version}-%{release}
53Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
54Conflicts: elfutils < %{version}-%{release}
55Conflicts: elfutils > %{version}-%{release}
56Conflicts: elfutils-devel < %{version}-%{release}
57Conflicts: elfutils-devel > %{version}-%{release}
58
59%description libs
60The elfutils-libs package contains libraries which implement DWARF, ELF,
61and machine-specific ELF handling.  These libraries are used by the programs
62in the elfutils package.  The elfutils-devel package enables building
63other programs using these libraries.
64
65
66%package devel
67Summary: Development libraries to handle compiled objects
68Summary(ja): コンパイル済オブジェクトを扱うための開発用ライブラリ
69License: GPLv2+ or LGPLv3+
70Group: Development/Libraries
71Provides: elfutils-devel-%{_arch} = %{version}-%{release}
72Requires: elfutils-libs-%{_arch} = %{version}-%{release}
73Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
74Conflicts: elfutils-libelf-devel < %{version}-%{release}
75Conflicts: elfutils-libelf-devel > %{version}-%{release}
76
77%description devel
78The elfutils-devel package contains the libraries to create
79applications for handling compiled objects.  libebl provides some
80higher-level ELF access functionality.  libdw provides access to
81the DWARF debugging information.  libasm provides a programmable
82assembler interface.
83
84
85%package devel-static
86Summary: Static archives to handle compiled objects
87Summary(ja): コンパイル済オブジェクトを扱うための静的ライブラリ
88License: GPLv2+ or LGPLv3+
89Group: Development/Libraries
90Provides: elfutils-devel-static-%{_arch} = %{version}-%{release}
91Requires: elfutils-devel-%{_arch} = %{version}-%{release}
92Requires: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
93Conflicts: elfutils-libelf-devel < %{version}-%{release}
94Conflicts: elfutils-libelf-devel > %{version}-%{release}
95
96%description devel-static
97The elfutils-devel-static package contains the static archives
98with the code to handle compiled objects.
99
100
101%package libelf
102Summary: Library to read and write ELF files
103Summary(ja): ELF ファイルを読み書きするためのライブラリ
104License: GPLv2+ or LGPLv3+
105Group: System Environment/Libraries
106Provides: libelf = %{version}-%{release}
107Obsoletes: libelf <= 0.8.2-2
108Provides: elfutils-libelf-%{_arch} = %{version}-%{release}
109Conflicts: elfutils < %{version}-%{release}
110Conflicts: elfutils > %{version}-%{release}
111Conflicts: elfutils-libs < %{version}-%{release}
112Conflicts: elfutils-libs > %{version}-%{release}
113Conflicts: elfutils-libelf-devel < %{version}-%{release}
114Conflicts: elfutils-libelf-devel > %{version}-%{release}
115
116%description libelf
117The elfutils-libelf package provides a DSO which allows reading and
118writing ELF files on a high level.  Third party programs depend on
119this package to read internals of ELF files.  The programs of the
120elfutils package use it also to generate new ELF files.
121
122
123%package libelf-devel
124Summary: Development support for libelf
125Summary(ja): libelf の開発用ライブラリ
126License: GPLv2+ or LGPLv3+
127Group: Development/Libraries
128Provides: libelf-devel = %{version}-%{release}
129Obsoletes: libelf-devel <= 0.8.2-2
130Provides: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
131Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
132Conflicts: libelf-devel < %{version}-%{release}
133
134%description libelf-devel
135The elfutils-libelf-devel package contains the libraries to create
136applications for handling compiled objects.  libelf allows you to
137access the internals of the ELF object file format, so you can see the
138different sections of an ELF file.
139
140
141%package libelf-devel-static
142Summary: Static archive of libelf
143Summary(ja): libelf の静的ライブラリ
144License: GPLv2+ or LGPLv3+
145Group: Development/Libraries
146Provides: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
147Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
148
149%description libelf-devel-static
150The elfutils-libelf-static package contains the static archive
151for libelf.
152
153
154# compat32
155%package -n compat32-%{name}-libelf
156Summary: Library to read and write ELF files
157Summary(ja): ELF ファイルを読み書きするためのライブラリ
158License: GPLv2+ or LGPLv3+
159Group: System Environment/Libraries
160Provides: compat32-libelf = %{version}-%{release}
161
162%description -n compat32-%{name}-libelf
163The elfutils-libelf package provides a DSO which allows reading and
164writing ELF files on a high level.  Third party programs depend on
165this package to read internals of ELF files.  The programs of the
166elfutils package use it also to generate new ELF files.
167
168%prep
169%setup -q
170
171find . -name \*.sh ! -perm -0100 -print | xargs chmod +x
172
173
174%build
175# Remove -Wall from default flags.  The makefiles enable enough warnings
176# themselves, and they use -Werror.  Appending -Wall defeats the cases where
177# the makefiles disable some specific warnings for specific code.
178# But add -Wformat explicitly for use with -Werror=format-security which
179# doesn't work without -Wformat (enabled by -Wall).
180RPM_OPT_FLAGS="${RPM_OPT_FLAGS/-Wall/}"
181RPM_OPT_FLAGS="${RPM_OPT_FLAGS} -Wformat"
182
183%configure CFLAGS="$RPM_OPT_FLAGS -fexceptions"
184make -s %{?_smp_mflags}
185
186
187%install
188rm -rf ${RPM_BUILD_ROOT}
189make -s install DESTDIR=${RPM_BUILD_ROOT}
190
191chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/lib*.so*
192chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/elfutils/lib*.so*
193
194%find_lang %{name}
195
196# XXX Nuke unpackaged files
197{ cd ${RPM_BUILD_ROOT}
198  rm -f .%{_bindir}/eu-ld
199}
200
201
202
203%check
204make -s %{?_smp_mflags} check || (cat tests/test-suite.log; %{nocheck})
205
206
207%clean
208rm -rf ${RPM_BUILD_ROOT}
209
210
211%post libs -p /sbin/ldconfig
212
213%postun libs -p /sbin/ldconfig
214
215%post libelf -p /sbin/ldconfig
216
217%postun libelf -p /sbin/ldconfig
218
219%post -n compat32-%{name}-libelf -p /sbin/ldconfig
220
221%postun -n compat32-%{name}-libelf -p /sbin/ldconfig
222
223
224%files -f %{name}.lang
225%defattr(-,root,root)
226%doc README TODO
227%{_bindir}/eu-addr2line
228%{_bindir}/eu-ar
229%{_bindir}/eu-elfcmp
230%{_bindir}/eu-elflint
231%{_bindir}/eu-findtextrel
232%{_bindir}/eu-nm
233%{_bindir}/eu-objdump
234%{_bindir}/eu-ranlib
235%{_bindir}/eu-readelf
236%{_bindir}/eu-size
237%{_bindir}/eu-stack
238%{_bindir}/eu-strings
239%{_bindir}/eu-strip
240#%{_bindir}/eu-ld
241%{_bindir}/eu-unstrip
242%{_bindir}/eu-make-debug-archive
243%{_bindir}/eu-elfcompress
244
245%files libs
246%defattr(-,root,root)
247%{_libdir}/libasm-%{version}.so
248%{_libdir}/libasm.so.*
249%{_libdir}/libdw-%{version}.so
250%{_libdir}/libdw.so.*
251%dir %{_libdir}/elfutils
252%{_libdir}/elfutils/lib*.so
253
254
255%files devel
256%defattr(-,root,root)
257%{_includedir}/dwarf.h
258%dir %{_includedir}/elfutils
259%{_includedir}/elfutils/elf-knowledge.h
260%{_includedir}/elfutils/known-dwarf.h
261%{_includedir}/elfutils/libasm.h
262%{_includedir}/elfutils/libebl.h
263%{_includedir}/elfutils/libdw.h
264%{_includedir}/elfutils/libdwelf.h
265%{_includedir}/elfutils/libdwfl.h
266%{_includedir}/elfutils/version.h
267%{_libdir}/libebl.a
268%{_libdir}/libasm.so
269%{_libdir}/libdw.so
270%{_libdir}/pkgconfig/libdw.pc
271
272
273%files devel-static
274%defattr(-,root,root)
275%{_libdir}/libasm.a
276%{_libdir}/libdw.a
277
278
279%files libelf
280%defattr(-,root,root)
281%{_libdir}/libelf-%{version}.so
282%{_libdir}/libelf.so.*
283
284
285%files libelf-devel
286%defattr(-,root,root)
287%{_includedir}/libelf.h
288%{_includedir}/gelf.h
289%{_includedir}/nlist.h
290%{_libdir}/libelf.so
291%{_libdir}/pkgconfig/libelf.pc
292
293
294%files libelf-devel-static
295%defattr(-,root,root)
296%{_libdir}/libelf.a
297
298%if %{build_compat32}
299%files -n compat32-%{name}-libelf
300%defattr(-,root,root)
301%{_libdir}/libelf-%{version}.so
302%{_libdir}/libelf.so.*
303%endif
304
305
306%changelog
307* Sat Jan 13 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.170-3
308- rebuilt
309- 2vl7 was skipped (used for vl6)
310
311* Sun Sep 10 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.170-1
312- updated to 0.170.
313- dropped all patches.
314
315* Wed Jun 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.161-3
316- rebuild with gcc-5.4.0
317
318* Sat Feb 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.161-2
319- create compat32-elfutils-libelf subpackage
320
321* Fri Feb 20 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.161-1
322- update to 0.161
323- added Japanese summary
324
325* Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 0.157-1
326- update to 0.157
327
328* Wed Apr 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-2
329- add BR: zlib-devel, bzip2-devel, xz-devel, m4, gettext
330
331* Tue Apr 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-1
332- update to 0.152
333
334* Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.135-2
335- elfutils-libs: changed Group to System Environment/Libraries
336- elfutils-libelf: changed Group to System Environment/Libraries
337- elfutils-devel: changed Group to Development/Libraries
338- elfutils-devel-static: changed Group to Development/Libraries
339- elfutils-libelf-devel: changed Group to Development/Libraries
340- elfutils-libelf-devel-static: changed Group to Development/Libraries
341
342* Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.135-1
343- merged with Fedora 9 0.135-1
344
345  - Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 0.131-1vl5
346  - applied new versioning policy
347  - added elfutils-0.131-readelf_c.patch
348
349  - Thu Nov 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.131-0vl1
350  - new upstream release
351  - move libelf/libelf-devel obsoletes tag (<BTS:0568>)
352    - remove Obsoletes: libelf, libelf-devel from elfutils
353    - add Obsoletes: libelf to elfutils-libelf
354    - add Obsoletes: libelf-devel to elfutils-libelf-devel
355
356* Mon May 12 2008 Roland McGrath <roland@redhat.com> - 0.135-1
357- Update to 0.135
358  - libdwfl: bug fixes
359  - eu-strip: changed handling of ET_REL files wrt symbol tables and relocs
360
361* Wed Apr  9 2008 Roland McGrath <roland@redhat.com> - 0.134-1
362- Update to 0.134
363  - elflint: backend improvements for sparc, alpha (#204170)
364  - libdwfl, libelf: bug fixes (#439344, #438867, #438263, #438190)
365- Remove Conflicts: libelf-devel from elfutils-libelf-devel. (#435742)
366
367* Sun Mar  2 2008 Roland McGrath <roland@redhat.com> - 0.133-2
368- Update to 0.133
369  - readelf, elflint, libebl: SHT_GNU_ATTRIBUTE section handling (readelf -A)
370  - readelf: core note handling for NT_386_TLS, NT_PPC_SPE, Alpha NT_AUXV
371  - libdwfl: bug fixes and optimization in relocation handling
372  - elfcmp: bug fix for non-allocated section handling
373  - ld: implement newer features of binutils linker.
374- Install eu-objdump and libasm, now has limited disassembler support.
375
376* Mon Jan 21 2008 Roland McGrath <roland@redhat.com> - 0.132-3
377- Update to 0.132
378  - libelf: Use loff_t instead of off64_t in libelf.h header. (#377241)
379  - eu-readelf: Fix handling of ET_REL files in archives.
380  - libcpu: Implement x86 and x86-64 disassembler.
381  - libasm: Add interface for disassembler.
382  - all programs: add debugging of branch prediction.
383  - libelf: new function elf_scnshndx.
384
385* Sun Nov 11 2007 Roland McGrath <roland@redhat.com> - 0.131-1
386- Update to 0.131
387  - libdw: DW_FORM_ref_addr support; dwarf_formref entry point now deprecated;
388           bug fixes for oddly-formatted DWARF
389  - libdwfl: bug fixes in offline archive support, symbol table handling;
390             apply partial relocations for dwfl_module_address_section on ET_REL
391  - libebl: powerpc backend support for Altivec registers
392
393* Wed Oct 17 2007 Roland McGrath <roland@redhat.com> - 0.130-3
394- Fix ET_REL support.
395- Fix odd indentation in eu-readelf -x output.
396
397* Tue Oct 16 2007 Roland McGrath <roland@redhat.com> - 0.130-1
398- Update to 0.130
399  - eu-readelf -p option can take an argument like -x for one section
400  - eu-readelf --archive-index (or -c)
401  - eu-readelf -n improved output for core dumps
402  - eu-readelf: handle SHT_NOTE sections without requiring phdrs (#249467)
403  - eu-elflint: ditto
404  - eu-elflint: stricter checks on debug sections
405  - eu-unstrip: new options, --list (or -n), --relocate (or -R)
406  - libelf: new function elf_getdata_rawchunk, replaces gelf_rawchunk;
407            new functions gelf_getnote, gelf_getauxv, gelf_update_auxv
408  - libebl: backend improvements (#324031)
409  - libdwfl: build_id support, new functions for it
410  - libdwfl: dwfl_module_addrsym fixes (#268761, #268981)
411  - libdwfl offline archive support, new script eu-make-debug-archive
412
413* Mon Aug 20 2007 Roland McGrath <roland@redhat.com> - 0.129-2
414- Fix false-positive eu-elflint failure on ppc -mbss-plt binaries.
415
416* Tue Aug 14 2007 Roland McGrath <roland@redhat.com> - 0.129-1
417- Update to 0.129
418  - readelf: new options --hex-dump (or -x), --strings (or -p) (#250973)
419  - addr2line: new option --symbols (or -S)
420  - libdw: dwarf_getscopes fixes (#230235)
421  - libdwfl: dwfl_module_addrsym fixes (#249490)
422
423* Fri Jun  8 2007 Roland McGrath <roland@redhat.com> - 0.128-2
424- Update to 0.128
425  - new program: unstrip
426  - elfcmp: new option --hash-inexact
427- Replace Conflicts: with Provides/Requires using -arch
428
429* Wed Apr 18 2007 Roland McGrath <roland@redhat.com> - 0.127-1
430- Update to 0.127
431  - libdw: new function dwarf_getsrcdirs
432  - libdwfl: new functions dwfl_module_addrsym, dwfl_report_begin_add,
433             dwfl_module_address_section
434
435* Mon Feb  5 2007 Roland McGrath <roland@redhat.com> - 0.126-1
436- Update to 0.126
437  - New program eu-ar.
438  - libdw: fix missing dwarf_getelf (#227206)
439  - libdwfl: dwfl_module_addrname for st_size=0 symbols (#227167, #227231)
440- Resolves: RHBZ #227206, RHBZ #227167, RHBZ #227231
441
442* Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-3
443- Fix overeager warn_unused_result build failures.
444
445* Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-1
446- Update to 0.125
447  - elflint: Compare DT_GNU_HASH tests.
448  - move archives into -static RPMs
449  - libelf, elflint: better support for core file handling
450  - Really fix libdwfl sorting of modules with 64-bit addresses (#220817).
451- Resolves: RHBZ #220817, RHBZ #213792
452
453* Tue Oct 10 2006 Roland McGrath <roland@redhat.com> - 0.124-1
454- eu-strip -f: copy symtab into debuginfo file when relocs use it (#203000)
455- Update to 0.124
456  - libebl: fix ia64 reloc support (#206981)
457  - libebl: sparc backend support for return value location
458  - libebl, libdwfl: backend register name support extended with more info
459  - libelf, libdw: bug fixes for unaligned accesses on machines that care
460  - readelf, elflint: trivial bugs fixed
461
462* Mon Aug 14 2006 Roland McGrath <roland@redhat.com> 0.123-1
463- Update to 0.123
464  - libebl: Backend build fixes, thanks to Stepan Kasal.
465  - libebl: ia64 backend support for register names, return value location
466  - libdwfl: Handle truncated linux kernel module section names.
467  - libdwfl: Look for linux kernel vmlinux files with .debug suffix.
468  - elflint: Fix checks to permit --hash-style=gnu format.
469
470* Mon Jul 17 2006 Roland McGrath <roland@redhat.com> - 0.122-4
471- Fix warnings in elflint compilation.
472
473* Wed Jul 12 2006 Roland McGrath <roland@redhat.com> - 0.122-3
474- Update to 0.122
475  - Fix libdwfl sorting of modules with 64-bit addresses (#198225).
476  - libebl: add function to test for relative relocation
477  - elflint: fix and extend DT_RELCOUNT/DT_RELACOUNT checks
478  - elflint, readelf: add support for DT_GNU_HASH
479  - libelf: add elf_gnu_hash
480  - elflint, readelf: add support for 64-bit SysV-style hash tables
481  - libdwfl: new functions dwfl_module_getsymtab, dwfl_module_getsym.
482
483* Thu Jun 15 2006 Roland McGrath <roland@redhat.com> - 0.121-1
484- Update to 0.121
485  - libelf: bug fixes for rewriting existing files when using mmap (#187618).
486  - make all installed headers usable in C++ code (#193153).
487  - eu-readelf: better output format.
488  - eu-elflint: fix tests of dynamic section content.
489  - libdw, libdwfl: handle files without aranges info.
490
491* Thu May 25 2006 Jeremy Katz <katzj@redhat.com> - 0.120-3
492- rebuild to pick up -devel deps
493
494* Tue Apr  4 2006 Roland McGrath <roland@redhat.com> - 0.120-2
495- Update to 0.120
496  - License changed to GPL, with some exceptions for using
497    the libelf, libebl, libdw, and libdwfl library interfaces.
498    Red Hat elfutils is an included package of the Open Invention Network.
499  - dwarf.h updated for DWARF 3.0 final specification.
500  - libelf: Fix corruption in ELF_C_RDWR uses (#187618).
501  - libdwfl: New function dwfl_version; fixes for offline.
502
503* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2.1
504- bump again for double-long bug on ppc(64)
505
506* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2
507- rebuilt for new gcc4.1 snapshot and glibc changes
508
509* Fri Jan 13 2006 Roland McGrath <roland@redhat.com> - 0.119-1
510- update to 0.119
511
512* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
513- rebuilt
514
515* Sun Nov 27 2005 Roland McGrath <roland@redhat.com> - 0.118-1
516- update to 0.118
517  - elflint: more tests.
518  - libdwfl: New function dwfl_module_register_names.
519  - libebl: New backend hook for register names.
520- Make sure -fexceptions is always in CFLAGS.
521
522* Tue Nov 22 2005 Roland McGrath <roland@redhat.com> - 0.117-2
523- update to 0.117
524  - libdwfl: New function dwfl_module_return_value_location (#166118)
525  - libebl: Backend improvements for several CPUs
526
527* Mon Oct 31 2005 Roland McGrath <roland@redhat.com> - 0.116-1
528- update to 0.116
529  - libdw fixes, API changes and additions
530  - libdwfl fixes (#169672)
531  - eu-strip/libelf fix to preserve setuid/setgid permission bits (#167745)
532
533* Fri Sep  9 2005 Roland McGrath <roland@redhat.com> - 0.115-3
534- Update requires/conflicts for better biarch update behavior.
535
536* Mon Sep  5 2005 Roland McGrath <roland@redhat.com> - 0.115-2
537- update to 0.115
538  - New program eu-strings.
539  - libdw: New function dwarf_getscopes_die.
540  - libelf: speed-ups of non-mmap reading.
541  - Implement --enable-gcov option for configure.
542
543* Wed Aug 24 2005 Roland McGrath <roland@redhat.com> - 0.114-1
544- update to 0.114
545  - new program eu-ranlib
546  - libdw: new calls for inlines
547  - libdwfl: new calls for offline modules
548
549* Sat Aug 13 2005 Roland McGrath <roland@redhat.com> - 0.113-2
550- update to 0.113
551  - elflint: relax a bit.  Allow version definitions for defined symbols
552    against DSO versions also for symbols in nobits sections.
553    Allow .rodata section to have STRINGS and MERGE flag set.
554  - strip: add some more compatibility with binutils.
555  - libdwfl: bug fixes.
556- Separate libdw et al into elfutils-libs subpackage.
557
558* Sat Aug  6 2005 Roland McGrath <roland@redhat.com> - 0.112-1
559- update to 0.112
560  - elfcmp: some more relaxation.
561  - elflint: many more tests, especially regarding to symbol versioning.
562  - libelf: Add elfXX_offscn and gelf_offscn.
563  - libasm: asm_begin interface changes.
564  - libebl: Add three new interfaces to directly access machine, class,
565    and data encoding information.
566
567* Fri Jul 29 2005 Roland McGrath <roland@redhat.com> - 0.111-2
568- update portability patch
569
570* Thu Jul 28 2005 Roland McGrath <roland@redhat.com> - 0.111-1
571- update to 0.111
572  - libdwfl library now merged into libdw
573
574* Sun Jul 24 2005 Roland McGrath <roland@redhat.com> - 0.110-1
575- update to 0.110
576
577* Fri Jul 22 2005 Roland McGrath <roland@redhat.com> - 0.109-2
578- update to 0.109
579  - verify that libebl modules are from the same build
580  - new eu-elflint checks on copy relocations
581  - new program eu-elfcmp
582  - new experimental libdwfl library
583
584* Thu Jun  9 2005 Roland McGrath <roland@redhat.com> - 0.108-5
585- robustification of eu-strip and eu-readelf
586
587* Wed May 25 2005 Roland McGrath <roland@redhat.com> - 0.108-3
588- more robustification
589
590* Mon May 16 2005 Roland McGrath <roland@redhat.com> - 0.108-2
591- robustification
592
593* Mon May  9 2005 Roland McGrath <roland@redhat.com> - 0.108-1
594- update to 0.108
595  - merge strip fixes
596  - sort records in dwarf_getsrclines, fix dwarf_getsrc_die searching
597  - update elf.h from glibc
598
599* Sun May  8 2005 Roland McGrath <roland@redhat.com> - 0.107-2
600- fix strip -f byte-swapping bug
601
602* Sun May  8 2005 Roland McGrath <roland@redhat.com> - 0.107-1
603- update to 0.107
604  - readelf: improve DWARF output format
605  - elflint: -d option to support checking separate debuginfo files
606  - strip: fix ET_REL debuginfo files (#156341)
607
608* Mon Apr  4 2005 Roland McGrath <roland@redhat.com> - 0.106-3
609- fix some bugs in new code, reenable make check
610
611* Mon Apr  4 2005 Roland McGrath <roland@redhat.com> - 0.106-2
612- disable make check for most arches, for now
613
614* Mon Apr  4 2005 Roland McGrath <roland@redhat.com> - 0.106-1
615- update to 0.106
616
617* Mon Mar 28 2005 Roland McGrath <roland@redhat.com> - 0.104-2
618- update to 0.104
619
620* Wed Mar 23 2005 Jakub Jelinek <jakub@redhat.com> 0.103-2
621- update to 0.103
622
623* Wed Feb 16 2005 Jakub Jelinek <jakub@redhat.com> 0.101-2
624- update to 0.101.
625- use %%configure macro to get CFLAGS etc. right
626
627* Sat Feb  5 2005 Jeff Johnson <jbj@redhat.com> 0.99-2
628- upgrade to 0.99.
629
630* Sun Sep 26 2004 Jeff Johnson <jbj@redhat.com> 0.97-3
631- upgrade to 0.97.
632
633* Tue Aug 17 2004 Jakub Jelinek <jakub@redhat.com> 0.95-5
634- upgrade to 0.96.
635
636* Mon Jul  5 2004 Jakub Jelinek <jakub@redhat.com> 0.95-4
637- rebuilt with GCC 3.4.x, workaround VLA + alloca mixing
638  warning
639
640* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
641- rebuilt
642
643* Fri Apr  2 2004 Jeff Johnson <jbj@redhat.com> 0.95-2
644- upgrade to 0.95.
645
646* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
647- rebuilt
648
649* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
650- rebuilt
651
652* Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.94-1
653- upgrade to 0.94
654
655* Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.93-1
656- upgrade to 0.93
657
658* Thu Jan  8 2004 Jakub Jelinek <jakub@redhat.com> 0.92-1
659- full version
660- macroized spec file for GPL or OSL builds
661- include only libelf under GPL plus wrapper scripts
662
663* Wed Jan  7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-2
664- macroized spec file for GPL or OSL builds
665
666* Wed Jan  7 2004 Ulrich Drepper <drepper@redhat.com>
667- split elfutils-devel into two packages.
668
669* Wed Jan  7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-1
670- include only libelf under GPL plus wrapper scripts
671
672* Tue Dec 23 2003 Jeff Johnson <jbj@redhat.com> 0.89-3
673- readelf, not readline, in %%description (#111214).
674
675* Fri Sep 26 2003 Bill Nottingham <notting@redhat.com> 0.89-1
676- update to 0.89 (fix eu-strip)
677
678* Tue Sep 23 2003 Jakub Jelinek <jakub@redhat.com> 0.86-3
679- update to 0.86 (fix eu-strip on s390x/alpha)
680- libebl is an archive now; remove references to DSO
681
682* Mon Jul 14 2003 Jeff Johnson <jbj@redhat.com> 0.84-3
683- upgrade to 0.84 (readelf/elflint improvements, rawhide bugs fixed).
684
685* Fri Jul 11 2003 Jeff Johnson <jbj@redhat.com> 0.83-3
686- upgrade to 0.83 (fix invalid ELf handle on *.so strip, more).
687
688* Wed Jul  9 2003 Jeff Johnson <jbj@redhat.com> 0.82-3
689- upgrade to 0.82 (strip tests fixed on big-endian).
690
691* Tue Jul  8 2003 Jeff Johnson <jbj@redhat.com> 0.81-3
692- upgrade to 0.81 (strip excludes unused symtable entries, test borked).
693
694* Thu Jun 26 2003 Jeff Johnson <jbj@redhat.com> 0.80-3
695- upgrade to 0.80 (debugedit changes for kernel in progress).
696
697* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
698- rebuilt
699
700* Wed May 21 2003 Jeff Johnson <jbj@redhat.com> 0.79-2
701- upgrade to 0.79 (correct formats for size_t, more of libdw "works").
702
703* Mon May 19 2003 Jeff Johnson <jbj@redhat.com> 0.78-2
704- upgrade to 0.78 (libdwarf bugfix, libdw additions).
705
706* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
707- debuginfo rebuild
708
709* Thu Feb 20 2003 Jeff Johnson <jbj@redhat.com> 0.76-2
710- use the correct way of identifying the section via the sh_info link.
711
712* Sat Feb 15 2003 Jakub Jelinek <jakub@redhat.com> 0.75-2
713- update to 0.75 (eu-strip -g fix)
714
715* Tue Feb 11 2003 Jakub Jelinek <jakub@redhat.com> 0.74-2
716- update to 0.74 (fix for writing with some non-dirty sections)
717
718* Thu Feb  6 2003 Jeff Johnson <jbj@redhat.com> 0.73-3
719- another -0.73 update (with sparc fixes).
720- do "make check" in %%check, not %%install, section.
721
722* Mon Jan 27 2003 Jeff Johnson <jbj@redhat.com> 0.73-2
723- update to 0.73 (with s390 fixes).
724
725* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
726- rebuilt
727
728* Wed Jan 22 2003 Jakub Jelinek <jakub@redhat.com> 0.72-4
729- fix arguments to gelf_getsymshndx and elf_getshstrndx
730- fix other warnings
731- reenable checks on s390x
732
733* Sat Jan 11 2003 Karsten Hopp <karsten@redhat.de> 0.72-3
734- temporarily disable checks on s390x, until someone has
735  time to look at it
736
737* Thu Dec 12 2002 Jakub Jelinek <jakub@redhat.com> 0.72-2
738- update to 0.72
739
740* Wed Dec 11 2002 Jakub Jelinek <jakub@redhat.com> 0.71-2
741- update to 0.71
742
743* Wed Dec 11 2002 Jeff Johnson <jbj@redhat.com> 0.69-4
744- update to 0.69.
745- add "make check" and segfault avoidance patch.
746- elfutils-libelf needs to run ldconfig.
747
748* Tue Dec 10 2002 Jeff Johnson <jbj@redhat.com> 0.68-2
749- update to 0.68.
750
751* Fri Dec  6 2002 Jeff Johnson <jbj@redhat.com> 0.67-2
752- update to 0.67.
753
754* Tue Dec  3 2002 Jeff Johnson <jbj@redhat.com> 0.65-2
755- update to 0.65.
756
757* Mon Dec  2 2002 Jeff Johnson <jbj@redhat.com> 0.64-2
758- update to 0.64.
759
760* Sun Dec 1 2002 Ulrich Drepper <drepper@redhat.com> 0.64
761- split packages further into elfutils-libelf
762
763* Sat Nov 30 2002 Jeff Johnson <jbj@redhat.com> 0.63-2
764- update to 0.63.
765
766* Fri Nov 29 2002 Ulrich Drepper <drepper@redhat.com> 0.62
767- Adjust for dropping libtool
768
769* Sun Nov 24 2002 Jeff Johnson <jbj@redhat.com> 0.59-2
770- update to 0.59
771
772* Thu Nov 14 2002 Jeff Johnson <jbj@redhat.com> 0.56-2
773- update to 0.56
774
775* Thu Nov  7 2002 Jeff Johnson <jbj@redhat.com> 0.54-2
776- update to 0.54
777
778* Sun Oct 27 2002 Jeff Johnson <jbj@redhat.com> 0.53-2
779- update to 0.53
780- drop x86_64 hack, ICE fixed in gcc-3.2-11.
781
782* Sat Oct 26 2002 Jeff Johnson <jbj@redhat.com> 0.52-3
783- get beehive to punch a rhpkg generated package.
784
785* Wed Oct 23 2002 Jeff Johnson <jbj@redhat.com> 0.52-2
786- build in 8.0.1.
787- x86_64: avoid gcc-3.2 ICE on x86_64 for now.
788
789* Tue Oct 22 2002 Ulrich Drepper <drepper@redhat.com> 0.52
790- Add libelf-devel to conflicts for elfutils-devel
791
792* Mon Oct 21 2002 Ulrich Drepper <drepper@redhat.com> 0.50
793- Split into runtime and devel package
794
795* Fri Oct 18 2002 Ulrich Drepper <drepper@redhat.com> 0.49
796- integrate into official sources
797
798* Wed Oct 16 2002 Jeff Johnson <jbj@redhat.com> 0.46-1
799- Swaddle.
Note: See TracBrowser for help on using the repository browser.