source: projects/specs/trunk/e/ekiga/ekiga-vl.spec @ 4812

Revision 4812, 8.4 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME-3.1.92

Line 
1Summary: A Gnome based SIP/H323 teleconferencing application
2Summary(ja): GNOME ベースの SIP/H323 遠隔会議アプリケーション
3Name: ekiga
4Version: 3.3.2
5Release: 1%{?_dist_release}
6URL: http://www.ekiga.org/
7Source0: http://www.ekiga.org/ekiga-%{version}.tar.xz
8License: GPL
9Group: Applications/Communications
10
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12BuildRequires: gtk2-devel >= 2.14.0
13BuildRequires: GConf2-devel >= 2.24.0
14BuildRequires: libgnomeui-devel >= 2.24.0
15BuildRequires: libgnome-devel >= 2.24.0
16BuildRequires: avahi-devel >= 0.6.23
17BuildRequires: avahi-glib-devel >= 0.6.23
18BuildRequires: openldap-devel
19BuildRequires: ptlib-devel >= 2.10.1
20BuildRequires: opal-devel >= 3.10.1
21BuildRequires: libxml2-devel >= 2.6.0
22BuildRequires: SDL-devel
23BuildRequires: intltool >= 0.22
24BuildRequires: pkgconfig
25BuildRequires: scrollkeeper
26BuildRequires: alsa-lib-devel
27BuildRequires: gettext
28BuildRequires: evolution-data-server-devel >= 2.32.0
29BuildRequires: gnome-doc-utils >= 0.3.2
30BuildRequires: desktop-file-utils
31BuildRequires: dbus-devel
32BuildRequires: dbus-glib-devel
33BuildRequires: libsigc++-devel
34BuildRequires: libXv-devel
35BuildRequires: libnotify-devel
36BuildRequires: libboost-devel
37BuildRequires: libboost-signals
38
39Requires(post): GConf2, scrollkeeper
40Requires(postun): scrollkeeper
41
42Obsoletes: gnomemeeting
43
44Vendor: Project Vine
45Distribution: Vine Linux
46
47%description
48Ekiga is a tool to communicate with video and audio over the internet.
49It uses the standard SIP and H323 protocols.
50
51%prep
52%setup -q
53
54%build
55CXXFLAGS="$RPM_OPT_FLAGS -DLDAP_DEPRECATED=1 -fPIC"
56%configure \
57        --disable-static \
58        --disable-scrollkeeper \
59        --disable-schemas-install
60make %{?_smp_mflags}
61
62%install
63rm -rf $RPM_BUILD_ROOT
64export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
65make install DESTDIR=$RPM_BUILD_ROOT
66unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
67
68rm -rf $RPM_BUILD_ROOT/var/scrollkeeper
69
70find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
71
72desktop-file-install \
73    --vendor gnome \
74    --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
75    --delete-original \
76    --copy-generic-name-to-name \
77    $RPM_BUILD_ROOT%{_datadir}/applications/ekiga.desktop
78
79%find_lang %{name} --with-gnome
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84%post
85export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
86gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/ekiga.schemas > /dev/null 2>&1
87gconftool-2 --shutdown
88(yes | ekiga-config-tool --install-schemas) > /dev/null 2>&1 ||:
89update-desktop-database %{_datadir}/applications >& /dev/null ||:
90scrollkeeper-update -q > /dev/null ||:
91touch --no-create %{_datadir}/icons/hicolor
92if [ -x /usr/bin/gtk-update-icon-cache ]; then
93  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
94fi
95 
96%pre
97if [ "$1" -gt 1 ]; then
98  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
99  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/ekiga.schemas > /dev/null 2>&1
100fi
101
102%preun
103if [ "$1" -eq 0 ]; then
104  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
105  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/ekiga.schemas > /dev/null 2>&1
106fi
107
108%postun
109update-desktop-database %{_datadir}/applications >& /dev/null ||:
110scrollkeeper-update -q > /dev/null ||:
111touch --no-create %{_datadir}/icons/hicolor
112if [ -x /usr/bin/gtk-update-icon-cache ]; then
113  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
114fi
115
116%files -f ekiga.lang
117%defattr(-,root,root)
118%doc AUTHORS COPYING ChangeLog NEWS README
119%{_sysconfdir}/gconf/schemas/ekiga.schemas
120%{_bindir}/ekiga
121%{_bindir}/ekiga-config-tool
122%{_bindir}/ekiga-helper
123%{_libdir}/%{name}/%{version}/libekiga.so
124%{_libdir}/%{name}/%{version}/plugins/*.so
125%{_datadir}/applications/gnome-ekiga.desktop
126%{_datadir}/dbus-1/services/*
127%{_datadir}/pixmaps/*
128%{_datadir}/man/*/*
129%{_datadir}/sounds/ekiga
130%{_datadir}/icons/hicolor/*/apps/*
131
132%changelog
133* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.2-1
134- new upstream release
135
136* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.1-2
137- rebuild with evolution-data-server-3.1.90
138
139* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.1-1
140- new upstream release
141- add BuildRequires: libnotify-devel, libboost-devel, libboost-signals
142
143* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.7-4
144- rebuild with openssl-1.0.0c
145
146* Tue Oct 05 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.7-3
147- rebuild with evolution-data-server-2.32.0
148
149* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.7-2
150- rebuild with evolution-data-server-2.30.2
151
152* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.7-1
153- new upstream release
154
155* Sun Mar 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.6-1
156- new upstream release
157- add BuildRequires: libXv-devel
158
159* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.4-1
160- new upstream release
161
162* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.1-1
163- new upstream release
164
165* Sat Apr  4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.0.2-1
166- new upstream release
167
168* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-1
169- new upstream release
170
171* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.0-1
172- new upstream release
173
174* Sun Sep 28 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.11-2vl5
175- built with gnome-2.24
176
177* Mon Sep 22 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.11-1vl5
178- applied new versioning policy
179
180* Sat Sep 29 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.11-0vl1
181- new upstream release
182
183* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.9-0vl5
184- rebuilt with evolution-data-server-devel 1.10.1
185
186* Tue May 22 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.9-0vl4
187- add BuildRequires: dbus-glib-devel
188
189* Sat May 12 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.9-0vl3
190- rebuilt with new toolchain
191
192* Mon Apr 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.9-0vl2
193- rebuilt with dbus 1.0.2
194
195* Sat Apr 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.9-0vl1
196- new upstream release
197
198* Sat Feb 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.5-0vl1
199- new upstream release
200
201* Sun Feb  4 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.4-1vl1
202- initial built for Vine Linux
203
204* Mon Jan 22 2007 Daniel Veillard <veillard@redhat.com> - 2.0.4-1
205- Upgrade to ekiga-2.0.4
206
207* Thu Nov  2 2006 Daniel Veillard <veillard@redhat.com> - 2.0.3-3
208- Resolves: rhbz#201535
209- fixes build-requires for opal-devel and pwlib-devel
210
211* Sat Oct 28 2006 Matthias Clasen <mclasen@redhat.com> - 2.0.3-2
212- Rebuild against evolution-data-server 1.9
213
214* Sat Oct 21 2006 Matthias Clasen <mclasen@redhat.com> - 2.0.3-1
215- Update to 2.0.3
216
217* Sat Sep 30 2006 Matthias Clasen <mclasen@redhat.com> - 2.0.2-7
218- Make the status icon work in transparent panels
219
220* Thu Aug 31 2006 Matthias Clasen <mclasen@redhat.com> - 2.0.2-6
221- Fix translator credits (197871)
222
223* Mon Aug  7 2006 Matthew Barnes <mbarnes@redhat.com> - 2.0.2-5
224- Rebuild against evolution-data-server-1.7.91
225
226* Sat Aug  5 2006 Caolan McNamara <caolanm@redhat.com> - 2.0.2-4
227- rebuild against new e-d-s
228
229* Tue Aug  1 2006 Daniel Veillard <veillard@redhat.com> - 2.0.2-3
230- rebuilt for #200960
231
232* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.0.2-1.1
233- rebuild
234
235* Wed May 31 2006 Daniel Veillard <veillard@redhat.com> - 2.0.2-1
236- new release of ekiga 2.0.2
237- activating Zeroconf support though avahi
238
239* Mon May 22 2006 Jesse Keating <jkeating@redhat.com> - 2.0.1-3
240- Fix BuildRequires and Requires(post), Requires(postun)
241
242* Wed Mar 15 2006 Daniel Veillard <veillard@redhat.com> - 2.0.1-2
243- run 'ekiga-config-tool --install-schemas' in %post, c.f. #178929
244
245* Tue Mar 14 2006 Daniel Veillard <veillard@redhat.com> - 2.0.1-1
246- last minute bug rerelease 2.0.1
247
248* Mon Mar 13 2006 Daniel Veillard <veillard@redhat.com> - 2.0.0-1
249- final release of 2.0.0
250
251* Mon Feb 20 2006 Karsten Hopp <karsten@redhat.de> 1.99.1-2
252- Buildrequires: gnome-doc-utils
253
254* Mon Feb 13 2006 Daniel Veillard <veillard@redhat.com> - 1.99.1-1
255- new beta release issued
256
257* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.99.0-3.2
258- bump again for double-long bug on ppc(64)
259
260* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.99.0-3.1
261- rebuilt for new gcc4.1 snapshot and glibc changes
262
263* Sat Jan 28 2006 Daniel Veillard <veillard@redhat.com> - 1.99.0-3
264- Rebuilt following a libedataserver revision
265
266* Fri Jan 27 2006 Matthias Clasen <mclasen@redhat.com> - 1.99.0-2
267- Use the upstream .desktop file
268
269* Tue Jan 24 2006 Daniel Veillard <veillard@redhat.com> - 1.99.0-1
270- initial version based on the 1.99.0 beta and gnomemeeting spec file.
Note: See TracBrowser for help on using the repository browser.