source: projects/specs/trunk/e/ekiga/ekiga-vl.spec @ 10488

Revision 10488, 9.6 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1Summary: A Gnome based SIP/H323 teleconferencing application
2Summary(ja): GNOME ベースの SIP/H323 遠隔会議アプリケーション
3Name: ekiga
4Version: 4.0.1
5Release: 9%{?_dist_release}
6URL: http://www.ekiga.org/
7Source0: http://www.ekiga.org/ekiga-%{version}.tar.xz
8License: GPL
9Group: Applications/Communications
10
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12BuildRequires: gtk2-devel >= 2.14.0
13BuildRequires: GConf2-devel >= 2.24.0
14BuildRequires: libgnomeui-devel >= 2.24.0
15BuildRequires: libgnome-devel >= 2.24.0
16BuildRequires: avahi-devel >= 0.6.23
17BuildRequires: avahi-glib-devel >= 0.6.23
18BuildRequires: openldap-devel
19BuildRequires: ptlib-devel >= 2.10.9
20BuildRequires: opal-devel >= 3.10.9
21BuildRequires: libxml2-devel >= 2.6.0
22BuildRequires: SDL-devel
23BuildRequires: intltool >= 0.22
24BuildRequires: pkgconfig
25BuildRequires: scrollkeeper
26BuildRequires: alsa-lib-devel
27BuildRequires: gettext
28BuildRequires: evolution-data-server-devel >= 2.32.0
29BuildRequires: gnome-doc-utils >= 0.3.2
30BuildRequires: desktop-file-utils
31BuildRequires: dbus-devel
32BuildRequires: dbus-glib-devel
33BuildRequires: libsigc++-devel
34BuildRequires: libXv-devel
35BuildRequires: libnotify-devel
36BuildRequires: libboost-devel
37BuildRequires: libboost-signals
38BuildRequires: gnome-icon-theme >= 3.0.0
39
40Requires(post): GConf2, scrollkeeper
41Requires(postun): scrollkeeper
42
43Obsoletes: gnomemeeting
44
45Vendor: Project Vine
46Distribution: Vine Linux
47
48%description
49Ekiga is a tool to communicate with video and audio over the internet.
50It uses the standard SIP and H323 protocols.
51
52%prep
53%setup -q
54
55%build
56CXXFLAGS="$RPM_OPT_FLAGS -DLDAP_DEPRECATED=1 -fPIC"
57%configure \
58        --disable-static \
59        --disable-scrollkeeper \
60        --disable-schemas-install
61make %{?_smp_mflags}
62
63%install
64rm -rf $RPM_BUILD_ROOT
65export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
66make install DESTDIR=$RPM_BUILD_ROOT
67unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
68
69rm -rf $RPM_BUILD_ROOT/var/scrollkeeper
70
71find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
72
73desktop-file-install \
74    --vendor gnome \
75    --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
76    --delete-original \
77    --copy-generic-name-to-name \
78    $RPM_BUILD_ROOT%{_datadir}/applications/ekiga.desktop
79
80%find_lang %{name} --with-gnome
81
82%clean
83rm -rf $RPM_BUILD_ROOT
84
85%post
86export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
87gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/ekiga.schemas > /dev/null 2>&1
88gconftool-2 --shutdown
89(yes | ekiga-config-tool --install-schemas) > /dev/null 2>&1 ||:
90update-desktop-database %{_datadir}/applications >& /dev/null ||:
91scrollkeeper-update -q > /dev/null ||:
92touch --no-create %{_datadir}/icons/hicolor
93if [ -x /usr/bin/gtk-update-icon-cache ]; then
94  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
95fi
96 
97%pre
98if [ "$1" -gt 1 ]; then
99  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
100  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/ekiga.schemas > /dev/null 2>&1
101fi
102
103%preun
104if [ "$1" -eq 0 ]; then
105  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
106  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/ekiga.schemas > /dev/null 2>&1
107fi
108
109%postun
110update-desktop-database %{_datadir}/applications >& /dev/null ||:
111scrollkeeper-update -q > /dev/null ||:
112touch --no-create %{_datadir}/icons/hicolor
113if [ -x /usr/bin/gtk-update-icon-cache ]; then
114  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
115fi
116
117%files -f ekiga.lang
118%defattr(-,root,root)
119%doc AUTHORS COPYING ChangeLog NEWS README
120%{_sysconfdir}/gconf/schemas/ekiga.schemas
121%{_bindir}/ekiga
122%{_bindir}/ekiga-config-tool
123%{_bindir}/ekiga-helper
124%{_libdir}/%{name}/%{version}/libekiga.so
125%{_libdir}/%{name}/%{version}/plugins/*.so
126%{_datadir}/applications/gnome-ekiga.desktop
127%{_datadir}/dbus-1/services/*
128%{_datadir}/pixmaps/*
129%{_datadir}/man/*/*
130%{_datadir}/sounds/ekiga
131%{_datadir}/icons/hicolor/*/apps/*
132
133%changelog
134* Sat Jul 02 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.1-9
135- rebuild with gcc-5.4.0
136
137* Mon Jun 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.1-8
138- rebuild with libboost-1.60.0
139
140* Sat Nov 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.1-7
141- rebuild with evolution-data-server-3.18.1
142
143* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.1-6
144- rebuild with evolution-data-server-3.16.0
145
146* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.1-5
147- rebuild with evolution-data-server-3.12.0
148
149* Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.1-4
150- rebuild with libboost-1.54.0
151
152* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.1-3
153- rebuild with evolution-data-server-3.10.1
154
155* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.1-2
156- rebuild with evolution-data-server-3.8.0
157
158* Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.1-1
159- new upstream release
160
161* Fri Jan 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.0-1
162- new upstream release
163- add BuildRequires; gnome-icon-theme
164
165* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.9.90-1
166- new upstream release
167
168* Thu Apr 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.2-2
169- rebuild with evolution-data-server-3.4.0
170
171* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.2-1
172- new upstream release
173
174* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.1-2
175- rebuild with evolution-data-server-3.1.90
176
177* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.1-1
178- new upstream release
179- add BuildRequires: libnotify-devel, libboost-devel, libboost-signals
180
181* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.7-4
182- rebuild with openssl-1.0.0c
183
184* Tue Oct 05 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.7-3
185- rebuild with evolution-data-server-2.32.0
186
187* Tue Jun 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.7-2
188- rebuild with evolution-data-server-2.30.2
189
190* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.7-1
191- new upstream release
192
193* Sun Mar 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.6-1
194- new upstream release
195- add BuildRequires: libXv-devel
196
197* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.4-1
198- new upstream release
199
200* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.1-1
201- new upstream release
202
203* Sat Apr  4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.0.2-1
204- new upstream release
205
206* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-1
207- new upstream release
208
209* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.0-1
210- new upstream release
211
212* Sun Sep 28 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.11-2vl5
213- built with gnome-2.24
214
215* Mon Sep 22 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.11-1vl5
216- applied new versioning policy
217
218* Sat Sep 29 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.11-0vl1
219- new upstream release
220
221* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.9-0vl5
222- rebuilt with evolution-data-server-devel 1.10.1
223
224* Tue May 22 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.9-0vl4
225- add BuildRequires: dbus-glib-devel
226
227* Sat May 12 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.9-0vl3
228- rebuilt with new toolchain
229
230* Mon Apr 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.9-0vl2
231- rebuilt with dbus 1.0.2
232
233* Sat Apr 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.9-0vl1
234- new upstream release
235
236* Sat Feb 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.5-0vl1
237- new upstream release
238
239* Sun Feb  4 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.4-1vl1
240- initial built for Vine Linux
241
242* Mon Jan 22 2007 Daniel Veillard <veillard@redhat.com> - 2.0.4-1
243- Upgrade to ekiga-2.0.4
244
245* Thu Nov  2 2006 Daniel Veillard <veillard@redhat.com> - 2.0.3-3
246- Resolves: rhbz#201535
247- fixes build-requires for opal-devel and pwlib-devel
248
249* Sat Oct 28 2006 Matthias Clasen <mclasen@redhat.com> - 2.0.3-2
250- Rebuild against evolution-data-server 1.9
251
252* Sat Oct 21 2006 Matthias Clasen <mclasen@redhat.com> - 2.0.3-1
253- Update to 2.0.3
254
255* Sat Sep 30 2006 Matthias Clasen <mclasen@redhat.com> - 2.0.2-7
256- Make the status icon work in transparent panels
257
258* Thu Aug 31 2006 Matthias Clasen <mclasen@redhat.com> - 2.0.2-6
259- Fix translator credits (197871)
260
261* Mon Aug  7 2006 Matthew Barnes <mbarnes@redhat.com> - 2.0.2-5
262- Rebuild against evolution-data-server-1.7.91
263
264* Sat Aug  5 2006 Caolan McNamara <caolanm@redhat.com> - 2.0.2-4
265- rebuild against new e-d-s
266
267* Tue Aug  1 2006 Daniel Veillard <veillard@redhat.com> - 2.0.2-3
268- rebuilt for #200960
269
270* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.0.2-1.1
271- rebuild
272
273* Wed May 31 2006 Daniel Veillard <veillard@redhat.com> - 2.0.2-1
274- new release of ekiga 2.0.2
275- activating Zeroconf support though avahi
276
277* Mon May 22 2006 Jesse Keating <jkeating@redhat.com> - 2.0.1-3
278- Fix BuildRequires and Requires(post), Requires(postun)
279
280* Wed Mar 15 2006 Daniel Veillard <veillard@redhat.com> - 2.0.1-2
281- run 'ekiga-config-tool --install-schemas' in %post, c.f. #178929
282
283* Tue Mar 14 2006 Daniel Veillard <veillard@redhat.com> - 2.0.1-1
284- last minute bug rerelease 2.0.1
285
286* Mon Mar 13 2006 Daniel Veillard <veillard@redhat.com> - 2.0.0-1
287- final release of 2.0.0
288
289* Mon Feb 20 2006 Karsten Hopp <karsten@redhat.de> 1.99.1-2
290- Buildrequires: gnome-doc-utils
291
292* Mon Feb 13 2006 Daniel Veillard <veillard@redhat.com> - 1.99.1-1
293- new beta release issued
294
295* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.99.0-3.2
296- bump again for double-long bug on ppc(64)
297
298* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.99.0-3.1
299- rebuilt for new gcc4.1 snapshot and glibc changes
300
301* Sat Jan 28 2006 Daniel Veillard <veillard@redhat.com> - 1.99.0-3
302- Rebuilt following a libedataserver revision
303
304* Fri Jan 27 2006 Matthias Clasen <mclasen@redhat.com> - 1.99.0-2
305- Use the upstream .desktop file
306
307* Tue Jan 24 2006 Daniel Veillard <veillard@redhat.com> - 1.99.0-1
308- initial version based on the 1.99.0 beta and gnomemeeting spec file.
Note: See TracBrowser for help on using the repository browser.