source: projects/specs/trunk/e/eigen2/eigen2-vl.spec @ 521

Revision 521, 1.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _with_check -DEIGEN_BUILD_TESTS:BOOL=ON
2
3Name:    eigen2
4Summary: A lightweight C++ template library for vector and matrix math
5Version: 2.0.9
6Release: 1%{?_dist_release}
7Group:   System Environment/Libraries
8License: GPLv2+ or LGPLv3+
9URL:     http://eigen.tuxfamily.org/
10Source0: http://bitbucket.org/eigen/eigen2/get/%{name}-%{version}.tar.bz2
11
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13BuildArch: noarch
14BuildRequires: cmake
15BuildRequires: pkgconfig
16#docs
17BuildRequires: doxygen graphviz
18
19%description
20%{summary}
21
22%package devel
23Summary: A lightweight C++ template library for vector and matrix math
24Group:   Development/Libraries
25# -devel subpkg only atm, compat with other distros
26Provides: %{name} = %{version}-%{release}
27Requires: pkgconfig
28
29%description devel
30%{summary}
31
32
33%prep
34%setup -q -n eigen2
35
36#patch50 -p1 -b .pkgconfig_noarch
37
38%build
39mkdir -p %{_target_platform}
40pushd %{_target_platform}
41%cmake ..
42popd
43
44make %{?_smp_mflags} -C %{_target_platform}
45
46# docs
47doxygen
48
49
50%install
51rm -rf $RPM_BUILD_ROOT
52make install DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
53
54# changed eigen2.pc location
55mkdir -p $RPM_BUILD_ROOT%{_datadir}/pkgconfig
56mv $RPM_BUILD_ROOT%{_libdir}/pkgconfig/eigen2.pc \
57    $RPM_BUILD_ROOT%{_datadir}/pkgconfig/eigen2.pc
58
59%clean
60rm -rf %{buildroot}
61
62
63%files devel
64%defattr(-,root,root,-)
65%doc COPYING COPYING.LESSER
66%doc html/
67%{_includedir}/eigen2
68%{_datadir}/pkgconfig/eigen2.pc
69
70%changelog
71* Thu Nov 12 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.9-1
72- new upstream release
73
74* Mon Oct 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.6-1
75- new upstream release
76
77* Sat Sep  5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.5-1
78- Initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.