source: projects/specs/trunk/e/efi-rpm-macros/efi-rpm-macros-vl.spec @ 12214

Revision 12214, 3.9 KB checked in by tomop, 5 years ago (diff)

updated 3 packages

efi-rpm-macros-4-4

efibootmgr-16-1

efivar-37-1

Line 
1%{!?_rpmmacrodir:%global _rpmmacrodir %{_sysconfdir}/rpm}
2
3Summary:        Common RPM Macros for building EFI-related packages
4Name:           efi-rpm-macros
5Version:        4
6Release:        4%{?_dist_release}
7License:        GPLv3+
8URL:            https://github.com/rhboot/%{name}/
9BuildRequires:  git sed
10BuildArch:      noarch
11
12Vendor:         Project Vine
13Distribution:   Vine Linux
14Packager:       tomop
15
16Source0:        https://github.com/rhboot/%{name}/releases/download/%{version}/%{name}-%{version}.tar.bz2
17
18%global debug_package %{nil}
19%global _efi_vendor_ %(eval echo $(sed -n -e 's/\"//g' -e 's/^ID=//p' /etc/os-release))
20
21%description
22%{name} provides a set of RPM macros for use in EFI-related packages.
23
24%package -n efi-srpm-macros
25Summary: Common SRPM Macros for building EFI-related packages
26BuildArch: noarch
27Requires: rpm
28
29%description -n efi-srpm-macros
30efi-srpm-macros provides a set of SRPM macros for use in EFI-related packages.
31
32%package -n efi-filesystem
33Summary: The basic directory layout for EFI machines
34BuildArch: noarch
35Requires: filesystem
36
37%description -n efi-filesystem
38The efi-filesystem package contains the basic directory layout for EFI
39machine bootloaders and tools.
40
41%prep
42%autosetup -S git -n %{name}-%{version}
43
44%global rpmbin %(bash -c "command -v rpm")
45sed -i \
46  -e 's|^RPM =.*$|RPM = "%{rpmbin}"|' \
47  -e 's|^MACRODIR =.*$|MACRODIR = "%{_rpmmacrodir}"|' \
48  Makefile
49
50git config --local --add efi.vendor "%{_efi_vendor_}"
51git config --local --add efi.esp-root /boot/efi
52git config --local --add efi.arches "x86_64 aarch64 %{arm} %{ix86}"
53
54%build
55%make_build clean all
56
57%install
58%make_install
59
60#%%files
61#%%{!?_licensedir:%%global license %%%%doc}
62#%%license LICENSE
63#%%doc README
64#%%{_rpmmacrodir}/macros.efi
65
66%files -n efi-srpm-macros
67%{!?_licensedir:%global license %%doc}
68%license LICENSE
69%doc README
70%{_rpmmacrodir}/macros.efi-srpm
71%{_rpmconfigdir}/brp-boot-efi-times
72
73%files -n efi-filesystem
74%defattr(0700,root,root,-)
75%dir /boot/efi
76%dir /boot/efi/EFI
77%dir /boot/efi/EFI/BOOT
78%dir /boot/efi/EFI/%{_efi_vendor_}
79
80%changelog
81* Thu Sep 12 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4-4
82- initial build for Vine Linux.
83
84* Wed Jul 24 2019 Fedora Release Engineering <releng@fedoraproject.org> - 4-3
85- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
86
87* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 4-2
88- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
89
90* Wed Sep 26 2018 Peter Jones <pjones@redhat.com> - 4-1
91- Provide %%{efi_build_requires} and brp-boot-efi-times
92
93* Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3-3
94- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
95
96* Fri May 04 2018 Peter Jones <pjones@redhat.com> - 3-2
97- Always provide macros for efi_arch and efi_alt_arch (and their _upper
98  variants), and make efi_has_arch and efi_has_alt_arch 0 when they will be
99  wrong.  This ensures everything can always expand when we're on a non-efi
100  architecture.
101
102* Fri May 04 2018 Peter Jones <pjones@redhat.com> - 3-1
103- Update to version 3 to try and un-break rawhide composes due to
104  ExclusiveArch constraints.
105
106* Thu May 03 2018 Peter Jones <pjones@redhat.com> - 2-6
107- Rework the macros for better srpm use.
108
109* Wed May 02 2018 Peter Jones <pjones@redhat.com> - 2-5
110- Add efi-filesystem subpackage
111
112* Wed May 02 2018 Peter Jones <pjones@redhat.com> - 2-4
113- Add %%{efi_has_alt_arch}
114
115* Tue May 01 2018 Peter Jones <pjones@redhat.com> - 2-3
116- Make an efi-srpm-macros subpackage to pull in so %%{efi} works in
117  ExclusiveArch in koji.
118
119* Tue May 01 2018 Peter Jones <pjones@redhat.com> - 2-2
120- Fix the non-efi and non-efi-alt-arch cases, hopefully.
121- Make efi-*-macros packages not be ExclusiveArch, because they need to work
122  in non-efi-arch packages.
123
124* Tue May 01 2018 Peter Jones <pjones@redhat.com> - 2-1
125- Lots of rpmlint fixups and the like.
126
127* Mon Apr 30 2018 Peter Jones <pjones@redhat.com> - 1-1
128- First shot at building it.
Note: See TracBrowser for help on using the repository browser.