source: projects/specs/trunk/e/eel2/eel2-vl.spec @ 521

Revision 521, 8.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define gtk2_version 2.14.0
2%define libgnomeui_version 2.24.0
3%define gnome_desktop_version 2.26.0
4%define gnome_menus_version 2.24.0
5%define gnome_vfs2_version 2.24.0
6%define librsvg2_version 2.14.0
7%define libxml2_version 2.5.10
8%define libart_lgpl_version 2.3.15
9
10%define po_package eel-2.0
11
12Name:      eel2
13Summary:   Eazel Extensions Library.
14Summary(ja): Eazel 拡張ライブラリ
15Version:   2.24.1
16Release:   2%{?_dist_release}
17License:   GPL
18Group:     System Environment/Libraries
19Source:    eel-%{version}.tar.bz2
20URL:       http://www.gnome.org/projects/nautilus/
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22
23BuildRequires: gtk2-devel >= %{gtk2_version}
24BuildRequires: libgnomeui-devel >= %{libgnomeui_version}
25BuildRequires: gnome-desktop-devel >= %{gnome_desktop_version}
26BuildRequires: gnome-menus-devel >= %{gnome_menus_version}
27BuildRequires: gnome-vfs2-devel >= %{gnome_vfs2_version}
28BuildRequires: librsvg2-devel >= %{librsvg2_version}
29BuildRequires: libxml2-devel >= %{libxml2_version}
30BuildRequires: libart_lgpl-devel >= %{libart_lgpl_version}
31BuildRequires: pango-devel
32BuildRequires: popt-devel
33
34%description
35Eazel Extensions Library is a collection of widgets and functions for
36use with GNOME.
37
38%package devel
39Summary: Libraries and include files for developing with Eel.
40Group: Development/Libraries
41Requires: %{name} = %{version}
42
43Requires: gtk2-devel >= %{gtk2_version}
44Requires: libgnomeui-devel >= %{libgnomeui_version}
45Requires: gnome-vfs2-devel >= %{gnome_vfs2_version}
46Requires: librsvg2-devel >= %{librsvg2_version}
47Requires: libxml2-devel >= %{libxml2_version}
48Requires: libart_lgpl-devel >= %{libart_lgpl_version}
49
50%description devel
51This package provides the necessary development libraries and include
52files to allow you to develop with Eel.
53
54%prep
55%setup -q -n eel-%{version}
56
57%build
58%configure
59
60make
61
62%install
63rm -rf $RPM_BUILD_ROOT
64%makeinstall
65
66rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
67
68%find_lang %{po_package}
69
70%clean
71rm -rf $RPM_BUILD_ROOT
72
73%post -p /sbin/ldconfig
74
75%postun -p /sbin/ldconfig
76
77%files -f %{po_package}.lang
78%defattr(-,root,root)
79%doc AUTHORS COPYING COPYING.LIB ChangeLog NEWS README
80%{_libdir}/*.so.*
81
82%files devel
83%defattr(-,root,root)
84%{_libdir}/*.so
85%{_libdir}/pkgconfig/*.pc
86%{_includedir}/eel-2
87
88%changelog
89* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-2
90- rebuild with gnome-desktop-2.26.0
91
92* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
93- new upstream release
94
95* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
96- new upstream release
97
98* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
99- new upstream release
100
101* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
102- new upstream release
103
104* Wed Jul  4 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.3-0vl1
105- new upstream release
106
107* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.0.1-0vl2
108- add BuildRequires: gnome-{desktop,menus}-devel
109
110* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
111- new upstream release
112
113* Mon Aug  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
114- new upstream release
115
116* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
117- new upstream release
118
119* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
120- new upstream release
121
122* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
123- new upstream release
124
125* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
126- new upstream release
127
128* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
129- new upstream release
130
131* Wed Aug 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
132- new upstream release
133
134* Mon May 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.1-0vl1
135- new upstream release
136
137* Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
138- remove bonobo-activation dependency
139
140* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
141- new upstream version
142
143* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
144- new upstream release
145
146* Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
147- new upstream release
148
149* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
150- new upstream release
151
152* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
153- new upstream release
154
155* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.9-0vl1
156- new upstream release
157
158* Thu Jul 10 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.4-0vl1
159- new upstream release
160
161* Thu Apr  3 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3.1-0vl1
162- new upstream release
163
164* Fri Mar 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
165- new upstream release
166
167* Sat Mar  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
168- new upstream release
169
170* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.2-0vl1
171- new upstream release
172
173* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0.1-0vl1
174- new upstream release
175
176* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
177- new upstream release
178
179* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
180- new upstream release
181
182* Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.6-0vl1
183- new upstream release
184
185* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
186- new upstream release
187
188* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
189- build for Vine Linux
190- new upstream release from gnome-2.1.4
191
192* Thu Aug 29 2002 Alexander Larsson <alexl@redhat.com>
193- Update to 2.0.6. No actual changes, just to keep versions in sync w/ nautilus
194
195* Fri Aug 23 2002 Alexander Larsson <alexl@redhat.com>
196- Update to 2.0.5, only translation changes
197
198* Wed Aug 14 2002 Alexander Larsson <alexl@redhat.com>
199- 2.0.4
200
201* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
202- 2.0.2
203
204* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
205- 2.0.1
206
207* Tue Jun 25 2002 Owen Taylor <otaylor@redhat.com>
208- Fix missing po files
209
210* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
211- 2.0.0
212- remove .so link from non-devel package
213
214* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
215- rebuild in different environment
216
217* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
218- 1.1.17
219
220* Tue May 28 2002 Havoc Pennington <hp@redhat.com>
221- rebuild with fixed rpm in build root
222
223* Tue May 28 2002 Havoc Pennington <hp@redhat.com>
224- 1.1.16.90 cvs snap to fix libpng issue
225
226* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
227- 1.1.15
228
229* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
230- 1.1.12
231
232* Mon Apr 22 2002 Alex Larsson <alexl@redhat.com>
233- Update to 1.1.11
234
235* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
236- getting really sleepy, fixed the wrong dumb typo
237
238* Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
239- 1.1.10
240- mumble, dumb typo in gail version
241
242* Thu Jan 24 2002 Havoc Pennington <hp@redhat.com>
243- rebuild in rawhide after fixing libart issue that broke build
244
245* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
246- Eel version 2 package created
247
248* Tue Oct 23 2001 Havoc Pennington <hp@redhat.com>
249- 1.0.2
250
251* Wed Aug 29 2001 Alex Larsson <alexl@redhat.com>
252- Added new font with cyrrilic glyphs from
253- ftp://ftp.gnome.ru/fonts/urw/
254- This closes #52772
255
256* Mon Aug 27 2001 Alex Larsson <alexl@redhat.com> 1.0.1-18
257- Add patch to fix #52348
258
259* Thu Aug 23 2001 Havoc Pennington <hp@redhat.com>
260- Applied patch from CVS to try fixing #51965
261
262* Wed Aug 22 2001 Havoc Pennington <hp@redhat.com>
263- Applied patch to handle multibyte chars in
264  eel_string_ellipsize - hopefully fixes #51710
265
266* Fri Aug 17 2001 Alexander Larsson <alexl@redhat.com> 1.0.1-15
267- Fixed the default font patch. It crashed on 64bit arch.
268
269* Tue Aug 14 2001 Alexander Larsson <alexl@redhat.com> 1.0.1-13
270- Fixed EelScalableFont to not keep reloading fonts
271- all the time.
272
273* Fri Aug  3 2001 Owen Taylor <otaylor@redhat.com>
274- Fix problems with EelImageChooser widget and Japanese
275
276* Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
277- Get some fixes from CVS head, one that segfaulted ia64.
278- This also moves the include file into a eel-1 dir, so that
279- it can later coexist with eel 2.0.
280
281* Tue Jul 24 2001 Owen Taylor <otaylor@redhat.com>
282- Fixes for efficiency of background drawing
283 
284* Tue Jul 24 2001 Akira TAGOH <tagoh@redhat.com> 1.0.1-7
285- fixed typo in patch. oops.
286
287* Mon Jul 23 2001 Akira TAGOH <tagoh@redhat.com> 1.0.1-6
288- fixed choose the default font with every locale.
289
290* Wed Jul 18 2001 Havoc Pennington <hp@redhat.com>
291- own some directories we didn't before
292
293* Sun Jul 08 2001 Tim Powers <timp@redhat.com>
294- cleaned up files list so that the defattr is doing something
295sensible and not leaving out the docs
296- moved changelog to the end of the specfile
297
298* Fri Jul 06 2001 Alexander Larsson <alla@redhat.com>
299- Removed docdir and cleaned up specfile a bit.
300
301* Fri Jul 06 2001 Alexander Larsson <alla@redhat.com>
302- Updated to 1.0.1
303
304* Wed May 09 2001 Jonathan Blandford <jrb@redhat.com>
305- Add to Red Hat build system
306
307* Wed Apr 04 2000 Ramiro Estrugo <ramiro@eazel.com>
308- created this thing
Note: See TracBrowser for help on using the repository browser.