source: projects/specs/trunk/e/e2tools/e2tools-vl.spec @ 3086

Revision 3086, 5.0 KB checked in by daisuke, 13 years ago (diff)

e2tools: new package, 0.0.16

Line 
1Summary:        Manipulate files in unmounted ext2/ext3 filesystems
2Summary(ja):    マウントされていない ext2/ext3 ファイルシステム内のファイルを操作するツール
3
4Name:           e2tools
5Version:        0.0.16
6Release:        1%{?_dist_release}
7
8Group:          Applications/System
9# No version specified.
10License:        GPL+
11URL:            http://home.earthlink.net/~k_sheff/sw/e2tools/
12
13Source0:        http://home.earthlink.net/~k_sheff/sw/e2tools/e2tools-0.0.16.tar.gz
14Source1:        e2tools-test.sh
15# Thank you very much for the man pages from Debian package.
16Source2:        e2cp.1
17Source3:        e2ln.1
18Source4:        e2ls.1
19Source5:        e2mkdir.1
20Source6:        e2mv.1
21Source7:        e2rm.1
22Source8:        e2tail.1
23Source9:        e2tools.7
24Patch1:         e2tools-fedora-fixes.patch
25Patch2:         e2tools-printf-lld-64bit.patch
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
28
29BuildRequires:  e2fsprogs-devel >= 1.27
30%if 0%{?fedora} >= 12
31BuildRequires:  libcom_err-devel
32%endif
33
34# For e2tools-test.sh
35BuildRequires:  e2fsprogs, diffutils
36
37
38%description
39A simple set of utilities to read, write, and manipulate files in an
40ext2/ext3 filesystem directly using the ext2fs library. This works
41
42  - without root access
43  - without the filesystem being mounted
44  - without kernel ext2/ext3 support
45
46The utilities are: e2cp e2ln e2ls e2mkdir e2mv e2rm e2tail
47
48%description -l ja
49ext2/ext3 ファイルシステム内のファイルを、ext2fs ライブラリを使って
50直接読み・書き・操作するためのシンプルなユーティリティ群です。次の
51ような特徴を持っています。
52
53 - root 権限が不要
54 - ファイルシステムのマウントが不要
55 - カーネルの ext2/ext3 サポート不要
56
57
58%prep
59%setup -q
60%patch1 -p1 -b .fedora-fixes
61%patch2 -p1 -b .printf-lld-64bit
62
63
64%build
65%configure
66%{__make} %{?_smp_mflags} CPPFLAGS="-Wall -Werror"
67
68
69%check
70# Run tests
71for e in e2ln e2ls e2mkdir e2mv e2rm e2tail; do
72    %{__ln_s} e2cp $e
73done
74sh %{SOURCE1}
75
76
77%install
78%{__rm} -rf $RPM_BUILD_ROOT
79%{__make} install DESTDIR=$RPM_BUILD_ROOT
80%{__install} -d -m 0755 $RPM_BUILD_ROOT%{_mandir}/man1/
81%{__install} -p -m 0644 \
82    %{SOURCE2} \
83    %{SOURCE3} \
84    %{SOURCE4} \
85    %{SOURCE5} \
86    %{SOURCE6} \
87    %{SOURCE7} \
88    %{SOURCE8} \
89    $RPM_BUILD_ROOT%{_mandir}/man1/
90%{__install} -d -m 0755 $RPM_BUILD_ROOT%{_mandir}/man7/
91%{__install} -p -m 0644 %{SOURCE9} $RPM_BUILD_ROOT%{_mandir}/man7/
92
93
94%clean
95%{__rm} -rf $RPM_BUILD_ROOT
96
97
98%files
99%defattr(-,root,root,-)
100%doc README COPYING ChangeLog TODO AUTHORS
101%{_bindir}/e2cp
102%{_bindir}/e2ln
103%{_bindir}/e2ls
104%{_bindir}/e2mkdir
105%{_bindir}/e2mv
106%{_bindir}/e2rm
107%{_bindir}/e2tail
108%doc %{_mandir}/man1/e2cp.1.gz
109%doc %{_mandir}/man1/e2ln.1.gz
110%doc %{_mandir}/man1/e2ls.1.gz
111%doc %{_mandir}/man1/e2mkdir.1.gz
112%doc %{_mandir}/man1/e2mv.1.gz
113%doc %{_mandir}/man1/e2rm.1.gz
114%doc %{_mandir}/man1/e2tail.1.gz
115%doc %{_mandir}/man7/e2tools.7.gz
116
117
118%changelog
119* Thu Mar 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.16-1
120- initial build for Vine Linux
121
122* Wed Feb  9 2011 Hans Ulrich Niedermann <hun@n-dimensional.de> - 0.0.16-17
123- Remove unused code parts triggering new gcc warning in f15
124
125* Wed Feb  9 2011 Hans Ulrich Niedermann <hun@n-dimensional.de> - 0.0.16-16
126- Fix CVS keyword substitution breaking our patch file
127
128* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.16-15
129- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
130
131* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.16-14
132- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
133
134* Sat Jul 18 2009 Hans Ulrich Niedermann <hun@n-dimensional.de> - 0.0.16-13
135- Add libcom_err-devel buildreq on F12 and later (e2fsprogs-devel split)
136
137* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.16-12
138- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
139
140* Thu Jul 17 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.0.16-11
141- fix license tag
142
143* Mon Feb 11 2008 Andreas Thienemann <andreas@bawue.net> - 0.0.16-10
144- Rebuild against gcc-4.3
145
146* Sun Dec  9 2007 Hans Ulrich Niedermann <hun@n-dimensional.de> - 0.0.16-9
147- Use format string macro from inttypes.h and uint64_t (#349851).
148
149* Sat Dec  8 2007 Hans Ulrich Niedermann <hun@n-dimensional.de> - 0.0.16-8
150- Special __u64 formatstring on 64bit platforms (#349851).
151- Reintroduce -Werror for all platforms.
152- Install man pages without x bit.
153
154* Sat Dec  8 2007 Hans Ulrich Niedermann <hun@n-dimensional.de> - 0.0.16-6
155- Cowardly avoid compiling with -Werror on alpha.
156- Install files preserving timestamps where possible.
157- Use RPM macros for shell commands where possible.
158
159* Mon Jul 31 2006 Andreas Thienemann <andreas@bawue.net> - 0.0.16-5
160- fix broken cast in rm.c:248 (exhibited on x86_64, but buggy everywhere) from Hans Ulrich Niedermann
161
162* Mon Jul 17 2006 Andreas Thienemann <andreas@bawue.net> - 0.0.16-4
163- Introduced %%check
164
165* Mon Jul 17 2006 Hans Ulrich Niedermann <hun@n-dimensional.de> - 0.0.16-3
166- initial package for fedora extras
167
Note: See TracBrowser for help on using the repository browser.