source: projects/specs/trunk/e/e2fsprogs/e2fsprogs-vl.spec @ 521

Revision 521, 16.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define _root_sbindir   /sbin
3%define _root_libdir    /%{_lib}
4
5Summary:     Utilities for managing ext2/3/4 filesystem.
6Summary(ja): ext2/3/4 ファイルシステム操作ユーティリティ
7Name:        e2fsprogs
8Version:     1.41.10
9Release:     1%{?_dist_release}
10License:     GPL
11Group:       System Environment/Base
12Url:         http://e2fsprogs.sourceforge.net/
13Source0:     ftp://download.sourceforge.net/pub/sourceforge/%{name}/%{name}-%{version}.tar.gz
14Source1:     ext2_types-wrapper.h
15
16Patch2:      e2fsprogs-1.40.4-sb_feature_check_ignore.patch
17
18BuildRoot:   %{_tmppath}/%{name}-%{version}-root
19
20BuildRequires: gettext, texinfo
21BuildRequires: pkgconfig, device-mapper-devel, gawk
22BuildRequires: libblkid-devel
23BuildRequires: libuuid-devel
24
25Requires(post): /sbin/install-info
26Requires(postun): /sbin/install-info
27Requires(post): chkconfig
28Requires(pre): shadow-utils
29
30%description
31The e2fsprogs package contains a number of utilities for creating,
32checking, modifying, and correcting any inconsistencies in ext2/3/4
33filesystems. E2fsprogs contains e2fsck (used to repair filesystem
34inconsistencies after an unclean shutdown), mke2fs (used to
35initialize a partition to contain an empty ext2/3/4 filesystem),
36debugfs (used to examine the internal structure of a filesystem, to
37manually repair a corrupted filesystem, or to create test cases for
38e2fsck), tune2fs (used to modify filesystem parameters), and most of
39the other core ext2fs filesystem utilities.
40
41You should install the e2fsprogs package if you need to manage the
42performance of an ext2/3/4 filesystem.
43
44%description -l ja
45e2fsprogs パッケージには,ファイルシステムの作成/チェック/変更/修正など,
46ext2/3/4 ファイルシステムに対する様々な操作を行うユーティリティが収めら
47れています.e2fsck(正しくアンマウントされずにシャットダウンされた等して
48破損したファイルシステムの不整合を修正する),mke2fs (パーティションを初
49期化してまっさらの ext2 ファイルシステムを作成する),debugfs(ファイルシ
50ステムの内部構造を直接参照して破損したファイルシステムを手で直したり
51e2fsck のテストケースを作りだしたりするのに使う),tune2fs(ファイルシス
52テムのパラメータを修正するのに使う)等,その他 ext2 ファイルシステム用基
53本ユーティリティが収められています.
54
55ext2/3/4 ファイルシステムのパフォーマンスをきちんと把握しておく為にも
56e2fsprogs パッケージを是非インストールしておきましょう.
57
58
59%package devel
60Summary:     Ext2/3/4 filesystem-specific static libraries and headers.
61Summary(ja): ext2/3/4 ファイルシステム特有のライブラリとヘッダ
62Group:       Development/Libraries
63Requires:    e2fsprogs = %{version}
64Prereq:      install-info
65
66
67%description devel
68E2fsprogs-devel contains the libraries and header files needed to
69develop ext2/3/4 filesystem-specific programs.
70
71%description devel -l ja
72e2fsprogs-devel には ext2/3/4 ファイルシステム固有のプログラムを開発する
73のに必要なライブラリとヘッダファイルが収められています.
74
75
76## to build compat32 for x86_64 architecture support
77%package -n compat32-%{name}
78Summary:     Utilities for managing ext2/3/4 filesystem.
79Group:       System Environment/Base
80%description -n compat32-%{name}
81The e2fsprogs package contains a number of utilities for creating,
82checking, modifying, and correcting any inconsistencies in ext2/3/4
83filesystems. E2fsprogs contains e2fsck (used to repair filesystem
84inconsistencies after an unclean shutdown), mke2fs (used to initialize
85a partition to contain an empty ext2 filesystem), debugfs (used to
86examine the internal structure of a filesystem, to manually repair
87a corrupted filesystem, or to create test cases for e2fsck),
88tune2fs (used to modify filesystem parameters), and most of the
89other core ext2fs filesystem utilities.
90
91You should install the e2fsprogs package if you need to manage the
92performance of an ext2/3/4 filesystem.
93
94%package -n compat32-%{name}-devel
95Summary:     Ext2/3/4 filesystem-specific static libraries and headers.
96Group:       Development/Libraries
97Requires:    compat32-%{name} = %{version}
98%description -n compat32-%{name}-devel
99E2fsprogs-devel contains the libraries and header files needed to
100develop second extended (ext2) filesystem-specific programs.
101
102You should install e2fsprogs-devel if you want to develop ext2
103filesystem-specific programs. If you install e2fsprogs-devel, you'll
104also want to install e2fsprogs.
105
106
107%prep
108%setup -q -n e2fsprogs-%{version}
109
110# ignore some flag differences on primary/backup sb feature checks
111# mildly unsafe but 'til I get something better, avoid full fsck
112# after an selinux install...
113%patch2 -p1 -b .featurecheck
114
115%build
116%configure --enable-elf-shlibs --enable-nls --disable-uuidd --disable-fsck \
117           --disable-e2initrd-helper --disable-libblkid --disable-libuuid
118make -C po update-po
119make %{?_smp_mflags}
120
121
122%install
123rm -rf $RPM_BUILD_ROOT
124export PATH=/sbin:$PATH
125
126make install install-libs DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -p" \
127        root_sbindir=%{_root_sbindir} root_libdir=%{_root_libdir}
128
129chmod 644 $RPM_BUILD_ROOT%{_libdir}/*.a
130
131%ifarch %{multilib_arches}
132mv -f %{buildroot}%{_includedir}/ext2fs/ext2_types.h \
133      %{buildroot}%{_includedir}/ext2fs/ext2_types-%{_arch}.h
134install -p -m 644 %{SOURCE1} %{buildroot}%{_includedir}/ext2fs/ext2_types.h
135%endif
136
137%find_lang %{name}
138
139
140%clean
141rm -rf $RPM_BUILD_ROOT
142
143%post -p /sbin/ldconfig
144%postun -p /sbin/ldconfig
145
146%post devel
147/sbin/install-info %{_infodir}/libext2fs.info.gz %{_infodir}/dir || :
148
149%preun devel
150if [ $1 = 0 ]; then
151   /sbin/install-info --delete %{_infodir}/libext2fs.info.gz %{_infodir}/dir || :
152fi
153exit 0
154
155%post -n compat32-%{name} -p /sbin/ldconfig
156%postun -n compat32-%{name} -p /sbin/ldconfig
157
158
159%files -f %{name}.lang
160%defattr(-,root,root)
161%doc README RELEASE-NOTES
162%config(noreplace) %{_sysconfdir}/mke2fs.conf
163%{_root_sbindir}/badblocks
164%{_root_sbindir}/debugfs
165%{_root_sbindir}/dumpe2fs
166%{_root_sbindir}/e2fsck
167%{_root_sbindir}/e2image
168%{_root_sbindir}/e2label
169%{_root_sbindir}/e2undo
170%{_root_sbindir}/fsck.ext2
171%{_root_sbindir}/fsck.ext3
172%{_root_sbindir}/fsck.ext4
173%{_root_sbindir}/fsck.ext4dev
174%{_root_sbindir}/logsave
175%{_root_sbindir}/mke2fs
176%{_root_sbindir}/mkfs.ext2
177%{_root_sbindir}/mkfs.ext3
178%{_root_sbindir}/mkfs.ext4
179%{_root_sbindir}/mkfs.ext4dev
180%{_root_sbindir}/resize2fs
181%{_root_sbindir}/tune2fs
182%{_sbindir}/filefrag
183%{_sbindir}/e2freefrag
184%{_sbindir}/mklost+found
185
186%{_root_libdir}/libcom_err.so.*
187%{_root_libdir}/libe2p.so.*
188%{_root_libdir}/libext2fs.so.*
189%{_root_libdir}/libss.so.*
190
191%{_bindir}/chattr
192%{_bindir}/lsattr
193
194%{_mandir}/man1/chattr.1*
195%{_mandir}/man1/lsattr.1*
196
197%{_mandir}/man5/e2fsck.conf.5*
198%{_mandir}/man5/mke2fs.conf.5*
199
200%{_mandir}/man8/badblocks.8*
201%{_mandir}/man8/debugfs.8*
202%{_mandir}/man8/dumpe2fs.8*
203%{_mandir}/man8/e2fsck.8*
204%{_mandir}/man8/e2undo.8*
205%{_mandir}/man8/filefrag.8*
206%{_mandir}/man8/e2freefrag.8*
207%{_mandir}/man8/fsck.ext2.8*
208%{_mandir}/man8/fsck.ext3.8*
209%{_mandir}/man8/fsck.ext4.8*
210%{_mandir}/man8/fsck.ext4dev.8*
211%{_mandir}/man8/e2image.8*
212%{_mandir}/man8/e2label.8*
213%{_mandir}/man8/logsave.8*
214%{_mandir}/man8/mke2fs.8*
215%{_mandir}/man8/mkfs.ext2.8*
216%{_mandir}/man8/mkfs.ext3.8*
217%{_mandir}/man8/mkfs.ext4.8*
218%{_mandir}/man8/mkfs.ext4dev.8*
219%{_mandir}/man8/mklost+found.8*
220%{_mandir}/man8/resize2fs.8*
221%{_mandir}/man8/tune2fs.8*
222     
223
224%files devel
225%defattr(-,root,root)
226%{_infodir}/libext2fs.info*
227%{_bindir}/compile_et
228%{_bindir}/mk_cmds
229
230%{_libdir}/libcom_err.a
231%{_libdir}/libcom_err.so
232%{_libdir}/libe2p.a
233%{_libdir}/libe2p.so
234%{_libdir}/libext2fs.a
235%{_libdir}/libext2fs.so
236%{_libdir}/libss.a
237%{_libdir}/libss.so
238%{_libdir}/pkgconfig/*.pc
239
240%{_datadir}/et
241%{_datadir}/ss
242%{_includedir}/e2p
243%{_includedir}/et
244%{_includedir}/ext2fs
245%{_includedir}/ss
246%{_mandir}/man1/compile_et.1*
247%{_mandir}/man1/mk_cmds.1*
248%{_mandir}/man3/com_err.3*
249
250
251%if %{build_compat32}
252%files -n compat32-%{name}
253%defattr(-,root,root)
254%{_root_libdir}/libcom_err.so.*
255%{_root_libdir}/libe2p.so.*
256%{_root_libdir}/libext2fs.so.*
257%{_root_libdir}/libss.so.*
258
259%files -n compat32-%{name}-devel
260%defattr(-,root,root)
261%{_libdir}/libcom_err.a
262%{_libdir}/libcom_err.so
263%{_libdir}/libe2p.a
264%{_libdir}/libe2p.so
265%{_libdir}/libext2fs.a
266%{_libdir}/libext2fs.so
267%{_libdir}/libss.a
268%{_libdir}/libss.so
269%{_libdir}/pkgconfig/*.pc
270%endif
271
272
273%changelog
274* Sun Feb 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.41.10-1
275- new upstream release
276
277* Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.41.9-1
278- new upstream release
279- disable libuuid/uuidd/libblkid/fsck (replaced by util-linux-ng)
280
281* Thu Jan 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.41.4-1
282- new upstream release
283
284* Sat Jan 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.41.3-2
285- add Requires(pre): shadow-utils
286- add Requires(post): chkconfig
287
288* Tue Oct 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.41.3-1
289- new upstream release
290
291* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.41.1-1
292- new upstream release
293- drop patch5 (merged in upstream)
294
295* Sun Aug 17 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.41.0-1
296- new upstream release
297- drop patch4 (included in upstream)
298- add e2undo and some ext4 related files in %%files section
299- add patch5 to fix "mount -l" segmentation fault
300
301* Fri Jul 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.40.10-1
302- new upstream release
303
304* Mon Apr 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.40.9-1
305- new upstream release
306
307* Fri Apr 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.40.8-1
308- new upstream release
309- drop unneeded patches
310- update fedora patches
311
312* Sat Dec 22 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.40.2-0vl3
313- removed %%if !%%{build_compat32} case condition
314
315* Mon Dec 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.40.2-0vl2
316- add Patch100 for CVE-2007-5497 (see also <BTS:316>)
317
318* Sun Dec 09 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.40.2-0vl1
319- new upstream release
320- import fedora patches
321- drop ext2resize(ext2online), online resize is now supported by resize2fs
322
323* Thu Mar 09 2006 Shu KONNO <owa@bg.wakwak.com> 1.38-2vl2
324- rebuilt for x86_64 architecture support
325- added compat32-* packages for x86_64
326
327* Sun Dec 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.38-2vl1
328- new upstream release based on Fedora package
329  * Thu Nov 10 2005 Thomas Woerner <twoerner@redhat.com> 1.38-2.1
330  - fixed file conflicts between 32bit and 64bit packages (#168815)
331  - fixed mklost+found crashes with buffer overflow (#157773)
332    Thanks to Arjan van de Ven for the patch
333  * Thu Sep  8 2005 Thomas Woerner <twoerner@redhat.com> 1.38-1
334  - Close File descriptor for unregognized devices (#159878)
335    Thanks to David Milburn for the patch.
336    Merged from RHEL-4
337  - enable tune2fs to set and clear feature resize_inode (#167816)
338  - removed outdated information from ext2online man page (#164383)
339  * Mon Sep  5 2005 Karel Zak <kzak@redhat.com> - 1.37-5
340  - fix swsuspend partition detection (#165863)
341  - fix revalidate from ext2 to ext3 (#162927)
342  - fix vfat without magic detection (#161873)
343  * Wed Sep  1 2004 Stephen C. Tweedie <sct@redhat.com> 1.35-9.4
344  - Build and package ext2online during the e2fsprogs build
345
346* Fri Jun 25 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.35-0vl2
347- import Patch7 from fedora package to fix 'check after next mount'
348  for filesystems with maximum mount count -1
349
350* Sun Apr 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.35-0vl1
351- new upstream release
352
353* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.34-0vl1
354- new upstream release
355
356* Sat May 24 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.33-2vl1
357- syncd with rawhide
358
359* Wed Nov 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.32-0vl1
360- new upstream release
361
362* Sun Sep 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.29-0vl1
363- new upstream release 1.29
364
365* Tue Mar 12 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.27-0vl1
366- updated to new upstream bugfix release 1.27
367  (the fix associated with Patch10 has been merged)
368- added missing man pages
369
370* Tue Mar 05 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.26-0vl2
371- added Patch10 (upstream fix)
372
373* Thu Feb 14 2002 Toru Sagami <sagami@vinelinux.org> 1.26-0vl1
374- updated to current release 1.26 with minor spec fixes
375
376* Sun Oct 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.25-0vl1
377- updated to newest 1.25 release
378
379* Fri Aug 31 2001 Toru Sagami <sagami@vinelinux.org>
380- 1.24-0vl1: updated to 1.24
381
382* Thu Aug 16 2001 <sagami@vinelinux.org>
383- 1.23-0vl1: updated to 1.23 and added e2image files
384
385* Fri Jul 13 2001 <sagami@vinelinux.org>
386- 1.22-0vl1: updated to 1.22
387
388* Sun Jun 17 2001 <sagami@vinelinux.org>
389- 1.21-0vl1: updated to 1.21
390
391* Sun Jun 10 2001 <sagami@vinelinux.org>
392- 1.20-0vl1: updated to 1.20
393
394* Sat May 19 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
395- 1.19-4vl2
396- added Japanese summary and description
397- revamp spec file
398
399* Wed May 09 2001 <sagami@vinelinux.org>
400- 1.19-4vl1: in sync with RH 1.19-4
401  * added some documant entries in %doc
402
403* Fri Apr 06 2001 Florian La Roche <Florian.LaRoche@redhat.de>
404- add further IDE and SCSI disks to a hardcoded list in fsck #34190
405
406* Tue Feb 27 2001 Florian La Roche <Florian.LaRoche@redhat.de>
407- require the main rpm from the devel rpm
408
409* Thu Feb 22 2001 Helge Deller <hdeller@redhat.de>
410- fix fsck -A bug (#21242)
411
412* Mon Feb 12 2001 Florian La Roche <Florian.LaRoche@redhat.de>
413- fix bug with 16 byte long labels #27071
414
415* Mon Sep 11 2000 Jeff Johnson <jbj@redhat.com>
416- build for Red Hat 7.1.
417
418* Tue Aug  8 2000 Jeff Johnson <jbj@redhat.com>
419- merge LABEL patch.
420- update to 1.19.
421
422* Tue Jul 25 2000 Erik Troan <ewt@redhat.com>
423- fixed LABEL handling
424
425* Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
426- rebuild to cope with glibc locale binary incompatibility
427
428* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
429- automatic rebuild
430
431* Mon Jun 26 2000 Matt Wilson <msw@redhat.com>
432- added resize2fs from the WIP snapshot
433
434* Thu Jun 15 2000 Matt Wilson <msw@redhat.com>
435- patched to build against linux 2.4 headers
436
437* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
438- FHS packaging.
439
440* Fri Apr 28 2000 Bill Nottingham <notting@redhat.com>
441- fix for ia64
442
443* Sat Feb  5 2000 Bill Nottingham <notting@redhat.com>
444- add install-info scripts
445
446* Thu Feb 03 2000 Elliot Lee <sopwith@redhat.com>
447- Fix bug #8585 (Y2K problems in debugfs)
448
449* Wed Feb 02 2000 Jakub Jelinek <jakub@redhat.com>
450- allow multiline errors in et, so that other programs
451  can use compile_et (from Kerberos)
452
453* Thu Jan 13 2000 Jeff Johnson <jbj@redhat.com>
454- build 1.18 for 6.2.
455
456* Tue Oct 26 1999 Bill Nottingham <notting@redhat.com>
457- update to 1.17
458
459* Mon Oct 25 1999 Bill Nottingham <notting@redhat.com>
460- update to 1.16
461
462* Thu Oct 21 1999 Bill Nottingham <notting@redhat.com>
463- add patch to fix SIGUSR1 kills.
464
465* Mon Oct 04 1999 Cristian Gafton <gafton@redhat.com>
466- rebuild against new glibc in the sparc tree
467
468* Thu Sep 23 1999 Jakub Jelinek <jakub@redhat.com>
469- update mke2fs man page so that it reflects changes in mke2fs
470  netweem 1.14 and 1.15
471
472* Thu Aug  5 1999 Bill Nottingham <notting@redhat.com>
473- fix lsattr on alpha
474
475* Thu Jul 29 1999 Jeff Johnson <jbj@redhat.com>
476- update to 1.15.
477
478* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
479- auto rebuild in the new build environment (release 4)
480
481* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
482- fix fsck segfault
483
484* Tue Feb  2 1999 Jeff Johnson <jbj@redhat.com>
485- update to 1.14
486- use %configure to generate config.sub on arm
487
488* Thu Jan 14 1999 Jeff Johnson <jbj@redhat.com>
489- fix /usr/bin/compile_et and doco for com_err.h (#673)
490
491* Thu Jan 07 1999 Cristian Gafton <gafton@redhat.com>
492- build with prefix=/usr
493- add arm patch
494
495* Mon Dec 28 1998 Jeff Johnson  <jbj@redhat.com>
496- update to 1.13.
497
498* Fri Aug 28 1998 Jeff Johnson <jbj@redhat.com>
499- recompile statically linked binary for 5.2/sparc
500
501* Mon Jul 13 1998 Jeff Johnson <jbj@redhat.com>
502- upgrade to 1.12.
503
504* Thu May 07 1998 Prospector System <bugs@redhat.com>
505- translations modified for de, fr, tr
506
507* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
508- include <asm/types.h> to match kernel types in utils
509
510* Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
511- spec file cleanups
512
513* Wed Oct 01 1997 Erik Troan <ewt@redhat.com>
514- fixed broken llseek() prototype
515
516* Wed Aug 20 1997 Erik Troan <ewt@redhat.com>
517- added patch to prototype llseek
518
519* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
520- built against glibc
Note: See TracBrowser for help on using the repository browser.