source: projects/specs/trunk/e/e2fsprogs/e2fsprogs-vl.spec @ 12478

Revision 12478, 17.3 KB checked in by tomop, 4 years ago (diff)

updated 9 packages

apache2-2.4.46-1

appstream-data-7-2

apr-util-1.6.1-2

apr-1.7.0-2

e2fsprogs-1.45.6-1

gnome-calculator-3.36.0-1

golang-1.15-1

tmux-3.1b-1

valgrind-3.16.1-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define _root_sbindir   /sbin
3%define _root_libdir    /%{_lib}
4
5Summary:        Utilities for managing ext2/3/4 filesystem.
6Summary(ja):    ext2/3/4 ファイルシステム操作ユーティリティ
7Name:           e2fsprogs
8Version:        1.45.6
9Release:        1%{?_dist_release}
10Group:          admin-tools,system
11Vendor:         Project Vine
12Distribution:   Vine Linux
13
14License:        GPL
15URL:            http://e2fsprogs.sourceforge.net/
16Source0:        https://mirrors.edge.kernel.org/pub/linux/kernel/people/tytso/e2fsprogs/v%{version}/%{name}-%{version}.tar.xz
17Source1:        ext2_types-wrapper.h
18
19Patch2:         e2fsprogs-1.40.4-sb_feature_check_ignore.patch
20
21BuildRoot:      %{_tmppath}/%{name}-%{version}-root
22
23BuildRequires: gettext, texinfo
24BuildRequires: pkgconfig, device-mapper-devel, gawk
25BuildRequires: libblkid-devel
26BuildRequires: libuuid-devel
27
28Requires(post): /sbin/install-info
29Requires(postun): /sbin/install-info
30Requires(post): chkconfig
31Requires(pre): shadow-utils
32
33%description
34The e2fsprogs package contains a number of utilities for creating,
35checking, modifying, and correcting any inconsistencies in ext2/3/4
36filesystems. E2fsprogs contains e2fsck (used to repair filesystem
37inconsistencies after an unclean shutdown), mke2fs (used to
38initialize a partition to contain an empty ext2/3/4 filesystem),
39debugfs (used to examine the internal structure of a filesystem, to
40manually repair a corrupted filesystem, or to create test cases for
41e2fsck), tune2fs (used to modify filesystem parameters), and most of
42the other core ext2fs filesystem utilities.
43
44You should install the e2fsprogs package if you need to manage the
45performance of an ext2/3/4 filesystem.
46
47%description -l ja
48e2fsprogs パッケージには,ファイルシステムの作成/チェック/変更/修正など,
49ext2/3/4 ファイルシステムに対する様々な操作を行うユーティリティが収めら
50れています.e2fsck(正しくアンマウントされずにシャットダウンされた等して
51破損したファイルシステムの不整合を修正する),mke2fs (パーティションを初
52期化してまっさらの ext2 ファイルシステムを作成する),debugfs(ファイルシ
53ステムの内部構造を直接参照して破損したファイルシステムを手で直したり
54e2fsck のテストケースを作りだしたりするのに使う),tune2fs(ファイルシス
55テムのパラメータを修正するのに使う)等,その他 ext2 ファイルシステム用基
56本ユーティリティが収められています.
57
58ext2/3/4 ファイルシステムのパフォーマンスをきちんと把握しておく為にも
59e2fsprogs パッケージを是非インストールしておきましょう.
60
61
62%package devel
63Summary:     Ext2/3/4 filesystem-specific static libraries and headers.
64Summary(ja): ext2/3/4 ファイルシステム特有のライブラリとヘッダ
65Group:       programming
66Requires:    e2fsprogs = %{version}
67Requires(post): install-info
68
69%description devel
70E2fsprogs-devel contains the libraries and header files needed to
71develop ext2/3/4 filesystem-specific programs.
72
73%description devel -l ja
74e2fsprogs-devel には ext2/3/4 ファイルシステム固有のプログラムを開発する
75のに必要なライブラリとヘッダファイルが収められています.
76
77
78## to build compat32 for x86_64 architecture support
79%package -n compat32-%{name}
80Summary:     Utilities for managing ext2/3/4 filesystem.
81Group:       system
82%description -n compat32-%{name}
83The e2fsprogs package contains a number of utilities for creating,
84checking, modifying, and correcting any inconsistencies in ext2/3/4
85filesystems. E2fsprogs contains e2fsck (used to repair filesystem
86inconsistencies after an unclean shutdown), mke2fs (used to initialize
87a partition to contain an empty ext2 filesystem), debugfs (used to
88examine the internal structure of a filesystem, to manually repair
89a corrupted filesystem, or to create test cases for e2fsck),
90tune2fs (used to modify filesystem parameters), and most of the
91other core ext2fs filesystem utilities.
92
93You should install the e2fsprogs package if you need to manage the
94performance of an ext2/3/4 filesystem.
95
96
97%package -n compat32-%{name}-devel
98Summary:     Ext2/3/4 filesystem-specific static libraries and headers.
99Group:       programming
100Requires:    compat32-%{name} = %{version}
101%description -n compat32-%{name}-devel
102E2fsprogs-devel contains the libraries and header files needed to
103develop second extended (ext2) filesystem-specific programs.
104
105You should install e2fsprogs-devel if you want to develop ext2
106filesystem-specific programs. If you install e2fsprogs-devel, you'll
107also want to install e2fsprogs.
108
109
110%prep
111%setup -q -n e2fsprogs-%{version}
112
113# ignore some flag differences on primary/backup sb feature checks
114# mildly unsafe but 'til I get something better, avoid full fsck
115# after an selinux install...
116%patch2 -p1 -b .featurecheck
117
118%build
119%configure --enable-elf-shlibs --enable-nls --disable-uuidd --disable-fsck \
120           --disable-e2initrd-helper --disable-libblkid --disable-libuuid \
121           --enable-quota
122make %{?_smp_mflags}
123
124
125%install
126rm -rf $RPM_BUILD_ROOT
127export PATH=/sbin:$PATH
128
129make install install-libs DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -p" \
130        root_sbindir=%{_root_sbindir} root_libdir=%{_root_libdir}
131
132chmod 644 $RPM_BUILD_ROOT%{_libdir}/*.a
133
134%ifarch %{multilib_arches}
135mv -f %{buildroot}%{_includedir}/ext2fs/ext2_types.h \
136      %{buildroot}%{_includedir}/ext2fs/ext2_types-%{_arch}.h
137install -p -m 644 %{SOURCE1} %{buildroot}%{_includedir}/ext2fs/ext2_types.h
138%endif
139
140%find_lang %{name}
141
142
143%clean
144rm -rf $RPM_BUILD_ROOT
145
146%post -p /sbin/ldconfig
147%postun -p /sbin/ldconfig
148
149%post devel
150/sbin/install-info %{_infodir}/libext2fs.info.gz %{_infodir}/dir || :
151
152%preun devel
153if [ $1 = 0 ]; then
154   /sbin/install-info --delete %{_infodir}/libext2fs.info.gz %{_infodir}/dir || :
155fi
156exit 0
157
158%post -n compat32-%{name} -p /sbin/ldconfig
159%postun -n compat32-%{name} -p /sbin/ldconfig
160
161
162%files -f %{name}.lang
163%defattr(-,root,root)
164%doc README RELEASE-NOTES
165%config(noreplace) %{_sysconfdir}/e2scrub.conf
166%config(noreplace) %{_sysconfdir}/mke2fs.conf
167
168%{_root_sbindir}/badblocks
169%{_root_sbindir}/debugfs
170%{_root_sbindir}/dumpe2fs
171%{_root_sbindir}/e2fsck
172%{_root_sbindir}/e2image
173%{_root_sbindir}/e2label
174%{_root_sbindir}/e2mmpstatus
175%{_root_sbindir}/e2scrub
176%{_root_sbindir}/e2scrub_all
177%{_root_sbindir}/e2undo
178%{_root_sbindir}/fsck.ext2
179%{_root_sbindir}/fsck.ext3
180%{_root_sbindir}/fsck.ext4
181%{_root_sbindir}/logsave
182%{_root_sbindir}/mke2fs
183%{_root_sbindir}/mkfs.ext2
184%{_root_sbindir}/mkfs.ext3
185%{_root_sbindir}/mkfs.ext4
186%{_root_sbindir}/resize2fs
187%{_root_sbindir}/tune2fs
188%{_sbindir}/filefrag
189%{_sbindir}/e2freefrag
190%{_sbindir}/e4crypt
191%{_sbindir}/e4defrag
192%{_sbindir}/mklost+found
193
194%{_root_libdir}/libcom_err.so.*
195%{_root_libdir}/libe2p.so.*
196%{_root_libdir}/libext2fs.so.*
197%{_root_libdir}/libss.so.*
198
199%{_bindir}/chattr
200%{_bindir}/lsattr
201
202%{_mandir}/man1/chattr.1*
203%{_mandir}/man1/lsattr.1*
204
205%{_mandir}/man5/e2fsck.conf.5*
206%{_mandir}/man5/ext2.5.gz
207%{_mandir}/man5/ext3.5.gz
208%{_mandir}/man5/ext4.5.gz
209%{_mandir}/man5/mke2fs.conf.5*
210
211%{_mandir}/man8/badblocks.8*
212%{_mandir}/man8/debugfs.8*
213%{_mandir}/man8/dumpe2fs.8*
214%{_mandir}/man8/e2fsck.8*
215%{_mandir}/man8/e2undo.8*
216%{_mandir}/man8/filefrag.8*
217%{_mandir}/man8/e2freefrag.8*
218%{_mandir}/man8/fsck.ext2.8*
219%{_mandir}/man8/fsck.ext3.8*
220%{_mandir}/man8/fsck.ext4.8*
221%{_mandir}/man8/e2image.8*
222%{_mandir}/man8/e2label.8*
223%{_mandir}/man8/e2mmpstatus.8.gz
224%{_mandir}/man8/e2scrub.8.gz
225%{_mandir}/man8/e2scrub_all.8.gz
226%{_mandir}/man8/e4crypt.8.gz
227%{_mandir}/man8/e4defrag.8*
228%{_mandir}/man8/logsave.8*
229%{_mandir}/man8/mke2fs.8*
230%{_mandir}/man8/mkfs.ext2.8*
231%{_mandir}/man8/mkfs.ext3.8*
232%{_mandir}/man8/mkfs.ext4.8*
233%{_mandir}/man8/mklost+found.8*
234%{_mandir}/man8/resize2fs.8*
235%{_mandir}/man8/tune2fs.8*
236     
237
238%files devel
239%defattr(-,root,root)
240%{_infodir}/libext2fs.info*
241%{_bindir}/compile_et
242%{_bindir}/mk_cmds
243
244%{_libdir}/libcom_err.a
245%{_libdir}/libcom_err.so
246%{_libdir}/libe2p.a
247%{_libdir}/libe2p.so
248%{_libdir}/libext2fs.a
249%{_libdir}/libext2fs.so
250%{_libdir}/libss.a
251%{_libdir}/libss.so
252%{_libdir}/pkgconfig/*.pc
253
254%{_datadir}/et
255%{_datadir}/ss
256%{_includedir}/e2p
257%{_includedir}/et
258%{_includedir}/com_err.h
259%{_includedir}/ext2fs
260%{_includedir}/ss
261%{_mandir}/man1/compile_et.1*
262%{_mandir}/man1/mk_cmds.1*
263%{_mandir}/man3/com_err.3*
264
265
266%if %{build_compat32}
267%files -n compat32-%{name}
268%defattr(-,root,root)
269%{_root_libdir}/libcom_err.so.*
270%{_root_libdir}/libe2p.so.*
271%{_root_libdir}/libext2fs.so.*
272%{_root_libdir}/libss.so.*
273
274%files -n compat32-%{name}-devel
275%defattr(-,root,root)
276%{_libdir}/libcom_err.so
277%{_libdir}/libe2p.so
278%{_libdir}/libext2fs.so
279%{_libdir}/libss.so
280#{_libdir}/pkgconfig/*.pc
281%endif
282
283
284%changelog
285* Tue Aug 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.45.6-1
286- new upstream release.
287
288* Wed Feb 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.45.5-1
289- new upstream release.
290
291* Fri Oct 25 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.45.4-1
292- new upstream release.
293
294* Wed Jul 16 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.42.11-1
295- new upstream release
296- remove static lib and pkgconfig file from compat32-e2fsprogs-devel
297
298* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.42.6-1
299- new upstream reelase
300
301* Thu Jan 12 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.42-1
302- new upstram release
303
304* Wed Mar 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.41.14-1
305- new upstream release
306
307* Fri Oct 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.41.10-2
308- rebuilt with rpm-4.8.1 for pkg-config
309
310* Sun Feb 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.41.10-1
311- new upstream release
312
313* Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.41.9-1
314- new upstream release
315- disable libuuid/uuidd/libblkid/fsck (replaced by util-linux-ng)
316
317* Thu Jan 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.41.4-1
318- new upstream release
319
320* Sat Jan 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.41.3-2
321- add Requires(pre): shadow-utils
322- add Requires(post): chkconfig
323
324* Tue Oct 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.41.3-1
325- new upstream release
326
327* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.41.1-1
328- new upstream release
329- drop patch5 (merged in upstream)
330
331* Sun Aug 17 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.41.0-1
332- new upstream release
333- drop patch4 (included in upstream)
334- add e2undo and some ext4 related files in %%files section
335- add patch5 to fix "mount -l" segmentation fault
336
337* Fri Jul 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.40.10-1
338- new upstream release
339
340* Mon Apr 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.40.9-1
341- new upstream release
342
343* Fri Apr 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.40.8-1
344- new upstream release
345- drop unneeded patches
346- update fedora patches
347
348* Sat Dec 22 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.40.2-0vl3
349- removed %%if !%%{build_compat32} case condition
350
351* Mon Dec 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.40.2-0vl2
352- add Patch100 for CVE-2007-5497 (see also <BTS:316>)
353
354* Sun Dec 09 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.40.2-0vl1
355- new upstream release
356- import fedora patches
357- drop ext2resize(ext2online), online resize is now supported by resize2fs
358
359* Thu Mar 09 2006 Shu KONNO <owa@bg.wakwak.com> 1.38-2vl2
360- rebuilt for x86_64 architecture support
361- added compat32-* packages for x86_64
362
363* Sun Dec 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.38-2vl1
364- new upstream release based on Fedora package
365  * Thu Nov 10 2005 Thomas Woerner <twoerner@redhat.com> 1.38-2.1
366  - fixed file conflicts between 32bit and 64bit packages (#168815)
367  - fixed mklost+found crashes with buffer overflow (#157773)
368    Thanks to Arjan van de Ven for the patch
369  * Thu Sep  8 2005 Thomas Woerner <twoerner@redhat.com> 1.38-1
370  - Close File descriptor for unregognized devices (#159878)
371    Thanks to David Milburn for the patch.
372    Merged from RHEL-4
373  - enable tune2fs to set and clear feature resize_inode (#167816)
374  - removed outdated information from ext2online man page (#164383)
375  * Mon Sep  5 2005 Karel Zak <kzak@redhat.com> - 1.37-5
376  - fix swsuspend partition detection (#165863)
377  - fix revalidate from ext2 to ext3 (#162927)
378  - fix vfat without magic detection (#161873)
379  * Wed Sep  1 2004 Stephen C. Tweedie <sct@redhat.com> 1.35-9.4
380  - Build and package ext2online during the e2fsprogs build
381
382* Fri Jun 25 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.35-0vl2
383- import Patch7 from fedora package to fix 'check after next mount'
384  for filesystems with maximum mount count -1
385
386* Sun Apr 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.35-0vl1
387- new upstream release
388
389* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.34-0vl1
390- new upstream release
391
392* Sat May 24 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.33-2vl1
393- syncd with rawhide
394
395* Wed Nov 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.32-0vl1
396- new upstream release
397
398* Sun Sep 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.29-0vl1
399- new upstream release 1.29
400
401* Tue Mar 12 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.27-0vl1
402- updated to new upstream bugfix release 1.27
403  (the fix associated with Patch10 has been merged)
404- added missing man pages
405
406* Tue Mar 05 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.26-0vl2
407- added Patch10 (upstream fix)
408
409* Thu Feb 14 2002 Toru Sagami <sagami@vinelinux.org> 1.26-0vl1
410- updated to current release 1.26 with minor spec fixes
411
412* Sun Oct 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.25-0vl1
413- updated to newest 1.25 release
414
415* Fri Aug 31 2001 Toru Sagami <sagami@vinelinux.org>
416- 1.24-0vl1: updated to 1.24
417
418* Thu Aug 16 2001 <sagami@vinelinux.org>
419- 1.23-0vl1: updated to 1.23 and added e2image files
420
421* Fri Jul 13 2001 <sagami@vinelinux.org>
422- 1.22-0vl1: updated to 1.22
423
424* Sun Jun 17 2001 <sagami@vinelinux.org>
425- 1.21-0vl1: updated to 1.21
426
427* Sun Jun 10 2001 <sagami@vinelinux.org>
428- 1.20-0vl1: updated to 1.20
429
430* Sat May 19 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
431- 1.19-4vl2
432- added Japanese summary and description
433- revamp spec file
434
435* Wed May 09 2001 <sagami@vinelinux.org>
436- 1.19-4vl1: in sync with RH 1.19-4
437  * added some documant entries in %doc
438
439* Fri Apr 06 2001 Florian La Roche <Florian.LaRoche@redhat.de>
440- add further IDE and SCSI disks to a hardcoded list in fsck #34190
441
442* Tue Feb 27 2001 Florian La Roche <Florian.LaRoche@redhat.de>
443- require the main rpm from the devel rpm
444
445* Thu Feb 22 2001 Helge Deller <hdeller@redhat.de>
446- fix fsck -A bug (#21242)
447
448* Mon Feb 12 2001 Florian La Roche <Florian.LaRoche@redhat.de>
449- fix bug with 16 byte long labels #27071
450
451* Mon Sep 11 2000 Jeff Johnson <jbj@redhat.com>
452- build for Red Hat 7.1.
453
454* Tue Aug  8 2000 Jeff Johnson <jbj@redhat.com>
455- merge LABEL patch.
456- update to 1.19.
457
458* Tue Jul 25 2000 Erik Troan <ewt@redhat.com>
459- fixed LABEL handling
460
461* Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
462- rebuild to cope with glibc locale binary incompatibility
463
464* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
465- automatic rebuild
466
467* Mon Jun 26 2000 Matt Wilson <msw@redhat.com>
468- added resize2fs from the WIP snapshot
469
470* Thu Jun 15 2000 Matt Wilson <msw@redhat.com>
471- patched to build against linux 2.4 headers
472
473* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
474- FHS packaging.
475
476* Fri Apr 28 2000 Bill Nottingham <notting@redhat.com>
477- fix for ia64
478
479* Sat Feb  5 2000 Bill Nottingham <notting@redhat.com>
480- add install-info scripts
481
482* Thu Feb 03 2000 Elliot Lee <sopwith@redhat.com>
483- Fix bug #8585 (Y2K problems in debugfs)
484
485* Wed Feb 02 2000 Jakub Jelinek <jakub@redhat.com>
486- allow multiline errors in et, so that other programs
487  can use compile_et (from Kerberos)
488
489* Thu Jan 13 2000 Jeff Johnson <jbj@redhat.com>
490- build 1.18 for 6.2.
491
492* Tue Oct 26 1999 Bill Nottingham <notting@redhat.com>
493- update to 1.17
494
495* Mon Oct 25 1999 Bill Nottingham <notting@redhat.com>
496- update to 1.16
497
498* Thu Oct 21 1999 Bill Nottingham <notting@redhat.com>
499- add patch to fix SIGUSR1 kills.
500
501* Mon Oct 04 1999 Cristian Gafton <gafton@redhat.com>
502- rebuild against new glibc in the sparc tree
503
504* Thu Sep 23 1999 Jakub Jelinek <jakub@redhat.com>
505- update mke2fs man page so that it reflects changes in mke2fs
506  netweem 1.14 and 1.15
507
508* Thu Aug  5 1999 Bill Nottingham <notting@redhat.com>
509- fix lsattr on alpha
510
511* Thu Jul 29 1999 Jeff Johnson <jbj@redhat.com>
512- update to 1.15.
513
514* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
515- auto rebuild in the new build environment (release 4)
516
517* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
518- fix fsck segfault
519
520* Tue Feb  2 1999 Jeff Johnson <jbj@redhat.com>
521- update to 1.14
522- use %configure to generate config.sub on arm
523
524* Thu Jan 14 1999 Jeff Johnson <jbj@redhat.com>
525- fix /usr/bin/compile_et and doco for com_err.h (#673)
526
527* Thu Jan 07 1999 Cristian Gafton <gafton@redhat.com>
528- build with prefix=/usr
529- add arm patch
530
531* Mon Dec 28 1998 Jeff Johnson  <jbj@redhat.com>
532- update to 1.13.
533
534* Fri Aug 28 1998 Jeff Johnson <jbj@redhat.com>
535- recompile statically linked binary for 5.2/sparc
536
537* Mon Jul 13 1998 Jeff Johnson <jbj@redhat.com>
538- upgrade to 1.12.
539
540* Thu May 07 1998 Prospector System <bugs@redhat.com>
541- translations modified for de, fr, tr
542
543* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
544- include <asm/types.h> to match kernel types in utils
545
546* Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
547- spec file cleanups
548
549* Wed Oct 01 1997 Erik Troan <ewt@redhat.com>
550- fixed broken llseek() prototype
551
552* Wed Aug 20 1997 Erik Troan <ewt@redhat.com>
553- added patch to prototype llseek
554
555* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
556- built against glibc
Note: See TracBrowser for help on using the repository browser.