source: projects/specs/trunk/d/dvdrtools/dvdrtools-vl.spec @ 521

Revision 521, 4.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

RevLine 
[521]1Summary: A collection of CD/DVD utilities.
2Summary(ja): CD/DVD ¥æ¡¼¥Æ¥£¥ê¥Æ¥£¥³¥ì¥¯¥·¥ç¥ó
3Name: dvdrtools
4Version: 0.1.5
5Release: 0vl1
6License: GPL
7Group: Applications/System
8Source: %{name}-%{version}.tar.bz2
9Patch1: dvdrtools-0.1.2-O_EXCL.patch
10Patch2: dvdrtools-0.1.4-video.patch
11
12URL: http://www.freesoftware.fsf.org/dvdrtools/
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14
15%description
16dvdrtools is a collection of CD/DVD utilities.
17
18%package -n dvdrecord
19Summary: A command line CD/DVD recording program.
20Group: Applications/Archiving
21
22%description -n dvdrecord
23Dvdrecord is an application for creating audio and data CDs and DVDs.
24Dvdrecord works with many different brands of CD/DVD recorders, fully supports
25multi-sessions and provides human-readable error messages.
26
27%package -n mkisofs
28Summary: Creates an image of an ISO9660 filesystem.
29Group: Applications/System
30Obsoletes: cdrecord-mkisofs
31
32%description -n mkisofs
33The mkisofs program is used as a pre-mastering program; i.e., it
34generates the ISO9660 filesystem.  Mkisofs takes a snapshot of
35a given directory tree and generates a binary image of the tree
36which will correspond to an ISO9660 filesystem when written to
37a block device.  Mkisofs is used for writing CD-ROMs, and includes
38support for creating bootable El Torito CD-ROMs.
39
40Install the mkisofs package if you need a program for writing
41CD-ROMs.
42
43%package -n cdda2wav
44Group: Applications/Multimedia
45Summary: A utility for sampling/copying .wav files from digital audio CDs.
46Obsoletes: cdrecord-cdda2wav
47
48%description -n cdda2wav
49Cdda2wav is a sampling utility for CD-ROM drives that are capable of
50providing a CD's audio data in digital form to your host. Audio data
51read from the CD can be saved as .wav or .sun format sound files.
52Recording formats include stereo/mono, 8/12/16 bits and different
53rates.  Cdda2wav can also be used as a CD player.
54
55%prep
56%setup -q
57%patch1 -p1 -b .excl
58%patch2 -p1 -b .video
59autoconf
60%configure
61
62%build
63make
64
65%install
66rm -rf "$RPM_BUILD_ROOT"
67make install DESTDIR="$RPM_BUILD_ROOT"
68# FIXME: remove once automake works correctly and doesn't mess with
69# filenames
70# KH: fixed it. Should work now in both cases
71files=`/bin/ls -1 $RPM_BUILD_ROOT%{_bindir}/*-*-*-*` 2>/dev/null ||:
72  for i in $files; do
73        mv $i $RPM_BUILD_ROOT%{_bindir}/`echo $i |sed -e "s,.*-,,"`
74  done
75files=`/bin/ls -1 $RPM_BUILD_ROOT%{_mandir}/man1/*-*-*-*` 2>/dev/null ||:
76  for i in $files; do
77        mv $i $RPM_BUILD_ROOT%{_mandir}/man1/`echo $i |sed -e "s,.*-,,"`
78  done
79ln -s dvdrecord $RPM_BUILD_ROOT%{_bindir}/cdrecord
80
81# remove unpackaged files from the buildroot
82rm -f $RPM_BUILD_ROOT%{_bindir}/{cdda2mp3,cdda2ogg,cdda2wav,devdump,isodump,isoinfo,isovfy,mkisofs,readcd}
83rm -rf $RPM_BUILD_ROOT%{_mandir}/man8
84rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{cdda2wav.1,readcd.1}*
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89%files -n dvdrecord
90%defattr(-,root,root)
91%doc ChangeLog NEWS AUTHORS README*
92%{_bindir}/dvdrecord
93%{_bindir}/dvdgen
94%{_bindir}/ifogen
95%{_bindir}/makecd
96#%{_bindir}/tocgen
97
98%if 0
99%{_bindir}/cdrecord
100%{_bindir}/readcd
101%{_bindir}/devdump
102%{_mandir}/man1/readcd.1*
103%endif
104%{_mandir}/man1/dvdrecord.1*
105
106%if 0
107%files -n mkisofs
108%defattr(-,root,root)
109%doc mkisofs/ChangeLog
110%doc mkisofs/README*
111%{_bindir}/*iso*
112%{_mandir}/man8/*iso*.8*
113
114%files -n cdda2wav
115%defattr(-,root,root)
116%doc cdda2wav/FAQ cdda2wav/OtherProgs
117%doc cdda2wav/README* cdda2wav/Frontends cdda2wav/HOWTOUSE
118%{_bindir}/cdda2*
119%{_mandir}/man1/cdda2wav.1*
120%endif
121
122%changelog
123* Sun Jun 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.5-0vl1
124- build for Vine Linux
125- new upstream release
126
127* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
128- rebuilt
129
130* Mon May 26 2003 Harald Hoyer <harald@redhat.de> 0.1.4-1
131- version 0.1.4
132
133* Tue May 13 2003 Harald Hoyer <harald@redhat.de> 0.1.2-12
134- refined O_EXCL patch, nonroot sg handling
135
136* Mon May 12 2003 Harald Hoyer <harald@redhat.de> 0.1.2-11
137- refined O_EXCL patch, nonroot sg handling
138
139* Wed Feb 26 2003 Harald Hoyer <harald@redhat.de> 0.1.2-10
140- refined O_EXCL patch
141
142* Tue Feb 25 2003 Harald Hoyer <harald@redhat.de> 0.1.2-9
143- refined O_EXCL patch
144
145* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
146- rebuilt
147
148* Thu Nov 28 2002 Harald Hoyer <harald@redhat.de> 0.1.2-7
149- dvdrtools-0.1.2-O_EXCL.patch added
150
151* Wed Nov 27 2002 Tim Powers <timp@redhat.com> 0.1.2-6
152- remove unpackaged files from the buildroot
153
154* Mon Oct  7 2002 Mike A. Harris <mharris@redhat.com> 0.1.2-5
155- All-arch rebuild
156
157* Thu Aug 08 2002 Karsten Hopp <karsten@redhat.de>
158- fixed automake workaround. Should work now even if automake behaves as
159  intended
160
161* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
162- automated rebuild
163
164* Thu May 23 2002 Tim Powers <timp@redhat.com>
165- automated rebuild
166
167* Thu Mar 14 2002 Bernhard Rosenkraenzer <bero@redhat.com> 0.1.2-1
168- initial build for Red Hat Linux; disable cdda2wav and mkisofs
169  and readcd because we're getting them from cdrtools for now.
Note: See TracBrowser for help on using the repository browser.