source: projects/specs/trunk/d/dump/dump-vl.spec @ 521

Revision 521, 14.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _sbindir /sbin
2# XXX --enable-kerberos         needs krcmd
3%define myoptions --enable-largefile --with-binmode=6755 --with-manowner=root --with-mangrp=root --with-manmode=0644 --with-dumpdates="%{_sysconfdir}/dumpdates" --enable-readline
4
5Summary: Programs for backing up and restoring ext2/ext3 filesystems.
6Summary(ja): ext2/ext3 ファイルシステムをバックアップ/リストアするプログラム
7Name: dump
8Version: 0.4b41
9Release: 2%{?_dist_release}
10License: BSD
11Group: Applications/Archiving
12URL: http://dump.sourceforge.net
13Source: dump-%{version}.tar.gz
14Patch1: dump-dmfix.patch
15#Patch2: dump-immutable.patch
16#Patch3: dump-0.4b41-libtinfo.patch
17
18
19BuildRoot: %{_tmppath}/%{name}-root
20
21BuildPrereq: libtermcap-devel
22BuildPrereq: e2fsprogs-devel >= 1.18, readline-devel >= 4.1
23BuildPrereq: zlib-devel, device-mapper-devel
24# This Prereq is now required because we only ship static binaries, and
25# need to ensure the "disk" group is created before installation (#60461)
26Prereq: setup
27Requires: rmt
28Obsoletes: dump-static
29#Provides: dump-static
30
31Packager: daisuke, kazutaka
32
33%description
34The dump package contains both dump and restore. Dump examines files
35in a filesystem, determines which ones need to be backed up, and
36copies those files to a specified disk, tape, or other storage medium.
37The restore command performs the inverse function of dump; it can
38restore a full backup of a filesystem. Subsequent incremental backups
39can then be layered on top of the full backup. Single files and
40directory subtrees may also be restored from full or partial backups.
41
42Install dump if you need a system for both backing up filesystems and
43restoring filesystems after backups.
44
45%description -l ja
46dump パッケージは dump と restore の両方を含んでいます。dump はファイル
47システム上のファイルを検査し、どれがバックアップが必要が特定し、指定し
48たディスク、テープ、あるいはその他のバックアップ用メディアにファイルを
49コピーします。
50restore コマンドは dump とは反対の処理を行います。restore コマンドを使
51うとファイルシステムのフルバックアップを復元できます。またフルバックアッ
52プからの増分バックアップを適用することもできます。フルバックアップ、ま
53たは部分パックアップから、単一のファイルやディレクトリのサブツリーだけ
54を復元することもできます。
55
56もしファイルシステムのフルバックアップや復元が必要な場合は、dump をイン
57ストールしてください。
58
59%package -n rmt
60Summary: Provides certain programs with access to remote tape devices.
61Summary(ja): リモートテープ装置のアクセスに必要なプログラム
62Group: Applications/Archiving
63
64%description -n rmt
65The rmt utility provides remote access to tape devices for programs
66like dump (a filesystem backup program), restore (a program for
67restoring files from a backup), and tar (an archiving program).
68
69%description -n rmt -l ja
70rmt ユーティリティは、dump (ファイルシステムのバックアップ)や restore
71(バックアップからの復元)、tar (アーカイブの作成/展開) といったプログラ
72ムに、テープ装置へのリモートアクセスを提供します。
73
74%prep
75%setup -q
76%patch1 -p1 -b .dmfix
77#%patch2 -p1 -b .orig
78#%patch3 -p1 -b .libtinfo
79
80
81%build
82%configure %{myoptions} --disable-static --enable-rmt
83
84%ifarch alpha
85RPM_OPT_FLAGS=""
86%endif
87make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes \
88                         -Wmissing-prototypes -Wno-char-subscripts "
89
90
91%install
92rm -rf %{buildroot}
93mkdir -p %{buildroot}%{_sbindir}
94mkdir -p %{buildroot}%{_mandir}/man8
95
96%makeinstall SBINDIR=%{buildroot}%{_sbindir} BINDIR=%{buildroot}%{_sbindir} MANDIR=%{buildroot}%{_mandir}/man8 BINOWNER=$(id -un) BINGRP=$(id -gn) MANOWNER=$(id -un) MANGRP=$(id -gn)
97
98pushd $RPM_BUILD_ROOT
99  ln -sf dump .%{_sbindir}/rdump
100#  ln -sf dump .%{_sbindir}/rdump.static
101#  ln -sf dump .%{_sbindir}/dump.static
102  ln -sf restore .%{_sbindir}/rrestore
103#  ln -sf restore .%{_sbindir}/rrestore.static
104#  ln -sf restore .%{_sbindir}/restore.static
105  chmod ug-s .%{_sbindir}/rmt
106  mkdir -p .%{_sysconfdir}
107  > .%{_sysconfdir}/dumpdates
108  ln -sf ..%{_sbindir}/rmt .%{_sysconfdir}/rmt
109  strip $RPM_BUILD_ROOT/sbin/* $RPM_BUILD_ROOT/usr/sbin/* || :
110popd
111
112%clean
113rm -rf %{buildroot}
114
115%files
116%defattr(-,root,root)
117%doc CHANGES COPYRIGHT KNOWNBUGS MAINTAINERS README REPORTING-BUGS THANKS TODO
118%doc dump.lsm
119%attr(0664,root,disk)   %config(noreplace) %{_sysconfdir}/dumpdates
120%attr(0755,root,root)   /sbin/dump
121/sbin/rdump
122%attr(0755,root,root)   /sbin/restore
123/sbin/rrestore
124#/sbin/*.static
125%{_mandir}/man8/dump.*
126%{_mandir}/man8/rdump.*
127%{_mandir}/man8/restore.*
128%{_mandir}/man8/rrestore.*
129
130%files -n rmt
131%defattr(-,root,root)
132%attr(0755,root,root)
133%{_sbindir}/rmt
134%{_sysconfdir}/rmt
135%{_mandir}/man8/rmt.*
136
137%changelog
138* Mon Jun 22 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4b41-2
139- spec in UTF-8
140- change configure option to --disable-static
141- remove -static stuffs
142
143* Sun Apr 27 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4b41-1
144- add Patch1 based on fedora development to build with device-mapper
145- add japanese summary and description.
146- apply new versioning policy.
147
148* Sun May 13 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4b41-0vl1
149- new upstream release
150
151* Fri Oct 15 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.4b34-0vl2
152- spec file was in SJIS. fixed.
153
154* Sat Feb 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4b34-0vl1
155- new upstream release
156
157* Sun Feb  9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4b28-5vl1
158- update upstream release based on rawhide package.
159- rebuild on new environment.
160  * Fri Mar 15 2002 Toru Sagami <sagami@vinelinux.org> 0.4b22-4vl2
161  - rebuilt against fixed statically linked system libraries
162  * Sat Jul 14 2001 Toru Sagami <sagami@vinelinux.org>
163  - 0.4b22-4vl1: based on 0.4b22-4 from Rawhide
164
165* Mon Oct  7 2002 Mike A. Harris <mharris@redhat.com> 0.4b28-5
166- All-arch rebuild
167
168* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
169- automated rebuild
170
171* Sun May 26 2002 Tim Powers <timp@redhat.com>
172- automated rebuild
173
174* Tue May 21 2002 Mike A. Harris <mharris@redhat.com> 0.4b28-2
175- Updated to dump 0.4b28
176- Removed atomic_read/write patch, not needed anymore
177
178* Fri Mar  1 2002 Mike A. Harris <mharris@redhat.com> 0.4b27-3
179- BuildRequires readline-devel >= 4.2 for the rl_completion_matches function
180- Added dump-0.4b27-dump-atomic-read-write.patch to avoid namespace conflict
181  with included kernel headers.  atomic_read is a function on s390 and as
182  such, cannot be #undef'd
183
184* Thu Feb 28 2002 Mike A. Harris <mharris@redhat.com> 0.4b27-2
185- Added prereq on "setup" to ensure disk group is created prior to this
186  package being installed
187- Somehow the dump package changelog got hosed, and part of the spec file
188  regressed.  I believe it is fixed now.
189
190* Tue Feb 26 2002 Mike A. Harris <mharris@redhat.com> 0.4b27-1
191- Updated to dump 0.4b27-1
192
193* Fri Feb 22 2002 Mike A. Harris <mharris@redhat.com> 0.4b25-5
194- Bumped release up a couple notches to rebuild in rawhide
195 
196* Thu Feb 21 2002 Mike A. Harris <mharris@redhat.com> 0.4b25-1.72.0
197- Rebuilt 0.4b25 for erratum release.  Fixes various bugs that have been
198  reported in bugzilla which are logged below.  Also fixes a bug caused by
199  linking statically to a faulty system library.
200- Added Provides dump-static line
201 
202* Mon Feb 11 2002 Mike A. Harris <mharris@redhat.com> 0.4b25-3
203- Added missing zlib buildprereq
204- Rebuild in new environment
205
206* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
207- automated rebuild
208
209* Wed Nov 21 2001 Mike A. Harris <mharris@redhat.com> 0.4b25-1
210- Updated to version 0.4b25-1
211- Added homepage URL for RFE (#54601)
212- Also fixed in this release are (#21272, #52663, #56616)
213- Dropped time.h patch as it is unneeded now
214
215* Tue Nov  6 2001 Mike A. Harris <mharris@redhat.com> 0.4b22-7
216- Updated BuildPreReq to e2fsprogs-devel >= 1.18, readline-devel >= 4.1 to
217  explicitly state the minimum required deps and fix (#51900)
218
219* Sat Sep  8 2001 Trond Eivind Glomsr藷?<teg@redhat.com> 0.4b22-6
220- Kill the static subpackage - the standard binaries are now static
221  This removes /usb/sbin/*. The static versions are now in /sbin
222  (#53433)
223- Obsolete dump-static
224
225* Tue Aug 14 2001 Trond Eivind Glomsr藷?<teg@redhat.com> 0.4b22-5
226- Move non-static binaries to /usr/sbin (#49520)
227
228* Fri Jun 29 2001 Mike A. Harris <mharris@redhat.com> 0.4b22-4
229- Added BuildPrereq: readline-devel (#44734 - which was reopened and changed)
230
231* Sat Jun 16 2001 Mike A. Harris <mharris@redhat.com> 0.4b22-3
232- Added BuildPrereq: libtermcap-devel (#44734)
233
234* Tue Jun 12 2001 Mike A. Harris <mharris@redhat.com> 0.4b22-2
235- Removed release tag from buildroot dirname - messy.
236- Broke all lines over multiple lines for readability in specfile.
237- Added --enable-largefile configure flags
238
239* Mon Jun 11 2001 Florian La Roche <Florian.LaRoche@redhat.de> 0.4b22-1
240- 0.4b22
241
242* Mon May  7 2001 Mike A. Harris <mharris@redhat.com> 0.4b21-5
243- Added BuildPrereq: e2fsprogs-devel (#27428)
244
245* Mon Apr  9 2001 Bill Nottingham <notting@redhat.com>
246- fix ia64
247
248* Wed Feb 14 2001 Bill Nottingham <notting@redhat.com>
249- fix build with current glibc
250
251* Mon Jan 29 2001 Nalin Dahyabhai <nalin@redhat.com>
252- change copyright: UCB to License: BSD
253
254* Fri Jan 26 2001 Nalin Dahyabhai <nalin@redhat.com>
255- update to 0.4b21.
256
257* Sun Nov 26 2000 Jeff Johnson <jbj@redhat.com>
258- update to 0.4b20.
259
260* Fri Nov 10 2000 Stelian Pop <pop@cybercable.fr>
261- dump 0.4b20 released, first packaging.
262
263* Tue Oct 31 2000 Jeff Johnson <jbj@redhat.com>
264- remove setuid bits for Red Hat 5.x errata.
265
266* Wed Aug 30 2000 Matt Wilson <msw@redhat.com>
267- rebuild to cope with glibc locale binary incompatibility, again
268
269* Wed Aug 30 2000 Preston Brown <pbrown@redhat.com>
270- fix for dumping files between 2 and 4 gigs (#16466)
271
272* Mon Aug 21 2000 Matt Wilson <msw@redhat.com>
273- don't use -O2 on alpha because of compiler ICE
274
275* Sun Aug 20 2000 Jeff Johnson <jbj@redhat.com>
276- update to 0.4b19.
277
278* Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
279- summaries from specspo.
280
281* Wed Aug 16 2000 Erik Troan <ewt@redhat.com>
282- support LABEL= in fstab
283
284* Sat Jul 22 2000 Bill Nottingham <notting@redhat.com>
285- if dump/restore aren't set(u|g)id, they don't need group tty (#12670)
286
287* Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
288- rebuild to cope with glibc locale binary incompatibility
289
290* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
291- automatic rebuild
292
293* Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
294- whoops I had dump commented out of the file list.  fixed.
295- dropped suid bits on the static binaries.
296- fix char buffer size issue (#11880)
297
298* Mon Jun 19 2000 Preston Brown <pbrown@redhat.com>
299- dropped SUID bits
300
301* Tue Jun  6 2000 Jeff Johnson <jbj@redhat.com>
302- update to 0.4b17.
303- FHS packaging.
304
305* Thu Jun  1 2000 Stelian Pop <pop@cybercable.fr>
306- dump 0.4b17 released, first packaging.
307
308* Sat Mar 11 2000 Stelian Pop <pop@cybercable.fr>
309- dump 0.4b16 released, first packaging.
310
311* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
312- use posix signal handling to preserve dump functionality with libc5.
313
314* Thu Mar  2 2000 Bill Nottingham <notting@redhat.com>
315- update to 0.4b15
316
317* Thu Feb 10 2000 Jeff Johnson <jbj@redhat.com>
318- dump -0ufB /dev/ftape 1638000 /mnt2 fails to use /mnt2 as tape device (#8036)
319
320* Thu Feb 10 2000 Stelian Pop <pop@cybercable.fr>
321- dump 0.4b14 released, first packaging.
322
323* Wed Feb  9 2000 Jeff Johnson <jbj@redhat.com>
324- compress man pages.
325
326* Thu Jan 27 2000 Jeff Johnson <jbj@redhat.com>
327- update to 0.4b13.
328
329* Fri Jan 21 2000 Stelian Pop <pop@cybercable.fr>
330- dump 0.4b13 released, first packaging.
331
332* Mon Jan 10 2000 Jeff Johnson <jbj@redhat.com.
333- update to 0.4b12.
334
335* Fri Jan 8 2000 Stelian Pop <pop@cybercable.fr>
336- dump 0.4b12 released, first packaging.
337
338* Sun Dec 5 1999 Stelian Pop <pop@cybercable.fr>
339- dump 0.4b11 released, first packaging.
340
341* Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
342- intergrate Stelian's fixes (Thanks!).
343
344* Sun Nov 21 1999 Stelian Pop <pop@cybercable.fr>
345- dump 0.4b10 released, first packaging.
346
347* Thu Nov 11 1999 Stelian Pop <pop@cybercable.fr>
348- make static versions also for rescue purposes.
349
350* Wed Nov 5 1999 Stelian Pop <pop@cybercable.fr>
351- dump 0.4b9 released, first packaging.
352
353* Wed Nov 3 1999 Stelian Pop <pop@cybercable.fr>
354- dump 0.4b8 released, first packaging.
355
356* Thu Oct 8 1999 Stelian Pop <pop@cybercable.fr>
357- dump 0.4b7 released, first packaging.
358
359* Thu Sep 30 1999 Stelian Pop <pop@cybercable.fr>
360- dump 0.4b6 released, first packaging.
361
362* Fri Sep 10 1999 Jeff Johnson <jbj@redhat.com>
363- recompile with e2fsprogs = 1.15 (#4962).
364
365* Sat Jul 31 1999 Jeff Johnson <jbj@redhat.com>
366- workaround egcs bug (#4281) that caused dump problems (#2989).
367- use sigjmp_buf, not jmp_buf (#3260).
368- invoke /etc/rmt (instead of rmt) like other unices. (#3272).
369- use glibc21 err/glob rather than the internal compatibility routines.
370- wire $(OPT) throughout Makefile's.
371- fix many printf problems, mostly lint clean.
372- merge SuSE, Debian and many OpenBSD fixes.
373
374* Thu Mar 25 1999 Jeff Johnson <jbj@redhat.com>
375- remove setuid/setgid bits from /sbin/rmt (dump/restore are OK).
376
377* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
378- auto rebuild in the new build environment (release 6)
379
380* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
381- strip binaries.
382
383* Thu Mar 18 1999 Jeff Johnson <jbj@redhat.com>
384- Fix dangling symlinks (#1551).
385
386* Wed Mar 17 1999 Michael Maher <mike@redhat.com>
387- Top O' the morning, build root's fixed for man pages. 
388
389* Fri Feb 19 1999 Preston Brown <pbrown@redhat.com>
390- upgraded to dump 0.4b4, massaged patches.
391
392* Tue Feb 02 1999 Ian A Cameron <I.A.Cameron@open.ac.uk>
393- added patch from Derrick J Brashear for traverse.c to stop bread errors
394
395* Wed Jan 20 1999 Jeff Johnson <jbj@redhat.com>
396- restore original 6755 root.tty to dump/restore, defattr did tty->root (#684).
397- mark /etc/dumpdates as noreplace.
398
399* Tue Jul 14 1998 Jeff Johnson <jbj@redhat.com>
400- add build root.
401
402* Tue May 05 1998 Prospector System <bugs@redhat.com>
403- translations modified for de, fr, tr
404
405* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
406- added a patch for resolving linux/types.h and sys/types.h conflicts
407
408* Wed Dec 31 1997 Erik Troan <ewt@redhat.com>
409- added prototype of llseek() so dump would work on large partitions
410
411* Thu Oct 30 1997 Donnie Barnes <djb@redhat.com>
412- made all symlinks relative instead of absolute
413
414* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
415- built against glibc
416
417* Thu Mar 06 1997 Michael K. Johnson <johnsonm@redhat.com>
418- Moved rmt to its own package.
419
420* Tue Feb 11 1997 Michael Fulbright <msf@redhat.com>
421- Added endian cleanups for SPARC
422
423* Fri Feb 07 1997 Michael K. Johnson <johnsonm@redhat.com>
424- Made /etc/dumpdates writeable by group disk.
Note: See TracBrowser for help on using the repository browser.