source: projects/specs/trunk/d/dump/dump-vl.spec @ 4676

Revision 4676, 14.7 KB checked in by shaolin, 13 years ago (diff)
  • dump: updated to 0.4b44
Line 
1%define _sbindir /sbin
2# XXX --enable-kerberos         needs krcmd
3%define myoptions --enable-largefile --with-binmode=6755 --with-manowner=root --with-mangrp=root --with-manmode=0644  --enable-readline
4
5Summary: Programs for backing up and restoring ext2/ext3/ext4 filesystems.
6Summary(ja): ext2/ext3/ext4 ファイルシステムをバックアップ/リストアするプログラム
7Name: dump
8Version: 0.4b44
9Release: 1%{?_dist_release}
10License: BSD
11Group: Applications/Archiving
12URL: http://dump.sourceforge.net/
13Source: dump-%{version}.tar.gz
14Patch0: dump-buildfix.patch
15
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18
19BuildRequires: libtermcap-devel
20BuildRequires: e2fsprogs-devel >= 1.18, readline-devel >= 4.2
21BuildRequires: zlib-devel, device-mapper-devel
22BuildRequires: libblkid-devel
23BuildRequires: libuuid-devel
24BuildRequires: bzip2-devel
25# This Prereq is now required because we only ship static binaries, and
26# need to ensure the "disk" group is created before installation (#60461)
27Requires(pre): setup
28Requires: rmt
29Obsoletes: dump-static
30
31Packager: daisuke, kazutaka, shaolin
32
33%description
34The dump package contains both dump and restore. Dump examines files
35in a filesystem, determines which ones need to be backed up, and
36copies those files to a specified disk, tape, or other storage medium.
37The restore command performs the inverse function of dump; it can
38restore a full backup of a filesystem. Subsequent incremental backups
39can then be layered on top of the full backup. Single files and
40directory subtrees may also be restored from full or partial backups.
41
42Install dump if you need a system for both backing up filesystems and
43restoring filesystems after backups.
44
45%description -l ja
46dump パッケージは dump と restore の両方を含んでいます。dump はファイル
47システム上のファイルを検査し、どれがバックアップが必要が特定し、指定し
48たディスク、テープ、あるいはその他のバックアップ用メディアにファイルを
49コピーします。
50restore コマンドは dump とは反対の処理を行います。restore コマンドを使
51うとファイルシステムのフルバックアップを復元できます。またフルバックアッ
52プからの増分バックアップを適用することもできます。フルバックアップ、ま
53たは部分パックアップから、単一のファイルやディレクトリのサブツリーだけ
54を復元することもできます。
55
56もしファイルシステムのフルバックアップや復元が必要な場合は、dump をイン
57ストールしてください。
58
59%package -n rmt
60Summary: Provides certain programs with access to remote tape devices.
61Summary(ja): リモートテープ装置のアクセスに必要なプログラム
62Group: Applications/Archiving
63
64%description -n rmt
65The rmt utility provides remote access to tape devices for programs
66like dump (a filesystem backup program), restore (a program for
67restoring files from a backup), and tar (an archiving program).
68
69%description -n rmt -l ja
70rmt ユーティリティは、dump (ファイルシステムのバックアップ)や restore
71(バックアップからの復元)、tar (アーカイブの作成/展開) といったプログラ
72ムに、テープ装置へのリモートアクセスを提供します。
73
74%prep
75%setup -q
76%patch0 -p1 -b .buildfix
77
78for i in THANKS MAINTAINERS COPYRIGHT CHANGES; do
79    iconv -f iso-8859-1 -t utf-8  $i -o $i.new
80    touch -r $i $i.new
81    mv $i.new $i
82done
83
84%build
85autoreconf -fiv
86%configure %{myoptions} --disable-static --enable-rmt --disable-transselinux
87
88%ifarch alpha
89RPM_OPT_FLAGS=""
90%endif
91make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes \
92                         -Wmissing-prototypes -Wno-char-subscripts "
93
94
95%install
96rm -rf %{buildroot}
97mkdir -p %{buildroot}%{_sbindir}
98mkdir -p %{buildroot}%{_mandir}/man8
99
100%makeinstall SBINDIR=%{buildroot}%{_sbindir} BINDIR=%{buildroot}%{_sbindir} MANDIR=%{buildroot}%{_mandir}/man8 BINOWNER=$(id -un) BINGRP=$(id -gn) MANOWNER=$(id -un) MANGRP=$(id -gn)
101
102pushd $RPM_BUILD_ROOT
103  ln -sf dump .%{_sbindir}/rdump
104  ln -sf restore .%{_sbindir}/rrestore
105  chmod ug-s .%{_sbindir}/rmt
106  mkdir -p .%{_sysconfdir}
107  > .%{_sysconfdir}/dumpdates
108  ln -sf ..%{_sbindir}/rmt .%{_sysconfdir}/rmt
109popd
110
111%clean
112rm -rf %{buildroot}
113
114%files
115%defattr(-,root,root)
116%doc CHANGES COPYRIGHT KNOWNBUGS MAINTAINERS README REPORTING-BUGS THANKS TODO
117%doc dump.lsm
118%attr(0664,root,disk)   %config(noreplace) %{_sysconfdir}/dumpdates
119%attr(0755,root,root)   /sbin/dump
120/sbin/rdump
121%attr(0755,root,root)   /sbin/restore
122/sbin/rrestore
123#/sbin/*.static
124%{_mandir}/man8/dump.*
125%{_mandir}/man8/rdump.*
126%{_mandir}/man8/restore.*
127%{_mandir}/man8/rrestore.*
128
129%files -n rmt
130%defattr(-,root,root)
131%attr(0755,root,root)
132%{_sbindir}/rmt
133%{_sysconfdir}/rmt
134%{_mandir}/man8/rmt.*
135
136%changelog
137* Sat Aug 27 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.4b44-1
138- updated to 0.4b44 (ext4 support in particular)
139
140* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4b41-3
141- rebuild with rpm-4.8.1
142- add BuildRequires: libblkid-devel, libuuid-devel, bzip2-devel
143
144* Mon Jun 22 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4b41-2
145- spec in UTF-8
146- change configure option to --disable-static
147- remove -static stuffs
148
149* Sun Apr 27 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4b41-1
150- add Patch1 based on fedora development to build with device-mapper
151- add japanese summary and description.
152- apply new versioning policy.
153
154* Sun May 13 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4b41-0vl1
155- new upstream release
156
157* Fri Oct 15 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.4b34-0vl2
158- spec file was in SJIS. fixed.
159
160* Sat Feb 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4b34-0vl1
161- new upstream release
162
163* Sun Feb  9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4b28-5vl1
164- update upstream release based on rawhide package.
165- rebuild on new environment.
166  * Fri Mar 15 2002 Toru Sagami <sagami@vinelinux.org> 0.4b22-4vl2
167  - rebuilt against fixed statically linked system libraries
168  * Sat Jul 14 2001 Toru Sagami <sagami@vinelinux.org>
169  - 0.4b22-4vl1: based on 0.4b22-4 from Rawhide
170
171* Mon Oct  7 2002 Mike A. Harris <mharris@redhat.com> 0.4b28-5
172- All-arch rebuild
173
174* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
175- automated rebuild
176
177* Sun May 26 2002 Tim Powers <timp@redhat.com>
178- automated rebuild
179
180* Tue May 21 2002 Mike A. Harris <mharris@redhat.com> 0.4b28-2
181- Updated to dump 0.4b28
182- Removed atomic_read/write patch, not needed anymore
183
184* Fri Mar  1 2002 Mike A. Harris <mharris@redhat.com> 0.4b27-3
185- BuildRequires readline-devel >= 4.2 for the rl_completion_matches function
186- Added dump-0.4b27-dump-atomic-read-write.patch to avoid namespace conflict
187  with included kernel headers.  atomic_read is a function on s390 and as
188  such, cannot be #undef'd
189
190* Thu Feb 28 2002 Mike A. Harris <mharris@redhat.com> 0.4b27-2
191- Added prereq on "setup" to ensure disk group is created prior to this
192  package being installed
193- Somehow the dump package changelog got hosed, and part of the spec file
194  regressed.  I believe it is fixed now.
195
196* Tue Feb 26 2002 Mike A. Harris <mharris@redhat.com> 0.4b27-1
197- Updated to dump 0.4b27-1
198
199* Fri Feb 22 2002 Mike A. Harris <mharris@redhat.com> 0.4b25-5
200- Bumped release up a couple notches to rebuild in rawhide
201 
202* Thu Feb 21 2002 Mike A. Harris <mharris@redhat.com> 0.4b25-1.72.0
203- Rebuilt 0.4b25 for erratum release.  Fixes various bugs that have been
204  reported in bugzilla which are logged below.  Also fixes a bug caused by
205  linking statically to a faulty system library.
206- Added Provides dump-static line
207 
208* Mon Feb 11 2002 Mike A. Harris <mharris@redhat.com> 0.4b25-3
209- Added missing zlib buildprereq
210- Rebuild in new environment
211
212* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
213- automated rebuild
214
215* Wed Nov 21 2001 Mike A. Harris <mharris@redhat.com> 0.4b25-1
216- Updated to version 0.4b25-1
217- Added homepage URL for RFE (#54601)
218- Also fixed in this release are (#21272, #52663, #56616)
219- Dropped time.h patch as it is unneeded now
220
221* Tue Nov  6 2001 Mike A. Harris <mharris@redhat.com> 0.4b22-7
222- Updated BuildPreReq to e2fsprogs-devel >= 1.18, readline-devel >= 4.1 to
223  explicitly state the minimum required deps and fix (#51900)
224
225* Sat Sep  8 2001 Trond Eivind Glomsr藷?<teg@redhat.com> 0.4b22-6
226- Kill the static subpackage - the standard binaries are now static
227  This removes /usb/sbin/*. The static versions are now in /sbin
228  (#53433)
229- Obsolete dump-static
230
231* Tue Aug 14 2001 Trond Eivind Glomsr藷?<teg@redhat.com> 0.4b22-5
232- Move non-static binaries to /usr/sbin (#49520)
233
234* Fri Jun 29 2001 Mike A. Harris <mharris@redhat.com> 0.4b22-4
235- Added BuildPrereq: readline-devel (#44734 - which was reopened and changed)
236
237* Sat Jun 16 2001 Mike A. Harris <mharris@redhat.com> 0.4b22-3
238- Added BuildPrereq: libtermcap-devel (#44734)
239
240* Tue Jun 12 2001 Mike A. Harris <mharris@redhat.com> 0.4b22-2
241- Removed release tag from buildroot dirname - messy.
242- Broke all lines over multiple lines for readability in specfile.
243- Added --enable-largefile configure flags
244
245* Mon Jun 11 2001 Florian La Roche <Florian.LaRoche@redhat.de> 0.4b22-1
246- 0.4b22
247
248* Mon May  7 2001 Mike A. Harris <mharris@redhat.com> 0.4b21-5
249- Added BuildPrereq: e2fsprogs-devel (#27428)
250
251* Mon Apr  9 2001 Bill Nottingham <notting@redhat.com>
252- fix ia64
253
254* Wed Feb 14 2001 Bill Nottingham <notting@redhat.com>
255- fix build with current glibc
256
257* Mon Jan 29 2001 Nalin Dahyabhai <nalin@redhat.com>
258- change copyright: UCB to License: BSD
259
260* Fri Jan 26 2001 Nalin Dahyabhai <nalin@redhat.com>
261- update to 0.4b21.
262
263* Sun Nov 26 2000 Jeff Johnson <jbj@redhat.com>
264- update to 0.4b20.
265
266* Fri Nov 10 2000 Stelian Pop <pop@cybercable.fr>
267- dump 0.4b20 released, first packaging.
268
269* Tue Oct 31 2000 Jeff Johnson <jbj@redhat.com>
270- remove setuid bits for Red Hat 5.x errata.
271
272* Wed Aug 30 2000 Matt Wilson <msw@redhat.com>
273- rebuild to cope with glibc locale binary incompatibility, again
274
275* Wed Aug 30 2000 Preston Brown <pbrown@redhat.com>
276- fix for dumping files between 2 and 4 gigs (#16466)
277
278* Mon Aug 21 2000 Matt Wilson <msw@redhat.com>
279- don't use -O2 on alpha because of compiler ICE
280
281* Sun Aug 20 2000 Jeff Johnson <jbj@redhat.com>
282- update to 0.4b19.
283
284* Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
285- summaries from specspo.
286
287* Wed Aug 16 2000 Erik Troan <ewt@redhat.com>
288- support LABEL= in fstab
289
290* Sat Jul 22 2000 Bill Nottingham <notting@redhat.com>
291- if dump/restore aren't set(u|g)id, they don't need group tty (#12670)
292
293* Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
294- rebuild to cope with glibc locale binary incompatibility
295
296* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
297- automatic rebuild
298
299* Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
300- whoops I had dump commented out of the file list.  fixed.
301- dropped suid bits on the static binaries.
302- fix char buffer size issue (#11880)
303
304* Mon Jun 19 2000 Preston Brown <pbrown@redhat.com>
305- dropped SUID bits
306
307* Tue Jun  6 2000 Jeff Johnson <jbj@redhat.com>
308- update to 0.4b17.
309- FHS packaging.
310
311* Thu Jun  1 2000 Stelian Pop <pop@cybercable.fr>
312- dump 0.4b17 released, first packaging.
313
314* Sat Mar 11 2000 Stelian Pop <pop@cybercable.fr>
315- dump 0.4b16 released, first packaging.
316
317* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
318- use posix signal handling to preserve dump functionality with libc5.
319
320* Thu Mar  2 2000 Bill Nottingham <notting@redhat.com>
321- update to 0.4b15
322
323* Thu Feb 10 2000 Jeff Johnson <jbj@redhat.com>
324- dump -0ufB /dev/ftape 1638000 /mnt2 fails to use /mnt2 as tape device (#8036)
325
326* Thu Feb 10 2000 Stelian Pop <pop@cybercable.fr>
327- dump 0.4b14 released, first packaging.
328
329* Wed Feb  9 2000 Jeff Johnson <jbj@redhat.com>
330- compress man pages.
331
332* Thu Jan 27 2000 Jeff Johnson <jbj@redhat.com>
333- update to 0.4b13.
334
335* Fri Jan 21 2000 Stelian Pop <pop@cybercable.fr>
336- dump 0.4b13 released, first packaging.
337
338* Mon Jan 10 2000 Jeff Johnson <jbj@redhat.com.
339- update to 0.4b12.
340
341* Fri Jan 8 2000 Stelian Pop <pop@cybercable.fr>
342- dump 0.4b12 released, first packaging.
343
344* Sun Dec 5 1999 Stelian Pop <pop@cybercable.fr>
345- dump 0.4b11 released, first packaging.
346
347* Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
348- intergrate Stelian's fixes (Thanks!).
349
350* Sun Nov 21 1999 Stelian Pop <pop@cybercable.fr>
351- dump 0.4b10 released, first packaging.
352
353* Thu Nov 11 1999 Stelian Pop <pop@cybercable.fr>
354- make static versions also for rescue purposes.
355
356* Wed Nov 5 1999 Stelian Pop <pop@cybercable.fr>
357- dump 0.4b9 released, first packaging.
358
359* Wed Nov 3 1999 Stelian Pop <pop@cybercable.fr>
360- dump 0.4b8 released, first packaging.
361
362* Thu Oct 8 1999 Stelian Pop <pop@cybercable.fr>
363- dump 0.4b7 released, first packaging.
364
365* Thu Sep 30 1999 Stelian Pop <pop@cybercable.fr>
366- dump 0.4b6 released, first packaging.
367
368* Fri Sep 10 1999 Jeff Johnson <jbj@redhat.com>
369- recompile with e2fsprogs = 1.15 (#4962).
370
371* Sat Jul 31 1999 Jeff Johnson <jbj@redhat.com>
372- workaround egcs bug (#4281) that caused dump problems (#2989).
373- use sigjmp_buf, not jmp_buf (#3260).
374- invoke /etc/rmt (instead of rmt) like other unices. (#3272).
375- use glibc21 err/glob rather than the internal compatibility routines.
376- wire $(OPT) throughout Makefile's.
377- fix many printf problems, mostly lint clean.
378- merge SuSE, Debian and many OpenBSD fixes.
379
380* Thu Mar 25 1999 Jeff Johnson <jbj@redhat.com>
381- remove setuid/setgid bits from /sbin/rmt (dump/restore are OK).
382
383* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
384- auto rebuild in the new build environment (release 6)
385
386* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
387- strip binaries.
388
389* Thu Mar 18 1999 Jeff Johnson <jbj@redhat.com>
390- Fix dangling symlinks (#1551).
391
392* Wed Mar 17 1999 Michael Maher <mike@redhat.com>
393- Top O' the morning, build root's fixed for man pages. 
394
395* Fri Feb 19 1999 Preston Brown <pbrown@redhat.com>
396- upgraded to dump 0.4b4, massaged patches.
397
398* Tue Feb 02 1999 Ian A Cameron <I.A.Cameron@open.ac.uk>
399- added patch from Derrick J Brashear for traverse.c to stop bread errors
400
401* Wed Jan 20 1999 Jeff Johnson <jbj@redhat.com>
402- restore original 6755 root.tty to dump/restore, defattr did tty->root (#684).
403- mark /etc/dumpdates as noreplace.
404
405* Tue Jul 14 1998 Jeff Johnson <jbj@redhat.com>
406- add build root.
407
408* Tue May 05 1998 Prospector System <bugs@redhat.com>
409- translations modified for de, fr, tr
410
411* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
412- added a patch for resolving linux/types.h and sys/types.h conflicts
413
414* Wed Dec 31 1997 Erik Troan <ewt@redhat.com>
415- added prototype of llseek() so dump would work on large partitions
416
417* Thu Oct 30 1997 Donnie Barnes <djb@redhat.com>
418- made all symlinks relative instead of absolute
419
420* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
421- built against glibc
422
423* Thu Mar 06 1997 Michael K. Johnson <johnsonm@redhat.com>
424- Moved rmt to its own package.
425
426* Tue Feb 11 1997 Michael Fulbright <msf@redhat.com>
427- Added endian cleanups for SPARC
428
429* Fri Feb 07 1997 Michael K. Johnson <johnsonm@redhat.com>
430- Made /etc/dumpdates writeable by group disk.
Note: See TracBrowser for help on using the repository browser.