source: projects/specs/trunk/d/dump/dump-vl.spec @ 8572

Revision 8572, 14.1 KB checked in by daisuke, 10 years ago (diff)

dump: remove rmt (we use star version)

Line 
1%define _sbindir /sbin
2# XXX --enable-kerberos         needs krcmd
3%define myoptions --enable-largefile --with-binmode=6755 --with-manowner=root --with-mangrp=root --with-manmode=0644  --enable-readline
4
5Summary: Programs for backing up and restoring ext2/ext3/ext4 filesystems.
6Summary(ja): ext2/ext3/ext4 ファイルシステムをバックアップ/リストアするプログラム
7Name: dump
8Version: 0.4b44
9Release: 2%{?_dist_release}
10License: BSD
11Group: Applications/Archiving
12URL: http://dump.sourceforge.net/
13Source: dump-%{version}.tar.gz
14Patch0: dump-buildfix.patch
15Patch3: dump-rmt-moved-star.patch
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18
19BuildRequires: libtermcap-devel
20BuildRequires: e2fsprogs-devel >= 1.18, readline-devel >= 4.2
21BuildRequires: zlib-devel, device-mapper-devel
22BuildRequires: libblkid-devel
23BuildRequires: libuuid-devel
24BuildRequires: bzip2-devel
25# This Prereq is now required because we only ship static binaries, and
26# need to ensure the "disk" group is created before installation (#60461)
27Requires(pre): setup
28Requires: rmt
29Obsoletes: dump-static
30
31Packager: daisuke, kazutaka, shaolin
32
33%description
34The dump package contains both dump and restore. Dump examines files
35in a filesystem, determines which ones need to be backed up, and
36copies those files to a specified disk, tape, or other storage medium.
37The restore command performs the inverse function of dump; it can
38restore a full backup of a filesystem. Subsequent incremental backups
39can then be layered on top of the full backup. Single files and
40directory subtrees may also be restored from full or partial backups.
41
42Install dump if you need a system for both backing up filesystems and
43restoring filesystems after backups.
44
45%description -l ja
46dump パッケージは dump と restore の両方を含んでいます。dump はファイル
47システム上のファイルを検査し、どれがバックアップが必要が特定し、指定し
48たディスク、テープ、あるいはその他のバックアップ用メディアにファイルを
49コピーします。
50restore コマンドは dump とは反対の処理を行います。restore コマンドを使
51うとファイルシステムのフルバックアップを復元できます。またフルバックアッ
52プからの増分バックアップを適用することもできます。フルバックアップ、ま
53たは部分パックアップから、単一のファイルやディレクトリのサブツリーだけ
54を復元することもできます。
55
56もしファイルシステムのフルバックアップや復元が必要な場合は、dump をイン
57ストールしてください。
58
59%prep
60%setup -q
61%patch0 -p1 -b .buildfix
62%patch3 -p1 -b .rmt-moved-star
63
64for i in THANKS MAINTAINERS COPYRIGHT CHANGES; do
65    iconv -f iso-8859-1 -t utf-8  $i -o $i.new
66    touch -r $i $i.new
67    mv $i.new $i
68done
69
70%build
71autoreconf -fiv
72
73export CFLAGS="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes \
74               -Wmissing-prototypes -Wno-char-subscripts -fno-strict-aliasing"
75
76%configure %{myoptions} \
77  --disable-static \
78  --enable-largefile \
79  --disable-rmt \
80  --enable-readline \
81  --disable-transselinux
82
83make %{?_smp_mflags}
84
85%install
86rm -rf %{buildroot}
87mkdir -p %{buildroot}%{_sbindir}
88mkdir -p %{buildroot}%{_mandir}/man8
89
90%makeinstall SBINDIR=%{buildroot}%{_sbindir} BINDIR=%{buildroot}%{_sbindir} MANDIR=%{buildroot}%{_mandir}/man8 BINOWNER=$(id -un) BINGRP=$(id -gn) MANOWNER=$(id -un) MANGRP=$(id -gn)
91
92pushd $RPM_BUILD_ROOT
93  ln -sf dump .%{_sbindir}/rdump
94  ln -sf restore .%{_sbindir}/rrestore
95  mkdir -p .%{_sysconfdir}
96  > .%{_sysconfdir}/dumpdates
97popd
98
99%clean
100rm -rf %{buildroot}
101
102%files
103%defattr(-,root,root)
104%doc CHANGES COPYRIGHT KNOWNBUGS MAINTAINERS README REPORTING-BUGS THANKS TODO
105%doc dump.lsm
106%attr(0664,root,disk)   %config(noreplace) %{_sysconfdir}/dumpdates
107%attr(0755,root,root)   /sbin/dump
108/sbin/rdump
109%attr(0755,root,root)   /sbin/restore
110/sbin/rrestore
111#/sbin/*.static
112%{_mandir}/man8/dump.*
113%{_mandir}/man8/rdump.*
114%{_mandir}/man8/restore.*
115%{_mandir}/man8/rrestore.*
116
117%changelog
118* Tue Jun 17 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 0.4b44-2
119- remove rmt subpackage, moved to star.
120
121* Sat Aug 27 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.4b44-1
122- updated to 0.4b44 (ext4 support in particular)
123
124* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4b41-3
125- rebuild with rpm-4.8.1
126- add BuildRequires: libblkid-devel, libuuid-devel, bzip2-devel
127
128* Mon Jun 22 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4b41-2
129- spec in UTF-8
130- change configure option to --disable-static
131- remove -static stuffs
132
133* Sun Apr 27 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4b41-1
134- add Patch1 based on fedora development to build with device-mapper
135- add japanese summary and description.
136- apply new versioning policy.
137
138* Sun May 13 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4b41-0vl1
139- new upstream release
140
141* Fri Oct 15 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.4b34-0vl2
142- spec file was in SJIS. fixed.
143
144* Sat Feb 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4b34-0vl1
145- new upstream release
146
147* Sun Feb  9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4b28-5vl1
148- update upstream release based on rawhide package.
149- rebuild on new environment.
150  * Fri Mar 15 2002 Toru Sagami <sagami@vinelinux.org> 0.4b22-4vl2
151  - rebuilt against fixed statically linked system libraries
152  * Sat Jul 14 2001 Toru Sagami <sagami@vinelinux.org>
153  - 0.4b22-4vl1: based on 0.4b22-4 from Rawhide
154
155* Mon Oct  7 2002 Mike A. Harris <mharris@redhat.com> 0.4b28-5
156- All-arch rebuild
157
158* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
159- automated rebuild
160
161* Sun May 26 2002 Tim Powers <timp@redhat.com>
162- automated rebuild
163
164* Tue May 21 2002 Mike A. Harris <mharris@redhat.com> 0.4b28-2
165- Updated to dump 0.4b28
166- Removed atomic_read/write patch, not needed anymore
167
168* Fri Mar  1 2002 Mike A. Harris <mharris@redhat.com> 0.4b27-3
169- BuildRequires readline-devel >= 4.2 for the rl_completion_matches function
170- Added dump-0.4b27-dump-atomic-read-write.patch to avoid namespace conflict
171  with included kernel headers.  atomic_read is a function on s390 and as
172  such, cannot be #undef'd
173
174* Thu Feb 28 2002 Mike A. Harris <mharris@redhat.com> 0.4b27-2
175- Added prereq on "setup" to ensure disk group is created prior to this
176  package being installed
177- Somehow the dump package changelog got hosed, and part of the spec file
178  regressed.  I believe it is fixed now.
179
180* Tue Feb 26 2002 Mike A. Harris <mharris@redhat.com> 0.4b27-1
181- Updated to dump 0.4b27-1
182
183* Fri Feb 22 2002 Mike A. Harris <mharris@redhat.com> 0.4b25-5
184- Bumped release up a couple notches to rebuild in rawhide
185 
186* Thu Feb 21 2002 Mike A. Harris <mharris@redhat.com> 0.4b25-1.72.0
187- Rebuilt 0.4b25 for erratum release.  Fixes various bugs that have been
188  reported in bugzilla which are logged below.  Also fixes a bug caused by
189  linking statically to a faulty system library.
190- Added Provides dump-static line
191 
192* Mon Feb 11 2002 Mike A. Harris <mharris@redhat.com> 0.4b25-3
193- Added missing zlib buildprereq
194- Rebuild in new environment
195
196* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
197- automated rebuild
198
199* Wed Nov 21 2001 Mike A. Harris <mharris@redhat.com> 0.4b25-1
200- Updated to version 0.4b25-1
201- Added homepage URL for RFE (#54601)
202- Also fixed in this release are (#21272, #52663, #56616)
203- Dropped time.h patch as it is unneeded now
204
205* Tue Nov  6 2001 Mike A. Harris <mharris@redhat.com> 0.4b22-7
206- Updated BuildPreReq to e2fsprogs-devel >= 1.18, readline-devel >= 4.1 to
207  explicitly state the minimum required deps and fix (#51900)
208
209* Sat Sep  8 2001 Trond Eivind Glomsr藷?<teg@redhat.com> 0.4b22-6
210- Kill the static subpackage - the standard binaries are now static
211  This removes /usb/sbin/*. The static versions are now in /sbin
212  (#53433)
213- Obsolete dump-static
214
215* Tue Aug 14 2001 Trond Eivind Glomsr藷?<teg@redhat.com> 0.4b22-5
216- Move non-static binaries to /usr/sbin (#49520)
217
218* Fri Jun 29 2001 Mike A. Harris <mharris@redhat.com> 0.4b22-4
219- Added BuildPrereq: readline-devel (#44734 - which was reopened and changed)
220
221* Sat Jun 16 2001 Mike A. Harris <mharris@redhat.com> 0.4b22-3
222- Added BuildPrereq: libtermcap-devel (#44734)
223
224* Tue Jun 12 2001 Mike A. Harris <mharris@redhat.com> 0.4b22-2
225- Removed release tag from buildroot dirname - messy.
226- Broke all lines over multiple lines for readability in specfile.
227- Added --enable-largefile configure flags
228
229* Mon Jun 11 2001 Florian La Roche <Florian.LaRoche@redhat.de> 0.4b22-1
230- 0.4b22
231
232* Mon May  7 2001 Mike A. Harris <mharris@redhat.com> 0.4b21-5
233- Added BuildPrereq: e2fsprogs-devel (#27428)
234
235* Mon Apr  9 2001 Bill Nottingham <notting@redhat.com>
236- fix ia64
237
238* Wed Feb 14 2001 Bill Nottingham <notting@redhat.com>
239- fix build with current glibc
240
241* Mon Jan 29 2001 Nalin Dahyabhai <nalin@redhat.com>
242- change copyright: UCB to License: BSD
243
244* Fri Jan 26 2001 Nalin Dahyabhai <nalin@redhat.com>
245- update to 0.4b21.
246
247* Sun Nov 26 2000 Jeff Johnson <jbj@redhat.com>
248- update to 0.4b20.
249
250* Fri Nov 10 2000 Stelian Pop <pop@cybercable.fr>
251- dump 0.4b20 released, first packaging.
252
253* Tue Oct 31 2000 Jeff Johnson <jbj@redhat.com>
254- remove setuid bits for Red Hat 5.x errata.
255
256* Wed Aug 30 2000 Matt Wilson <msw@redhat.com>
257- rebuild to cope with glibc locale binary incompatibility, again
258
259* Wed Aug 30 2000 Preston Brown <pbrown@redhat.com>
260- fix for dumping files between 2 and 4 gigs (#16466)
261
262* Mon Aug 21 2000 Matt Wilson <msw@redhat.com>
263- don't use -O2 on alpha because of compiler ICE
264
265* Sun Aug 20 2000 Jeff Johnson <jbj@redhat.com>
266- update to 0.4b19.
267
268* Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
269- summaries from specspo.
270
271* Wed Aug 16 2000 Erik Troan <ewt@redhat.com>
272- support LABEL= in fstab
273
274* Sat Jul 22 2000 Bill Nottingham <notting@redhat.com>
275- if dump/restore aren't set(u|g)id, they don't need group tty (#12670)
276
277* Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
278- rebuild to cope with glibc locale binary incompatibility
279
280* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
281- automatic rebuild
282
283* Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
284- whoops I had dump commented out of the file list.  fixed.
285- dropped suid bits on the static binaries.
286- fix char buffer size issue (#11880)
287
288* Mon Jun 19 2000 Preston Brown <pbrown@redhat.com>
289- dropped SUID bits
290
291* Tue Jun  6 2000 Jeff Johnson <jbj@redhat.com>
292- update to 0.4b17.
293- FHS packaging.
294
295* Thu Jun  1 2000 Stelian Pop <pop@cybercable.fr>
296- dump 0.4b17 released, first packaging.
297
298* Sat Mar 11 2000 Stelian Pop <pop@cybercable.fr>
299- dump 0.4b16 released, first packaging.
300
301* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
302- use posix signal handling to preserve dump functionality with libc5.
303
304* Thu Mar  2 2000 Bill Nottingham <notting@redhat.com>
305- update to 0.4b15
306
307* Thu Feb 10 2000 Jeff Johnson <jbj@redhat.com>
308- dump -0ufB /dev/ftape 1638000 /mnt2 fails to use /mnt2 as tape device (#8036)
309
310* Thu Feb 10 2000 Stelian Pop <pop@cybercable.fr>
311- dump 0.4b14 released, first packaging.
312
313* Wed Feb  9 2000 Jeff Johnson <jbj@redhat.com>
314- compress man pages.
315
316* Thu Jan 27 2000 Jeff Johnson <jbj@redhat.com>
317- update to 0.4b13.
318
319* Fri Jan 21 2000 Stelian Pop <pop@cybercable.fr>
320- dump 0.4b13 released, first packaging.
321
322* Mon Jan 10 2000 Jeff Johnson <jbj@redhat.com.
323- update to 0.4b12.
324
325* Sat Jan 8 2000 Stelian Pop <pop@cybercable.fr>
326- dump 0.4b12 released, first packaging.
327
328* Sun Dec 5 1999 Stelian Pop <pop@cybercable.fr>
329- dump 0.4b11 released, first packaging.
330
331* Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
332- intergrate Stelian's fixes (Thanks!).
333
334* Sun Nov 21 1999 Stelian Pop <pop@cybercable.fr>
335- dump 0.4b10 released, first packaging.
336
337* Thu Nov 11 1999 Stelian Pop <pop@cybercable.fr>
338- make static versions also for rescue purposes.
339
340* Fri Nov 5 1999 Stelian Pop <pop@cybercable.fr>
341- dump 0.4b9 released, first packaging.
342
343* Wed Nov 3 1999 Stelian Pop <pop@cybercable.fr>
344- dump 0.4b8 released, first packaging.
345
346* Fri Oct 8 1999 Stelian Pop <pop@cybercable.fr>
347- dump 0.4b7 released, first packaging.
348
349* Thu Sep 30 1999 Stelian Pop <pop@cybercable.fr>
350- dump 0.4b6 released, first packaging.
351
352* Fri Sep 10 1999 Jeff Johnson <jbj@redhat.com>
353- recompile with e2fsprogs = 1.15 (#4962).
354
355* Sat Jul 31 1999 Jeff Johnson <jbj@redhat.com>
356- workaround egcs bug (#4281) that caused dump problems (#2989).
357- use sigjmp_buf, not jmp_buf (#3260).
358- invoke /etc/rmt (instead of rmt) like other unices. (#3272).
359- use glibc21 err/glob rather than the internal compatibility routines.
360- wire $(OPT) throughout Makefile's.
361- fix many printf problems, mostly lint clean.
362- merge SuSE, Debian and many OpenBSD fixes.
363
364* Thu Mar 25 1999 Jeff Johnson <jbj@redhat.com>
365- remove setuid/setgid bits from /sbin/rmt (dump/restore are OK).
366
367* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
368- auto rebuild in the new build environment (release 6)
369
370* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
371- strip binaries.
372
373* Thu Mar 18 1999 Jeff Johnson <jbj@redhat.com>
374- Fix dangling symlinks (#1551).
375
376* Wed Mar 17 1999 Michael Maher <mike@redhat.com>
377- Top O' the morning, build root's fixed for man pages. 
378
379* Fri Feb 19 1999 Preston Brown <pbrown@redhat.com>
380- upgraded to dump 0.4b4, massaged patches.
381
382* Tue Feb 02 1999 Ian A Cameron <I.A.Cameron@open.ac.uk>
383- added patch from Derrick J Brashear for traverse.c to stop bread errors
384
385* Wed Jan 20 1999 Jeff Johnson <jbj@redhat.com>
386- restore original 6755 root.tty to dump/restore, defattr did tty->root (#684).
387- mark /etc/dumpdates as noreplace.
388
389* Tue Jul 14 1998 Jeff Johnson <jbj@redhat.com>
390- add build root.
391
392* Tue May 05 1998 Prospector System <bugs@redhat.com>
393- translations modified for de, fr, tr
394
395* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
396- added a patch for resolving linux/types.h and sys/types.h conflicts
397
398* Wed Dec 31 1997 Erik Troan <ewt@redhat.com>
399- added prototype of llseek() so dump would work on large partitions
400
401* Thu Oct 30 1997 Donnie Barnes <djb@redhat.com>
402- made all symlinks relative instead of absolute
403
404* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
405- built against glibc
406
407* Thu Mar 06 1997 Michael K. Johnson <johnsonm@redhat.com>
408- Moved rmt to its own package.
409
410* Tue Feb 11 1997 Michael Fulbright <msf@redhat.com>
411- Added endian cleanups for SPARC
412
413* Fri Feb 07 1997 Michael K. Johnson <johnsonm@redhat.com>
414- Made /etc/dumpdates writeable by group disk.
Note: See TracBrowser for help on using the repository browser.