source: projects/specs/trunk/d/dracd/dracd-vl.spec @ 521

Revision 521, 4.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Dynamic relay authorization control
2Name: dracd
3Version: 1.12
4Release: 2%{?_dist_release}
5License: Other
6Group: System Environment/Daemons
7Url: http://mail.cc.umanitoba.ca/drac/
8Source0: drac.tar.Z
9Source1: dracd-init.d.source
10Source2: dracd-rc.d.source
11Source3: dracd.allow-sample
12Source4: README.vine-drac
13Patch0: drac-Makefile-1.12.patch
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildPrereq: db4-devel >= 4.6.21
16Prereq: chkconfig portmap
17Requires: db4 >= 4.6.21
18
19%description
20DRAC is a daemon that dynamically updates a relay authorization map
21for sendmail. It provides a way to allow legitimate users to relay
22mail through an SMTP server, while still preventing others from using
23it as a spam relay. User's IP addresses are added to the map
24immediately after they have authenticated to the POP or IMAP
25server. By default, map entries expire after 30 minutes, but can be
26renewed by additional authentication. Periodically checking mail on a
27POP server is sufficient to do this. The POP and SMTP servers can be
28on different hosts.
29
30%prep
31%setup -q -c -n drac-1.12
32%patch0 -p0
33cp %{SOURCE4} ./README.vine
34
35%build
36make OPTFLAGS="$RPM_OPT_FLAGS -fPIC"
37
38%install
39install -d $RPM_BUILD_ROOT%{_sbindir}
40install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
41install -d $RPM_BUILD_ROOT/etc/mail
42install -d $RPM_BUILD_ROOT%{_libdir}
43install -d $RPM_BUILD_ROOT%{_mandir}/man3
44install -d $RPM_BUILD_ROOT%{_mandir}/man8
45install -m755 rpc.dracd $RPM_BUILD_ROOT%{_sbindir}
46install -m644 dracauth.3 $RPM_BUILD_ROOT%{_mandir}/man3/
47install -m644 rpc.dracd.1m $RPM_BUILD_ROOT%{_mandir}/man8/rpc.dracd.8
48install -m755 %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/dracd
49install -m755 %{SOURCE2} $RPM_BUILD_ROOT%{_sbindir}/rc.dracd
50install -m644 %{SOURCE3} $RPM_BUILD_ROOT/etc/mail/dracd.allow
51install -m644 libdrac.a $RPM_BUILD_ROOT%{_libdir}
52install -m755 testing $RPM_BUILD_ROOT%{_sbindir}/testdrac
53
54%post
55/sbin/chkconfig --add dracd
56
57%preun
58if [ $1 = 0 ] ; then
59    /sbin/chkconfig --del dracd
60fi
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65%files
66%defattr(-,root,root)
67%doc COPYRIGHT Changes INSTALL PORTING README*
68%{_sbindir}/rpc.dracd
69%{_sbindir}/rc.dracd
70%{_sbindir}/testdrac
71%{_libdir}/libdrac.a
72%{_mandir}/man3/dracauth.3*
73%{_mandir}/man8/rpc.dracd.8*
74%config /etc/rc.d/init.d/dracd
75%config(noreplace) /etc/mail/dracd.allow
76
77%changelog
78* Tue Jul  7 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.12-2
79- README.vine-drac in UTF-8
80
81* Sat Jun 21 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.12-1
82- rebuilt against db4-4.6.21
83- new versioning policy
84
85* Tue Nov 20 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.12-0vl6
86- use RPM_OPT_FLAGS and -fPIC
87
88* Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12-0vl5
89- rebuild with db4-4.3
90
91* Thu Jul 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.12-0vl4
92- changed Group to System Environment/Daemons
93
94* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.12-0vl3
95- rebuilt with db4-4.2.52
96
97* Mon Sep  6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.12-0vl2
98- fix typo on README.vine
99
100* Sat Aug 23 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.12-0vl1
101- source upgrade
102- update Patch0
103
104* Fri Aug 22 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.11-0vl6
105- update SOURCE4
106- use License tag
107
108* Fri Aug 22 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.11-0vl5
109- BuildPrereq: db4-devel and Requires: db4
110
111* Fri Aug 23 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.11-0vl4
112- add README.vine (SOURCE4)
113
114* Fri Jun 21 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.11-0vl3
115- build for Vine Linux 2.5
116- add BuildPrereq: db3-devel and Requires: db3
117
118* Tue May 28 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.11-0vl2
119- clean up spec
120
121* Thu Mar 15 2001 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp>
122- 1.11-0vl1
123
124* Thu Dec 14 2000 Kenneth Porter <shiva@well.com>
125- Add testing program to package, renamed to testdrac
126
127* Thu Nov 2 2000 Kenneth Porter <shiva@well.com>
128- Move rc.dracd out of /etc
129- Mark remaining /etc files (init file) as config
130- Return a value from init script
131- Add status to init script
132
133* Mon Oct 30 2000 Kenneth Porter <shiva@well.com>
134- Add Requires: portmap
135- Make dracd.allow a config file
136- Compressed man pages on newer RPM systems
137
138* Sat Jul 1 2000 Kenneth Porter <shiva@well.com>
139- Fix install for non-root packager
140- Remove bogus address from default client allow file.
141- Add chkconfig invocation to automatically install startup links.
142- Move libdrac.a to /usr/lib. No need for a directory of its own.
143
144* Tue Oct 26 1999 Mike McHenry <mmchen@minn.net>
145- First RPM build
Note: See TracBrowser for help on using the repository browser.