source: projects/specs/trunk/d/dpkg/dpkg-vl.spec @ 10570

Revision 10570, 8.3 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1Summary:        Package maintenance system for Debian GNU/Linux
2Summary(ja):    Debian GNU/Linux のパッケージ管理システム
3
4Name:           dpkg
5Version:        1.15.5.6
6Release:        2%{?_dist_release}
7
8Group:          System Environment/Base
9# The entire source code is GPLv2+ with exception of the following
10# lib/dpkg/md5.c, lib/dpkg/md5.h - Public domain
11# lib/dpkg/showpkg.c, dselect/methods/multicd, lib/dpkg/utils.c, lib/dpkg/showpkg.c - GPLv2
12# dselect/methods/ftp - GPL no version info
13# scripts/Dpkg/Gettext.pm - BSD
14# lib/compat/obstack.h, lib/compat/gettext.h,lib/compat/obstack.c - LGPLv2+
15License:        GPLv2 and GPLv2+ and LGPLv2+ and Public Domain and BSD
16URL:            http://packages.debian.org/unstable/admin/dpkg
17Source0:        http://ftp.debian.org/debian/pool/main/d/dpkg/%{name}_%{version}.tar.bz2
18# obtained from dpkg-source -x dpkg_1.15.5.6.dsc
19Source1:        dpkg.archtable
20# Fedora specific patch to store files under /usr/share/dpkg, not these are not binary
21# libs. and set user search path to /usr/local/share/dpkg
22Patch1:         dpkg-change-libdir-path.patch
23# Fixes CVE-2010-0396 bugzilla #572522
24Patch2:         fedora-fix-CVE-2010-0396-00.patch
25Patch3:         fedora-fix-CVE-2010-0396-01.patch
26Patch4:     fedora-bug642160-empty-argv.patch
27Patch5:         fedora-fix-CVE-2010-1679_CVE-2011-0402.patch
28BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
29BuildRequires:  zlib-devel, bzip2-devel, gettext, ncurses-devel
30
31%description
32
33This package contains the tools (including dpkg-source) required
34to unpack, build and upload Debian source packages.
35
36This package also contains the programs dpkg which used to handle the
37installation and removal of packages on a Debian system.
38
39This package also contains dselect, an interface for managing the
40installation and removal of packages on the system.
41
42dpkg and dselect will certainly be non-functional on a rpm-based system
43because packages dependencies will likely be unmet.
44
45%package devel
46Summary:  Debian package development tools
47Summary(ja):  Debian パッケージ開発ツール
48Group:    Development/System
49Requires: %{name} = %{version}-%{release}
50Requires: perl, patch, make, binutils, bzip2, lzma
51BuildArch: noarch
52
53%description devel
54This package provides the development tools (including dpkg-source).
55Required to unpack, build and upload Debian source packages
56
57
58%package -n dselect
59Summary:  Debian package management front-end
60Summary(ja):  Debian パッケージ管理フロントエンド
61Group:    System Environment/Base
62Requires: %{name} = %{version}-%{release}
63
64%description -n dselect
65dselect is a high-level interface for the installation/removal of debs .
66
67%prep
68%setup -q
69
70%patch1 -p1
71%patch2 -p1
72%patch3 -p1
73%patch4 -p1
74%patch5 -p1
75
76# Filter unwanted Requires:
77cat << \EOF > %{name}-req
78#!/bin/sh
79%{__perl_requires} $* |\
80  sed -e '/perl(Dselect::Ftp)/d' -e '/perl(extra)/d' -e '/perl(file)/d' -e '/perl(dpkg-gettext.pl)/d' -e '/perl(controllib.pl)/d' -e '/perl(in)/d'
81EOF
82
83%define __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
84chmod +x %{__perl_requires}
85
86%build
87%configure --without-start-stop-daemon \
88        --disable-linker-optimisations \
89        --with-admindir=%{_localstatedir}/lib/dpkg \
90        --libdir=%{_datadir} \
91        --with-zlib \
92        --with-bz2 \
93        --disable-silent-rules
94
95make %{?_smp_mflags}
96
97
98%install
99rm -rf $RPM_BUILD_ROOT
100make install DESTDIR=$RPM_BUILD_ROOT
101install -pm0644 %SOURCE1 $RPM_BUILD_ROOT/%{_datadir}/dpkg/archtable
102
103%find_lang dpkg
104%find_lang dpkg-dev
105%find_lang dselect
106
107# fedora has its own implementation
108rm -rf $RPM_BUILD_ROOT%{_bindir}/update-alternatives
109rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/alternatives/
110
111%clean
112rm -rf $RPM_BUILD_ROOT
113
114
115%files   -f dpkg.lang
116%defattr(-,root,root,-)
117%doc debian/changelog README AUTHORS COPYING THANKS TODO
118%dir %{_sysconfdir}/dpkg
119%{_bindir}/dpkg
120%{_bindir}/dpkg-deb
121%{_bindir}/dpkg-query
122%{_bindir}/dpkg-split
123%{_bindir}/dpkg-trigger
124%{_bindir}/dpkg-divert
125%{_bindir}/dpkg-statoverride
126%{_sbindir}/*
127%dir %{_datadir}/dpkg
128%{_datadir}/dpkg/mksplit
129%{_datadir}/dpkg/archtable
130%{_datadir}/dpkg/cputable
131%{_datadir}/dpkg/ostable
132%{_datadir}/dpkg/triplettable
133%{perl_vendorlib}/Dpkg.pm
134%dir %{perl_vendorlib}/Dpkg
135%{perl_vendorlib}/Dpkg/Gettext.pm
136%{_mandir}/man1/dpkg-deb.1.gz
137%{_mandir}/man1/dpkg-query.1.gz
138%{_mandir}/man1/dpkg-split.1.gz
139%{_mandir}/man1/dpkg-trigger.1.gz
140%{_mandir}/man1/dpkg.1.gz
141%{_mandir}/man5/dpkg.cfg.5.gz
142%{_mandir}/man8/dpkg-divert.8.gz
143%{_mandir}/man8/dpkg-statoverride.8.gz
144#fedora has own implemenation
145%exclude %{_sbindir}/install-info
146#fedora has own implemenation
147%exclude %{_mandir}/man8/update-alternatives.8.gz
148
149%files  devel -f dpkg-dev.lang
150%defattr(-,root,root,-)
151%doc doc/README.api
152%{_bindir}/dpkg-architecture
153%{_bindir}/dpkg-buildpackage
154%{_bindir}/dpkg-checkbuilddeps
155%{_bindir}/dpkg-distaddfile
156%{_bindir}/dpkg-genchanges
157%{_bindir}/dpkg-gencontrol
158%{_bindir}/dpkg-gensymbols
159%{_bindir}/dpkg-name
160%{_bindir}/dpkg-parsechangelog
161%{_bindir}/dpkg-scanpackages
162%{_bindir}/dpkg-scansources
163%{_bindir}/dpkg-shlibdeps
164%{_bindir}/dpkg-source
165%{_bindir}/dpkg-vendor
166%dir %{_datadir}/dpkg/parsechangelog
167%{_datadir}/dpkg/parsechangelog/*
168%exclude %{perl_vendorlib}/Dpkg/Gettext.pm
169%{perl_vendorlib}/Dpkg/*.pm
170%{perl_vendorlib}/Dpkg/Changelog
171%{perl_vendorlib}/Dpkg/Shlibs
172%{perl_vendorlib}/Dpkg/Source
173%{perl_vendorlib}/Dpkg/Vendor
174%{perl_vendorlib}/Dpkg/Control
175%{_mandir}/man1/dpkg-architecture.1.gz
176%{_mandir}/man1/dpkg-buildpackage.1.gz
177%{_mandir}/man1/dpkg-checkbuilddeps.1.gz
178%{_mandir}/man1/dpkg-distaddfile.1.gz
179%{_mandir}/man1/dpkg-genchanges.1.gz
180%{_mandir}/man1/dpkg-gencontrol.1.gz
181%{_mandir}/man1/dpkg-gensymbols.1.gz
182%{_mandir}/man1/dpkg-name.1.gz
183%{_mandir}/man1/dpkg-parsechangelog.1.gz
184%{_mandir}/man1/dpkg-scanpackages.1.gz
185%{_mandir}/man1/dpkg-scansources.1.gz
186%{_mandir}/man1/dpkg-shlibdeps.1.gz
187%{_mandir}/man1/dpkg-source.1.gz
188%{_mandir}/man1/dpkg-vendor.1.gz
189%{_mandir}/man5/deb-control.5.gz
190%{_mandir}/man5/deb-old.5.gz
191%{_mandir}/man5/deb-override.5.gz
192%{_mandir}/man5/deb-extra-override.5.gz
193%{_mandir}/man5/deb-shlibs.5.gz
194%{_mandir}/man5/deb-substvars.5.gz
195%{_mandir}/man5/deb-symbols.5.gz
196%{_mandir}/man5/deb-triggers.5.gz
197%{_mandir}/man5/deb-version.5.gz
198%{_mandir}/man5/deb.5.gz
199
200
201%files -n dselect -f dselect.lang
202%defattr(-,root,root,-)
203%doc dselect/methods/multicd/README.multicd dselect/methods/ftp/README.mirrors.txt
204%{_bindir}/dselect
205%{perl_vendorlib}/Debian
206%{_datadir}/dpkg/methods
207%{_mandir}/man*/dselect*.gz
208
209
210
211%changelog
212* Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.15.5.6-2
213- rebuild with gcc-5.4.0
214
215* Tue Dec 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.15.5.6-1
216- initial build for Vine Linux
217
218* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.15.5.6-7
219- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
220
221* Wed Jan 12 2011 Andrew Colin Kissa <andrew@topdog.za.net> - 1.15.5.6-6
222- Fix CVE-2010-1679
223- Fix CVE-2011-0402
224
225* Sun Oct 17 2010 Jeroen van Meeuwen <kanarip@kanarip.com> - 1.15.5.6-5
226- Apply minimal fix for rhbz #642160
227
228* Thu Mar 11 2010 Andrew Colin Kissa <andrew@topdog.za.net> - 1.15.5.6-4
229- Fix CVE-2010-0396
230
231* Mon Feb 15 2010 Andrew Colin Kissa <andrew@topdog.za.net> - 1.15.5.6-3
232- review changes
233
234* Sun Feb 14 2010 Andrew Colin Kissa <andrew@topdog.za.net> - 1.15.5.6-2
235- review changes
236
237* Sat Feb 13 2010 Andrew Colin Kissa <andrew@topdog.za.net> - 1.15.5.6-1
238- Upgrade to latest upstream
239- review changes
240
241* Tue Nov 10 2009 Andrew Colin Kissa <andrew@topdog.za.net> - 1.15.4.1-1
242- Upgrade to latest upstream
243- review changes
244
245* Tue Dec 30 2008 Leigh Scott <leigh123linux@googlemail.com> - 1.14.23-3
246- more review changes               
247
248* Mon Dec 15 2008 Leigh Scott <leigh123linux@googlemail.com> - 1.14.23-1
249- bump version and make some of the review changes
250
251* Tue Aug 19 2008 Leigh Scott <leigh123linux@googlemail.com> - 1.14.20-5
252- made changes for review
253
254* Thu Jul 31 2008 Leigh Scott <leigh123linux@googlemail.com> - 1.14.20-4
255- Change release to -4 as server refused -3
256
257* Thu Jul 31 2008 Leigh Scott <leigh123linux@googlemail.com> - 1.14.20-3
258- split the package into dkpg, dpkg-dev & dselect
259
260* Tue Jul 29 2008 Leigh Scott <leigh123linux@googlemail.com> - 1.14.20-2
261- recode man files to UTF8
262
263* Tue Jul 29 2008 Leigh Scott <leigh123linux@googlemail.com> - 1.14.20-1
264- Rebuild ans add build requires ncurses-devel
265
266* Thu Jul 19 2007 Patrice Dumas <pertusus@free.fr> - 1.14.5-1
267- initial packaging
Note: See TracBrowser for help on using the repository browser.