source: projects/specs/trunk/d/doxygen/doxygen-vl.spec @ 10570

Revision 10570, 8.5 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1# Set this to "1" if you want to build doxywizard
2%define wizard 1
3
4Summary: A documentation system for C/C++.
5Summary(ja): C/C++ 向けドキュメンテーションシステム
6Name: doxygen
7Version: 1.8.6
8Release: 2%{?_dist_release}
9Source0: ftp://ftp.stack.nl/pub/users/dimitri/%{name}-%{version}.src.tar.gz
10Patch0: doxygen-1.8.6-config.patch
11Patch1: doxygen-1.8.5-html_timestamp_default_false.patch
12Patch2: doxygen-1.8.3-multilib.patch
13
14Group: Development/Tools
15License: GPLv2
16URL: http://www.stack.nl/~dimitri/doxygen/
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: perl texlive texlive-collection-fontutils ghostscript gettext
20BuildRequires: flex bison
21%if %{wizard}
22BuildRequires: qt4-devel => 4.4
23%endif
24
25%description
26Doxygen can generate an online class browser (in HTML) and/or a
27reference manual (in LaTeX) from a set of documented source files. The
28documentation is extracted directly from the sources. Doxygen can
29also be configured to extract the code structure from undocumented
30source files.
31
32%package doxywizard
33Summary: A GUI for creating and editing configuration files.
34Group: Applications/Development
35Requires: %{name} = %{version}-%{release}
36
37%description doxywizard
38Doxywizard is a GUI for creating and editing configuration files that
39are used by doxygen.
40
41%prep
42%setup -q -n %{name}-%{version}
43%patch0 -p1 -b .config
44%patch1 -p1 -b .html_timestamp_default_false
45%patch2 -p1 -b .multilib
46
47%build
48unset QTDIR
49
50./configure \
51    --prefix %{_prefix} \
52    --shared \
53%if %{wizard}
54     --with-doxywizard \
55%endif
56     --release
57
58make %{?_smp_mflags} all
59make docs
60
61%install
62rm -rf $RPM_BUILD_ROOT
63
64make install DESTDIR=$RPM_BUILD_ROOT
65
66%if %{wizard}
67make doxywizard_install DESTDIR=$RPM_BUILD_ROOT
68%else
69rm -f $RPM_BUILD_ROOT%{_mandir}/man1/doxywizard.*
70%endif
71
72# convert into utf-8
73iconv --from=ISO-8859-1 --to=UTF-8 LANGUAGE.HOWTO > LANGUAGE.HOWTO.new
74touch -r LANGUAGE.HOWTO LANGUAGE.HOWTO.new
75mv LANGUAGE.HOWTO.new LANGUAGE.HOWTO
76
77
78%clean
79rm -rf $RPM_BUILD_ROOT
80
81%files
82%defattr(-,root,root)
83%doc LANGUAGE.HOWTO LICENSE README.md examples html
84%{_bindir}/doxygen
85%{_mandir}/man1/doxygen.*
86
87%if %{wizard}
88%files doxywizard
89%defattr(-,root,root)
90%{_bindir}/doxywizard
91%{_mandir}/man1/doxywizard.*
92%endif
93
94%changelog
95* Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.6-2
96- rebuild with gcc-5.4.0
97
98* Tue Jan 14 2014 NAKAMURA Kenta <kenta@vinelinux.org> - 1.8.6-1
99- new upstream release
100
101* Wed Nov 02 2011 NAKAMURA Kenta <kenta@vinelinux.org> - 1.7.5.1-1
102- new upstream release
103- updated Patch0 and 1
104
105* Mon Oct 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.6.1-1
106- new upstream release
107- added Patch0, 1 from Fedora
108  * Mon Aug 24 2009 Than Ngo <than@redhat.com> - 1.6.0-2
109  - fix #516339, allow to enable/disable timstamp to avoid the multilib issue
110    HTMP_TIMESTAMP is disable by default
111- enabled doxywizard
112
113* Tue Dec  9 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.7.1-1
114- new upstream release
115- disable doxywizard
116
117* Thu May 29 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.6-1
118- new upstream release
119
120* Thu Feb 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.5-0vl1
121- new upstream release
122
123* Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.2-0vl1
124- new upstream release
125
126* Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.7-0vl3
127- rebuild with libstdc++34
128
129* Sun Oct 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.7-0vl2
130- add BuildRequires: flex
131
132* Fri Sep 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.7-0vl1
133- new upstream release
134- changed doxygen-doxywizard Group to Applications/Development
135
136* Sat Aug 05 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.4.5-0vl2
137- added doxygen-1.4.5-libdir.patch for x86_64 and ppc64 archtecture
138
139* Tue Nov 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.5-0vl1
140- new upstream release
141
142* Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.4-0vl1
143- new upstream release
144- update Requires
145
146* Wed Jun  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.3-0vl2
147- build for VineSeed
148
149* Wed Jun  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.3-0vl1
150- new upstream release
151- build for Vine3.1
152- LANG=C when build and install
153- add man pages
154
155* Mon Jan 24 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.1-0vl1
156- new upstream release
157- BuildPrereq: qt-devel => 3.2
158
159* Tue Dec  7 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.9.1-0vl1
160- source upgrade
161
162* Sun May 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.7-0vl1
163- source upgrade
164- remove %%{_bindir}/doxysearch from %%files
165- remove about Vine2.6
166
167* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.3-0vl2
168- build for VineSeed
169
170* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.3-0vl1
171- source upgrade
172- add BuildPrereq: graphviz and Requires: graphviz
173- change spec to build both VineSeed and Vine2.5/2.6
174
175* Sat May 31 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.1-0vl1
176- source upgrade
177
178* Sat May 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3-0vl1
179- source upgrade
180
181* Wed Jan  8 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3-0vl0.3
182- source upgrade to 1.3-rc3
183- enable %%configure --with-doxywizard
184
185* Wed Jan  8 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3-0vl0.1
186- source upgrade to 1.3-rc2
187- add BuildPrereq: libpng-devel
188- add Requires: XFree86-gl libexpat to %%package doxywizard
189- add LICENSE to %%docs
190- disable %%configure --with-doxywizard
191
192* Fri Jan  3 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.18-0vl1
193- source upgrade
194- build with new toolchains
195- delete Patch2
196
197* Mon Aug  5 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.17-0vl1
198- source upgrade
199- build with qt-3.0.5
200
201* Sun Jun  9 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.2.16-0vl1
202- source update to 1.2.16
203
204* Thu May 09 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.2.15-0vl1
205- source update to 1.2.15
206
207* Sat Mar 23 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.2.14-3vl1
208- build for VineSeed
209- delete Epoch
210
211* Fri Mar  8 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.13-3
212- rebuild against qt 3.0.2
213
214* Tue Feb 26 2002 Than Ngo <than@redhat.com> 1.2.14-2
215- rebuild against qt 2.3.2
216
217* Tue Feb 19 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.14-1
218- 1.2.14
219
220* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
221- automated rebuild
222
223* Sun Jan 06 2002 Than Ngo <than@redhat.com> 1.2.13.1-1
224- update to 1.2.13.1
225- fixed build doxywizard with qt3
226
227* Sun Dec 30 2001 Jeff Johnson <jbj@redhat.com> 1.2.13-1
228- update to 1.2.13
229
230* Sun Nov 18 2001 Than Ngo <than@redhat.com> 1.2.12-1
231- update to 1.2.12
232- s/Copyright/License
233
234* Wed Sep 12 2001 Tim Powers <timp@redhat.com>
235- rebuild with new gcc and binutils
236
237* Wed Jun 13 2001 Than Ngo <than@redhat.com>
238- update tp 1.2.8.1
239- make doxywizard as separat package
240- fix to use install as default
241
242* Tue Jun 05 2001 Than Ngo <than@redhat.com>
243- update to 1.2.8
244
245* Tue May 01 2001 Than Ngo <than@redhat.com>
246- update to 1.2.7
247- clean up specfile
248- patch to use RPM_OPT_FLAG
249
250* Wed Mar 14 2001 Jeff Johnson <jbj@redhat.com>
251- update to 1.2.6
252
253* Wed Feb 28 2001 Trond Eivind Glomsrød <teg@redhat.com>
254- rebuild
255
256* Tue Dec 26 2000 Than Ngo <than@redhat.com>
257- update to 1.2.4
258- remove excludearch ia64
259- bzip2 sources
260
261* Mon Dec 11 2000 Than Ngo <than@redhat.com>
262- rebuild with the fixed fileutils
263
264* Mon Oct 30 2000 Jeff Johnson <jbj@redhat.com>
265- update to 1.2.3.
266
267* Sun Oct  8 2000 Jeff Johnson <jbj@redhat.com>
268- update to 1.2.2.
269- enable doxywizard.
270
271* Sat Aug 19 2000 Preston Brown <pbrown@redhat.com>
272- 1.2.1 is latest stable, so we upgrade before Winston is released.
273
274* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
275- automatic rebuild
276
277* Tue Jul  4 2000 Jakub Jelinek <jakub@redhat.com>
278- Rebuild with new C++
279
280* Fri Jun 30 2000 Florian La Roche <laroche@redhat.de>
281- fix QTDIR detection
282
283* Fri Jun 09 2000 Preston Brown <pbrown@redhat.com>
284- compile on x86 w/o optimization, revert when compiler fixed!!
285
286* Wed Jun 07 2000 Preston Brown <pbrown@redhat.com>
287- use newer RPM macros
288
289* Tue Jun  6 2000 Jeff Johnson <jbj@redhat.com>
290- add to distro.
291
292* Tue May  9 2000 Tim Powers <timp@redhat.com>
293- rebuilt for 7.0
294
295* Wed Feb  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
296- recompile with current Qt (2.1.0/1.45)
297
298* Wed Jan  5 2000 Jeff Johnson <jbj@redhat.com>
299- update to 1.0.0.
300- recompile with qt-2.0.1 if available.
301- relocatable package.
302
303* Mon Nov  8 1999 Tim Powers <timp@redhat.com>
304-updated to 0.49-991106
305
306* Tue Jul 13 1999 Tim Powers <timp@redhat.com>
307- updated source
308- cleaned up some stuff in the spec file
309
310* Thu Apr 22 1999 Jeff Johnson <jbj@redhat.com>
311- Create Power Tools 6.0 package.
Note: See TracBrowser for help on using the repository browser.