source: projects/specs/trunk/d/dovecot/dovecot-vl.spec @ 6667

Revision 6667, 32.8 KB checked in by daisuke, 12 years ago (diff)

2.0.21

Line 
1Summary: Dovecot Secure imap server
2Summary(ja): Dovecot セキュア IMAP サーバ
3Name: dovecot
4Version: 2.0.21
5Release: 1%{?_dist_release}
6#dovecot itself is MIT, a few sources are PD, pigeonhole is LGPLv2
7License: MIT and LGPLv2 and BSD with advertising
8Group: System Environment/Daemons
9
10%define build_postgres 1
11%define build_mysql 1
12%define build_sqlite 1
13%define build_ldap 1
14
15# pigeonhole
16%define build_pigeonhole 1
17%define pigeonholever 0.2.6
18
19# pop before smtp (drac)
20%define build_drac 1
21
22URL: http://www.dovecot.org/
23
24Source: http://www.dovecot.org/releases/2.0/%{name}-%{version}.tar.gz
25Source1: dovecot.init
26Source2: dovecot.pam
27Source8: http://www.rename-it.nl/dovecot/2.0/dovecot-2.0-pigeonhole-%{pigeonholever}.tar.gz
28Source9: dovecot.sysconfig
29Source10: dovecot.tmpfilesd
30
31#our own
32Source14: dovecot.conf.5
33
34# drac plugin (pop before smtp)
35# Source100: http://www.dovecot.org/patches/1.1/drac.c
36Source100: http://sourceforge.jp/projects/dovecot2-drac/downloads/53176/dovecot2-drac-0.1.tar.gz
37Source110: README.plugin-drac
38
39Patch1: dovecot-2.0-defaultconfig.patch
40Patch2: dovecot-1.0.beta2-mkcert-permissions.patch
41# local filesystem rules
42Patch3: dovecot-1.0.rc7-mkcert-paths.patch
43
44Packager: iwamoto
45Vendor: Project Vine
46Distribution: Vine Linux
47
48Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
49BuildRequires: openssl-devel, pam-devel, zlib-devel
50BuildRequires: bzip2-devel, libcap-devel
51BuildRequires: libtool autoconf automake, gettext-devel
52BuildRequires: pkgconfig
53BuildRequires: krb5-devel
54
55# Package includes an initscript service file,
56# needs to require initscripts package
57Requires: initscripts
58Requires(pre): /usr/sbin/useradd
59Requires(post): /sbin/chkconfig, /usr/sbin/useradd, /sbin/chkconfig
60Requires(preun): /usr/sbin/userdel, /usr/sbin/groupdel
61Requires(preun): /sbin/chkconfig, /sbin/service
62Requires(postun): /sbin/service
63
64%if %{build_postgres}
65BuildRequires: postgresql-devel
66%endif
67
68%if %{build_mysql}
69BuildRequires: mysql-devel
70%endif
71
72%if %{build_sqlite}
73BuildRequires: sqlite3-devel
74%endif
75
76%if %{build_ldap}
77BuildRequires: openldap-devel
78%endif
79
80%if %{build_drac}
81BuildRequires: dracd
82%endif
83
84%define docdir %{_docdir}/%{name}
85%define ssldir %{_sysconfdir}/pki/%{name}
86
87%description
88Dovecot is an IMAP server for Linux/UNIX-like systems, written with security
89primarily in mind.  It also contains a small POP3 server.  It supports mail
90in either of maildir or mbox formats.
91
92The SQL drivers and authentication plugins are in their subpackages.
93
94
95%if %{build_pigeonhole}
96%package pigeonhole
97Requires: %{name} = %{version}-%{release}
98Obsoletes: dovecot-sieve
99Summary: Sieve and managesieve plug-in for dovecot
100Group: System Environment/Daemons
101License: MIT and LGPLv2
102
103%description pigeonhole
104This package provides sieve and managesieve plug-in for dovecot LDA.
105
106%endif
107
108%if %{build_postgres}
109%package pgsql
110Requires: %{name} = %{version}-%{release}
111Summary: Postgres SQL backend for dovecot
112Group: System Environment/Daemons
113%description pgsql
114This package provides the Postgres SQL backend for dovecot-auth etc.
115%endif
116
117%if %{build_mysql}
118%package mysql
119Requires: %{name} = %{version}-%{release}
120Summary: MySQL backend for dovecot
121Group: System Environment/Daemons
122%description mysql
123This package provides the MySQL backend for dovecot-auth etc.
124%endif
125
126%if %{build_sqlite}
127%package sqlite
128Requires: %{name} = %{version}-%{release}
129Summary: SQLite backend for dovecot
130Group: System Environment/Daemons
131%description sqlite
132This package provides the SQLite backend for dovecot-auth etc.
133%endif
134
135%if %{build_ldap}
136%package ldap
137Requires: %{name} = %{version}-%{release}
138Summary: LDAP auth plugin for dovecot
139Group: System Environment/Daemons
140%description ldap
141This package provides the LDAP auth plugin for dovecot-auth etc.
142%endif
143
144%if %{build_drac}
145%package drac
146Summary: Dovecot plugin module for support drac (POP before SMTP)
147Group: System Environment/Daemons
148Requires: %{name} = %{version}-%{release}
149Requires: dracd
150Obsoletes: %{name}-plugin-drac < %{version}-%{release}
151
152%description drac
153Dovecot plugin module for support drac (POP before SMTP)
154%endif
155
156%package devel
157Requires: %{name} = %{version}-%{release}
158Summary: Development files dor dovecot
159Group: Development/Libraries
160%description devel
161This package provides the development files for dovecot.
162
163
164%prep
165
166%setup -q
167
168%patch1 -p1 -b .default-settings
169%patch2 -p1 -b .mkcert-permissions
170%patch3 -p1 -b .mkcert-paths
171
172%if %{build_drac}
173%setup -T -D -q -a 100
174mv dovecot2-drac/README README.dovecot2-drac
175mv dovecot2-drac/README.j README.dovecot2-drac.jp
176cp %{SOURCE110} .
177%endif
178
179%if %{build_pigeonhole}
180%setup -q -D -T -a 8
181%endif
182
183%build
184# rm -f ./configure
185# autoreconf -i -f
186%configure                           \
187    INSTALL_DATA="install -c -p -m644" \
188    --enable-header-install      \
189    --disable-static             \
190%if %{build_postgres}
191    --with-pgsql                 \
192%endif
193%if %{build_mysql}
194    --with-mysql                 \
195%endif
196%if %{build_sqlite}
197    --with-sqlite                \
198%endif
199    --with-sql=plugin            \
200    --with-sql-drivers           \
201    --with-ssl=openssl           \
202    --with-ssldir=%{ssldir}      \
203    --with-libcap                \
204    --with-zlib                  \
205%if %{build_ldap}
206    --with-ldap=plugin
207%endif
208
209make %{?_smp_mflags}
210
211%if %{build_pigeonhole}
212#pigeonhole
213pushd dovecot-2.0-pigeonhole-%{pigeonholever}
214autoreconf -fiv
215%configure                             \
216    INSTALL_DATA="install -c -p -m644" \
217    --disable-static                   \
218    --with-dovecot=../                 \
219    --without-unfinished-features
220
221make %{?_smp_mflags}
222popd
223%endif
224
225%if %{build_drac}
226pushd dovecot2-drac
227make DOVDIR=../
228popd
229%endif
230
231%install
232rm -rf $RPM_BUILD_ROOT
233make install DESTDIR=$RPM_BUILD_ROOT
234rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}
235
236%if %{build_pigeonhole}
237pushd dovecot-2.0-pigeonhole-%{pigeonholever}
238make install DESTDIR=$RPM_BUILD_ROOT
239popd
240%endif
241
242%if %{build_drac}
243pushd dovecot2-drac
244install -m 755 drac_plugin.so $RPM_BUILD_ROOT/%{_libdir}/dovecot/
245mkdir -p $RPM_BUILD_ROOT/%{_libdir}/dovecot/imap/
246mkdir -p $RPM_BUILD_ROOT/%{_libdir}/dovecot/pop3/
247ln -s ../drac_plugin.so $RPM_BUILD_ROOT/%{_libdir}/dovecot/imap/
248ln -s ../drac_plugin.so $RPM_BUILD_ROOT/%{_libdir}/dovecot/pop3/
249popd
250%endif
251
252# install -p -m 755 src/plugins/convert/convert-tool $RPM_BUILD_ROOT%{_libexecdir}/%{name}
253
254mkdir -p $RPM_BUILD_ROOT%{_initrddir}
255install -p -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_initrddir}/dovecot
256
257mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pam.d
258install -p -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/dovecot
259
260mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
261install -p -m 600 %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/dovecot
262
263#install man pages
264install -p -D -m 644 %{SOURCE14} $RPM_BUILD_ROOT%{_mandir}/man5/dovecot.conf.5
265
266# generate ghost .pem file
267mkdir -p $RPM_BUILD_ROOT%{ssldir}/certs
268mkdir -p $RPM_BUILD_ROOT%{ssldir}/private
269touch $RPM_BUILD_ROOT%{ssldir}/certs/dovecot.pem
270chmod 600 $RPM_BUILD_ROOT%{ssldir}/certs/dovecot.pem
271touch $RPM_BUILD_ROOT%{ssldir}/private/dovecot.pem
272chmod 600 $RPM_BUILD_ROOT%{ssldir}/private/dovecot.pem
273
274mkdir -p $RPM_BUILD_ROOT/var/run/dovecot/login
275chmod 755 $RPM_BUILD_ROOT/var/run/dovecot
276chmod 700 $RPM_BUILD_ROOT/var/run/dovecot/login
277       
278# Install dovecot.conf and dovecot-openssl.cnf
279mkdir -p $RPM_BUILD_ROOT%{ssldir}
280mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/dovecot/conf.d
281install -p -m 644 doc/example-config/dovecot.conf $RPM_BUILD_ROOT%{_sysconfdir}/dovecot
282install -p -m 644 doc/example-config/conf.d/*.conf $RPM_BUILD_ROOT%{_sysconfdir}/dovecot/conf.d
283install -p -m 644 doc/example-config/conf.d/*.conf.ext $RPM_BUILD_ROOT%{_sysconfdir}/dovecot/conf.d
284install -p -m 644 doc/dovecot-openssl.cnf $RPM_BUILD_ROOT%{ssldir}/dovecot-openssl.cnf
285
286# Install pigeonhole conf
287pushd dovecot-2.0-pigeonhole-%{pigeonholever}
288install -p -m 644 doc/example-config/conf.d/*.conf $RPM_BUILD_ROOT%{_sysconfdir}/dovecot/conf.d
289popd
290
291# Install some of our own documentation
292# install -p -m644 %{SOURCE7} $RPM_BUILD_ROOT%{docdir}/REDHAT-FAQ.txt
293
294# Install the licensing files into the documentation area
295install -p -m644 COPYING* $RPM_BUILD_ROOT%{docdir}
296
297mkdir -p $RPM_BUILD_ROOT%{docdir}/examples/
298install -p -m755 doc/mkcert.sh $RPM_BUILD_ROOT%{_libexecdir}/%{name}/mkcert.sh
299# for f in `cd doc; echo *.conf`; do
300#      install -p -m644 doc/$f $RPM_BUILD_ROOT%{docdir}/examples/$f;
301# done
302
303mv $RPM_BUILD_ROOT%{docdir} $RPM_BUILD_ROOT%{docdir}-%{version}
304mkdir -p $RPM_BUILD_ROOT/var/lib/dovecot
305
306#remove the libtool archives
307find $RPM_BUILD_ROOT%{_libdir}/%{name}/ -name '*.la' | xargs rm -f
308
309#prepare the filelist
310(
311    find ${RPM_BUILD_ROOT}%{_libdir}/%{name} -type d | sed -e "s|^|%dir |";
312    find ${RPM_BUILD_ROOT}%{_libdir}/%{name} -! -type d | \
313        grep -v 'dovecot-config\|lib90_cmusieve_plugin\.so\|libdriver_.*\.so\|libauthdb_.*\.so\|libmech_.*\.so\|drac\.so';
314) | sed -e "s|$RPM_BUILD_ROOT||" >libs.filelist
315
316#remove what we don't want
317rm -f $RPM_BUILD_ROOT%{_sysconfdir}/dovecot/README
318pushd doc
319#rm -f securecoding.txt thread-refs.txt
320popd
321
322%clean
323rm -rf $RPM_BUILD_ROOT
324
325
326%pre
327getent group dovecot >/dev/null || groupadd -r dovecot
328getent passwd dovecot >/dev/null || \
329useradd -r -g dovecot -d /usr/libexec/dovecot -s /sbin/nologin -c "Dovecot IMAP server" dovecot
330getent group dovenull >/dev/null || groupadd -r dovenull
331getent passwd dovenull >/dev/null || \
332useradd -r -g dovenull -d /usr/libexec/dovecot -s /sbin/nologin -c "Dovecot's unauthorized user" dovenull
333exit 0
334
335%post
336/sbin/chkconfig --add %{name}
337# generate the ssl certificates
338if [ ! -f %{ssldir}/certs/%{name}.pem ]; then
339    SSLDIR=%{ssldir} OPENSSLCONFIG=%{ssldir}/dovecot-openssl.cnf \
340         %{_libexecdir}/%{name}/mkcert.sh &> /dev/null
341fi
342
343if ! test -f /var/run/dovecot/login/ssl-parameters.dat; then
344    dovecot --build-ssl-parameters &>/dev/null
345fi
346exit 0
347
348%preun
349if [ $1 = 0 ]; then
350    /sbin/service %{name} stop > /dev/null 2>&1 || :
351    /sbin/chkconfig --del %{name} || :
352fi
353
354%postun
355if [ "$1" -ge "1" ]; then
356    /sbin/service %{name} condrestart 2>/dev/null || :
357fi
358
359%check
360make check
361cd dovecot-2.0-pigeonhole-%{pigeonholever}
362make check
363
364%files -f libs.filelist
365%defattr(-,root,root,-)
366%doc doc/* AUTHORS ChangeLog COPYING COPYING.LGPL COPYING.MIT NEWS README
367# %doc AUTHORS ChangeLog NEWS README doc/*.txt
368
369%dir %{_sysconfdir}/dovecot
370%dir %{_sysconfdir}/dovecot/conf.d
371%config(noreplace) %{_sysconfdir}/dovecot/dovecot.conf
372%config(noreplace) %{_sysconfdir}/dovecot/conf.d/*.conf
373%config(noreplace) %{_sysconfdir}/dovecot/conf.d/*.conf.ext
374# %config(noreplace) %{_sysconfdir}/dovecot.conf
375
376%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/dovecot
377%{_initrddir}/dovecot
378%config(noreplace) %{_sysconfdir}/pam.d/dovecot
379%dir %{ssldir}
380%dir %{ssldir}/certs
381%dir %{ssldir}/private
382%config(noreplace) %{ssldir}/dovecot-openssl.cnf
383%attr(0600,root,root) %ghost %config(missingok,noreplace) %verify(not md5 size mtime) %{ssldir}/certs/dovecot.pem
384%attr(0600,root,root) %ghost %config(missingok,noreplace) %verify(not md5 size mtime) %{ssldir}/private/dovecot.pem
385
386%{_libexecdir}/%{name}
387%{_sbindir}/dovecot
388# %{_sbindir}/dovecotpw
389%{_bindir}/doveadm
390%{_bindir}/doveconf
391%{_bindir}/dsync
392
393%attr(0755,root,dovecot) %dir /var/run/dovecot
394%attr(0750,root,dovenull) %dir /var/run/dovecot/login
395# %attr(0755,root,dovecot) %{_libexecdir}/%{name}/mkcert.sh
396%attr(0750,dovecot,dovecot) %dir /var/lib/dovecot
397
398%{_mandir}/man1/deliver.1.gz
399%{_mandir}/man1/doveadm*.1.gz
400%{_mandir}/man1/doveconf.1.gz
401%{_mandir}/man1/dovecot*.1.gz
402%{_mandir}/man1/dsync.1.gz
403%{_mandir}/man5/dovecot.conf.5.gz
404%{_mandir}/man7/doveadm-search-query.7.gz
405
406%if %{build_pigeonhole}
407%files pigeonhole
408%defattr(-,root,root,-)
409%{_bindir}/sieve-dump
410%{_bindir}/sieve-test
411%{_bindir}/sievec
412%config(noreplace) %{_sysconfdir}/dovecot/conf.d/90-sieve.conf
413%config(noreplace) %{_sysconfdir}/dovecot/conf.d/20-managesieve.conf
414%{_libexecdir}/%{name}/managesieve
415%{_libexecdir}/%{name}/managesieve-login
416
417%dir %{_libdir}/dovecot/settings
418%{_libdir}/dovecot/settings/libmanagesieve_*.so
419
420%{_mandir}/man1/sieve-test.1.gz
421%{_mandir}/man1/sieve-dump.1.gz
422%{_mandir}/man1/sievec.1.gz
423%{_mandir}/man1/sieved.1.gz
424%{_mandir}/man7/pigeonhole.7.gz
425%endif
426
427%if %{build_mysql}
428%files mysql
429%defattr(-,root,root,-)
430%{_libdir}/%{name}/libdriver_mysql.so
431%{_libdir}/%{name}/auth/libdriver_mysql.so
432%{_libdir}/%{name}/dict/libdriver_mysql.so
433%endif
434
435%if %{build_postgres}
436%files pgsql
437%defattr(-,root,root,-)
438%{_libdir}/%{name}/libdriver_pgsql.so
439%{_libdir}/%{name}/auth/libdriver_pgsql.so
440%{_libdir}/%{name}/dict/libdriver_pgsql.so
441%endif
442
443%if %{build_sqlite}
444%files sqlite
445%defattr(-,root,root,-)
446%{_libdir}/%{name}/libdriver_sqlite.so
447%{_libdir}/%{name}/auth/libdriver_sqlite.so
448%{_libdir}/%{name}/dict/libdriver_sqlite.so
449%endif
450
451%if %{build_ldap}
452%files ldap
453%defattr(-,root,root,-)
454%{_libdir}/%{name}/auth/libauthdb_ldap.so
455%endif
456
457%if %{build_drac}
458%files drac
459%defattr(-,root,root)
460%{_libdir}/%{name}/drac_plugin.so
461%{_libdir}/%{name}/imap/drac_plugin.so
462%{_libdir}/%{name}/pop3/drac_plugin.so
463%doc README.plugin-drac
464%endif
465
466%files devel
467%defattr(-,root,root,-)
468%{_includedir}/%{name}
469%{_libdir}/%{name}/dovecot-config
470%{_datadir}/aclocal/dovecot.m4
471
472%changelog
473* Sat Jun 16 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.21-1
474- new upstream release
475- new upstream release pigeonhole 0.2.6
476
477* Mon Oct 31 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.15-1
478- new upstream release
479
480* Tue Sep 28 2011 Masanobu HAGANE <masanobu@hagane.jp> 2.0.13-2
481- revival drac_plugin.so (POP bedore SMTP) support
482- use DRAC plugin for Dovecot-2.x
483-  (get from http://sourceforge.jp/projects/dovecot2-drac/releases/)
484
485* Sat May 21 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.13-1
486- new upstream release
487
488* Sun Apr 17 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.12-1
489- new upstream release
490- new upstream release pigeonholever 0.2.3
491
492* Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 2.0.9-6
493- rebuilt with postgresql-9.0.3
494
495* Mon Feb 14 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.9-5
496- fix pigeonhole R: (remove epoch)
497
498* Mon Jan 24 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.9-4
499- fix source url
500
501* Wed Jan 19 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.9-3
502- disable drac sub package (drac plugin not work with dovecot 2.x)
503
504* Mon Jan 17 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.9-2
505- fix config file path in dovecot.init
506- fix group of /var/run/dovecot/login
507
508* Sun Jan 16 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.9-1
509- new upstream release 2.0.x
510
511* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.15-2
512- rebuild with openssl-1.0.0c
513
514* Sat Oct  9 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.15-1
515- new upstream release with security fixes (CVE-2010-3780,3779,3707,3706)
516- add BR: pkgconfig
517
518* Thu Mar 11 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.11-1
519- new upstream release with mbox DoS fix
520
521* Mon Jan 25 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.10-2
522- fix drac.so in libs.files
523
524* Mon Jan 25 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.10-1
525- new upstream release
526
527* Fri Jan  8 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.9-1
528- new upstream release
529- update to dovecot sieve 1.1.8
530
531* Thu Sep 17 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.3-2
532- update to dovecot sieve 1.1.7 to fix BoF
533- add BR: bzip2-devel, libcap-devel
534
535* Mon Aug 10 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.3-1
536- new upstream release
537
538* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.2-1
539- new upstream release 
540
541* Sun Jul 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.1-1
542- new upstream release
543
544* Tue Jul  7 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.0-1
545- new upstream 1.2.x release
546- update Patch1 to fit new release
547- README.plugin-drac in UTF-8
548
549* Tue Jun  2 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.16-1
550- new upstream release
551
552* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.15-3
553- rebuilt with MySQL-5.1.34.
554
555* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.15-2
556- add BuildRequires gettext-devel instead of gettext
557
558* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.15-1
559- new upstream release
560- update patch1 to fix new release
561
562* Mon Apr 27 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.14-1
563- new upstream release
564
565* Sun Mar 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.1.13-2
566- rebuilt with openldap-2.4.11
567
568* Sun Mar 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.13-1
569- new upstream release
570
571* Sat Feb 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.11-1
572- new upstream release
573
574* Sun Feb 01 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.10-1
575- new upstream release
576
577* Sun Jan 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.8-1
578- new upstream release
579
580* Sat Nov 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.6-1
581- new upstream release
582
583* Tue Oct 21 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.4-2
584- change BuildRequires sqlite-devel -> sqlite3-devel
585
586* Mon Oct 20 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.4-1
587- new upstream release
588
589* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.3-1
590- new upstream release
591
592* Sun Aug 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.2-1
593- new upstream release
594- split ldap plugin to subpackage
595- split sql plugins to subpackages
596- add -devel subpackage
597- update drac module, rename to -drac from -plugin-drac
598- add dovecot-sieve
599
600* Mon Mar 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.13-0vl2
601- build for VineSeed (0vl1 is for VinePlus 4.x)
602- new upstream release
603
604* Mon Jan 07 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.10-0vl2
605- build for VineSeed (0vl1 is for VinePlus 4.x)
606- new upstream release with security fix (CVE-2007-6598)
607- turn on daemon stop massage (Already start message is on)
608
609* Sat Dec 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.9-0vl1
610- new upstream source
611
612* Wed Nov 21 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.7-0vl4
613- updated %%install section to support lib64 architecture
614
615* Sun Nov 04 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.7-0vl3
616- rebuild for VineSeed (from VinePlus 4.x)
617
618  * Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.5-0vl1
619  - new upstream release
620  - rebuilt with postgresql-devel 8.2.5
621
622  * Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-0vl1
623  - new upstream release
624
625  * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl1
626  - new upstream release
627
628* Sat Nov 03 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.7-0vl2
629- add Require dracd tag in plugin-drac
630
631* Sat Nov 03 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.7-0vl1
632- new upstream release
633
634* Fri Oct 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-0vl4
635- fix drac plugin make method
636- change drac.so install method (use sym link)
637- add README.plugin-drac
638
639* Fri Oct 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-0vl3
640- add dovecot-openssl.cnf install to doc
641- daemon restart message turn on when package is upgraded
642
643* Tue Oct 09 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-0vl2
644- add drac.so (POP bedore SMTP) support
645
646* Mon Oct 08 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-0vl1
647- new upstream release
648- drop patch500 (it is included in new release)
649- move Mysql buildreq tag to "if build_mysql" section
650- add Requires: postgresql-libs and Requires: MySQL-shared in "if-endif"
651- add Requires: openldap
652
653* Wed Aug 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0-0.rc17.0vl2
654- add Patch500 to fix directory traversal vulnerability (CVE-2007-2231)
655  note that version 1.0.rc29 and up have been already fixed in upstream
656
657* Mon Jan 08 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0-0.rc17.0vl1
658- new upstream RC release
659
660* Sun Jan 07 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0-0.rc16.0vl1
661- new upstream RC release
662
663* Thu Dec 21 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0-0.rc15.0vl2
664- add Vendor/Distribution tag
665
666* Sun Dec 10 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0-0.rc15.0vl1
667- new upstream RC release
668- add BuildRequires: MySQL-shared, MySQL-devel
669- update patch100
670
671* Mon Oct 30 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0-0.rc7.1vl2
672- rebuilt with MySQL 5.0.27
673
674* Mon Aug 28 2006 IWAI, Masaharu <iwai@alib.jp> 1.0-0.rc7.1vl1
675- new upstream release
676- update default settings patch (Patch100)
677- build with openldap-2.3.24
678
679* Tue Aug  1 2006 IWAI, Masaharu <iwai@alib.jp> 1.0-0.rc2.1vl1
680- first release for Vine Linux
681
682* Mon Jul 17 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.rc2.1
683- reenable inotify and see what happens
684
685* Thu Jul 13 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.rc2
686- update to latest upstream release candidate
687- disable inotify for now, doesn't build -- this needs fixing though
688
689* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.beta8.2.1
690- rebuild
691
692* Thu Jun 08 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta8.2
693- put back pop3_uidl_format default that got lost
694  in the beta2->beta7 upgrade (would cause pop3 to not work
695  at all in many situations)
696
697* Thu May 04 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta8.1
698- upgrade to latest upstream beta release (beta8)
699- contains a security fix in mbox handling
700
701* Thu May 04 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta7.1
702- upgrade to latest upstream beta release
703- fixed BR 173048
704
705* Fri Mar 17 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.8
706- fix sqlite detection in upstream configure checks, second part
707  of #182240
708
709* Wed Mar  8 2006 Bill Nottingham <notting@redhat.com> - 1.0-0.beta2.7
710- fix scriplet noise some more
711
712* Mon Mar  6 2006 Jeremy Katz <katzj@redhat.com> - 1.0-0.beta2.6
713- fix scriptlet error (mitr, #184151)
714
715* Mon Feb 27 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.5
716- fix #182240 by looking in lib64 for libs first and then lib
717- fix comment #1 in #182240 by copying over the example config files
718  to documentation directory
719
720* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.beta2.4.1
721- bump again for double-long bug on ppc(64)
722
723* Thu Feb 09 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.4
724- enable inotify as it should work now (#179431)
725
726* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.beta2.3.1
727- rebuilt for new gcc4.1 snapshot and glibc changes
728
729* Thu Feb 02 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.3
730- change the compiled-in defaults and adjust the default's configfile
731  commented-out example settings to match compiled-in defaults,
732  instead of changing the defaults only in the configfile, as per #179432
733- fix #179574 by providing a default uidl_format for pop3
734- half-fix #179620 by having plaintext auth enabled by default... this
735  needs more thinking (which one we really want) and documentation
736  either way
737
738* Tue Jan 31 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.2
739- update URL in description
740- call dovecot --build-ssl-parameters in postinst as per #179430
741
742* Mon Jan 30 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.1
743- fix spec to work with BUILD_DIR != SOURCE_DIR
744- forward-port and split pam-nocred patch
745
746* Mon Jan 23 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2
747- new upstream version, hopefully fixes #173928, #163550
748- fix #168866, use install -p to install documentation
749
750* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
751- rebuilt
752
753* Sat Nov 12 2005 Tom Lane <tgl@redhat.com> - 0.99.14-10.fc5
754- Rebuild due to mysql update.
755
756* Wed Nov  9 2005 Tomas Mraz <tmraz@redhat.com> - 0.99.14-9.fc5
757- rebuilt with new openssl
758
759* Fri Sep 30 2005 Tomas Mraz <tmraz@redhat.com> - 0.99.14-8.fc5
760- use include instead of pam_stack in pam config
761
762* Wed Jul 27 2005 John Dennis <jdennis@redhat.com> - 0.99.14-7.fc5
763- fix bug #150888, log authenication failures with ip address
764
765* Fri Jul 22 2005 John Dennis <jdennis@redhat.com> - 0.99.14-6.fc5
766- fix bug #149673, add dummy PAM_TTY
767
768* Thu Apr 28 2005 John Dennis <jdennis@redhat.com> - 0.99.14-5.fc4
769- fix bug #156159 insecure location of restart flag file
770
771* Fri Apr 22 2005 John Dennis <jdennis@redhat.com> - 0.99.14-4.fc4
772- openssl moved its certs, CA, etc. from /usr/share/ssl to /etc/pki
773
774* Tue Apr 12 2005 Tom Lane <tgl@redhat.com> 0.99.14-3.fc4
775- Rebuild for Postgres 8.0.2 (new libpq major version).
776
777* Mon Mar  7 2005 John Dennis <jdennis@redhat.com> 0.99.14-2.fc4
778- bump rev for gcc4 build
779
780* Mon Feb 14 2005 John Dennis <jdennis@redhat.com> - 0.99.14-1.fc4
781- fix bug #147874, update to 0.99.14 release
782  v0.99.14 2005-02-11  Timo Sirainen <tss at iki.fi>
783  - Message address fields are now parsed differently, fixing some
784    issues with spaces. Affects only clients which use FETCH ENVELOPE
785    command.
786  - Message MIME parser was somewhat broken with missing MIME boundaries
787  - mbox: Don't allow X-UID headers in mails to override the UIDs we
788    would otherwise set. Too large values can break some clients and
789    cause other trouble.
790  - passwd-file userdb wasn't working
791  - PAM crashed with 64bit systems
792  - non-SSL inetd startup wasn't working
793  - If UID FETCH notices and skips an expunged message, don't return
794    a NO reply. It's not needed and only makes clients give error
795    messages.
796
797* Wed Feb  2 2005 John Dennis <jdennis@redhat.com> - 0.99.13-4.devel
798- fix bug #146198, clean up temp kerberos tickets
799
800* Mon Jan 17 2005 John Dennis <jdennis@redhat.com> 0.99.13-3.devel
801- fix bug #145214, force mbox_locks to fcntl only
802- fix bug #145241, remove prereq on postgres and mysql, allow rpm auto
803  dependency generator to pick up client lib dependency if needed.
804
805* Thu Jan 13 2005 John Dennis <jdennis@redhat.com> 0.99.13-2.devel
806- make postgres & mysql conditional build
807- remove execute bit on migration example scripts so rpm does not pull
808  in additional dependences on perl and perl modules that are not present
809  in dovecot proper.
810- add REDHAT-FAQ.txt to doc directory
811
812* Thu Jan  6 2005 John Dennis <jdennis@redhat.com> 0.99.13-1.devel
813- bring up to date with latest upstream, 0.99.13, bug #143707
814  also fix bug #14462, bad dovecot-uid macro name
815
816* Thu Jan  6 2005 John Dennis <jdennis@redhat.com> 0.99.11-10.devel
817- fix bug #133618, removed LITERAL+ capability from capability string
818
819* Wed Jan  5 2005 John Dennis <jdennis@redhat.com> 0.99.11-9.devel
820- fix bug #134325, stop dovecot during installation
821
822* Wed Jan  5 2005 John Dennis <jdennis@redhat.com> 0.99.11-8.devel
823- fix bug #129539, dovecot starts too early,
824  set chkconfig to 65 35 to match cyrus-imapd
825- also delete some old commented out code from SSL certificate creation
826
827* Thu Dec 23 2004 John Dennis <jdennis@redhat.com> 0.99.11-7.devel
828- add UW to Dovecot migration documentation and scripts, bug #139954
829  fix SSL documentation and scripts, add missing documentation, bug #139276
830
831* Thu Nov 15 2004 Warren Togami <wtogami@redhat.com> 0.99.11-2.FC4.1
832- rebuild against MySQL4
833
834* Thu Oct 21 2004 John Dennis <jdennis@redhat.com>
835- fix bug #136623
836  Change License field from GPL to LGPL to reflect actual license
837
838* Thu Sep 30 2004 John Dennis <jdennis@redhat.com> 0.99.11-1.FC3.3
839- fix bug #124786, listen to ipv6 as well as ipv4
840
841* Wed Sep  8 2004 John Dennis <jdennis@redhat.com> 0.99.11-1.FC3.1
842- bring up to latest upstream,
843  comments from Timo Sirainen <tss at iki.fi> on release v0.99.11 2004-09-04 
844  + 127.* and ::1 IP addresses are treated as secured with
845    disable_plaintext_auth = yes
846  + auth_debug setting for extra authentication debugging
847  + Some documentation and error message updates
848  + Create PID file in /var/run/dovecot/master.pid
849  + home setting is now optional in static userdb
850  + Added mail setting to static userdb
851  - After APPENDing to selected mailbox Dovecot didn't always notice the
852    new mail immediately which broke some clients
853  - THREAD and SORT commands crashed with some mails
854  - If APPENDed mail ended with CR character, Dovecot aborted the saving
855  - Output streams sometimes sent data duplicated and lost part of it.
856    This could have caused various strange problems, but looks like in
857    practise it rarely caused real problems.
858
859* Wed Aug  4 2004 John Dennis <jdennis@redhat.com>
860- change release field separator from comma to dot, bump build number
861
862* Mon Aug  2 2004 John Dennis <jdennis@redhat.com> 0.99.10.9-1,FC3,1
863- bring up to date with latest upstream, fixes include:
864- LDAP support compiles now with Solaris LDAP library
865- IMAP BODY and BODYSTRUCTURE replies were wrong for MIME parts which
866  didn't contain Content-Type header.
867- MySQL and PostgreSQL auth didn't reconnect if connection was lost
868  to SQL server
869- Linking fixes for dovecot-auth with some systems
870- Last fix for disconnecting client when downloading mail longer than
871  30 seconds actually made it never disconnect client. Now it works
872  properly: disconnect when client hasn't read _any_ data for 30
873  seconds.
874- MySQL compiling got broken in last release
875- More PostgreSQL reconnection fixing
876
877
878* Mon Jul 26 2004 John Dennis <jdennis@redhat.com> 0.99.10.7-1,FC3,1
879- enable postgres and mySQL in build
880- fix configure to look for mysql in alternate locations
881- nuke configure script in tar file, recreate from configure.in using autoconf
882
883- bring up to latest upstream, which included:
884- Added outlook-pop3-no-nuls workaround to fix Outlook hang in mails with NULs.
885- Config file lines can now contain quoted strings ("value ")
886- If client didn't finish downloading a single mail in 30 seconds,
887  Dovecot closed the connection. This was supposed to work so that
888  if client hasn't read data at all in 30 seconds, it's disconnected.
889- Maildir: LIST now doesn't skip symlinks
890
891
892* Wed Jun 30 2004 John Dennis <jdennis@redhat.com>
893- bump rev for build
894- change rev for FC3 build
895
896* Fri Jun 25 2004 John Dennis <jdennis@redhat.com> - 0.99.10.6-1
897- bring up to date with upstream,
898  recent change log comments from Timo Sirainen were:
899  SHA1 password support using OpenSSL crypto library
900  mail_extra_groups setting
901  maildir_stat_dirs setting
902  Added NAMESPACE capability and command
903  Autocreate missing maildirs (instead of crashing)
904  Fixed occational crash in maildir synchronization
905  Fixed occational assertion crash in ioloop.c
906  Fixed FreeBSD compiling issue
907  Fixed issues with 64bit Solaris binary
908
909* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
910- rebuilt
911
912* Thu May 27 2004 David Woodhouse <dwmw2@redhat.com> 0.99.10.5-1
913- Update to 0.99.10.5 to fix maildir segfaults (#123022)
914
915* Fri May 07 2004 Warren Togami <wtogami@redhat.com> 0.99.10.4-4
916- default auth config that is actually usable
917- Timo Sirainen (author) suggested functionality fixes
918  maildir, imap-fetch-body-section, customflags-fix
919
920* Mon Feb 23 2004 Tim Waugh <twaugh@redhat.com>
921- Use ':' instead of '.' as separator for chown.
922
923* Tue Feb 17 2004 Jeremy Katz <katzj@redhat.com> - 0.99.10.4-3
924- restart properly if it dies (#115594)
925
926* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
927- rebuilt
928
929* Mon Nov 24 2003 Jeremy Katz <katzj@redhat.com> 0.99.10.4-1
930- update to 0.99.10.4
931
932* Mon Oct  6 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-7
933- another patch from upstream to fix returning invalid data on partial
934  BODY[part] fetches
935- patch to avoid confusion of draft/deleted in indexes
936
937* Tue Sep 23 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-6
938- add some patches from upstream (#104288)
939
940* Thu Sep  4 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-5
941- fix startup with 2.6 with patch from upstream (#103801)
942
943* Tue Sep  2 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-4
944- fix assert in search code (#103383)
945
946* Tue Jul 22 2003 Nalin Dahyabhai <nalin@redhat.com> 0.99.10-3
947- rebuild
948
949* Thu Jul 17 2003 Bill Nottingham <notting@redhat.com> 0.99.10-2
950- don't run by default
951
952* Thu Jun 26 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-1
953- 0.99.10
954
955* Mon Jun 23 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-0.2
956- 0.99.10-rc2 (includes ssl detection fix)
957- a few tweaks from fedora
958  - noreplace the config file
959  - configure --with-ldap to get LDAP enabled
960
961* Mon Jun 23 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-0.1
962- 0.99.10-rc1
963- add fix for ssl detection
964- add zlib-devel to BuildRequires
965- change pam service name to dovecot
966- include pam config
967
968* Thu May  8 2003 Jeremy Katz <katzj@redhat.com> 0.99.9.1-1
969- update to 0.99.9.1
970- add patch from upstream to fix potential bug when fetching with
971  CR+LF linefeeds
972- tweak some things in the initscript and config file noticed by the
973  fedora folks
974
975* Sun Mar 16 2003 Jeremy Katz <katzj@redhat.com> 0.99.8.1-2
976- fix ssl dir
977- own /var/run/dovecot/login with the correct perms
978- fix chmod/chown in post
979
980* Fri Mar 14 2003 Jeremy Katz <katzj@redhat.com> 0.99.8.1-1
981- update to 0.99.8.1
982
983* Tue Mar 11 2003 Jeremy Katz <katzj@redhat.com> 0.99.8-2
984- add a patch to fix quoting problem from CVS
985
986* Mon Mar 10 2003 Jeremy Katz <katzj@redhat.com> 0.99.8-1
987- 0.99.8
988- add some buildrequires
989- fixup to build with openssl 0.9.7
990- now includes a pop3 daemon (off by default)
991- clean up description and %%preun
992- add dovecot user (uid/gid of 97)
993- add some buildrequires
994- move the ssl cert to %{_datadir}/ssl/certs
995- create a dummy ssl cert in %post
996- own /var/run/dovecot
997- make the config file a source so we get default mbox locks of fcntl
998
999* Sun Dec  1 2002 Seth Vidal <skvidal@phy.duke.edu>
1000- 0.99.4 and fix startup so it starts imap-master not vsftpd :)
1001
1002* Tue Nov 26 2002 Seth Vidal <skvidal@phy.duke.edu>
1003- first build
Note: See TracBrowser for help on using the repository browser.