source: projects/specs/trunk/d/dovecot/dovecot-vl.spec @ 3418

Revision 3418, 31.8 KB checked in by owa, 13 years ago (diff)

rebuild with postgresql-9.0.3

Line 
1Summary: Dovecot Secure imap server
2Summary(ja): Dovecot セキュア IMAP サーバ
3Name: dovecot
4Version: 2.0.9
5Release: 6%{?_dist_release}
6#dovecot itself is MIT, a few sources are PD, pigeonhole is LGPLv2
7License: MIT and LGPLv2 and BSD with advertising
8Group: System Environment/Daemons
9
10%define build_postgres 1
11%define build_mysql 1
12%define build_sqlite 1
13%define build_ldap 1
14
15# pigeonhole
16%define build_pigeonhole 1
17%define pigeonholever 0.2.2
18
19# pop before smtp (drac)
20%define build_drac 0
21
22URL: http://www.dovecot.org/
23
24Source: http://www.dovecot.org/releases/2.0/%{name}-%{version}.tar.gz
25Source1: dovecot.init
26Source2: dovecot.pam
27Source8: http://www.rename-it.nl/dovecot/2.0/dovecot-2.0-pigeonhole-%{pigeonholever}.tar.gz
28Source9: dovecot.sysconfig
29Source10: dovecot.tmpfilesd
30
31#our own
32Source14: dovecot.conf.5
33
34Source100: http://www.dovecot.org/patches/1.1/drac.c
35Source110: README.plugin-drac
36
37Patch1: dovecot-2.0-defaultconfig.patch
38Patch2: dovecot-1.0.beta2-mkcert-permissions.patch
39# local filesystem rules
40Patch3: dovecot-1.0.rc7-mkcert-paths.patch
41
42Packager: iwamoto
43Vendor: Project Vine
44Distribution: Vine Linux
45
46Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
47BuildRequires: openssl-devel, pam-devel, zlib-devel
48BuildRequires: bzip2-devel, libcap-devel
49BuildRequires: libtool autoconf automake, gettext-devel
50BuildRequires: pkgconfig
51BuildRequires: krb5-devel
52
53# Package includes an initscript service file,
54# needs to require initscripts package
55Requires: initscripts
56Requires(pre): /usr/sbin/useradd
57Requires(post): /sbin/chkconfig, /usr/sbin/useradd, /sbin/chkconfig
58Requires(preun): /usr/sbin/userdel, /usr/sbin/groupdel
59Requires(preun): /sbin/chkconfig, /sbin/service
60Requires(postun): /sbin/service
61
62%if %{build_postgres}
63BuildRequires: postgresql-devel
64%endif
65
66%if %{build_mysql}
67BuildRequires: mysql-devel
68%endif
69
70%if %{build_sqlite}
71BuildRequires: sqlite3-devel
72%endif
73
74%if %{build_ldap}
75BuildRequires: openldap-devel
76%endif
77
78%if %{build_drac}
79BuildRequires: dracd
80%endif
81
82%define docdir %{_docdir}/%{name}
83%define ssldir %{_sysconfdir}/pki/%{name}
84
85%description
86Dovecot is an IMAP server for Linux/UNIX-like systems, written with security
87primarily in mind.  It also contains a small POP3 server.  It supports mail
88in either of maildir or mbox formats.
89
90The SQL drivers and authentication plugins are in their subpackages.
91
92
93%if %{build_pigeonhole}
94%package pigeonhole
95Requires: %{name} = %{version}-%{release}
96Obsoletes: dovecot-sieve
97Summary: Sieve and managesieve plug-in for dovecot
98Group: System Environment/Daemons
99License: MIT and LGPLv2
100
101%description pigeonhole
102This package provides sieve and managesieve plug-in for dovecot LDA.
103
104%endif
105
106%if %{build_postgres}
107%package pgsql
108Requires: %{name} = %{version}-%{release}
109Summary: Postgres SQL backend for dovecot
110Group: System Environment/Daemons
111%description pgsql
112This package provides the Postgres SQL backend for dovecot-auth etc.
113%endif
114
115%if %{build_mysql}
116%package mysql
117Requires: %{name} = %{version}-%{release}
118Summary: MySQL backend for dovecot
119Group: System Environment/Daemons
120%description mysql
121This package provides the MySQL backend for dovecot-auth etc.
122%endif
123
124%if %{build_sqlite}
125%package sqlite
126Requires: %{name} = %{version}-%{release}
127Summary: SQLite backend for dovecot
128Group: System Environment/Daemons
129%description sqlite
130This package provides the SQLite backend for dovecot-auth etc.
131%endif
132
133%if %{build_ldap}
134%package ldap
135Requires: %{name} = %{version}-%{release}
136Summary: LDAP auth plugin for dovecot
137Group: System Environment/Daemons
138%description ldap
139This package provides the LDAP auth plugin for dovecot-auth etc.
140%endif
141
142%if %{build_drac}
143%package drac
144Summary: Dovecot plugin module for support drac (POP before SMTP)
145Group: System Environment/Daemons
146Requires: %{name} = %{version}-%{release}
147Requires: dracd
148Obsoletes: %{name}-plugin-drac < %{version}-%{release}
149
150%description drac
151Dovecot plugin module for support drac (POP before SMTP)
152%endif
153
154%package devel
155Requires: %{name} = %{version}-%{release}
156Summary: Development files dor dovecot
157Group: Development/Libraries
158%description devel
159This package provides the development files for dovecot.
160
161
162%prep
163
164%setup -q
165
166cp %{SOURCE100} .
167cp %{SOURCE110} .
168
169%patch1 -p1 -b .default-settings
170%patch2 -p1 -b .mkcert-permissions
171%patch3 -p1 -b .mkcert-paths
172
173%if %{build_pigeonhole}
174%setup -q -D -T -a 8
175%endif
176
177%build
178# rm -f ./configure
179# autoreconf -i -f
180%configure                           \
181    INSTALL_DATA="install -c -p -m644" \
182    --enable-header-install      \
183    --disable-static             \
184%if %{build_postgres}
185    --with-pgsql                 \
186%endif
187%if %{build_mysql}
188    --with-mysql                 \
189%endif
190%if %{build_sqlite}
191    --with-sqlite                \
192%endif
193    --with-sql=plugin            \
194    --with-sql-drivers           \
195    --with-ssl=openssl           \
196    --with-ssldir=%{ssldir}      \
197    --with-libcap                \
198    --with-zlib                  \
199%if %{build_ldap}
200    --with-ldap=plugin
201%endif
202
203make %{?_smp_mflags}
204
205%if %{build_pigeonhole}
206#pigeonhole
207pushd dovecot-2.0-pigeonhole-%{pigeonholever}
208autoreconf -fiv
209%configure                             \
210    INSTALL_DATA="install -c -p -m644" \
211    --disable-static                   \
212    --with-dovecot=../                 \
213    --without-unfinished-features
214
215make %{?_smp_mflags}
216popd
217%endif
218
219%if %{build_drac}
220%{__cc} -Wall -W -shared -fPIC -DHAVE_CONFIG_H \
221    -I. -I./src/lib \
222    drac.c -o drac.so -ldrac
223%endif
224
225%install
226rm -rf $RPM_BUILD_ROOT
227make install DESTDIR=$RPM_BUILD_ROOT
228rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}
229
230%if %{build_pigeonhole}
231pushd dovecot-2.0-pigeonhole-%{pigeonholever}
232make install DESTDIR=$RPM_BUILD_ROOT
233popd
234%endif
235
236%if %{build_drac}
237install -m 755 drac.so $RPM_BUILD_ROOT/%{_libdir}/dovecot/
238ln -s ../drac.so $RPM_BUILD_ROOT/%{_libdir}/dovecot/imap/
239ln -s ../drac.so $RPM_BUILD_ROOT/%{_libdir}/dovecot/pop3/
240%endif
241
242# install -p -m 755 src/plugins/convert/convert-tool $RPM_BUILD_ROOT%{_libexecdir}/%{name}
243
244mkdir -p $RPM_BUILD_ROOT%{_initrddir}
245install -p -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_initrddir}/dovecot
246
247mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pam.d
248install -p -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/dovecot
249
250mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
251install -p -m 600 %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/dovecot
252
253#install man pages
254install -p -D -m 644 %{SOURCE14} $RPM_BUILD_ROOT%{_mandir}/man5/dovecot.conf.5
255
256# generate ghost .pem file
257mkdir -p $RPM_BUILD_ROOT%{ssldir}/certs
258mkdir -p $RPM_BUILD_ROOT%{ssldir}/private
259touch $RPM_BUILD_ROOT%{ssldir}/certs/dovecot.pem
260chmod 600 $RPM_BUILD_ROOT%{ssldir}/certs/dovecot.pem
261touch $RPM_BUILD_ROOT%{ssldir}/private/dovecot.pem
262chmod 600 $RPM_BUILD_ROOT%{ssldir}/private/dovecot.pem
263
264mkdir -p $RPM_BUILD_ROOT/var/run/dovecot/login
265chmod 755 $RPM_BUILD_ROOT/var/run/dovecot
266chmod 700 $RPM_BUILD_ROOT/var/run/dovecot/login
267       
268# Install dovecot.conf and dovecot-openssl.cnf
269mkdir -p $RPM_BUILD_ROOT%{ssldir}
270mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/dovecot/conf.d
271install -p -m 644 doc/example-config/dovecot.conf $RPM_BUILD_ROOT%{_sysconfdir}/dovecot
272install -p -m 644 doc/example-config/conf.d/*.conf $RPM_BUILD_ROOT%{_sysconfdir}/dovecot/conf.d
273install -p -m 644 doc/example-config/conf.d/*.conf.ext $RPM_BUILD_ROOT%{_sysconfdir}/dovecot/conf.d
274install -p -m 644 doc/dovecot-openssl.cnf $RPM_BUILD_ROOT%{ssldir}/dovecot-openssl.cnf
275
276# Install pigeonhole conf
277pushd dovecot-2.0-pigeonhole-%{pigeonholever}
278install -p -m 644 doc/example-config/conf.d/*.conf $RPM_BUILD_ROOT%{_sysconfdir}/dovecot/conf.d
279popd
280
281# Install some of our own documentation
282# install -p -m644 %{SOURCE7} $RPM_BUILD_ROOT%{docdir}/REDHAT-FAQ.txt
283
284# Install the licensing files into the documentation area
285install -p -m644 COPYING* $RPM_BUILD_ROOT%{docdir}
286
287mkdir -p $RPM_BUILD_ROOT%{docdir}/examples/
288install -p -m755 doc/mkcert.sh $RPM_BUILD_ROOT%{_libexecdir}/%{name}/mkcert.sh
289# for f in `cd doc; echo *.conf`; do
290#      install -p -m644 doc/$f $RPM_BUILD_ROOT%{docdir}/examples/$f;
291# done
292
293mv $RPM_BUILD_ROOT%{docdir} $RPM_BUILD_ROOT%{docdir}-%{version}
294mkdir -p $RPM_BUILD_ROOT/var/lib/dovecot
295
296#remove the libtool archives
297find $RPM_BUILD_ROOT%{_libdir}/%{name}/ -name '*.la' | xargs rm -f
298
299#prepare the filelist
300(
301    find ${RPM_BUILD_ROOT}%{_libdir}/%{name} -type d | sed -e "s|^|%dir |";
302    find ${RPM_BUILD_ROOT}%{_libdir}/%{name} -! -type d | \
303        grep -v 'dovecot-config\|lib90_cmusieve_plugin\.so\|libdriver_.*\.so\|libauthdb_.*\.so\|libmech_.*\.so\|drac\.so';
304) | sed -e "s|$RPM_BUILD_ROOT||" >libs.filelist
305
306#remove what we don't want
307rm -f $RPM_BUILD_ROOT%{_sysconfdir}/dovecot/README
308pushd doc
309#rm -f securecoding.txt thread-refs.txt
310popd
311
312%clean
313rm -rf $RPM_BUILD_ROOT
314
315
316%pre
317getent group dovecot >/dev/null || groupadd -r dovecot
318getent passwd dovecot >/dev/null || \
319useradd -r -g dovecot -d /usr/libexec/dovecot -s /sbin/nologin -c "Dovecot IMAP server" dovecot
320getent group dovenull >/dev/null || groupadd -r dovenull
321getent passwd dovenull >/dev/null || \
322useradd -r -g dovenull -d /usr/libexec/dovecot -s /sbin/nologin -c "Dovecot's unauthorized user" dovenull
323exit 0
324
325%post
326/sbin/chkconfig --add %{name}
327# generate the ssl certificates
328if [ ! -f %{ssldir}/certs/%{name}.pem ]; then
329    SSLDIR=%{ssldir} OPENSSLCONFIG=%{ssldir}/dovecot-openssl.cnf \
330         %{_libexecdir}/%{name}/mkcert.sh &> /dev/null
331fi
332
333if ! test -f /var/run/dovecot/login/ssl-parameters.dat; then
334    dovecot --build-ssl-parameters &>/dev/null
335fi
336exit 0
337
338%preun
339if [ $1 = 0 ]; then
340    /sbin/service %{name} stop > /dev/null 2>&1 || :
341    /sbin/chkconfig --del %{name} || :
342fi
343
344%postun
345if [ "$1" -ge "1" ]; then
346    /sbin/service %{name} condrestart 2>/dev/null || :
347fi
348
349%check
350make check
351cd dovecot-2.0-pigeonhole-%{pigeonholever}
352make check
353
354%files -f libs.filelist
355%defattr(-,root,root,-)
356%doc doc/* AUTHORS ChangeLog COPYING COPYING.LGPL COPYING.MIT NEWS README
357# %doc AUTHORS ChangeLog NEWS README doc/*.txt
358
359%dir %{_sysconfdir}/dovecot
360%dir %{_sysconfdir}/dovecot/conf.d
361%config(noreplace) %{_sysconfdir}/dovecot/dovecot.conf
362%config(noreplace) %{_sysconfdir}/dovecot/conf.d/*.conf
363%config(noreplace) %{_sysconfdir}/dovecot/conf.d/*.conf.ext
364# %config(noreplace) %{_sysconfdir}/dovecot.conf
365
366%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/dovecot
367%{_initrddir}/dovecot
368%config(noreplace) %{_sysconfdir}/pam.d/dovecot
369%dir %{ssldir}
370%dir %{ssldir}/certs
371%dir %{ssldir}/private
372%config(noreplace) %{ssldir}/dovecot-openssl.cnf
373%attr(0600,root,root) %ghost %config(missingok,noreplace) %verify(not md5 size mtime) %{ssldir}/certs/dovecot.pem
374%attr(0600,root,root) %ghost %config(missingok,noreplace) %verify(not md5 size mtime) %{ssldir}/private/dovecot.pem
375
376%{_libexecdir}/%{name}
377%{_sbindir}/dovecot
378# %{_sbindir}/dovecotpw
379%{_bindir}/doveadm
380%{_bindir}/doveconf
381%{_bindir}/dsync
382
383%attr(0755,root,dovecot) %dir /var/run/dovecot
384%attr(0750,root,dovenull) %dir /var/run/dovecot/login
385# %attr(0755,root,dovecot) %{_libexecdir}/%{name}/mkcert.sh
386%attr(0750,dovecot,dovecot) %dir /var/lib/dovecot
387
388%{_mandir}/man1/deliver.1.gz
389%{_mandir}/man1/doveadm*.1.gz
390%{_mandir}/man1/doveconf.1.gz
391%{_mandir}/man1/dovecot*.1.gz
392%{_mandir}/man1/dsync.1.gz
393%{_mandir}/man5/dovecot.conf.5.gz
394%{_mandir}/man7/doveadm-search-query.7.gz
395
396%if %{build_pigeonhole}
397%files pigeonhole
398%defattr(-,root,root,-)
399%{_bindir}/sieve-dump
400%{_bindir}/sieve-test
401%{_bindir}/sievec
402%config(noreplace) %{_sysconfdir}/dovecot/conf.d/90-sieve.conf
403%config(noreplace) %{_sysconfdir}/dovecot/conf.d/20-managesieve.conf
404%{_libexecdir}/%{name}/managesieve
405%{_libexecdir}/%{name}/managesieve-login
406
407%dir %{_libdir}/dovecot/settings
408%{_libdir}/dovecot/settings/libmanagesieve_*.so
409
410%{_mandir}/man1/sieve-test.1.gz
411%{_mandir}/man1/sieve-dump.1.gz
412%{_mandir}/man1/sievec.1.gz
413%{_mandir}/man1/sieved.1.gz
414%{_mandir}/man7/pigeonhole.7.gz
415%endif
416
417%if %{build_mysql}
418%files mysql
419%defattr(-,root,root,-)
420%{_libdir}/%{name}/libdriver_mysql.so
421%{_libdir}/%{name}/auth/libdriver_mysql.so
422%{_libdir}/%{name}/dict/libdriver_mysql.so
423%endif
424
425%if %{build_postgres}
426%files pgsql
427%defattr(-,root,root,-)
428%{_libdir}/%{name}/libdriver_pgsql.so
429%{_libdir}/%{name}/auth/libdriver_pgsql.so
430%{_libdir}/%{name}/dict/libdriver_pgsql.so
431%endif
432
433%if %{build_sqlite}
434%files sqlite
435%defattr(-,root,root,-)
436%{_libdir}/%{name}/libdriver_sqlite.so
437%{_libdir}/%{name}/auth/libdriver_sqlite.so
438%{_libdir}/%{name}/dict/libdriver_sqlite.so
439%endif
440
441%if %{build_ldap}
442%files ldap
443%defattr(-,root,root,-)
444%{_libdir}/%{name}/auth/libauthdb_ldap.so
445%endif
446
447%if %{build_drac}
448%files drac
449%defattr(-,root,root)
450%{_libdir}/%{name}/drac.so
451%{_libdir}/%{name}/imap/drac.so
452%{_libdir}/%{name}/pop3/drac.so
453%doc README.plugin-drac
454%endif
455
456%files devel
457%defattr(-,root,root,-)
458%{_includedir}/%{name}
459%{_libdir}/%{name}/dovecot-config
460%{_datadir}/aclocal/dovecot.m4
461
462%changelog
463* Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 2.0.9-6
464- rebuilt with postgresql-9.0.3
465
466* Mon Feb 14 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.9-5
467- fix pigeonhole R: (remove epoch)
468
469* Mon Jan 24 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.9-4
470- fix source url
471
472* Wed Jan 19 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.9-3
473- disable drac sub package (drac plugin not work with dovecot 2.x)
474
475* Mon Jan 17 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.9-2
476- fix config file path in dovecot.init
477- fix group of /var/run/dovecot/login
478
479* Sun Jan 16 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.9-1
480- new upstream release 2.0.x
481
482* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.15-2
483- rebuild with openssl-1.0.0c
484
485* Sat Oct  9 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.15-1
486- new upstream release with security fixes (CVE-2010-3780,3779,3707,3706)
487- add BR: pkgconfig
488
489* Thu Mar 11 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.11-1
490- new upstream release with mbox DoS fix
491
492* Mon Jan 25 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.10-2
493- fix drac.so in libs.files
494
495* Mon Jan 25 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.10-1
496- new upstream release
497
498* Fri Jan  8 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.9-1
499- new upstream release
500- update to dovecot sieve 1.1.8
501
502* Thu Sep 17 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.3-2
503- update to dovecot sieve 1.1.7 to fix BoF
504- add BR: bzip2-devel, libcap-devel
505
506* Mon Aug 10 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.3-1
507- new upstream release
508
509* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.2-1
510- new upstream release 
511
512* Sun Jul 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.1-1
513- new upstream release
514
515* Tue Jul  7 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.0-1
516- new upstream 1.2.x release
517- update Patch1 to fit new release
518- README.plugin-drac in UTF-8
519
520* Tue Jun  2 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.16-1
521- new upstream release
522
523* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.15-3
524- rebuilt with MySQL-5.1.34.
525
526* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.15-2
527- add BuildRequires gettext-devel instead of gettext
528
529* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.15-1
530- new upstream release
531- update patch1 to fix new release
532
533* Mon Apr 27 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.14-1
534- new upstream release
535
536* Sun Mar 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.1.13-2
537- rebuilt with openldap-2.4.11
538
539* Sun Mar 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.13-1
540- new upstream release
541
542* Sat Feb 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.11-1
543- new upstream release
544
545* Sun Feb 01 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.10-1
546- new upstream release
547
548* Sun Jan 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.8-1
549- new upstream release
550
551* Sat Nov 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.6-1
552- new upstream release
553
554* Tue Oct 21 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.4-2
555- change BuildRequires sqlite-devel -> sqlite3-devel
556
557* Mon Oct 20 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.4-1
558- new upstream release
559
560* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.3-1
561- new upstream release
562
563* Sun Aug 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.2-1
564- new upstream release
565- split ldap plugin to subpackage
566- split sql plugins to subpackages
567- add -devel subpackage
568- update drac module, rename to -drac from -plugin-drac
569- add dovecot-sieve
570
571* Mon Mar 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.13-0vl2
572- build for VineSeed (0vl1 is for VinePlus 4.x)
573- new upstream release
574
575* Mon Jan 07 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.10-0vl2
576- build for VineSeed (0vl1 is for VinePlus 4.x)
577- new upstream release with security fix (CVE-2007-6598)
578- turn on daemon stop massage (Already start message is on)
579
580* Sat Dec 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.9-0vl1
581- new upstream source
582
583* Wed Nov 21 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.7-0vl4
584- updated %%install section to support lib64 architecture
585
586* Sun Nov 04 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.7-0vl3
587- rebuild for VineSeed (from VinePlus 4.x)
588
589  * Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.5-0vl1
590  - new upstream release
591  - rebuilt with postgresql-devel 8.2.5
592
593  * Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-0vl1
594  - new upstream release
595
596  * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl1
597  - new upstream release
598
599* Sat Nov 03 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.7-0vl2
600- add Require dracd tag in plugin-drac
601
602* Sat Nov 03 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.7-0vl1
603- new upstream release
604
605* Fri Oct 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-0vl4
606- fix drac plugin make method
607- change drac.so install method (use sym link)
608- add README.plugin-drac
609
610* Fri Oct 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-0vl3
611- add dovecot-openssl.cnf install to doc
612- daemon restart message turn on when package is upgraded
613
614* Tue Oct 09 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-0vl2
615- add drac.so (POP bedore SMTP) support
616
617* Mon Oct 08 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-0vl1
618- new upstream release
619- drop patch500 (it is included in new release)
620- move Mysql buildreq tag to "if build_mysql" section
621- add Requires: postgresql-libs and Requires: MySQL-shared in "if-endif"
622- add Requires: openldap
623
624* Wed Aug 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0-0.rc17.0vl2
625- add Patch500 to fix directory traversal vulnerability (CVE-2007-2231)
626  note that version 1.0.rc29 and up have been already fixed in upstream
627
628* Mon Jan 08 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0-0.rc17.0vl1
629- new upstream RC release
630
631* Sun Jan 07 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0-0.rc16.0vl1
632- new upstream RC release
633
634* Thu Dec 21 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0-0.rc15.0vl2
635- add Vendor/Distribution tag
636
637* Sun Dec 10 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0-0.rc15.0vl1
638- new upstream RC release
639- add BuildRequires: MySQL-shared, MySQL-devel
640- update patch100
641
642* Mon Oct 30 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0-0.rc7.1vl2
643- rebuilt with MySQL 5.0.27
644
645* Mon Aug 28 2006 IWAI, Masaharu <iwai@alib.jp> 1.0-0.rc7.1vl1
646- new upstream release
647- update default settings patch (Patch100)
648- build with openldap-2.3.24
649
650* Tue Aug  1 2006 IWAI, Masaharu <iwai@alib.jp> 1.0-0.rc2.1vl1
651- first release for Vine Linux
652
653* Mon Jul 17 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.rc2.1
654- reenable inotify and see what happens
655
656* Thu Jul 13 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.rc2
657- update to latest upstream release candidate
658- disable inotify for now, doesn't build -- this needs fixing though
659
660* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.beta8.2.1
661- rebuild
662
663* Thu Jun 08 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta8.2
664- put back pop3_uidl_format default that got lost
665  in the beta2->beta7 upgrade (would cause pop3 to not work
666  at all in many situations)
667
668* Thu May 04 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta8.1
669- upgrade to latest upstream beta release (beta8)
670- contains a security fix in mbox handling
671
672* Thu May 04 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta7.1
673- upgrade to latest upstream beta release
674- fixed BR 173048
675
676* Fri Mar 17 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.8
677- fix sqlite detection in upstream configure checks, second part
678  of #182240
679
680* Wed Mar  8 2006 Bill Nottingham <notting@redhat.com> - 1.0-0.beta2.7
681- fix scriplet noise some more
682
683* Mon Mar  6 2006 Jeremy Katz <katzj@redhat.com> - 1.0-0.beta2.6
684- fix scriptlet error (mitr, #184151)
685
686* Mon Feb 27 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.5
687- fix #182240 by looking in lib64 for libs first and then lib
688- fix comment #1 in #182240 by copying over the example config files
689  to documentation directory
690
691* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.beta2.4.1
692- bump again for double-long bug on ppc(64)
693
694* Thu Feb 09 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.4
695- enable inotify as it should work now (#179431)
696
697* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.beta2.3.1
698- rebuilt for new gcc4.1 snapshot and glibc changes
699
700* Thu Feb 02 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.3
701- change the compiled-in defaults and adjust the default's configfile
702  commented-out example settings to match compiled-in defaults,
703  instead of changing the defaults only in the configfile, as per #179432
704- fix #179574 by providing a default uidl_format for pop3
705- half-fix #179620 by having plaintext auth enabled by default... this
706  needs more thinking (which one we really want) and documentation
707  either way
708
709* Tue Jan 31 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.2
710- update URL in description
711- call dovecot --build-ssl-parameters in postinst as per #179430
712
713* Mon Jan 30 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.1
714- fix spec to work with BUILD_DIR != SOURCE_DIR
715- forward-port and split pam-nocred patch
716
717* Mon Jan 23 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2
718- new upstream version, hopefully fixes #173928, #163550
719- fix #168866, use install -p to install documentation
720
721* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
722- rebuilt
723
724* Sat Nov 12 2005 Tom Lane <tgl@redhat.com> - 0.99.14-10.fc5
725- Rebuild due to mysql update.
726
727* Wed Nov  9 2005 Tomas Mraz <tmraz@redhat.com> - 0.99.14-9.fc5
728- rebuilt with new openssl
729
730* Fri Sep 30 2005 Tomas Mraz <tmraz@redhat.com> - 0.99.14-8.fc5
731- use include instead of pam_stack in pam config
732
733* Wed Jul 27 2005 John Dennis <jdennis@redhat.com> - 0.99.14-7.fc5
734- fix bug #150888, log authenication failures with ip address
735
736* Fri Jul 22 2005 John Dennis <jdennis@redhat.com> - 0.99.14-6.fc5
737- fix bug #149673, add dummy PAM_TTY
738
739* Thu Apr 28 2005 John Dennis <jdennis@redhat.com> - 0.99.14-5.fc4
740- fix bug #156159 insecure location of restart flag file
741
742* Fri Apr 22 2005 John Dennis <jdennis@redhat.com> - 0.99.14-4.fc4
743- openssl moved its certs, CA, etc. from /usr/share/ssl to /etc/pki
744
745* Tue Apr 12 2005 Tom Lane <tgl@redhat.com> 0.99.14-3.fc4
746- Rebuild for Postgres 8.0.2 (new libpq major version).
747
748* Mon Mar  7 2005 John Dennis <jdennis@redhat.com> 0.99.14-2.fc4
749- bump rev for gcc4 build
750
751* Mon Feb 14 2005 John Dennis <jdennis@redhat.com> - 0.99.14-1.fc4
752- fix bug #147874, update to 0.99.14 release
753  v0.99.14 2005-02-11  Timo Sirainen <tss at iki.fi>
754  - Message address fields are now parsed differently, fixing some
755    issues with spaces. Affects only clients which use FETCH ENVELOPE
756    command.
757  - Message MIME parser was somewhat broken with missing MIME boundaries
758  - mbox: Don't allow X-UID headers in mails to override the UIDs we
759    would otherwise set. Too large values can break some clients and
760    cause other trouble.
761  - passwd-file userdb wasn't working
762  - PAM crashed with 64bit systems
763  - non-SSL inetd startup wasn't working
764  - If UID FETCH notices and skips an expunged message, don't return
765    a NO reply. It's not needed and only makes clients give error
766    messages.
767
768* Wed Feb  2 2005 John Dennis <jdennis@redhat.com> - 0.99.13-4.devel
769- fix bug #146198, clean up temp kerberos tickets
770
771* Mon Jan 17 2005 John Dennis <jdennis@redhat.com> 0.99.13-3.devel
772- fix bug #145214, force mbox_locks to fcntl only
773- fix bug #145241, remove prereq on postgres and mysql, allow rpm auto
774  dependency generator to pick up client lib dependency if needed.
775
776* Thu Jan 13 2005 John Dennis <jdennis@redhat.com> 0.99.13-2.devel
777- make postgres & mysql conditional build
778- remove execute bit on migration example scripts so rpm does not pull
779  in additional dependences on perl and perl modules that are not present
780  in dovecot proper.
781- add REDHAT-FAQ.txt to doc directory
782
783* Thu Jan  6 2005 John Dennis <jdennis@redhat.com> 0.99.13-1.devel
784- bring up to date with latest upstream, 0.99.13, bug #143707
785  also fix bug #14462, bad dovecot-uid macro name
786
787* Thu Jan  6 2005 John Dennis <jdennis@redhat.com> 0.99.11-10.devel
788- fix bug #133618, removed LITERAL+ capability from capability string
789
790* Wed Jan  5 2005 John Dennis <jdennis@redhat.com> 0.99.11-9.devel
791- fix bug #134325, stop dovecot during installation
792
793* Wed Jan  5 2005 John Dennis <jdennis@redhat.com> 0.99.11-8.devel
794- fix bug #129539, dovecot starts too early,
795  set chkconfig to 65 35 to match cyrus-imapd
796- also delete some old commented out code from SSL certificate creation
797
798* Thu Dec 23 2004 John Dennis <jdennis@redhat.com> 0.99.11-7.devel
799- add UW to Dovecot migration documentation and scripts, bug #139954
800  fix SSL documentation and scripts, add missing documentation, bug #139276
801
802* Thu Nov 15 2004 Warren Togami <wtogami@redhat.com> 0.99.11-2.FC4.1
803- rebuild against MySQL4
804
805* Thu Oct 21 2004 John Dennis <jdennis@redhat.com>
806- fix bug #136623
807  Change License field from GPL to LGPL to reflect actual license
808
809* Thu Sep 30 2004 John Dennis <jdennis@redhat.com> 0.99.11-1.FC3.3
810- fix bug #124786, listen to ipv6 as well as ipv4
811
812* Wed Sep  8 2004 John Dennis <jdennis@redhat.com> 0.99.11-1.FC3.1
813- bring up to latest upstream,
814  comments from Timo Sirainen <tss at iki.fi> on release v0.99.11 2004-09-04 
815  + 127.* and ::1 IP addresses are treated as secured with
816    disable_plaintext_auth = yes
817  + auth_debug setting for extra authentication debugging
818  + Some documentation and error message updates
819  + Create PID file in /var/run/dovecot/master.pid
820  + home setting is now optional in static userdb
821  + Added mail setting to static userdb
822  - After APPENDing to selected mailbox Dovecot didn't always notice the
823    new mail immediately which broke some clients
824  - THREAD and SORT commands crashed with some mails
825  - If APPENDed mail ended with CR character, Dovecot aborted the saving
826  - Output streams sometimes sent data duplicated and lost part of it.
827    This could have caused various strange problems, but looks like in
828    practise it rarely caused real problems.
829
830* Wed Aug  4 2004 John Dennis <jdennis@redhat.com>
831- change release field separator from comma to dot, bump build number
832
833* Mon Aug  2 2004 John Dennis <jdennis@redhat.com> 0.99.10.9-1,FC3,1
834- bring up to date with latest upstream, fixes include:
835- LDAP support compiles now with Solaris LDAP library
836- IMAP BODY and BODYSTRUCTURE replies were wrong for MIME parts which
837  didn't contain Content-Type header.
838- MySQL and PostgreSQL auth didn't reconnect if connection was lost
839  to SQL server
840- Linking fixes for dovecot-auth with some systems
841- Last fix for disconnecting client when downloading mail longer than
842  30 seconds actually made it never disconnect client. Now it works
843  properly: disconnect when client hasn't read _any_ data for 30
844  seconds.
845- MySQL compiling got broken in last release
846- More PostgreSQL reconnection fixing
847
848
849* Mon Jul 26 2004 John Dennis <jdennis@redhat.com> 0.99.10.7-1,FC3,1
850- enable postgres and mySQL in build
851- fix configure to look for mysql in alternate locations
852- nuke configure script in tar file, recreate from configure.in using autoconf
853
854- bring up to latest upstream, which included:
855- Added outlook-pop3-no-nuls workaround to fix Outlook hang in mails with NULs.
856- Config file lines can now contain quoted strings ("value ")
857- If client didn't finish downloading a single mail in 30 seconds,
858  Dovecot closed the connection. This was supposed to work so that
859  if client hasn't read data at all in 30 seconds, it's disconnected.
860- Maildir: LIST now doesn't skip symlinks
861
862
863* Wed Jun 30 2004 John Dennis <jdennis@redhat.com>
864- bump rev for build
865- change rev for FC3 build
866
867* Fri Jun 25 2004 John Dennis <jdennis@redhat.com> - 0.99.10.6-1
868- bring up to date with upstream,
869  recent change log comments from Timo Sirainen were:
870  SHA1 password support using OpenSSL crypto library
871  mail_extra_groups setting
872  maildir_stat_dirs setting
873  Added NAMESPACE capability and command
874  Autocreate missing maildirs (instead of crashing)
875  Fixed occational crash in maildir synchronization
876  Fixed occational assertion crash in ioloop.c
877  Fixed FreeBSD compiling issue
878  Fixed issues with 64bit Solaris binary
879
880* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
881- rebuilt
882
883* Thu May 27 2004 David Woodhouse <dwmw2@redhat.com> 0.99.10.5-1
884- Update to 0.99.10.5 to fix maildir segfaults (#123022)
885
886* Fri May 07 2004 Warren Togami <wtogami@redhat.com> 0.99.10.4-4
887- default auth config that is actually usable
888- Timo Sirainen (author) suggested functionality fixes
889  maildir, imap-fetch-body-section, customflags-fix
890
891* Mon Feb 23 2004 Tim Waugh <twaugh@redhat.com>
892- Use ':' instead of '.' as separator for chown.
893
894* Tue Feb 17 2004 Jeremy Katz <katzj@redhat.com> - 0.99.10.4-3
895- restart properly if it dies (#115594)
896
897* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
898- rebuilt
899
900* Mon Nov 24 2003 Jeremy Katz <katzj@redhat.com> 0.99.10.4-1
901- update to 0.99.10.4
902
903* Mon Oct  6 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-7
904- another patch from upstream to fix returning invalid data on partial
905  BODY[part] fetches
906- patch to avoid confusion of draft/deleted in indexes
907
908* Tue Sep 23 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-6
909- add some patches from upstream (#104288)
910
911* Thu Sep  4 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-5
912- fix startup with 2.6 with patch from upstream (#103801)
913
914* Tue Sep  2 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-4
915- fix assert in search code (#103383)
916
917* Tue Jul 22 2003 Nalin Dahyabhai <nalin@redhat.com> 0.99.10-3
918- rebuild
919
920* Thu Jul 17 2003 Bill Nottingham <notting@redhat.com> 0.99.10-2
921- don't run by default
922
923* Thu Jun 26 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-1
924- 0.99.10
925
926* Mon Jun 23 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-0.2
927- 0.99.10-rc2 (includes ssl detection fix)
928- a few tweaks from fedora
929  - noreplace the config file
930  - configure --with-ldap to get LDAP enabled
931
932* Mon Jun 23 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-0.1
933- 0.99.10-rc1
934- add fix for ssl detection
935- add zlib-devel to BuildRequires
936- change pam service name to dovecot
937- include pam config
938
939* Thu May  8 2003 Jeremy Katz <katzj@redhat.com> 0.99.9.1-1
940- update to 0.99.9.1
941- add patch from upstream to fix potential bug when fetching with
942  CR+LF linefeeds
943- tweak some things in the initscript and config file noticed by the
944  fedora folks
945
946* Sun Mar 16 2003 Jeremy Katz <katzj@redhat.com> 0.99.8.1-2
947- fix ssl dir
948- own /var/run/dovecot/login with the correct perms
949- fix chmod/chown in post
950
951* Fri Mar 14 2003 Jeremy Katz <katzj@redhat.com> 0.99.8.1-1
952- update to 0.99.8.1
953
954* Tue Mar 11 2003 Jeremy Katz <katzj@redhat.com> 0.99.8-2
955- add a patch to fix quoting problem from CVS
956
957* Mon Mar 10 2003 Jeremy Katz <katzj@redhat.com> 0.99.8-1
958- 0.99.8
959- add some buildrequires
960- fixup to build with openssl 0.9.7
961- now includes a pop3 daemon (off by default)
962- clean up description and %%preun
963- add dovecot user (uid/gid of 97)
964- add some buildrequires
965- move the ssl cert to %{_datadir}/ssl/certs
966- create a dummy ssl cert in %post
967- own /var/run/dovecot
968- make the config file a source so we get default mbox locks of fcntl
969
970* Sun Dec  1 2002 Seth Vidal <skvidal@phy.duke.edu>
971- 0.99.4 and fix startup so it starts imap-master not vsftpd :)
972
973* Tue Nov 26 2002 Seth Vidal <skvidal@phy.duke.edu>
974- first build
Note: See TracBrowser for help on using the repository browser.