source: projects/specs/trunk/d/docbook-utils/docbook-utils-vl.spec @ 521

Revision 521, 7.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define name    docbook-utils
2%define ver     0.6.14
3%define rel     2%{?_dist_release}
4
5Summary:        Shell scripts for managing DocBook documents.
6Summary(ja):    DocBook ドキュメントを操作するためのスクリプト集
7Name:           %{name}
8Version:        %{ver}
9Release:        %{rel}
10License:        GPL
11Group:          Applications/Text
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13BuildArch:      noarch
14
15Requires:       docbook-style-dsssl >= 1.72
16Requires:       docbook-dtds
17Requires:       perl-SGMLSpm >= 1.03ii
18Requires:       which
19Requires:       jadetex w3m
20Obsoletes:      stylesheets
21Provides:       stylesheets
22
23BuildRequires: perl-SGMLSpm
24
25Source0: %{name}-%{version}.tar.gz
26Source1: db2html
27Source2: gdp-both.dsl
28# Vine (Original of Source3 is Source2)
29Source3: gdp-both.dsl.vine 
30
31# Vine Patches
32# for using w3m priority
33Patch100: docbook-utils-w3m.patch
34
35
36%description
37This package contains scripts are for easy conversion from DocBook
38files to other formats (for example, HTML, RTF, and PostScript), and
39for comparing SGML files.
40
41%description -l ja
42DocBook ドキュメントを他の形式 (例: HTML, RTF, PostScript) に変換したり、
43SGML と比較するためのスクリプト集です。
44
45%package pdf
46Summary: A script for converting DocBook documents to PDF format.
47Summary(ja): DocBook ドキュメントを PDF 形式に変換するスクリプト
48Group: Applications/Text
49Requires: jadetex >= 2.5
50Requires: docbook-utils = %{version}
51Obsoletes: stylesheets-db2pdf
52Provides: stylesheets-db2pdf
53
54
55%description pdf
56This package contains a script for converting DocBook documents to
57PDF format.
58
59%description pdf
60DocBook ドキュメントを PDF 形式に変換するためのスクリプトです。
61
62%prep
63%setup -q
64%patch100 -p1 -b .w3m
65
66%build
67
68%configure --prefix=%{_prefix} --mandir=%{_mandir}
69make
70
71%install
72[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
73
74%makeinstall
75for util in dvi html pdf ps rtf
76do
77        ln -s docbook2$util $RPM_BUILD_ROOT%{_bindir}/db2$util
78        ln -s jw.1.gz $RPM_BUILD_ROOT%{_mandir}/man1/db2$util.1
79done
80# db2html is not just a symlink, as it has to create the output directory
81rm -f $RPM_BUILD_ROOT%{_bindir}/db2html
82install -c -m 775 %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/db2html
83install -c -m 644 %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/sgml/docbook/utils-%{version}/docbook-utils.dsl
84install -c -m 644 %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/sgml/docbook/utils-%{version}/docbook-utils-a4.dsl
85perl -pi -e 's/^ "USletter"/ "A4"/' $RPM_BUILD_ROOT%{_datadir}/sgml/docbook/utils-%{version}/docbook-utils-a4.dsl
86
87# rm docdir
88rm -r $RPM_BUILD_ROOT/usr/doc
89
90%clean
91[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
92
93
94%files
95%defattr (-,root,root)
96%doc README COPYING TODO doc/HTML/*.html
97%{_bindir}/jw
98%{_bindir}/docbook2dvi
99%{_bindir}/docbook2html
100%{_bindir}/docbook2man
101%{_bindir}/docbook2ps
102%{_bindir}/docbook2rtf
103%{_bindir}/docbook2tex
104%{_bindir}/docbook2texi
105%{_bindir}/docbook2txt
106%{_bindir}/db2dvi
107%{_bindir}/db2html
108%{_bindir}/db2ps
109%{_bindir}/db2rtf
110%{_bindir}/sgmldiff
111%{_datadir}/sgml/docbook/utils-%{version}
112%{_mandir}/*/db2dvi.*
113%{_mandir}/*/db2html.*
114%{_mandir}/*/db2ps.*
115%{_mandir}/*/db2rtf.*
116%{_mandir}/*/docbook2dvi.*
117%{_mandir}/*/docbook2html.*
118%{_mandir}/*/docbook2ps.*
119%{_mandir}/*/docbook2rtf.*
120%{_mandir}/*/docbook2man.*
121%{_mandir}/*/docbook2tex.*
122%{_mandir}/*/docbook2texi.*
123%{_mandir}/*/jw.*
124%{_mandir}/*/sgmldiff.*
125%{_mandir}/*/*-spec.*
126
127%files pdf
128%defattr (-,root,root)
129%{_bindir}/docbook2pdf
130%{_bindir}/db2pdf
131%{_mandir}/*/db2pdf.*
132%{_mandir}/*/docbook2pdf.*
133
134%changelog
135* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 0.6.14-2vl5
136- applied new versioning policy, spec in utf-8
137
138* Tue Jul 13 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.14-2vl1
139- new upstream release
140- dropped Patch0 and 1 because those integrated to upstream
141- add Requires: jadetex, w3m
142- added Patch100 to use /usr/bin/w3m priority
143
144* Mon Sep 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.13-7vl1
145- based on Rawhide 0.6.13-7
146  * Tue Jun 10 2003 Tim Waugh <twaugh@redhat.com> 0.6.13-7
147  - Fix manpage output: escape dots in column 1 (bug #97087).
148
149* Sun May 18 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.13-3vl2
150- use gdp-both.dsl.vine instead of gdp-both.dsl
151  (for enable use-id-as-filename)
152- fixed spec file
153
154* Wed May  7 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.13-3vl1
155- based on Rawhide 0.6.13-3
156  - Move docbook2pdf man pages to pdf subpackage (bug #90041).
157  - 0.6.13, fixing bug #86152.
158- added html document in %{_docdir}
159
160* Sun Feb  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.12-5vl1
161- based on Rawhide 0.6.12-5
162  - Build reqires perl-SGMLSpm
163  - Fixed from CVS
164  - No longer need separate stylesheet for A4
165- add Japanese summary and description
166
167* Sat Oct 26 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.12-0vl1
168- 0.6.12
169- add BuildRequires docbook-dtd31-sgml (make uses this...)
170
171* Mon Sep 30 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.11-2vl4
172- fix Requires (previous version didn't change... )
173
174* Sat Sep 28 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.11-2vl3
175- change Require docbook-dtd-sgml, docbook-dtd-xml
176
177* Sat Sep 28 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.11-2vl2
178- updated to 0.6.11 by based on rawhide 0.6.11-2
179- don't apply patch
180
181* Thu Oct 11 2001 Akira TAGOH <tagoh@gnome.gr.jpj> 0.6.9-2vl1
182- Rebuild for Vine.
183
184* Mon Aug 13 2001 Tim Waugh <twaugh@redhat.com> 0.6.9-2
185- Larger bottom margin in gdp-both.dsl to fix RTF output (bug #49677).
186
187* Tue Jul  3 2001 Tim Waugh <twaugh@redhat.com> 0.6.9-1
188- 0.6.9.
189- With --nochunks, send output to a file instead of stdout (bug #46913).
190
191* Mon Jun  4 2001 Tim Waugh <twaugh@redhat.com> 0.6.8-2
192- Make sure COPYING isn't installed as a symlink.
193
194* Mon May 21 2001 Tim Waugh <twaugh@redhat.com> 0.6.8-1
195- 0.6.8.
196
197* Mon May 21 2001 Tim Waugh <twaugh@redhat.com> 0.6-14
198- db2html: copy admon graphics to output directory (bug #40143).
199- Require docbook-style-dsssl 1.64-2 for symbolic link used by db2html.
200- db2html: handle arguments with spaces better.
201
202* Sat Mar 24 2001 Tim Waugh <twaugh@redhat.com> 0.6-13
203- Fix man pages (bug #32820).
204
205* Mon Mar 12 2001 Tim Waugh <twaugh@redhat.com>
206- Fix argument parsing in docbook2xxx (bug #31518).
207- Fix argument passing in db2html (bug #31520).
208- Fix pdf generation (bug #31524).
209
210* Fri Feb 23 2001 Tim Waugh <twaugh@redhat.com>
211- Allow the use of custom backends and frontends (bug #29067).
212
213* Fri Feb 16 2001 Tim Waugh <twaugh@redhat.com>
214- Use gdp-both.dsl as the default stylesheet.
215
216* Mon Feb 12 2001 Tim Waugh <twaugh@redhat.com>
217- REALLY only create output directory for db2html (duh).
218- Handle filenames with dots in properly.
219
220* Sun Feb 11 2001 Tim Waugh <twaugh@redhat.com>
221- Only create output directory for db2html (bug #27092). (docbook2html
222  does not create an output directory in the upstream version, but
223  the compatibility script has been made to do so.)
224
225* Mon Jan 22 2001 Tim Waugh <twaugh@redhat.com>
226- Move the jadetex requirement to the -pdf subpackage.
227
228* Tue Jan 16 2001 Tim Waugh <twaugh@redhat.com>
229- Put output files in new directory instead of current directory.
230
231* Mon Jan 15 2001 Tim Waugh <twaugh@redhat.com>
232- Don't play so many macro games.
233- Be sure to own utils directory.
234
235* Fri Jan 12 2001 Tim Waugh <twaugh@redhat.com>
236- Split off docbook2pdf into subpackage for dependency reasons.
237
238* Mon Jan 08 2001 Tim Waugh <twaugh@redhat.com>
239- Change group.
240- Use %%{_mandir} and %%{_prefix}.
241- db2* symlinks.
242- Obsolete stylesheets (and -db2pdf).
243- Change Copyright: to License:.
244- Remove Packager: line.
245- Reword description.
246
247* Mon Jan 08 2001 Tim Waugh <twaugh@redhat.com>
248- Based on Eric Bischoff's new-trials packages.
Note: See TracBrowser for help on using the repository browser.