source: projects/specs/trunk/d/docbook-style-xsl/docbook-style-xsl-vl.spec @ 521

Revision 521, 10.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name: docbook-style-xsl
2Version: 1.75.2
3Release: 6%{?_dist_release}
4Group: Applications/Text
5
6Summary: Norman Walsh's XSL stylesheets for DocBook XML.
7Summary(ja): DocBook XML用 XSLスタイルシート
8
9License: Copyright only
10URL: http://docbook.sourceforge.net/projects/xsl/
11
12Source0: http://downloads.sourceforge.net/docbook/docbook-xsl-%{version}.tar.bz2
13Source1: %{name}.Makefile
14Source2: http://downloads.sourceforge.net/docbook/docbook-xsl-doc-%{version}.tar.bz2
15
16# Avoid proportional-column-width for passivetex (bug #176766).
17Patch1: docbook-xsl-pagesetup.patch
18# Hard-code the margin-left work around to expect passivetex (bug #113456).
19Patch2: docbook-xsl-marginleft.patch
20# fix of #161619 - adjustColumnWidths now available
21Patch3: docbook-xsl-newmethods.patch
22# change a few non-constant expressions to constant - needed for passivetex(#366441)
23Patch4: docbook-xsl-non-constant-expressions.patch
24# added fixes for passivetex extension and list-item-body(#161371)
25Patch5: docbook-xsl-list-item-body.patch
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-root
28BuildArch: noarch
29
30Provides: docbook-xsl = %{version}
31Requires: docbook-dtd-xml
32# xml-common was using /usr/share/xml until 0.6.3-8.
33Requires: xml-common >= 0.6.3-8
34# required because of usage of /usr/bin/xmlcatalog
35Requires(post): libxml2 >= 2.4.8
36Requires(postun): libxml2 >= 2.4.8
37# PassiveTeX before 1.21 can't handle the newer stylesheets.
38Conflicts: passivetex < 1.21
39
40
41%description
42These XSL stylesheets allow you to transform any DocBook XML document to
43other formats, such as HTML, FO, and XHMTL.  They are highly customizable.
44
45%description -l ja
46この XSL スタイルシートを使って, さまざまな DocBook XML 形式のドキュメント
47を HTML や FO や XHTML などの他のフォーマットに変換することができます.
48
49
50%prep
51%setup -q -n docbook-xsl-%{version}
52pushd ..
53tar jxf %{SOURCE2}
54popd
55%patch1 -p1 -b .pagesetup
56%patch2 -p1 -b .marginleft
57%patch3 -p1 -b .newmethods
58%patch4 -p1 -b .nonconstant
59%patch5 -p1 -b .listitembody
60
61cp %{SOURCE1} Makefile
62
63# fix of non UTF-8 files rpmlint warnings
64for fhtml in $(find ./doc -name '*.html' -type f)
65do
66  iconv -f ISO-8859-1 -t UTF-8 "$fhtml" -o "$fhtml".tmp
67  mv -f "$fhtml".tmp "$fhtml"
68  sed -i 's/charset=ISO-8859-1/charset=UTF-8/' "$fhtml"
69done
70
71for f in $(find -name "*'*")
72do
73  mv -v "$f" $(echo "$f" | tr -d "'")
74done
75
76%build
77
78%install
79[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
80
81DESTDIR=$RPM_BUILD_ROOT
82make install BINDIR=$DESTDIR%{_bindir} DESTDIR=$DESTDIR%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}
83ln -s xsl-stylesheets-%{version} \
84        $DESTDIR%{_datadir}/sgml/docbook/xsl-stylesheets
85
86# Don't ship the extensions (bug #177256).
87rm -rf $DESTDIR%{_datadir}/sgml/docbook/xsl-stylesheets/extensions/*
88
89%clean
90[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
91
92%post
93CATALOG=%{_sysconfdir}/xml/catalog
94%{_bindir}/xmlcatalog --noout --add "rewriteSystem" \
95 "http://docbook.sourceforge.net/release/xsl/%{version}" \
96 "file://%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}" $CATALOG
97%{_bindir}/xmlcatalog --noout --add "rewriteURI" \
98 "http://docbook.sourceforge.net/release/xsl/%{version}" \
99 "file://%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}" $CATALOG
100%{_bindir}/xmlcatalog --noout --add "rewriteSystem" \
101 "http://docbook.sourceforge.net/release/xsl/current" \
102 "file://%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}" $CATALOG
103%{_bindir}/xmlcatalog --noout --add "rewriteURI" \
104 "http://docbook.sourceforge.net/release/xsl/current" \
105 "file://%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}" $CATALOG
106
107%postun
108# remove entries only on removal of package
109if [ "$1" = 0 ]; then
110  CATALOG=%{_sysconfdir}/xml/catalog
111  %{_bindir}/xmlcatalog --noout --del \
112   "file://%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}" $CATALOG
113fi
114
115
116%files
117%defattr (-,root,root)
118%doc BUGS README TODO doc
119%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}
120%{_datadir}/sgml/docbook/xsl-stylesheets
121
122
123%changelog
124* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.75.3-6
125- updated based on FC 1.75.3-5
126  * Fri Dec 18 2009 Ondrej Vasik <ovasik@redhat.com> 1.75.3-5
127  - comment patches purpose
128  - License Copyright only
129  * Mon May 11 2009 Ondrej Vasik <ovasik@redhat.com> 1.75.0-1
130  - New upstream release 1.75.0
131  - update marginleft patch
132  * Mon Feb 23 2009 Ondrej Vasik <ovasik@redhat.com> 1.74.2-2
133  - updated Makefile: do ship .svg images(#486849), xsl
134    stylesheets for website, xhtml-1_1, docbook -> epub
135    convertor
136  * Wed Feb 11 2009 Ondrej Vasik <ovasik@redhat.com> 1.74.0-7
137  - fix broken varlistentry (#479683)
138  * Mon Feb 02 2009 Ondrej Vasik <ovasik@redhat.com> 1.74.0-6
139  - fix improper localization for rtl languages, thanks
140    Muayyad Alsadi(#475077)
141  * Wed Jan 28 2009 Ondrej Vasik <ovasik@redhat.com> 1.74.0-5
142  - fix xsl stylesheets for rtl languages(#475077)
143  * Fri Dec 12 2008 Ondrej Vasik <ovasik@redhat.com> 1.74.0-4
144  - Author_Group "<orgname>" merged between "<surname>"
145    and "<surname>" (#473019)
146  * Wed Aug 06 2008 Kamil Dudka <kdudka@redhat.com> 1.74.0-3
147  - Rediffed all patches to work with patch --fuzz=0
148  * Wed Aug 06 2008 Kamil Dudka <kdudka@redhat.com> 1.74.0-2
149  - Tiny changes in docbook-xsl-newmethods.patch to work with xalan
150    (#452867)
151  * Fri Dec 14 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-9
152  - added fixes for passivetex extension and list-item-body
153    (#161371)
154  * Mon Dec 03 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-6
155  - fixed docbook-xsl-pagesetup.patch to follow Norman Walsh's
156    documentation for nonpassivetex processing(#307001)
157  * Tue Nov 27 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-5
158  - convert all html files in doc to UTF-8 in prep
159    (latest rpmlint gives warnings)
160  - no longer using release in style-xsl dir(#389231)
161
162* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.73.2-5vl5
163- applied new versioning policy, spec in utf-8
164
165* Fri Jan 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.73.2-5vl1
166- updated to 1.73.2 based on Fedora development
167  * Tue Dec 11 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-4
168  - remove entries from xmlcatalog only on removal of package
169    (required because of the last change with droping release
170     -caused drop of catalog entries during update)
171  * Wed Dec 05 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-3
172  - change a few non-constant expressions to constant that
173    could now be handled by passivetex(#366441)
174  - fixed docbook-xsl-pagesetup.patch to follow Norman Walsh's
175    documentation for nonpassivetex processing(#307001)
176    (use passivetex.extensions = 1 option in param.xsl for
177     processing with passivetex)
178  * Fri Sep  7 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-2
179  - Added PreReq of libxml2(#253962)
180
181* Sun Jul 22 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.72.0-3vl1
182- updated to 1.72.0 based on Fedora development
183  * Mon Jun 18 2007 Ondrej Vasik <ovasik@redhat.com> 1.72.0-3
184  - patch fixing #161619 taken from upstream
185  * Tue Jan 23 2007 Tim Waugh <twaugh@redhat.com> 1.72.0-1
186  - 1.72.0.
187  * Fri Jan 19 2007 Tomas Mraz <tmraz@redhat.com> 1.71.1-2
188  - Add new wordml and especially highlighting (which is referenced
189    from html) subdirs to Makefile.
190  * Tue Jan 24 2006 Tim Waugh <twaugh@redhat.com> 1.69.1-5
191  - Don't ship docsrc/* (bug #177256).
192  - Don't ship the extensions (bug #177256).
193
194* Sun Oct  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.69.1-1vl1
195- updated to 1.69.1 based on Fedora development
196
197* Sun Dec 19 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.67.2-2vl1
198- updated to 1.67.2 based on Fedora development
199  * Wed Dec  8 2004 Tim Waugh <twaugh@redhat.com> 1.67.2-2
200  - Prevent expressions in passivetex output from index.xsl (bug #142229).
201  * Thu Dec  2 2004 Tim Waugh <twaugh@redhat.com> 1.67.2-1
202  - No longer need nbsp or listblock patches.
203
204* Tue Jan 27 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.64.1-2vl2
205- patch from Fedora 1.64.1-6
206  * Tue Jan 20 2004 Tim Waugh <twaugh@redhat.com> 1.64.1-6
207  - Fix last margin-left fix (bug #113456).
208  - Reduce instances of itemized/ordered lists having misalignments.
209  * Sun Jan 18 2004 Tim Waugh <twaugh@redhat.com> 1.64.1-5
210  - And another (bug #113456).
211  * Thu Jan 15 2004 Tim Waugh <twaugh@redhat.com> 1.64.1-4
212  - Fixed another instance of bug #113456 in lists layout.
213  * Wed Jan 14 2004 Tim Waugh <twaugh@redhat.com> 1.64.1-3
214  - Hard-code the margin-left work around to expect passivetex (bug #113456).
215
216* Mon Jan  5 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.64.1-2vl1
217- based on Fedora 1.64.1-2
218- fixed Japanese summary
219
220* Sat May 24 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.61.1-1vl1
221- based on Redhat Rawhide 1.61.1-1
222- add Japanese summary and description
223
224* Tue Feb  4 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.60.1-0vl1
225- upstream release
226
227* Tue Nov 26 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.57.0-2vl1
228- based on Redhat Rawhide 1.57.0-2
229
230* Sat Oct 26 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.57.0-0vl1
231- 1.57.0
232
233* Tue Sep 24 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.55.0-0vl3
234- Rebuilded for Vine Linux (add PreReq: docbook-dtd412-xml)
235- based on rawhide 1.50.0 and source updated 1.55.0
236- use better macros
237
238* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
239- automated rebuild
240
241* Thu May 23 2002 Tim Powers <timp@redhat.com>
242- automated rebuild
243
244* Wed May  1 2002 Tim Waugh <twaugh@redhat.com> 1.50.0-1
245- 1.50.0.
246
247* Thu Feb 21 2002 Tim Waugh <twaugh@redhat.com> 1.49-1
248- 1.49.
249- Rebuild in new environment.
250
251* Fri Feb  1 2002 Tim Waugh <twaugh@redhat.com> 1.48-4
252- Put URIs instead of pathnames in the XML catalog.
253
254* Thu Jan 17 2002 Tim Waugh <twaugh@redhat.com> 1.48-3
255- Back to /usr/share/sgml.
256
257* Wed Jan 09 2002 Tim Powers <timp@redhat.com> 1.48-2
258- automated rebuild
259
260* Mon Jan  7 2002 Tim Waugh <twaugh@redhat.com> 1.48-1
261- 1.48.
262
263* Sat Dec  8 2001 Tim Waugh <twaugh@redhat.com> 1.47-2
264- Conflict with PassiveTeX before 1.11.
265
266* Tue Oct 16 2001 Tim Waugh <twaugh@redhat.com> 1.47-1
267- 1.47-experimental.
268
269* Tue Oct  9 2001 Tim Waugh <twaugh@redhat.com> 1.45-2
270- Fix unversioned symlink.
271
272* Mon Oct  8 2001 Tim Waugh <twaugh@redhat.com> 1.45-1
273- XML Catalog entries.
274- Move files to /usr/share/xml.
275
276* Mon Oct  1 2001 Tim Waugh <twaugh@redhat.com> 1.45-0.1
277- 1.45.
278- Built for Red Hat Linux.
279
280* Tue Jun 26 2001 Chris Runge <crunge@pobox.com>
281- 1.40
282
283* Fri Jun 09 2001 Chris Runge <crunge@pobox.com>
284- added extensions and additional doc
285- bin added to doc; the Perl files are for Win32 Perl and so need some
286  conversion first
287
288* Fri Jun 08 2001 Chris Runge <crunge@pobox.com>
289- Initial RPM (based on docbook-style-dsssl RPM)
290- note: no catalog right now (I don't know how to do it; and not sure why
291  it is necessary)
Note: See TracBrowser for help on using the repository browser.