source: projects/specs/trunk/d/docbook-style-xsl/docbook-style-xsl-vl.spec @ 11579

Revision 11579, 12.9 KB checked in by tomop, 6 years ago (diff)

docbook-style-xsl-1.79.2-1

Line 
1Name: docbook-style-xsl
2Version: 1.79.2
3Release: 1%{?_dist_release}
4Group: Applications/Text
5
6Summary: Norman Walsh's XSL stylesheets for DocBook XML.
7Summary(ja): DocBook XML用 XSLスタイルシート
8
9License: DMIT
10URL: https://github.com/docbook/xslt10-stylesheets
11
12Source0: https://github.com/docbook/xslt10-stylesheets/releases/download/release%2F%{version}/docbook-xsl-nons-%{version}.tar.bz2
13Source1: %{name}.Makefile
14Source2: https://github.com/docbook/xslt10-stylesheets/releases/download/release%2F%{version}/docbook-xsl-doc-%{version}.tar.bz2
15
16# Avoid proportional-column-width for passivetex (bug #176766).
17Patch1: docbook-xsl-pagesetup.patch
18# Hard-code the margin-left work around to expect passivetex (bug #113456).
19Patch2: docbook-xsl-marginleft.patch
20# fix of #161619 - adjustColumnWidths now available
21Patch3: docbook-xsl-newmethods.patch
22# change a few non-constant expressions to constant - needed for passivetex(#366441)
23Patch4: docbook-xsl-non-constant-expressions.patch
24# added fixes for passivetex extension and list-item-body(#161371)
25Patch5: docbook-xsl-list-item-body.patch
26#workaround missing mandir section problem (#727251)
27Patch6: docbook-xsl-mandir.patch
28#Non-recursive string.subst that doesn't kill smb.conf.5 generation
29Patch7: docbook-style-xsl-non-recursive-string-subst.patch
30
31BuildRoot: %{_tmppath}/%{name}-%{version}-root
32BuildArch: noarch
33
34Provides: docbook-xsl = %{version}
35Requires: docbook-dtd-xml
36# xml-common was using /usr/share/xml until 0.6.3-8.
37Requires: xml-common >= 0.6.3-8
38# required because of usage of /usr/bin/xmlcatalog
39Requires(post): libxml2 >= 2.4.8
40Requires(postun): libxml2 >= 2.4.8
41# PassiveTeX before 1.21 can't handle the newer stylesheets.
42Conflicts: passivetex < 1.21
43
44Vendor: Project Vine
45Distribution: Vine Linux
46
47%description
48These XSL stylesheets allow you to transform any DocBook XML document to
49other formats, such as HTML, FO, and XHMTL.  They are highly customizable.
50
51%description -l ja
52この XSL スタイルシートを使って, さまざまな DocBook XML 形式のドキュメント
53を HTML や FO や XHTML などの他のフォーマットに変換することができます.
54
55
56%prep
57%setup -c -T -n docbook-xsl-%{version}
58tar jxf %{SOURCE0}
59mv docbook-xsl-nons-%{version}/* .
60pushd ..
61tar jxf %{SOURCE2}
62popd
63%patch1 -p1 -b .pagesetup
64%patch2 -p1 -b .marginleft
65%patch3 -p1 -b .newmethods
66%patch4 -p1 -b .nonconstant
67%patch5 -p1 -b .listitembody
68%patch6 -p1 -b .mandir
69%patch7 -p2 -b .non-recursive-subst
70
71cp %{SOURCE1} Makefile
72
73# fix of non UTF-8 files rpmlint warnings
74for fhtml in $(find ./doc -name '*.html' -type f)
75do
76  iconv -f ISO-8859-1 -t UTF-8 "$fhtml" -o "$fhtml".tmp
77  mv -f "$fhtml".tmp "$fhtml"
78  sed -i 's/charset=ISO-8859-1/charset=UTF-8/' "$fhtml"
79done
80
81for f in $(find -name "*'*")
82do
83  mv -v "$f" $(echo "$f" | tr -d "'")
84done
85
86%build
87
88%install
89[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
90
91DESTDIR=$RPM_BUILD_ROOT
92make install BINDIR=$DESTDIR%{_bindir} DESTDIR=$DESTDIR%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}
93cp -a VERSION.xsl $DESTDIR%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}/VERSION.xsl
94ln -s xsl-stylesheets-%{version} \
95        $DESTDIR%{_datadir}/sgml/docbook/xsl-stylesheets
96
97# Don't ship the extensions (bug #177256).
98rm -rf $DESTDIR%{_datadir}/sgml/docbook/xsl-stylesheets/extensions/*
99
100%clean
101[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
102
103%post
104CATALOG=%{_sysconfdir}/xml/catalog
105%{_bindir}/xmlcatalog --noout --add "rewriteSystem" \
106 "http://cdn.docbook.org/release/xsl-nons/%{version}" \
107 "file://%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}" $CATALOG
108%{_bindir}/xmlcatalog --noout --add "rewriteURI" \
109 "http://cdn.docbook.org/release/xsl-nons/%{version}" \
110 "file://%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}" $CATALOG
111%{_bindir}/xmlcatalog --noout --add "rewriteSystem" \
112 "http://cdn.docbook.org/release/xsl-nons/current/" \
113 "file://%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}" $CATALOG
114%{_bindir}/xmlcatalog --noout --add "rewriteURI" \
115 "http://cdn.docbook.org/release/xsl-nons/current/" \
116 "file://%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}" $CATALOG
117#keep the old one sourceforge URIs at least temporarily
118%{_bindir}/xmlcatalog --noout --add "rewriteSystem" \
119 "http://docbook.sourceforge.net/release/xsl/current" \
120 "file://%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}" $CATALOG
121%{_bindir}/xmlcatalog --noout --add "rewriteURI" \
122 "http://docbook.sourceforge.net/release/xsl/current" \
123 "file://%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}" $CATALOG
124 
125%postun
126# remove entries only on removal of package
127if [ "$1" = 0 ]; then
128  CATALOG=%{_sysconfdir}/xml/catalog
129  %{_bindir}/xmlcatalog --noout --del \
130   "file://%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}" $CATALOG
131fi
132
133%files
134%defattr (-,root,root)
135%doc BUGS README TODO doc
136%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}
137%{_datadir}/sgml/docbook/xsl-stylesheets
138
139
140%changelog
141* Thu Mar 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.79.2-1
142- new upstream release.
143- updated Patch1 and 6.
144- imported Patch7 from rawhide.
145
146* Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.78.1-1
147- new upstream release
148- update Patch2 from fedora
149
150* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.77.1-2
151- new upstream release
152
153* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.77.1-1
154- new upstream release
155- add Patch6 (docbook-xsl-mandir.patch) from fedora
156- update Source1 (%{name}.Makefile)
157- update following patches from fedora
158  - Patch1 (docbook-xsl-pagesetup.patch)
159  - Patch2 (docbook-xsl-marginleft.patch)
160  - Patch3 (docbook-xsl-newmethods.patch)
161- update spec file based on fedora package
162  * Tue Jun  5 2012 Ondrej Vasik <ovasik@redhat.com> 1.77.1-2
163  - ship VERSION.xsl file (#829014)
164  * Tue Jun  5 2012 Ondrej Vasik <ovasik@redhat.com> 1.77.1-1
165  - new stable upstream release 1.77.1
166  - defuzz patches
167  * Tue Sep  6 2011 Ondrej Vasik <ovasik@redhat.com> 1.76.1-4
168  - revert previous change, workaround the mandir links issue
169    in buildroot (#727251)
170  * Mon Aug 29 2011 Ondrej Vasik <ovasik@redhat.com> 1.76.1-3
171  - make man.output.in.separate.dir "on" by default (#727251)
172  * Tue Nov 02 2010 Ondrej Vasik <ovasik@redhat.com> 1.76.1-1
173  - new upstream release 1.76.1
174  * Mon Sep 06 2010 Ondrej Vasik <ovasik@redhat.com> 1.76.0-1
175  - new upstream release 1.76.0
176
177* Fri Apr 22 2011 IWAI, Masaharu <iwai@alib.jp> 1.76.1-1
178- new upstream release
179- add Vendor and Distribution tags
180
181* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.75.3-6
182- updated based on FC 1.75.3-5
183  * Fri Dec 18 2009 Ondrej Vasik <ovasik@redhat.com> 1.75.3-5
184  - comment patches purpose
185  - License Copyright only
186  * Mon May 11 2009 Ondrej Vasik <ovasik@redhat.com> 1.75.0-1
187  - New upstream release 1.75.0
188  - update marginleft patch
189  * Mon Feb 23 2009 Ondrej Vasik <ovasik@redhat.com> 1.74.2-2
190  - updated Makefile: do ship .svg images(#486849), xsl
191    stylesheets for website, xhtml-1_1, docbook -> epub
192    convertor
193  * Wed Feb 11 2009 Ondrej Vasik <ovasik@redhat.com> 1.74.0-7
194  - fix broken varlistentry (#479683)
195  * Mon Feb 02 2009 Ondrej Vasik <ovasik@redhat.com> 1.74.0-6
196  - fix improper localization for rtl languages, thanks
197    Muayyad Alsadi(#475077)
198  * Wed Jan 28 2009 Ondrej Vasik <ovasik@redhat.com> 1.74.0-5
199  - fix xsl stylesheets for rtl languages(#475077)
200  * Fri Dec 12 2008 Ondrej Vasik <ovasik@redhat.com> 1.74.0-4
201  - Author_Group "<orgname>" merged between "<surname>"
202    and "<surname>" (#473019)
203  * Wed Aug 06 2008 Kamil Dudka <kdudka@redhat.com> 1.74.0-3
204  - Rediffed all patches to work with patch --fuzz=0
205  * Wed Aug 06 2008 Kamil Dudka <kdudka@redhat.com> 1.74.0-2
206  - Tiny changes in docbook-xsl-newmethods.patch to work with xalan
207    (#452867)
208  * Fri Dec 14 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-9
209  - added fixes for passivetex extension and list-item-body
210    (#161371)
211  * Mon Dec 03 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-6
212  - fixed docbook-xsl-pagesetup.patch to follow Norman Walsh's
213    documentation for nonpassivetex processing(#307001)
214  * Tue Nov 27 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-5
215  - convert all html files in doc to UTF-8 in prep
216    (latest rpmlint gives warnings)
217  - no longer using release in style-xsl dir(#389231)
218
219* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.73.2-5vl5
220- applied new versioning policy, spec in utf-8
221
222* Fri Jan 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.73.2-5vl1
223- updated to 1.73.2 based on Fedora development
224  * Tue Dec 11 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-4
225  - remove entries from xmlcatalog only on removal of package
226    (required because of the last change with droping release
227     -caused drop of catalog entries during update)
228  * Wed Dec 05 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-3
229  - change a few non-constant expressions to constant that
230    could now be handled by passivetex(#366441)
231  - fixed docbook-xsl-pagesetup.patch to follow Norman Walsh's
232    documentation for nonpassivetex processing(#307001)
233    (use passivetex.extensions = 1 option in param.xsl for
234     processing with passivetex)
235  * Fri Sep  7 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-2
236  - Added PreReq of libxml2(#253962)
237
238* Sun Jul 22 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.72.0-3vl1
239- updated to 1.72.0 based on Fedora development
240  * Mon Jun 18 2007 Ondrej Vasik <ovasik@redhat.com> 1.72.0-3
241  - patch fixing #161619 taken from upstream
242  * Tue Jan 23 2007 Tim Waugh <twaugh@redhat.com> 1.72.0-1
243  - 1.72.0.
244  * Fri Jan 19 2007 Tomas Mraz <tmraz@redhat.com> 1.71.1-2
245  - Add new wordml and especially highlighting (which is referenced
246    from html) subdirs to Makefile.
247  * Tue Jan 24 2006 Tim Waugh <twaugh@redhat.com> 1.69.1-5
248  - Don't ship docsrc/* (bug #177256).
249  - Don't ship the extensions (bug #177256).
250
251* Sat Oct  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.69.1-1vl1
252- updated to 1.69.1 based on Fedora development
253
254* Sun Dec 19 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.67.2-2vl1
255- updated to 1.67.2 based on Fedora development
256  * Wed Dec  8 2004 Tim Waugh <twaugh@redhat.com> 1.67.2-2
257  - Prevent expressions in passivetex output from index.xsl (bug #142229).
258  * Thu Dec  2 2004 Tim Waugh <twaugh@redhat.com> 1.67.2-1
259  - No longer need nbsp or listblock patches.
260
261* Tue Jan 27 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.64.1-2vl2
262- patch from Fedora 1.64.1-6
263  * Tue Jan 20 2004 Tim Waugh <twaugh@redhat.com> 1.64.1-6
264  - Fix last margin-left fix (bug #113456).
265  - Reduce instances of itemized/ordered lists having misalignments.
266  * Sun Jan 18 2004 Tim Waugh <twaugh@redhat.com> 1.64.1-5
267  - And another (bug #113456).
268  * Thu Jan 15 2004 Tim Waugh <twaugh@redhat.com> 1.64.1-4
269  - Fixed another instance of bug #113456 in lists layout.
270  * Wed Jan 14 2004 Tim Waugh <twaugh@redhat.com> 1.64.1-3
271  - Hard-code the margin-left work around to expect passivetex (bug #113456).
272
273* Mon Jan  5 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.64.1-2vl1
274- based on Fedora 1.64.1-2
275- fixed Japanese summary
276
277* Sat May 24 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.61.1-1vl1
278- based on Redhat Rawhide 1.61.1-1
279- add Japanese summary and description
280
281* Tue Feb  4 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.60.1-0vl1
282- upstream release
283
284* Tue Nov 26 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.57.0-2vl1
285- based on Redhat Rawhide 1.57.0-2
286
287* Sat Oct 26 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.57.0-0vl1
288- 1.57.0
289
290* Tue Sep 24 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.55.0-0vl3
291- Rebuilded for Vine Linux (add PreReq: docbook-dtd412-xml)
292- based on rawhide 1.50.0 and source updated 1.55.0
293- use better macros
294
295* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
296- automated rebuild
297
298* Thu May 23 2002 Tim Powers <timp@redhat.com>
299- automated rebuild
300
301* Wed May  1 2002 Tim Waugh <twaugh@redhat.com> 1.50.0-1
302- 1.50.0.
303
304* Thu Feb 21 2002 Tim Waugh <twaugh@redhat.com> 1.49-1
305- 1.49.
306- Rebuild in new environment.
307
308* Fri Feb  1 2002 Tim Waugh <twaugh@redhat.com> 1.48-4
309- Put URIs instead of pathnames in the XML catalog.
310
311* Thu Jan 17 2002 Tim Waugh <twaugh@redhat.com> 1.48-3
312- Back to /usr/share/sgml.
313
314* Wed Jan 09 2002 Tim Powers <timp@redhat.com> 1.48-2
315- automated rebuild
316
317* Mon Jan  7 2002 Tim Waugh <twaugh@redhat.com> 1.48-1
318- 1.48.
319
320* Sat Dec  8 2001 Tim Waugh <twaugh@redhat.com> 1.47-2
321- Conflict with PassiveTeX before 1.11.
322
323* Tue Oct 16 2001 Tim Waugh <twaugh@redhat.com> 1.47-1
324- 1.47-experimental.
325
326* Tue Oct  9 2001 Tim Waugh <twaugh@redhat.com> 1.45-2
327- Fix unversioned symlink.
328
329* Mon Oct  8 2001 Tim Waugh <twaugh@redhat.com> 1.45-1
330- XML Catalog entries.
331- Move files to /usr/share/xml.
332
333* Mon Oct  1 2001 Tim Waugh <twaugh@redhat.com> 1.45-0.1
334- 1.45.
335- Built for Red Hat Linux.
336
337* Tue Jun 26 2001 Chris Runge <crunge@pobox.com>
338- 1.40
339
340* Sat Jun 09 2001 Chris Runge <crunge@pobox.com>
341- added extensions and additional doc
342- bin added to doc; the Perl files are for Win32 Perl and so need some
343  conversion first
344
345* Fri Jun 08 2001 Chris Runge <crunge@pobox.com>
346- Initial RPM (based on docbook-style-dsssl RPM)
347- note: no catalog right now (I don't know how to do it; and not sure why
348  it is necessary)
Note: See TracBrowser for help on using the repository browser.