source: projects/specs/trunk/d/docbook-style-dsssl/docbook-style-dsssl-vl.spec @ 521

Revision 521, 5.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:        Norman Walsh's modular stylesheets for DocBook.
2Summary(ja):    Norman Walsh 作の DocBook 用スタイルシート
3Name:           docbook-style-dsssl
4Version:        1.79
5Release:        11%{?_dist_release}
6Group:          Applications/Text
7
8License:        Copyright only
9URL:            http://docbook.sourceforge.net/
10
11Source0:        http://prdownloads.sourceforge.net/docbook/docbook-dsssl-%{version}.tar.gz
12Source1:        %{name}.Makefile
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15BuildArch:      noarch
16
17%define openjadever 1.3.2
18Requires: openjade = %{openjadever}
19Requires: docbook-dtds
20Requires: sgml-common
21Requires(post): sgml-common
22Requires(preun): sgml-common
23Conflicts:      docbook-utils < 0.6.9
24
25%description
26These DSSSL stylesheets allow to convert any DocBook document to another
27printed (for example, RTF or PostScript) or online (for example, HTML) format.
28They are highly customizable.
29
30%prep
31%setup -q -n docbook-dsssl-%{version}
32cp %{SOURCE1} Makefile
33
34
35%build
36
37
38%install
39[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
40
41DESTDIR=$RPM_BUILD_ROOT
42make install BINDIR=$DESTDIR%{_bindir} DESTDIR=$DESTDIR%{_datadir}/sgml/docbook/dsssl-stylesheets-%{version} MANDIR=$DESTDIR%{_mandir}
43cd ..
44ln -s dsssl-stylesheets-%{version} $DESTDIR%{_datadir}/sgml/docbook/dsssl-stylesheets
45
46
47%clean
48[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
49
50%post
51rel=$(echo /etc/sgml/sgml-docbook-3.0-*.cat)
52rel=${rel##*-}
53rel=${rel%.cat}
54for centralized in /etc/sgml/*-docbook-*.cat
55do
56       /usr/bin/install-catalog --remove $centralized \
57               /usr/share/sgml/docbook/dsssl-stylesheets-*/catalog \
58               >/dev/null 2>/dev/null
59done
60
61for centralized in /etc/sgml/*-docbook-*$rel.cat
62do
63       /usr/bin/install-catalog --add $centralized \
64               /usr/share/sgml/openjade-%{openjadever}/catalog \
65               > /dev/null 2>/dev/null
66       /usr/bin/install-catalog --add $centralized \
67               /usr/share/sgml/docbook/dsssl-stylesheets-%{version}/catalog \
68               > /dev/null 2>/dev/null
69done
70
71
72%preun
73if [ "$1" = "0" ]; then
74  for centralized in /etc/sgml/*-docbook-*.cat
75  do   /usr/bin/install-catalog --remove $centralized /usr/share/sgml/openjade-%{openjadever}/catalog > /dev/null 2>/dev/null
76    /usr/bin/install-catalog --remove $centralized /usr/share/sgml/docbook/dsssl-stylesheets-%{version}/catalog > /dev/null 2>/dev/null
77  done
78fi
79exit 0
80
81
82%files
83%defattr (-,root,root)
84%doc BUGS README RELEASE-NOTES.txt ChangeLog WhatsNew
85%{_bindir}/collateindex.pl
86%{_datadir}/sgml/docbook/dsssl-stylesheets-%{version}
87%{_datadir}/sgml/docbook/dsssl-stylesheets
88%{_mandir}/man1/collateindex.pl.1*
89
90
91%changelog
92* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.79-11
93- based on FC 1.79-10
94  * Tue Feb 02 2010 Ondrej Vasik <ovasik@redhat.com> - 1.79-10
95  - fix merge review issues(#225703)
96  * Fri Dec 18 2009 Ondrej Vasik <ovasik@redhat.com> - 1.79-9
97  - License Copyright only
98  * Fri Aug 28 2009 Ondrej Vasik <ovasik@redhat.com> - 1.79-8
99  - ship manpage for collateindex.pl
100  - preserve attributes and timestamps in Makefile
101  * Thu Nov 10 2005 Tim Waugh <twaugh@redhat.com> 1.79-2
102  - Ship olink.dsl (bug #172523).
103
104* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.79-1vl5
105- applied new versioning policy, spec in utf-8
106- s/Copyright/License/
107
108* Thu Jun  9 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.79-1vl1
109- new upstream release
110- No longer need articleinfo patch
111- added Japanese summary
112
113* Wed Jun  4 2003 Jun NISHII <jun@vinelinux.org> 1.78-2vl2
114- keep silence in preun
115
116* Sat May  3 2003 IWAI Masaharu <iwai@alib.jp> 1.78-2vl1
117- update %%post and %%preun script from rawhide 1.78-2
118- source update to 1.78
119- drop docbook-dsssl-1.76-seealso.patch (Patch1): upstream merged
120- update Makefile (Source1)
121- require newest openjade (version 1.3.2)
122
123* Wed Nov 27 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.77-0vl1
124- source update to 1.77
125- Don't apply patch2
126- require newest openjade (version 1.3.1)
127
128* Tue Sep 24 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.76-6vl1
129- update to 1.76 based on rawhide 1.76-6
130- Change URL
131
132* Thu Oct 11 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.64-3vl1
133- Rebuild for Vine.
134
135* Wed Jul 25 2001 Bill Nottingham <notting@redhat.com> 1.64-3
136- bump release
137
138* Thu May  9 2001 Tim Waugh <twaugh@redhat.com> 1.64-2
139- Make an unversioned dsssl-stylesheets symbolic link.
140
141* Wed May  2 2001 Tim Waugh <twaugh@redhat.com> 1.64-1
142- 1.64 (fixes #38095).
143- Fix up post/preun scripts so that we don't get duplicate entries with
144  different versions on upgrade.
145
146* Sun Mar 25 2001 Tim Waugh <twaugh@redhat.com> 1.59-10
147- Fix up Makefile (patch from SATO Satoru).
148- Change postun to preun.
149- Make preun conditional on remove rather than upgrade.
150
151* Tue Mar  6 2001 Tim Waugh <twaugh@redhat.com>
152- PreReq docbook-dtd-sgml (it was a requirement before), so that the
153  scripts work right.
154
155* Tue Feb 20 2001 Tim Waugh <twaugh@redhat.com>
156- Change Requires(...) to PreReq at Preston's request.
157- PreReq at least openjade-1.3-12, so that its catalogs get installed.
158
159* Wed Jan 24 2001 Tim Waugh <twaugh@redhat.com>
160- Make scripts quieter.
161
162* Tue Jan 23 2001 Tim Waugh <twaugh@redhat.com>
163- Last fix was wrong; corrected (require openjade 1.3).
164
165* Fri Jan 19 2001 Tim Waugh <twaugh@redhat.com>
166- Require jade not openjade (bug #24306).
167
168* Mon Jan 15 2001 Tim Waugh <twaugh@redhat.com>
169- Don't play so many macro games.
170- Change requirement on /usr/bin/install-catalog to sgml-common.
171- Be sure to own dsssl-stylesheets-1.59 directory.
172
173* Mon Jan 08 2001 Tim Waugh <twaugh@redhat.com>
174- Change group.
175- openjade not jade.
176- %%{_tmppath}.
177- rm before install.
178- Change Copyright: to License:.
179- Remove Packager: line.
180
181* Mon Jan 08 2001 Tim Waugh <twaugh@redhat.com>
182- Based on Eric Bischoff's new-trials packages.
Note: See TracBrowser for help on using the repository browser.