source: projects/specs/trunk/d/docbook-dtds/docbook-dtds-vl.spec @ 521

Revision 521, 20.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name: docbook-dtds
2Version: 1.0
3Release: 53%{?_dist_release}
4Group: Applications/Text
5
6Summary: SGML and XML document type definitions for DocBook.
7Summary(ja): DocBook 向け SGML/XML DTD
8
9License: Copyright only
10URL: http://www.oasis-open.org/docbook/
11
12Obsoletes: docbook-dtd30-sgml < %{version}-%{release}
13Obsoletes: docbook-dtd31-sgml < %{version}-%{release}
14Obsoletes: docbook-dtd40-sgml < %{version}-%{release}
15Obsoletes: docbook-dtd41-sgml < %{version}-%{release}
16Obsoletes: docbook-dtd412-xml < %{version}-%{release}
17
18Provides: docbook-dtd-xml = %{version}-%{release}
19Provides: docbook-dtd-sgml = %{version}-%{release}
20Provides: docbook-dtd30-sgml = %{version}-%{release}
21Provides: docbook-dtd31-sgml = %{version}-%{release}
22Provides: docbook-dtd40-sgml = %{version}-%{release}
23Provides: docbook-dtd41-sgml = %{version}-%{release}
24Provides: docbook-dtd412-xml = %{version}-%{release}
25Provides: docbook-dtd42-sgml = %{version}-%{release}
26Provides: docbook-dtd42-xml = %{version}-%{release}
27Provides: docbook-dtd43-sgml = %{version}-%{release}
28Provides: docbook-dtd43-xml = %{version}-%{release}
29Provides: docbook-dtd44-sgml = %{version}-%{release}
30Provides: docbook-dtd44-xml = %{version}-%{release}
31Provides: docbook-dtd45-sgml = %{version}-%{release}
32Provides: docbook-dtd45-xml = %{version}-%{release}
33
34Requires(post): /usr/bin/xmlcatalog
35Requires(postun): /usr/bin/xmlcatalog
36Requires(post): /bin/chmod
37Requires: sgml-common >= 0.6.3-4
38Requires: xml-common >= 0.6.3-8
39
40BuildRoot: %{_tmppath}/%{name}-%{version}-root
41
42BuildArch: noarch
43Source0: http://www.oasis-open.org/docbook/sgml/3.0/docbk30.zip
44Source1: http://www.oasis-open.org/docbook/sgml/3.1/docbk31.zip
45Source2: http://www.oasis-open.org/docbook/sgml/4.0/docbk40.zip
46Source3: http://www.oasis-open.org/docbook/sgml/4.1/docbk41.zip
47Source4: http://www.oasis-open.org/docbook/xml/4.1.2/docbkx412.zip
48Source5: http://www.oasis-open.org/docbook/sgml/4.2/docbook-4.2.zip
49Source6: http://www.oasis-open.org/docbook/xml/4.2/docbook-xml-4.2.zip
50Source7: http://www.docbook.org/sgml/4.3/docbook-4.3.zip
51Source8: http://www.docbook.org/xml/4.3/docbook-xml-4.3.zip
52Source9: http://www.docbook.org/sgml/4.4/docbook-4.4.zip
53Source10: http://www.docbook.org/xml/4.4/docbook-xml-4.4.zip
54Source11: http://www.docbook.org/sgml/4.5/docbook-4.5.zip
55Source12: http://www.docbook.org/xml/4.5/docbook-xml-4.5.zip
56# fix old catalog files
57Patch0: docbook-dtd30-sgml-1.0.catalog.patch
58Patch1: docbook-dtd31-sgml-1.0.catalog.patch
59Patch2: docbook-dtd40-sgml-1.0.catalog.patch
60Patch3: docbook-dtd41-sgml-1.0.catalog.patch
61Patch4: docbook-dtd42-sgml-1.0.catalog.patch
62# fix euro sign in 4.2 dtds
63Patch5: docbook-4.2-euro.patch
64# Fix ISO entities in 4.3/4.4/4.5 SGML
65Patch6: docbook-dtds-ents.patch
66# Use system rewrite for web URL's in sgml catalogs to prevent reading from the network(#478680)
67Patch7: docbook-sgml-systemrewrite.patch
68# use XML at the end of public identificators of XML 4.1.2 ISO entities
69Patch8: docbook-dtd412-entities.patch
70
71BuildRequires: unzip
72
73%define openjadever 1.3.2
74#PreReq: openjade = %{openjadever}
75%define version_list "{3,4}.{0,1}-sgml 4.1.2-xml 4.{2,3,4,5}-{sgml,xml}"
76
77
78%description
79The DocBook Document Type Definition (DTD) describes the syntax of
80technical documentation texts (articles, books and manual pages).
81This syntax is XML-compliant and is developed by the OASIS consortium.
82This package contains SGML and XML versions of the DocBook DTD.
83
84
85%prep
86%setup -c -T
87# DocBook V3.0
88mkdir 3.0-sgml
89cd 3.0-sgml
90unzip %{SOURCE0}
91%patch0 -p0 -b docbook.cat
92cd ..
93
94# DocBook V3.1
95mkdir 3.1-sgml
96cd 3.1-sgml
97unzip %{SOURCE1}
98%patch1 -p0 -b docbook.cat
99cd ..
100
101# DocBook V4.0
102mkdir 4.0-sgml
103cd 4.0-sgml
104unzip %{SOURCE2}
105%patch2 -p0 -b docbook.cat
106cd ..
107
108# DocBook V4.1
109mkdir 4.1-sgml
110cd 4.1-sgml
111unzip %{SOURCE3}
112%patch3 -p0 -b docbook.cat
113cd ..
114
115# DocBook XML V4.1.2
116mkdir 4.1.2-xml
117cd 4.1.2-xml
118unzip %{SOURCE4}
119cd ..
120
121# DocBook V4.2
122mkdir 4.2-sgml
123cd 4.2-sgml
124unzip %{SOURCE5}
125%patch4 -p0 -b docbook.cat
126cd ..
127
128# DocBook XML V4.2
129mkdir 4.2-xml
130cd 4.2-xml
131unzip %{SOURCE6}
132cd ..
133
134# DocBook V4.3
135mkdir 4.3-sgml
136cd 4.3-sgml
137unzip %{SOURCE7}
138cd ..
139
140# DocBook XML V4.3
141mkdir 4.3-xml
142cd 4.3-xml
143unzip %{SOURCE8}
144cd ..
145
146# DocBook V4.4
147mkdir 4.4-sgml
148cd 4.4-sgml
149unzip %{SOURCE9}
150cd ..
151
152# DocBook XML V4.4
153mkdir 4.4-xml
154cd 4.4-xml
155unzip %{SOURCE10}
156cd ..
157
158# DocBook v4.5
159mkdir 4.5-sgml
160cd 4.5-sgml
161unzip %{SOURCE11}
162cd ..
163
164# DocBook XML v4.5
165mkdir 4.5-xml
166cd 4.5-xml
167unzip %{SOURCE12}
168cd ..
169
170# Fix &euro; in SGML.
171%patch5 -p1
172
173# Fix ISO entities in 4.3/4.4/4.5 SGML
174%patch6 -p1
175
176# Rewrite SYSTEM to use local catalog instead web ones (#478680)
177%patch7 -p1
178
179# Add XML to the end of public identificators of 4.1.2 XML entities
180%patch8 -p1
181
182# Increase NAMELEN (bug #36058, bug #159382).
183sed -e's,\(NAMELEN\s\+\)44\(\s\*\)\?,\1256,' -i.namelen */docbook.dcl
184
185# fix of \r\n issue from rpmlint
186sed -i 's/\r//' */*.txt
187
188
189if [ `id -u` -eq 0 ]; then
190  chown -R root:root .
191  chmod -R a+rX,g-w,o-w .
192fi
193
194
195%build
196
197
198%install
199rm -rf $RPM_BUILD_ROOT
200
201# Symlinks
202mkdir -p $RPM_BUILD_ROOT/etc/sgml
203for fmt in sgml xml; do
204  ln -s $fmt-docbook-4.5-%{version}-%{release}.cat \
205     $RPM_BUILD_ROOT/etc/sgml/$fmt-docbook.cat
206done
207
208eval set %{version_list}
209for dir
210do
211  cd $dir
212  fmt=${dir#*-} vvr=${dir%%-*}-%{version}-%{release}
213  DESTDIR=$RPM_BUILD_ROOT%{_datadir}/sgml/docbook/$fmt-dtd-$vvr
214  case $fmt in
215    sgml)   mkdir -p $DESTDIR ; install *.dcl $DESTDIR ;;
216    xml)    mkdir -p $DESTDIR/ent ; install ent/* $DESTDIR/ent ;;
217  esac
218  install *.dtd *.mod $DESTDIR
219  install docbook.cat $DESTDIR/catalog
220  cd ..
221  # File for %%ghost
222  touch $RPM_BUILD_ROOT/etc/sgml/$fmt-docbook-$vvr.cat
223done
224
225
226%clean
227rm -rf $RPM_BUILD_ROOT
228
229
230%post
231catcmd='%{_bindir}/xmlcatalog --noout'
232xmlcatalog=%{_datadir}/sgml/docbook/xmlcatalog
233
234## Clean up pre-docbook-dtds mess caused by broken trigger.
235for v in 3.0 3.1 4.0 4.1 4.2
236do
237  if [ -f /etc/sgml/sgml-docbook-$v.cat ]
238  then
239    $catcmd --sgml --del /etc/sgml/sgml-docbook-$v.cat \
240      %{_datadir}/sgml/openjade-1.3.1/catalog 2>/dev/null
241  fi
242done
243
244# The STYLESHEETS/catalog command is for the case in which the style sheets
245# were installed after another DTD but before this DTD
246for STYLESHEETS in %{_datadir}/sgml/docbook/dsssl-stylesheets-*; do : ; done
247case $STYLESHEETS in
248  *-"*") STYLESHEETS= ;;
249esac
250eval set %{version_list}
251for dir
252do
253  fmt=${dir#*-} ver=${dir%%-*} vvr=$ver-%{version}-%{release}
254  sgmldir=%{_datadir}/sgml/docbook/$fmt-dtd-$vvr
255  ## SGML catalog
256  # Update the centralized catalog corresponding to this version of the DTD
257  for cat_dir in %{_datadir}/sgml/sgml-iso-entities-8879.1986 $sgmldir $STYLESHEETS; do
258    $catcmd --sgml --add /etc/sgml/$fmt-docbook-$vvr.cat $cat_dir/catalog
259  done
260  ## XML catalog
261  if [ $fmt = xml -a -w $xmlcatalog ]; then
262    while read f desc; do
263      case $ver in 4.[45]) f=${f/-/} ;; esac
264      $catcmd --add public "$desc" $sgmldir/$f $xmlcatalog
265    done <<ENDENT
266      ent/iso-pub.ent   ISO 8879:1986//ENTITIES Publishing//EN
267      ent/iso-grk1.ent  ISO 8879:1986//ENTITIES Greek Letters//EN
268      dbpoolx.mod       -//OASIS//ELEMENTS DocBook XML Information Pool V$ver//EN
269      ent/iso-box.ent   ISO 8879:1986//ENTITIES Box and Line Drawing//EN
270      docbookx.dtd      -//OASIS//DTD DocBook XML V$ver//EN
271      ent/iso-grk3.ent  ISO 8879:1986//ENTITIES Greek Symbols//EN
272      ent/iso-amsn.ent  ISO 8879:1986//ENTITIES Added Math Symbols: Negated Relations//EN
273      ent/iso-num.ent   ISO 8879:1986//ENTITIES Numeric and Special Graphic//EN
274      dbcentx.mod       -//OASIS//ENTITIES DocBook XML Character Entities V$ver//EN
275      ent/iso-grk4.ent  ISO 8879:1986//ENTITIES Alternative Greek Symbols//EN
276      dbnotnx.mod       -//OASIS//ENTITIES DocBook XML Notations V$ver//EN
277      ent/iso-dia.ent   ISO 8879:1986//ENTITIES Diacritical Marks//EN
278      ent/iso-grk2.ent  ISO 8879:1986//ENTITIES Monotoniko Greek//EN
279      dbgenent.mod      -//OASIS//ENTITIES DocBook XML Additional General Entities V$ver//EN
280      dbhierx.mod       -//OASIS//ELEMENTS DocBook XML Document Hierarchy V$ver//EN
281      ent/iso-amsa.ent  ISO 8879:1986//ENTITIES Added Math Symbols: Arrow Relations//EN
282      ent/iso-amso.ent  ISO 8879:1986//ENTITIES Added Math Symbols: Ordinary//EN
283      ent/iso-cyr1.ent  ISO 8879:1986//ENTITIES Russian Cyrillic//EN
284      ent/iso-tech.ent  ISO 8879:1986//ENTITIES General Technical//EN
285      ent/iso-amsc.ent  ISO 8879:1986//ENTITIES Added Math Symbols: Delimiters//EN
286      soextblx.dtd      -//OASIS//DTD XML Exchange Table Model 19990315//EN
287      calstblx.dtd      -//OASIS//DTD DocBook XML CALS Table Model V$ver//EN
288      ent/iso-lat1.ent  ISO 8879:1986//ENTITIES Added Latin 1//EN
289      ent/iso-amsb.ent  ISO 8879:1986//ENTITIES Added Math Symbols: Binary Operators//EN
290      ent/iso-lat2.ent  ISO 8879:1986//ENTITIES Added Latin 2//EN
291      ent/iso-amsr.ent  ISO 8879:1986//ENTITIES Added Math Symbols: Relations//EN
292      ent/iso-cyr2.ent  ISO 8879:1986//ENTITIES Non-Russian Cyrillic//EN
293ENDENT
294    for f in System URI; do
295      $catcmd --add rewrite$f "http://www.oasis-open.org/docbook/xml/$ver" \
296        $sgmldir $xmlcatalog
297    done
298  fi
299done
300
301# Historic versions of this scriptlet contained the following comment:
302# <quote>
303# Fix up SGML super catalog so that there isn't an XML DTD before an
304# SGML one.  We need to do this (*sigh*) because xmlcatalog messes up
305# the order of the lines, and SGML tools don't like to see XML things
306# they aren't expecting.
307# </quote>
308# But the code that followed just found the first XML DTD and the first
309# SGML DTD, swappinmg these two lines if the XML one preceded.
310# But that only ensures that there is an SGML DTD before all XML ones.
311# No one complained, so either this was enough, or the buggy SGML tools
312# are long dead, or their users do not use bugzilla.
313# Anyway, the following code, introduced in 1.0-46, does better: it ensures
314# that all XML DTDs are after all SGML ones, by moving them to the end.
315sed -ni '
316  /xml-docbook/ H
317  /xml-docbook/ !p
318  $ {
319          g
320          s/^\n//p
321  }
322  ' /etc/sgml/catalog
323
324# Finally, make sure everything in /etc/sgml is readable!
325/bin/chmod a+r /etc/sgml/*
326
327
328%postun
329catcmd='%{_bindir}/xmlcatalog --noout'
330xmlcatalog=%{_datadir}/sgml/docbook/xmlcatalog
331entities="
332ent/iso-pub.ent
333ent/iso-grk1.ent
334dbpoolx.mod
335ent/iso-box.ent
336docbookx.dtd
337ent/iso-grk3.ent
338ent/iso-amsn.ent
339ent/iso-num.ent
340dbcentx.mod
341ent/iso-grk4.ent
342dbnotnx.mod
343ent/iso-dia.ent
344ent/iso-grk2.ent
345dbgenent.mod
346dbhierx.mod
347ent/iso-amsa.ent
348ent/iso-amso.ent
349ent/iso-cyr1.ent
350ent/iso-tech.ent
351ent/iso-amsc.ent
352soextblx.dtd
353calstblx.dtd
354ent/iso-lat1.ent
355ent/iso-amsb.ent
356ent/iso-lat2.ent
357ent/iso-amsr.ent
358ent/iso-cyr2.ent
359"
360eval set %{version_list}
361for dir
362do
363  fmt=${dir#*-} ver=${dir%%-*} vvr=$ver-%{version}-%{release}
364  sgmldir=%{_datadir}/sgml/docbook/$fmt-dtd-$vvr
365  ## SGML catalog
366  # Update the centralized catalog corresponding to this version of the DTD
367  $catcmd --sgml --del /etc/sgml/catalog /etc/sgml/$fmt-docbook-$vvr.cat
368  rm -f /etc/sgml/$fmt-docbook-$vvr.cat
369  ## XML catalog
370  if [ $fmt = xml -a -w $xmlcatalog ]; then
371    for f in $entities; do
372      case $ver in 4.[45]) f=${f/-/} ;; esac
373      $catcmd --del $sgmldir/$f $xmlcatalog
374    done
375    $catcmd --del $sgmldir $xmlcatalog
376  fi
377done
378
379# See the comment attached to this command in the %%post scriptlet.
380sed -ni '
381  /xml-docbook/ H
382  /xml-docbook/ !p
383  $ {
384          g
385          s/^\n//p
386  }
387  ' /etc/sgml/catalog
388
389
390%triggerin -- openjade >= %{openjadever}
391eval set %{version_list}
392for dir
393do
394  fmt=${dir#*-} ver=${dir%%-*} vvr=$ver-%{version}-%{release}
395  %{_bindir}/xmlcatalog --sgml --noout --add /etc/sgml/$fmt-docbook-$vvr.cat \
396    %{_datadir}/sgml/openjade-%{openjadever}/catalog
397done
398
399
400%triggerun -- openjade >= %{openjadever}
401[ $2 = 0 ] || exit 0
402eval set %{version_list}
403for dir
404do
405  fmt=${dir#*-} ver=${dir%%-*} vvr=$ver-%{version}-%{release}
406  %{_bindir}/xmlcatalog --sgml --noout --del /etc/sgml/$fmt-docbook-$vvr.cat \
407    %{_datadir}/sgml/openjade-%{openjadever}/catalog
408done
409
410
411%files
412%defattr (-,root,root)
413%doc --parents 3.1-sgml/ChangeLog
414%doc --parents 4.1-sgml/ChangeLog
415%doc --parents */*.txt
416%config(noreplace) /etc/sgml/sgml-docbook.cat
417%config(noreplace) /etc/sgml/xml-docbook.cat
418%{_datadir}/sgml/docbook/sgml-dtd-3.0-%{version}-%{release}
419%{_datadir}/sgml/docbook/sgml-dtd-3.1-%{version}-%{release}
420%{_datadir}/sgml/docbook/sgml-dtd-4.0-%{version}-%{release}
421%{_datadir}/sgml/docbook/sgml-dtd-4.1-%{version}-%{release}
422%{_datadir}/sgml/docbook/sgml-dtd-4.2-%{version}-%{release}
423%{_datadir}/sgml/docbook/sgml-dtd-4.3-%{version}-%{release}
424%{_datadir}/sgml/docbook/sgml-dtd-4.4-%{version}-%{release}
425%{_datadir}/sgml/docbook/sgml-dtd-4.5-%{version}-%{release}
426%{_datadir}/sgml/docbook/xml-dtd-4.1.2-%{version}-%{release}
427%{_datadir}/sgml/docbook/xml-dtd-4.2-%{version}-%{release}
428%{_datadir}/sgml/docbook/xml-dtd-4.3-%{version}-%{release}
429%{_datadir}/sgml/docbook/xml-dtd-4.4-%{version}-%{release}
430%{_datadir}/sgml/docbook/xml-dtd-4.5-%{version}-%{release}
431%ghost %config(noreplace) /etc/sgml/*ml-docbook-*-%{version}-%{release}.cat
432
433%changelog
434* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0-53
435- updated based on FC 1.0-52
436  * Wed Mar 03 2010 Ondrej Vasik <ovasik@redhat.com> - 1.0-52
437  - remove explicit lib dependency (#225700)
438  * Wed Mar 03 2010 Ondrej Vasik <ovasik@redhat.com> - 1.0-51
439  - fix Merge Review comments (#225700) - unversion requires,
440    fix buildroot
441  * Thu Dec 17 2009 Ondrej Vasik <ovasik@redhat.com> - 1.0-50
442  - comment patches
443  - License: Copyright only
444  * Tue Oct 27 2009 Ondrej Vasik <ovasik@redhat.com> - 1.0-49
445  - do not obsolete self
446  * Mon May 11 2009 Ondrej Vasik <ovasik@redhat.com> - 1.0-47
447  - add requires(post) for /bin/chmod (#498680)
448  * Wed Apr  8 2009 Stepan Kasal <skasal@redhat.com> - 1.0-46
449  - remove perl dependency (#462997)
450  - make %%install and the scriptlets more compact
451  * Thu Feb 19 2009 Ondrej Vasik <ovasik@redhat.com> - 1.0.44
452  - fix ISO entities for 4.5 SGML, use XML at the end of
453    public identificators of XML 4.1.2 ISO entities
454  * Thu Feb 19 2009 Ondrej Vasik <ovasik@redhat.com> - 1.0-43
455  - register sgml catalogs before xml catalogs in openjade
456    (#486257)
457  * Thu Feb 05 2009 Ondrej Vasik <ovasik@redhat.com> - 1.0-42
458  - Use SYSTEM rewrite for web URL's in sgml catalogs to
459    prevent reading from the network(#478680)
460  * Fri Sep 26 2008 Ondrej Vasik <ovasik@redhat.com> - 1.0-41
461  - Removed openjade requirement - registration reworked to
462    triggers(#234345)
463  * Fri Jul 11 2008 Ondrej Vasik <ovasik@redhat.com> - 1.0-38
464  - fixed typo in post scriptlet(causing mishandling of DocBook
465    4.4 and 4.5 DTDs,#453513)
466  * Tue Oct 23 2007 Ondrej Vasik <ovasik@redhat.com> - 1.0-34
467  - corrected most of rpmlint issues
468  - (PreReq, tab/spaces , wrong permissions on some files,
469  -  wrong file end encoding of txt files, non config files
470  -  in /etc, some requires issues, versioned provides and
471  -  obsoletes, fixed license tag)
472  * Fri Oct 19 2007 Ondrej Vasik <ovasik@redhat.com> - 1.0-33
473  - fixed wrong attributes for docs(#326581)
474  * Mon Oct  1 2007 Ondrej Vasik <ovasik@redhat.com> - 1.0-32
475  - DocBook 4.5 SGML and XML.(#312941)
476  * Wed Jun 20 2007 Ondrej Vasik <ovasik@redhat.com> - 1.0-31
477  - .cat files touched and ghosted to be owned by package
478  - (bug #193475)
479  * Tue Dec 13 2005 Tim Waugh <twaugh@redhat.com> 1.0-30
480  - Fix ISO entities in 4.3/4.4 SGML.
481
482* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.0-27vl5
483- applied new versioning policy, spec in utf-8
484
485* Thu Jun  9 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0-27vl1
486- based on Fedora 1.0-27
487  * Thu Jun  2 2005 Tim Waugh <twaugh@redhat.com> 1.0-27
488  - Increase NAMELEN (bug #36058, bug #159382).
489  * Tue Feb  1 2005 Tim Waugh <twaugh@redhat.com> 1.0-26
490  - DocBook 4.4 SGML and XML.
491  * Mon Sep 13 2004 Tim Waugh <twaugh@redhat.com> 1.0-25
492  - DocBook 4.3 SGML and XML (bug #131861).
493- added Japanese summary
494
495* Sat Mar 27 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0-24vl1
496- based on Fedora 1.0-24
497  * Mon Feb 23 2004 Tim Waugh <twaugh@redhat.com> 1.0-24
498  - Use ':' instead of '.' as separator for chown.
499
500* Tue Sep 30 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0-22vl2
501- fixed %postun to remove old version /etc/sgml-*.cat
502
503* Mon Sep 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0-22vl1
504- based on Rawhide 1.0-22.1
505  * Wed Aug  6 2003 Tim Waugh <twaugh@redhat.com> 1.0-22
506  - More work-arounds for buggy xmlcatalog.
507  * Tue Jul 15 2003 Tim Waugh <twaugh@redhat.com> 1.0-21
508  - Fix &euro; in SGML tools.
509  * Wed May 28 2003 Tim Waugh <twaugh@redhat.com> 1.0-20
510  - Fix summary and description (bug #73005).
511
512* Tue Jun  3 2003 Jun Nishii <jun@vinelinux.org> 1.0-19vl2
513- fixed some typo in scripts
514- use for loop in scripts
515
516* Sat May  3 2003 IWAI Masaharu <iwai@alib.jp> 1.0-19vl1
517- update %%post and %%postun script from rawhide 1.0-19
518- build with openjade-1.3.2
519
520* Mon Nov 25 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0-15vl2
521- use PreReq rather than dual Conflicts (it's too bad for apt)
522
523* Mon Nov 25 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0-15vl1
524- based on 1.0-15 from Rawhide and rebuilt for Vine Linux
525
526* Wed Nov 20 2002 Tim Powers <timp@redhat.com>
527- rebuild in current collinst
528
529* Mon Jul 30 2002 Tim Waugh <twaugh@redhat.com> 1.0-14
530- Fix typo in XML catalog (Eric Raymond).
531
532* Tue Jul 23 2002 Tim Waugh <twaugh@redhat.com> 1.0-13
533- Provide docbook-dtd42-sgml and docbook-dtd42-xml.
534
535* Thu Jul 18 2002 Tim Waugh <twaugh@redhat.com> 1.0-12
536- Fix up SGML super catalog if necessary.
537
538* Wed Jul 17 2002 Tim Waugh <twaugh@redhat.com> 1.0-11
539- Add DocBook V4.2.
540
541* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.0-10
542- automated rebuild
543
544* Thu May 23 2002 Tim Powers <timp@redhat.com> 1.0-9
545- automated rebuild
546
547* Thu Mar 14 2002 Tim Waugh <twaugh@redhat.com> 1.0-8
548- Allow for shared /usr/share (bug #61147).
549
550* Tue Mar 12 2002 Tim Waugh <twaugh@redhat.com> 1.0-7
551- Make sure that the config files are readable.
552
553* Fri Mar  8 2002 Tim Waugh <twaugh@redhat.com> 1.0-6
554- Make %%post scriptlet quiet (bug #60820).
555
556* Thu Feb 21 2002 Tim Waugh <twaugh@redhat.com> 1.0-5
557- Make sure to clean up old catalog files.
558
559* Thu Feb 21 2002 Tim Waugh <twaugh@redhat.com> 1.0-3
560- Rebuild in new environment.
561
562* Mon Jan 28 2002 Tim Waugh <twaugh@redhat.com> 1.0-2
563- Prepare for openjade 1.3.1.
564
565* Thu Jan 17 2002 Tim Waugh <twaugh@redhat.com> 1.0-1
566- Merged all the DTD packages into one (bug #58448).
567- Use /usr/share/sgml exclusively.
568- Prevent catalog files from disappearing on upgrade (bug #58463).
569
570* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
571- automated rebuild
572
573* Mon Nov  5 2001 Tim Waugh <twaugh@redhat.com> 1.0-8
574- Hmm, still need to depend on sgml-common for /etc/sgml.
575
576* Mon Nov  5 2001 Tim Waugh <twaugh@redhat.com> 1.0-7
577- Use xmlcatalog (libxml2) instead of install-catalog (sgml-common) in
578  scriptlets.
579- Conflict with install-catalog if it can't handle quotes in catalogs.
580- Use release number in centralized catalog name, so that the scriptlets
581  work properly.
582
583* Wed Oct 10 2001 Tim Waugh <twaugh@redhat.com> 1.0-6
584- Change some Requires: to PreReq:s (bug #54507).
585
586* Mon Oct  8 2001 Tim Waugh <twaugh@redhat.com> 1.0-5
587- Use release number in the installed directory name, so that the
588  package scripts work.
589
590* Sat Oct  6 2001 Tim Waugh <twaugh@redhat.com> 1.0-4
591- Restore the /etc/sgml/catalog manipulation again.
592- Oops, fix DTD path.
593
594* Sat Oct  6 2001 Tim Waugh <twaugh@redhat.com> 1.0-2
595- Require xml-common.  Use xmlcatalog.
596- Move files to /usr/share/xml.
597
598* Tue Jun 12 2001 Tim Waugh <twaugh@redhat.com> 1.0-1
599- Build for Red Hat Linux.
600
601* Sat Jun 09 2001 Chris Runge <crunge@pobox.com>
602- Provides: docbook-dtd-xml (not docbook-dtd-sgml)
603- undo catalog patch and dbcentx patch (this resulted in an effectively
604  broken DTD when the document was processed with XSL stylesheets); added a
605  symbolic link to retain docbook.cat -> catalog; added ent
606- added ChangeLog to doc
607
608* Fri Jun 08 2001 Chris Runge <crunge@pobox.com>
609- created a 4.1.2 version
610- update required a change to OTHERCAT in postun
611- update required a change to the Makefile patch (no dbgenent.ent any more,
612  apparently)
613
614* Wed Jan 24 2001 Tim Waugh <twaugh@redhat.com>
615- Scripts require fileutils.
616- Make scripts quieter.
617
618* Mon Jan 15 2001 Tim Waugh <twaugh@redhat.com>
619- Don't play so many macro games.
620- Don't use 'rpm' in post scripts.
621- Be sure to own xml-dtd-4.1 directory.
622
623* Sun Jan 14 2001 Tim Waugh <twaugh@redhat.com>
624- Change requirement on /usr/bin/install-catalog to sgml-common.
625
626* Tue Jan 09 2001 Tim Waugh <twaugh@redhat.com>
627- Change group.
628- Use %%{_tmppath}.
629- Correct typo.
630- rm before install
631- openjade not jade.
632- Build requires unzip.
633- Require install-catalog for post and postun.
634- Change Copyright: to License:.
635- Remove Packager: line.
636
637* Tue Jan 09 2001 Tim Waugh <twaugh@redhat.com>
638- Based on Eric Bischoff's new-trials packages.
Note: See TracBrowser for help on using the repository browser.