source: projects/specs/trunk/d/dnsmasq/dnsmasq-vl.spec @ 12346

Revision 12346, 9.7 KB checked in by tomop, 4 years ago (diff)

updated 14 packages

ca-certificates-2020.2.40-1

dmidecode-3.2-1

dnsmasq-2.80-2

golang-1.14.1-1

gthumb-3.8.3-1

haveged-1.9.8-1

iw-5.4-1

liblockfile-1.14-6

libnl3-3.5.0-1

libvisio-0.1.7-2

mailx-8.1.2.20180807-1

strace-5.5-1

tzdata-2019c-1

zlib-1.2.11-2

Line 
1Name:           dnsmasq
2Version:        2.80
3Release:        2%{?_dist_release}
4Summary:        A lightweight DHCP/caching DNS server
5Summary(ja):    軽量 DHCP/DNSキャッシュサーバ
6
7Group:          System Environment/Daemons
8License:        GPLv2 or GPLv3
9URL:            http://www.thekelleys.org.uk/dnsmasq/
10Source0:        http://www.thekelleys.org.uk/dnsmasq/%{name}-%{version}.tar.xz
11Patch0:         %{name}-2.33-initscript.patch
12BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
13
14BuildRequires:  dbus-devel, libidn2-devel, nettle-devel
15BuildRequires:  pkgconfig
16
17Requires(post):  /sbin/chkconfig
18Requires(post):  /sbin/service
19Requires(post):  /bin/sed /bin/grep
20Requires(preun): /sbin/chkconfig
21Requires(preun): /sbin/service
22
23Vendor: Project Vine
24Distribution: Vine Linux
25
26%description
27Dnsmasq is lightweight, easy to configure DNS forwarder and DHCP server.
28It is designed to provide DNS and, optionally, DHCP, to a small network.
29It can serve the names of local machines which are not in the global
30DNS. The DHCP server integrates with the DNS server and allows machines
31with DHCP-allocated addresses to appear in the DNS with names configured
32either in each host or in a central configuration file. Dnsmasq supports
33static and dynamic DHCP leases and BOOTP for network booting of diskless
34machines.
35
36
37%prep
38%setup -q -n %{name}-%{version}
39%patch0 -p1
40
41# use /var/lib/dnsmasq instead of /var/lib/misc
42for file in dnsmasq.conf.example man/dnsmasq.8 man/es/dnsmasq.8 src/config.h; do
43    sed -i 's|/var/lib/misc/dnsmasq.leases|/var/lib/dnsmasq/dnsmasq.leases|g' "$file"
44done
45
46# fix the path to the trust anchor
47sed -i 's|%%%%PREFIX%%%%|%{_prefix}|' dnsmasq.conf.example
48
49#enable dbus
50sed -i 's|/\* #define HAVE_DBUS \*/|#define HAVE_DBUS|g' src/config.h
51
52#enable libidn2 support
53sed -i 's|/\* #define HAVE_LIBIDN2 \*/|#define HAVE_LIBIDN2|g' src/config.h
54
55#enable DNSSEC support
56sed -i 's|/\* #define HAVE_DNSSEC \*/|#define HAVE_DNSSEC|g' src/config.h
57
58#enable /etc/dnsmasq.d fix bz 526703, ignore RPM backup files
59cat << EOF >> dnsmasq.conf.example
60
61# Include all files in /etc/dnsmasq.d except RPM backup files
62conf-dir=%{_sysconfdir}/dnsmasq.d,.rpmnew,.rpmsave,.rpmorig
63EOF
64
65
66%build
67make %{?_smp_mflags}
68
69
70%install
71rm -rf $RPM_BUILD_ROOT
72# normally i'd do 'make install'...it's a bit messy, though
73mkdir -p $RPM_BUILD_ROOT%{_sbindir} $RPM_BUILD_ROOT%{_initrddir} \
74        $RPM_BUILD_ROOT%{_mandir}/man8 \
75        $RPM_BUILD_ROOT%{_var}/lib/dnsmasq \
76        $RPM_BUILD_ROOT%{_sysconfdir}/dnsmasq.d \
77        $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d
78install src/dnsmasq $RPM_BUILD_ROOT%{_sbindir}/dnsmasq
79install dnsmasq.conf.example $RPM_BUILD_ROOT%{_sysconfdir}/dnsmasq.conf
80install dbus/dnsmasq.conf $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d/
81install rpm/dnsmasq.init $RPM_BUILD_ROOT%{_initrddir}/dnsmasq
82install -m 644 man/dnsmasq.8 $RPM_BUILD_ROOT%{_mandir}/man8/
83
84%clean
85rm -rf $RPM_BUILD_ROOT
86
87%post
88if [ "$1" = "2" ]; then # if we're being upgraded
89    # if using the old leases location, move the file to the new one
90    # but only if we're not clobbering another file
91    #
92    if [ -f /var/lib/misc/dnsmasq.leases -a ! -f /var/lib/dnsmasq/dnsmasq.leases ]; then
93        # causes rpmlint to report dangerous-command-in-post,
94        # but that's the price of selinux compliance :-(
95        mv -f /var/lib/misc/dnsmasq.leases /var/lib/dnsmasq/dnsmasq.leases || :
96    fi
97    # ugly, but kind of necessary
98    if [ ! `grep -q dhcp-leasefile=/var/lib/misc/dnsmasq.leases %{_sysconfdir}/dnsmasq.conf` ]; then
99        cp %{_sysconfdir}/dnsmasq.conf %{_sysconfdir}/dnsmasq.conf.tmp || :
100        sed -e 's/var\/lib\/misc/var\/lib\/dnsmasq/' < %{_sysconfdir}/dnsmasq.conf.tmp > %{_sysconfdir}/dnsmasq.conf || :
101        rm -f %{_sysconfdir}/dnsmasq.conf.tmp || :
102    fi
103    /sbin/service dnsmasq condrestart >/dev/null 2>&1 || :
104else # if we're being installed
105    /sbin/chkconfig --add dnsmasq
106fi
107
108%preun
109if [ "$1" = "0" ]; then     # execute this only if we are NOT doing an upgrade
110    /sbin/service dnsmasq stop >/dev/null 2>&1 || :
111    /sbin/chkconfig --del dnsmasq
112fi
113
114
115%files
116%defattr(-,root,root,-)
117%license COPYING*
118%doc CHANGELOG FAQ doc.html setup.html dbus/DBus-interface
119%config(noreplace) %attr(644,root,root) %{_sysconfdir}/dnsmasq.conf
120%dir /etc/dnsmasq.d
121%dir %{_var}/lib/dnsmasq
122%config(noreplace) %attr(644,root,root) %{_sysconfdir}/dbus-1/system.d/dnsmasq.conf
123%{_initrddir}/dnsmasq
124%{_sbindir}/dnsmasq
125%{_mandir}/man8/dnsmasq*
126
127
128%changelog
129* Sat Mar 21 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.80-2
130- rebuilt with libidn2.
131
132* Sat May 25 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.80-1
133- new upstream release.
134
135* Tue Jul  5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.76-1
136- new upstream release.
137
138* Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.45-3
139- rebuild with VineSeed environment
140
141* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2.45-2
142- rebuilt with rpm-4.8.1-3
143
144* Thu Jul 31 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.45-1
145- initial build for Vine Linux
146
147* Mon Jul 21 2008 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.45-1
148- Upstream release (bugfixes)
149
150* Wed Jul 16 2008 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.43-2
151- New upstream release, contains fixes for CVE-2008-1447/CERT VU#800113
152- Dropped patch for newer glibc (merged upstream)
153
154* Wed Feb 13 2008 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.41-0.8
155- Added upstream-authored patch for newer glibc (thanks Simon!)
156
157* Wed Feb 13 2008 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.41-0.7
158- New upstream release
159
160* Wed Jan 30 2008 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.41-0.6.rc1
161- Release candidate
162- Happy Birthday Isaac!
163
164* Wed Jan 23 2008 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.41-0.5.test30
165- Bugfix update
166
167* Mon Dec 31 2007 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.41-0.4.test26
168- Bugfix/feature enhancement update
169
170* Thu Dec 13 2007 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.41-0.3.test24
171- Upstream fix for fairly serious regression
172
173* Tue Dec 04 2007 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.41-0.2.test20
174- New upstream test release
175- Moving dnsmasq.leases to /var/lib/dnsmasq/ as per BZ#407901
176- Ignoring dangerous-command-in-%%post rpmlint warning (as per above fix)
177- Patch consolidation/cleanup
178- Removed conditionals for Fedora <= 3 and Aurora 2.0
179
180* Tue Sep 18 2007 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.40-1
181- Finalized upstream release
182- Removing URLs from patch lines (CVS is the authoritative source)
183- Added more magic to make spinning rc/test packages more seamless
184
185* Sun Aug 26 2007 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.40-0.1.rc2
186- New upstream release candidate (feature-frozen), thanks Simon!
187- License clarification
188
189* Tue May 29 2007 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.39-1
190- New upstream version (bugfixes, enhancements)
191
192* Mon Feb 12 2007 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.38-1
193- New upstream version with bugfix for potential hang
194
195* Tue Feb 06 2007 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.37-1
196- New upstream version
197
198* Wed Jan 24 2007 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.36-1
199- New upstream version
200
201* Mon Nov 06 2006 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.35-2
202- Stop creating /etc/sysconfig on %%install
203- Create /etc/dnsmasq.d on %%install
204
205* Mon Nov 06 2006 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.35-1
206- Update to 2.35
207- Removed UPGRADING_to_2.0 from %%doc as per upstream change
208- Enabled conf-dir in default config as per RFE BZ#214220 (thanks Chris!)
209- Added %%dir /etc/dnsmasq.d to %%files as per above RFE
210
211* Tue Oct 24 2006 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.34-2
212- Fixed BZ#212005
213- Moved %%postun scriptlet to %%post, where it made more sense
214- Render scriptlets safer
215- Minor cleanup for consistency
216
217* Thu Oct 19 2006 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.34-1
218- Hardcoded version in patches, as I'm getting tired of updating them
219- Update to 2.34
220
221* Mon Aug 28 2006 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.33-2
222- Rebuild for FC6
223
224* Tue Aug 15 2006 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.33-1
225- Update
226
227* Sat Jul 22 2006 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.32-3
228- Added pkgconfig BuildReq due to reduced buildroot
229
230* Thu Jul 20 2006 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.32-2
231- Forced update due to dbus version bump
232
233* Mon Jun 12 2006 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.32-1
234- Update from upstream
235- Patch from Dennis Gilmore fixed the conditionals to detect Aurora Linux
236
237* Mon May  8 2006 Patrick "Jima" Laughton <jima@auroralinux.org> 2.31-1
238- Removed dbus config patch (now provided upstream)
239- Patched in init script (no longer provided upstream)
240- Added DBus-interface to docs
241
242* Tue May  2 2006 Patrick "Jima" Laughton <jima@auroralinux.org> 2.30-4.2
243- More upstream-recommended cleanups :)
244- Killed sysconfig file (provides unneeded functionality)
245- Tweaked init script a little more
246
247* Tue May  2 2006 Patrick "Jima" Laughton <jima@auroralinux.org> 2.30-4
248- Moved options out of init script and into /etc/sysconfig/dnsmasq
249- Disabled DHCP_LEASE in sysconfig file, fixing bug #190379
250- Simon Kelley provided dbus/dnsmasq.conf, soon to be part of the tarball
251
252* Thu Apr 27 2006 Patrick "Jima" Laughton <jima@auroralinux.org> 2.30-3
253- Un-enabled HAVE_ISC_READER, a hack to enable a deprecated feature (request)
254- Split initscript & enable-dbus patches, conditionalized dbus for FC3
255- Tweaked name field in changelog entries (trying to be consistent)
256
257* Mon Apr 24 2006 Patrick "Jima" Laughton <jima@auroralinux.org> 2.30-2
258- Disabled stripping of binary while installing (oops)
259- Enabled HAVE_ISC_READER/HAVE_DBUS via patch
260- Added BuildReq for dbus-devel
261
262* Mon Apr 24 2006 Patrick "Jima" Laughton <jima@auroralinux.org> 2.30-1
263- Initial Fedora Extras RPM
Note: See TracBrowser for help on using the repository browser.