source: projects/specs/trunk/d/dmraid/dmraid-vl.spec @ 521

Revision 521, 10.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Device-mapper RAID tool and library.
2Summary(ja): Device-mapper RAID ツールおよびライブラリ
3Name: dmraid
4Version: 1.0.0.rc15
5Release: 1%{?_dist_release}
6License: GPL
7Group: System Environment/Base
8URL: http://people.redhat.com/heinzm/sw/dmraid
9
10Source: ftp://people.redhat.com/heinzm/sw/dmraid/src/%{name}-%{version}.tar.bz2
11Patch0: dmraid-1.0.0.rc15-whitespace.patch
12Patch1: dmraid-1.0.0.rc15-isw-raid10.patch
13Patch2: dmraid-1.0.0.rc15-rm_partitions.patch
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
16BuildRequires: device-mapper-devel >= 1.02.22
17Requires: device-mapper >= 1.02.22
18Requires(postun): ldconfig
19Requires(post): ldconfig
20
21%description
22DMRAID supports RAID device discovery, RAID set activation and display of
23properties for ATARAID on Linux >= 2.4 using device-mapper.
24
25%package -n dmraid-devel
26Summary: Development libraries and headers for dmraid.
27Group: Development/Libraries
28
29%description -n dmraid-devel
30dmraid-devel provides a library interface for RAID device discovery,
31RAID set activation and display of properties for ATARAID volumes.
32
33%prep
34%setup -q -n dmraid/%{version}
35%patch0 -p1
36%patch1 -p1
37%patch2 -p1
38
39%build
40%configure \
41  --prefix=${RPM_BUILD_ROOT}/usr --sbindir=${RPM_BUILD_ROOT}/sbin \
42  --libdir=${RPM_BUILD_ROOT}/%{_libdir} --mandir=${RPM_BUILD_ROOT}/%{_mandir} \
43  --includedir=${RPM_BUILD_ROOT}/%{_includedir} \
44  --disable-libselinux --enable-static_link
45make DESTDIR=$RPM_BUILD_ROOT
46mv tools/dmraid tools/dmraid.static
47make clean
48%configure \
49  --prefix=${RPM_BUILD_ROOT}/usr --sbindir=${RPM_BUILD_ROOT}/sbin \
50  --libdir=${RPM_BUILD_ROOT}/%{_libdir} --mandir=${RPM_BUILD_ROOT}/%{_mandir} \
51  --includedir=${RPM_BUILD_ROOT}/%{_includedir} \
52  --disable-libselinux --disable-static_link
53make -C lib DESTDIR=$RPM_BUILD_ROOT libdmraid.so
54
55%install
56rm -rf $RPM_BUILD_ROOT
57install -m 755 -d $RPM_BUILD_ROOT{%{_libdir},/sbin,%{_sbindir},%{_bindir},%{_libdir},%{_includedir}/dmraid/,/var/lock/dmraid}
58make DESTDIR=$RPM_BUILD_ROOT install
59install -m 755 tools/dmraid.static $RPM_BUILD_ROOT/sbin/dmraid.static
60install -m 644 include/dmraid/*.h $RPM_BUILD_ROOT%{_includedir}/dmraid/
61
62# if requested, install the dso
63install -m 755 lib/libdmraid.so \
64        $RPM_BUILD_ROOT%{_libdir}/libdmraid.so.%{version}
65(cd $RPM_BUILD_ROOT/%{_libdir} ; ln -sf libdmraid.so.%{version} libdmraid.so)
66
67rm -f $RPM_BUILD_ROOT/%{_libdir}/libdmraid.a
68
69%clean
70rm -rf $RPM_BUILD_ROOT
71
72%post -p /sbin/ldconfig
73 
74%postun -p /sbin/ldconfig
75
76%files
77%defattr(-,root,root)
78%doc CHANGELOG CREDITS KNOWN_BUGS LICENSE LICENSE_GPL LICENSE_LGPL README TODO doc/dmraid_design.txt
79%{_mandir}/man8/*
80/sbin/*
81%{_libdir}/libdmraid.so.*
82/var/lock/dmraid
83
84%files -n dmraid-devel
85%defattr(-,root,root)
86%dir %{_includedir}/dmraid
87%{_includedir}/dmraid/*
88%{_libdir}/libdmraid.so
89
90%changelog
91* Sat Mar 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0.rc15-1
92- new upstream release
93
94* Mon Dec 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl0.rc14.1
95- initial build for Vine Linux
96- disable selinux
97- require device-mapper 1.02.22
98
99* Wed Nov 21 2007 Ian Kent <ikent@redhat.com> - 1.0.0.rc14-6
100- Bug 379911: dmraid needs to generate UUIDs for lib device-mapper
101  - add "DMRAID-" prefix to dmraid UUID string.
102
103* Wed Nov 14 2007 Ian Kent <ikent@redhat.com> - 1.0.0.rc14-5
104- Bug 379911: dmraid needs to generate UUIDs for lib device-mapper
105- Bug 379951: dmraid needs to activate device-mapper mirror resynchronization error handling
106
107* Mon Oct 22 2007 Ian Kent <ikent@redhat.com> - 1.0.0.rc14-4
108- Fix SEGV on "dmraid -r -E" (bz 236891).
109
110* Wed Apr 18 2007 Peter Jones <pjones@redhat.com> - 1.0.0.rc14-3
111- Fix jmicron name parsing (#219058)
112
113* Mon Feb 05 2007 Alasdair Kergon <agk@redhat.com> - 1.0.0.rc14-2
114- Add build dependency on new device-mapper-devel package.
115- Add dependency on device-mapper.
116- Add post and postun ldconfig.
117- Update BuildRoot and Summary.
118
119* Wed Nov 08 2006 Heinz Mauelshagen <heinzm@redhat.com> - 1.0.0.rc14-1
120- asr.c: fixed Adaptec HostRAID DDF1 metadata discovery (bz#211016)
121- ddf1_crc.c: added crc() routine to avoid linking to zlib alltogether,
122              because Ubuntu had problems with this
123- dropped zlib build requirement
124
125* Thu Oct 26 2006 Heinz Mauelshagen <heinzm@redhat.com> - 1.0.0.rc14-bz211016-1
126- ddf1.c: get_size() fixed (bz#211016)
127- ddf1_lib.c: ddf1_cr_off_maxpds_helper() fixed (bz#211016)
128
129* Wed Oct 11 2006 Heinz Mauelshagen <heinzm@redhat.com> - 1.0.0.rc13-1
130- metadata.c: fixed bug returning wrang unified RAID type (bz#210085)
131- pdc.c: fixed magic number check
132
133* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0.rc12-7
134- rebuilt for unwind info generation, broken in gcc-4.1.1-21
135
136* Fri Sep 22 2006 Heinz Mauelshagen <heinzm@redhat.com> - 1.0.0.rc12-1
137- sil.c: quorate() OBO fix
138- activate.c: handler() OBO fix
139- added SNIA DDF1 support
140- added reload functionality to devmapper.c
141- added log_zero_sectors() to various metadata format handlers
142- sil.[ch]: added JBOD support
143
144* Fri Sep  1 2006 Peter Jones <pjones@redhat.com> - 1.0.0.rc11-4
145- Require kpartx, so initscripts doesn't have to if you're not using dmraid
146
147* Thu Aug 17 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0.rc11-3
148- Change Release to follow guidelines, and add dist tag.
149
150* Thu Aug 17 2006 Peter Jones <pjones@redhat.com> - 1.0.0.rc11-FC6.3
151- No more excludearch for s390/s390x
152
153* Fri Jul 28 2006 Peter Jones <pjones@redhat.com> - 1.0.0.rc11-FC6.2
154- Fix bounds checking on hpt37x error log
155- Only build the .so, not the .a
156- Fix asc.c duplication in makefile rule
157
158* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0.rc11-FC6.1.1
159- rebuild
160
161* Fri Jul  7 2006 Heinz Mauelshagen <heinzm@redhat.com> - 1.0.0.rc11-FC6.1
162- rebuilt for FC6 with dos partition discovery fix (#197573)
163
164* Tue May 16 2006 Heinz Mauelshagen <heinzm@redhat.com> - 1.0.0.rc11-FC6
165- rebuilt for FC6 with better tag
166
167* Tue May 16 2006 Heinz Mauelshagen <heinzm@redhat.com> - 1.0.0.rc11-FC5_7.2
168- rebuilt for FC5
169
170* Tue May 16 2006 Heinz Mauelshagen <heinzm@redhat.com> - 1.0.0.rc11-FC5_7.1
171- jm.c: checksum() calculation
172- misc.c: support "%d" in p_fmt and fix segfault with wrong format identifier
173- nv.c: size fix in setup_rd()
174- activate.c:
175        o striped devices could end on non-chunk boundaries
176        o calc_region_size() calculated too small sizes causing large
177          dirty logs in memory
178- isw.c: set raid5 type to left asymmetric
179- toollib.c: fixed 'No RAID...' message
180- support selection of RAID5 allocation algorithm in metadata format handlers
181- build
182
183* Mon Mar 27 2006 Milan Broz <mbroz@redhat.com> - 1.0.0.rc10-FC5_6.2
184- fixed /var/lock/dmraid in specfile (#168195)
185
186* Fri Feb 17 2006 Heinz Mauelshagen <heinzm@redhat.com> - 1.0.0.rc10-FC5_6
187- add doc/dmraid_design.txt to %doc (#181885)
188- add --enable-libselinux --enable-libsepol to configure
189- rebuilt
190
191* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0.rc9-FC5_5.2
192- bump again for double-long bug on ppc(64)
193
194* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0.rc9-FC5_5.1
195- rebuilt for new gcc4.1 snapshot and glibc changes
196
197* Sun Jan 22 2006 Peter Jones <pjones@redhat.com> 1.0.0.rc9-FC5_5
198- Add selinux build deps
199- Don't set owner during make install
200
201* Fri Dec  9 2005 Jesse Keating <jkeating@redhat.com> 1.0.0.rc9-FC5_4.1
202- rebuilt
203
204* Sun Dec  3 2005 Peter Jones <pjones@redhat.com> 1.0.0.rc9-FC5_4
205- rebuild for device-mapper-1.02.02-2
206
207* Fri Dec  2 2005 Peter Jones <pjones@redhat.com> 1.0.0.rc9-FC5_3
208- rebuild for device-mapper-1.02.02-1
209
210* Thu Nov 10 2005 Peter Jones <pjones@redhat.com> 1.0.0.rc9-FC5_2
211- update to 1.0.0.rc9
212- make "make install" do the right thing with the DSO
213- eliminate duplicate definitions in the headers
214- export more symbols in the DSO
215- add api calls to retrieve dm tables
216- fix DESTDIR for 'make install'
217- add api calls to identify degraded devices
218- remove several arch excludes
219
220* Sat Oct 15 2005 Florian La Roche <laroche@redhat.com>
221- add -lselinux -lsepol for new device-mapper deps
222
223* Fri May 20 2005 Heinz Mauelshagen <heinzm@redhat.com> 1.0.0.rc8-FC4_2
224- specfile change to build static and dynamic binray into one package
225- rebuilt
226
227* Thu May 19 2005 Heinz Mauelshagen <heinzm@redhat.com> 1.0.0.rc8-FC4_1
228- nv.c: fixed stripe size
229- sil.c: avoid incarnation_no in name creation, because the Windows
230         driver changes it every time
231- added --ignorelocking option to avoid taking out locks in early boot
232  where no read/write access to /var is given
233
234* Wed Mar 16 2005 Elliot Lee <sopwith@redhat.com>
235- rebuilt
236
237* Tue Mar 15 2005 Heinz Mauelshagen <heinzm@redhat.com> 1.0.0.rc6.1-4_FC4
238- VIA metadata format handler
239- added RAID10 to lsi metadata format handler
240- "dmraid -rD": file device size into {devicename}_{formatname}.size
241- "dmraid -tay": pretty print multi-line tables ala "dmsetup table"
242- "dmraid -l": display supported RAID levels + manual update
243- _sil_read() used LOG_NOTICE rather than LOG_INFO in order to
244  avoid messages about valid metadata areas being displayed
245  during "dmraid -vay".
246- isw, sil filed metadata offset on "-r -D" in sectors rather than in bytes.
247- isw needed dev_sort() to sort RAID devices in sets correctly.
248- pdc metadata format handler name creation. Lead to
249  wrong RAID set grouping logic in some configurations.
250- pdc RAID1 size calculation fixed (rc6.1)
251- dos.c: partition table code fixes by Paul Moore
252- _free_dev_pointers(): fixed potential OOB error
253- hpt37x_check: deal with raid_disks = 1 in mirror sets
254- pdc_check: status & 0x80 doesn't always show a failed device;
255  removed that check for now. Status definitions needed.
256- sil addition of RAID sets to global list of sets
257- sil spare device memory leak
258- group_set(): removal of RAID set in case of error
259- hpt37x: handle total_secs > device size
260- allow -p with -f
261- enhanced error message by checking target type against list of
262  registered target types
263
264* Fri Jan 21 2005 Alasdair Kergon <agk@redhat.com> 1.0.0.rc5f-2
265- Rebuild to pick up new libdevmapper.
266
267* Fri Nov 26 2004 Heinz Mauelshagen <heinzm@redhat.com> 1.0.0.rc5f
268- specfile cleanup
269
270* Tue Aug 20 2004 Heinz Mauelshagen <heinzm@redhat.com> 1.0.0-rc4-pre1
271- Removed make flag after fixing make.tmpl.in
272
273* Tue Aug 18 2004 Heinz Mauelshagen <heinzm@redhat.com> 1.0.0-rc3
274- Added make flag to prevent make 3.80 from looping infinitely
275
276* Thu Jun 17 2004 Heinz Mauelshagen <heinzm@redhat.com> 1.0.0-pre1
277- Created
Note: See TracBrowser for help on using the repository browser.