source: projects/specs/trunk/d/dmraid/dmraid-vl.spec @ 8607

Revision 8607, 14.0 KB checked in by Takemikaduchi, 10 years ago (diff)

NEW: eudev
rtmpdump: add R: gmp-devel
gpac: remove Requires
others: rebuild with eudev

Line 
1Summary: Device-mapper RAID tool and library.
2Summary(ja): Device-mapper RAID ツールおよびライブラリ
3Name: dmraid
4Version: 1.0.0.rc16
5Release: 3%{?_dist_release}
6License: GPL
7Group: System Environment/Base
8URL: http://people.redhat.com/heinzm/sw/dmraid
9
10Source: ftp://people.redhat.com/heinzm/sw/dmraid/src/%{name}-%{version}.tar.bz2
11Patch0: dmraid-1.0.0.rc16-test_devices.patch
12Patch1: ddf1_lsi_persistent_name.patch
13Patch2: pdc_raid10_failure.patch
14Patch3: return_error_wo_disks.patch
15Patch4: fix_sil_jbod.patch
16Patch5: avoid_register.patch
17Patch6: move_pattern_file_to_var.patch
18Patch7: libversion.patch
19Patch8: libversion-display.patch
20Patch9: bz635995-data_corruption_during_activation_volume_marked_for_rebuild.patch
21Patch11: bz626417_19-enabling_registration_degraded_volume.patch
22Patch12: bz626417_20-cleanup_some_compilation_warning.patch
23Patch13: bz626417_21-add_option_that_postpones_any_metadata_updates.patch
24
25Patch100: dmraid-1.0.0.rc16-libudev.patch
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
28BuildRequires: device-mapper-devel >= 1.02.22
29BuildRequires: device-mapper-event-devel
30BuildRequires: device-mapper-static
31BuildRequires: eudev-libudev-static
32BuildRequires: glibc-static
33Requires: device-mapper >= 1.02.22
34Requires(postun): ldconfig
35Requires(post): ldconfig
36
37Vendor: Project Vine
38Distribution: Vine Linux
39
40%description
41DMRAID supports RAID device discovery, RAID set activation and display of
42properties for ATARAID on Linux >= 2.4 using device-mapper.
43
44%package -n dmraid-devel
45Summary: Development libraries and headers for dmraid.
46Group: Development/Libraries
47
48%description -n dmraid-devel
49dmraid-devel provides a library interface for RAID device discovery,
50RAID set activation and display of properties for ATARAID volumes.
51
52%package -n dmraid-events
53Summary: dmevent_tool (Device-mapper event tool) and DSO
54Group: System Environment/Base
55Requires: dmraid = %{version}-%{release}, sgpio
56Requires: device-mapper-event
57
58%description -n dmraid-events
59Provides a dmeventd DSO and the dmevent_tool to register devices with it
60for device monitoring.  All active RAID sets should be manually registered
61with dmevent_tool.
62
63%package -n dmraid-events-logwatch
64Summary: dmraid logwatch-based email reporting
65Group: System Environment/Base
66Requires: dmraid-events = %{version}-%{release}, logwatch, /etc/cron.d
67
68%description -n dmraid-events-logwatch
69Provides device failure reporting via logwatch-based email reporting.
70Device failure reporting has to be activated manually by activating the
71/etc/cron.d/dmeventd-logwatch entry and by calling the dmevent_tool
72(see manual page for examples) for any active RAID sets.
73
74%prep
75%setup -q -n dmraid/%{version}
76%patch0 -p1
77%patch1 -p1
78%patch2 -p1
79%patch3 -p1
80%patch4 -p1
81%patch5 -p1
82%patch6 -p1
83%patch7 -p1
84%patch8 -p1
85%patch9 -p1
86%patch11 -p1
87%patch12 -p1
88%patch13 -p1
89%patch100 -p1
90
91%build
92%configure \
93  --prefix=${RPM_BUILD_ROOT}/usr --sbindir=${RPM_BUILD_ROOT}/sbin \
94  --libdir=${RPM_BUILD_ROOT}/%{_libdir} --mandir=${RPM_BUILD_ROOT}/%{_mandir} \
95  --includedir=${RPM_BUILD_ROOT}/%{_includedir} \
96  --disable-libselinux --enable-static_link
97make DESTDIR=$RPM_BUILD_ROOT
98mv tools/dmraid tools/dmraid.static
99make clean
100%configure \
101  --prefix=${RPM_BUILD_ROOT}/usr --sbindir=${RPM_BUILD_ROOT}/sbin \
102  --libdir=${RPM_BUILD_ROOT}/%{_libdir} --mandir=${RPM_BUILD_ROOT}/%{_mandir} \
103  --includedir=${RPM_BUILD_ROOT}/%{_includedir} \
104  --disable-libselinux --disable-static_link
105make -C lib DESTDIR=$RPM_BUILD_ROOT libdmraid.so
106
107%install
108rm -rf $RPM_BUILD_ROOT
109install -m 755 -d $RPM_BUILD_ROOT{%{_libdir},/sbin,%{_sbindir},%{_bindir},%{_libdir},%{_includedir}/dmraid/,/var/lock/dmraid,%{_sysconfdir}/cron.d/}
110install -m 755 -d $RPM_BUILD_ROOT{%{_sysconfdir}/logwatch/conf/services/,%{_sysconfdir}/logwatch/scripts/services/,/var/cache/logwatch/dmeventd}
111make DESTDIR=$RPM_BUILD_ROOT install
112install -m 755 tools/dmraid.static $RPM_BUILD_ROOT/sbin/dmraid.static
113
114# Provide convenience link from dmevent_tool
115(cd $RPM_BUILD_ROOT/sbin ; ln -f dmevent_tool dm_dso_reg_tool)
116(cd $RPM_BUILD_ROOT/%{_mandir}/man8 ; ln -f dmevent_tool.8 dm_dso_reg_tool.8 ; ln -f dmraid.8 dmraid.static.8)
117
118#
119install -m 644 include/dmraid/*.h $RPM_BUILD_ROOT%{_includedir}/dmraid/
120
121# Install the libdmraid and libdmraid-events (for dmeventd) DSO
122# Create version symlink to libdmraid.so.1 we link against
123install -m 755 lib/libdmraid.so \
124        $RPM_BUILD_ROOT%{_libdir}/libdmraid.so.%{version}
125(cd $RPM_BUILD_ROOT/%{_libdir} ; ln -sf libdmraid.so.%{version} libdmraid.so ; ln -sf libdmraid.so.%{version} libdmraid.so.1)
126install -m 755 lib/libdmraid-events-isw.so \
127        $RPM_BUILD_ROOT%{_libdir}/libdmraid-events-isw.so.%{version}
128(cd $RPM_BUILD_ROOT/%{_libdir} ; ln -sf libdmraid-events-isw.so.%{version} libdmraid-events-isw.so ; ln -sf libdmraid-events-isw.so.%{version} libdmraid-events-isw.so.1)
129                 
130# Install logwatch config file and script for dmeventd
131install -m 644 logwatch/dmeventd.conf $RPM_BUILD_ROOT%{_sysconfdir}/logwatch/conf/services/dmeventd.conf
132install -m 755 logwatch/dmeventd $RPM_BUILD_ROOT%{_sysconfdir}/logwatch/scripts/services/dmeventd
133install -m 644 logwatch/dmeventd_cronjob.txt $RPM_BUILD_ROOT%{_sysconfdir}/cron.d/dmeventd-logwatch
134install -m 0700 /dev/null $RPM_BUILD_ROOT/var/cache/logwatch/dmeventd/syslogpattern.txt
135
136# remove static libs
137rm -f $RPM_BUILD_ROOT/%{_libdir}/libdmraid.a
138
139%clean
140rm -rf $RPM_BUILD_ROOT
141
142%post -p /sbin/ldconfig
143 
144%postun -p /sbin/ldconfig
145
146%files
147%defattr(-,root,root)
148%doc CHANGELOG CREDITS KNOWN_BUGS LICENSE LICENSE_GPL LICENSE_LGPL README TODO doc/dmraid_design.txt
149%{_mandir}/man8/*
150/sbin/*
151%{_libdir}/libdmraid.so*
152%{_libdir}/libdmraid-events-isw.so*
153%ghost /var/lock/dmraid
154
155%files -n dmraid-devel
156%defattr(-,root,root)
157%dir %{_includedir}/dmraid
158%{_includedir}/dmraid/*
159
160%files -n dmraid-events
161%defattr(-,root,root)
162/%{_mandir}/man8/dmevent_tool*
163/%{_mandir}/man8/dm_dso_reg_tool*
164/sbin/dmevent_tool
165/sbin/dm_dso_reg_tool
166
167%files -n dmraid-events-logwatch
168%defattr(-,root,root)
169%config(noreplace) %{_sysconfdir}/logwatch/*
170%config(noreplace) %{_sysconfdir}/cron.d/dmeventd-logwatch
171%dir /var/cache/logwatch/dmeventd
172%ghost /var/cache/logwatch/dmeventd/syslogpattern.txt
173
174
175%changelog
176* Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0.rc16-3
177- change BuildRequires: eudev-libudev-static instead of libudev-static
178
179* Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0.rc16-2
180- rebuild with VineSeed environment
181
182* Tue Apr 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0.rc16-1
183- update to 1.0.0.rc16
184- update patches from fedora package
185- add BR: libudev-static, device-mapper-static, glibc-static
186- add BR: device-mapper-event-devel
187- add -events, -events-logwatch subpackage
188- move libdmraid.so to main package
189- use %ghost for /var/lock/dmraid
190
191* Sat Mar 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0.rc15-1
192- new upstream release
193
194* Mon Dec 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl0.rc14.1
195- initial build for Vine Linux
196- disable selinux
197- require device-mapper 1.02.22
198
199* Wed Nov 21 2007 Ian Kent <ikent@redhat.com> - 1.0.0.rc14-6
200- Bug 379911: dmraid needs to generate UUIDs for lib device-mapper
201  - add "DMRAID-" prefix to dmraid UUID string.
202
203* Wed Nov 14 2007 Ian Kent <ikent@redhat.com> - 1.0.0.rc14-5
204- Bug 379911: dmraid needs to generate UUIDs for lib device-mapper
205- Bug 379951: dmraid needs to activate device-mapper mirror resynchronization error handling
206
207* Mon Oct 22 2007 Ian Kent <ikent@redhat.com> - 1.0.0.rc14-4
208- Fix SEGV on "dmraid -r -E" (bz 236891).
209
210* Wed Apr 18 2007 Peter Jones <pjones@redhat.com> - 1.0.0.rc14-3
211- Fix jmicron name parsing (#219058)
212
213* Mon Feb 05 2007 Alasdair Kergon <agk@redhat.com> - 1.0.0.rc14-2
214- Add build dependency on new device-mapper-devel package.
215- Add dependency on device-mapper.
216- Add post and postun ldconfig.
217- Update BuildRoot and Summary.
218
219* Wed Nov 08 2006 Heinz Mauelshagen <heinzm@redhat.com> - 1.0.0.rc14-1
220- asr.c: fixed Adaptec HostRAID DDF1 metadata discovery (bz#211016)
221- ddf1_crc.c: added crc() routine to avoid linking to zlib alltogether,
222              because Ubuntu had problems with this
223- dropped zlib build requirement
224
225* Thu Oct 26 2006 Heinz Mauelshagen <heinzm@redhat.com> - 1.0.0.rc14-bz211016-1
226- ddf1.c: get_size() fixed (bz#211016)
227- ddf1_lib.c: ddf1_cr_off_maxpds_helper() fixed (bz#211016)
228
229* Wed Oct 11 2006 Heinz Mauelshagen <heinzm@redhat.com> - 1.0.0.rc13-1
230- metadata.c: fixed bug returning wrang unified RAID type (bz#210085)
231- pdc.c: fixed magic number check
232
233* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0.rc12-7
234- rebuilt for unwind info generation, broken in gcc-4.1.1-21
235
236* Fri Sep 22 2006 Heinz Mauelshagen <heinzm@redhat.com> - 1.0.0.rc12-1
237- sil.c: quorate() OBO fix
238- activate.c: handler() OBO fix
239- added SNIA DDF1 support
240- added reload functionality to devmapper.c
241- added log_zero_sectors() to various metadata format handlers
242- sil.[ch]: added JBOD support
243
244* Fri Sep  1 2006 Peter Jones <pjones@redhat.com> - 1.0.0.rc11-4
245- Require kpartx, so initscripts doesn't have to if you're not using dmraid
246
247* Thu Aug 17 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0.rc11-3
248- Change Release to follow guidelines, and add dist tag.
249
250* Thu Aug 17 2006 Peter Jones <pjones@redhat.com> - 1.0.0.rc11-FC6.3
251- No more excludearch for s390/s390x
252
253* Fri Jul 28 2006 Peter Jones <pjones@redhat.com> - 1.0.0.rc11-FC6.2
254- Fix bounds checking on hpt37x error log
255- Only build the .so, not the .a
256- Fix asc.c duplication in makefile rule
257
258* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0.rc11-FC6.1.1
259- rebuild
260
261* Fri Jul  7 2006 Heinz Mauelshagen <heinzm@redhat.com> - 1.0.0.rc11-FC6.1
262- rebuilt for FC6 with dos partition discovery fix (#197573)
263
264* Tue May 16 2006 Heinz Mauelshagen <heinzm@redhat.com> - 1.0.0.rc11-FC6
265- rebuilt for FC6 with better tag
266
267* Tue May 16 2006 Heinz Mauelshagen <heinzm@redhat.com> - 1.0.0.rc11-FC5_7.2
268- rebuilt for FC5
269
270* Tue May 16 2006 Heinz Mauelshagen <heinzm@redhat.com> - 1.0.0.rc11-FC5_7.1
271- jm.c: checksum() calculation
272- misc.c: support "%d" in p_fmt and fix segfault with wrong format identifier
273- nv.c: size fix in setup_rd()
274- activate.c:
275        o striped devices could end on non-chunk boundaries
276        o calc_region_size() calculated too small sizes causing large
277          dirty logs in memory
278- isw.c: set raid5 type to left asymmetric
279- toollib.c: fixed 'No RAID...' message
280- support selection of RAID5 allocation algorithm in metadata format handlers
281- build
282
283* Mon Mar 27 2006 Milan Broz <mbroz@redhat.com> - 1.0.0.rc10-FC5_6.2
284- fixed /var/lock/dmraid in specfile (#168195)
285
286* Fri Feb 17 2006 Heinz Mauelshagen <heinzm@redhat.com> - 1.0.0.rc10-FC5_6
287- add doc/dmraid_design.txt to %doc (#181885)
288- add --enable-libselinux --enable-libsepol to configure
289- rebuilt
290
291* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0.rc9-FC5_5.2
292- bump again for double-long bug on ppc(64)
293
294* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0.rc9-FC5_5.1
295- rebuilt for new gcc4.1 snapshot and glibc changes
296
297* Sun Jan 22 2006 Peter Jones <pjones@redhat.com> 1.0.0.rc9-FC5_5
298- Add selinux build deps
299- Don't set owner during make install
300
301* Fri Dec  9 2005 Jesse Keating <jkeating@redhat.com> 1.0.0.rc9-FC5_4.1
302- rebuilt
303
304* Sat Dec  3 2005 Peter Jones <pjones@redhat.com> 1.0.0.rc9-FC5_4
305- rebuild for device-mapper-1.02.02-2
306
307* Fri Dec  2 2005 Peter Jones <pjones@redhat.com> 1.0.0.rc9-FC5_3
308- rebuild for device-mapper-1.02.02-1
309
310* Thu Nov 10 2005 Peter Jones <pjones@redhat.com> 1.0.0.rc9-FC5_2
311- update to 1.0.0.rc9
312- make "make install" do the right thing with the DSO
313- eliminate duplicate definitions in the headers
314- export more symbols in the DSO
315- add api calls to retrieve dm tables
316- fix DESTDIR for 'make install'
317- add api calls to identify degraded devices
318- remove several arch excludes
319
320* Sat Oct 15 2005 Florian La Roche <laroche@redhat.com>
321- add -lselinux -lsepol for new device-mapper deps
322
323* Fri May 20 2005 Heinz Mauelshagen <heinzm@redhat.com> 1.0.0.rc8-FC4_2
324- specfile change to build static and dynamic binray into one package
325- rebuilt
326
327* Thu May 19 2005 Heinz Mauelshagen <heinzm@redhat.com> 1.0.0.rc8-FC4_1
328- nv.c: fixed stripe size
329- sil.c: avoid incarnation_no in name creation, because the Windows
330         driver changes it every time
331- added --ignorelocking option to avoid taking out locks in early boot
332  where no read/write access to /var is given
333
334* Wed Mar 16 2005 Elliot Lee <sopwith@redhat.com>
335- rebuilt
336
337* Tue Mar 15 2005 Heinz Mauelshagen <heinzm@redhat.com> 1.0.0.rc6.1-4_FC4
338- VIA metadata format handler
339- added RAID10 to lsi metadata format handler
340- "dmraid -rD": file device size into {devicename}_{formatname}.size
341- "dmraid -tay": pretty print multi-line tables ala "dmsetup table"
342- "dmraid -l": display supported RAID levels + manual update
343- _sil_read() used LOG_NOTICE rather than LOG_INFO in order to
344  avoid messages about valid metadata areas being displayed
345  during "dmraid -vay".
346- isw, sil filed metadata offset on "-r -D" in sectors rather than in bytes.
347- isw needed dev_sort() to sort RAID devices in sets correctly.
348- pdc metadata format handler name creation. Lead to
349  wrong RAID set grouping logic in some configurations.
350- pdc RAID1 size calculation fixed (rc6.1)
351- dos.c: partition table code fixes by Paul Moore
352- _free_dev_pointers(): fixed potential OOB error
353- hpt37x_check: deal with raid_disks = 1 in mirror sets
354- pdc_check: status & 0x80 doesn't always show a failed device;
355  removed that check for now. Status definitions needed.
356- sil addition of RAID sets to global list of sets
357- sil spare device memory leak
358- group_set(): removal of RAID set in case of error
359- hpt37x: handle total_secs > device size
360- allow -p with -f
361- enhanced error message by checking target type against list of
362  registered target types
363
364* Fri Jan 21 2005 Alasdair Kergon <agk@redhat.com> 1.0.0.rc5f-2
365- Rebuild to pick up new libdevmapper.
366
367* Fri Nov 26 2004 Heinz Mauelshagen <heinzm@redhat.com> 1.0.0.rc5f
368- specfile cleanup
369
370* Fri Aug 20 2004 Heinz Mauelshagen <heinzm@redhat.com> 1.0.0-rc4-pre1
371- Removed make flag after fixing make.tmpl.in
372
373* Wed Aug 18 2004 Heinz Mauelshagen <heinzm@redhat.com> 1.0.0-rc3
374- Added make flag to prevent make 3.80 from looping infinitely
375
376* Thu Jun 17 2004 Heinz Mauelshagen <heinzm@redhat.com> 1.0.0-pre1
377- Created
Note: See TracBrowser for help on using the repository browser.