source: projects/specs/trunk/d/djvulibre/djvulibre-vl.spec @ 521

Revision 521, 7.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: DjVu viewers, encoders and utilities.
2Summary(ja): DjVu 画像形式ファイル操作用ライブラリ、ツール
3Name: djvulibre
4Version: 3.5.22
5Release: 1%{?_dist_release}
6License: GPL
7Group: System Environment/Libraries
8Source0: http://prdownloads.sourceforge.net/djvu/djvulibre-%{version}.tar.gz
9#Source1: djview.png
10BuildRoot: %{_tmppath}/%{name}-%{version}-root
11URL: http://djvu.sourceforge.net
12BuildRequires: qt-devel, qt-designer
13BuildRequires: libtiff-devel
14BuildRequires: libjpeg-devel
15BuildRequires: glibc-devel
16Requires: qt, libtiff, libjpeg, glibc-devel
17Distribution: Project Vine
18Vendor: Vine Linux
19
20%description
21DjVu is a web-centric format and software platform for distributing documents
22and images.  DjVu content downloads faster, displays and renders faster, looks
23nicer on a screen, and consume less client resources than competing formats.
24DjVu was originally developed at AT&T Labs-Research by Leon Bottou, Yann
25LeCun, Patrick Haffner, and many others.  In March 2000, AT&T sold DjVu to
26LizardTech Inc. who now distributes Windows/Mac plug-ins, and commercial
27encoders (mostly on Windows)
28
29In an effort to promote DjVu as a Web standard, the LizardTech management was
30enlightened enough to release the reference implementation of DjVu under the
31GNU GPL in October 2000.  DjVuLibre (which means free DjVu), is an enhanced
32version of that code maintained by the original inventors of DjVu. It is
33compatible with version 3.5 of the LizardTech DjVu software suite.
34
35DjVulibre-3.5 contains:
36- a standalone DjVu viewer based on the Qt library.
37- A browser plugin that works with most Unix browsers.
38- A full-fledged wavelet-based compressor for pictures.
39- A simple compressor for bitonal (black and white) scanned pages.
40- A compressor for palettized images (a la GIF/PNG).
41- A set of utilities to manipulate and assemble DjVu images and documents.
42- A set of decoders to convert DjVu to a number of other formats.
43- An up-to-date version of the C++ DjVu Reference Library.
44
45%package devel
46Summary: The libraries and header files needed for djvulibre development.
47Group: Development/Libraries
48Requires: djvulibre = %{version}
49%description devel
50DjVulibre libraries and header files for development.
51
52%package plugin
53Summary: The plug-in files needed for mozilla.
54Group: Applications/Internet
55Requires: djvulibre = %{version}
56%description plugin
57DjVulibre plug-in files for mozilla.
58
59%prep
60%setup -q
61cp gui/nsdejavu/Makefile.in gui/nsdejavu/Makefile.in.orig
62sed "s|netscape|mozilla|" gui/nsdejavu/Makefile.in.orig \
63        > gui/nsdejavu/Makefile.in
64
65%build
66%ifarch i386
67export CXXFLAGS="-march=i686"
68%endif
69%configure
70
71# don't set smp option (-j n) with make
72make depend
73make
74
75%install
76rm -rf %{buildroot}
77make DESTDIR=%{buildroot} install
78
79# fix to stop ldconfig from complaining
80find %{buildroot}%{_libdir} -name "*.so*" -exec chmod 755 {} \;
81
82# cleanup of the docs
83rm -rf doc/CVS 2>/dev/null || :
84
85cat > djview.desktop <<EOF
86[Desktop Entry]
87Encoding=UTF-8
88Name=djview
89Name[ja]=Djvuビュアー
90Comment=Standalone Djvu Viewer
91Comment[ja]=スタンドアロンでDjvu画像を表示するツールです
92Icon=djview
93Terminal=false
94Exec=djview
95Type=Application
96Categories=Application;Graphics;
97EOF
98
99mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
100install -m644 djview.desktop $RPM_BUILD_ROOT%{_datadir}/applications/
101#mkdir -p $RPM_BUILD_ROOT%{_datadir}/pixmaps
102#cp %SOURCE1 $RPM_BUILD_ROOT%{_datadir}/pixmaps/
103
104
105%clean
106rm -rf %{buildroot}
107
108%post
109/sbin/ldconfig
110if test -x /sbin/update-alternatives ; then
111        m1=`ls -1 %{_mandir}/man1/djview3.* | head -1`
112        m2=`echo $m1 | sed -e 's/djview3/djview/'`
113        /sbin/update-alternatives \
114                --install %{_bindir}/djview djview %{_bindir}/djview3 103 \
115                --slave $m2 `basename $m2` $m1
116fi
117
118%preun
119if test "$1" = 0 ; then
120        if test -x /sbin/update-alternatives ; then
121                /sbin/update-alternatives --remove djview %{_bindir}/djview3
122        fi
123fi
124
125%postun
126/sbin/ldconfig
127
128%files
129%defattr(-, root, root)
130%doc README COPYRIGHT COPYING INSTALL NEWS TODO doc
131%{_bindir}
132%{_libdir}
133%exclude %{_libdir}/mozilla
134%exclude %{_libdir}/pkgconfig
135%exclude %{_libdir}/libdjvulibre.la
136
137%{_datadir}/applications/djview.desktop
138#%{_datadir}/pixmaps/djview.png
139%{_datadir}/djvu/djview3
140%{_datadir}/djvu/pubtext
141%{_datadir}/djvu/osi/languages.xml
142%{_datadir}/djvu/osi/en
143%{_datadir}/djvu/osi/cs/messages.xml
144%lang(ja) %{_datadir}/djvu/osi/ja*
145%lang(fr) %{_datadir}/djvu/osi/fr*
146%lang(de) %{_datadir}/djvu/osi/de*
147%lang(zh) %{_datadir}/djvu/osi/zh*
148%{_mandir}/man?
149%lang(ja) %{_mandir}/ja*
150%lang(fr) %{_mandir}/fr*
151%lang(de) %{_mandir}/de*
152
153%files devel
154%defattr(-, root, root)
155%{_includedir}/libdjvu
156%{_libdir}/pkgconfig/ddjvuapi.pc
157
158%files plugin
159%defattr(-, root, root)
160%{_libdir}/mozilla/plugins/nsdejavu.so
161
162%changelog
163* Wed Jul 01 2009 Shu KONNO <owa@bg.wakwak.com> 3.5.22-1
164- updated djvulibre to 3.5.22
165
166* Tue Dec 30 2008 Shu KONNO <owa@bg.wakwak.com> 3.5.21-1
167- initial build for VineSeed
168- spec in utf-8, and applied vine versioning policy
169- updated djvulibre to 3.5.21
170- added CXXFLAG="-march=i686" if i386
171- added djview desktop file
172
173* Tue Apr 03 2007 Shu KONNO <owa@bg.wakwak.com> 3.5.19-uvl1
174- updated djvulibre to 3.5.19
175- added scripts to alternative djview at %%post, %%preun
176
177* Thu Dec 01 2005 Shu KONNO <owa@bg.wakwak.com> 3.5.16-uvl1
178- updated djvulibre to 3.5.16
179- changed suffix
180- divided into djvulibre, djvulibre-devel, djvulibre-plugin
181
182* Tue Nov 09 2004 Shu KONNO <owa@bg.wakwak.com> 3.5.14-uvl2
183- updated djvulibre to 3.5.14 (realese 2)
184
185* Thu Jun 17 2004 Leon Bottou <leon@bottou.org> 3.5.13-4
186- changed runtime generation of file list.
187* Mon May 31 2004 Leon Bottou <leon@bottou.org> 3.5.13-3
188- removed 'make install-desktop-files'
189* Wed May  5 2004 Leon Bottou <leon@bottou.org> 3.5.13-2
190* Fri Apr  9 2004 Leon Bottou <leon@bottou.org> 3.5.13-1
191- added runtime generation of file list.
192- using DESTDIR instead of %makeinstall.
193- added 'make install-desktop-files'
194* Wed Nov  5 2003 Leon Bottou <leon@bottou.org> 3.5.12-3
195- added support for i18n
196- renamed symlink in mozilla plugin dirs.
197* Mon Jul  7 2003 Leon Bottou <leon@bottou.org> 3.5.12-1
198* Thu Apr 24 2003 Leon Bottou <leon@bottou.org> 3.5.11-1
199* Thu Feb  6 2003 Leon Bottou <leon@bottou.org> 3.5.10-2
200* Fri Jan 24 2003 Leon Bottou <leon@bottou.org> 3.5.10-1
201* Wed Oct  9 2002 Leon Bottou <leonb@users.sourceforge.net> 3.5.9-2
202- fixed logic for uninstalling nsdejavu links.
203- learned a few tricks from the freshrpms spec file.
204* Sun Oct  6 2002 Leon Bottou <leonb@users.sourceforge.net> 3.5.9-1
205- added logic to install nsdejavu for mozilla.
206* Wed May 29 2002 Leon Bottou <leonb@users.sourceforge.net> 3.5.6-1
207* Mon Apr 1 2002  Leon Bottou <leonb@users.sourceforge.net> 3.5.5-2
208- changed group to Applications/Publishing.
209* Tue Mar 25 2002 Leon Bottou <leonb@users.sourceforge.net> 3.5.5-2
210* Tue Jan 22 2002 Leon Bottou <leonb@users.sourceforge.net> 3.5.4-2
211- added macros to locate man directory.
212* Wed Jan 16 2002 Leon Bottou <leonb@users.sourceforge.net> 3.5.3-1
213* Fri Dec  7 2001 Leon Bottou <leonb@users.sourceforge.net> 3.5.2-1
214* Wed Dec  5 2001 Leon Bottou <leonb@users.sourceforge.net> 3.5.1-1
215- created initial file.
216
Note: See TracBrowser for help on using the repository browser.