source: projects/specs/trunk/d/dirmngr/dirmngr-vl.spec @ 6424

Revision 6424, 5.9 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1
2# Fedora Review: http://bugzilla.redhat.com/171289
3
4Name:    dirmngr
5Summary: Client for Managing/Downloading CRLs
6Version: 1.1.0
7Release: 1%{?_dist_release}
8
9License: GPLv2+
10Group:   System Environment/Libraries
11URL:     http://www.gnupg.org/
12Source0: ftp://ftp.gnupg.org/gcrypt/dirmngr/dirmngr-%{version}.tar.bz2
13Source1: ftp://ftp.gnupg.org/gcrypt/dirmngr/dirmngr-%{version}.tar.bz2.sig
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
15
16Source10: dirmngr.conf
17Source11: ldapservers.conf
18Source12: dirmngr.logrotate
19
20BuildRequires: gawk
21BuildRequires: gettext
22BuildRequires: libassuan-devel
23BuildRequires: libgcrypt-devel >= 1.2.0
24BuildRequires: libksba-devel >= 1.0.0
25BuildRequires: openldap-devel
26BuildRequires: pth-devel
27
28Requires(post): /sbin/install-info
29Requires(postun): /sbin/install-info
30Requires: logrotate
31
32%description
33Dirmngr is a server for managing and downloading certificate
34revocation lists (CRLs) for X.509 certificates and for downloading
35the certificates themselves. Dirmngr also handles OCSP requests as
36an alternative to CRLs. Dirmngr is either invoked internally by
37gpgsm (from gnupg2) or when running as a system daemon through
38the dirmngr-client tool.
39
40
41%prep
42%setup -q
43
44pushd doc
45iconv -f iso-8859-1 -t utf-8 dirmngr.texi -o dirmngr.texi.NEW && mv dirmngr.texi.NEW dirmngr.texi
46iconv -f iso-8859-1 -t utf-8 dirmngr.info -o dirmngr.info.NEW && mv dirmngr.info.NEW dirmngr.info
47popd
48
49
50%build
51sed -i "s|\"-lldap\"||" configure.ac
52autoreconf -if
53%configure \
54  --disable-dependancy-tracking
55
56make %{?_smp_mflags}
57
58
59%install
60rm -rf %{buildroot}
61
62# dirs
63mkdir -p %{buildroot}%{_sysconfdir}/dirmngr/trusted-certs
64mkdir -p %{buildroot}%{_var}/cache/dirmngr/crls.d
65mkdir -p %{buildroot}%{_var}/lib/dirmngr/extra-certs
66mkdir -p %{buildroot}%{_var}/log/dirmngr
67mkdir -p %{buildroot}%{_var}/run/dirmngr
68
69make install DESTDIR=%{buildroot}
70
71# dirmngr.log, logrotate
72install -p -m644 -D %{SOURCE12} %{buildroot}%{_sysconfdir}/logrotate.d/dirmngr
73
74# conf files
75install -p -m644 %{SOURCE10} %{SOURCE11} %{buildroot}%{_sysconfdir}/dirmngr/
76
77%find_lang %{name}
78
79## unpackaged files
80rm -f %{buildroot}%{_infodir}/dir
81rm -rf %{buildroot}%{_docdir}/dirmngr/examples
82
83
84%check
85make check
86
87
88%post
89/sbin/install-info %{_infodir}/dirmngr.info.gz %{_infodir}/dir ||:
90
91%postun
92if [ $1 -eq 0 ]; then
93  /sbin/install-info --delete %{_infodir}/dirmngr.info.gz %{_infodir}/dir ||:
94fi
95
96
97%clean
98rm -rf %{buildroot}
99
100
101%files -f %{name}.lang
102%defattr(-,root,root,-)
103%doc COPYING README ChangeLog NEWS
104%doc doc/examples
105%{_bindir}/dirmngr*
106%{_libexecdir}/dirmngr_ldap
107%{_infodir}/dirmngr.info*
108%{_mandir}/man1/*
109# TODO/FIXME
110#{_initrddir}/*
111## files/dirs for --daemon mode
112%dir %{_sysconfdir}/dirmngr
113%config(noreplace) %{_sysconfdir}/dirmngr/*.conf
114%config %{_sysconfdir}/logrotate.d/*
115%{_var}/cache/dirmngr/
116%{_var}/lib/dirmngr/
117%{_var}/log/dirmngr/
118%{_var}/run/dirmngr/
119
120
121%changelog
122* Sun Jun 24 2012 Yoji TOYODA <bsymaato@sea.plala.or.jp> - 1.1.0-1
123- update to 1.1.0
124- remove Patch100
125
126* Sat Apr  4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.0.2-2
127- rebuilt with openldap-2.4.11
128
129* Thu Aug 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.0.2-1
130- initial build for VineSeed
131
132* Fri Aug 01 2008 Rex Dieter <rdieter@fedoraproject.org> 1.0.2-1
133- dirmngr-1.0.2
134
135* Mon Feb 11 2008 Rex Dieter <rdieter@fedoraproject.org> 1.0.1-2
136- respin (gcc43)
137
138* Thu Jan 03 2008 Rex Dieter <rdieter[AT]fedoraproject.org> 1.0.1-1
139- dirmngr-1.0.1
140
141* Tue Dec 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.0.0-7
142- respin for openldap
143
144* Wed Oct 03 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.0.0-6
145- /var/log/dirmngr.log -> /var/log/dirmngr/dirmngr.log
146- remove use of %%ghost (e.g. dirmngr.log shouldn't be owned)
147- BR: gettext
148
149* Sun Aug 26 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.0.0-5
150- BR: gawk
151
152* Sat Aug 25 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.0.0-4
153- respin (BuildID)
154
155* Thu Aug 09 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.0.0-3
156- License: GPLv2+
157
158* Wed Nov 29 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.0.0-2
159- dirmngr-1.0.0
160
161* Mon Nov 13 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.9.6-2
162- BR: libassuan-static
163
164* Tue Sep 05 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.9.6-1
165- dirmngr-0.9.6
166
167* Tue Aug 29 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.9.4-5
168- fc6 respin
169
170* Mon Jun 26 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.9.4-4
171- %%config(noreplace) %%_sysconfdir/logrotate.d/dirmngr
172
173* Mon Jun 26 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.9.4-3
174- use 'iconv -f iso-8859-1 -t utf-8' to avoid dropping characters
175
176* Mon Jun 26 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.9.4-2
177- remove non-ASCII chars from dirmngr.info
178- %%config %%_sysconfdir/logrotate.d/dirmngr
179
180* Mon Jun 26 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.9.4-1
181- 0.9.4
182- %%doc COPYING
183- drop upstreamed info patch
184- use logrotate on dirmngr.log
185- add comment to (previously) empty ldapservers.conf
186
187* Tue May 16 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.9.3-1
188- 0.9.3
189
190* Sat Oct 22 2005 Rex Dieter <rexdieter[AT]users.sf.net> 0.9.2-3
191- create/own more files/dirs for --daemon mode
192- TODO: proper init script
193
194* Thu Oct 20 2005 Rex Dieter <rexdieter[AT]users.sf.net> 0.9.2-2
195- drop BR: libgpg-error-devel, texinfo
196- drop goofy conditional 'make install-strip '
197- BR: libksba-devel >= 0.9.11
198- BR: libassuan-devel >= 0.6.8
199- fix spelling error(s) in %%description
200- --disable-dependancy-tracking
201
202* Thu Oct 20 2005 Rex Dieter <rexdieter[AT]users.sf.net> 0.9.2-1
203- 0.9.2
204
205* Mon Mar 21 2005 Rex Dieter <rexdieter[AT]users.sf.net> 0.9.1-0.fdr.1
206- 0.9.1
207
208* Fri Jan 07 2005 Rex Dieter <rexdieter[AT]users.sf.net> 0.9.0-0.fdr.2
209- fix info entry (so deletion/uninstallation works)
210
211* Fri Jan 07 2005 Rex Dieter <rexdieter[AT]users.sf.net> 0.9.0-0.fdr.1
212- 0.9.0
213
214* Thu Dec 16 2004 Rex Dieter <rexdieter[AT]users.sf.net> 0.5.5-0.fdr.2
215- 64bit fix (look for openldap in %%_libdir, not just /usr/lib)
216
217* Wed Oct 20 2004 Rex Dieter <rexdieter[AT]users.sf.net> 0.5.5-0.fdr.1
218- first try
219
Note: See TracBrowser for help on using the repository browser.